infoscale-sles12sp1_x86_64-Patch-7.0.1.100

 Basic information
Release type: Patch
Release date: 2016-04-12
OS update support: SLES12 x86-64 SP 1
Technote: None
Documentation: None
Popularity: 706 viewed    53 downloaded
Download size: 54.81 MB
Checksum: 55360473

 Applies to one or more of the following products:
InfoScale Availability 7.0 On SLES12 x86-64
InfoScale Enterprise 7.0 On SLES12 x86-64
InfoScale Foundation 7.0 On SLES12 x86-64
InfoScale Storage 7.0 On SLES12 x86-64

 Obsolete patches, incompatibilities, superseded patches, or other requirements:

This patch requires: Release date
infoscale-sles12_x86_64-MR-7.0.1 2015-12-11

 Fixes the following incidents:
3870478, 3872401, 3872403, 3872404, 3872405, 3872724, 3872726, 3873872, 3873875, 3874320

 Patch ID:
VRTSvxvm-7.0.1.100-SLES12
VRTSgab-7.0.1.100-SLES12
VRTSllt-7.0.1.200-SLES12
VRTSamf-7.0.1.100-SLES12
VRTSvxfen-7.0.1.100-SLES12
VRTSdbac-7.0.1.100-SLES12
VRTSveki-7.0.0.100-SLES12
VRTSodm-7.0.0.100-SLES12
VRTSglm-7.0.1.100-SLES12
VRTSgms-7.0.0.100-SLES12
VRTSvxfs-7.0.1.100-SLES12
VRTSaslapm-7.0.1.100-SLES12

Readme file
                          * * * READ ME * * *
                      * * * InfoScale 7.0.1 * * *
                         * * * Patch 100 * * *
                         Patch Date: 2016-03-22


This document provides the following information:

   * PATCH NAME
   * OPERATING SYSTEMS SUPPORTED BY THE PATCH
   * PACKAGES AFFECTED BY THE PATCH
   * BASE PRODUCT VERSIONS FOR THE PATCH
   * SUMMARY OF INCIDENTS FIXED BY THE PATCH
   * DETAILS OF INCIDENTS FIXED BY THE PATCH
   * INSTALLATION PRE-REQUISITES
   * INSTALLING THE PATCH
   * REMOVING THE PATCH


PATCH NAME
----------
InfoScale 7.0.1 Patch 100


OPERATING SYSTEMS SUPPORTED BY THE PATCH
----------------------------------------
SLES12 x86-64


PACKAGES AFFECTED BY THE PATCH
------------------------------
VRTSamf
VRTSaslapm
VRTSdbac
VRTSgab
VRTSglm
VRTSgms
VRTSllt
VRTSodm
VRTSveki
VRTSvxfen
VRTSvxfs
VRTSvxvm


BASE PRODUCT VERSIONS FOR THE PATCH
-----------------------------------
   * InfoScale Availability 7.0
   * InfoScale Enterprise 7.0
   * InfoScale Foundation 7.0
   * InfoScale Storage 7.0


SUMMARY OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
Patch ID: VRTSvxvm-7.0.1.100-SLES12
* 3872724 (3865904) VRTSvxvm patch version 6.2.1 and 7.0.1 failed to install on new kernel 
update 
SLES12SP1
* 3872726 (3845712) On SLES12 when encapsulation is performed, System is not able to boot up 
through vxvm_root grub entry.
Patch ID: VRTSvxfs-7.0.1.100-SLES12
* 3872401 (3865599) VxFS module failed to load on SLES12 SP1.
Patch ID: VRTSodm-7.0.0.100-SLES12
* 3872403 (3865602) ODM module failed to load on SLES12 SP1.
Patch ID: VRTSglm-7.0.1.100-SLES12
* 3872404 (3865604) GLM module failed to load on SLES12 SP1.
Patch ID: VRTSgms-7.0.0.100-SLES12
* 3872405 (3865607) GMS module failed to load on SLES12 SP1.
Patch ID: VRTSdbac-7.0.1.100-SLES12
* 3874320 (3874329) 7.0.1 vcsmm module does not load with SLES12SP1 (3.12.49-11-default)
Patch ID: VRTSllt-7.0.1.200-SLES12
* 3873875 (3873874) Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).
Patch ID: VRTSllt-7.0.1.100-SLES12
* 3870478 (3870477) Veritas Infoscale Availability does not support Red Hat Enterprise Linux 7
Update 2 (RHEL7.2).
Patch ID: VRTSgab-7.0.1.100-SLES12
* 3873875 (3873874) Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).
Patch ID: VRTSamf-7.0.1.100-SLES12
* 3873875 (3873874) Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).
Patch ID: VRTSvxfen-7.0.1.100-SLES12
* 3873875 (3873874) Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).
Patch ID: VRTSveki-7.0.0.100-SLES12
* 3873872 (3872885) Resolve future VRTSveki upgrade issue.


DETAILS OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
This patch fixes the following Symantec incidents:

Patch ID: VRTSvxvm-7.0.1.100-SLES12

* 3872724 (Tracking ID: 3865904)

SYMPTOM:
The installation failed while installing VxVM 6.2.1 and 7.0.1 on 
SLES12SP1

# rpm -ivh VRTSvxvm-6.2.1.000-
SLES12.x86_64.rpm
Preparing...                          ################################# 
[100%]
Updating / installing...
   1:VRTSvxvm-6.2.1.000-SLES12        ################################# 
[100%]
Installing file /etc/init.d/vxvm-boot
vxvm-boot                 0:off  1:off  2:on   3:on   4:on   5:on   
6:off
creating VxVM device nodes under /dev
ERROR: No appropriate modules found. Error in loading module "vxdmp". 
See 
documentation.
warning: %post(VRTSvxvm-6.2.1.000-SLES12.x86_64) scriptlet failed, exit 
status 1

DESCRIPTION:
Installation of VRTSvxvm patch version 6.2.1 and 7.0.1 failed on
SLES12SP1 due to change in kernel version.

RESOLUTION:
The VxVM package has been re-compiled with SLES12SP1 build environment.

* 3872726 (Tracking ID: 3845712)

SYMPTOM:
After booting through vxvm_root entry of the grub, Following message is 
seen at the console -
"/dev/disk/by-uuid/**UUID** doesn't exist."

DESCRIPTION:
This is because, when the VxVM-initrd image is created as part of root 
device encapsulation, the SWAP device has old Swap UUID and when vxvm 
creates swap-volumes, it uses new UUID for swap device, which will not 
be present in VxVM-initrd image. Dracut has checks for mapping of swap 
UUID to get the device-id while booting up, and it doesn't match with 
the UUID of swap device present in the VxVM-initrd image, hence this 
issue.

RESOLUTION:
Code changes are implemented so that UUID checks for swap device in 
dracut  passes properly.

Patch ID: VRTSvxfs-7.0.1.100-SLES12

* 3872401 (Tracking ID: 3865599)

SYMPTOM:
VxFS module failed to load on SLES12 SP1.

DESCRIPTION:
Since SLES12 SP1 is new release therefore VxFS module failed to load
on it.

RESOLUTION:
Added VxFS support for SLES12 SP1.

Patch ID: VRTSodm-7.0.0.100-SLES12

* 3872403 (Tracking ID: 3865602)

SYMPTOM:
ODM module may not get loaded on SLES12 SP1.

DESCRIPTION:
Since SLES12 SP1 is new release therefore ODM module was not
getting loaded on it.

RESOLUTION:
Added ODM support for SLES12 SP1.

Patch ID: VRTSglm-7.0.1.100-SLES12

* 3872404 (Tracking ID: 3865604)

SYMPTOM:
GLM module will not get loaded on SLES12 SP1.

DESCRIPTION:
Since SLES12 SP1 is new release therefore GLM module failed to load
on it.

RESOLUTION:
Added GLM support for SLES12 SP1.

Patch ID: VRTSgms-7.0.0.100-SLES12

* 3872405 (Tracking ID: 3865607)

SYMPTOM:
GMS module will not get loaded on SLES12 SP1.

DESCRIPTION:
Since SLES12 SP1 is new release therefore GMS module failed to load
on it.

RESOLUTION:
Added GMS support for SLES12 SP1.

Patch ID: VRTSdbac-7.0.1.100-SLES12

* 3874320 (Tracking ID: 3874329)

SYMPTOM:
VRTSdbac patch version does not work with SLES12SP1 (3.12.49-11-default 
kernel) and is unable to load the vcsmm module on SLES12SP1.

DESCRIPTION:
Installation of VRTSdbac patch version 7.0.1 fails on SLES12SP1 as 
the VCSMM module is not available on SLES12SP1 kernel 3.12.49-11-default. 
The system log file logs the following messages:

Starting VCSMM:
ERROR: No appropriate modules found.
Error in loading module "vcsmm". See documentation.
Error : VCSMM driver could not be loaded.
Error : VCSMM could not be started.

RESOLUTION:
The VRTSdbac package is re-compiled with SLES12SP1 kernel in the build 
environment to mitigate the failure

Patch ID: VRTSllt-7.0.1.200-SLES12

* 3873875 (Tracking ID: 3873874)

SYMPTOM:
Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).

DESCRIPTION:
Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 
versions later than SLES 12.

RESOLUTION:
Veritas Infoscale Availability now supports SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).

Patch ID: VRTSllt-7.0.1.100-SLES12

* 3870478 (Tracking ID: 3870477)

SYMPTOM:
Veritas Infoscale Availability does not support Red Hat Enterprise Linux 7
Update 2 (RHEL 7.2).

DESCRIPTION:
Veritas Infoscale Availability 7.0 did not support RHEL 7.1 and later versions.

RESOLUTION:
Veritas Infoscale Availability 7.0.1 now supports Red Hat Enterprise Linux 7
Update 2 (RHEL 7.2).

Patch ID: VRTSgab-7.0.1.100-SLES12

* 3873875 (Tracking ID: 3873874)

SYMPTOM:
Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).

DESCRIPTION:
Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 
versions later than SLES 12.

RESOLUTION:
Veritas Infoscale Availability now supports SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).

Patch ID: VRTSamf-7.0.1.100-SLES12

* 3873875 (Tracking ID: 3873874)

SYMPTOM:
Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).

DESCRIPTION:
Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 
versions later than SLES 12.

RESOLUTION:
Veritas Infoscale Availability now supports SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).

Patch ID: VRTSvxfen-7.0.1.100-SLES12

* 3873875 (Tracking ID: 3873874)

SYMPTOM:
Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).

DESCRIPTION:
Veritas Infoscale Availability does not support SUSE Linux Enterprise Server 
versions later than SLES 12.

RESOLUTION:
Veritas Infoscale Availability now supports SUSE Linux Enterprise Server 12 
Service Pack 1 (SLES 12 SP1).

Patch ID: VRTSveki-7.0.0.100-SLES12

* 3873872 (Tracking ID: 3872885)

SYMPTOM:
Resolve future VRTSveki upgrade issue.

DESCRIPTION:
There is a bug in pre/post uninstall script of the VRTSveki. Due to
which the veki service will not be start in case of upgrade.

RESOLUTION:
Adding code to resolve future upgrade issue.



INSTALLING THE PATCH
--------------------
Run the Installer script to automatically install the patch:
-----------------------------------------------------------
To install the patch perform the following steps on at least one node in the cluster:
1. Copy the patch infoscale-sles12_x86_64-Patch-7.0.1.100.tar.gz to /tmp
2. Untar infoscale-sles12_x86_64-Patch-7.0.1.100.tar.gz to /tmp/hf
    # mkdir /tmp/hf
    # cd /tmp/hf
    # gunzip /tmp/infoscale-sles12_x86_64-Patch-7.0.1.100.tar.gz
    # tar xf /tmp/infoscale-sles12_x86_64-Patch-7.0.1.100.tar
3. Install the hotfix
    # pwd /tmp/hf
    # ./installVRTSinfoscale701P100 [<host1> <host2>...]

Install the patch manually:
--------------------------
o Before-the-upgrade :-
 (a) Stop I/Os to all the VxVM volumes.
 (b) Umount any filesystems with VxVM volumes.
 (c) Stop applications using any VxVM volumes.
o Select the appropriate RPMs for your system, and upgrade to the new patch.
 # rpm -Uhv VRTSvxvm-7.0.1.100-GA_SLES12.x86_64.rpm


REMOVING THE PATCH
------------------
rpm -e rpm-name


SPECIAL INSTRUCTIONS
--------------------
NONE


OTHERS
------
NONE
Read and accept Terms of Service