cpi-Patch-7.3.1.200

 Basic information
Release type: Patch
Release date: 2018-05-23
OS update support: None
Technote: None
Documentation: None
Popularity: 643 viewed    111 downloaded
Download size: 4.93 KB
Checksum: 3520026798

 Applies to one or more of the following products:
InfoScale Availability 7.3.1 On AIX 7.1
InfoScale Availability 7.3.1 On AIX 7.2
InfoScale Availability 7.3.1 On RHEL6 x86-64
InfoScale Availability 7.3.1 On RHEL7 x86-64
InfoScale Availability 7.3.1 On SLES11 x86-64
InfoScale Availability 7.3.1 On SLES12 x86-64
InfoScale Availability 7.3.1 On Solaris 11 SPARC
InfoScale Availability 7.3.1 On Solaris 11 X64
InfoScale Enterprise 7.3.1 On AIX 7.1
InfoScale Enterprise 7.3.1 On AIX 7.2
InfoScale Enterprise 7.3.1 On RHEL6 x86-64
InfoScale Enterprise 7.3.1 On RHEL7 x86-64
InfoScale Enterprise 7.3.1 On SLES11 x86-64
InfoScale Enterprise 7.3.1 On SLES12 x86-64
InfoScale Enterprise 7.3.1 On Solaris 11 SPARC
InfoScale Enterprise 7.3.1 On Solaris 11 X64
InfoScale Foundation 7.3.1 On AIX 7.1
InfoScale Foundation 7.3.1 On AIX 7.2
InfoScale Foundation 7.3.1 On RHEL6 x86-64
InfoScale Foundation 7.3.1 On RHEL7 x86-64
InfoScale Foundation 7.3.1 On SLES11 x86-64
InfoScale Foundation 7.3.1 On SLES12 x86-64
InfoScale Foundation 7.3.1 On Solaris 11 SPARC
InfoScale Foundation 7.3.1 On Solaris 11 X64
InfoScale Storage 7.3.1 On AIX 7.1
InfoScale Storage 7.3.1 On AIX 7.2
InfoScale Storage 7.3.1 On RHEL6 x86-64
InfoScale Storage 7.3.1 On RHEL7 x86-64
InfoScale Storage 7.3.1 On SLES11 x86-64
InfoScale Storage 7.3.1 On SLES12 x86-64
InfoScale Storage 7.3.1 On Solaris 11 SPARC
InfoScale Storage 7.3.1 On Solaris 11 X64

 Obsolete patches, incompatibilities, superseded patches, or other requirements:

This patch supersedes the following patches: Release date
cpi-Patch-7.3.1.100 (obsolete) 2018-04-25

 Fixes the following incidents:
3944164, 3945461

 Patch ID:
None.

Readme file
                          * * * READ ME * * *
                         * * * CPI 7.3.1 * * *
                         * * * Patch 200 * * *
                         Patch Date: 2018-05-02


This document provides the following information:

   * PATCH NAME
   * OPERATING SYSTEMS SUPPORTED BY THE PATCH
   * PACKAGES AFFECTED BY THE PATCH
   * BASE PRODUCT VERSIONS FOR THE PATCH
   * SUMMARY OF INCIDENTS FIXED BY THE PATCH
   * DETAILS OF INCIDENTS FIXED BY THE PATCH
   * INSTALLATION PRE-REQUISITES
   * INSTALLING THE PATCH
   * REMOVING THE PATCH


PATCH NAME
----------
CPI 7.3.1 Patch 200


OPERATING SYSTEMS SUPPORTED BY THE PATCH
----------------------------------------
AIX
RHEL6 x86-64
RHEL7 x86-64
SLES11 x86-64
SLES12 x86-64
Solaris 11 SPARC
Solaris 11 X86



BASE PRODUCT VERSIONS FOR THE PATCH
-----------------------------------
   * InfoScale Availability 7.3.1
   * InfoScale Enterprise 7.3.1
   * InfoScale Foundation 7.3.1
   * InfoScale Storage 7.3.1


SUMMARY OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
Patch ID: 7.3.1.200
* 3944164 (3944161) Installer could not upgrade VRTSvxfs and VRTSodm inside
non-global zones
* 3945461 (3945456) When performing an upgrade from InfoScale 7.3 to 7.3.1.xxx, CPI installs the packages from 
the 7.3.1.xxx patch only and does not install the base packages of 7.3.1 GA.


DETAILS OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
This patch fixes the following incidents:

Patch ID: 7.3.1.200

* 3944164 (Tracking ID: 3944161)

SYMPTOM:
If older versions of the VRTSvxfs and VRTSodm packages are installed in
non-global zones, they are not 
upgraded when upgrade to a newer version of the product.

DESCRIPTION:
If older versions of the VRTSvxfs and VRTSodm packages are installed in
non-global zones, you must 
uninstall them before you perform a product upgrade. After you upgrade those
packages in global zones, you 
must then install the VRTSvxfs and VRTSodm packages manaully in the non-global
zones.

RESOLUTION:
The CPI will handle the VRTSodm and VRTSvxfs package in non-global zone in the
same manner it does in global zone.

* 3945461 (Tracking ID: 3945456)

SYMPTOM:
CPI assumes that the third digit in an InfoScale 7.3.1 version indicates a patch release, and 
not a GA release. It then upgrades the packages from the patch only and does not upgrade 
the base packages.

DESCRIPTION:
To compare release versions and set the type of installation, CPI compares the currently 
installed release version with the target release version to be installed. However, instead of 
considering all the digits in a release version, it incorrectly compares only the first two 
digits. In this case, CPI compares 7.3 with 7.3.1, and finds that the first 2 digits match 
exactly. Thus, it assumes that the base release is already installed and so it only installs the 
patch packages.

RESOLUTION:
This hotfix updates the CPI to recognize InfoScale 7.3.1 as a higher release and 7.3.1.100 
(for example) as a patch release. CPI can now properly upgrade the base packages first 
and then proceed to upgrade the packages that are in the patch.



INSTALLING THE PATCH
--------------------
1. Copy the hot-fix CPI_7.3.1_P2.pl to /tmp
2. Run installation scripts with the hot-fix
     Example:
     ./installer -require /tmp/CPI_7.3.1_P2.pl


REMOVING THE PATCH
------------------
NONE


SPECIAL INSTRUCTIONS
--------------------
NONE


OTHERS
------
NONE
Read and accept Terms of Service