cpi-Patch-7.4.0.200
Obsolete
The latest patch(es) : cpi-Patch-7.4.0.700 

 Basic information
Release type: Patch
Release date: 2019-02-17
OS update support: None
Technote: None
Documentation: None
Popularity: 338 viewed    28 downloaded
Download size: 10.08 KB
Checksum: 4171481443

 Applies to one or more of the following products:
InfoScale Availability 7.4 On AIX 7.1
InfoScale Availability 7.4 On AIX 7.2
InfoScale Availability 7.4 On RHEL6 x86-64
InfoScale Availability 7.4 On RHEL7 x86-64
InfoScale Availability 7.4 On SLES11 x86-64
InfoScale Availability 7.4 On SLES12 x86-64
InfoScale Availability 7.4 On Solaris 11 SPARC
InfoScale Availability 7.4 On Solaris 11 X64
InfoScale Enterprise 7.4 On AIX 7.1
InfoScale Enterprise 7.4 On AIX 7.2
InfoScale Enterprise 7.4 On RHEL6 x86-64
InfoScale Enterprise 7.4 On RHEL7 x86-64
InfoScale Enterprise 7.4 On SLES11 x86-64
InfoScale Enterprise 7.4 On SLES12 x86-64
InfoScale Enterprise 7.4 On Solaris 11 SPARC
InfoScale Enterprise 7.4 On Solaris 11 X64
InfoScale Foundation 7.4 On AIX 7.1
InfoScale Foundation 7.4 On AIX 7.2
InfoScale Foundation 7.4 On RHEL6 x86-64
InfoScale Foundation 7.4 On RHEL7 x86-64
InfoScale Foundation 7.4 On SLES11 x86-64
InfoScale Foundation 7.4 On SLES12 x86-64
InfoScale Foundation 7.4 On Solaris 11 SPARC
InfoScale Foundation 7.4 On Solaris 11 X64
InfoScale Storage 7.4 On AIX 7.1
InfoScale Storage 7.4 On AIX 7.2
InfoScale Storage 7.4 On RHEL6 x86-64
InfoScale Storage 7.4 On RHEL7 x86-64
InfoScale Storage 7.4 On SLES11 x86-64
InfoScale Storage 7.4 On SLES12 x86-64
InfoScale Storage 7.4 On Solaris 11 SPARC
InfoScale Storage 7.4 On Solaris 11 X64

 Obsolete patches, incompatibilities, superseded patches, or other requirements:

This patch is obsolete. It is superseded by: Release date
cpi-Patch-7.4.0.700 2019-06-27
cpi-Patch-7.4.0.600 (obsolete) 2019-06-25
cpi-Patch-7.4.0.500 (obsolete) 2019-04-04
cpi-Patch-7.4.0.400 (obsolete) 2019-03-14
cpi-Patch-7.4.0.300 (obsolete) 2019-03-14

This patch supersedes the following patches: Release date
cpi-Patch-7.4.0.100 (obsolete) 2018-12-05

 Fixes the following incidents:
3960118, 3969318

 Patch ID:
None.

Readme file
                          * * * READ ME * * *
                          * * * CPI 7.4 * * *
                         * * * Patch 200 * * *
                         Patch Date: 2019-01-31


This document provides the following information:

   * PATCH NAME
   * OPERATING SYSTEMS SUPPORTED BY THE PATCH
   * PACKAGES AFFECTED BY THE PATCH
   * BASE PRODUCT VERSIONS FOR THE PATCH
   * SUMMARY OF INCIDENTS FIXED BY THE PATCH
   * DETAILS OF INCIDENTS FIXED BY THE PATCH
   * INSTALLATION PRE-REQUISITES
   * INSTALLING THE PATCH
   * REMOVING THE PATCH


PATCH NAME
----------
CPI 7.4 Patch 200


OPERATING SYSTEMS SUPPORTED BY THE PATCH
----------------------------------------
AIX
RHEL6 x86-64
RHEL7 x86-64
SLES11 x86-64
SLES12 x86-64
Solaris 11 SPARC
Solaris 11 X86
Solaris 11 SPARC
Solaris 11 X86



BASE PRODUCT VERSIONS FOR THE PATCH
-----------------------------------
   * InfoScale Availability 7.4
   * InfoScale Enterprise 7.4
   * InfoScale Foundation 7.4
   * InfoScale Storage 7.4


SUMMARY OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
Patch ID: 7.4.0.200
* 3960118 (3960116) Installer reports incorrect licensing status as "Unlicensed" for InfoScale 7.4 even when the systems are properly licensed and also fails to download the available Maintenance or Patch releases.
* 3969318 (3969113) The 'pkg list <pkg name>' command to check the uucp and bourne package fail for solaris 11.4 and later versions


DETAILS OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
This patch fixes the following incidents:

Patch ID: 7.4.0.200

* 3960118 (Tracking ID: 3960116)

SYMPTOM:
Installer reports incorrect licensing status as "Unlicensed" for InfoScale 7.4 even when the systems are properly licensed and also fails to download the available Maintenance or Patch releases.

DESCRIPTION:
For InfoScale version 7.4,  when you use the installer command with the -version option or the showversion script in the /opt/VRTS/install directory, the installer reports incorrect licensing status as "Unlicensed" even when the systems are properly licensed. 
This is due to incorrect release version string set in the installer. Later, installer is unable the get the path of the repository where the Maintenance or Patch releases should be downloaded.

RESOLUTION:
The installer is enhanced to fetch the correct licensing status by setting correct release version string. It is also enhanced to either use /opt/VRTS/repository as the default repository or to accept a different location to download the suggested releases.

* 3969318 (Tracking ID: 3969113)

SYMPTOM:
The 'pkg list <pkg name>' command to check the uucp and bourne package fail for solaris 11.4 and later versions

DESCRIPTION:
In Solaris 11.4 or later, the /usr/sunos/bin/sh file is part of the bourne package and the /var/spool/locks directory is part of the uucp package. For the prior Solaris releases, this file and directory were included in the core-os package. As these files are no longer available in the core-os package, the 'pkg list <pkg name>' command to check the uucp and bourne package fail for solaris 11.4 and later versions.

RESOLUTION:
The installer is enhanced to use the 'pkg search -l <file or directory>' command to identify if the file or directory is available in the installed packages. If it is not available, the installer prompts the user to install the required packages(uucp/bourne). For the versions prior to Solaris 11.4, the core-os package is available and the installer continues without failing.



INSTALLING THE PATCH
--------------------
1. Copy the hot-fix CPI_7.4.0_P2.pl to /tmp/
2. Run installation scripts with the hot-fix
Example:
./installer -require /tmp/CPI_7.4.0_P2.pl


REMOVING THE PATCH
------------------
NONE


SPECIAL INSTRUCTIONS
--------------------
NONE


OTHERS
------
NONE
Read and accept Terms of Service