python-sles12_x86_64-Patch-3.6.6.1

 Basic information
Release type: Patch
Release date: 2019-08-19
OS update support: None
Technote: None
Documentation: None
Popularity: 215 viewed    33 downloaded
Download size: 71.63 MB
Checksum: 313634579

 Applies to one or more of the following products:
InfoScale Availability 7.4.1 On SLES12 x86-64
InfoScale Enterprise 7.4.1 On SLES12 x86-64
InfoScale Foundation 7.4.1 On SLES12 x86-64
InfoScale Storage 7.4.1 On SLES12 x86-64

 Obsolete patches, incompatibilities, superseded patches, or other requirements:
None.

 Fixes the following incidents:
3982281

 Patch ID:
VRTSpython-3.6.6.1-SLES12

Readme file
                          * * * READ ME * * *
                           * * *  3.6.6 * * *
                          * * * Patch 1 * * *
                         Patch Date: 2019-08-14


This document provides the following information:

   * PATCH NAME
   * OPERATING SYSTEMS SUPPORTED BY THE PATCH
   * PACKAGES AFFECTED BY THE PATCH
   * BASE PRODUCT VERSIONS FOR THE PATCH
   * SUMMARY OF INCIDENTS FIXED BY THE PATCH
   * DETAILS OF INCIDENTS FIXED BY THE PATCH
   * INSTALLATION PRE-REQUISITES
   * INSTALLING THE PATCH
   * REMOVING THE PATCH


PATCH NAME
----------
 3.6.6 Patch 1


OPERATING SYSTEMS SUPPORTED BY THE PATCH
----------------------------------------
SLES12 x86-64


PACKAGES AFFECTED BY THE PATCH
------------------------------
VRTSpython


BASE PRODUCT VERSIONS FOR THE PATCH
-----------------------------------
   * InfoScale Availability 7.4.1
   * InfoScale Enterprise 7.4.1
   * InfoScale Foundation 7.4.1
   * InfoScale Storage 7.4.1


SUMMARY OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
Patch ID: 3.6.6.1
* 3982281 (3982282) When commands that need openssl are run on a SLES 12 SP4 system, the following error is logged: "/opt/VRTSpython/openssl/lib/libssl.so.1.0.0: no version information available."


DETAILS OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
This patch fixes the following incidents:

Patch ID: 3.6.6.1

* 3982281 (Tracking ID: 3982282)

SYMPTOM:
When commands that need openssl are run on a SLES 12 SP4 system, the following error is logged: "/opt/VRTSpython/openssl/lib/libssl.so.1.0.0: no version information available."

DESCRIPTION:
This issue occurs on SLES 12 SP4 systems that have a higher version of openssl (1.0.0p) installed while the VRTSpython package itself contains a lower version of openssl (1.0.0o). The VRTSpython adds the path "/opt/VRTSpython/openssl" in the ld.so.conf file, because the older version of openssl is built with dynamic linking. When other system commands are run on such a configuration, they fail to seek the openssl version, because the path of the lower version of openssl gets picked first.

RESOLUTION:
This hotfix provides the VRTSpython package with static linking so that the openssl path entry is not added to the ld.so.conf file.



INSTALLING THE PATCH
--------------------
- Copy the patch tar.gz file on the local system and untar it to say /tmp location
- Extract of the tar.gz file will have rpms/VRTSpython-3.6.6.1-SLES12.x86_64.rpm
- First you need to uninstall the old installed VRTSpython of version 3.6.6.1. To do so, please run the command ' rpm -e VRTSpython'
- Once the uninstallation of the old rpm is successful, run the command 'ldconfig' 
- Install the extracted rpm with command ' rpm -Uvh /tmp/rpms/VRTSpython-3.6.6.1-SLES12.x86_64.rpm '


REMOVING THE PATCH
------------------
NONE


SPECIAL INSTRUCTIONS
--------------------
NONE


OTHERS
------
NONE
Read and accept Terms of Service