This page lists publically-released patches for Veritas Enterprise Products.
For Product GA build, see Veritas Entitlement Management System(VEMS) by clicking the Veritas Support 'Licensing' option.
For information on private patches, contact Veritas Technical Support.
Veritas is making it easier to find all software installers and updates for Veritas products with a completely redesigned experience. NetBackup HotFixes, NetBackup Appliance patches and APTARE IT Analytics patches are now also available at the new Veritas Download Center.
Patches for your product can have a variety of names. These names are based on product, component, or package names. For more information on patch naming conventions and the relationship between products, components, and packages, see the SORT online help.
vcsea-sles15_x86_64-Patch-7.4.1.1600
Sign in if you want to rate this patch.

 Basic information
Release type: Patch
Release date: 2019-12-19
OS update support: None
Technote: None
Documentation: None
Popularity: 37 viewed    0 downloaded
Download size: 1.93 MB
Checksum: 2311072134

 Applies to one or more of the following products:
InfoScale Availability 7.4.1 On SLES15 x86-64
InfoScale Enterprise 7.4.1 On SLES15 x86-64

 Obsolete patches, incompatibilities, superseded patches, or other requirements:
None.

 Fixes the following incidents:
3982248

 Patch ID:
VRTSvcsea-7.4.1.1600-SLES15

 Readme file  [Save As...]
                          * * * READ ME * * *
     * * * Veritas High Availability Enterprise Agents 7.4.1 * * *
                         * * * Patch 1600 * * *
                         Patch Date: 2019-12-16


This document provides the following information:

   * PATCH NAME
   * OPERATING SYSTEMS SUPPORTED BY THE PATCH
   * PACKAGES AFFECTED BY THE PATCH
   * BASE PRODUCT VERSIONS FOR THE PATCH
   * SUMMARY OF INCIDENTS FIXED BY THE PATCH
   * DETAILS OF INCIDENTS FIXED BY THE PATCH
   * INSTALLATION PRE-REQUISITES
   * INSTALLING THE PATCH
   * REMOVING THE PATCH


PATCH NAME
----------
Veritas High Availability Enterprise Agents 7.4.1 Patch 1600


OPERATING SYSTEMS SUPPORTED BY THE PATCH
----------------------------------------
RHEL6 x86-64
RHEL7 x86-64
SLES12 x86-64
SLES15 x86-64


PACKAGES AFFECTED BY THE PATCH
------------------------------
VRTSvcsea


BASE PRODUCT VERSIONS FOR THE PATCH
-----------------------------------
   * InfoScale Availability 7.4.1
   * InfoScale Enterprise 7.4.1


SUMMARY OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
Patch ID: 7.4.1.1600
* 3982248 (3989510) The VCS agent for Oracle does not support Oracle 19c databases.


DETAILS OF INCIDENTS FIXED BY THE PATCH
---------------------------------------
This patch fixes the following incidents:

Patch ID: 7.4.1.1600

* 3982248 (Tracking ID: 3989510)

SYMPTOM:
The VCS agent for Oracle does not support Oracle 19c databases.

DESCRIPTION:
In case of non-CDB or CDB-only databases, the VCS agent for Oracle does not recognize that an Oracle 19c resource is intentionally offline after a graceful shutdown. This functionality is never supported for PDB-type databases.

RESOLUTION:
The agent is updated to recognize the graceful shutdown of an Oracle 19c resource as intentional offline in case of non-CDB or CDB-only databases. For details, refer to the article at: https://www.veritas.com/support/en_US/article.100046803.



INSTALLING THE PATCH
--------------------
Run the Installer script to automatically install the patch:
-----------------------------------------------------------
Please be noted that the installation of this P-Patch will cause downtime.

To install the patch perform the following steps on at least one node in the cluster:
1. Copy the patch vcsea-sles15_x86_64-Patch-7.4.1.1600.tar.gz to /tmp
2. Untar vcsea-sles15_x86_64-Patch-7.4.1.1600.tar.gz to /tmp/hf
    # mkdir /tmp/hf
    # cd /tmp/hf
    # gunzip /tmp/vcsea-sles15_x86_64-Patch-7.4.1.1600.tar.gz
    # tar xf /tmp/vcsea-sles15_x86_64-Patch-7.4.1.1600.tar
3. Install the hotfix(Please be noted that the installation of this P-Patch will cause downtime.)
    # pwd /tmp/hf
    # ./installVRTSvcsea741P1600 [<host1> <host2>...]

You can also install this patch together with 7.4.1 base release using Install Bundles
1. Download this patch and extract it to a directory
2. Change to the Veritas InfoScale 7.4.1 directory and invoke the installer script
   with -patch_path option where -patch_path should point to the patch directory
    # ./installer -patch_path [<path to this patch>] [<host1> <host2>...]

Install the patch manually:
--------------------------
The following steps should be run on all nodes in the VCS cluster:
1. Stopping VCS on the cluster node.
2. Installing the patch.
3. Restarting VCS on the node.

Stopping VCS on the cluster node
--------------------------------
To stop VCS on the cluster node:
1. Ensure that the "/opt/VRTS/bin" directory is included in your PATH
   environment variable so that you can execute all the VCS commands.
   For more information, refer to the Veritas Cluster Server
   Installation Guide.
2. Verify that the version of VRTSvcs is 7.4.1 for Linux.
3. Freeze all the service groups persistently.
    # haconf -makerw
    # hagrp -freeze [group] -persistent
    # haconf -dump -makero
4. Stop the cluster on all nodes. If the cluster is writable, you may
   close the configuration before stopping the cluster.
    # haconf -dump -makero
   From any node, execute the following command.
    # hastop -all
    or
    # hastop -all -force
   Verify that the cluster is stopped on all nodes
   by running the 'ha' command.
    # hasys -state
   On all nodes, make sure that both had and hashadow processes are
   stopped.
5. Log in as the super user into the system where the patch is to be
   installed.
6. Run the preceding steps on all nodes in the VCS cluster.

Installing the Patch
--------------------
Perform the following steps:
1. Un-compress the downloaded patch from Veritas.
   Change the directory to the uncompressed patch location.
   Install the VRTSvcsea patch using the following command:
# rpm -Uvh VRTSvcsea-7.4.1.1600-SLES15.x86_64.rpm
2. Run the following command to verify if the new patch has been installed:
    # rpm -q VRTSvcsea
   If the proper patch is installed, the following output is displayed:
VRTSvcsea-7.4.1.1600-SLES15.x86_64.rpm

Re-starting VCS on the cluster node
-----------------------------------
1. To start the cluster services on all cluster
   nodes. Execute the following command first on one node:
    # hastart
   On all the other nodes, start VCS by executing the hastart command after the
   first node goes to LOCAL_BUILD or RUNNING state.
2. Unfreeze all the groups.
     # haconf -makerw
     # hagrp -unfreeze [group] -persistent
     # haconf -dump -makero


REMOVING THE PATCH
------------------
Removal of the patch will result in removing the entire package 
from the system/node. To go back to a previous installed version 
of the package, you may need to re-install the package.
Run the following steps on all the VCS cluster nodes:

To remove the patch from a cluster node:
---------------------------------------------
1. Freeze all the service groups persistently.
    # haconf -makerw
    # hagrp -freeze [group] -persistent

2. Stop VCS on the node by following the steps provided in the section 
   "Stopping VCS on the cluster node".

3. Remove the patch by using the following command:
    # rpm -e VRTSvcsea

4. Verify that the patch has been removed from the system:
    # rpm -qa | grep VRTSvcsea
   Ensure that the VRTSvcsea package is not be displayed. This confirms 
   that the package is removed.

5. Install the VRTSvcsea 7.4.1 package from the installation media.

6. To start the cluster services on all cluster 
   nodes, execute the following command first on one node:
    # hastart

   On all the other nodes, start VCS by executing hastart after the 
   first node goes to LOCAL_BUILD or RUNNING state.

7. Unfreeze all the groups.
     # hagrp -unfreeze [group] -persistent
     # haconf -dump -makero


SPECIAL INSTRUCTIONS
--------------------
NONE


OTHERS
------
NONE



Read and accept Terms of Service