This page lists publically-released patches for Veritas Enterprise Products.
For Product GA build, see Veritas Entitlement Management System(VEMS) by clicking the Veritas Support 'Licensing' option.
For information on private patches, contact Veritas Technical Support.
Veritas is making it easier to find all software installers and updates for Veritas products with a completely redesigned experience. NetBackup HotFixes and NetBackup Appliance patches are now also available at the new Veritas Download Center.
Patches for your product can have a variety of names. These names are based on product, component, or package names. For more information on patch naming conventions and the relationship between products, components, and packages, see the SORT online help.
vcs_agents-hpux1131-VRTSvcsor-5.0RP2HF1
Obsolete
The latest patch(es) : vcs_agents-hpux1131-VRTSvcsor-5.0RP2HF2 
Sign in if you want to rate this patch.

 Basic information
Release type: Hot Fix
Release date: 2009-07-22
OS update support: None
Technote: 328818
Documentation: None
Popularity: 886 viewed    16 downloaded
Download size: 4.14 MB
Checksum: 4106621946

 Applies to one or more of the following products:
Cluster Server Agents 5.0 On HP-UX 11i v3 (11.31)
Storage Foundation for Oracle 5.0 On HP-UX 11i v3 (11.31)
Storage Foundation for Oracle RAC 5.0 On HP-UX 11i v3 (11.31)

 Obsolete patches, incompatibilities, superseded patches, or other requirements:

This patch is obsolete. It is superseded by: Release date
vcs_agents-hpux1131-VRTSvcsor-5.0RP2HF2 2009-11-05

This patch supersedes the following patches: Release date
vcs_agents-hpux1131-VRTSvcsor-5.0RP2 (obsolete) 2009-06-09

 Fixes the following incidents:
1718459

 Patch ID:
PVCO_03897

 Readme file  [Save As...]
OS: HP-UX
OS Version: 11i v3
Fixes Applied for Products:
	VRTSvcsor - Veritas High Availability Agent for Oracle by Symantec

Additional Instructions:
Please read the following instructions before installing the patch.

 PATCH PVCO_03897 for VCS Oracle Agent 5.0 (11i v3)
==================================================

 Patch Date:  July, 2009

This README provides information on the following:
 * BEFORE GETTING STARTED
 * FIXES AND ENHANCEMENTS INCLUDED IN THE PATCH
 * PACKAGES AFFECTED BY THE PATCH
 * INSTALLING THE PATCH
 * UNINSTALLING THE PATCH
 * KNOWN ISSUES


BEFORE GETTING STARTED:
----------------------
This patch should be applied to:
	VRTSvcsor 5.0 running on HP-UX 11i v3
or
	VRTSvcsor 5.0RP2 running on HP-UX 11i v3

Ensure that you are running the supported configurations before
installing this patch.


FIXES AND ENHANCEMENTS INCLUDED IN THE PATCH:
--------------------------------------------
Etrack Incidents: 1718459

SDR's of Fixed Symantec Incidents:
---------------------------------
Symantec Incident : 1718459
Symptom:
	When you set an error corresponding to an ORA error in the 
	"oraerror.dat" file, the agent does not honor the corresponding  
	action. Instead, the agent fails over the resource.
Defect Description:
	This happens because the function call for parsing 
	the ORA errors and taking the corresponding action was missing.
Resolution:
	The ORA errors are populated in the VCSAgStartUp() function.
	Once the ORA errors and its corresponding actions are populated,
	the agent will start performing action to the corresponding error.


PACKAGES AFFECTED BY THE PATCH :
-------------------------------
This patch updates the following VCS package(s) 
	VRTSvcsor from 5.0 (or 5.0RP2) to 5.0RP2HF1 on HP-UX 11i v3


INSTALLING THE PATCH :
--------------------
The following steps should be run on all nodes in the VCS cluster:

A] Stopping the VCS agent on the cluster node:
---------------------------------------------
Stop the VCS agent in the cluster node with the following command:
	# haagent -stop Oracle -sys [sysname] -force

B] Installing the Patch:
-----------------------
1. Extract the downloaded patch from Symantec website.
   Change directory to the unzipped patch location.
   Install the VRTSvcsor patch using the following command:
	# swinstall -s `pwd`/patches -x autoreboot=true PVCO_03897 

2. Verify that the new patch has been installed:
	# swlist PVCO_03897
   You will find the following output on display with the patch 
   installed properly:
	PVCO_03897    1.0       VRTS 5.0 RP2 HF1 VRTSvcsor Command Patch

C] Re-starting the VCS agent on the cluster node:
------------------------------------------------
After successful installation of the patch, run the following command 
for restarting the agent:
	# haagent -start Oracle -sys [sysname]


UNINSTALLING THE PATCH:
-----------------------
The following steps should be run on all nodes in the VCS cluster:

A] To remove the patch from a cluster node:
------------------------------------------
1. Follow the steps provided under "Stopping the VCS agent on the 
   cluster node" section above, to stop VCS agent on the node.

2. Remove the patch by the following command:
	# swremove -x autoreboot=true PVCO_03897

3. Verify that the patch has been removed from the system:
	# swlist | grep PVCO_03897
   There will be no output on the display following this command,
   for a successful removal.

4. Restart the VCS Agent following the steps under 
   "Re-starting the VCS agent on the cluster node" section above.

KNOWN ISSUES:
------------
e1531512:
	OracleAgent picks up only the last corresponding action
	from oraerror.dat ignoring the previous.



Read and accept Terms of Service