This page lists publically-released patches for Veritas Enterprise Products.
For Product GA build, see Veritas Entitlement Management System(VEMS) by clicking the Veritas Support 'Licensing' option.
For information on private patches, contact Veritas Technical Support.
Veritas is making it easier to find all software installers and updates for Veritas products with a completely redesigned experience. NetBackup HotFixes and NetBackup Appliance patches are now also available at the new Veritas Download Center.
Patches for your product can have a variety of names. These names are based on product, component, or package names. For more information on patch naming conventions and the relationship between products, components, and packages, see the SORT online help.
vcs_agents-sol_sparc-VRTSvcsor-5.0MP3HF2
Obsolete
The latest patch(es) : sfha-sol_sparc-5.0MP3RP5 
Sign in if you want to rate this patch.

 Basic information
Release type: Hot Fix
Release date: 2009-08-07
OS update support: None
Technote: 329645
Documentation: None
Popularity: 1375 viewed    105 downloaded
Download size: 146.78 KB
Checksum: 753715020

 Applies to one or more of the following products:
Storage Foundation for Oracle 5.0MP3 On Solaris 10 SPARC
Storage Foundation for Oracle 5.0MP3 On Solaris 8 SPARC
Storage Foundation for Oracle 5.0MP3 On Solaris 9 SPARC
Storage Foundation for Oracle RAC 5.0MP3 On Solaris 10 SPARC
Storage Foundation for Oracle RAC 5.0MP3 On Solaris 8 SPARC
Storage Foundation for Oracle RAC 5.0MP3 On Solaris 9 SPARC

 Obsolete patches, incompatibilities, superseded patches, or other requirements:

This patch is obsolete. It is superseded by: Release date
sfha-sol_sparc-5.0MP3RP5 2011-05-06
sfha-sol_sparc-5.0MP3RP4 (obsolete) 2010-06-10
sfha-sol_sparc-5.0MP3RP3 (obsolete) 2009-12-18

This patch supersedes the following patches: Release date
vcs_agents-sol_sparc-5.0MP3-sol_sparc_HF1_OracleAgent (obsolete) 2009-03-23

 Fixes the following incidents:
1543386, 1544263, 1780698

 Patch ID:
140660-02

 Readme file  [Save As...]
OS: Solaris Sparc
OS Version: 5.8, 5.9 & 5.10
Fixes Applied for Products:
	VRTSvcsor - Veritas High Availability Agent for Oracle by Symantec

Additional Instructions:
Please read the following instructions before installing the patch.

 PATCH VRTSvcsor 5.0MP3HF2 for VCS Oracle Agent 5.0MP3
=======================================================

 Patch Date:  August, 2009

This README provides information on:
 * BEFORE GETTING STARTED
 * FIXES AND ENHANCEMENTS INCLUDED IN THE PATCH
 * PACKAGES AFFECTED BY THE PATCH
 * INSTALLING THE PATCH
 * UNINSTALLING THE PATCH


BEFORE GETTING STARTED:
----------------------
This patch applies to:
	VRTSvcsor 5.0MP3 running on Solaris Sparc 5.8, 5.9 or 5.10

Ensure that you are running the supported configurations before
installing this patch.


FIXES AND ENHANCEMENTS INCLUDED IN THE PATCH:
--------------------------------------------
Etrack Incidents: 1543386, 1544263, 1780698

SDR's of Fixed Symantec Incidents:
--------------------------------
Symantec Incident : 1543386
Symptom:
	When an error corresponding to an ORA error, is set in 
	the oraerror.dat file, the agent did not honor the action.
	Instead, it was always failing over the resource.
Defect Description:
	This happenned because, the function call to parse the ORA
	errors and to take the corresponding actions was missing.
Resolution:
	The ORA errors are now populated properly for the Oracle 
	agent's reference. It now performs the corresponding 
	actions mentioned in the oraerror.dat.

Symantec Incident : 1544263
Symptom:
	With different kind of errors, the agent used to take actions
	corresponding to the last received error, ignoring the rest.
Defect Description:
	With this parsing method, Oracle agent may ignore some 
	important actions, specified in oraerror.dat file,
	which could result in inconsistency of the state of the resource.
Resolution:
	The parsing method is updated to prioritize certain actions, 
	when multiple errors occur at a time.

Symantec Incident : 1780698
Symptom:
	Oracle Agent was not able to send SNMP/SMTP notifications 
	in case of any error defined in oraerror.dat file.
Defect Description:
	There was a problem in forming the hanotify(1m) command 
	in Oracle Agent, while sending notifications.
Resolution:
	The problem is now fixed to correctly form the hanotify(1m) 
	command in Oracle Agent, while sending notifications.


PACKAGES AFFECTED BY THE PATCH:
-------------------------------
This patch updates the following VCS package(s) 
	VRTSvcsor from 5.0MP3 to 5.0MP3HF2


INSTALLING THE PATCH:
--------------------
The following steps should be run on all nodes in the VCS cluster:

Stopping VCS agent on a node:
-----------------------------
Stop Oracle agent using:
	# haagent -stop Oracle -sys [system_name] -force

Installing the Patch:
--------------------
1. Gunzip and untar the downloaded patch from Symantec.
   Change directory to the unzipped patch location. 
   Install the VRSTvcsor patch using the following command:
	# patchadd 140660-02

2. Verify that the new patch has been installed:
	# showrev -p | grep 140660-02
   You will find the following output on display with the patch 
   installed properly:
Patch: 140660-02 Obsoletes:  Requires: 123670-03 Incompatibles:  
Packages: VRTSvcsor

Restart VCS agent on a node:
----------------------------
Re-start Oracle agent using:
	# haagent -start Oracle -sys [system_name]


UNINSTALLING THE PATCH:
-----------------------
The following steps should be run on all nodes in the VCS cluster:

Steps to remove the Patch from a cluster node:
---------------------------------------------
1. Follow the steps provided under "Stopping VCS agent on a node" 
   section above, to stop VCS agent on the node.

2. Remove the patch by the following command:
	# patchrm 140660-02

3. Verify that the patch has been removed from the system:
	# showrev -p | grep 140660-02
   Nothing will be printed after successful removal of the patch.
4. Restart the node following the steps under 
   "Restart VCS agent on a node" section above.



Read and accept Terms of Service