This page lists publically-released patches for Veritas Enterprise Products.
For Product GA build, see Veritas Entitlement Management System(VEMS) by clicking the Veritas Support 'Licensing' option.
For information on private patches, contact Veritas Technical Support.
For NetBackup Enterprise Server and NetBackup Server patches, see the NetBackup Downloads.
Patches for your product can have a variety of names. These names are based on product, component, or package names. For more information on patch naming conventions and the relationship between products, components, and packages, see the SORT online help.
vcs-rhel5_x86_64-VRTSvxfen-VRTSvcssy-5.0.1P1
Sign in if you want to rate this patch.

 Basic information
Release type: P-patch
Release date: 2010-12-16
OS update support: None
Technote: None
Documentation: None
Popularity: 398 viewed    10 downloaded
Download size: 409.67 KB
Checksum: 1700589923

 Applies to one or more of the following products:
Cluster Server 5.0 On RHEL5 x86-64
Storage Foundation Cluster File System 5.0 On RHEL5 x86-64
Storage Foundation Cluster File System for Oracle RAC 5.0 On RHEL5 x86-64
Storage Foundation for DB2 5.0 On RHEL5 x86-64
Storage Foundation for Oracle 5.0 On RHEL5 x86-64
Storage Foundation for Oracle RAC 5.0 On RHEL5 x86-64
Storage Foundation HA 5.0 On RHEL5 x86-64

 Obsolete patches, incompatibilities, superseded patches, or other requirements:
None.

 Fixes the following incidents:
2093659, 2186348

 Patch ID:
VRTSvcssy-5.0.30.10-GA_P1_RHEL5
VRTSvxfen-5.0.30.10-GA_P1_RHEL5

 Readme file  [Save As...]
Patch Date: December, 2010

OS: Linux
OS Version: RHEL50 (x86_64)

Please read the instructions below for installing the patch.

PATCH UPGRADE TO SFSYBASECE 5.0 GA P1 on RHEL5 (x86_64)
===================================================

This README provides information on:
 * GETTING STARTED
 * FIXES AND ENHANCEMENTS INCLUDED IN THE PATCH
 * PACKAGES AFFECTED BY THE PATCH
 * INSTALLING THE PATCH USING FULL UPGRADE PROCEDURE:
 * INSTALLING THE PATCH USING PHASED UPGRADE PROCEDURE
 * UNINSTALLING THE PATCH


GETTING STARTED:
----------------
This patch applies only to:
	VRTSvxfen and VRTSvcssy 5.0 GA on RHEL5 (x86_64)

Ensure that you are running the supported configuration before
installing this patch.

FIXES AND ENHANCEMENTS INCLUDED IN THE PATCH: 
--------------------------------------------
Etrack Incidents: 2093659, 2186348

SDR's of Fixed Symantec Incidents:
--------------------------------
Symantec Incident : 2093659
Symptom:
	VCS fails to start due to incorrect fencing mode.
Defect Description:
	VCS fails to recognize the "sybase" fencing mode when the 
	UseFence attribute is set to "SCSI3" in the main.cf file.

Resolution:
	VCS now starts successfully as the fencing driver 
	sends the correct fencing mode.

Symantec Incident : 2186348
Enhancement:
	With Sybase ASE CE version 15.5 ESD #1 onwards, a new timeout option is supported 
	with dataserver shutdown command. This option specifies the maximum amount of time 
	within which the Sybase dataserver ensures stopping of all of its running or 
	sleeping database processes. In the current Sybase agent implementation (without this 
	timeout option), this is achieved using some delays (with sleep command), but under 
	certain situations, this implementation may not cover all the cases where few Sybase 
	specific processes still keep running even after calling out shutdown with wait
	command for shutting down the database.

PACKAGES AFFECTED BY THE PATCH:
-------------------------------
This patch updates the following VCS package(s) 
	VRTSvxfen 5.0 (Veritas I/O Fencing by Symantec)
	VRTSvcssy 5.0 (Veritas High Availability Agent for Sybase 
		       by Symantec)

INSTALLING THE PATCH USING FULL UPGRADE PROCEDURE:
--------------------------------------------------
Run the following steps on all the cluster nodes at the same time:

Note: If this is an upgrade of extisting SFSYBASECE cluster, please ignore 
step 1 and continue from step 2.

1. If this a fresh install of cluster, please install and configure SFSYBASECE 
   5.0 GA. 

   Refer to Veritas Storage Foundation Sybase ASE CE Installation and 
   Configuration Guide and follow the instructions till chapter 5 to complete 
   the exercise.

2. Stop the stack up to the fencing level.
   Stop VCS which will stop CFS and CVM:
	# /etc/init.d/vcs stop
   Stop fencing:
	# /etc/init.d/vxfen stop

3. Upgrade to SFSYBASECE 5.0 GA P1 as follows:

    a. Change to the appropriate directory where patches are present. 

    b. Upgrade VRTSvxfen and VRTSvcssy 5.0 GA P1 patches:
	# rpm -Uvh VRTSvxfen-5.0.30.10-GA_P1_RHEL5.x86_64.rpm
	# rpm -Uvh VRTSvcssy-5.0.30.10-GA_P1_RHEL5.i686.rpm

4. Verify if the packages have been upgraded
	# rpm -qa|grep VRTSvxfen
   You should see output similar to:
	VRTSvxfen-5.0.30.10-GA_P1_RHEL5
	
	# rpm -qa|grep VRTSvcssy
   You should see output similar to:
        VRTSvcssy-5.0.30.10-GA_P1_RHEL5

5. Start fencing and vcs on the node:
	# /etc/init.d/vxfen start
	
	Add UseFence=SCSI3 under cluster servicegroup definition in main.cf, 
        on one of the cluster nodes and then restart VCS on that node first 
        before starting it on the other nodes:
	# /etc/init.d/vcs start

6. Upgrade the Sybase ASE CE database if required. Refer to Sybase 
   documentation for instructions.

INSTALLING THE PATCH USING PHASED UPGRADE PROCEDURE
---------------------------------------------------
For phased upgrade, divide the cluster into two subclusters. 
For e.g. 4 node cluster can have 2 subclusters each with 2 nodes in it.

Perform steps 1 to 3 on first subcluster (eg first 2 nodes in 4 node cluster)
1. Stop the stack up to the fencing level.
   Stop VCS which will stop CFS and CVM:
        # /etc/init.d/vcs stop
   Stop fencing:
        # /etc/init.d/vxfen stop

2. Upgrade to SFSYBASECE 5.0 GA P1 as follows:

    a. Change to the appropriate directory where patches are present.

    b. Upgrade VRTSvxfen and VRTSvcssy 5.0 GA P1 patches:
        # rpm -Uvh VRTSvxfen-5.0.30.10-GA_P1_RHEL5.x86_64.rpm
        # rpm -Uvh VRTSvcssy-5.0.30.10-GA_P1_RHEL5.i686.rpm

3. Verify if the packages have been upgraded
        # rpm -qa|grep VRTSvxfen
   You should see output similar to:
        VRTSvxfen-5.0.30.10-GA_P1_RHEL5

        # rpm -qa|grep VRTSvcssy
   You should see output similar to:
        VRTSvcssy-5.0.30.10-GA_P1_RHEL5

4. Add UseFence=SCSI3 under cluster servicegroup definition in main.cf, 
   on one of the nodes of first subcluster.

5. Now on the second subcluster (eg remaining 2 nodes of the 4 node cluster), 
   perform the following:
   Stop the stack up to the fencing level.
   Stop VCS which will stop CFS and CVM:
        # /etc/init.d/vcs stop
   Stop fencing:
        # /etc/init.d/vxfen stop

   Note: Downtime starts here.

   Now start fencing and VCS on the node where main.cf is modified in step 4
   the first subcluster. 
        # /etc/init.d/vxfen start
        # /etc/init.d/vcs start

   Note: Downtime ends here.

6. Start fencing and vcs on the other nodes (other than the one where main.cf was
   modified as mentioned in step 4 in the first subcluster.
        # /etc/init.d/vxfen start
        # /etc/init.d/vcs start

7. Repeat Steps 2, 3 on the second subcluster with the remaining nodes.

8. Start fencing and vcs on all the nodes in the second subcluster
        # /etc/init.d/vxfen start
        # /etc/init.d/vcs start

9. Upgrade the Sybase database if required. Please refer to the Sybase 
   documentation for the same.

UNINSTALLING THE PATCH:
-----------------------

Run the following steps on all the cluster nodes at the same time:

1. Stop the stack up to the fencing level.
   Stop VCS which will stop CFS and CVM:
	# /etc/init.d/vcs stop
   Stop fencing:
	# /etc/init.d/vxfen stop

2. Remove the patch by the following command:
	# rpm -e --nodeps VRTSvxfen
	# rpm -e --nodeps VRTSvcssy

3. Verify that the patch is uninstalled from the node:
	# rpm -q VRTSvxfen
   You should see output similar to:
	package VRTSvxfen is not installed

	# rpm -q VRTSvcssy
   You should see output similar to:
	package VRTSvcssy is not installed

4. Install the previous version of VRTSvxfen and VRTSvcssy packages:
	# rpm -ivh VRTSvxfen<version>
	where, <version> is the previous version of VRTSvxfen
	package, which was installed before applying the patch.

	# rpm -ivh VRTSvcssy<version>
	where, <version> is the previous version of VRTSvcssy
	package, which was installed before applying the patch.

5. Restart fencing and vcs on the node:
	# /etc/init.d/vxfen start
	
	Remove UseFence=SCSI3 from under the cluster servicegroup definition 
	in main.cf, on one of the cluster nodes and then restart VCS on that 
	node first before starting it on the other nodes:
	# /etc/init.d/vcs start



Read and accept Terms of Service