This page lists publically-released patches for Veritas Enterprise Products.
For Product GA build, see Veritas Entitlement Management System(VEMS) by clicking the Veritas Support 'Licensing' option.
For information on private patches, contact Veritas Technical Support.
Veritas is making it easier to find all software installers and updates for Veritas products with a completely redesigned experience. NetBackup HotFixes and NetBackup Appliance patches are now also available at the new Veritas Download Center.
Patches for your product can have a variety of names. These names are based on product, component, or package names. For more information on patch naming conventions and the relationship between products, components, and packages, see the SORT online help.
vm-aix-5.1SP1P2
Obsolete
The latest patch(es) : sfha-aix-5.1SP1RP4 
Sign in if you want to rate this patch.

 Basic information
Release type: P-patch
Release date: 2011-01-12
OS update support: None
Technote: None
Documentation: None
Popularity: 1137 viewed    42 downloaded
Download size: 6.08 MB
Checksum: 3528100046

 Applies to one or more of the following products:
Dynamic Multi-Pathing 5.1SP1 On AIX 5.3
Dynamic Multi-Pathing 5.1SP1 On AIX 6.1
Storage Foundation 5.1SP1 On AIX 5.3
Storage Foundation 5.1SP1 On AIX 6.1
Storage Foundation Cluster File System 5.1SP1 On AIX 5.3
Storage Foundation Cluster File System 5.1SP1 On AIX 6.1
Storage Foundation for Oracle RAC 5.1SP1 On AIX 5.3
Storage Foundation for Oracle RAC 5.1SP1 On AIX 6.1
Storage Foundation HA 5.1SP1 On AIX 5.3
Storage Foundation HA 5.1SP1 On AIX 6.1

 Obsolete patches, incompatibilities, superseded patches, or other requirements:

This patch is obsolete. It is superseded by: Release date
sfha-aix-5.1SP1RP4 2013-08-21
vm-aix-5.1SP1RP3P1 (obsolete) 2012-11-16
sfha-aix-5.1SP1RP3 (obsolete) 2012-10-02
vm-aix-5.1SP1RP2P3 (obsolete) 2012-06-13
vm-aix-5.1SP1RP2P2 (obsolete) 2011-10-28
vm-aix-5.1SP1RP2P1 (obsolete) 2011-10-19
sfha-aix-5.1SP1RP2 (obsolete) 2011-09-28
vm-aix-5.1SP1RP1P1 (obsolete) 2011-02-24
sfha-aix-5.1SP1RP1 (obsolete) 2011-02-11

This patch supersedes the following patches: Release date
vm-aix-5.1SP1P1 (obsolete) 2010-12-01

 Fixes the following incidents:
2200097, 2218706, 2226248

 Patch ID:
VRTSvxvm-05.01.0100.0200

 Readme file  [Save As...]
Date: 2011-01-12
OS: AIX
OS Version: 5.3, 6.1
Etrack Incidents: 2226248, 2218706, 2200097

Errors/Problems Fixed:
======================
Incidents included in this 5.1SP1P2
----------------------------------
2226248 VXDMP driver loading failed after SP1 applied
2218706 Support for MAXCPU on Power 7
2200097 VxVM processes failed to start after rejecting the upgraded patch.


Install/Uninstall Instructions:
===============================
=======================
Installation Procedure:
=======================

If the currently installed VRTSvxvm is below 5.1.100.0 level,  
upgrade VRTSvxvm to 5.1.100.0 level before installing this patch.

AIX maintenance levels and APARs can be downloaded from the
IBM web site:

        http://techsupport.services.ibm.com 


1. Since the patch process will configure the new kernel extensions,
ensure that no VxVM volumes are in use or open or mounted before
starting the installation procedure

2. Check whether root support or DMP native support is enabled. If it is enabled, it will be retained after patch upgrade.

# vxdmpadm gettune dmp_native_support
If the current value is "on", DMP native support is enabled on this machine.
# vxdmpadm native list vgname=rootvg
If the output is some list of hdisks, root support is enabled on this machine

3.
	a. Before applying this VxVM 5.1 SP1P2 patch, stop the VEA Server's vxsvc process:
	# /opt/VRTSob/bin/vxsvcctrl stop

	b. To apply this patch, use following command:
	# installp -ag -d ./VRTSvxvm.bff VRTSvxvm

	c. To apply and commit this patch, use following command:
	# installp -acg -d ./VRTSvxvm.bff VRTSvxvm
	NOTE: Please refer installp(1M) man page for clear understanding on APPLY & COMMIT state of the package/patch.

	d. Reboot the system to complete the patch upgrade.
	# reboot

	e. Confirm that the point patch is installed:
	# lslpp -hac VRTSvxvm | tail -1
	/etc/objrepos:VRTSvxvm:5.1.100.200::APPLY:COMPLETE:01/02/11:10;56;11

	f. if root support or dmp native support is enabled in step 2, verify whether it is retained after completing the patch upgrade
	# vxdmpadm gettune dmp_native_support
	# vxdmpadm native list vgname=rootvg

==========================
De-installation Procedure:
==========================

1. Check whether root support or DMP native support is enabled or not:

	# vxdmpadm gettune dmp_native_support
If the current value is "on", DMP native support is enabled on this machine.
	# vxdmpadm native list vgname=rootvg
If the output is some list of hdisks, root support is enabled on this machine

If disabled: goto step 3.
If enabled: goto step 2.

2. If root support or DMP native support is enabled:

	a. It is essential to disable DMP native support.
	Run the following command to disable DMP native support as well as root support
	# vxdmpadm settune dmp_native_support=off

	b. If only root support is enabled, run the following command to disable root support
	# vxdmpadm native disable vgname=rootvg

	c. Reboot the system
	# reboot

	d. Before backing out patch, stop the VEA server's vxsvc process:
	# /opt/VRTSob/bin/vxsvcctrl stop

   To reject the patch if it is in "APPLIED" state, use the following command and re-enable DMP support
	# installp -r VRTSvxvm 5.1.100.200

	a. Reboot the system
	# reboot

	b. Enable DMP native support, this will also enable root suppport
	# vxdmpadm settune dmp_native_support=on

	c. Reboot the system.
	# reboot

	d. Verify DMP native or root support is enabled:
	# vxdmpadm gettune dmp_native_support


   To remove the patch if it is in "COMMITED" state, use the following command and re-enable DMP support

	# installp -ug VRTSvxvm

	a. Install previous VxVM package version. Install base VxVM package and any dependent packages

	b. Run vxinstall to start the processes
	# vxinstall

	c. Enable DMP native support, this will also enable root suppport
	# vxdmpadm settune dmp_native_support=on

	d. Reboot the system.
	# reboot

	e. Verify DMP native support has been enabled:
	# vxdmpadm gettune dmp_native_support


3. If root support or DMP native support is not enabled

	a. Before back out patch, kill the VEA Server's vxsvc process:
	# /opt/VRTSob/bin/vxsvcctrl stop

   To reject the patch if it is "APPLIED state, use the following command

	# installp -r VRTSvxvm 5.1.100.200
	Reboot the system
	# reboot

   To remove the patch if it is "COMMITED" state, use the following command

	# installp -ug VRTSvxvm
	a. Reboot the system
	# reboot

	b. Install previous VxVM package version. Install base VxVM package and any dependent packages

	c. Run vxinstall to start the processes
	# vxinstall

Additional Notes:
=================



Read and accept Terms of Service