cpi-5.1SP1RP1P3
Obsolete

 Basic information
Release type: P-patch
Release date: 2011-08-05
OS update support: None
Technote: None
Documentation: None
Popularity: 1295 viewed    73 downloaded
Download size: 6.69 KB
Checksum: 3964872664

 Applies to one or more of the following products:
Cluster Server 5.1SP1 On AIX 5.3
Cluster Server 5.1SP1 On AIX 6.1
Cluster Server 5.1SP1 On RHEL5 x86-64
Cluster Server 5.1SP1 On SLES10 x86-64
Cluster Server 5.1SP1 On SLES11 x86-64
Cluster Server 5.1SP1 On Solaris 10 SPARC
Cluster Server 5.1SP1 On Solaris 10 X64
Cluster Server 5.1SP1 On Solaris 9 SPARC
Storage Foundation HA 5.1SP1 On AIX 5.3
Storage Foundation HA 5.1SP1 On AIX 6.1
Storage Foundation HA 5.1SP1 On RHEL5 x86-64
Storage Foundation HA 5.1SP1 On SLES10 x86-64
Storage Foundation HA 5.1SP1 On SLES11 x86-64
Storage Foundation HA 5.1SP1 On Solaris 10 SPARC
Storage Foundation HA 5.1SP1 On Solaris 10 X64
Storage Foundation HA 5.1SP1 On Solaris 9 SPARC

 Obsolete patches, incompatibilities, superseded patches, or other requirements:

This patch is obsolete. It is superseded by: Release date
cpi-5.1SP1RP1P4 2012-10-31
sfha-sol_x64-5.1SP1RP2 (obsolete) 2011-09-28
sfha-sol_sparc-5.1SP1RP2 (obsolete) 2011-09-28
sfha-sles10_x86_64-5.1SP1RP2 (obsolete) 2011-09-28
sfha-rhel5_x86_64-5.1SP1RP2 (obsolete) 2011-09-28
sfha-aix-5.1SP1RP2 (obsolete) 2011-09-28

This patch supersedes the following patches: Release date
cpi-5.1SP1RP1P2 (obsolete) 2011-07-13
cpi-5.1SP1RP1P1 (obsolete) 2011-05-23

This patch requires: Release date
sfha-sol_x64-5.1SP1RP1 (obsolete) 2011-02-14
sfha-sol_sparc-5.1SP1RP1 (obsolete) 2011-02-14
sfha-sles11_x86_64-5.1SP1RP1 (obsolete) 2011-02-11
sfha-rhel5_x86_64-5.1SP1RP1 (obsolete) 2011-02-11
sfha-sles10_x86_64-5.1SP1RP1 (obsolete) 2011-02-11
sfha-aix-5.1SP1RP1 (obsolete) 2011-02-11

 Fixes the following incidents:
2275547, 2324154, 2368684, 2489862

 Patch ID:
None.

Readme file
The patch fixes the following installer issues:

Issue 1:
OS: All supported platforms
Products: VCS, SFHA
Etrack: 2324154

Problem statement:
During upgrade of a one-node cluster from 5.1SP1 to 5.1SP1RP1 using responsefile, if VCS is not running before upgrade, then the installer will overwrite the main.cf file, since it fails to detect that VCS was previously configured. The patch also provides a new CLI option, nostart, which allows processes to not be started after RP upgraded. 


Issue 2:
OS: All supported platforms
Products: VCS, SFHA
Etrack: 2368684

Problem statement:
During upgrade of a one-node cluster from 5.1SP1 to 5.1SP1RP1, if VCS is running with -onenode option, then installer should detect it as a single-node cluster even if llttab, llthost, or gabtab files exist.


Issue 3:
OS: Linux
Products: All HA products
Etrack: 2275547

Problem statement:
SFHA 5.1SP1 or 5.1SP1RP1 installer cannot configure vlan-devices for LLT heartbeat links on Linux.


Issue 4:
OS: Linux, AIX, SunOS
Products: All HA products
Release: 5.1SP1RP1
Etrack: 2489862

Problem statement:
Installer fails to check existing VCS configuration if the cluster ID was set by "set-cluster" at the first line of /etc/llttab.


Workaround Steps:
Symantec has provided a patch to resolve the above mentioned issues.


Usage:
1. Copy the hot-fix CPI_5.1SP1RP1_P3.pl to /tmp
2. Run installation scripts with the hot-fix
   Example:
   ./installrp -require /tmp/CPI_5.1SP1RP1_P3.pl
Read and accept Terms of Service