perl-sol_x64-5.1P1a

 Basic information
Release type: P-patch
Release date: 2012-10-12
OS update support: None
Technote: None
Documentation: None
Popularity: 406 viewed    52 downloaded
Download size: 14.83 KB
Checksum: 1280959000

 Applies to one or more of the following products:
VirtualStore 5.1 On Solaris 10 X64
VirtualStore 5.1SP1 On Solaris 10 X64
Cluster Server 5.1 On Solaris 10 X64
Cluster Server 5.1SP1 On Solaris 10 X64
Dynamic Multi-Pathing 5.1 On Solaris 10 X64
Dynamic Multi-Pathing 5.1SP1 On Solaris 10 X64
Storage Foundation 5.1 On Solaris 10 X64
Storage Foundation 5.1SP1 On Solaris 10 X64
Storage Foundation Cluster File System 5.1 On Solaris 10 X64
Storage Foundation Cluster File System 5.1SP1 On Solaris 10 X64
Storage Foundation for Oracle RAC 5.1 On Solaris 10 X64
Storage Foundation for Oracle RAC 5.1SP1 On Solaris 10 X64
Storage Foundation HA 5.1 On Solaris 10 X64
Storage Foundation HA 5.1SP1 On Solaris 10 X64

 Obsolete patches, incompatibilities, superseded patches, or other requirements:
None.

 Fixes the following incidents:
2941980

 Patch ID:
149701-01

Readme file
                          * * * READ ME * * *
                          * * * Perl 5.1 * * *
                         * * * P-patch 1 * * *
                         Patch Date: 2012-10-12


This document provides the following information:

   * PATCH NAME
   * PACKAGES AFFECTED BY THE PATCH
   * BASE PRODUCT VERSIONS FOR THE PATCH
   * OPERATING SYSTEMS SUPPORTED BY THE PATCH
   * INCIDENTS FIXED BY THE PATCH
   * INSTALLATION PRE-REQUISITES
   * INSTALLING THE PATCH
   * REMOVING THE PATCH


PATCH NAME
----------
Perl 5.1 P-patch 1


PACKAGES AFFECTED BY THE PATCH
------------------------------
VRTSperl


BASE PRODUCT VERSIONS FOR THE PATCH
-----------------------------------
   * Veritas Cluster Server 5.1
   * Veritas Storage Foundation for Oracle RAC 5.1
   * Veritas Storage Foundation Cluster File System 5.1
   * Veritas Storage Foundation 5.1
   * Veritas Storage Foundation High Availability 5.1
   * Veritas Dynamic Multi-Pathing 5.1
   * Symantec VirtualStore 5.1
   * Veritas Cluster Server 5.1SP1
   * Veritas Storage Foundation for Oracle RAC 5.1SP1
   * Veritas Storage Foundation Cluster File System 5.1SP1
   * Veritas Storage Foundation 5.1SP1
   * Veritas Storage Foundation High Availability 5.1SP1
   * Veritas Dynamic Multi-Pathing 5.1SP1
   * Symantec VirtualStore 5.1SP1   


OPERATING SYSTEMS SUPPORTED BY THE PATCH
----------------------------------------
Solaris 9 X64, Solaris 10 X64


INCIDENTS FIXED BY THE PATCH
----------------------------
This patch fixes the following Symantec incidents:

Patch ID: 149701-01

* 2941980 (Tracking ID: 2941980)

SYMPTOM:
iA flaw was reported in perl Digest module's "Digest->new()" function, which did not properly sanitize input before using it in an eval() call, which could possibly be exploited to inject and execute arbitrary perl code.

DESCRIPTION:
Eval injection in the Digest module before 1.17 for Perl allows context-dependent attackers to execute arbitrary commands via the new constructor.

RESOLUTION:
Source change


INSTALLING THE PATCH
--------------------
patchadd 149701-01


REMOVING THE PATCH
------------------
patchrm 149701-01


SPECIAL INSTRUCTIONS
--------------------
NONE


OTHERS
------
NONE
Read and accept Terms of Service