This page lists publically-released patches for Veritas Enterprise Products.
For Product GA build, see Veritas Entitlement Management System(VEMS) by clicking the Veritas Support 'Licensing' option.
For information on private patches, contact Veritas Technical Support.
For NetBackup Enterprise Server and NetBackup Server patches, see the NetBackup Downloads.
Patches for your product can have a variety of names. These names are based on product, component, or package names. For more information on patch naming conventions and the relationship between products, components, and packages, see the SORT online help.
4.0.4.21(AxRT 4.0 MP4RP2HF1 - vxio binary alone)
Obsolete
The latest patch(es) : 4.0MP4RP4 VRTSvxvm 
Sign in if you want to rate this patch.

 Basic information
Release type: Hot Fix
Release date: 2007-06-29
OS update support: None
Technote: None
Documentation: None
Popularity: 1198 viewed    9 downloaded
Download size: 6.05 MB
Checksum: 3779337651

 Applies to one or more of the following products:
Storage Foundation 4.0MP4 On AIX 5.2
Storage Foundation 4.0MP4 On AIX 5.3
Storage Foundation for DB2 4.0MP4 On AIX 5.2
Storage Foundation for DB2 4.0MP4 On AIX 5.3
Storage Foundation for Oracle 4.0MP4 On AIX 5.2
Storage Foundation for Oracle 4.0MP4 On AIX 5.3
Storage Foundation HA 4.0MP4 On AIX 5.2
Storage Foundation HA 4.0MP4 On AIX 5.3
Volume Manager 4.0MP4 On AIX 5.2
Volume Manager 4.0MP4 On AIX 5.3
Volume Replicator 4.0MP4 On AIX 5.2
Volume Replicator 4.0MP4 On AIX 5.3

 Obsolete patches, incompatibilities, superseded patches, or other requirements:

This patch is obsolete. It is superseded by: Release date
4.0MP4RP4 VRTSvxvm 2008-06-06
4.0MP4RP3 (obsolete) 2007-09-10
4.0.4.23(AxRT 4.0 MP4RP2HF3) (obsolete) 2007-07-18
4.0.4.22(AxRT 4.0 MP4RP2HF2) (obsolete) 2007-07-04

This patch supersedes the following patches: Release date
4.0MP4RP2 (obsolete) 2007-06-27
4.0.4.2(AxRT 4.0 MP4RP1HF1) (obsolete) 2007-04-27
4.0MP4RP1 (obsolete) 2007-02-26

 Fixes the following incidents:
1075037

 Patch ID:
VRTSvxvm-04.00.0004.0021

 Readme file  [Save As...]
                Volume Manager 4.0.4.21 (Rolling-Patch_2 HotFiX-1)
                ========================================

Patch Information:
==================

Date:           29nt Jun 2007
AIX Release:    AIX 5.2 /AIX 5.3
Product:        VERITAS Volume Manager
Release:        VxVM 4.0
Fileset:        VRTSvxvm
Fileset level:  VxVM 4.0.4.21
Description:    VERITAS Volume Manager (VxVM) 4.0MP4 + Rolling-Patch_2 HotFiX-1.


Pre-requisites:
===============

1. VxVM release level 4.0.4.0 (minimum)
2. AIX release level 5.2 TL8 and above (minimum)
3. AIX release level 5.3 TL5 Plus Service Pack 1 and above (minimum)

Support for AIX 5.1 is not available for this release.

Software patch for the VERITAS volume Manager(VxVM) to install over the VRTSvxvm fileset.

Binaries included in this Rolling patch2 HotFix-1:
======================================
./usr/lib/drivers/vxio.5.1
./usr/lib/drivers/vxio.5.2
./usr/lib/drivers/vxio.5.3


Installation Procedure:
=======================

If the currently installed VRTSvxvm is below 4.0.4.0 level, you
must upgrade VRTSvxvm to 4.0.4.0 level before installing this patch.

AIX maintenance levels and APARs can be downloaded from the
IBM web site:

        http://techsupport.services.ibm.com


1. Since the patch process will configure the new kernel extensions,
ensure that no VxVM volumes are in use or open or mounted before
starting the installation procedure

2. Use the installp or Smit to install the patch image.

   Using installp:

   0. Before applying this patch, please kill the vxsvc process:

        /opt/VRTSob/bin/vxsvcctrl stop

   1. To apply this patch, use following command.

        installp -ag -d ./VRTSvxvm.04.00.0004.0021.bff VRTSvxvm

   2. To apply and commit this patch, use following command

        installp -acg -d ./VRTSvxvm.04.00.0004.0021.bff VRTSvxvm

   NOTE: Please refer installp(1M) man page for clear understanding
   on APPLY & COMMIT state of the package/patch.

   Using Smit:

        Software Installation and Maintenance ->
        Install and Update Software ->
        Update Installed Software to Latest Level

   3. Reboot the system after the installation is complete.


Deinstallation Procedure:
=========================

If patch installation is in "APPLY" state, patch image can be rejected
or deinstalled. For rejecting the patch image, please use following
command

     installp -r -V 4.0.4.21 VRTSvxvm

This command will reject/deinstall the VRTSvxvm 4.0.4.21 (MP4 RP2 HF1) patch.
Patch contents cannot be rejected/deinstalled if it is in COMMITed state.
Note that rejecting the patch will stop the vxconfigd(1M) (VxVM configuration
Daemon). Please start vxconfigd manually or reboot the system.

NOTE: Please refer SF 4.0 Installation Guide for AIX minimum level
requirements.



Incidents fixed in this patch (entire list):
============================================
1) Incident e1075037:
        VVR: RU thread should start nio after it is created
        from than waiting for all replicas to have NIO"s created.




Read and accept Terms of Service