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Chapter
 1
Introducing the

VEA console

The Veritas Enterprise Administrator (VEA) Console displays data about 

application objects and connectivity in graphical form and provides a user 

interface for the many tools and functions.

Before using the VEA GUI, you should familiarize yourself with the following 

introductory topics:

■ VEA features

■ VEA home page

■ Main window

VEA  features
You use the VEA  to administer disks, volumes, and file systems on local or 

remote machines.

VEA  consists of a server and a client. The server runs on a machine that is 

running the application to be monitored, such as VxVM. The client runs on 

Windows, HP, Linux, Solaris, and AIX machines that support the Java Runtime 

Environment.

VEA  provides the following features:

■ Accessibility - Using the Mouse and Keyboard

Accelerators and mnemonics are provided as alternatives to using the 

mouse (refer to the VEA online help for more information).

■ Ease of Use 

The task-based user interface provides access to tasks through menus or a 

task list. Administrators can easily navigate and configure their systems, 
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VEA features
and browse through all of the objects on the system or view detailed 

information about a specific object. 

■ Remote Administration 

Administrators can perform administration remotely or locally. The VEA 

client runs on UNIX, Linux, or Windows machines.

■ Java-based Interface 

A pure Java-based interface is used. Administrators can run VEA  as a Java 

application. 

■ Scalability

■ VEA  can handle systems containing large numbers of disks. Administrators 

can view all of the objects on the system, or focus on a specific object or set 

of objects.

■ Security

Please refer to the VEA online help for information on communication 

between the client and server across a firewall.

■ Multiple VEA Support 

The VEA  client can provide simultaneous access to multiple host machines. 

The administrator can use a single client session to connect to multiple 

hosts, view the objects on each host, and perform administrative tasks on 

each host. Each host machine must be running the VEA  server.

■ Multiple Views of Objects

VEA  provides multiple views of objects:

■ The main window tree and grid view lists objects on the system. 

Other views are application dependent. For example, when running VxVM:

■ The Disk View window displays a graphical view of volumes, disks, and 

other objects in a disk group. 

■ The Volume View window displays a graphical view of the volumes on a 

host. 

■ The Volume to Disk Mapping window shows the relationships between 

volumes and their underlying disks.
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VEA home page
VEA home page 
The VEA home page is the first screen displayed when you invoke the VEA.

Figure 1-1 VEA home page and Assistant

The toolbar shows icons:

■ Connect - to make a connection to a VEA-enabled host.

■ Disconnect - to disconnect from a host.

■ New Window - to open a new window

Using Assistant, you can browse the most significant and important tasks:

■ Connect to a Host or Domain - see “Connecting and disconnecting hosts and 

domains” on page 28

■ View or Edit VEA Preferences - see “Setting VEA preferences” on page 19

■ Manage User Profiles - see “Managing user profiles” on page 34

■ View Online Help
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Main window
Main window 
Once you are connected to a host, the VEA Main Window is displayed. This 

consists of:

■ Quick access bar

■ Object tree and grid

■ Menu bar

■ Toolbar

■ Status area

Figure 1-2 Main window

The toolbar can be separated from, and reattached to, the main window (this is 

known as docking). The grid can be replicated in a separate window.

Quick access bar
The quick access bar provides quick access to perspectives using the following 

icons:

■ System

■ Assistant
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Main window
■ Logs

■ Control Panel

Object tree and grid
The VEA  main window is divided into two main panes:

■ Left Pane (Object Tree)

■ Right Pane (Grid)

Object Tree

Any host machines connected to the current VEA  client session typically appear 

as nodes in the object tree..

Grid

The right pane contains a grid, which is a tabular display of objects and their 

properties. The grid displays objects that belong to the group icon that is 

currently selected in the object tree (left pane).

The splitter is the vertical bar that separates the object tree from the grid. You 

can resize the left and right panes by pressing and holding the mouse button 

over the splitter and dragging the splitter to the left or right. 

Menu bar
The menu bar at the top of the main window contains the following menus: 

■ File 

The File menu establishes new host connections, disconnects current host 

sessions, provides access to an object Properties window, handles page 

setup, executes print and print preview functions, or exits VEA. 

■ Tools 

The Tools menu allows you to:

■ Initiate the setting Preferences dialog

■ Manage User Profiles

■ Maintain the VEA Error Console

■ Actions

The Actions menu is a context-sensitive menu that launches tasks on a 

selected object. It is inactive until you connect to a host. When an object is 

selected, the Actions menu provides access to tasks appropriate for the 

selected object. 
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Main window
Note: If any DCLI operations are performed, in order for the changes to be 

reflected in the GUI, an Actions->Rescan operation must be performed.

■ View

The View menu enables you to select the view displayed on the VEA console:

■ Select Connection to switch between connected hosts.

■ Selecting Perspective allows you to choose the display mode (System, 

Assistant, and so on).

■ Select Home to return to the Home page.

■ Window

The Window menu gives you access to the Tear off feature. This allows you 

to copy views displayed by the VEA Client into new windows. You can then 

view details of several different object types at the same time, and to 

correlate relationships between them.

Then select the view to be displayed in a new window from the drop-down 

menu.

■ Help 

The Help menu provides access to online help for VEA.

Toolbar
The toolbar provides quick access for performing some of the program’s most 

common tasks.

The toolbar handle is the thin bar next to the toolbar. You can use the toolbar 

handle to separate the toolbar from the main window or move the toolbar to the 

bottom, side, or top of the main window. To reposition the toolbar, press and 

hold the mouse button over the toolbar handle and drag the toolbar to its new 

location. 

Note: The toolbar handle is not visible when running on UNIX clients.

Status area 
The status area is at the bottom of the main window. It includes the Console 

View and Task View.
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Multiple selections
Console View

When a host is selected, you can click on Console to bring up the Console View. 

This displays the most recent messages for the host. When a message is 

selected, additional information about that message is displayed.

You can also double-click on a selected message to display message properties in 

the Console Message Details dialog.

Select Configure this view to bring up the Preferences dialog, if you want to 

change the buffer and filter settings.

Tasks View

Click on Tasks to bring up the Task View. This displays information about the 

current tasks.

Multiple selections
You can select more than one object from a list (for example, when you need to 

add several disks into a disk group) using the SHIFT and CONTROL keys in 

conjunction with the left mouse button.

Use the SHIFT key to select a range of objects.

Use the CONTROL key to select individual objects.

Accessing tasks
Most VEA tasks are performed by selecting objects and/or tasks and then 

completing the resulting dialog boxes. With VEA, you can access tasks from the 

menu bar and from a context-sensitive popup menu.

For a selected task, you can use the popup menu options: Abort Task to cancel 

the task; Pause Task to temporarily stop a task, Resume Task to continue the 

task; and Throttle Task to throttle a task. 

Task throttling
Task Throttling causes an operation to pause for the allowed amount of time 

whenever a disk I/O is performed, allowing the CPU and disks to perform other 

tasks.

Select the popup menu option Throttle Task to change the task priority. You can 

change the priority for a single task, or select Throttle All Tasks to apply the 

priority to all Volume Manager Tasks. Click Ok to complete your selection.
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Opening a new window
Clearing finished tasks
Tasks are persistent in the Tasks console. To remove completed tasks from the 

window, select Clear All Finished Tasks from the popup menu.

Viewing task properties
To view task properties and the low-level commands used to perform a task, 

select the task and choose Properties from the popup menu. 

Opening a new window
At any time, you can open a new window and replicate the window currently 

displayed by selecting the New Window icon. 

Alternatively, you can select:

File > New Window



Chapter
 2
Using the VEA

The Veritas Enterprise Administrator (VEA) enables you to access all hosts on 

your network. It also provides task and setup functions that allow you to tailor 

your VEA environment prior to performing storage management procedures on 

those hosts.

This chapter introduces you to:

■ Setting up your system

■ Starting VEA

■ Managing user profiles

■ Setting VEA preferences

■ Viewing objects and object properties

■ Performing tasks

■ Running tasks from the menu bar

■ Running tasks from a popup menu

■ Running tasks from the Task Assistant

■ Using the Control Panel

■ Viewing the Alert Log

■ Viewing the Task Log

■ Connecting and disconnecting hosts and domains

■ Viewing different products

■ Printing views

■ Exiting the VEA client
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Setting up your system
Setting up your system
VEA consists of a server (vxsvc) and a client (vea). You must install and run the 

VEA server on a UNIX machine running VxVM. You can install and run the VEA 

client on any Windows, HP, Linux, Solaris, or AIX machine that supports the 

Java Runtime Environment. 

Before you can use VEA, you need to:

1 Install VxVM on the machine to be administered. 

2 Install the VEA server and client on the machine to be administered. 

3 If users other than root need to access VEA, set up security to specify which 

users can run VEA. 

4 If you plan to run the VEA client from a machine other than the machine to 

be administered, install the VEA client on the machine where the client will 

run.

5 Start the VEA server on the machine to be administered. 

6 Start the VEA client.

Refer to the Installation manuals for your products for details on how to install 

and set up your products and VEA.

Starting VEA
Only users with appropriate privileges can run VEA. (Refer to the Installation 

manuals for your products for information on security and access permissions.)

You can use VEA to administer the local machine or a remote machine. The 

VxVM daemon (vxconfigd) and the VEA server (vxsvc) must be running on the 

machine to be administered. Once VEA is installed, the VEA server starts up 

automatically at system startup. 

You can start the VEA console from a Windows or UNIX client.

From a Windows client
From a Windows client, you can start VEA from the Start menu, or from the 

command line.

Using the Start menu

To invoke VEA from the Start menu, click on:

Start > Programs > Veritas Enterprise Administrator > 

Veritas Enterprise Administrator Console
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Starting VEA
Using the command line

To invoke VEA from the command line:

1 Go to the directory where the VEA client is installed, for example:

Object Bus\bin 

2 Start the VEA client by running the batch file vea.bat from this location.

When starting the VEA client from the command line, the following options 

are available

-v Shows the version of client console.

-c Specifies the configuration file for advanced settings.

-host Specifies the host to connect to. If the username and password 

for the host is already stored, these will be used; otherwise, 

you will be prompted for your username and password.

From a UNIX client
To invoke VEA from the command line:

1 Go to the directory where VEA client is installed, for example:

/opt/VRTSob/bin

2 Start the VEA client by running the script vea from this location.

When starting the VEA client from the command line, the following options 

are available

-v Shows the version of client console.

-c Specifies the configuration file for advanced settings.

-host Specifies the host to connect to. If the username and password 

for the host is already stored, these will be used; otherwise, 

you will be prompted for your username and password.

Startup profile
If you have selected a password protected profile as your startup profile, you are 

prompted to enter the password when VEA starts up. 

Enter your password and click OK to continue, or click Select Profile to bring up 

the Select Profile dialog, which enables you to select an alternative profile.

(Clicking Cancel will end the application.)
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Starting VEA
Selecting an alternate profile

Select one of the profiles from the list, and enter the password, if necessary.

Click OK to log in. 

You can also select Tools > Manage Profiles to bring up the Manage Profiles 

dialog (refer to Managing user profiles). 

If no profiles exist

If no profiles exist when you start VEA, the following message appears:

No profiles exist on this system. A new default profile has been 
created. If you want to create additional profiles, you may 
create using the “Tools” -> “Manage Profiles...” menu item

Click OK to continue. 

You can also select Tools > Manage Profiles to bring up the Manage Profiles 

dialog (refer to Managing user profiles). 
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Setting VEA preferences
Setting VEA preferences
You can set up your own individual preferences for running VEA using the VEA 

preferences feature. This offers the following selections:

■ Connection - “Setting connection preferences” on page 19

■ Advanced - “Setting advanced preferences” on page 21

■ General - “Setting general preferences” on page 20

■ Language - “Setting language preference” on page 21

■ Security - “Setting user accounts” on page 22

■ Console View - “Setting the console view” on page 21

To set preferences, you can either:

■ Select Tools > Preferences. 

or

■ Use the VEA Assistant feature, View or Edit VEA Preferences.

The Preferences window appears. Select your preferences, then, when you have 

made your selection:

■ Press Apply to apply the selection. 

■ Press Reset to revert back to the original settings in effect before you opened 

the Preferences window.

■ Press OK to apply and close the Preference Window.

■ Press Cancel to discard the changes and close the Preference Window.

Note: You need to restart the GUI for the change to take effect.

Setting connection preferences
The Connection tab allows you to set connection preferences.

Adding and removing favorite hosts

Favorites displays a list of hosts that will be connected to by default at the 

startup of VEA if the username/password is saved for them. If the username /

password is not saved for a particular host, then this information will be 

prompted for at the time of connection

Use the following procedure to add a host to Favorite Hosts:

1 Right click on any of the connected host nodes
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Setting VEA preferences
2 Choose Add to Favorites from the popup menu. 

Removing a host from favorite hosts

Use the following proedure to remove a host from Favorites:

1 In the Preferences Favorites window, highlight the host to be removed.

2 Click on Remove. 

Reconnecting hosts

By default, hosts under the Favorites are reconnected when logging on. 

(Reconnect At Logon is set to Yes). 

You can avoid a host being reconnected at startup by setting Reconnect At 

Logon to No. 

Adjusting the history settings

To adjust the history settings, type the number of servers (hosts) for which 

information can be stored in the history file under Maximum Connections 

(default value is 10)

The maximum limit for the number of hosts for which information can be stored 

is 99.

Press Apply to apply the changes, Reset to revert back the changes, OK to apply 

and close the Preference window, Cancel to discard and close the Preference 

window.

Setting general preferences
The General tab allows you to set display and connection properties.

Setting display properties

You can set the display properties for the Toolbar and Perspective Bar icons.

Icon text properties can be set to:

■ No text - select Icons.

■ Text displayed above, below, to the right, or left - select Icons with Text, 

then, select the position using the drop-down menu.

Setting connection properties

You can use the Switch focus to new host on connection checkbox to enable or 

disable changing perspective when connecting to a new host.
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Setting VEA preferences
Setting advanced preferences
The Advanced tab displays the allows you to set the action for temporary files, 

and to reset preference settings.

Deleting temporary files on exit

You can delete all temporary files when you leave VEA by selecting the checkbox 

Delete temporary files on exit.

If you want to delete the temporary files immediately, click the button Delete 

Now.

Restoring default values

Select Restore Defaults to restore application and system default values.

Setting language preference
To set your language preference, select the Language tab. You can then set your 

preferred language to one of the languages supported by VEA and available on 

your machine. Selections may include:

■ English (United Kingdom)

■ French (France)

■ Japanese (Japan)

■ Korean (South Korea)

■ Chinese (China)

■ Chinese (Taiwan)

■ English (United States) 

Setting the console view
The Console View tab allows you to set:

■ Maximum number of unfiltered messages

■ Filters

Number of unfiltered messages

The Message Buffer value enables you to set a limit on the number of unfiltered 

messages held in the Console View buffer. By default, the number of unfiltered 

messages held in the buffer is set to 50. Use Enter Limit to modify the limit.
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Viewing objects and object properties
When the limit is reached, messages are discarded, starting at the oldest 

message.

Filter messages

You can filter messages in the Console View by selecting the Activate Filter 

checkbox. Only messages that meet all the defined criteria (Severity, Source, 

and Classification) will be displayed. Criteria can be defined as:

■ Severity - Select one or more of:

■ Critical - Indicating an event of high importance, such as system crash, 

or irrecoverable loss of data.

■ Warning - Indicating a recoverable error, with no data loss

■ Error - Indicating loss of functionality of data.

■ Information - Indicating an informational event.

■ Source - Defines the host, or hosts, providing the source of the messages. 

(Host names must be separated by commas.) 

■ Classification - The type, or types, of message. (Types be separated by 

commas.) 

Setting user accounts
User account information includes details about user ids., domains, and 

passwords. You can remove a user account, or set it to be the default account to 

be used for all connections.

Security settings allow you to validate authentication brokers.

Viewing objects and object properties 
Objects in the system are displayed in the Main Window and Tabular View 

shown in “Main window” on page 10 . The tree is a hierarchical display of object 

groups. The Tabular View displays a table of objects and a limited set of 

properties. 

In the VEA client, objects typically represent entities in the product domain.  

For example, in the case of Veritas Volume Manager, the object might be a disk.  

You can use the views to browse objects and guide the operation of the client 

console. 

There are four main views:

■ Navigation View, at the left, which uses the tree structure

■ Detailed View, at the right, which used table structure
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Viewing objects and object properties
■ Console View, at the bottom

■ Tasks View, at the bottom

The following functions are provided for simplifying viewing objects in the tree 

and Tabular View:

■ To expand or collapse the hierarchy under a particular object group node in 

the tree: 

Click on the plus sign (+) or minus sign (-) icon next to that node. 

■ To display the objects in an object group listed in the object tree: 

Click on the object group. All objects that belong to the selected object group 

appear in Tabular View. 

■ To display the objects in an object group listed in Tabular View: 

Double-click on the object group. All objects that belong to the object group 

appear in Tabular View.

(Double-clicking on an object that does not contain other objects (children) 

displays the Properties window for the object instead of its children.)

■ To sort the objects in Tabular View by a specific property: 

Click on the appropriate property column heading. To reverse the sort order, 

click on the column heading again. 

■ To resize a grid column: 

Place the pointer over the line that divides the column headings, then press 

and hold the mouse button to drag the column divider to the desired 

position. 

■ To resize the left pane (tree) and right pane (Tabular View): 

Place the pointer over the vertical splitter, then press and hold the mouse 

button to drag the splitter to the desired position. 

Selecting objects
You can select Tabular View objects in most VEA windows using the following 

procedures: 

■ To select a single object: 

Click on the object. 

■ To select multiple objects: 

Hold down the Control key while selecting the objects. The objects that you 

select in this way do not have to be adjacent.

■ To select a range of adjacent objects: 

Select the first object, then hold down the Shift key while selecting the last 

object in the range. You can also select multiple adjacent objects by pressing 
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Viewing objects and object properties
and holding the mouse button while dragging the pointer over the desired 

objects.

Navigational View
Navigational View supports object browsing and operations on those objects in a 

tree structure. The following nodes typically appear in this view:

■ System nodes: representing the connected and disconnected computer 

systems, these are distinguished by icons.

■ Network nodes: listing the systems that are currently running on the given 

domain.

■ History nodes: listing the most recently connected servers.

■ Favorite Hosts nodes: listing hosts that will be connected by default at start 

up.

The system objects are arranged in containers called group nodes. Group nodes 

can contain homogenous or heterogeneous types of objects. You can view 

detailed information about these objects in the Details View by selecting the 

object in the Navigational View.
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Viewing objects and object properties
Details View
The Details View (Figure 2-1) gives a tabular representation of the objects in a 

particular group node, or even a single object, depending upon the selection in 

the Navigational View.

Figure 2-1 Details View

Console View
The Console View displays the active events and alerts for the connected hosts. 

Click on Console to display the events that have been received by the client 

during the user session. The events for all hosts over the lifetime of the session 

is displayed.

Note: Events on the server side are recorded on the server.

Tasks View
The Tasks View displays the start time of the task along with the object name for 

which the task was fired.

You view the Task Log to obtain historical task information (see “Viewing the 

Task Log” on page 33).
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Performing tasks
Properties of an object
Each property has the following attributes:

A property set is a collection of properties. It can contain an array of properties 

or even another property set as its element. A property set with one or more 

property sets contained within it is called a recursive property set.

VEA uses Tabular View to display the properties of an object. Each object is 

represented by a row in the table and the properties are the column cells in it.

Performing tasks
Most VEA tasks are performed by selecting objects and/or tasks and then 

completing the resulting dialog boxes. You can run tasks from the following:

■ Menu bar

■ Context-sensitive popup menu

■ VEA Task Assistant

Running tasks from the menu bar 
Once you have connected to a host, you can launch tasks from the Actions menu 

in the main window menu bar. The context-sensitive Actions menu launches 

tasks on a selected object. The Actions menu is dynamic and changes its options 

based on the type of object that is selected in the tree or grid. 

To perform a task on an object with the Actions menu, select the object and 

choose the appropriate task from the Actions menu. If this launches a dialog box 

or wizard, complete the dialog box (or wizard). 

Table 2-1 Property attributes

Property type Definition

Type Defines the property value; for example, boolean, integer with 

varied size, and string.

Flags Determines one of the characteristics of the property (for 

example, Hidden or Displayable).

Name Identification given to the property.

Value Value assigned to property, depending upon the type.
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Performing tasks
Running tasks from a popup menu 
Once you have connected to a host, you can use a context-sensitive popup menu 

to launch a task on the selected object. A popup menu provides access to tasks or 

options appropriate for the selected object. Popup menus are available in the 

main window and most other windows.

◆ To perform a task on an object with the popup menu, right-click on the 

object and choose the appropriate task in the popup menu. If this launches a 

dialog box or wizard, complete the dialog box (or wizard). 

Running tasks from the Task Assistant 
Once you have connected to a host, you can use the VEA Task Assistant to 

launch a task on a selected object and activity, as shown in Figure 2-2. 

Figure 2-2 VEA Task Assistant
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Connecting and disconnecting hosts and domains
Connecting and disconnecting hosts and domains
The system host typically has multiple Symantec products installed on it. To be 

able to use the products, client console needs to connect to the system through 

an authentication channel.

VEA can access and display multiple host machines simultaneously. 

■ Connecting to a host or domain

■ Logon authentication

■ Disconnecting from a host

■ Switching between connected hosts‘

Connecting to a host or domain
You can first connect to a system host by:

■ Using the VEA Assistant

■ Clicking on File --> Connect

■ Clicking on the Connect tool bar icon

The Connect dialog box is then displayed. You can now:

■ Click Browse, to select a Favorite host

■ Supply the data in the following fields and then click OK: 

Hostname— 

Select from the drop-down list; or type the name, IP address, or 

qualified domain name for Server host.

■ Check one of the following:

■ Connect Using: 

Displays the default user account, if one has been set.

■ Connect using a different user account

Note: The login credentials for the host are identical to the Server host root 

credentials, root and its password. See your system administrator for more 

information.

■ Supply the password when prompted. Type the password for the root 

account on the Server. Select the Remember Password box to save the 

password on your computer.

You are now connected to your host.
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Connecting and disconnecting hosts and domains
Note: Entries for the user name and password must exist in the password file or 

corresponding Network Information Name Service (NIS) table on the machine to 

be administered.

Logon authentication
There are three authentication mechanisms by which a connection can be 

established with the server.

■ Silent Logon (Windows platforms only): This happens when the server is 

local; that is, the VEA client and server both are running on the same 

machine. If the user has logged on with administrator privileges, then 

username and password are not required. (The basic connection dialog box 

is used.)

■ Native Logon: Username and password are required to authenticate the user. 

(The expanded connection dialog box is used.)

■ DCOM authentication (Windows platforms only): If the user has logged in as 

administrator on the domain, then username and password are not required 

to authenticate the user (the basic connection box is expanded after 

entering the server name and clicking OK), and the user is connected to the 

server. The server needs to be started with administrator privileges for this 

type of authentication. 

If the user does not have administrator privileges, then the connection 

takes place using the Native Logon mechanism. 

Disconnecting from a host 
The Disconnect procedure disconnects a host machine from the current VEA 

session. When a host machine is disconnected, VEA cannot administer that 

machine until a new connection is made. 

1 Right-click the computer icon to be disconnected.

2 Select Disconnect from the file menu on the menu bar.

3 A confirmation dialog will appear, click Yes to end the remote connection.

4 The computer icon disappears from the left tree view.

If the connection is lost for any other reason, a message appears that indicates 

the connection has been terminated, and the icon for that computer is removed 

from the left tree view. You need to click OK to close the message box. 

To restore access to a disconnected host machine, you must reconnect to the 

host.
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Exiting the VEA client
Switching between connected hosts‘

You can switch the VEA console display between connected hosts:

■ Select View > Connection. 

■ Select the host to be displayed from the list of connected hosts displayed.

The display changes to show information for the selected host.

Exiting the VEA client
To exit the VEA client, choose File > Exit. 

It is also possible to close the client by using the close button available at the top 

right of the window.

Viewing different products
VEA allows you to simultaneously access several products on different systems, 

and to view each product in the language of the VEA client, if available.

For example, if you connect from a VEA client, displaying French text, to Veritas 

Volume Manager running on a remote Solaris system also displaying French, 

you will see French text in the VEA client window. If you now connect the same 

VEA client (displaying French text) to SAN Appliance running on a remote Linux 

system, displaying English text then, if the SAN Appliance is available in French, 

the VEA client displays everything in French. If the SAN Appliance is available 

only in English, then the SAN Appliance information will be displayed in English 

on the VEA client.

Using the Control Panel
Use the Control Panel to view and modify application settings. Selecting the 

Control Panel will bring up the Control Panel view in the right hand pane.
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Viewing the Alert Log
Figure 2-3 Control Panel

Viewing the Alert Log
The alert log resides on the server, and records information such as alerts 

raised, about the server. 

After connecting to the host (server), you can display a snapshot of the log 

information by clicking on Logs then the Alert Log tab. 

The server can have single or multiple alert log files, depending upon the policy. 

If the server has more than one alert log file, then a drop down box is displayed 

from which you select the required log file. 

The alert information is displayed in the Details View. Up to 25 alerts can be 

displayed in a set.
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Viewing the Alert Log
Figure 2-4 Alert Log

Previous and next alert sets
The Previous and Next set of alerts buttons are situated below the Details View.

You can display the next set of alerts by clicking the “Next set of Alerts” button. 

The current set of alerts is then replaced with the next set of alerts. If there are 

no more alerts in the event log, the current set continues to be shown.

You can display the previous set of alerts by clicking the “Previous set of Alerts” 

button. The current set of alerts is then replaced with the previous set of alerts. 

When the first set is reached, and there are no more old alerts, the “Previous set 

of Alerts” button is disabled.

Viewing alert details
You can view the details for particular alert by selecting the alert and double-

clicking on the alert. A new window opens up to show the alert details.
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Viewing the Task Log
Figure 2-5 Alert Details

Viewing the Task Log 
The task log resides on the server, and is similar to the event log; but records 

information about task objects. You can display a snapshot of the task log 

information on the client.

After connecting to the host (server), you display the task log of the server by 

selecting the “TaskLog” node under “Logs” in the tree view. The server can have 

single or multiple task log files, depending upon the policy. If the server has 

more than one task log file, then a drop down box is displayed from which you 

select the required log file. 

The client gets the latest set of tasks from the log file of the server and displays 

the information in the Details View. Up to 25 tasks can be displayed in a set. 

Previous and next task sets
The Previous and Next set of tasks buttons are situated below the Details View.

You can display the next set of tasks by clicking the “Next set of Tasks” button. 

The current set of tasks is then replaced with the next set of tasks. If there are 

no more tasks in the task log, the current set continues to be shown.

You can display the previous set of tasks by clicking the “Previous set of Tasks” 

button. The current set of tasks is then replaced with the previous set of tasks. 

When the first set is reached, and there are no more old tasks, the “Previous set 

of Tasks” button is disabled.
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Configuring logs
Task details
You can view the details for particular task. Select the task and click on 

“Details.” A new window opens up to show the task details.

Configuring logs
You can configure the server task and alert logs from the client:

1 Select the “control panel” node in the tree view. The details view appears, 

listing all the configuration applications. 

2 Launch the “Log Settings” configuration application by double clicking on it.

You can set the maximum log size from 10KB to 2MB. The default log size is 

500KB. 

Printing views
You can print some of the Views in the right pane by clicking File >Print.

Print functionality is determined by the server, which means that the Print and 

Page Setup functions appear only when the VEA installed on the server 

supports printing. This also means that Page Setup may be shown as disabled, 

even when the Print function is available.

The complete View is printed, including any information which may be scrolled 

off the screen. If there is more than one tab for the displayed View, then only 

information relevant to the displayed tab is printed.

Managing user profiles
The user profile feature enables individual users running VEA on the same 

machine to maintain their own preferences, connection history and favorites 

information.

To use the user profile feature, select Tools > Manage Profiles. The Manage 

Profiles dialog appears. This allows you to:

■ Set a profile to be used when starting VEA (Selecting a startup profile)

■ Create a new profile (Creating a new profile)

■ Change your password (Changing your password)

■ Delete a profile (Deleting a profile)
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Managing user profiles
Figure 2-6 User Profiles

Selecting a startup profile
A default startup profile (Default) is created by VEA when it is invoked by the 

first time. The Default profile is particularly useful when VEA is being used in a 

single user environment, in which case, you can use the Default profile rather 

than creating additional profiles.

You cannot delete or modify the Default profile, and it is not password 

protected. 

You also have the option of selecting your own startup profile (in Startup 

using:). Alternatively, you can choose to be asked at each logon, which profile to 

use.

Creating a new profile
Select the New button to create a new profile. This brings up the New Profile 

dialog.

You then enter the desired name for the profile. The following characters are 

not allowed in the profile name:

“ ~!@#$%^&*()=+-[]{}\\|’\”;:.,<>/?`”

You can also choose to employ a password.
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Firewall support
Note: You must remember this password, for there is no way of retrieving a lost 

password, and the profile cannot then be deleted at a later stage. (A blank 

password or a password consisting of spaces alone will not be considered for a 

password, and the profile will be marked as not having a password.)

Changing your password
Select the profile, and then click Edit to change the password for the profile. 

This brings up the Edit Profile dialog.

You will need to know the current password in order to change your password.

Deleting a profile
Select the profile, and then click Delete to delete a profile. You are then 

prompted to confirm the deletion of the profile.

If the selected profile is password protected, you are then prompted to enter the 

password.

Firewall support
In VEA, the client connects to the server using a specific port number: 2148. In 

order to connect to the server through a firewall, a port on the firewall is 

mapped to the 2148 port of the VEA server. 

When the client wishes to connect to the server through the firewall, it needs to 

specify the host and port in the following format.

Firewallhost:port 

where: 

Firewallhost is the name or IP address of the firewall.

port is the port on the firewall that is internally mapped to the VEA server. 

When the client connects to the server, the VEA client displays the host name 

(server name) that it connected to, and not the firewall-port combination in the 

list of connected hosts. The host name is also displayed in the history and 

favorites nodes. The firewall and port information is stored in the user profile 

(wallet) and is used for subsequent connections to the same server. The firewall-

port combination is displayed only in the connection dialog. 
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Firewall support
Example 1
If a.b.c.d is a firewall machine, then:

Port 1234 on a.b.c.d = 2148 on veaserver1, and 

Port 3456 on a.b.c.d = 2148 on veaserver2 

...

and so on.

Now, if the client wishes to connect to veaserver1 then, it should specify the 

following in the connection box:

a.b.c.d:1234

This then connects to veaserver1 and displays veaserver1 in the connected 

hosts, history and favorites databases. The firewall:port combination is stored in 

the wallet for subsequent connection to the server if requested by the user.

Example 2
client ---> Internet ---> firewall ---> server

and

client ---> firewall ---> server

We need to do the following:

1 Allow for an alias of port 2148 on server A to be a particular port on the 

firewall machine.

2 Let Pf be the port on the firewall machine F which is an alias for port 2148 

on server A.

3 Connect using the GUI to port Pf on F. You are actually managing server A

Note: VEA uses Anonymous Deffie Hellman key exchange and is therefore 

vulnerable to the man-in-the-middle attack. Therefore it is recommended that 

SSH or some kind of tunnelling software be used if going across the internet. If 

SSH is used set up port forwarding from client to firewall port Pf and use SSH to 

tunnel.
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Firewall support
Example 3
For the case where 2148 is forwarded through the firewall (punch through):

1 Let machines A and B be the servers on the secure side of the firewall.

2 Let client be on the internet/intranet side

client ---> firewall ---> A|B

3 Configure TCP/IP routing on the client such that packets destined for A|B 

are routed to firewall F.

4 Add A and B to /etc/hosts (or equivalent) for name resolution if required.

5 Connect to A or B or both machines (depending on which are to be managed). 
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 3
Accessibility

Accessibility is enhanced by the use of:

■ Keyboard shortcuts

■ Dialog boxes

Keyboard shortcuts
Keyboard shortcuts are possible using accelerators and mnemonics.

Accelerators
Accelerators are key combinations that provide shortcut access to GUI 

functions. They allow you to use a computer from the keyboard, rather than 

using the mouse. Accelerators are sometimes a quicker way of getting to a 

command, especially for the experienced user or a user who is disabled and is 

unable to manipulate a mouse or to press more than one key at the same time. 

Accelerator keys are either a single keystroke or two or more keystrokes that 

can be pressed in succession (rather than holding them simultaneously). Some 

users are unable to use a mouse, and some users prefer to use the keyboard 

rather than a mouse. 
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Keyboard shortcuts
Mnemonics
Mnemonics are single key strokes, used to activate components such as menu 

items. A single mnemonic is equivalent to a mouse click. A mnemonic can be 

used to select a menu item by pressing the <Alt> key to go into menu pull-down 

mode, pressing a single key to open a menu and another key to select a menu 

item. For example:

■ <Alt> to go into menu pull-down mode

■ <f> key to access the File menu

■ <o> to activate the ‘‘open’’ command

Mnemonics are case insensitive. Keys can be pressed sequentially instead of 

simultaneously.

Keyboard mapping conventions
Exceptions and additions to the Microsoft Keyboard Conventions are listed in:

■ VEA exceptions to Microsoft keyboard conventions

■ VEA additions to Microsoft keyboard conventions

■ VEA help additions to Microsoft keyboard conventions

VEA exceptions to Microsoft keyboard conventions

Table 3-1 summarizes the keyboard differences between the VEA 

implementation of mnemonics and accelerators, and the Microsoft keyboard 

convention:

Table 3-1 VEA exceptions to Microsoft keyboard conventions

Convention Mnemonic Accelerator

Cancel C Alt C, Escape

OK O Alt O

Refresh E None

Yes None None

No None Escape

Shift+F10 A Alt A
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Keyboard shortcuts
VEA additions to Microsoft keyboard conventions

Table 3-2 summarizes the keyboard additions to the Microsoft keyboard 

conventions in the VEA implementation of mnemonics and accelerators:

Table 3-2 VEA additions to Microsoft keyboard conventions

Convention Mnemonic Accelerator

Actions A Alt A. Use this accelerator in 

place of Shift+F10 with a selected 

item to bring up the context 

menu with the Actions menu.

Add category A None

Add D Alt D

Connect C None

Contents C None

Delete Now None None

Delete Temporary files 

on Exit

E Alt E

Disconnect D None

Number of items in 

history

N Alt N

Password P Alt P

Previous P Alt P

Overwrite the log file W Alt W

Overwrite the log file 

(s) after

A Alt A

Overwrite the log file 

(s) older than

O Alt O

Remove E Alt E

Rescan S None

Reset R Alt R

Set to Defaults S AltS

Remember Password R Alt R

Username U Alt U
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Dialog boxes
VEA help additions to Microsoft keyboard conventions

Table 3-3 summarizes the keyboard additions to the Microsoft keyboard 

conventions in the VEA implementation of mnemonics and accelerators:

Dialog boxes
Dialog boxes often contain groups of controls necessary to set options or 

settings for programs. 

You can select or choose controls that have an underlined letter in their titles by 

typing ALT + the underlined letter at any time when the dialog box is active. TAB 

moves the keyboard focus between controls, but which controls are included in 

the focus sequence, and the order of the sequence, may vary between 

applications. Typically, items that cannot be changed are not visited by the TAB 

key. Arrow keys are used to move within a list box, groups of option controls, or 

groups of page tabs. Arrow keys can move the keyboard focus between other 

controls but this behavior is not reliable. Options that are unavailable appear 

dimmed and cannot be selected.

While the controls described here are typically found on dialog boxes, they also 

can occur in other contexts.

Command buttons, such as the OK button, carry out the command using the 

information supplied in the dialog box. Other command buttons let you cancel 

the command or choose from additional options.

Command buttons marked with an ellipsis (...) open another dialog box so you 

can provide more information or confirm an action. 

Table 3-3 VEA and applications help additions to Microsoft keyboard 

conventions

Convention Mnemonic Accelerator

Find in Topic… F Ctrl + F

Find Next N F3

Find Previous P None

Hide Navigation Tabs H None

Index I None

Print P None

Search S None

Synchronize N None
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Dialog boxes
A dark border initially indicates the default button. Press ENTER at any time to 

choose the button with a dark border. Use TAB to move the keyboard focus to the 

next control, and add SHIFT to reverse the direction. When you move the 

keyboard focus to a command button it temporarily takes the dark border, but 

when the keyboard focus is not on a command button the dark border returns to 

the default button. Press SPACEBAR to choose the command button you selected 

with TAB. Use ESC to immediately choose the Cancel button if there is one. Typing 

the access key for a command button will immediately carry out the command.

Check boxes Use TAB to move between boxes, and SPACE to change the check box 

to the next state. Typing the access key for a check box also will move the focus 

to the box and change is state.

Option controls (also known as radio buttons) are used to select only one option 

from a group of options. (Like check boxes, option buttons may represent two or 

three states.) In some applications, you can add CTRL to move to the button 

without selecting it, then use SPACEBAR to choose the currently selected option 

button. Typing the access key for an option control will also move the focus to 

the control and select it.

Tabbed pages are used to fit many options into a single dialog box. They appear 

visually similar to dividers from a notebook. Each page contains separate groups 

of controls such as check boxes or option controls. Use TAB to move the focus to 

the tab for the currently visible page. Typing the access key for a page tab also 

will move the focus to the tab and display its page.

Table 3-4 summarizes the actions for the keys in tabbed pages:     

Sliders appear as an indicator on a vertical or horizontal gauge. The slider both 

displays and sets a value from a continuous range, such as speed, brightness, or 

volume. Use TAB or the appropriate access key to move the focus to the slider. 

Spin boxes appear as a text box with up and down arrows used to select from a 

list of fixed values. Use TAB to move the keyboard focus to the text box, then 

enter a valid value in the box or use the UP ARROW or DOWN ARROW keys to select 

the next higher or lower values.

Table 3-4 Tabbed pages

Keys Action

CTRL+PAGE DOWN OR CTRL+TAB Switches to the next tab and displays the page.

CTRL+PAGE UP Switches to the previous tab and displays the page.

DOWN ARROW or UP ARROW Chooses the tab in the next or previous row and displays 

the page.

right arrow or left arrow When the focus is on a tab selector, chooses the next or 

previous tab in the current row and displays the page.
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Dialog boxes
List boxes display a column of available choices. If there are more choices than 

can fit in the open list box, moving the selection through the list will scroll more 

choices into view. Use TAB or type the appropriate access key to move the focus 

to the list box.

Single selection list boxes allow only one item to be selected from the list at a 

time. Use the UP ARROW or DOWN ARROW keys to select items. Moving to a second 

item will automatically deselect all other items. 

Drop-down list boxes by default show only the selected item. There is a small 

button to the right of the control that shows a downward-pointing arrow. You 

can click the arrow to display more items from the list. You also can show or 

hide the list using ALT+DOWN ARROW, ALT+UP ARROW, or F4. In all other respects it 

behaves like a normal single-selection list box.

Extended selection list boxes support selecting single items, blocks of items, or 

combinations of the two. After selecting an item as in a single-selection list box, 

hold down SHIFT+Navigation keys to select or deselect more items.

Multiple selection list boxes typically have comparatively long lists and more of 

these items are expected to be chosen individually (not in blocks). Navigating to 

items does not automatically select them nor does selecting an item change the 

status of other selections. Press SPACEBAR to select or deselect an item.

Combo-boxes and drop-down combo boxes are list boxes with attached edit 

boxes. You can make your selection by either typing in the edit box or using the 

standard commands to select from the list. 

Table 3-5 summarizes the actions for keys in combo boxes:

Edit controls are rectangular boxes used for displaying or editing text. Use TAB 

or the appropriate access key to move the focus to the edit control and select the 

text.

Table 3-5 Combo boxes and drop-down combo boxes

Keys Action

UP ARROW or DOWN ARROW Selects the previous or next item. In an extended 

selection list box, add SHIFT to select additional items 

and add CTRL to move to an item without selecting it. In 

a multiple selection list box, moves without changing 

the selection.

PAGE UP or PAGE DOWN Selects the item up or down one screen. In an extended 

selection list box, add SHIFT to select additional items 

and add CTRL to move to an item without selecting it. In 

a multiple selection list box, moves without changing 

the selection.
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Action menu

A context-sensitive menu that changes its menu options to match the type of object that is 

selected. By default, the Action menu is greyed out. When an object is selected, the Action 

menu provides access to tasks appropriate for the selected object.

alert

An indication that an error or failure has occurred on an object on the system. When an 

object fails or experiences an error, an alert icon appears.

alert icon

An icon that indicates that an error or failure has occurred on an object on the system. 

Alert icons usually appear in the status area of the main window and on the group icon of 

the affected object.

Alert Monitor

A window that provides information about objects that have failed or experienced errors. 

Array Support Library

See ASL.

ASL

A dynamically loadable library to discover attributes of a disk array.

browse dialog box

A dialog box that is used to view and/or select existing objects on the system. Most browse 

dialog boxes consist of a tree and grid.

button

A window control that the user clicks to initiate a task or display another object (such as a 

window or menu). 

capability

You can create volumes having specific capabilities. A capability is a simple name used to 

indicate what the capability means. Storage is allocated according to your request. For 

example, you can ask for a volume to be Performant and Reliable. These are capabilities 

have parameters such as, number of striped columns or number of mirrors.

CFS

Cluster file system. A VxFS file system mounted on a selected volume in cluster (shared) 

mode.

check box

A control button used to select optional settings. A check mark usually indicates that a 

check box is selected. 
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children

Objects that belong to an object group.

cluster

A set of host machines (nodes) that shares a set of disks.

cluster file system

See CFS.

command log

A log file that contains a history of Veritas Volume Manager (VxVM) tasks performed in the 

current session and previous sessions. Each task is listed with the task originator, the 

start/finish times, the task status, and the low-level commands used to perform the task.

DCO Data Change Object

See DCO.

DCO

A Volume Manager object that keeps the Persistent FastResync tracking information

DDI

DDI properties are device driver properties primarily used in Solaris OS.

DDL

Device Discovery Layer. A facility of VxVM for discovering disk attributes needed for VxVM 

DMP operation.

Device Discovery Layer

See DDL.

Dirty Region Logging

See DRL.

device name

The physical disk device name (or disk access name).

dialog box

A window in which the user submits information to VxVM. Dialog boxes can contain 

selectable buttons and/or fields that accept information.

disk group

A set of disks that are under VxVM control and share a common configuration. A disk 

group configuration is a set of records containing detailed information on existing Veritas 

Volume Manager objects (such as disk and volume attributes) and their relationships. Each 

disk group has an administrator-assigned name. Volumes can only be created on disks that 

belong to disk groups.

disk name

The Veritas Volume Manager disk name (or disk media name). This is the logical name 

given to the disk by VxVM or the administrator. 

DMP

The Veritas Volume Manager Dynamic Multipathing facility.
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dock

To separate or attach the main window and a subwindow.

DRL

A VxVM mechanism that tracks mirror write inconsistency which helps in fast 

resynchronization of mirrors after system crash. Even though the term log is used, 

internally DRL is implemented as a map.

Dynamic Multipathing

See DMP.

enclosure

A disk array.

FastResync

A VxVM feature for fast resynchronizing of stale mirrors at the time of reattach which were 

earlier split off as a result of snapshot or detach operation.

gap

A disk region that does not contain Veritas Volume Manager objects (subdisks).

graphical view

A window that displays a graphical view of objects. In VxVM, the graphical views include 

the Object View window and the Volume Layout Details window. 

grid

A tabular display of objects and their properties. The grid lists Veritas Volume Manager 

objects, disks, controllers, or file systems. The grid displays objects that belong to the 

group icon that is currently selected in the object tree. The grid is dynamic and constantly 

updates its contents to reflect changes to objects.

group icon

The icon that represents a specific object group.

GUI

Graphical User Interface.

host

A machine or system.

launch

To start a task or open a window.

LUN

Logical Unit Number. Each disk in an array has a LUN. Disk partitions may also be assigned 

a LUN. 

main window

The main VERITAS Volume Manager window. This window contains a tree and grid that 

display volumes, disks, and other objects on the system. The main window also has a menu 

bar, a toolbar, and an optional Command Launcher.

menu

A list of options or tasks. A menu item is selected by pointing to the item and clicking the 

mouse.
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menu bar

A bar that contains a set of menus for the current window. The menu bar is typically placed 

across the top of a window.

mirror

A copy of a volume and its data. There can be several mirrors per volume. The terms mirror 

and plex are used synonymously. 

node

In the VxVM tree, a node is an element attached to the tree. 

In a cluster environment, a node is a host machine in a cluster. 

object group

A group of objects of the same type. Each object group has a group icon and a group name. 

In VxVM, object groups include disk groups, disks, volumes, controllers, free disk pool 

disks, uninitialized disks, and file systems.

object tree

A dynamic hierarchical display of Veritas Volume Manager objects and other objects on the 

system. Each node in the tree represents a group of objects of the same type. 

Object View Window

A window that displays a graphical view of the volumes, disks, and other objects in a 

particular disk group. The objects displayed in this window are automatically updated 

when object properties change. This window can display detailed or basic information 

about volumes and disks. 

Organization principle for disk group

An organization principle is associated with a disk group. These disk groups have storage 

pools present on them. Volumes created on such disk groups are maintained by ISP. 

Traditional volumes cannot be created on these disk groups. You have the option of not 

associating a organization principle to a disk group.

plex

A copy of a volume and its data. There can be several plexes per volume. The terms mirror 

and plex are used synonymously. 

popup menu

A context-sensitive menu that only appears when you click on a specific object or area. 

properties window

A window that displays detailed information about a selected object.

radio buttons

A set of buttons used to select optional settings. Only one radio button in the set can be 

selected at any given time. These buttons toggle on or off. 

rules

Rules specify the storage allocation criteria. These define storage selection and storage 

layout. Rules are simple sentences written in the ISP language. 

scroll bar

A sliding control that is used to display different portions of the contents of a window. 



49Glossary
Search window

The VERITAS Volume Manager search tool. The Search window provides a set of search 

options that can be used to search for objects on the system. 

splitter

A bar that separates two panes of a window (such as the object tree and the grid). A splitter 

can be used to adjust the sizes of the panes. 

status area

An area of the main window that displays an alert icon when an object fails or experiences 

some other error.

storage pool - data pool, clone pool

Storage pools are associated with disk groups. Storage pools are defined by templates, 

capabilities and policies. Policies governing a storage pool decide whether to grow a storage 

pool to accommodate additional storage, and whether to use templates that are not 

currently associated with the storage pool.

There are two types of storage pools: data pools and clone pools. Data pools are created 

first. All other storage pools that are created within a disk group are clone pools.

subdisk

A set of contiguous disk blocks that form a logical disk segment. Subdisks are associated 

with plexes (mirrors) to form volumes. 

task properties window

A window that displays detailed information about a task listed in the Task Request 

Monitor window.

task request monitor

A window that displays a history of tasks performed in the current VERITAS Volume 

Manager session. Each task is listed with the task originator, the task status, and the start/ 

finish times for the task.

toolbar

A set of buttons used to access VERITAS Volume Manager windows. These include another 

main window, a task request monitor, an alert monitor, a search window, and a customize 

window. 

tree

A dynamic hierarchical display of objects on the system. Each node in the tree represents 

a group of objects of the same type.

uninitialized disks

Disks that are not under VxVM control.

user templates

User templates are a collection of capabilities, templates and rules defined by the user to 

simplify tasks. You can group the capabilities you want the volume to have, and save these 

capabilities along with the rules as a user template.

volume

A virtual disk or entity that is made up of portions of one or more physical disks. 



50 Glossary
Volume Layout Details Window

A window that displays a graphical view of a volume and its components. The objects 

displayed in this window are not automatically updated when the volume properties 

change.

Volume to Disk Mapping Window

A window that displays a tabular view of volumes and their underlying disks. This window 

can also display details such as the subdisks and gaps on each disk.

volume set

The volume set feature provides support for the multi-device file system enhancement of 

Veritas File System (VxFS). A volume set allows several volumes to be treated as a single 

object with one logical I/O interface. 

VxFS

Veritas File System.

VxVM

Veritas Volume Manager. 
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