Using AI to install the Solaris 11 operating system and SFHA products

Use the following procedure to install the Solaris 11 operating system and SFHA products using AI.

To use AI to install the Solaris 11 operating system and SFHA products

  1. Follow the Oracle documentation to setup a Solaris AI server and DHCP server.

    You can find the documentation at http://docs.oracle.com.

  2. Set up the Symantec package repository.

    Run the following commands to start up necessary SMF services and create directories:

    # svcadm enable svc:/network/dns/multicast:default
    # mkdir /ai 
    # zfs create -o compression=on -o mountpoint=/ai rpool/ai 
    
  3. Run the following commands to set up the IPS repository for Symantec Opteron packages:
    # mkdir -p /ai/repo_symc_x64
    # pkgrepo create /ai/repo_symc_x64
    # pkgrepo add-publisher -s /ai/repo_symc_x64 Symantec
    # pkgrecv -s <media_x64>/pkgs/VRTSpkgs.p5p -d /ai/repo_symc_x64 '*'
    # svccfg -s pkg/server add symcx64
    # svccfg -s pkg/server list
    # svccfg -s pkg/server:symcx64 addpg pkg application
    # svccfg -s pkg/server:symcx64 setprop pkg/port=10002 
    # svccfg -s pkg/server:symcx64 setprop pkg/inst_root=/ai/repo_symc_x64
    # svccfg -s pkg/server:symcx64 addpg general framework
    # svccfg -s pkg/server:symcx64 addpropvalue 
    general/complete astring: symcx64
    # svccfg -s pkg/server:symcx64 addpropvalue general/enable 
    boolean: true
    # svcs -a | grep pkg/server
    # svcadm refresh application/pkg/server:symcx64
    # svcadm enable application/pkg/server:symcx64
    	

    Or run the following commands to set up the private depot server for testing purposes:

    # /usr/lib/pkg.depotd -d /ai/repo_symc_x64 -p 10002 > /dev/null &
    

    Check the following URL on IE or Firefox browser:

    http://<host>:10002

  4. Run the following commands to setup IPS repository for Symantec Sparc packages:
    # mkdir -p /ai/repo_symc_sparc
    # pkgrepo create /ai/repo_symc_sparc
    # pkgrepo add-publisher -s /ai/repo_symc_sparc Symantec
    # pkgrecv -s <media_sparc>/pkgs/VRTSpkgs.p5p -d 
    /ai/repo_symc_sparc '*'
    # svccfg -s pkg/server list
    # svcs -a | grep pkg/server
    # svccfg -s pkg/server add symcsparc
    # svccfg -s pkg/server:symcsparc addpg pkg application 
    # svccfg -s pkg/server:symcsparc setprop pkg/port=10003
    # svccfg -s pkg/server:symcsparc setprop pkg/inst_root=
    /ai/repo_symc_sparc
    # svccfg -s pkg/server:symcsparc addpg general framework
    # svccfg -s pkg/server:symcsparc addpropvalue general/complete 
    astring: symcsparc
    # svccfg -s pkg/server:symcsparc addpropvalue general/enable 
    boolean: true
    # svcs -a | grep pkg/server
    # svcadm refresh application/pkg/server:symcsparc
    # svcadm enable application/pkg/server:symcsparc
    	

    Or run the following commands to set up the private depot server for testing purposes:

    # /usr/lib/pkg.depotd -d /ai/repo_symc_sparc -p 10003 > /dev/null &
    

    Check the following URL on IE or Firefox browser:

    http://<host>:10003

  5. Run the following commands to setup IPS repository to merge Symantec Sparc and x64 packages:
    # mkdir /ai/repo_symc
    # pkgrepo create /ai/repo_symc
    # pkgrepo add-publisher -s /ai/repo_symc Symantec
    # pkgmerge -s arch=sparc,/ai/repo_symc_sparc -s arch=i386,
    /ai/repo_symc_x64 -d /ai/repo_symc 
    # svcs -a | grep pkg/server
    # svccfg -s pkg/server list
    # svccfg -s pkg/server add symcmerged
    # svccfg -s pkg/server:symcmerged addpg pkg application
    # svccfg -s pkg/server:symcmerged setprop pkg/port=10004
    # svccfg -s pkg/server:symcmerged setprop pkg/inst_root=/ai/repo_symc 
    # svccfg -s pkg/server:symcmerged addpg general framework
    # svccfg -s pkg/server:symcmerged addpropvalue general/complete 
    astring: symcmerged
    # svccfg -s pkg/server:symcmerged addpropvalue general/enable 
    boolean: true
    # svcadm refresh application/pkg/server:symcmerged
    # svcadm enable application/pkg/server:symcmerged 
    # svcs -a | grep pkg/server
    	

    Or run the following commands to set up the private depot server for testing purposes:

    # # /usr/lib/pkg.depotd -d /ai/repo_symc -p 10004 > /dev/null &
    

    Check the following URL on IE or Firefox browser:

    http://<host>:10004

  6. Set up the install service on the AI server.

    Run the following command:

    # mkdir /ai/iso

    Download the AI image from the Oracle Web site and place the iso in the /ai/iso directory.

    Create an install service.

    For example:

    To set up the AI install server for Opteron platform::

    # installadm create-service -n sol11x86 -s 
    /ai/iso/sol-11-1111-ai-x86.iso -d /ai/aiboot/

    To set up the AI install server for SPARC platform::

    # # installadm create-service -n sol11sparc -s\
     /ai/iso/sol-11-1111-ai-sparc.iso -d /ai/aiboot/
  7. Run the installer to generate manifest XML files for all the SFHA products that you plan to install.
    # mkdir /ai/manifests 
    # <media>/installer -ai /ai/manifests
  8. For each system, generate the system configuration and include the hostname, user accounts, and IP addresses. For example, enter one of the following:
    # mkdir /ai/profiles 
    # sysconfig create-profile -o /ai/profiles/profile_client.xml

    or

    # cp /ai/aiboot/auto-install/sc_profiles/sc_sample.xml 
    /ai/profiles/profile_client.xml
  9. Add a system and match it to the specified product manifest and system configuration.

    Run the following command to add an Opteron system, for example:

    # installadm create-client -e "<client_MAC>" -n sol11x86 
    # installadm add-manifest -n sol11x86 -f 
    /ai/manifests/vrts_manifest_sfha.xml 
    # installadm create-profile -n sol11x86 -f 
    /ai/profiles/profile_client.xml -p profile_sc 
    # installadm set-criteria -n sol11x86 -m vrts_sfha 
    -p profile_sc -c mac="<client_MAC>" 
    # installadm list -m -c -p -n sol11x86

    Run the following command to add a SPARC system, for example:

    # installadm create-client -e "<client_MAC>" -n sol11sparc
    # installadm add-manifest -n sol11sparc -f \
    /ai/manifests/vrts_manifest_sfha.xml
    # installadm create-profile -n sol11sparc -f \
    /ai/profiles/profile_client.xml -p profile_sc
    # installadm set-criteria -n sol11sparc -m \
    vrts_sfha -p profile_sc -c mac="<client_MAC>"
    # installadm list -m -c -p -n sol11sparc
  10. For Opteron system, use Preboot Execution Environment(PXE) to reboot the system and install the operating system and Storage Foundation products.

    For Sparc system, run the following command to reboot the system and install the operating system and Storage Foundation products:

    # boot net:dhcp - install