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Technical Support
Symantec Technical Support maintains support centers globally. Technical 
Support’s primary role is to respond to specific queries about product features and 
functionality. The Technical Support group also creates content for our online 
Knowledge Base. The Technical Support group works collaboratively with the 
other functional areas within Symantec to answer your questions in a timely 
fashion. For example, the Technical Support group works with Product 
Engineering and Symantec Security Response to provide alerting services and 
virus definition updates.
Symantec’s support offerings include the following:

■ A range of support options that give you the flexibility to select the right 
amount of service for any size organization

■ Telephone and/or web-based support that provides rapid response and 
up-to-the-minute information

■ Upgrade assurance that delivers automatic software upgrades protection

■ Global support purchased on a regional business hours or 24 hours a day, 7 
days a week basis

■ Premium service offerings that include Account Management Services
For information about Symantec’s support offerings, you can visit our web site at 
the following URL:
www.symantec.com/business/support/index.jsp
All support services will be delivered in accordance with your support agreement
and the then-current enterprise technical support policy.

Contacting Technical Support
Customers with a current support agreement may access Technical Support 
information at the following URL:
www.symantec.com/business/support/contact_techsupp_static.jsp
Before contacting Technical Support, make sure you have satisfied the system 
requirements that are listed in your product documentation. Also, you should be at 
the computer on which the problem occurred, in case it is necessary to replicate 
the problem.
When you contact Technical Support, please have the following information
available:

■ Product release level

■ Hardware information

■ Available memory, disk space, and NIC information

■ Operating system

■ Version and patch level

■ Network topology

■ Router, gateway, and IP address information

http://www.symantec.com/business/support/index.jsp
http://www.symantec.com/business/support/contact_techsupp_static.jsp
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■ Problem description:
■ Error messages and log files
■ Troubleshooting that was performed before contacting Symantec
■ Recent software configuration changes and network changes

Licensing and registration
If your Symantec product requires registration or a license key, access our 
technical support web page at the following URL:
www.symantec.com/business/support/

Customer service
Customer service information is available at the following URL:
www.symantec.com/business/support/
Customer Service is available to assist with non-technical questions, such as the
following types of issues:

■ Questions regarding product licensing or serialization

■ Product registration updates, such as address or name changes

■ General product information (features, language availability, local dealers)

■ Latest information about product updates and upgrades

■ Information about upgrade assurance and support contracts

■ Information about the Symantec Buying Programs

■ Advice about Symantec's technical support options

■ Nontechnical presales questions

■ Issues that are related to CD-ROMs or manuals

Documentation feedback
Your feedback on product documentation is important to us. Send suggestions for 
improvements and reports on errors or omissions. Include the title and document 
version (located on the second page), and chapter and section titles of the text on 
which you are reporting. Send feedback to:
sfha_docs@symantec.com

www.symantec.com/business/support/
www.symantec.com/business/support/
mailto:sfha_docs@symantec.com
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Support agreement resources
If you want to contact Symantec regarding an existing support agreement, please 
contact the support agreement administration team for your region as follows:

Additional enterprise services
Symantec offers a comprehensive set of services that allow you to maximize your 
investment in Symantec products and to develop your knowledge, expertise, and 
global insight, which enable you to manage your business risks proactively.
Enterprise services that are available include the following:

To access more information about enterprise services, please visit our web site at 
the following URL:
www.symantec.com/business/services/
Select your country or language from the site index.

Asia-Pacific and Japan customercare_apac@symantec.com

Europe, Middle-East, and Africa semea@symantec.com

North America and Latin America supportsolutions@symantec.com

Managed Services These services remove the burden of managing and monitoring 
security devices and events, ensuring rapid response to real 
threats.

Consulting Services Symantec Consulting Services provide on-site technical 
expertise from Symantec and its trusted partners. Symantec 
Consulting Services offer a variety of prepackaged and 
customizable options that include assessment, design, 
implementation, monitoring, and management capabilities. Each 
is focused on establishing and maintaining the integrity and 
availability of your IT resources.

Education Services Education Services provide a full array of technical training, 
security education, security certification, and awareness 
communication programs.

mailto:customercare_apac@symantec.com
mailto:semea@symantec.com
mailto:supportsolutions@symantec.com
www.symantec.com/business/services/
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This section includes the following chapters:

■ “Introducing Veritas Cluster Server One” on page 25.

■ “Components of Veritas Cluster Server One” on page 29.

■ “How VCS One works” on page 47.

■ “How Veritas Cluster Server One works with virtualization” on page 63

■ “How VCS One global clusters work” on page 73

■ “How the UNIX Policy Master cluster operates” on page 89.

■ “How the Windows Policy Master cluster operates” on page 109
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Chapter
 1
Introducing Veritas Cluster 
Server One 

This chapter includes the following topics:

■ About Veritas Cluster Server One

■ About the Simulator

■ What you can do with VCS One

■ Sample solutions using VCS One

■ Where to get more information about VCS One
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About Veritas Cluster Server One
About Veritas Cluster Server One
Veritas™ Cluster Server One (VCS One) solves many of the problems that are 
found in the complex modern datacenter. It continues to support the familiar 
concepts that are used in Veritas Cluster Server, such as service groups, 
resources, and agents. However, VCS One introduces a new product 
architecture. This new architecture allows many powerful capabilities to be 
added to the high-availability and application management features of VCS.

These capabilities include multi-tier applications that run across different 
operating systems, virtualization, and rolling upgrades. 

VCS One builds upon the expertise of the use of VCS in mission-critical 
environments with an architecture that is ready for the newest challenges that 
face your datacenter.

VCS One has the following functional modes:

■ VCS One HA/DR

All functionality is available, including high availability and the ability to 
configure a disaster recovery failover.

■ VCS One HA

Most functionality is available, including high availability, but not including 
the ability to configure a disaster recovery failover.

■ VCS One Start

VCS One Start eliminates the following features:

■ Auto-failover

■ Priority-based application availability

■ Disaster recovery

About the Simulator 
You can use the simulator to simulate a VCS One cluster. You can view, modify, 
and test the VCS One cluster configuration and behavior. 

The simulator includes the following features:

■ Runs an instance of the Policy Master that simulates the Policy Master 
running in a real VCS One cluster. Simulator behavior is identical to the 
behavior in a real VCS One cluster. 

■ Imports the configuration from an actual VCS One cluster into the 
Simulator. You can troubleshoot configuration issues and perform root 
cause analysis in a safe simulation that does not affect the production 
environment.
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■ Induces simulated faults and view how they affect the VCS One cluster and 
execute failover policy. You can create and fine-tune the VCS One cluster 
configuration separately from a production environment. The simulated 
configuration can then be imported into your production environment.

■ Tests the configurations from different operating systems. For example, you 
can run VCS One Simulator on a Windows system and test configurations 
for Windows, Linux, and Solaris VCS One clusters. 

■ Educate VCS One users in a protected environment. The simulator has the 
same look-and-feel as the actual VCS One software. You can reproduce your 
own environment for realistic lab scenarios. 

■ Runs on a stand-alone system.

Does not require any additional storage or networking hardware. 

■ Runs in non-secure mode.

■ Runs from the VCS One Console or from the command line. 

See “About the Simulator” on page 204.

What you can do with VCS One
Use the following VCS One capabilities to improve operations center staff 
efficiency and to better manage a large number of applications:

■ Control applications and application components from a single interface, 
scalable to hundreds of systems and thousands of applications. Start, stop, 
and monitor applications and their related application components.

VCS One supports the high availability of the application whether it is 
running on a physical server or in a virtual environment.

■ View applications in a data center, whether they are running on physical 
servers or virtual servers.

■ Create, control, and visualize dependencies between components of an 
application, as well as between applications.

■ Control access to specific applications. Security and user level settings give 
operations staff control of specific applications without the need to provide 
a local logon account to the system.

■ Manage application hosts with a lightweight storage, processor, and 
memory footprint on the client system.

■ Control application hosts with secure encrypted communications.
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Sample solutions using VCS One
VCS One resolves the following datacenter issues:

■ Allows all applications to be monitored and controlled uniformly, with levels 
of availability configured as necessary for each application. In the past, 
these features usually were available only for highly-critical applications. 

■ Reduces or eliminates the need for front line operations staff to possess 
application-specific knowledge to start, restart, or stop complex 
applications.

■ Removes the need to write, deploy, and maintain custom scripts to start, 
stop, and monitor applications in many cases.

Where to get more information about VCS One
More information about VCS One is available on the Symantec Web site:

http://www.symantec.com

http://www.symantec.com


Chapter
 2
Components of Veritas 
Cluster Server One

This chapter includes the following topics:

■ Components of application management

■ Physical components of a VCS One environment

■ Policy Master components
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Components of application management
The components of application management wrap a structure around your 
application and provide powerful tools to monitor and control your application 
both manually and automatically.

VCS One can manage an application running inside a virtual machine, and a 
virtual machine itself.

When VCS One manages a virtualization environment, in addition to the 
components of application management, virtualization-based objects are also in 
use.

About managed applications
A managed application is an application service under the control of VCS One. 
An application service is the entire collection of hardware and software 
components that are required to provide an application to the end user. 

For example, an end user accesses an Oracle database by connecting to a 
particular host system. 

The application is the database but the application service consists of all of the 
following components:

■ Oracle database software, including the listener

■ File systems containing data files

■ Disk groups that have volumes on which the file systems reside

■ One or more IP addresses

■ Network Interface Card (NIC) 

An application service can comprise more than one application. The database 
may connect to a financial application, and the financial application may have a 
web-based front end. In this case the application service is three-tier, consisting 
of the three applications: the database, the financial application, and the 
web-based interface.

Each managed application typically requires the following types of components: 

■ Application 

■ Storage
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■ Networking

If a managed application is moved to another physical system or virtual system, 
all of the components of the managed application move together.

About resources and resource dependencies
The hardware components and software components that make up the managed 
application are called resources. Resources are objects in the VCS One 
configuration.

As an example, an Oracle database managed application consists of the 
following resources:

■ Database instance

■ Database listener

■ File System

■ Disk groups

■ IP address

■ Network interface card

To control a managed application, you control all the resources that make up 
that application service. You can perform the following operations to control a 
resource:

■ Bring it online, or start the resource

■ Take it offline, or stop the resource

■ Monitor it for status and failure detection

To manage the application you must also know how the individual resources 
that make up the application interrelate. Resource dependencies indicate the 
resources that depend on each other because of application or operating system 
requirements. 

Table 2-1 Components of a managed Oracle database

Type of component Component

Application ■ Database instance

■ Database listener

Storage Components ■ File system

■ Disk group

Networking Components ■ IP address

■ Network interface card
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Resource dependencies are hierarchical. This hierarchy is called a resource 
dependency tree. The resources higher up in the tree (parent) depend on the 
resources lower down in the tree (child). 

Figure 2-1 shows the hierarchy for an Oracle database managed application.

Figure 2-1 Sample resource dependency tree

Resource dependencies determine the order in which resources are brought 
online or taken offline. Child resources must be online before parent resources 
can be brought online. Likewise, parent resources are brought offline before 
child resources are taken offline. 

For example, you must configure and import a disk group before you mount the 
file system. Conversely, file systems must be unmounted before disk groups are 
deported. 

To start a managed application, each child resource is brought online. Then the 
parent that depends on the resource is brought online. This pattern continues 
up the tree, until finally the application is started. Conversely, to take a 
managed application offline, the resources at the top of the hierarchy are taken 
offline first. 

If the resources do not have parent-child interdependencies, they can be 
brought online or taken offline concurrently. In the Oracle database example, 
the database listener is stopped first. Next, the Oracle database application and 
the IP address can be stopped concurrently because they do not have a resource 
dependency between them.

About service groups and service group dependencies
A service group is a virtual container that contains all the hardware resources 
and software resources that are required to run the managed application. 
Service groups are objects in the VCS One configuration.

Service groups allow VCS One to control all the resources of the managed 
application as a single unit. When a failover occurs in VCS One, the entire 
service group fails over as a unit. Resources do not fail over individually. 
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A service group can have several states, which indicate the state of the managed 
application.

See “State” on page 857.

Figure 2-2 shows a sample service group.

Figure 2-2 Sample service group

A system may host multiple service groups, where each service group provides a 
discrete managed application to networked customer client systems. 

If multiple service groups are running on a single system, they are monitored 
and managed independently. Independent management enables a service group 
to be manually idled or switched to another system without having an impact on 
the other service groups. 

A service group may also be configured to failover automatically under certain 
predefined conditions, such as a system failure.

Actions performed on a service group
You can perform the following actions on a service group:

■ Start

■ Monitor

■ Stop

■ Switch

■ Failover

■ Freeze

■ Unfreeze

You can perform administrative operations on individual resources and on 
service groups. When you perform administrative operations at the service 
group level, a series of commands is initiated for all of the resources within the 
service group. 
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For example, when you direct a service group to go online, an online command is 
initiated for each resource within that service group. 

See “Managing service groups” on page 355.

About service group dependencies
Service groups can be dependent on each other. For example a Web application 
can be a front end to a finance application that is in turn dependent on a 
database application. 

The dependent service group is called the parent service group, and the service 
group on which it is depends is called the child service group. 

Figure 2-3 is an example of a two tier service group dependency.

Figure 2-3 Two tier service group dependency

Because the managed application comprises all the components that are 
required to provide the application service, service group dependencies create 
more complex managed applications. 

See “About designing service group dependencies” on page 283.

Service group dependencies affect how the service groups can come online, go 
offline, or move to another system. 

See “About designing application and virtual machine placement policy” on 
page 312.
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About composite service groups
A composite service group (CSG) is a collection of objects. Use composite service 
groups to manage a group of objects as a single logical object. 

A composite service group may contain service groups and VFrames. A service 
group may only be part of one composite service group at a time. 

A composite service group can be local or global. A global composite service 
group is the unit of failover between different VCS One clusters.

The following examples are ways you may use composite service groups:

■ To manage a multi-tier application as a single logical unit in a VCS One 
cluster.

■ To switch a multi-tier application between two separate VCS One clusters, 
for example as part of a maintenance plan.

■ To perform a takeover of a multi-tier application between two separate VCS 
One clusters, for example during disaster recovery conditions.

See “Managing composite service groups” on page 405.

In a multi-cluster environment and with global composite service groups, only 
one site has the authority to bring the composite service group online.

See “Authority” on page 831.

About systems
A system in VCS One is an object that represents an operating system that is not 
capable of running virtual machines. 

The VCS One object that represents an operating system that is capable of 
running virtual machines is a PFrame.

See “About the physical systems in the VCS One cluster” on page 41.

A system object can run on a physical server or a virtual machine (VFrame). 

Systems are categorized by their operating system type, as defined by the 
PlatformName attribute of the system object.

The service group that encapsulates the managed application runs on a system 
object. You configure on which system object or objects the service group may 
run. A system object may run on a physical machine or a virtual machine 
(VFrame). 

Systems can be of any supported operating system. A VCS One cluster supports 
different operating systems in the same VCS One cluster.

About VFrames and management consoles
VFrames and management consoles are virtualization-based objects.
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A virtual frame, or a VFrame, is a VCS One object that represents a virtual 
machine. VFrames run on PFrames (physical frames). VFrames are further 
categorized by the visibility and control that VCS One maintains over the 
applications running inside the virtual frame.

See “About VFrames” on page 66.

Example VFrame objects are ESXVM and LDomsVM.

A management console is an object of type ManagementConsole and represents 
a management console of a certain type of virtual environment.

An example of a management console object is VMwareVC.

About the Organization Tree
The VCS One managed environment is collectively referred to as the VCS One 
cluster. An Organization Tree is a logical hierarchical structure of the VCS One 
cluster. The Organization Tree provides an infrastructure that is used to 
delineate the user views and privileges of your managed applications and the 
systems that run them. 

The Organization Tree can be changed and the objects can move around in the 
tree. As the tree changes, the user privileges are dynamically updated.

Figure 2-4 shows a sample Organization Tree.

Figure 2-4 Sample Organization Tree

The Organization Tree is made up of branches and nodes. In Figure 2-4, Retail 
and Wholesale constitute separate branches of the tree. Each individual 
component part is termed a node of the tree.

Retail branch

Wholesale branch
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When you add a system, service group, pframe, vframe, mframe, user, or user 
group to the VCS One cluster, you anchor, or attach, that object to a particular 
node of the Organization Tree. 

Users must be granted explicit privileges to perform operations on objects. The 
following exceptions exist to this rule:

■ The local root user on a client-side system can perform all client-side 
operations on the node, such as starting an agent on the system or taking a 
service group on that system offline.

■ The local root user on the active Policy Master can perform all operations on 
all objects.

The local root user on an inactive Policy Master does not have privileges to 
perform operations.

See “Policy Master components” on page 43.

The objects for which a user is granted permission must reside at or under the 
node where the user is anchored. A user cannot be granted permission for any 
object outside of their anchored node or subtree.

The Organization Tree in Figure 2-4 can be used to illustrate how privileges are 
related to the location of an object in the tree. An operator anchored at the 
Wholesale node can have the privilege to online or offline service groups on any 
system in the Wholesale branch. If additional systems are added to the 
Wholesale branch, the privileges of that user are automatically updated to 
include the new systems.

The same operator will not see the Retail branch of the tree.

See “About users and the Organization tree” on page 252.

See “About the architecture of the Organization Tree” on page 255.

About users, user groups, and their roles
Users are objects in the VCS One configuration. A user is created and assigned a 
role. A role is a named collection of privileges. Privileges define what actions the 
user can perform, such as adding a system to the VCS One cluster or modifying a 
service group. Every action a user can perform is individually defined as a 
privilege. 

Roles and privileges are a flexible way to manage your users for the following 
reasons:

■ You can associate a pre-defined role to a new user to decrease start-up time.

■ You can create custom roles, with any appropriate privileges.

■ You can create as many custom roles as you need in your environment.
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When a user performs an operation, VCS One authorizes the action and the 
objects the user can act on using the user’s configured privileges. If the user 
does not have appropriate privileges, the operation will not execute.

VCS One has both predefined roles and the ability to create custom roles. A chart 
that compares the privileges of each of the predefined roles is available.

See “Reference of privileges” on page 753.

About user privileges 
Because every action in VCS One requires a privilege, the privileges are 
organized into privilege categories for ease of administration. The privilege 
categories sort the individual actions the role can perform by the type of object 
to which the action is related.

For example, the System Privilege category contains the privileges to freeze a 
system or to add the system to a service group’s SystemList attribute. Similarly, 
the Notifier Privilege category contains the privilege to change the notification 
settings.

The total privileges of a user are a union of the following sets of privileges:

■ Privileges explicitly granted to the user

■ Privileges granted to any user group of which the user is a member

About user groups
A VCS One user group object can represent existing groups of users already 
configured in the datacenter. Some examples of existing groups of external 
users are the user groups defined with NIS or with LDAP. 

VCS One uses Symantec Product Authentication Service (AT) to identify the 
membership of the external user to a VCS One user group. Roles and privileges 
are assigned to a user group in the same manner as they are assigned to an 
individual user.

A user is associated with a user group dynamically. The user is implicitly 
associated with all the groups specified in the user credentials. The credentials 
of the user include the credentials of the user groups to which the user belongs.

About extended attributes
An extended attribute (EA) is customer-defined metadata assigned to a VCS One 
object that defines a characteristic for that object.
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Types of extended attributes
Extended attributes can be one of the following types:

Values of extended attributes
You define extended attributes at a node in the Organization Tree. When a VCS 
One object is anchored at or beneath that same Organization Tree node, the 
defined extended attributes can be given a corresponding value.

The Organization Tree in Figure 2-4 can be used to illustrate how values of 
extended attributes work. You can define a system extended attribute named 
Location at the B2B node. This Location system attribute automatically exists at 
the Production and Development nodes because those nodes are beneath the 
B2B node.

Because this is a system extended attribute, all systems attached to the B2B, 
Production, and Development nodes inherit the Location attribute.

If you configure a default value for this Location attribute, such as
Location = London, all systems attached at the B2B, Production, and 
Development nodes have the value Location = London. If there is not a default 
value configured, you must explicitly define the Location system attribute for 
each system at those nodes. 

See “About extended attributes” on page 632.

Uses for extended attributes
You can use extended attributes for the following application management 
tasks:

System Defines a characteristic for all system objects that are attached to that 
node and below in the Organization Tree.

Service group Defines a characteristic for all service group objects that are attached to 
that node and below in the Organization Tree.

Vobject Defines a characteristic for all mframe objects that are attached at that 
node and below in the Organization Tree.

Pframe Defines a characteristic for all pframe objects that are attached at that 
node and below in the Organization Tree.

Vframe Defines a characteristic for all vframe objects that are attached at that 
node and below in the Organization Tree.

Common Defines a characteristic for all system, service group, mframe, pframe, 
and vframe objects that are attached to that node and below in the 
organization tree.



40 Components of Veritas Cluster Server One
Physical components of a VCS One environment
■ To perform operations on multiple objects

■ To categorize objects in reports or scripts

■ To help troubleshoot issues

When you use extended attributes as part of an expression, the objects that the 
expression affects are dynamically updated. For example:

■ You can configure a system extended attribute named OracleInstalled. 

■ You can use an expression to build a collection of the systems in your 
environment that have the OracleInstalled attribute. You can save this 
collection of systems as a set.

■ You can then use the set to perform operations on all the systems in that set.

■ If you then add more systems to your environment and assign the 
OracleInstalled attribute to them, the set automatically includes these new 
systems.

See “About extended attributes” on page 632.

See “About administrating sets of objects” on page 666.

Extended attributes can be used in an expression in the following ways:

■ To create a set of objects in the Organization Tree

For example, to online a set of service groups that the expression defines 
rather than to create a list of the service groups.

■ To filter the view of objects in the Organization Tree

For example, to display all systems in a particular location.

■ As part of a command when using the command line instead of the console

■ As a variable in a resource attribute value, with certain restrictions.

See “Defining an attribute value with a resource variable” on page 439.

Physical components of a VCS One environment
The following components are the physical aspects of a VCS One environment:

■ Physical systems in the VCS One cluster

■ Customer systems

■ Data storage

■ Networking
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About the physical systems in the VCS One cluster
VCS One uses a client-server architecture to provide a scalable and 
highly-available application management solution. 

The VCS One cluster consists of physical systems that are used for the following 
general purposes:

■ Physical VCS One cluster systems that run managed applications.

These systems are the clients in the client-server architecture. These 
systems host the managed applications and the virtual machines under the 
control of VCS One.

Note that these physical cluster systems are different than the system 
objects in the cluster.

See “About systems” on page 35.

■ Policy Master cluster systems that manage the VCS One cluster.

These systems are the server in the client-server architecture. Best practice 
recommends that these systems are not used to host managed applications.

See “Policy Master components” on page 43.

■ Physical Frames, or Pframes.

A PFrame is a virtualization-based object. A PFrame is a VCS One object that 
represents an operating system that is capable of running one or more 
virtual machines.

PFrames are categorized by the type of virtualization technology they run. 
Examples of PFrame objects are ESXServer and LDomsServer.

Physical systems that run different operating systems can co-exist inside the 
same VCS One cluster. 

Each VCS One cluster system is connected to networking hardware. A VCS One 
cluster system usually is connected to storage hardware as well.

Once deployed, a physical VCS One cluster node contains the following 
elements:

■ Operating system

■ VCS One client daemon (vcsoneclientd)

■ Unique Authentication Service (AT) principal for secure communications

The client daemon on a VCS One cluster node communicates only with the 
Policy Master daemon. It does not communicate with the client daemon on other 
VCS One cluster nodes.



42 Components of Veritas Cluster Server One
Physical components of a VCS One environment
About customer systems
Customer systems access the managed applications on the VCS One cluster 
systems. This access is by an IP address on a public network. 

In configurations where an application may move between systems, customers 
access a virtual IP address instead of a static IP address. 

The virtual IP address allows customer systems to connect to the same IP 
address regardless of which VCS One cluster system is currently running the 
service group. 

About storage in the VCS One cluster
Storage is a key resource of most applications services, and therefore most 
service groups. A service group can only be started on a system that has access 
to the data files associated with the application service.

If a service group can move between systems in the VCS One cluster, any system 
that hosts the service group must make available the associated data files that 
are needed by the managed application. Typically, this availability requires 
some form of shared storage. VCS One supports shared storage on NAS and 
SAN. To ensure data integrity, configure shared storage to allow VCS One to 
restrict access to only the active node that currently hosts the service group. On 
NAS based storage, VCS One provides the ability to control NFS exports from a 
NetApp based NAS filer. On SAN based storage, VCS One uses Veritas Storage 
Foundation to control SCSI-III reservations at the disk group level.

About networking in the VCS One cluster
Networking in the VCS One cluster is used for the following purposes:

■ To communicate between the VCS One cluster systems and the Policy 
Master cluster. 

■ To communicate within the Policy Master cluster.

See “How VCS One provides security in communications” on page 59.

See “How the Policy Master and client systems resolve failures in 
communication” on page 54.

Redundant paths are recommended.

For more information on networking design, see Veritas Cluster Server One 
Installation Guide.
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Policy Master components
The Policy Master is the core of VCS One. The Policy Master is a single, 
highly-available, specialized application that provides the central logic of VCS 
One. Also known as the Policy Master daemon, or vcsoned, it is responsible for 
all configuration and management of the VCS One environment.

The Policy Master has the following components:

Policy Master daemon 
(vcsoned)

The Policy Master daemon is the main VCS One daemon. It 
provides the core logic of VCS One. 

On Windows, the Policy Master daemon runs as a service.

The Policy Master daemon does the following tasks:

■ Builds a running VCS One cluster configuration from the 
configuration database on startup

■ Updates the configuration database with configuration 
and status changes

■ Determines the system membership in the VCS One 
cluster

■ Communicates with agents to monitor and manage 
resources on the VCS One cluster systems

■ Implements all managed application placement policy 

■ Responds to operator input and provides service to the 
Web server and user interface components 

Policy Master Web server The Policy Master Web server is a Java application. It accepts 
connections from Web clients, connects to the Policy Master 
daemon, and acts as a front end for all user interaction. It also 
authenticates users, interprets commands, and logs in on 
behalf of Web users.
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The Policy Master application is encapsulated into a service group, called the 
Policy Master service group (PMSG). This encapsulation allows the components 
of the Policy Master to become a managed application. 

The following components are in the Policy Master service group:

■ Policy Master daemon (vcsoned)

■ Policy Master Web server (VCSOneWeb)

■ Policy Master configuration database (vcsonedb)

■ Storage (disk group, volume, and on UNIX, mount, or on UNIX, NetApp NFS 
storage)

■ Networking (pmip and pmnic)

■ Authentication broker resource (atd)

To ensure that the Policy Master application is highly-available, the Policy 
Master service group runs in a small cluster of up to four systems. The Policy 
Master cluster systems are separate from the VCS One cluster systems and are 
only used for Policy Master functionality. Application service groups do not run 
in the Policy Master cluster. 

The Policy Master cluster runs Veritas Cluster Server. 

Figure 2-5 shows the VCS One cluster systems alongside the Policy Master 
cluster.

Policy Master 
configuration database

The Policy Master controls the configuration database and 
stores all the information for the entire VCS One cluster. 

The following information is stored in the configuration 
database:

■ Configuration and status of all the VCS One cluster 
objects, such as systems, PFrames, VFrames, service 
groups, resources, sets, and users.

■ Policies, such as scheduled jobs

■ GUI settings

■ Custom views for both the Policy Master and the VCS One 
cluster systems

The database is highly available because it is configured as a 
resource of the Policy Master service group that runs in the 
Policy Master cluster.

The database only accepts connections from the Policy Master. 
It does not permit outside connections for any purpose. You 
can use the hadb utility to perform operations on the 
configuration database.

See “Managing the configuration database” on page 689.
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Figure 2-5 Policy Master cluster with VCS One cluster
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Chapter
 3
How VCS One works

This chapter includes the following topics:

■ How the Policy Master manages the applications

■ How the Policy Master and the VCS One clients start up

■ How the Policy Master loads the VCS One cluster configuration

■ How the Policy Master and client systems resolve failures in 
communication

■ About Load and Capacity

■ About the control of the scheduling class and scheduling priority of agent 
operations

■ How you can configure automated tasks and group operations

■ How VCS One provides security in communications
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How the Policy Master manages the applications
The Policy Master controls the managed applications by controlling the 
resources in the service group that encapsulate the managed application.

At a high level, the following process manages an application:

■ The Policy Master determines the logic of what action to perform on a 
resource. 

■ The Policy Master daemon, vcsoned, communicates the action to the 
daemon running on the client system, which is vcsoneclientd.

■ The client daemon, vcsoneclientd, communicates the action to the agent 
that controls the resource.

■ The agent for that resource performs the action, such as online the resource.

About the client daemon vcsoneclientd
The VCS One client daemon is the main VCS One component that runs on each 
of the VCS One cluster systems. It is responsible for the following tasks:

■ Forming secure communications with the Policy Master 

■ Sending and receiving a heartbeat signal with the Policy Master 

■ Starting and stopping the agents on the local system

A vcsoneclientd daemon shadow tries to restart vcsoneclientd if it fails.

About agents and resource types
Every resource has a resource type, such as Oracle, Disk or IP. Each type of 
resource that runs in the VCS One cluster has a corresponding agent. The agent 
contains the logic of how to perform all supported actions on resources of that 
resource type.

For example, VCS One uses the Oracle agent to control all resources of type 
Oracle. The Oracle agent contains all the code that is needed to start, stop, and 
monitor instances of Oracle. 

When you configure a new Oracle resource in the VCS One cluster, you only 
need to provide the information that is unique to that instance, such as the 
home directory and system identifier (SID). This information is passed to the 
agent that controls the resource.

Likewise when you configure a new IP resource, you provide the IP address and 
the subnet mask. The agent contains the code to use this information to start, 
stop, and monitor the health of that IP resource.
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When a service group is configured to run on a specific set of system, the 
corresponding agents for the resources in that service group run on the same set 
of systems. This action lets the agent continuously monitor the resource 
whether or not it is online.

One instance of the agent controls all the resources of that resource type on the 
system. If no resources of a particular resource type are used, the agent is not 
started. For example, if there are no Oracle resources in your configuration, the 
Oracle agent is not started on any system.

The agents can take the following actions on a resource:

In the rare case where an agent does not already exist for a resource in your 
environment, you can develop a custom agent. An agent framework provides a 
level of abstraction to the agent that makes it easier for a developer or 
consultant to write a custom agent. 

More information is available on writing custom agents.

See Veritas Cluster Server One Agent Developer’s Guide.

monitor Determines if the 
resource is running 
properly.

All resources are monitored at regular intervals of time, whether they are 
online or offline.This action is also an agent entry point.

online Starts the resource. Resources are brought online to start the managed application. The Policy 
Master controls the order the resources come online with respect to resource 
dependencies. This action is also an agent entry point.

restart Tries to online the 
resource again. 

The Policy Master may try to restart a resource upon detection of failure 
depending on the value of the RestartLimit attribute.

offline Stops the resource. Resources are brought offline to stop the managed application. The Policy 
Master controls the order the resources go offline with respect to resource 
dependencies. This action is also an agent entry point.

clean Ensures that the 
resource is completely 
offline.

The clean function is called for the following events:

■ An online command to the resource fails. 

■ An offline command to the resource fails.

■ The resource goes offline unexpectedly. Unexpectedly means that the 
following actions took place:
The resource was in an online state
Without the user issuing an offline command, the agent monitors the 
status of the resource to be in an offline state. 

■ The monitor of the resource fails consecutively for the number of times 
that is configured in the resource attribute FaultOnMonitorTimeout.

The clean function is always called before a resource fault is reported to the 
Policy Master
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How the Policy Master and the VCS One clients start 
up

This topic describes the various startup actions for the Policy Master and the 
client systems.

First initialization of the VCS One cluster
The sequence of events for VCS One cluster startup is as follows:

■ On each client system, operating system scripts start the client daemon, 
vcsoneclientd, when the system initially starts.

■ The vcsoneclientd daemon initiates a connection to the Policy Master by 
sending a connection request.

■ The Policy Master responds to the connection request.

■ The vcsoneclientd daemon indicates to the Policy Master that the system is 
in startup mode.

■ The Policy Master sends a configuration snapshot to the system.

The configuration snapshot contains information specific to that VCS One 
cluster system, such as what agents to start up, the attributes of all the 
resources configured to run on that system, and a configuration version 
number. 

The configuration version number keeps track of configuration changes for 
the system. Whenever there is a configuration change, both the Policy 
Master and the client system independently increment their configuration 
version number. This keeps the message exchange during a reconnect 
between the Policy Master and vcsoneclientd to a minimum.

This action completes the initialization of the client system.

The Policy Master start up mode determines the next action to take place.

Once the Policy Master and client systems are up and running, actions in 
response to any state changes in resources, service groups or systems are 
dictated by configured policy.

More information is available about initialization in VCS One cluster 
environments that incorporate supported virtualization technologies.

See “How Veritas Cluster Server One works with virtualization” on page 63.

Policy Master start up modes
When the Policy Master starts up, either due to a system start up or a Policy 
Master failover, the following modes are available:
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■ Warm (Normal)

On a Windows Policy Master, this is the only startup mode available.

■ Cold 

The hastart command denotes the Policy Master start up mode.

See the Veritas Cluster Server One Command Line Reference Guide.

Warm (normal) start up mode
When the Policy Master service group starts after a failover or switch to an 
alternate system at the same site, warm mode is the default action.

In warm mode, the Policy Master enforces the configuration and state of the 
VCS One cluster stored in the configuration database. If the configuration and 
state of the VCS One cluster when the Policy Master starts up are different than 
when the Policy Master went down, the changes are interpreted as a fault and 
the Policy Master issues commands to bring the VCS One cluster back to the last 
state stored in the configuration database. GTQ entries remain intact.

To do this, the Policy Master reads the configuration database and replays the 
logs to bring VCS One cluster configuration and state information to the most 
current available. 

If there are groups that are planned to go online or offline, then those actions 
are acted upon after the respective host connects to the Policy Master and the 
agents on those hosts probe the resources.

Note: The Policy Master commands vcsoneclientd to perform operations at the 
resource level. The client daemon only knows about resources; service groups 
are a Policy Master construct.

Cold start up mode
When the Policy Master service group starts after a failover or switch to an 
alternate system at a DR site, cold mode is the default action.

This mode is not available on a Windows Policy Master.

In cold start mode, the Policy Master enforces the configuration in the 
configuration database, but does not enforce state information. The Policy 
Master probes all resources on all systems, determines their current state, and 
accepts that state as the correct state. Any existing GTQ entries are eliminated.

See “About the Group Transition Queue” on page 327.

This mode is used when you do not want to treat new state information as a 
fault. For example, when the state of a service group has changed while the 
Policy Master was offline. 
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The following are reasons this could occur:

■ While the Policy Master was offline, the configuration changed. For 
example, a database was taken down and moved to another system using 
database commands outside of the VCS One cluster environment.

■ The Policy Master cluster failed but the systems continued to run. 

■ You want to restore a previous configuration by loading an archived 
configuration database snapshot, and ignore the state information present 
with the snapshot.

See “Starting the Policy Master in Cold mode on UNIX” on page 688.

Accepting the result of the probe as the current state of the VCS One cluster 
means the administrator must manually bring online any service groups that 
are not running when the probe occurs.

Note: A group brought offline manually by the administrator remains offline on 
all subsequent start ups for all Policy Master start up modes until the 
administrator manually brings the group back online.

How the Policy Master loads the VCS One cluster 
configuration

The VCS One cluster configuration is stored in a database.

VCS One supports the following configuration formats:

■ XML — configuration exists in flat files

■ Database — configuration exists in the database

■ CMD — configuration exists in CLI (command line interface) format

VCS One provides a Configuration Manager (CFM) as an abstraction layer that 
provides an interface to load, update, and save the VCS One cluster 
configuration. You can use haconf utility to interface with the Configuration 
Manager and convert configurations from one format to another. 

See Veritas Cluster Server One Command Reference Guide.

Figure 3-1 depicts how the Configuration Manager makes the configuration 
available to the Policy Master.

Figure 3-1 Configuration Manager conversions
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Depending on the operation performed in the VCS One cluster, the VCS One 
configuration flows in the following ways:

■ Initial VCS One startup — The configuration is read from the XML files, is 
written to the database, and an in-memory copy is available with the PM.

XML —> DB —> PM

■ Subsequent VCS One start ups — Once the configuration database is seeded, 
for all subsequent start ups, the configuration is read from the database and 
an in-memory copy is available with the PM.

DB —> PM

■ PM failover — The configuration remains with the database while an 
in-memory copy is written to the failover PM node.

DB —> PM

■ Database backup — The configuration is written to an XML file.

DB —> XML

■ Configuration updates — All configuration updates are written to the 
database. 

PM —> DB

VCS One provides utilities haconf and hadb to interface with the database. 

Configuration Manager (CFM)

haconf Policy 
Master

Configuration 
in CF

Configuration 
in CMD

Configuration 
in XML

Configuration 
in DB
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How the Policy Master and client systems resolve
failures in communication

The Policy Master and the client systems communicate over one designated 
TCP/IP-based primary network, and one or more optional secondary networks. 
If the designated primary network becomes unavailable, the secondary path 
becomes primary. If the primary path is restored, a heartbeat connection is 
established over this path as a standby for the current communication path.

The Policy Master uses communication links to the systems to determine 
membership in the VCS One cluster. Communications over these networks are 
secured using the Symantec Product Authentication Service authentication and 
encryption package.

VCS One cluster membership
Membership in the VCS One cluster is determined by the Policy Master receiving 
a continuous heartbeat signal from a system. Change in membership in the VCS 
One cluster is determined by the loss of heartbeats across all configured 
network links. 

Policy Master detects loss of heartbeat, ping 
command responds
If there is a loss of the heartbeat signal from a client system on all connections 
to the Policy Master, the Policy Master attempts a ping command to the physical 
system to differentiate between a system failure and a vcsoneclientd daemon 
failure. If the system replies to the ping command, this indicates the rare 
situation where the daemon has failed or been shutdown and has not been 
restarted by the vcsoneclientd shadow. 

This special condition is known as Daemon Dead Node Alive (DDNA). In this case, 
the Policy Master does not take corrective action to failover service groups 
running on the suspect system because it is not able to determine the state of 
the resources running on the system. The administrator must intervene to 
verify the service groups are offline on the failed system and manually failover 
the service groups. 

Policy Master detects loss of heartbeat, ping command fails
If there is a loss of the heartbeat signal from the system on all connections, and 
the system does not respond to the ping command from the Policy Master, the 
client system is designated FAULTED. Any configured policy for that system 
pertaining to failover of service groups is performed.
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System detects loss of connection to Policy Master
If a client system detects a failure of its connection to the Policy Master on all 
configured network paths, all agents on the system are put in a QUIESCE state. 
In this state, the agent does not run any entry points, therefore monitoring of 
resources halts. No further action is taken on any resources in service groups 
running locally on the system while the connection is down.

The vcsoneclientd daemon repeatedly sends connection requests to the Policy 
Master to attempt a reconnect. 

Once the daemon reconnects, the actions are as follows:

About Load and Capacity
The Capacity and Load construct allows you to define the amount of assets a 
physical system or PFrame provides (Capacity), and the amount of assets a 
specific service group or VFrame is expected to utilize (Load). 

When a service group or VFrame is brought online, the values attributed to the 
Load of that service group or VFrame are subtracted from the values attributed 
to the Capacity of the physical system or PFrame on which the object is brought 
online. 

The client daemon, 
vcsoneclientd, on the VCS One 
cluster system sends its 
configuration version number 
(CVN) to the Policy Master.

The configuration version number is used to keep track 
of configuration changes for the system. Whenever 
there is a configuration change, both the Policy Master 
and the client system independently increment their 
configuration version number.

The Policy Master compares the 
two configuration version 
numbers.

The Policy Master compares the received CVN to the 
one the Policy Master has stored. The numbers will be 
different if the configuration changed on the Policy 
Master while the connection was down. 

Action depends on whether the 
two configuration version 
numbers match.

If the CVNs match, vcsoneclientd removes the QUIESCE 
state from the agents and probes all the resources.

If the CVNs do not match, the Policy Master clears the 
configuration on the system, which stops all running 
agents. The Policy Master then sends a new 
configuration snapshot to the system. vcsoneclientd 
starts the new set of agents and probes all the 
resources.

The latest state of all resources is 
sent from the client system to 
the Policy Master.

The Policy Master has the state of all service groups and 
can take corrective action if needed.
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If a service group or VFrame object has no Load-related values set, that is, they 
are the default values of zero, then the object can go online on any system for 
which it is configured, provided the compatibility criteria is met.

If a service group or VFrame has a Load value, then it can only go online on a 
system that has a Capacity value defined and sufficient to accommodate the 
Load value.

The Load and Capacity construct is configured using the VCS One cluster 
attribute PrecedenceOrder. The attribute enables definition of up to four 
prioritized keys. The keys are user-configurable, but typically represent CPU, 
memory, network, and storage (I/O) resources. The keys for Capacity and Load 
are always identical.

See “Designing application and virtual machine placement policy” on page 311.

Defining Load and Capacity keys with the PrecedenceOrder
attribute
The default value of the VCS One cluster attribute PrecedenceOrder is as 
follows:

The names and ranking of the four keys can be customized or eliminated. For 
example, using all four keys for PrecedenceOrder may look as follows:

These keys define a relative ranking of Load and Capacity across the VCS One 
cluster. For example, if PrecedenceOrder is defined with two keys, cpu and 
memory, values for the Capacity attribute for two systems in that VCS One 
cluster could be as follows:

PrecedenceOrder CPU

MEM

STBW

NTBW

PrecedenceOrder CPU

MEMORY

STORAGE

NETBANDWIDTH

On sys1: Capacity CPU: 400

MEM: 200



57How VCS One works
About the control of agent versions
These values may indicate that sys1 has four processors, and sys2 has two 
processors, or they may indicate that sys1 has processors that are twice as fast 
as the sys2 processors. These settings could also indicate that sys1 has twice as 
much memory as sys2. As long as the values are consistently relative, the 
measurement remains standardized across the VCS One cluster.

Load and Capacity values are hard values, meaning the values are strictly 
enforced. The total of the Load values of the service groups online on a system 
can not exceed the system’s Capacity value.

The order of precedence of the four attributes affects the calculation of the 
target system to host a service group as well as the calculation of disruption 
factor. 

See “PrecedenceOrder” on page 827.

About the control of agent versions
Each time an agent registers with the Policy Master, the Policy Master checks 
the version of the agent to ensure it meets the requirements of the 
MinCompatAgentVersion attribute. 

See “MinCompatAgentVersion” on page 868.

Note that this check is done when the agent registers. A runtime upgrade of the 
agent type on the Policy Master after the agent registers results in an old agent 
version on the client side. However, the agent will continue to work until the 
agent is restarted and attempts to register with the Policy Master. At that point, 
the Policy Master rejects the agent registration request, and the agent will not 
run on the client. 

In this case, stop the agent and upgrade it.

MinCompatAgentVersion checks may apply to bundled agent, enterprise agents, 
or custom agents.

See the agent-specific documentation for instructions on how to upgrade an 
agent.

About the control of the scheduling class and
scheduling priority of agent operations

Symantec has introduced four new attributes—EPClass, EPPriority, OnlineClass, 
and OnlinePriority—to enable you to control the scheduling class and scheduling 

On sys2: Capacity CPU: 200

MEM: 100
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priority of the agent operations. Agent operations include online, offline and 
monitor. 

The new attributes OnlineClass and OnlinePriority are used to set the 
scheduling class and scheduling priority for the online entry point. 

The new attributes EPClass and EPPriority are used to set the scheduling class 
and scheduling priority for all entry points, except the online entry point.

These attributes provide a single interface to tune the scheduling parameters 
for all entry points. It does not matter if they are implemented as C-based or 
script-based entry points.

It is usually required that the monitor, clean, offline and the other entry points 
running on an application have a higher scheduling class and scheduling 
priority without which they would compete with the application for system 
resources. However, running the online entry point with a higher scheduling 
class and scheduling priority may create problems because applications inherit 
the scheduling parameters from the application vendors, who specify that the 
applications are run using the default operating system scheduling parameters. 
Also, the online entry point is usually invoked before you start the application 
and the system is not very busy.

Hence, you must usually set the values of EPPriority and EPClass attributes to a 
higher value than the default value. You must usually set the value of the 
OnlinePriority and OnlineClass attribute to the default operating system 
scheduling values.

Setting the attribute’s values to zero instructs VCS One to take the operating 
system default value for the particular operating system for which that 
application's type is configured. This value accommodates different operating 
systems that have different default operating system scheduling values. 

You may use only one of the following sets of attributes to configure scheduling 
class and scheduling priority for VCS One:

■ AgentClass, AgentPriority, ScriptClass, ScriptPriority

■ OnlineClass, OnlinePriority, EPClass, EPPriority

How you can configure automated tasks and group 
operations

VCS One allows you to automate administrative tasks based on a schedule or an 
event.
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Schedule
These tasks are initiated by a scheduler. A day, date, time of day, or range of 
time trigger these tasks. You may use automated tasks based on a schedule in 
the following ways: 

Events
The state of objects, such as resources, groups, users, and systems, trigger these 
tasks. You may use automated tasks based on an event in the following ways:

How VCS One provides security in communications
Symantec Product Authentication Service (AT) provides services that 
implement core security mechanisms in VCS One. AT works within the 
configured authentication policy to perform the following operations:

■ Validates the identities of users, as well as the identities of systems, 
connecting to the Policy Master.

■ Gives a credential to any entity whose identity it can validate.

Trigger Task

Every Saturday at 9 A.M. Switch all the applications running on 
server S1 over to server S2

The first Monday of every month Run a script that creates a report.

Between the hours of 6 PM and 6 AM Run the CRM application at a Priority=2

Event Task

A managed application has failed and there 
is no failover target system available

Start a virtual machine and add it to
the applications system list

A system is not available to run an 
application 

Externally connect to a provisioning system 
to allocate a new server

A service group moves to a new node in the 
Organization Tree. 

Check if it was an AIX system.

Send an email notification.

A system is added to the VCS One cluster Update the SystemList attribute of an 
application to include that system, if the 
operating system and extended attributes 
are appropriate.
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■ Sets up secured communications between authenticated entities.

Note: On a Windows Policy Master, the authentication service is named Veritas 
Cluster Server One Product Authentication Service.

VCS One uses AT to authenticate and secure communications between various 
VCS One modules (for example, between the client systems and the Policy 
Master). AT also authenticates users when they log in to the Policy Master or 
VCS One client systems.

VCS One uses digital certificates for authentication and the secure sockets layer 
(SSL) protocol to encrypt communications over the network.

Authenticated and encrypted communications exist between the Policy Master 
and the system, the GUI connection, and the command line interface 
connection.

Each system obtains a different system identity credential that lets the Policy 
Master uniquely identify it. The VCS One client daemon (vcsoneclientd) running 
on the system uses this credential to validate its identity to the Policy Master. 

The system identity credential has privileges associated with it that lets the 
system carry out tasks, such as sending resource state changes to the Policy 
Master.

The Policy Master has the following explicit checks to make sure the 
communication is valid, such as:

■ The Policy Master only allows messages that originate from a system 
identity credential.

■ The Policy Master checks that the message is valid with respect to the 
known configuration.

In VCS One, AT runs as a single daemon process on the active Policy Master 
node. The VCS One Policy Master installer configures AT to run on the active 
Policy Master node.

When you add a new system to the VCS One cluster, components on the system 
use secure socket layer (SSL) protocol to validate their identity with Symantec 
Product Authentication Service in the Policy Master cluster and receive an 
authentication certificate.

This certificate is a type of electronic passport that vouches for the identity of 
its holder and binds the holder to their public key. The certificate is then 
combined with a private key to make a valid credential. The credential allows 
the establishment of a secure session between the client system component and 
the Policy Master.
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After a credential is established, all communication between the client system 
and the Policy Master is encrypted by the sender and decrypted by the receiver. 
Local host communication is not encrypted.
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Chapter
 4
How Veritas Cluster Server 
One works with 
virtualization

This chapter includes the following topics:

■ About how VCS One works with virtualization

■ Overview of virtualization objects in VCS One

■ How VCS One manages a virtualized environment

■ About VFrames

■ About VFrames with linked systems

■ About virtual machine high availability

■ About VFrames and disaster recovery

■ Monitoring VM Kernel Network and Service Console Network



64 How Veritas Cluster Server One works with virtualization
About how VCS One works with virtualization
About how VCS One works with virtualization
VCS One provides flexibility to manage virtual machines as either "black box" 
virtual machines or "application-aware" virtual machines. 

Black box virtual machines allow you to manage (monitor, start, stop, and 
failover) virtual machines in response to a virtual machine or hardware level 
failure. Black box virtual machines do not have any awareness of applications 
running inside the virtual machines. 

Use black-box virtual machines in cases where the application inside the virtual 
machine is not critical enough, or the virtual machine status is a good enough 
indicator of the application status.

Application-aware virtual machines provide everything that a black box virtual 
machine provides plus the added ability to manage the applications running 
inside the virtual machine. 

Use application-aware virtual machines in cases where you want to monitor the 
state of the application inside the virtual machine, start or stop the application, 
failover the application, or fail over the virtual machine in response to an 
application failure.

Overview of virtualization objects in VCS One
Table 4-1 shows the virtualization-based objects used in VCS One.

More detailed information is available about these objects.

See “Components of Veritas Cluster Server One” on page 29.

Table 4-1 Virtualization objects and types

Vtype Description Object type(s) CLI command 
to manage

PFrame A PFrame is a VCS One object that 
represents an operating system that is 
capable of running one or more virtual 
machines.

ESXServer, LDomsServer hapframe

VFrame A VFrame is a VCS One object that 
represents a virtual machine. 

VFrames run on PFrames. VFrames may or 
may not be linked to a system object.

ESXVM, LDomsVM havframe

ManagementConsole Management frame, a management console 
of a certain type of virtual environment.

VMwareVC havobject
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About virtualization type definitions
In the same way that a resource type defines a resource object, a virtualization 
type (Vtype) defines a virtualization object. The type and vtype definitions are a 
template for the attributes and default values for each object. 

For example, a vframe object of VType ESXVM represents a virtual machine in a 
VMware ESX environment. This VFrame object inherits the attributes that are 
defined in the ESXVM VType. As is true with resource type definitions, 
non-static attributes can be overridden. Resources that can be configured in a 
VFrame of type ESXVM are defined in the types.esx.xml file.

Resources that can be configured in a VFrame of type LDomVM are defined in 
the types.sun.xml file.

Virtualization types are defined in the vtypes.xml file.

About virtualization application management
For technologies that support Live Migration, such as VMware, you can trigger 
the migration through VCS One.

When using the AWM feature of VCS One, the Priority attribute of the virtual 
machine is derived from the Priority of the service groups running on the virtual 
machine. You may configure VCS One to kick out lower priority virtual 
machines in order to host higher priority ones in a resource-constrained 
environment.

See “About Priority” on page 316.

The Priority of a VFrame is equal to the highest value of the Priority attribute of 
all the service groups that are configured to run on that VFrame.

Priority of VFrame = max(priority of service groups configured on vframe)

System A system is a VCS One object that 
represents an operating system that is not 
capable of running one or more virtual 
machines

A system object can run on a physical server 
or a VFrame. 

System hasys

Table 4-1 Virtualization objects and types

Vtype Description Object type(s) CLI command 
to manage
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How VCS One manages a virtualized environment
In all VCS One environments, a managed application is encapsulated in a service 
group, and the service group runs on a system.

A system in VCS One is an object that represents an operating system that is not 
capable of running virtual machines.

VCS One manages the start, stop, and monitoring of VFrames and PFrames in 
much the same way it manages service groups, system objects, and physical 
systems. VCS One policy determines what actions to take in the case of faults of 
the application, the virtual machine, or the physical system.

About VFrames
A VFrame is an object in the VCS One configuration that corresponds to a virtual 
machine. VFrames are categorized by the visibility and control that VCS One has 
over the applications running inside the virtual machine, as follows:

■ Application-aware VFrame

The application-aware VFrame is used to manage virtual machines that 
host applications.

Specifically, it is a VFrame that is linked to a system object. This allows the 
user to host service groups on these system objects, and create failover 
policies for these service groups. 

See “VFrame level control” on page 264.

■ Black-box VFrame

The black-box VFrame is used to manage the virtual machine itself and not 
applications running inside the virtual machine.

A Black-box VFrames may have one of the following characteristics.

■ A VFrame that is not linked to a system object.

■ A Vframe that has a system object linked to it, but the system object is 
categorized as operating system type "not known."

The following bullets outline the theory of operations of a VFrame object in VCS 
One:

■ The VFrame is added to the VCS One configuration.

See “Adding a VFrame” on page 507.

When a VFrame is first added, it is a black box VFrame without a linked 
system. The black box VFrame is used when VCS One manages the virtual 
machine itself. A VCS One user can not view any applications running 
inside a black box VFrame. Likewise, VCS One does not manage applications 
running inside a black box VFrame.
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■ You may link a system to the black box VFrame. The link can be a manual or 
automatic process. 

The VType attribute EnableAutoLinkSys configures VCS One to 
automatically link a system object to a VFrame, and is set by default. 

See “EnableAutoLinkSys” on page 905.

The Platform attribute of a system that is autolinked to a newly created 
VFrame is “unidentified.”

See “PlatformName” on page 906.

In virtual environments, a linked system object can be one of the following 
types:

■ Managed systems

A system that has a valid value for its Platform attribute, and the value 
does not equal “unidentified.” A user may not modify a system object 
using hasys commands until it becomes managed system.

■ Unmanaged system

A system object that has a the value “unidentified” for the Platform 
attribute, and does not have the vcsoneclientd client daemon running.

■ You may install and start vcsoneclientd on the linked system.

When vcsoneclientd is installed in the VFrame, the system becomes a 
managed system. The client daemon performs the following actions:

■ Populates the Platform attribute of the system to reflect the actual 
operating system installed. 

■ Populates the NetHwAddr key of the SysInfo attribute with the MAC 
address of the network interface that is used for communication with 
the Policy Master. This information helps the Policy Master to 
determine if the system is running on a VFrame. 

■ A VFrame with a linked, managed system may run service groups. The 
service group may only have the one managed system listed in their 
SystemList attribute.

See “SystemList” on page 857.

Additionally, the Priority, Load and Capacity features become relevant in a 
VFrame with a linked, managed system.

See “About virtual machine high availability” on page 68.

About VFrames with linked systems
When EnableAutoLinkSys is set to one, each VFrame in the configuration has a 
system object automatically linked to it. The name of the system is determined 
by the following convention:
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■ If there does not already exist a system with the same name as the VFrame, 
VCS One creates and links an unmanaged system to the VFrame. The 
unmanaged system object has the same name as the VFrame.

See “About the names of your VCS One cluster objects and attributes” on 
page 240.

If VCS One detects that a system object that represents the operating 
system instance in the VFrame exists in the configuration, VCS One links 
that VFrame with that system object. 

■ If there already exists a system with the same name as the VFrame, VCS One 
does not create and link an unmanaged system.

You can not add an auto-linked system to a SystemList until it has a valid value 
for its PlatformName attribute. The PlatformName attribute is populated when 
the user configures a system object representing the operating system instance 
that runs in that Vframe.

Instructions are available to install the client daemon on the VFrame.

See the Veritas Cluster Server One Installation Guide.

In the simulator, the EnableAutoLinkSys attribute is not active, and auto-linking 
does not occur. The user needs to manually link systems and vframes.

About virtual machine high availability
Virtual machine high availability (VMHA) policy determines the actions taken 
during application or virtual machine fail over. This policy may affect one or 
more of the following: the service group, the VFrame, and the corresponding 
linked system object.

A VFrame must have a linked system to be part of the high availability policy.

The UseForPolicy key of the system attribute LinkedVFrame determines 
whether VMHA policy is enabled.

See “LinkedVFrame” on page 843.

See “Configuring VFrame high availability” on page 513.

If VMHA policy is enabled, the following rules apply:

■ The service group running on a VFrame can only have one system in the 
SystemList, and that system is linked to the VFrame.

■ The application and the virtual machine fail over together to another 
PFrame.

This operation requires that the PropagateFaultPolicy attribute of the 
service group is set to Propagate.

■ The Capacity of the system object equals the sum of the Load of service 
groups configured on the System object.



69How Veritas Cluster Server One works with virtualization
About VFrames and disaster recovery
■ The Capacity of the system object equals the Load of the linked VFrame.

■ The Priority of the linked VFrame equals the maximum Priority value of 
configured service groups on the system object.

The fail over may be one of the following types:

■ Local to the cluster

See “Designing actions taken after a fault” on page 259.

■ Remote to a disaster recovery site.

Only global composite service groups can migrate or switch to a remote 
cluster. A VFrame must be part of a CSG in order to move to a remote 
cluster.

See “About VFrames and disaster recovery” on page 69.

About VFrames and disaster recovery
You can configure VCS One to be able to fail over the application and its virtual 
machine to a disaster recovery site. 

See “How VCS One disaster recovery works in virtual environments” on page 82.

Each virtualization technology has a slightly different process to implement 
disaster recovery for a Vframe object.

See “About setting up virtual machines for disaster recovery” on page 586.

Monitoring VM Kernel Network and Service Console 
Network

You can use an infrastructure service group to enable monitoring of VM Kernel 
Network and Service Console Network on a PFrame.

To enable monitoring of VM Kernel Network and Service Console Network 
using the VCS One console

1 Create an infrastructure service group.

2 Add the PFrame on which you want to enable monitoring of VM Kernel 
Network and Service Console Network.

3 Add ESXVSwitch resources corresponding to each network to the 
infrastructure service group.

4 Populate the VSName attribute of each of the resources with the vSwitch 
name on which the networks are configured.
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5 Add resource of type Phantom to the infrastructure service group so that 
the resource states get propagated to the group state.

6 Probe all resources of the infrastructure service group on the PFrame—the 
service group should come online.

Now, if one of the resources corresponding to the networks faults, then the 
state of the service group will reflect the proper state of the network.

For additional information about VM Kernel Network and Service Console 
Network, refer to the VMWare documentation.

Sample of the main.xml
The following text is an example from the main.xml file of a setup on which 
monitoring has been enabled for VM Kernel Network and Service Console 
Network.
<group name="rhel5vm1_monitor_isg">
  <attributes>
    <attribute name="CompatibleGroups">
      <val key="ALLGROUPS"></val>
    </attribute>
    <attribute name="Enabled" context = "vcslx309.example.com">   
      <scalar>1</scalar>
    </attribute>
    <attribute name="Load">
      <val key="CPU">0</val>
      <val key="MEM">0</val>
    </attribute>
    <attribute 
name="PlatformName"><scalar>"esx"</scalar></attribute>
    <attribute name="SystemList">
      <val key="vcslx309.example.com">0</val>
    </attribute>
    <attribute name="UserIntLocal" context = "vcslx309.example.com">
      <scalar>0</scalar>
    </attribute>
    <attribute name="UserStrLocal" context = "vcslx309.example.com">  
    </attribute>
    </attributes>
    <resources>
      <resource name="Service_Console" type="ESXVSwitch">
        <attribute name="VSName" context = "vcslx309.example.com">
         <scalar>"vSwitch0"</scalar></attribute>
      </resource>
      <resource name="VM_Kernel" type="ESXVSwitch">
        <attribute name="VSName" context = "vcslx309.example.com">  
          <scalar>"vSwitch2"</scalar></attribute>
      </resource>
      <resource name="dummy" type="Phantom"></resource>
      </resources>
</group>
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Chapter
 5
How VCS One global 
clusters work

This chapter includes the following topics:

■ About VCS One global clusters

■ About global cluster building blocks

■ Typical VCS One global cluster setup

■ How global clusters work
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About VCS One global clusters
A VCS One global cluster links the individual VCS One clusters at separate sites, 
and enables wide-area failover and disaster recovery (DR) for the applications 
you configured. A VCS One global cluster configuration can have a maximum of 
two clusters. Clustering on a global level also requires an infrastructure to 
replicate the application data between these clusters.

Local clustering provides local failover within a site. Large-scale disasters such 
as major floods, hurricanes, and earthquakes can cause outages for an entire 
city or region. In such situations, with global clustering you can migrate 
applications to a different site that is located at a considerable distance away to 
ensure application and data availability.

In a global cluster environment, VCS One failover behavior is as follows:

■ If an application or a virtual machine fails on a system within a cluster, VCS 
One fails over the faulted application or virtual machine to another system 
within the same cluster.

■ If an application or a virtual machine fails on all systems within a cluster or 
if the entire cluster fails, VCS One provides the capability to fail over the 
application or the virtual machine in that cluster to a system in another 
cluster.

See “About setting up VCS One global clusters” on page 580.
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About global cluster building blocks
VCS One extends clustering concepts to wide-area high availability and disaster 
recovery with the following components:

VCS One clusters Each site must have a VCS one cluster configured with a unique 
cluster name.

Wide-area network links The VCS One clusters must have redundant wide-area network 
(WAN) connections between them for inter-cluster 
communication.

Storage arrays for data 
replication

Storage arrays at each site must replicate the application data 
to the other site using a technology that Symantec supports. 
The storage arrays must meet the requirements of the 
corresponding replication technology. 

For example, you must configure EMC SRDF replication on the 
symmetrix arrays at each site.

Remote cluster objects A remote cluster object must be defined at each site to 
represent the VCS One cluster at the other site.

Global composite service 
group (CSG)

A global CSG must be defined for each application for which 
you want to enable disaster recovery. A global CSG is a CSG 
with additional properties to enable wide-area failover. A 
global CSG requires that you specify the remote clusters on 
which the CSG can run in addition to the local cluster.

VCS One disaster recovery setup must meet the following 
conditions:

■ A CSG with the same name must exist on all sites.

■ The list of clusters on which the CSG can run must be the 
same on all sites.

See “About composite service groups” on page 35.

VCS One replication 
agents

The appropriate VCS One replication agent must be installed at 
each site.

For example, if EMC SRDF replication is configured, then the 
VCS One agent for EMC SRDF is installed at each site.

VCS one provides agents for supported replication 
technologies. These agents are available in the Veritas High 
Availability Agent Pack software.

See the Veritas High Availability Agent Pack Getting Started 
Guide for a list of replication technologies that VCS One 
supports.

Contact your sales representative for more details. 
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Typical VCS One global cluster setup
Figure 5-1 depicts a typical VCS One global cluster setup. The example setup 
shows two VCS One clusters seattle and tucson.

Figure 5-1 Typical two-site VCS One global cluster setup

For VCS One global cluster setup in virtual environments, see Figure 5-3‚ 
”Typical two-site VCS One global cluster setup in virtual environments.”
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Review the following sections to understand how global clusters work:

■ How VCS One global clusters communicate with each other

■ How VCS One enables wide-area failover of an application

■ How VCS One determines the state of a multi-tier application

■ How VCS One resolves authority for application that spans clusters

■ How VCS One disaster recovery works in virtual environments

■ How VCS One responds to various disasters

How VCS One global clusters communicate with each other
In a VCS One global cluster environment, each cluster must have a remote 
cluster object that represents the cluster at the remote site. Based on the local 
and remote cluster names you provide during configuration, VCS One 
designates one of the clusters as Initiator and the other as Acceptor. The 
Initiator is responsible to initiate DR connections to the Acceptor. VCS One 
stores this connection role information of the remote cluster in the 
ConnectionRole attribute of the remote cluster object at each site.

Figure 5-2 illustrates the correlation between the cluster and the remote cluster 
objects.



78 How VCS One global clusters work
How global clusters work
Figure 5-2 Cluster and remote cluster objects in a global cluster setup

VCS One clusters listen for incoming connections from the remote clusters on 
an IP address and port that are defined in the cluster-level attributes DRAddress 
and DRListeningPort. If DRAddress attribute is not defined, then VCS One uses 
the IP addresses defined in the ClusterAddress attribute for inter-cluster 
communication in addition to the communication between the Policy Master 
and the client systems. If a port is not defined in the attribute DRListeningPort, 
VCS One uses the default port number 14151 to listen for incoming connections. 

VCS One clusters communicate with each other over the wide-area network 
links that you configure. Symantec recommends that you set up at least two 
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network links for cluster communication in a global cluster environment. This 
network link information in the form of IP addresses is specified in the 
NetworkConnections attribute of the remote cluster. The Initiator connects to 
the remote cluster (designated as the Acceptor) on IP addresses specified in the 
NetworkConnections attribute of that remote cluster. Similarly, the Initiator 
connects to the port specified in the DRPort attribute of the remote cluster.

VCS One uses Symantec Product Authentication Service (AT) for authentication 
and secure communication. In a global cluster setup, the local and the remote 
clusters must have an explicit trust relationship for VCS One to successfully 
establish connection between the clusters.

The EnableConnections attribute of the remote cluster controls the connectivity 
between the Initiator and Acceptor clusters. After you enable connections 
between the clusters by setting the EnableConnections attribute, VCS One 
initiates connections on all IP addresses specified in the NetworkConnections 
attribute of the remote cluster. The first network connection link that 
establishes connection with the remote cluster is the primary link. VCS One 
exchanges snapshots of global cluster objects on the primary link. 

VCS One maintains persistent connections on all links and periodically sends 
heartbeats on all links to monitor the health of the remote cluster. If a primary 
link fails, VCS One fails over to any available secondary link for primary 
communications. If all network links fail, VCS One transitions the remote 
cluster state as FAULTED.

How VCS One enables wide-area failover of an application
Each application for which you want to enable disaster recovery must belong to 
a composite service group (CSG). For multi-tier applications, you can configure 
each tier in the application as separate service group in the VCS One cluster 
configuration. The CSG is a collection of such related service groups to enable 
you to perform operations on the multi-tier application as a whole. 

In a VCS One global cluster setup, you must configure the CSG as a global CSG. A 
global CSG spans multiple clusters. The CSG-level attribute ClusterList 
represents the names of all clusters where a CSG can potentially fail over to. 

A CSG is the smallest unit of failover across clusters. The Policy Master 
exchanges pertinent information about the global CSG only with the other 
clusters that the CSG is defined on. The attributes in a global CSG that are 
exchanged between the clusters are ClusterList, Authority, CSGState, and 
InTransition.

See “Composite service group attributes” on page 831.
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How VCS One determines the state of a multi-tier application
The state of a CSG represents the state of the multi-tier application in the 
cluster. VCS One uses the cluster-wide state of each group in the CSG to 
determine the state of the CSG. A CSG can have the following states and is 
stored in the CSG-level attribute CSGState:

■ ONLINE—All groups are online

■ PARTIAL—Some groups are online or partial

■ OFFLINE—All groups are offline

VCS One sets the ATTN and PENDING flags for the CSG in the following 
situations:

The value of the CSGState attribute can be a combination of the flags and the 
state values. For example, ONLINE | ATTN, OFFLINE | PENDING, or PARTIAL | PENDING | 
ATTN.

See “Composite service group attributes” on page 831.

How VCS One resolves authority for application that spans clusters
The CSG-level attribute Authority designates which cluster has the right to 
bring a global CSG online in a global cluster setup. VCS One uses this attribute to 
prevent a multi-tier application from coming online in multiple clusters at the 
same time.

When you set up global clusters, the clusters initially do not have authority for 
the CSG. The Authority attribute is a non-editable attribute; user-initiated 
actions seed authority for the CSG. The cluster where you perform an online 
operation or a request authority operation for the CSG gets the authority for the 
CSG. The Policy Master negotiates authority for the global CSG with the other 
clusters it is connected to.

ATTN flag

(Requires user 
intervention)

■ A group in the CSG is unable to go online on any system in 
the VCS One cluster.

■ A group in the CSG is faulted on all systems in the cluster.

■ CSG is online or partially online on more than one cluster.

■ CSG state is stale. For example, when the Policy Master 
restarts in warm mode (normal mode), the state of the groups 
is not up-to-date because the Policy Master reads the 
configuration information from the VCS One database.

PENDING flag ■ A resource or group in the CSG is in transition on any system 
within the cluster.
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VCS One automatically resolves authority for a global CSG when the CSG state 
changes on any of the clusters. 

When the Policy Master starts up in the warm (normal) mode, it restores the 
configuration with the state information stored in the database. However, the 
information in the database might not be up-to-date as a CSG takeover 
operation could have been initiated at the remote site. So, the Policy Master does 
the following to reconcile the state changes before it resolves authority for the 
global CSGs:

■ Marks the state of the global CSGs that are not in a clean OFFLINE state as 
STALE and sets the ATTN flag.

■ Waits to establish connection with other remote clusters that the global CSG 
is defined on.

If a remote cluster is unreachable, the Policy Master waits until the time as 
defined in the cluster-level attribute DRStaleStateTimeout.

■ Clears the STALE state of the global CSGs after the connection is established 
or the time-out expires.

The Policy Master does not clear the STALE state of the global CSG if it 
detects a concurrency violation for the global CSG. You must resolve the 
concurrency violation for the Policy Master to proceed.

See “Policy Master start up modes” on page 50.
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How VCS One disaster recovery works in virtual environments
In virtual environments such as LDoms and ESX servers, VCS One disaster 
recovery works similar as that in physical environments. Additionally, in the 
virtual environments where the boot image of the virtual machine is replicated, 
during disaster recovery, VCS One brings up the virtual machine on the 
secondary site and reconfigures the network details based on what you provided 
during the initial setup.

VCS One virtualization objects include:

■ PFrame object—a system which is capable of running one or more virtual 
machines

■ VFrame object—a virtual machine

See “Overview of virtualization objects in VCS One” on page 64.

In a global cluster environment, each VFrame object must be configured with 
the network details for that site and each virtual machine must have the 
VRTSvcsnr package installed. During a site failover, the network 
reconfiguration service (vcs-net-reconfig) that is installed with the VRTSvcsnr 
package updates the network configuration files based on the network details 
you provided. The global CSG typically contains the following VCS One objects 
that enables wide-area failover:

■ VFrames

■ Infrastructure Service Group (ISG)—includes the replication resource that 
the VFrame depends on, and any other resources common across VFrames.

■ Application service groups—service groups for VCS One-managed 
applications that run inside the VFrames.
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Figure 5-3 depicts a typical VCS One global cluster setup in virtual 
environments. 

Figure 5-3 Typical two-site VCS One global cluster setup in virtual 
environments
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How VCS One responds to various disasters
VCS One triggers a BPA event each time the state of a remote cluster changes 
from RUNNING. VCS One also triggers a BPA event each time a global CSG faults 
or requires administrative attention (ATTN flag).

Figure 5-4 presents a diagnosis flow and basic recovery methods for the various 
disasters. 

See Table 5-1‚ ”Failure scenarios in VCS One global clusters” for detailed failure 
description, and for the procedures on how to recover and how to fail back.
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Figure 5-4 Diagnosing failures and recovering from disasters
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Table 5-1 lists the possible failure scenarios and how to recover from these 
failures in a VCS One global cluster environment.

Table 5-1 Failure scenarios in VCS One global clusters

Failure and description Recovery and failback procedure

Total site failure:

VCS One cluster at the primary site 
fails:

■ The Policy Master cluster at 
the primary site fails. 

■ All client systems and their 
storage at the primary site fail.

The Policy Master at the secondary site marks the primary site’s VCS One 
cluster state as FAULTED|LINK_DOWN, and triggers a BPA event.

To recover from a total site failure

1 Verify that the primary site has indeed suffered an outage or disaster.

2 Take over the global CSG at the secondary site. 

See “Taking over a global CSG” on page 619.

To fail back to the primary site after a total site failure

1 If you restore the primary site after an extended outage, then restart 
the Policy Master at the primary site in the cold mode.

See “Starting the Policy Master in Cold mode on UNIX” on page 688.

2 If you restore the primary site after a brief outage, then restart the 
Policy Master at the primary site in the warm mode.

When the primary site has been restored, the Policy Master at the 
primary site faults all the service groups that were previously online. 
The service group state is FAULTED and the global CSG state is 
OFFLINE|ATTN.
See “Policy Master start up modes” on page 50.
See “How VCS One resolves authority for application that spans 
clusters” on page 80.

Partial site failure (Policy Master 
cluster failure):

■ The Policy Master cluster at 
the primary site fails. 

■ The client systems and their 
storage at the primary site are 
functional.

The Policy Master at the secondary site marks the primary site’s VCS One 
cluster state as FAULTED|LINK_DOWN, and triggers a BPA event.

Note: Application is still online on the client systems in such a partial 
failure scenario. So, do not attempt to take over the global CSG at the 
secondary site.

To recover from a Policy Master cluster failure

1 Determine the reason for the Policy Master cluster failure.

2 Start the Policy Master cluster in the warm mode at the primary site.
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Partial site failure (client systems 
failure, storage failure, or 
application failure)

■ The Policy Master cluster at 
the primary site is functional. 

■ One or more of the following 
failures occur at the primary 
site:
- Storage for the client systems 
fails.
- The client systems and their 
storage fail.
- Application fails on all the 
client systems.

The Policy Master at the primary site sets the ATTN flag for the CSGs, and 
marks the state of the associated service groups as FAULTED.

Note: If the application fails on one of the client systems at the primary 
site, VCS One fails the application over to another client system within the 
same VCS One cluster.

To recover from a partial site failure

1 If the client systems have failed, check if a network partition exists 
between the Policy Master and the client systems at the primary site. 
Fix any network issues.

2 For all other failures, fix the problem locally and bring the global CSG 
online at the primary site.

3 If you cannot succeed in step 2, then bring the global CSG online on 
the secondary site.

See “Bringing a global CSG online” on page 616.

To fail back to the primary site after a partial site failure

1 If you have set up data replication, then ensure that the data at the 
primary is up-to-date with the secondary.

2 If the data is not up-to-date, use the replication agent’s update action 
to synchronize the data.

Refer to the replication agent guide for details.

3 Switch back the global CSG to the primary site.

See “Switching a global CSG” on page 618.

Policy Master node failure:

One of the nodes in the Policy 
Master cluster at a site fails

When one node in the Policy Master cluster fails, VCS One brings the Policy 
Master online on the standby node. When the Policy Master is fully up and 
running on the standby node at the primary site, the cluster state changes 
to RUNNING.

To recover from a Policy Master node failure

■ Determine the reason for the Policy Master node failure and fix the 
issue.

Table 5-1 Failure scenarios in VCS One global clusters

Failure and description Recovery and failback procedure
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Complete network link failure:

All the network links between the 
two VCS One clusters fail.

During such network partitions, VCS One in each cluster marks the state of 
the remote cluster as FAULTED|LINK_DOWN. The status of each network link is 
DOWN.

To recover from a complete network link failure

1 Determine the reason for the network partition.

2 Fix the network links.

Note: Symantec recommends you to not take over the CSGs in such a 
failure.

Partial network link failure:

One or more network links to the 
remote cluster is down.

When a network link to the remote cluster fails, VCS One marks the state of 
this link as DOWN. The state of the VCS One cluster is RUNNING | 
LINK_PARTIAL.

Symantec recommends that you configure multiple network links for 
resilience. When the primary link fails, VCS One automatically fails over to 
any active secondary link. VCS One periodically attempts to initiate 
connection over the network links that you have defined. 

To recover from a partial network link failure

■ Fix the faulted network links.
When the link comes up, VCS One automatically establishes the 
communication link and exchanges heartbeats with the remote 
cluster.

Replication link failure:

Replication link between the storage 
at the two sites fail

The application is still available at the primary site and so the CSG state 
does not change.

The replication resource’s ResourceInfo attribute indicates the replication 
link failure and that the data replication is not in progress.

To recover from a replication link failure

1 Fix the replication link.

2 Restart the replication. 

Refer to the replication agent guide for details.

Table 5-1 Failure scenarios in VCS One global clusters

Failure and description Recovery and failback procedure
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How the UNIX Policy 
Master cluster operates

This chapter includes the following topics:

■ About protecting data in the VCS One cluster

■ About communications in the Policy Master cluster

■ About membership in the Policy master cluster

■ About membership arbitration in the Policy Master cluster

■ About data protection in the Policy Master cluster using SCSI-3 storage

■ How I/O fencing works

■ Best practices for Policy Master cluster communications
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About protecting data in the VCS One cluster
When systems in the VCS One cluster share storage devices, you can configure a 
protection mechanism to eliminate multiple simultaneous access to the storage. 
When failover occurs, the system that is the failover target for the service group 
blocks access to the shared data resources from other systems. 

The default protection mechanism is SCSI-3 Persistent Reservations 
implemented by Veritas Volume Manager. You may also designate and 
configure other forms of data protection, such as SAN fabric zoning and LUN 
masking.

About communications in the Policy Master cluster
The Policy Master cluster is kept highly available by the use of Veritas Cluster 
Server (VCS) software. VCS uses local communications on a system and 
system-to-system communications.

About communications between systems in the Policy Master cluster
Each system in the Policy Master cluster runs the VCS High Availability Daemon 
(HAD), which is the decision logic for the Policy Master cluster. HAD uses a 
VCS-specific communication protocol known as Inter Process Messaging (IPM) 
to communicate with the GUI, the command line, and the agents in the Policy 
Master cluster. 

Figure 6-1 shows basic communication on a single VCS system. 

Figure 6-1 Communication on a single VCS system

Figure 6-2 depicts communication from a single agent to HAD.

AGENT COMMAND-LINE 
UTILITIES

VCS HIGH AVAILABILITY DAEMON (HAD)

AGENT VCS GUI
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Figure 6-2 Communication between HAD and an agent

The agent uses the agent framework, which is compiled into the agent itself. For 
each resource type configured in a VCS One cluster, an agent runs on each client 
system. The agent handles all resources of that type. The engine passes 
commands to the agent and the agent returns the status of command execution. 
For example, an agent is commanded to bring a resource online. The agent 
responds back with the success (or failure) of the operation. Once the resource is 
online, the agent communicates with the engine only if this status changes.

About inter-system Policy Master cluster communications
VCS uses the Policy Master cluster interconnect for network communications 
between Policy Master cluster systems. Each system runs as an independent 
operating system and shares information at the Policy Master cluster level. On 
each system the VCS High Availability Daemon, (HAD), maintains a view of the 
Policy Master cluster configuration. This daemon operates as a replicated state 
machine, which means all systems in the Policy Master cluster have a 
synchronized state of the Policy Master cluster configuration. 

This synchronized state is accomplished by the following design:

■ All systems run an identical copy of HAD. 

■ HAD on each system maintains the state of its own resources, and sends all 
Policy Master cluster information about the local system to all other 
machines in the Policy Master cluster.

■ HAD on each system receives information from the other Policy Master 
cluster systems to update its own view of the Policy Master cluster. 

■ Each system follows the same code path for actions on the Policy Master 
cluster. 

The replicated state machine communicates over a purpose-built 
communications package consisting of two components, Group Membership 
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Services/Atomic Broadcast (GAB) and Low Latency Transport (LLT). Figure 6-3 
illustrates the overall communications paths between two systems using the 
replicated state machine model.

Figure 6-3 Policy Master cluster communications with replicated state 
machine

Group Membership Services/Atomic Broadcast (GAB)
The Group Membership Services/Atomic Broadcast protocol (GAB) is 
responsible for Policy Master cluster membership and reliable Policy Master 
cluster communications. 

GAB has the following major functions.

■ Policy Master cluster membership

GAB maintains Policy Master cluster membership by receiving input on the 
status of the heartbeat from each system via LLT. When a system no longer 
receives heartbeats from a Policy Master cluster peer, LLT passes the 
heartbeat loss to GAB. GAB marks the peer as DOWN and excludes it from the 
Policy Master cluster. In most configurations, membership arbitration is 
used to prevent network partitions.

■ Policy Master cluster communications

GAB provides reliable Policy Master cluster communications with 
guaranteed delivery of messages to all Policy Master cluster systems. The 
Atomic Broadcast functionality is used by HAD to ensure that all systems in 
the Policy Master cluster receive all configuration change messages, or are 
rolled back to the previous state, much like a database atomic commit. 
Although the communications function in GAB is known as Atomic 
Broadcast, no network broadcast traffic is generated. An Atomic Broadcast 
message is a series of point-to-point unicast messages from the sending 
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system to each receiving system, with a corresponding acknowledgement 
from each receiving system.

Low Latency Transport (LLT)
The Low Latency Transport protocol is used for all Policy Master cluster 
communications as a high-performance, low-latency replacement for the IP 
stack. 

LLT has the following major functions.

■ Traffic distribution

LLT provides the communications backbone for GAB. LLT distributes (load 
balances) inter-system communication across all configured network links. 
This distribution ensures all Policy Master cluster communications are 
evenly distributed across all network links for performance and fault 
resilience. If a link fails, LLT redirects traffic to the remaining links. A 
maximum of eight network links are supported.

■ Heartbeat

LLT sends and receives heartbeat traffic over each configured network link. 
LLT heartbeat is an Ethernet broadcast packet. This broadcast heartbeat 
method lets a single packet notify all other Policy Master cluster members 
that the sender is functional, as well as provide necessary address 
information for the receiver to send unicast traffic back to the sender. The 
heartbeat is the only broadcast traffic generated by VCS. Each system sends 
two heartbeat packets per second per interface. All other Policy Master 
cluster communications, including all status and configuration traffic is 
point-to-point unicast. This heartbeat is used by the Group Membership 
Services to determine Policy Master cluster membership.

The heartbeat signal is defined as follows: 

■ LLT on each system in the Policy Master cluster sends heartbeat packets out 
on all configured LLT interfaces every half second.

■ LLT on each system tracks the heartbeat status from each peer on each 
configured LLT interface.

■ LLT on each system forwards the heartbeat status of each system in the 
Policy Master cluster to the local Group Membership Services function of 
GAB. 

■ GAB receives the status of heartbeat from all Policy Master cluster systems 
from LLT and makes membership determination based on this information. 

Figure 6-4 shows the flow of the heartbeat in the Policy Master cluster
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Figure 6-4 Heartbeat in the Policy Master cluster

You can configure LLT to designate specific Policy Master cluster interconnect 
links as either high priority or low priority. High priority links are used for 
Policy Master cluster communications to GAB as well as heartbeat signals. Low 
priority links, during normal operation, are used for heartbeat and link state 
maintenance only, and the frequency of heartbeats is reduced to 50% of normal 
to reduce network overhead. 

If all configured high priority links fail, LLT switches all Policy Master cluster 
communications traffic to the first available low priority link. Communication 
traffic returns to the high priority links when they become available. 

While not required, best practice recommends to configure at least one low 
priority link, and to configure two high priority links on dedicated Policy Master 
cluster interconnects to provide redundancy in the communications path. Low 
priority links are typically configured on the public or administrative network. 

About membership in the Policy master cluster
The current members of the Policy Master cluster are the systems that are 
actively participating in the Policy Master cluster. It is critical for HAD to 
accurately determine current Policy Master cluster membership in order to take 
corrective action on system failure and maintain overall Policy Master cluster 
topology.
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A change in Policy Master cluster membership is one of the starting points of 
the logic to determine if HAD needs to perform any fault handling in the Policy 
Master cluster.

There are two aspects to Policy Master cluster membership: initial joining of the 
Policy Master cluster and how membership is determined once the Policy 
Master cluster is up and running.

Initial joining of systems to the Policy Master cluster membership
When the Policy Master cluster initially boots, LLT determines which systems 
are sending heartbeat signals, and passes that information to GAB. GAB uses 
this information in the process of seeding the Policy Master cluster 
membership.

Seeding ensures a new Policy Master cluster starts with an accurate 
membership count of the number of systems in the Policy Master cluster. This 
prevents the possibility of one Policy Master cluster splitting into multiple 
sub-clusters upon initial startup. 

The following process seeds a new Policy Master cluster:

■ When the Policy Master cluster initially starts, all systems in the Policy 
Master cluster are not yet seeded. 

■ GAB checks the number of systems that have been declared to be members 
of the Policy Master cluster in the /etc/gabtab file.

The number of systems declared in the Policy Master cluster is denoted as 
follows:
/sbin/gabconfig -c -n# 

where the variable # is replaced with the number of systems in the Policy 
Master cluster. 

Note: This number should represent 100% of the systems in the Policy 
Master cluster

■ When GAB on each system detects that the correct number of systems are 
running, based on the number declared in /etc/gabtab and input from LLT, 
it seeds.

■ HAD starts on each seeded system. HAD only runs on a seeded system.

Manual seeding of a Policy Master cluster
Seeding the Policy Master cluster manually is appropriate when there are more 
Policy Master cluster systems declared in /etc/gabtab than will join the Policy 
Master cluster. This could occur if a system is down for maintenance when the 
Policy Master cluster starts. 
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Caution: Do not seed the Policy Master cluster manually unless you are aware of 
the risks and implications of the command.

Before manually seeding the Policy Master cluster, check that systems that will 
join the Policy Master cluster are able to send and receive heartbeats to each 
other. Confirm there is no possibility of a network partition condition in the 
Policy Master cluster.

There is no declaration of the number of systems in the Policy Master cluster 
with a manual seed. The command seeds all systems that are in communication 
with the system where the command is run. 

Ongoing Policy Master cluster membership
Once the Policy Master cluster is up and running, a system remains an active 
member of the Policy Master cluster as long as peer systems receive a heartbeat 
signal from that system over the Policy Master cluster interconnect. 

A change in Policy Master cluster membership is determined in the following 
way:

■ When LLT on a system no longer receives heartbeat messages from a system 
on any of the configured LLT interfaces for a predefined time, LLT informs 
GAB of the heartbeat loss from that specific system. 

This predefined time is 16 seconds by default, but can be configured. It is set 
with the set-timer peerinact command as described in the /etc/llttab 
manual page. 

■ When LLT informs GAB of a heartbeat loss, the systems that are remaining 
in the Policy Master cluster coordinate to agree which systems are still 
actively participating in the Policy Master cluster and which are not. This 
happens during a 
5-second period known as “GAB Stable Timeout.” 

VCS has specific error handling that takes effect when the systems do not 
agree.

■ GAB marks the system as DOWN, excludes the system from the Policy 
Master cluster membership, and delivers the membership change to the 
fencing module.

■ The fencing module performs membership arbitration to ensure that only 
one functional cohesive Policy Master cluster continues to run. 

The fencing module is turned on by default. 
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About membership arbitration in the Policy Master 
cluster

Membership arbitration is necessary on a perceived membership change 
because systems may falsely appear to be down. When LLT on a system does not 
receive heartbeat messages from another system on any configured LLT 
interface, GAB marks the system as DOWN. However, if the Policy Master 
cluster interconnect network fails, a system can appear to be failed when it is 
not. In most environments when this happens, it is caused by an insufficient 
Policy Master cluster interconnect network infrastructure, usually one that 
routes all communication links through a single point of failure. 

If all the Policy Master cluster interconnect links fail, one Policy Master cluster 
can separate into two sub-cluster, each of which does not know about the other. 
The two sub-cluster could each carry out recovery actions for the departed 
systems. This is termed split brain. 

In a split brain condition, two systems could try to import the same storage and 
cause damage, have an IP address up in two places, or mistakenly run an 
application in two places at once.

Membership arbitration prevents split brain conditions.

Components of membership arbitration
The components of membership arbitration are the fencing module and the 
coordinator disks.

Fencing module
Each system in the Policy Master cluster runs a kernel module called vxfen, or 
the fencing module. This module uses membership arbitration to ensure valid 
and current Policy Master cluster membership on a membership change. 

vxfen performs the following actions:

■ Registers with the coordinator disks during normal operation 

■ Races for control of the coordinator disks during membership changes

Coordinator disks
Coordinator disks are special purpose disks that act together as a global lock 
device. Racing for control of these disks is used to determine Policy Master 
cluster membership. Control is won by the system that gains control of a 
majority of the coordinator disks, so there must always be an odd number of 
disks, with three disks recommended. 
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You cannot use coordinator disks for any other purpose in the Policy Master 
cluster configuration, such as data storage or inclusion in a disk group for user 
data. Any disks that support SCSI-3 Persistent Reservation can be coordinator 
disks. Best practice is to select the smallest possible LUNs for use as coordinator 
disks. 

How the fencing module starts up 
The fencing module starts up in the following way:

■ The coordinator disks are placed in a disk group.

During initial Policy Master cluster configuration, the coordinator disks are 
placed in a disk group, and the name of the disk group is placed in 
/etc/vxfendg. This set up allows the fencing start up script to use Symantec 
Veritas Volume Manager (VxVM) commands to easily determine which 
disks are coordinator disks, and what paths exist to those disks. This disk 
group is never imported, and is not used for any other purpose.

■ The fencing start up script uses the disk group name in /etc/vxfendg and 
VxVM commands to populate the file /etc/vxfentab with all paths available 
to the coordinator disks.

For example, if you configure three coordinator disks with two paths to 
each disk, the /etc/vxfentab file will contain six individual lines, 
representing the path name to each disk, such as /dev/rdsk/c1t1d1s2.

■ When the fencing driver is started, it reads the physical disk names from the 
/etc/vxfentab file. These disk names represent the physical paths available 
on a system to the coordinator disks. 

■ The fencing driver determines the serial number of the disk represented by 
a specific path. Using this information, the driver builds an in-memory list 
of the physical coordinator disks.

■ The fencing driver verifies that any other systems in the Policy Master 
cluster that are already up and running detect the same coordinator disks.

The fencing driver examines GAB port B for membership information. If no 
other systems are up and running, it is the first system up and is considered 
the correct coordinator disk configuration. When a new member joins, it 
requests a coordinator disks configuration. The system with the lowest LLT 
ID responds with a list of the coordinator disk serial numbers. If there is a 
match, the new member joins the Policy Master cluster. If there is not a 
match, vxfen enters an error state and the new member is not allowed to 
join. This process ensures that all systems communicate with the same 
coordinator disks.

■ The fencing driver determines if a possible preexisting split brain condition 
exists.
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This is done by verifying that any system that has keys on the coordinator 
disks can also be seen in the current GAB membership. If this verification 
fails, the fencing driver prints a warning to the console and system log and 
does not start.

■ If all verifications pass, the fencing driver on each system registers keys 
with each coordinator disk. 

Figure 6-5 shows the topology of the coordinator disks in the Policy Master 
cluster:

Figure 6-5 Topology of coordinator disks in the Policy Master cluster

How membership arbitration works
When the Policy Master cluster starts, all systems register a unique key on the 
coordinator disks. The key is based on the LLT system ID, for example
LLT ID 0 = A. 

When there is a perceived change in membership, the following process is 
followed for membership arbitration:

■ GAB marks the system as DOWN, excludes the system from the Policy 
Master cluster membership, and delivers the membership change—the list 
of departed systems—to the fencing module.

■ The system with the lowest LLT system ID in the Policy Master cluster races 
for control of the coordinator disks

■ In the most common case, where departed systems are truly down or 
faulted, this race has only one contestant. 

System0

SAN Connection LLT Links

System1 System2 System 3

Coordinator Disks



100 How the UNIX Policy Master cluster operates
About membership arbitration in the Policy Master cluster
■ In a split brain scenario, where two or more subclusters have formed, 
the race for the coordinator disks is performed by the system with the 
lowest LLT system ID of that subcluster. This system races on behalf of 
all the other systems in its subcluster.

■ The race consists of executing a preempt and abort command for each key of 
each system that appears to no longer be in the GAB membership.

The preempt and abort command allows only a registered system with a 
valid key to eject the key of another system. This ensures that even when 
multiple systems try to eject other, each race has only one winner. The first 
system to issue a preempt and abort command wins and ejects the key of 
the other system. When the second system issues a preempt and abort 
command, it can not perform the key eject because it is no longer a 
registered system with a valid key.

■ If the preempt and abort command returns success, that system has won the 
race for that coordinator disk. 

Each system repeats this race to all the coordinator disks. The race is won 
by, and control is attained by, the system that ejects the other system’s 
registration keys from a majority of the coordinator disks. 

■ On the system that wins the race, the vxfen module informs all the systems 
that it was racing on behalf of that it won the race, and that subcluster is 
still valid. This information is passed back to GAB.

■ On the system(s) that do not win the race, the vxfen module triggers a 
system panic. The other systems in this subcluster note the panic, 
determine they lost control of the coordinator disks, and also panic and 
restart. 

■ Upon restart, the systems try to seed into the Policy Master cluster.

■ If the systems that restart can exchange heartbeat with the number of 
Policy Master cluster systems declared in /etc/gabtab, they 
automatically seed and continue to join the Policy Master cluster. Their 
keys are replaced on the coordinator disks. This case only happens if 
the original reason for the membership change has cleared during the 
restart.

■ If the systems that restart can not exchange heartbeat with the number 
of Policy Master cluster systems declared in /etc/gabtab, they do not 
automatically seed, and HAD does not start. This is a possible split 
brain condition, and requires the administrator to intervene.
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Note: Forcing a manual seed at this point lets the Policy Master cluster seed. 
However, when the fencing module checks the GAB membership against the 
systems that have keys on the coordinator disks, a mismatch occurs. vxfen 
detects a possible split brain condition, prints a warning, and does not start. 
In turn, HAD does not start. Administrative intervention is required.

About data protection in the Policy Master cluster 
using SCSI-3 storage

Membership arbitration alone is not complete data protection because it 
assumes, similar to quorum solutions, that all systems either participate in the 
arbitration or are already down. 

The following examples are rare situations which much also be protected 
against: 

■ A system hang causes the kernel to stop processing for a period of time.

■ The system resources were so busy that the heartbeat signal was not sent.

■ A break and resume function is supported by the hardware and executed. 
Dropping the system to a system controller level with a break command can 
result in the heartbeat signal timeout.

■ The OfflineMonitorInterval resource attribute, which controls the 
monitoring of offline resource, is disabled to avoid extra processing on 
client nodes.

In the first three types of situations, the systems are not actually down, and may 
return to the Policy Master cluster after Policy Master cluster membership has 
been recalculated. This could corrupt data because a system could potentially 
write to disk before it determines it should no longer be in the Policy Master 
cluster. In the fourth situation, a concurrency violation could occur if you online 
resources outside of VCS One control.

Combining membership arbitration with data protection of the shared storage 
eliminates all of the above possibilities for data corruption.

Data protection fences off (removes access to) the shared data storage from any 
system that is not a current and verified member of the Policy Master cluster. 
Access is blocked by the use of SCSI-3 persistent reservations. 

SCSI-3 Persistent Reservation (SCSI-3 PR) is an enhancement to the SCSI 
specification that supports multiple systems, or multiple paths from a single 
system, accessing a device. At the same time it blocks access to the device from 
other systems, or other paths. 



102 How the UNIX Policy Master cluster operates
How I/O fencing works
When a service group comes online on a particular system, if the service group 
contains a disk group, the disk group is imported. When using SCSI-3 PR, 
importing the disk group puts registration and reservation on the data disks. 
Only the system that has imported the storage with SCSI-3 reservation can write 
to the shared storage. This prevents a system that did not participate in 
membership arbitration from corrupting the shared storage.

SCSI-3 PR ensures persistent reservations across SCSI bus resets.

Note: Use of SCSI III PR protects against all elements in the IT environment that 
might be trying to write illegally to storage, not only VCS related elements.

Membership arbitration combined with data protection is termed I/O Fencing.

How I/O fencing works
This topic describes the general logic employed by the I/O fencing module along 
with some specific example scenarios. 

About the I/O fencing algorithm 
To ensure the most appropriate behavior is followed in both common and rare 
corner case events, the fencing algorithm works as follows:

■ The fencing module is designed to never have systems in more than one 
subcluster remain current and valid members of the Policy Master cluster. 
In all cases, either one subcluster survives, or in very rare cases, no systems 
will.

■ The system with the lowest LLT ID in any subcluster of the original Policy 
Master cluster races for control of the coordinator disks on behalf of the 
other systems in that subcluster.

■ If a system wins the race for the first coordinator disk, that system is given 
priority to win the race for the other coordinator disks. 

Any system that loses a race delays a short period of time before racing for 
the next disk. Under normal circumstances, the winner of the race to the 
first coordinator disk wins all disks.

This ensures a clear winner when multiple systems race for the coordinator 
disk, preventing the case where three or more systems each win the race for 
one coordinator disk. 

■ If the Policy Master cluster splits such that one of the sub-clusters has at 
least 51% of the members of the previous stable membership, that 
subcluster is given priority to win the race. 
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The system in the smaller subcluster(s) delay a short period before 
beginning the race. 

This ensures that as many systems as possible remain running in the Policy 
Master cluster.

Two system Policy Master cluster where one system fails
System1 fails, and System0 carries out the I/O fencing operation in the 
following way:

■ The GAB module on System0 determines System1 has failed due to loss of 
heartbeat signal reported from LLT.

■ GAB passes the membership change to the fencing module on each system 
in the Policy Master cluster.

The only system that is still running is System0 

■ System0 gains control of the coordinator disks by ejecting the key registered 
by System1 from each coordinator disk. 

The ejection takes place one by one, in the order of the coordinator disk’s 
serial number. 

■ When the fencing module on System0 successfully controls the coordinator 
disks, HAD carries out any associated policy connected with the 
membership change.

■ System1 is blocked access to the shared storage, if this shared storage was 
part of a service group that was now taken over by System0 and imported.

Figure 6-6 shows a two system Policy Master cluster where one system fails.

Figure 6-6 I/O Fencing example with system failure
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Four system Policy Master cluster where cluster interconnect fails
The Policy Master cluster interconnect fails in such a way as to split the Policy 
Master cluster from one four-system Policy Master cluster to two two-system 
Policy Master clusters. The Policy Master cluster performs membership 
arbitration to ensure that only one subcluster remains.

Due to loss of heartbeat, System0 and System1 both believe System2 and 
System3 are down. System2 and System3 both believe System0 and System1 are 
down. 

I/O fencing operations progress in the following way:

■ LLT on each of the four systems no longer receives heartbeat messages from 
the systems on the other side of the interconnect failure on any of the 
configured LLT interfaces for the peer inactive timeout configured time. 

■ LLT on each machine passes to GAB that it has noticed a membership 
change. Specifically: 

■ LLT on System0 passes to GAB that it no longer detects System2 and 
System3

■ LLT on System1 passes to GAB that it no longer detects System2 and 
System3

■ LLT on System2 passes to GAB that it no longer detects System0 and 
System1

■ LLT on System3 passes to GAB that it no longer detects System0 and 
System1

Figure 6-7 shows a four system Policy Master cluster with a cluster interconnect 
failure
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Figure 6-7 Four system Policy Master cluster where cluster interconnect fails

■ After LLT informs GAB of a heartbeat loss, the systems that are remaining 
perform a 5-second GAB Stable Timeout. In this example:

■ System0 and System1 confirm that both of them do not detect System2 
and System3

■ System2 and System3 agree that both of them do not detect System0 
and System1

■ GAB marks the system as DOWN, and excludes the system from the Policy 
Master cluster membership. In this example:

■ GAB on System0 and System1 mark System2 and System3 as DOWN 
and excludes them from Policy Master cluster membership.

■ GAB on System2 and System3 mark System0 and System1 as DOWN 
and excludes them from Policy Master cluster membership.

■ GAB on each of the four systems passes the membership change to the vxfen 
driver for membership arbitration. Each subcluster races for control of the 
coordinator disks. In this example:

■ System0 has the lower LLT ID, and races on behalf of itself and 
System1.

■ System2 has the lower LLT ID, and races on behalf of itself and 
System3.

■ GAB on each of the four systems also passes the membership change to 
HAD. HAD waits for the result of the membership arbitration from the 
fencing module before taking any further action.
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■ Assume System0 wins the race for the coordinator disks, and ejects the 
registration keys of System2 and System3 off the disks. The result is as 
follows:

■ System0 wins the race for the coordinator disk. The fencing module on 
System0 communicates race success to all other fencing modules in the 
current Policy Master cluster, in this case System0 and System1. The 
fencing module on each system in turn communicates success to HAD. 
System0 and System1 remain valid and current members of the Policy 
Master cluster.

■ System2 loses the race for control of the coordinator disks. The fencing 
module on System2 calls a kernel panic and the system restarts.

■ System3 detects another membership change from the kernel panic of 
System2. Because that was the system that was racing for control of the 
coordinator disks in this subcluster, System3 panics also. 

■ HAD carries out any associated policy or recovery actions based on the 
membership change.

■ System2 and System3 are blocked access to the shared storage (if the shared 
storage was part of a service group that was now taken over by System0 or 
System 1).

■ To rejoin System2 and System3 to the Policy Master cluster, you must do the 
following:

■ Shut down System2 and System3

■ Fix the Policy Master cluster interconnect links

■ Restart System2 and System3

Best practices for Policy Master cluster 
communications

The following are the recommended best practices for Policy Master cluster 
communications to best support proper Policy Master cluster membership and 
data protection.

■ Properly seed the Policy Master cluster by requiring all systems are in the 
GAB membership before the Policy Master cluster automatically seeds. 

If every system is not present, manual intervention by the administrator 
must eliminate the possibility of a split brain condition before manually 
seeding the Policy Master cluster.

■ Configure multiple independent communication network links between 
Policy Master cluster systems.
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Networks should not have a single point of failure, such as a shared hub or 
ethernet card.

■ Low-priority LLT links are recommended.

Low-priority LLT links provide an extra path for heartbeat communications 
in case the main communication links fail.

■ Disable the console-abort sequence

Most UNIX systems provide a console-abort sequence that enables the 
administrator to halt and continue the processor. Continuing operations 
after the processor has stopped may corrupt data and is therefore 
unsupported by VCS. 

When a system is halted with the abort sequence, it stops producing 
heartbeats. The other systems in the Policy Master cluster consider the 
system failed and take over its services. If the system is later enabled with 
another console sequence, it continues writing to shared storage as before, 
even though its applications have been restarted on other systems. 

Disable the console-abort sequence or create an alias to force the “go” 
command to perform a restart on systems not running I/O fencing.

■ Select the smallest possible LUNs for use as coordinator disks. Use three 
coordinator disks.

■ Do not reconnect the Policy Master cluster interconnect after a network 
partition without shutting down one side of the split Policy Master cluster.

A common example of this happens during testing, where the administrator 
may disconnect the Policy Master cluster interconnect and create a network 
partition. Depending on when the interconnect cables are reconnected, 
unexpected behavior can occur.
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Chapter
 7
How the Windows Policy 
Master cluster operates

This chapter includes the following topics:

■ “About the Policy Master cluster” on page 110

■ “About the high availability daemon (HAD)” on page 110
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About the Policy Master cluster
The Policy Master cluster is kept highly available by the use of Veritas Cluster 
Server (VCS) software. 

VCS uses local communications on a system and system-to-system 
communications. Cluster communications enable VCS to recognize which 
systems are active members of the Policy Master cluster, which have joined or 
left the cluster, and which have failed.

About the high availability daemon (HAD)
The VCS high availability daemon (HAD) runs on each Policy Master system. 
Also known as the VCS engine, HAD is responsible for:

■ Building the running cluster configuration from the configuration files

■ Distributing the information when new nodes join the cluster

■ Responding to operator input

■ Taking corrective action when something fails

The engine uses agents to monitor and manage resources. It collects 
information about resource states from the agents on the local system and 
forwards it to all cluster members. 

The local engine also receives information from the other cluster members to 
update its view of the cluster. HAD operates as a replicated state machine (RSM). 
The engine running on each node has a completely synchronized view of the 
resource status on each node. Each instance of HAD follows the same code path 
for corrective action, as required. 

The hashadow process monitors HAD and restarts it when required.

The RSM is maintained through the use of a purpose-built communications 
package. The communications package consists of the following protocols:

■ Low Latency Transport (LLT)

VCS uses private network communications between cluster nodes for 
cluster maintenance. The Low Latency Transport protocol functions as a 
high-performance, low-latency replacement for the IP stack, and is used for 
all cluster communications. 

■ Group Membership Services/Atomic Broadcast (GAB)

The Group Membership Services/Atomic Broadcast protocol (GAB) is 
responsible for cluster membership and reliable cluster communications.
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Getting started

This section includes the following chapters:

■ “Starting and stopping Veritas Cluster Server One” on page 113.

■ “Using the VCS One console” on page 121.

■ “Using the Simulator” on page 203.
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Starting and stopping 
Veritas Cluster Server One

This chapter includes the following topics:

■ About VCS One user interfaces

■ Setting the PATH variable to use the CLI on UNIX

■ Executing commands on Windows

■ Before starting the VCS One console

■ Logging off from the VCS One console
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About VCS One user interfaces
VCS One provides efficient and centralized control of numerous mission critical 
applications that run on multiple systems in the VCS One cluster. VCS One 
provides a command line interface (CLI), and a management console to perform 
administrative tasks on the VCS One cluster. The management console is a Web-
based interface, which uses the Symantec Web server. The Symantec Web 
Server and the Policy Master must reside on the same system.

Setting the PATH variable to use the CLI on UNIX
Use this procedure to set the PATH variable to use the CLI (command line 
interface) with VCS One.

Note that on the Policy Master, both VCS and VCS One are installed. In some 
instances, the same command exists in both these products, such as halog and 
haclus. Be aware of the order of your PATH variable. To avoid confusion, use the 
full path name when executing a command.

To set the PATH variable to use the command line interface (CLI)

◆ At the command prompt, type the following command:

PATH=$PATH:/opt/VRTSvcsone/bin
export PATH

More information is available about VCS One commands. See the Veritas Cluster 
Server One Command Reference Guide.

Executing commands on Windows
On the Policy Master, both VCS and VCS One are installed. In some instances, 
the same command (for example, halog and haclus) exists in both of these 
products.

On Windows, the installation process sets a PATH variable for both VCS and 
VCS One. 

When you execute a command with the command line interface, if the same 
command exists in both products, the operating system will run the VCS 
command if it locates that path first. 

To avoid confusion, use the CD command to change the VCS One directory to the 
following path when executing a VCS One command:

%VCSONE_HOME%\bin

where
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%VCSONE_HOME% is the path that you specify during VCS One installation. 
The default installation path is:

C:\Program Files\Veritas\Cluster Server One

In addition, note the following when executing commands on the Policy Master.

On Windows Server 2008, if User Access Control (UAC) is enabled and 
configured, non-default administrators cannot run VCS One commands from 
the command prompt. All VCS One commands must be run from the command 
prompt in the Run as administrator mode.

To launch the command prompt in the Run as administrator mode, right click 
the command prompt shortcut from the Windows Start menu and click Run as 
administrator from the context menu.

See the Microsoft documentation for more information on UAC.

Before starting the VCS One console
Before starting the VCS One console, ensure that you perform the following 
tasks:

■ Install a supported browser.

■ Install a supported Macromedia Flash plug-in.

■ Install and configure VCS One. 

See the Veritas Cluster Server One Installation Guide.

■ Configure the ports that the Symantec Web server uses.

■ Enable the Web browser cookies and JavaScript, and disable the pop-up 
blocker. 

For supported software versions, see the Veritas Cluster Server One Release 
Notes.

Changing Web browser settings
This section describes how to change the Web browser settings for Microsoft 
Internet Explorer 7.0 to accurately view the VCS One console. These steps 
disable browser caching, and set the ActiveX and cookie settings as required by 
VCS One. You may need to follow the equivalent steps given in the browser’s 
documentation.

To change Web browser settings

1 Start Microsoft Internet Explorer.

2 In the Tools menu, select Internet Options.
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3 In the Internet Options dialog box, click the General tab.

4 Under Browsing history, click Settings.

5 In the Temporary Internet Files and History Settings dialog box, select the 
Every time I visit the webpage option, and then click OK.

6 In the Internet Options dialog box, click the Security tab, click Local 
intranet, and then click Custom Level.

7 In the Security Settings dialog box, under ActiveX controls and plug-ins, 
enable the following settings:

■ Download signed ActiveX controls

■ Run ActiveX controls and plug-ins

■ Script ActiveX controls marked safe for scripting

8 In the Security Settings dialog box, click OK.

9 In the Internet Options dialog box, click the Privacy tab. Under Settings, 
click Advanced. 

10 In the Advanced Privacy Settings dialog box, perform the following tasks: 

■ Select the Override automatic cookie handling check box.

■ Under First-party Cookies, select the Accept option.

■ Under Third-party Cookies, select the Accept option.

■ Select the Always allow session cookies check box. 

■ Click OK. 

11 In the Internet Options dialog box, click Apply. 

12 Click OK.

Starting and logging on to the VCS One console

To start and log on to the VCS One console

1 Open a Web browser and enter the following URL:
http://PM_cluster_virtual_IP_address:14171

It is recommended that you use the virtual IP address of the Policy Master 
cluster instead of the name of the active Policy Master cluster node. If you 
use the virtual IP address, the VCS One console maintains a connection with 
the Policy Master after a Policy Master cluster failover operation.
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Note: When you start the VCS One web console for the first time, a Web 
page might appear with a Secure Connection Failed message. Follow 
the steps provided in the browser to add and permanently store a trusted 
security certificate as an exception. After the security certificate is added, 
the VCS One Web console login page appears in the browser.

In Internet Explorer 8, the security certificate error also appears whenever 
you open a VCS One popup window. Add the security certificate to display 
the page contents.

2 In the web browser, click the VCS One Web Console link.

3 In the Log on page, specify the following details:

■ In the Select Language box, select the appropriate language. In this 
release, only English is supported.

■ In the User Name field, enter the name of the user.

■ In the Password field, enter the password.

■ In the Domain field, enter the domain name.

You must specify a domain name for all domain types except unixpwd 
(which is the default domain type) and pam. 

To view a list of all the domains on the Policy Master system, enter the 
following command.

On UNIX, enter the following:
# /opt/VRTSvcsone/bin/haat showallbrokerdomains

On Windows, enter the following:
%VCSONE_HOME%\bin\haat showallbrokerdomains

If the Domain field is left blank and the domain type is unixpwd or pam, 
VCS One assumes that the domain type is the same as the Policy Master 
system’s domain type.

■ In the Domain Type field, select a domain type (uxixpwd, nt, nis, 
nisplus, pam, vx, or ldap).

■ In the Broker:Port field, enter the authentication broker name and the 
port number separated by a colon (:). This field is optional and is 
populated automatically.

4 Click Log On.

The web console is best viewed at 1024x768 screen resolution.

More information is available about the VCS One console. 

See “Using the VCS One console” on page 121. 

More information is available about how to troubleshoot authentication issues. 

See “Troubleshooting authentication issues” on page 738.
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Logging on to VCS One using the command line
The halogin command authenticates users in the VCS One environment and 
sets up a valid user profile. Authentication is required to execute VCS One 
commands.

To log on to VCS One using the command line 

◆ On UNIX, at the command prompt, type the following command: 

# /opt/VRTSvcsone/bin/halogin [-forclient] [-passwd password] \
-user user@domain -domaintype domaintype

◆ On Windows, at the command prompt, type the following command: 

%VCSONE_HOME%\bin\halogin [-forclient] [-passwd password] \
-user user@domain -domaintype domaintype

Use the optional -forclient option to ensure that the user profile is used 
when “ha” commands are executed within script-based entry points inside local 
zones so that they can connect to the Policy Master via the VCS One client 
daemon (vcsoneclientd). If you do not supply a password, the command prompts 
you for it. 

The -user user@domain option is the fully qualified user name and the 
-domaintype domaintype option is the relevant domain type. Accepted values 
for the domain type include unixpwd, nt, nis, nisplus, ldap, pam, and vx (which is 
the Symantec Private Domain). These values are case sensitive.

If you do not use the halogin command to log on to VCS One, you must use the 
-user and -domaintype switches each time you issue a VCS One command. 

The VCS One client system root user (localhost root user) is an exception, and 
has the user privileges that are associated with the VCS One client daemon. For 
the root user, VCS One commands ignore the profile that is created by the 
halogin command on the active Policy Master cluster node.

For more information about VCS One commands, refer to the Veritas Cluster 
Server One Command Reference Guide.
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Logging off from the VCS One console
This section describes how to log off from the VCS One console.

To log off from the VCS One console

◆ In the VCS One console, click Logout.

After you successfully log off from the VCS One console, the following 
information message is displayed: 

VCS One INFO V-97-11-10 You have been successfully logged out.

Note: If you use the Firefox Web browser and have multiple open browser 
connections to the VCS One console, when you log off from one console, VCS 
One simultaneously logs you off from all the other open browser connections. 
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Using the VCS One console

This chapter includes the following topics:

■ About the VCS One console

■ About VCS One console ports

■ Managing SSL certificates

■ VCS One console layout

■ Summary information on the Home menu

■ Manage menu options

■ Logs menu options

■ Administration menu options

■ Summary information on the Search menu
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About the VCS One console
The VCS One console enables you to configure, manage, and monitor the VCS 
One cluster. You can use the console to perform various operations on one or 
more VCS One objects, such as service groups, systems, and sets. 

You can use the VCS One Simulator to familiarize yourself with the console and 
simulate tasks and functionality of VCS One. 

See “About the Simulator” on page 204.

Note: Before starting the VCS One console ensure that pop-up blockers are 
disabled in the Web browser.

About VCS One console ports
By default, the VCS One console serves HTML content on port 14171 and 14172. 
Be sure to enable these ports. These ports are used as follows:

■ 14171 (HTTPS): Secure SSL port. VCS One console presents a self-signed 
SSL certificate (issued by Symantec) to the browser. You must accept the 
certificate before accessing the secure Web consoles. The SSL protocol 
prevents malicious users from sniffing Web console data from the network.

■ 14172: Administrative port.

■ 14173: Webservices communication port.

If you use these ports for another application on the system, configure the VCS 
One console to use different ports.

Managing SSL certificates
This section points you to the tools and files you need to perform SSL-related 
tasks, such as installing and managing certificates signed by a Certificate 
Authority (CA). For more detailed information about certificate management, 
see the Apache Tomcat 6.0 SSL Configuration instructions available on the 
Internet.

You can use the self-signed certificate that VCS One provides, or you can 
optionally obtain a certificate from a third-party certificate authority (CA). 

The self signed certificate is stored in the key store located at:

■ Unix: /opt/VRTSvcsone/web/tomcat/cert

■ Windows: %VCSONE_HOME%\web\tomcat\cert
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Configuring and Managing SSL certificates (optional)
You do not need to perform any tasks to manage the SSL certificate that 
Symantec provides. However, you can optionally configure and manage SSL 
certificates using Java Keytool, or another tool of your choice.

After you make any modifications to your SSL configuration, you must stop and 
restart the server using (on UNIX):

/opt/VRTSvcsone/bin/hastop -web
/opt/VRTSvcsone/bin/hastart -web

On Windows, the command path is as follows:
%VCSONE_HOME%\bin\hastop -web
%VCSONE_HOME%\bin\hastart -web

Locating the Java Keytool utility
For your convenience, the Java Keytool utility is included in the VCS One 
installation, and is located at:

■ Unix: /opt/VRTSvcsone/jre/bin

■ Windows: %VCSONE_HOME%\ jre\bin

Changing the key store password
The default password that protects the key store is changeit. If you change the 
key store password, you need to update the server.xml file with the new 
password. The server.xml file is located at:

■ Unix: /opt/VRTSvcsone/web/tomcat/conf

■ Windows: %VCSONE_HOME%\web/tomcat/conf

VCS One console layout
The VCS One console area consists of the following elements:

■ The navigation menu bar, which provides access to VCS One commands.

See “About the navigation menu bar” on page 124.

■ The left and right panes, which display the navigation hierarchy and object 
information respectively.

See “About panes” on page 125.

■ The history menu, which provides access to recently visited objects.

See “About the History menu” on page 132.

■ The wizards, which provide access to configuration settings.

See “About wizards” on page 132.
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■ The Help link, which displays help information.

See “About VCS One Help” on page 133.

■ The About link, which displays the VCS One version and copyright 
information.

■ The Logout link, which logs you out of the VCS One console.

See “Logging off from the VCS One console” on page 133.

About the navigation menu bar
The navigation menu bar is located in the top area of the VCS One console. The 
menu bar is visible from all the views in the console. Moving the mouse over the 
menu names (except the Home menu and Search menu) displays the menu 
items.

Figure 7-1 shows the location of the navigation menu bar in the VCS One 
console.

Figure 7-1 Navigation menu bar

The navigation menu bar provide access to the following functionality: 

■ The Home menu enables you to perform VCS One cluster operations.

See “Summary information on the Home menu” on page 133.

■ The Manage menu enables you to perform operations on VCS One cluster 
objects such as service groups, composite service groups, systems, 
resources, PFrames, VFrames, jobs, and rules.

See “Manage menu options” on page 135.

■ The Logs menu enables you to view, search, and delete log messages.
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See “Logs menu options” on page 185.

■ The Administration menu enables you to configure users and roles, manage 
organization units and sets, define extended attributes, and configure global 
and automation settings.

See “Administration menu options” on page 191.

■ The Search menu enables you to search for specific VCS One cluster objects.

See “Summary information on the Search menu” on page 201.

About panes
The area below the navigation menu bar is divided into two panes. The left pane 
contains navigation hierarchies. The right pane displays various views which 
depend on the command or object selected.

Figure 7-2 shows the location of the right pane, the left pane, the breadcrumb 
bar, the task menu bar, the page summary pane, and the tables.

Figure 7-2 Panes, breadcrumb bar, task menu, tables, and page summary pane

The left pane of the VCS One console contains a list box. The list box provides 
access to the organization tree nodes and object sets. You can right-click a node 
or set and access the related operations.

In the list box, you can select one of the following options: 

■ My Objects or a custom view name to select the default set (My Objects) or a 
custom view that is associated with the service group or system.

See “About administrating sets of objects” on page 666.
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■ Organization Tree to navigate to a specific organization tree node to which 
the service group or system is attached.

See “How you manage users using the Organization Tree” on page 253.

The right pane contains the breadcrumb bar, the task menu bar, tables, and the 
page summary pane. The breadcrumb bar, which is located below the navigation 
menu, shows a list of the objects that you selected to navigate to this view. The 
task menu bar has various menus which contain commands for operations and 
tasks that are related to the selected navigation menu item. The page summary 
pane displays the summary information about the current page. The right pane 
also displays the console information, most of which is in the form of tables.

About console refresh
As you use the console, the status of the various VCS One cluster objects, such as 
systems, changes. Service groups go online and offline, alerts are generated, and 
object data changes. The information in the console updates (refreshes) 
automatically to reflect the latest data. 

For information that is displayed in tables, only the relevant cells of the rows are 
updated—the complete page does not reload. This behavior of the console is 
known as partial page refresh. This feature prevents refresh issues for systems 
that have a large number of objects or have slow connections. Additionally, user 
activity is not disrupted due to continuous updates to the systems and 
applications under management.

Tip: To manually refresh the current view, use the browser refresh command.

About tables
Most of the information in the right pane is displayed in the form of tables. A 
table can also contain another table which is known as a nested table. The 
information in the tables is updated automatically to reflect the latest data. 

You can configure most of the tables to suit your viewing preferences. You can 
perform the following configuration tasks:

■ Select objects in a table

See “About selecting objects in a table” on page 127.

■ Sort the table contents

See “Sorting the contents of a table” on page 127.

■ View multiple pages

See “Viewing multiple pages of a data table” on page 127.

■ Change table settings such as column order and number of rows displayed
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See “Changing the table settings” on page 128.

■ Configure table views

See “Configuring table views” on page 128.

■ Filter results in a table

See “Filtering results in a table” on page 129.

About selecting objects in a table
You can select an object in a table by checking the check box next to the object’s 
name or by clicking anywhere on the object’s row. You can also select multiple 
objects by using the CTRL and SHIFT keys. To select multiple objects that are 
contiguous, click the first object, press the SHIFT key, then select the last object 
in the series. To select multiple objects that are non-contiguous, select the first 
object, press the CTRL key, then select the second object, and so on.

Sorting the contents of a table
In some of the VCS One console tables, you can sort the rows by the data in a 
column. Some columns cannot be sorted.

To sort rows in a table by data in a column

1 In the table, locate the column that you want to use to sort the data.

2 Click the column heading.

The table refreshes with the list sorted by the values in that column in 
ascending order. A triangle icon (pointing up) displays in that column 
heading.

3 To sort the table in the descending order, click the column heading again.

The table refreshes with the list sorted by the values in descending order. A 
triangle icon (pointing down) displays in that column heading.

Viewing multiple pages of a data table
Tables can contain multiple pages. You can view subsequent pages of a table 
using the go-to-page bar. This bar is located in the right corner above and below 
the table.

Figure 7-3 shows the go-to-page bar.

Figure 7-3 Go-to-page bar
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To access pages in the table

1 In a table with multiple pages, locate the go-to-page bar above or below the 
table.

2 Click the controls on the go-to-page bar to move forward and backward 
through the table pages.

Changing the table settings
Tables can be configured to change the columns that are displayed, the order of 
columns, and the number of rows displayed.

To change the table settings

1 In the top right corner of the table, click the Settings drop-down arrow (the 
spanner icon), then select Table Settings.

2 In the Table Settings dialog box, in the Available Columns area, check the 
box for each column that you want to display.

3 Click >>.

4 To change the position of the column in the table, in the Selected Columns 
area, check the column name check box. 

5 Click Move Up or Move Down.

6 To arrange the information in the ascending or descending order, in the Sort 
column, click the arrow against the column name.

7 Select Up or Down.

8 To change the number of rows displayed, select the appropriate value in the 
Rows Per Page box.

9 Click OK.

Configuring table views
A view is a snapshot of the current table settings. The view that is displayed 
before any new views are created is called the default view. You can change the 
table settings, such as the columns displayed and the number of rows, and save 
these settings as a view. You can also delete a view; however, the default view 
cannot be removed.

To save a view

1 If required, change the table settings as per your preference.

See “Changing the table settings” on page 128.
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2 In the top right corner of the table, click the Settings drop-down arrow (the 
spanner icon), then select Save View.

3 In the View Manager dialog box, click the Action drop-down arrow, and 
select Save As.

4 In the Name and Description text boxes, enter a name for the view and its 
description respectively.

5 Click Save As.

To select a saved view

◆ In the top right corner of the table, click the Settings drop-down arrow (the 
spanner icon), and then select the view name.

The page refreshes and displays the new view.

To remove a view

1 Change to the view that you want to remove.

2 In the top right corner of the table, click the Settings drop-down arrow (the 
spanner icon), then select Delete View.

3 In the confirmation dialog box, click OK.

Filtering results in a table
Within a table, you can filter the results to search for a specific VCS One object. 
You can filter objects by entering a keyword or by selecting an extended 
attribute value. You can apply multiple filters to narrow your search.

To filter objects by entering a keyword

1 In the right pane above the table, click the plus sign next to the EA Filter 
button. The Keyword box displays.

2 In the Keyword box, enter the keyword. The keyword can be a string that 
matches part of the object names that you want to locate.

3 Click Go.

If the search is successful, the specified objects matching the keyword 
string display in the table.

To filter objects by selecting an extended attribute value

1 Click the EA Filter drop-down arrow, and select the desired extended 
attribute value. The table is refreshed and only objects matching the 
selected filter display.

2 Repeat the preceding step to add more filters.
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3 To save the list of filtered objects as a set, click Save as Set.

To remove filters

1 To remove a filter, click the cross mark next to the filter name.

2 To remove all filters, click Clear All.

About selecting menu commands
The commands used to perform various operations can be invoked in any of the 
following ways:

■ Click the menu bar in the right pane and select the command.

■ Right-click an object name in the table and select the command from the 
context-sensitive menu.

■ In the left pane, right-click an OU name and select the command from the 
context-sensitive menu.

About unavailable commands
Depending on the administrative level of the logged-in user, the commands for 
which the user does not have privileges are unavailable.

In certain cases where the pre-conditions for the operation are not met, an 
operation might not complete after you click the command. The reasons for 
non-completion of the command display as messages on the screen. You can 
take corrective action based on these messages. The operation will complete 
only after all the pre-conditions for the operation are met.

About filtering objects using the organization tree
The organization tree, which is located in the left pane of the console, can be 
used to filter objects displayed in the right pane. Using the organization tree, 
you can filter objects such as systems, service groups, composite service groups, 
resources, users, extended attributes, rules, and jobs.

To filter objects, in the list page of the object, select the appropriate 
Organization Tree Node (OU Name node or OU Value node). For example, to 
filter systems, use the following procedure.

To filter systems using the organization tree

1 In the VCS One console, click the Manage menu, and then click Systems.

2 In the left pane, if the organization tree is not displayed, select Organization 
Tree from the list.
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3 In the left pane, select the appropriate Organization Tree Node (OU Name 
node or OU Value node). All the systems associated with the selected 
Organization Tree node are listed in the right pane under Systems.

About the asset tree
The asset tree is located in the left pane of the console. It displays in place of the 
organization tree on the details page of objects such as systems, service groups, 
PFrames, and VFrames. You can use the asset tree for quick in-context 
comparison of objects.

The asset tree list has two view options—you can choose to view only those 
objects which belong to the OU of the selected object or you can view all objects 
of that type. For example, when viewing the details page for a system you can 
click the Asset Tree list to view all systems belonging to the OU of the selected 
system or you can view all systems.

Figure 7-4 shows the asset tree.

Figure 7-4 Asset tree
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About the History menu
Figure 7-5 shows the History menu.

Figure 7-5 History menu

The History menu contains a list of recently visited VCS One cluster objects such 
as service groups, VFrames, systems, PFrames, and resources. Each object in the 
History menu has an icon associated with it which indicates the type of the 
object. Each object also has links to related operations and tasks. For example, 
for a recently visited service group the following links are available: Group 
Details, Resource Dependencies, Group Dependencies, Workload, Map View, and 
All Attributes.

When you navigate to object-specific pages such as the details page for an object 
the object name gets added to the History menu. The most recently visited object 
is placed at the top of the list. The History menu holds 10 objects. You cannot 
configure this value. The list is cleared after you log off.

To view the list of recently visited objects, click the History menu.

About wizards
Many of the VCS One commands use wizards that help you configure various 
settings. You can navigate through the wizard screens either by using a pointing 
device such as a mouse or by using the keyboard. You can use the TAB key to 
move between the various screen elements such as buttons. To select a button, 
use the SPACEBAR key. Note that the ENTER key does not work when selecting a 
button.

The VCS One wizards have a welcome screen. You can configure VCS One to 
show or hide the welcome screen. For instructions, see “Configuring the 
welcome screen of VCS One wizards” on page 132.

Configuring the welcome screen of VCS One wizards
You may configure VCS One to either show or hide the welcome screen—the first 
screen of all wizards. By default, the welcome screen of all VCS One wizards is 
always displayed.

To hide the welcome screen of VCS one wizards:

◆ On the welcome page of any wizard, check the Do not show the Welcome 
screen check box.



133Using the VCS One console
Summary information on the Home menu
To show the welcome screen of VCS One wizards:

1 In the VCS One console, click the Administration menu, and then click User 
Preferences.

2 Click Reset.

About VCS One Help
The Help link is located on the right top corner of the VCS One console area. The 
Help is context-sensitive—when you click the Help link you see the help for the 
current page in a separate window.

Logging off from the VCS One console

To log off from the VCS One console

◆ Click the Logout link located at the top-right corner of the VCS One console 
area.

Summary information on the Home menu
When you log on to the VCS One console or click the Home menu, the console 
displays the summary information about the VCS One cluster.

The summary information includes a comprehensive view of all the service 
groups, composite service groups, systems, PFrames, and VFrames present in 
the VCS One cluster. You can check the status of all the service groups and 
systems at a glance and determine the health of the VCS One cluster.

Table 7-1 describes the console details that are displayed in the right pane.

Table 7-1 VCS One cluster summary console elements

Element Description

Service Groups The numerical distribution of service groups in the online, 
offline, faulted, and partial states is displayed in the Service 
Groups graph. To view the service groups that are currently in a 
particular state, click the number or the state name or the bar 
that corresponds to each state.

Systems The numerical distribution of systems in the running, offline, and 
faulted states is displayed in the Systems graph. To view the 
systems that are currently in a particular state, click the number 
or the state name or the bar that corresponds to each state.
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VFrames The numerical distribution of virtual servers in the online, 
offline, faulted, and partial states is displayed in the VFrames 
graph. To view the service groups that are currently in that state, 
click the number or the state name that corresponds to each state.

PFrames The numerical distribution of physical servers in the offline, 
faulted, and running states is displayed in the PFrames graph. To 
view the service groups that are currently in that state, click the 
number or the state name that corresponds to each state.

Needs Attention The Needs Attention table lists all the service groups, systems, 
VFrames, and PFrames that are currently in the faulted state or 
which otherwise need attention. This table also lists the faulted 
remote clusters and those composite service groups which have a 
concurrency violation. Each object is displayed as a link. You can 
click an object to view its details and perform operations on it.

Automation The Automation table lists the jobs, business rules, and 
notification rules that are currently invalid.

Disaster Recovery The numerical distribution of remote clusters in the running, 
offline, faulted, and disabled states is displayed in this table. To 
view the respective remote clusters that are currently in a 
particular state, click the number that corresponds to each state.

Composite Service 
Groups

The numerical distribution of composite service groups in the 
online, offline, and partial states is displayed in the Composite 
Service Groups graph. To view the composite service groups that 
are currently in a particular state, click the number or the state 
name or the bar that corresponds to each state.

Table 7-1 VCS One cluster summary console elements

Element Description
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Manage menu options
All VCS One cluster objects such as service groups, systems, and resources are 
created, configured, and managed from the Manage menu. You can use the 
menu items on the Manage menu to perform various operations on VCS One 
cluster objects.

Table 7-2  Commands under the Manage menu

Command Description

Workload Displays a graphical view of service groups, systems, PFrames and 
VFrames. This view also contains options to configure the view and 
locate specific objects.

See “Workload menus” on page 136.

Service Groups Provides access to the service group-related commands.

See “Service Groups operations” on page 147.

Composite 
Service Groups

Provides access to the composite service group-related commands.

See “Composite Service Groups operations” on page 156.

Systems Provides access to the system-related commands.

See “Systems operations” on page 158.

Resources Provides access to the resources-related commands.

See “Resources operations” on page 163.

Disaster 
Recovery

Provides access to the disaster recovery-related commands.

See “Disaster Recovery operations” on page 166.

PFrames Provides access to the PFrames-related commands.

See “PFrames operations” on page 169.

VFrames Provides access to the VFrames-related commands.

See “PFrames operations” on page 169.

Management 
Consoles

Provides access to the Management Consoles-related commands.

See “PFrames operations” on page 169.

Automation Provides access to the jobs and rules-related commands.

Jobs Provides access to the jobs-related commands.

See “Jobs operations” on page 180.
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Workload menus
The Workload menu item displays the service groups, systems, PFrames and 
VFrames in a graphical view. This view is called the Workload view. 

Clicking the Workload menu item displays the task menu bar which is located in 
the right pane below the breadcrumb bar. Each menu contains commands which 
you can use to perform service group, system, and virtual server operations.

Workload configuration menu commands
In the Workload view, the Configuration menu provides commands to manage 
systems and service groups.

Business Rules Provides access to the business rules-related commands.

See “Business Rules and Notification Rules operations” on page 182.

Notification 
Rules

Provides access to the notification rules-related commands.

See “Business Rules and Notification Rules operations” on page 182.

Table 7-2  Commands under the Manage menu

Command Description

Table 7-3 Workload menus

Menu Description

Configuration Contains commands to perform operations such as adding a system, 
deleting a system, adding a service group, and deleting a service group.

See “Workload configuration menu commands” on page 136.

Views Contains the command to view the Group Transition Queue (GTQ) and 
the VFrame Workload.

See “Workload view menu commands” on page 137.

Table 7-4 Workload view Configuration menu commands

Command Description

Add System Adds a system to the VCS One cluster using the Add System 
wizard.

See “Adding a system to the VCS One cluster” on page 336.
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Workload view menu commands
In the Workload view, you can click Views to select the following view: 

■ VFrame Workload View

Displays the workload view for virtual servers.

See “About the VFrame workload view” on page 140.

■ GTQ View

Displays the GTQ view in a separate window.

See “About the GTQ view” on page 142.

About the Service Group Workload view
The Service Group Workload view displays the service group and system 
information in a bar graph form. Each vertical rectangle represents a system in 
the VCS One cluster. When no service groups are online on the system, the 
rectangle has a uniform solid color. When a service group is online on a system, 
a part of the vertical rectangle is shaded. The shaded area represents a service 
group that is online. The size of the shaded area represents the load of the 
service group as a percentage of the capacity of the system.

The numbers that are displayed above each rectangle indicate the load of the 
service group and the capacity of the system. If the system capacity exceeds six 
digits, only the load of the service group is displayed. A blinking area around a 
number indicates that the load dimensions of one of the service group has 
exceeded 80 percent of the capacity of the system. Move the mouse pointer over 
the numbers to view the eighty-percent mark for a particular system.

The bar graph under each system represents all the defined Load attribute key 
values for the service groups on the respective system. A small orange triangle 

Delete System Deletes a system from the VCS One cluster.

See “Deleting a system from the VCS One cluster” on page 342.

Add Service Group Adds a service group using the Service Group Configuration 
Wizard.

See “Adding a service group or an infrastructure service group” 
on page 357.

Delete Service Group Deletes a service group.

See “Deleting a service group” on page 370.

Table 7-4 Workload view Configuration menu commands

Command Description
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in the shaded area indicates that a service group is a partially online on the 
system.

How to view service group information
In the Workload view, you can click a shaded area to select a service group. A 
dotted line is displayed around the shaded area and information about the 
service group is displayed under the Group Overview box. Information about the 
systems that are part of the service group’s SystemList attribute is displayed 
under the SystemList box. The Other Info box contains information such as the 
incompatible groups, parent groups, and child groups for the selected service 
group.

You can also move the mouse pointer over a service group to view the name, the 
priority, and the current load values of the service group. 

How to view system details 
In the Workload view, you can click the entire rectangle to view information 
about the system itself. The information also shows service groups that are 
online or faulted on the selected system. This information is displayed under the 
System Overview and Groups Configured boxes respectively. You can view 
service group information only if you have privileges for the service group. 
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About service groups that are not online
In the right side of the Workload view, you can view in a tabular form the service 
groups that are currently not online. Service groups that are not online can be in 
the waiting, offline, or faulted state. Click the respective table caption to display 
the service groups in that state. You can right-click a group name and perform 
the relevant operation.

Table 7-5 States of the service groups that are not online

Service group 
state

Description

Waiting Groups The Waiting Groups table lists the service groups that are placed in 
the Group Transition Queue (GTQ). The action ID, service group name, 
priority, current operation, and the target system is also displayed for 
each service group. You can change the width of these columns. If IN is 
displayed as the current operation, the service group is in the INTENT 
ONLINE state. 

From the Waiting Groups table, you can right-click a service group to 
perform any of the following operations:

■ Abort action
Aborts the selected action. 

■ Flush All Groups
Removes all the service groups currently in the GTQ.

Offline Groups The Offline Groups table lists the service groups which are currently 
offline in the VCS One cluster. The service group name and priority is 
displayed for each service group. 

From the Offline Groups table, you can right-click a service group to 
perform any of the following operations:

■ Online Group Anywhere
Brings the service group online on any available system that is 
defined in the system list of the service group.

■ Show member systems
Displays only those systems that are defined in the system list of 
the service group. 
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About the VFrame workload view
The VFrame workload view displays the host system and virtual frame 
information in a bar graph form. Each vertical rectangle represents a host 
system in the VCS One cluster. When no VFrames are online on a host system, 
the rectangle has a uniform solid color. When a VFrame is online on a host 
system the color of the rectangle changes. If more than one VFrame is online on 
the host system, the rectangle is divided into smaller rectangles and each 
VFrame is represented as a box. Each box displays the name of the VFrame, its 
operating system, and priority. The size of the box represents the load of the 
VFrame as a percentage of the capacity of the host system.

The numbers that are displayed above each rectangle indicate the load of the 
VFrame and the capacity of the host system. If the system capacity exceeds six 
digits, only the load of the VFrame is displayed. A blinking area around a 
number indicates that the load dimensions of one of the VFrame has exceeded 
80 percent of the capacity of the host system. Move the mouse pointer over the 
numbers to view the eighty-percent mark for a particular system.

The bar graph under each host system represents all the defined Load attribute 
key values for the VFrames on the respective host system. 

How to view VFrame information
In the Virtual Server Workload view, you can click a box on the bar graph 
rectangle to select a VFrame. A dotted line is displayed around the box and 
information about the VFrame is displayed under the VFrame(s) tab. 
Information about the host systems on which the VFrames are configured is 
displayed under the Host PFrame tab. Additional information such as the 

Faulted Groups The Faulted Groups table lists the service groups currently faulted in 
the VCS One cluster. The service group name and priority is displayed 
for each service group.

From the Faulted Groups table, you can right-click a service group to 
perform any of the following operations:

■ Clear Group Fault
Clears the service group fault and brings the service group online.

■ Show member systems
Displays only those systems that are defined in the system list of 
the service group. 

Table 7-5 States of the service groups that are not online

Service group 
state

Description
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priority of the VFrame and the linked system is displayed under the Other Info 
tab.

You can also move the mouse pointer over a VFrame box to view the name, the 
priority, and the current load values of the VFrame.

How to view host system details 
In the Virtual Server Workload view, you can click the any of the load bar graph 
rectangles to view information about the host system itself. The information 
also shows VFrames that are online or faulted on the selected system. This 
information is displayed under the Host System and VFrame(s) tabs 
respectively. You can view VFrame information only if you have privileges for 
the VFrame.

About VFrames that are not online
In the right side of the Virtual Server Workload view, you can view the VFrames 
that are currently not online in a tabular form. You can click the table caption to 
display the VFrames in that state.

Table 7-6 States of the VFrames that are not online

Virtual server 
state

Description

Waiting 
VFrames

The Waiting VFrames table lists the VFrames that are placed in the 
Group Transition Queue (GTQ). The action ID, VFrame name, priority, 
current operation, and the target host system is also displayed for each 
VFrame. You can change the width of these columns. If IN is displayed 
as the current operation, the VFrame is in the INTENT ONLINE state.

Offline VFrames The Offline VFrames table lists the VFrames, which are currently 
offline in the VCS One cluster. The VFrame name and priority is 
displayed for each VFrame. 

From the Offline Frames table, you can right-click a VFrame to 
perform any of the following operations:

■ Online VFrame
Brings the VFrame online on the host system.

■ Show PFrames
Displays the host systems on which the VFrame is configured. 
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About the GTQ view
The GTQ (Group Transition Queue) view displays the service groups that are 
currently in the GTQ in a separate window. You can abort the current action for 
selected service groups or flush all groups from the queue.

See “About the Group Transition Queue” on page 327.

See “Stopping the current action for an object in the GTQ” on page 382.

See “Flushing the plan of action on all service groups in the GTQ” on page 381.

Workload view service group operations
You can use the Workload view to perform service group operations. For 
example, you can bring a service group online or take it offline, switch the 
service group to another system, freeze or unfreeze a service group, or clear a 
service group fault. From the Workload view, you can select the shaded area that 
represents a service group, then right-click it to select an operation.

Service group operations are also available from the Manage menu.

See “Service Groups operations” on page 147.

Faulted 
VFrames

The Faulted VFrames table lists the VFrames currently faulted in the 
VCS One cluster. The name and priority is displayed for each VFrame.

From the Faulted VFrames table, you can right-click a VFrame to 
perform any of the following operations:

■ Clear VFrame Fault
Clears the VFrame fault and brings it online.

■ Show PFrames
Displays the host systems on which the VFrame is configured.

Table 7-7 Service group commands that are accessible from the Workload 
view

Command Description

Offline Group Takes the service group offline but does not cause the service 
group to fail over.

See “Taking a service group offline” on page 376.

Table 7-6 States of the VFrames that are not online

Virtual server 
state

Description
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Fault Group Faults the service group on a system. If the service group is 
configured to fail over and a failover target is available, the 
service group is brought online on another system. This option 
is available only with the VCS One Simulator and not in real-
time product deployment.

See “Faulting a service group in the Simulator” on page 385.

Switch Group Switches the service group to another system that is listed in the 
system list of the service group.

See “Switching a service group” on page 379.

Freeze Group Freezes a service group. A frozen service group cannot be moved 
to another system. Diagonal lines identify a frozen service 
group.

See “Freezing a service group” on page 382.

Unfreeze Group Unfreezes a currently frozen service group. An unfrozen service 
group lets you perform online or offline operations on it.

See “Unfreezing a service group” on page 383.

Clear Group Fault Clears a service group fault. When a service group faults on a 
system, first clear the service group fault. After you clear the 
fault, you should bring the service group online on the same 
system.

See “Clearing a service group fault” on page 386.

Edit Attributes Edits the service group attributes.

See “Editing service group attributes” on page 367.

Show Hosting Systems Displays only those systems in the Workload section that are 
part of the system list for a particular service group. The values 
that are set in the View box limits this view.

Go to Group Details Displays the details for the selected service group.

Go to Map View Displays the object relationship of a service group in a graphical 
way.

See “Summary information on the map view” on page 154.

Zoom Host System Displays the details of the host system in a Zoom Window. The 
Zoom Window is located in the right pane of the Workload 
section.

Table 7-7 Service group commands that are accessible from the Workload 
view

Command Description
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Workload view system operations
You can use the Workload view to perform system operations. For example, stop 
or start a system, pin or unpin a system, or freeze or unfreeze a system. The type 
of operation that you can perform depends on user privileges. From the 
Workload view, you can select the bar graph rectangle that represents a system, 
then right-click it to select an operation.

System operations are also available from the Manage menu.

See “Systems operations” on page 158.

Table 7-8 System commands accessible from the Workload view

Command Description

Pin System Fixes a system in the Workload view. You can pin up to four 
systems. A pinned system is always visible in the Workload view. 
Pin a system that requires continuous monitoring, such as one 
that hosts critical service groups.

Zoom System Displays the system’s details in a zoom window. The zoom window 
is located in the right pane of the Workload section.

Unpin System Releases a system that is currently pinned.

Freeze System Freezes a system. You can freeze a system to prevent service 
groups from coming online on it. Diagonal lines identify a frozen 
system.

See “Freezing a system” on page 344.

Unfreeze System Unfreezes a currently frozen system. You may need to unfreeze a 
frozen system to enable service groups to come online on the 
system.

See “Unfreezing a system” on page 345.

Stop System Takes a system offline. An offline system is displayed in gray. This 
option is available only with the VCS One Simulator and not in 
real-time product deployment.

See “Putting a system in the offline state” on page 352.

Start System Starts an offline or a faulted system. This option is available only 
with the VCS One Simulator and not in real-time product 
deployment.

See “Repairing a system using the Simulator” on page 349.
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Workload view options
You can use the Workload view options to configure the graphical view.

Figure 7-6 shows the various options found in the Workload view.

Figure 7-6 Workload view options

Simulate Daemon 
Dead

Simulates a system state in which the client daemon process stops 
functioning on the system, but the system itself is still up-and-
running. This option is available only with the VCS One Simulator 
and not in real-time product deployment.

See “Simulating a system in DDNA state” on page 353.

Simulate System 
Fault

Simulates a system fault. A faulted system is displayed with red 
lines around it. This option is available only with the VCS One 
Simulator and not in real-time product deployment.

See “Faulting a system using the Simulator” on page 349.

Edit Attributes Edits the system attributes.

See “Editing system attributes” on page 341.

Go to System Details Displays the detail system information.

Go to Map View Displays the system’s object relationship in a graphical way.

See “Summary information on the map view” on page 154.

Reset system filter Resets the system filters. 

Table 7-9 Workload view options

Option Description

The Dimension box Click the arrow to change the load dimension that is displayed for 
all the systems. For example, if you want to view the memory 
consumption, change the load dimension to mem. The color 
changes for each load dimension. 

Table 7-8 System commands accessible from the Workload view

Command Description
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Filtering systems in the Workload view
In the Workload view, you can filter systems based on their name and their 
operating system. 

To filter systems in the Workload view

1 Click the Filter Systems icon. 

2 In the Filter Systems dialog box, perform the following steps: 

a In the Select Platform box, select an operating system. All the systems 
that run the specified operating system are listed.

The Sort By box Click the arrow to arrange the systems in the order of their System 
Names, Total Load, Available Capacity, and Total Capacity. 
Systems are displayed from left to right with increasing values.

The Layout box Click the arrow to toggle between the Best Fit, Actual Fit, and 
Uniform Fit views.

The View box Enter the number of systems that you want to view. The default 
value is seven. You can expand the view by clicking the gray 
rectangle in the pane divider. Note that up to 32 systems can be 
viewed without using the slider.

The Navigator tab Click the tab to view a snapshot of all systems in the VCS One 
cluster. Systems that are currently displayed in the workload 
section are displayed in a shaded rectangle in the Navigator. Move 
the rectangle or the slider in the appropriate direction to select 
systems.

The Find tab Use the Find tab to search for service groups and systems.

See “Finding a system or a service group” on page 147.

The Filter Systems icon Click the icon to launch the Filter Systems dialog box. The dialog 
box enables you to select the systems that you want to display 
based on their name and their operating system.

See “Filtering systems in the Workload view” on page 146.

The Legend icon Click the icon to view a legend that represents the colors and 
patterns that are used to depict various states and load capacity 
dimensions. 

Table 7-9 Workload view options

Option Description
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b Check the box that corresponds to each system that you want to view in 
the Workload section. Check Select All to select all the systems in the 
list.

3 Click OK.

Finding a system or a service group 
In the Workload view, you can search for service groups and systems. 

To find a system or a service group

1 Under Find, in the Name box, enter the name of the system or service group 
that you want to locate.

2 Check Exact Match, if you want to find the service group or system that 
exactly matches the search criteria.

3 Select either the System or the Group option to search for systems or 
service groups respectively. 

4 Click Find.

If the search is successful the respective system or service group is 
displayed with a dotted rectangle border.

Service Groups operations
Clicking the Service Groups menu item displays the task menu bar which is 
located in the right pane below the breadcrumb bar. Each menu contains 
commands which you can use to perform service group operations.

Table 7-10 Service Groups menus

Menu Description

Operations Contains commands to perform operations such as bringing a service 
group online or taking it offline, freezing or unfreezing a service group, 
and enabling or disabling a service group.

See “Service group operations menu commands” on page 148.

Configuration Contains commands to perform operations such as adding, modifying, 
and moving a service group.

See “Service group configuration menu commands” on page 150.

Views Contains commands to view the service groups in a variety of views 
such as the workload view or map view.

See “Service group view menu commands” on page 151.
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Summary information on the Service Groups default view
The Service Groups default view displays a tabular list of service groups for a 
selected OU node or set. 

For each service group, the table contains the following information:

■ The name of the service group. 

■ The current status of the service group. 

■ The priority value that is assigned to the service group.

■ The load dimension values specified for the service group.

■ The dependency details of the service group. 

■ The name of the OUValue to which the service group belongs.

■ Other relevant service group information.

■ The operating system of the system to which the service group belongs.

You can display additional information such as the fault policy and the date of 
creation by changing the table settings. 

See “To change the table settings” on page 128.

Service group operations menu commands
In the right pane of the Service Groups view, the Operations menu has 
commands for managing service groups.

Simulation Contains commands to perform simulation operations such as inducing 
a service group fault.

See “Service group simulation menu commands” on page 155.

Table 7-11 Service group Operations menu commands

Command Description

Online Brings one or more service groups online on any or all available 
systems.

See “Bringing a service group online” on page 373.

Offline Takes one or more service groups offline on all systems.

See “Taking a service group offline” on page 376.

Table 7-10 Service Groups menus

Menu Description
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Probe All Resources Probes all resources of the selected service group.

See “Probing service group resources” on page 391.

Enable All Resources Enables all resources of one or more service groups.

See “Enabling service group resources” on page 389.

Disable All 
Resources

Disables all resources of one or more service groups.

See “Disabling service group resources” on page 390.

Enable Enables the selected service group.

See “Enabling a service group” on page 384.

Disable Disables the selected service group.

See “Disabling a service group” on page 385.

Freeze Freezes one or more service groups.

See “Freezing a service group” on page 382.

Unfreeze Unfreezes one or more service groups.

See “Unfreezing a service group” on page 383.

Clear Fault Clears one or more faulted service groups.

See “Clearing a service group fault” on page 386.

Clear All Faults 
under OU

Clears all faults of a service group.

See “Clearing a service group fault” on page 386.

Refresh System List Refreshes the system list of the selected service groups. Run this 
command whenever you modify the SystemListExpr attribute.

See “Refreshing a service group’s SystemList” on page 369.

Flush Cancels the online or offline operation that is currently being 
performed on the service group.

See “Flushing a pending action on a service group” on page 380.

Switch Switches a selected service group to a different system.

See “Switching a service group” on page 379.

Table 7-11 Service group Operations menu commands

Command Description
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Service group configuration menu commands
In the right pane of the Service Groups section, the Configuration menu has 
commands for configuring service groups.

Table 7-12 Service group Configuration menu commands

Command Description

Add Service Group Adds a service group using the Service Group Configuration 
Wizard.

See “Adding a service group or an infrastructure service group” 
on page 357.

Add ISG Adds a infrastructure service group.

See “Adding a service group or an infrastructure service group” 
on page 357.

Modify Service 
Group

Changes the resource values of the selected service group using 
the Service Group Configuration Wizard.

See “Modifying a service group” on page 371.

Delete Service 
Group(s)

Deletes one or more service groups.

See “Deleting a service group” on page 370.

Add/Modify 
Resource

Adds or changes resources of the selected service group.

See “Adding a resource to a service group” on page 426.

Edit Attribute(s) Edits the attributes of the selected service groups. Use this 
command to edit common attributes of multiple service groups in 
a single batch operation.

See “Editing service group attributes” on page 367.

Link/Unlink 
Resource

Manages resource dependencies for the selected service group.

See step 15 on page 362 in the section See “Adding a service group 
or an infrastructure service group” on page 357.

Edit Extended 
Attribute(s)

Edits the extended attributes of the selected service groups. Use 
this command to edit common extended attributes of multiple 
service groups in a single batch operation.

See “Assigning an extended attribute a value” on page 635.

Edit Fault Policy Configures the fault policy for the selected service group.

See “Configuring a service group’s fault policy” on page 398.
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Service group view menu commands
In the right pane of the Service Group view, the Views menu has commands for 
managing service group views.

Edit SystemList Changes the system list of the selected service group.

See “Configuring a service group’s SystemList with a list of 
systems” on page 394.

Edit Compatibility Specifies the compatible or incompatible service groups for the 
selected service group.

See “Configuring a service group’s compatibility list” on page 396.

Move Service 
Group(s)

Moves one or more service groups to another node in the 
organization tree.

See “Moving a service group to another organization tree node” 
on page 372.

Clone Service Group Clones the selected service group.

See “Cloning service groups” on page 392.

Add to CSG Adds one or more service groups to a composite service group.

See “Adding a service group to a composite service group” on 
page 370.

Delete from CSG Removes one or more service groups from a composite service 
group.

See “Deleting a service group from a composite service group” on 
page 371.

Manage 
Dependencies

Defines the dependencies among service groups.

See “Managing service group dependencies” on page 387.

Table 7-13 Service group Views menu commands

Command Description

Resource 
Dependencies

Displays the resource dependencies for a selected service group in a 
separate window.

See “Summary information on the dependency view” on page 152.

Table 7-12 Service group Configuration menu commands

Command Description
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Summary information on the dependency view
The dependency view is a graphical representation of a service group’s 
dependency with other service groups as well as the dependency of the 
resources for a selected service group. 

The VCS One console provides two types of dependency views:

■ Group dependency view

Displays the dependency of the selected service group with other service 
groups.

See “About service groups and service group dependencies” on page 32.

■ Resource dependency view

Displays the dependency of resources for a selected service group.

See “About resources and resource dependencies” on page 31.

The dependency view window area contains the following elements:

■ Main section

See “About the main section of the dependency view” on page 153.

■ Search and other icons

See “About the icons in the dependency view” on page 153.

■ System icons

See “About the system icons in the dependency view” on page 154.

■ Navigator

See “About the Navigator” on page 154.

Group/VFrame 
Dependencies

Displays the service group dependencies for a selected service group in 
a separate window.

See “Summary information on the dependency view” on page 152.

Workload Displays the workload view for a selected service group.

See “About the Service Group Workload view” on page 137.

Map View Displays the object relationship of a service group in a graphical way.

See “Summary information on the map view” on page 154.

All Attributes Displays all attributes of the selected service group in a separate 
window.

GTQ View Displays the Group Transition Queue in a separate window.

See “About the GTQ view” on page 142.

Table 7-13 Service group Views menu commands

Command Description
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Figure 7-7 illustrates the resource dependency view.

Figure 7-7 Resource dependency view

About the main section of the dependency view 
The main section of the dependency view is located in the center of the 
dependency view window. To pan or move the view in any direction, click and 
drag the mouse in the desired direction. You can also move the view by using the 
Navigator.

See “About the Navigator” on page 154.

About the icons in the dependency view
The left side of the dependency view contains the following icons:

Search Enables you to search for a service group or resource. 

Click the icon to open the search panel. Enter the search string in the 
text box and click the Search icon. The results display in the Search 
Results pane. Click the object name in the Search Results pane to 
locate it in the dependency view. The selected object is highlighted in 
the dependency view with a yellow rectangle.
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About the system icons in the dependency view
The bottom area of the resource dependency view contains icons representing 
the systems present in the system list of the selected service group. The icon 
indicates the current state of each system. You can right-click on any icon to 
perform operations related to that system.

About the Navigator
You can use the Navigator to pan or zoom the dependency view. The Navigator 
is located in the lower right corner of the Dependency View window. The 
Navigator itself cannot be resized, though it can be collapsed.

The Navigator contains a window with a red border which can be resized or 
moved around. You can use the window to pan the dependency view or to zoom 
in or out of the dependency view. 

The Navigator also has two icons located on the lower right side of the Navigator 
window. Click the round arrow to reset the dependency view to its original size. 
Click the diagonal arrow to collapse the Navigator.

To pan (or move around) in the dependency view

◆ Click and hold anywhere in the red window, then move the window while 
still holding the mouse button.

To zoom in or zoom out of the dependency view

◆ Click and hold the lower right corner of the red window, then move the 
mouse in the desired direction to stretch the window. To zoom in, make the 
window smaller. To zoom out, make the window bigger. 

The window can be stretched in any direction. You might have to move the 
window around to stretch it in a better way.

Summary information on the map view
The map view is a graphical representation of an object’s relationship with other 
objects. These objects can be service groups, systems, or virtual objects. The 
object connection is represented by lines of various colors. The colors indicate 
the status of the main object with respect to the connected object. For example, 
in the case of a service group, a red line indicates that the service group is 
faulted on the connected system, a blue line indicates that the service group is 

Show/Hide Run In 
Container resources

Shows or hides the run-in container resources. 

This icon is available only in the resource dependency view. The 
container resource icons are marked with a shaded green rectangle 
in the dependency view.
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online on the connected system, and a gray line indicates that the service group 
is offline on the connected system.

The map view contains five icons which are located on the left side of the map 
view page. The first four icons provide access to panels. The panels provide 
access to additional information and map view settings. Click an icon to hide or 
display the respective panel.

Service group simulation menu commands
Simulation operations are available only in the VCS One Simulator and not in 
real-time product deployment. In the right pane of the Service Groups section, 
the Simulation menu contains the Fault Service Groups command. This 
command enables you to simulate a fault in one or more service groups. 

More information is available about how to induce a service group fault. 

See “Faulting a service group in the Simulator” on page 385.

Table 7-14 Map view icons

Icon Description

Details panel

This panel displays information about the service group and status of the 
service group on various systems.

Filters panel

The filter panel has options for controlling the types of groups displayed. 
Use the Expand All option to expand all the objects that are displayed in the 
map.

Settings panel

The Settings panel has options to control the information that is displayed in 
the map. The panel also contains a slider bar which you can use to adjust the 
space between the map objects. Adjust the object spacing if the map view 
appears cluttered because of too many objects.

Legend

The legend panel depicts the icons that are used to represent objects in the 
map view. In the Legend panel, you can click the arrow icon next to the object 
icon to display the legend for that object.

Pause Graph

You can click this icon to pause the movement of the graph.
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Composite Service Groups operations
Clicking the Composite Service Groups menu item displays the task menu bar 
which is located in the right pane below the breadcrumb bar. Each menu 
contains commands which you can use to perform composite service group 
operations.

Summary information on the Composite Service Groups 
default view
The Composite Service Groups default view displays a tabular list of composite 
service groups for a selected OU node or set. 

For each composite service group, the table contains the following information:

■ The name of the composite service group. The name can be expanded to see 
the list of the service groups that make up the composite service group. You 
can perform operations on the service groups by selecting them inline, then 
right-clicking to select the appropriate command.

■ The current status of the composite service group. 

■ The OU to which the composite service group belongs.

■ The information about whether the composite service group needs 
attention.

■ The status of the composite service group on the remote cluster.

■ The authority of the composite service group.

Table 7-15 Composite Service Groups menus

Menu Description

Operations Contains commands to perform operations such as bringing a 
composite service group online or taking it offline, flushing a 
composite service group, and switching a composite service group.

See “Composite service group operations menu commands” on 
page 157.

Configuration Contains commands to perform operations such as adding, modifying, 
and moving a composite service group.

See “Composite service group configuration menu commands” on 
page 157.

Views Contains the command to view all attributes of the composite service 
group.

See “Composite service group view menu commands” on page 158.
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You can control the display of the columns by changing the table settings. 

See “To change the table settings” on page 128.

Composite service group operations menu commands
In the right pane of the Composite Service Groups view, the Operations menu 
has commands for managing composite service groups.

Composite service group configuration menu commands
In the right pane of the Composite Service Groups section, the Configuration 
menu has commands for configuring composite service groups.

Table 7-16 Composite service group Operations menu commands

Command Description

Online CSG(s) Brings the selected composite service group online.

See “Bringing a composite service group online” on page 418.

Offline CSG(s) Takes the selected composite service group offline.

See “Taking a composite service group offline” on page 419.

Flush CSG(s) Cancels the online or offline operation that is currently being 
performed on the composite service group.

See “Flushing a pending action on a composite service group” on 
page 420.

Request Authority Requests authority for a global composite service group.

See “Requesting authority for a global CSG” on page 615.

Switch CSG Brings a global composite service group online on another system 
in a different VCS One cluster site.

See “Switching a global CSG” on page 618.

Table 7-17 Composite service group Configuration menu commands

Command Description

Add CSG Adds a composite service group using the Composite Service 
Group Configuration wizard.

See “Creating a composite service group” on page 406.

Delete CSG(s) Deletes one or more composite service groups.

See “Deleting a composite service group” on page 416.



158 Using the VCS One console
Manage menu options
Composite service group view menu commands
In the right pane of the Composite Service Group view, the Views menu has 
commands for managing composite service group views.

Systems operations
Clicking the Systems menu item displays the task menu bar which is located in 
the right pane below the breadcrumb bar. Each menu contains commands which 
you can use to perform system operations.

Edit GroupList Changes the group list of the selected composite service group.

See “Modifying the list of groups in the CSG” on page 412.

Edit VFrameList Changes the VFrame list of the selected composite service group.

Move CSG(s) Moves one or more composite service groups to another node in 
the organization tree.

See “Moving a local composite service group in the organization 
tree” on page 417.

Configure Global 
CSG

Changes the VCS One cluster list of the selected composite service 
group. The VCS One cluster list determines whether the composite 
service group is local or global.

See “Configuring a global CSG” on page 614.

Table 7-18 Composite service group Views menu commands

Command Description

All Attributes 
(CSG)

Displays all attributes of the selected composite service group.

See “Editing a composite service group’s attributes” on page 415.

Table 7-17 Composite service group Configuration menu commands

Command Description

Table 7-19 Systems menus

Menu Description

Operations Contains commands to perform operations such as freezing or 
unfreezing a system, and stopping the system.

See “System operations menu commands” on page 160.
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Summary information on the Systems default view
The Systems default view displays the list of systems for a selected OU node or 
set in a table form. 

For each system, the table contains the following information:

■ The name of the system. 

■ The current status of the system. 

■ The capacity dimension values specified for the system.

■ The platform that the system runs. 

■ The name of the virtual machine on which the system is configured.

■ The name of the OUValue to which the system belongs. 

■ Other relevant system information. This information includes special 
conditions, such as whether a system is in the FROZEN state or DDNA state. 

You can display additional information such as the date of creation and IP 
address by changing the table settings. 

See “To change the table settings” on page 128.

Configuration Contains commands to perform operations such as moving and deleting 
a system.

See “Systems configuration menu commands” on page 160.

Views Contains commands to view the service groups in a map view.

See “Systems view menu commands” on page 161.

Simulation Contains commands to perform simulation operations such as inducing 
a system fault.

See “Systems simulation menu commands” on page 162.

Table 7-19 Systems menus

Menu Description
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System operations menu commands
In the right pane of the Systems view, the Operations menu has commands for 
managing systems.

Systems configuration menu commands
In the right pane of the Systems view, the Configuration menu has commands 
for configuring systems.

Table 7-20 System Operations menu commands

Command Description

Freeze Freezes one or more systems.

See “Freezing a system” on page 344.

Unfreeze Unfreezes one or more systems.

See “Unfreezing a system” on page 345.

Stop System(s) Stops the selected systems.

See “Putting a system in the offline state” on page 352.

Mark as Faulted Faults the selected system.

See “Faulting a system” on page 348.

Table 7-21 System Configuration menu commands

Command Description

Add System Adds a system to the VCS One cluster.

See “Adding a system to the VCS One cluster” on page 336.

Delete System(s) Deletes one or more systems.

See “Deleting a system from the VCS One cluster” on page 342.

Move System(s) Moves one or more systems to another node in the organization 
tree.

See “Moving a system to another organization tree node” on 
page 350.

Edit Attributes Edits the system attributes. Use this command to edit common 
attributes of multiple systems in a single batch operation.

See “Editing system attributes” on page 341.
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Systems view menu commands
In the right pane of the Systems view, the Views menu has commands for 
managing system views.

Edit Extended 
Attribute(s)

Edits the extended attributes of the selected systems. Use this 
command to edit common extended attributes of multiple systems 
in a single batch operation.

See “Assigning an extended attribute a value” on page 635.

Link VFrame Links a VFrame to a system.

See “Linking a VFrame to a system” on page 516.

Unlink VFrame Unlinks a Vframe from a system.

See “Unlinking a VFrame from a system” on page 518.

Enable VMHA Enables high availability for an application running inside a 
VFrame.

See “Configuring VFrame high availability” on page 513.

Disable VMHA Disables high availability for an application running inside a 
VFrame.

See “Configuring VFrame high availability” on page 513.

Table 7-22 System Views menu commands

Command Description

Map View Displays the object relationship of a system in a graphical way.

See “Summary information on the map view” on page 154.

Workload Displays the workload view for the selected systems.

For more information about the Workload view, see “Workload menus” 
on page 136.

All Attributes Displays all attributes of the selected system in a separate window.

Table 7-21 System Configuration menu commands

Command Description
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Systems simulation menu commands
Simulation operations are available only in the VCS One Simulator and not in 
real-time product deployment. In the right pane of the Systems view, the 
Simulation menu has commands for simulating system operations.

Table 7-23 Systems Simulation menu commands

Command Description

Start Systems Starts a faulted system.

See “Repairing a system using the Simulator” on page 349.

Fault System Simulates a system fault.

See “Faulting a system using the Simulator” on page 349.

Simulate Daemon 
Dead

Simulates a daemon dead node alive (DDNA) situation.

See “Simulating a system in DDNA state” on page 353.
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Resources operations
Clicking the Resources menu item displays the task menu bar which is located 
in the right pane below the breadcrumb bar. Each menu contains commands 
which you can use to perform resource operations.

Summary information on the Resources default view
The Resources default view displays the list of resources for a selected OU node 
or set in a table form. The list of displayed resources also depends on your 
privileges.

For each resource, the table contains the following information:

■ The name of the resource.

■ The current state of the resource. 

■ The resource type.

■ The name of the service group to which the resource belongs.

■ The date when the resource state was last updated.

You can display additional information such as the date of creation by changing 
the table settings. 

See “To change the table settings” on page 128.

Table 7-24 Resources menus

Menu Description

Operations Contains commands to perform operations such enabling or disabling a 
resource, bringing the resource online or offline, and clearing a resource 
fault.

See “Resource operations menu commands” on page 164.

Configuration Contains the command for removing a resource.

See “Resources configuration menu commands” on page 165.

Views Contains commands to view the resource types and all attributes of a 
selected resource.

See “Resources view menu commands” on page 165.

Simulation Contains commands to perform simulation operations such as inducing a 
resource fault and clearing a simulated fault and bringing the resource 
online.

See “Resources simulation menu commands” on page 165.
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Resource operations menu commands
In the right pane of the Resources view, the Operations menu has commands for 
managing resources.

Table 7-25 Resource Operations menu commands

Command Description

Online Brings the selected resource online.

See “Bringing a resource online” on page 431.

Offline Takes the selected resource offline.

See “Taking a resource offline” on page 432.

Offline Propagate Takes the selected resource and all its children offline.

See “Taking parent and child resources offline concurrently” on 
page 432.

Probe Probes the selected resource.

See “Probing a resource” on page 433.

Enable Resources Enables a resource.

See “Enabling resources in a service group” on page 429.

Disable Resources Disables a resource.

See “Disabling resources in a service group” on page 430.

Clear Fault Clears the resource fault.

See “Clearing a resource fault” on page 435.

Clear Admin Wait Clears a resource having the ADMIN_WAIT state.

See “Clearing resources in the ADMIN_WAIT state” on page 436.

Actions Runs actions for the selected resource.

For more information about actions, see “About designing the 
actions taken after a fault” on page 260.
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Resources configuration menu commands
In the right pane of the Resources view, the Configuration menu has commands 
for configuring resources.

Resources view menu commands
In the right pane of the Resources view, the Views menu has commands for 
viewing resource types and resource attributes.

Resources simulation menu commands
Simulation operations are available only in the VCS One Simulator and not in 
real-time product deployment. In the right pane of the Resources view, the 
Simulation menu has commands for simulating resource operations.

Table 7-26 Resource Configuration menu command

Command Description

Delete Resource Removes the selected resource.

See “Deleting a resource from a service group” on page 427.

Table 7-27 Resource Views menu command

Command Description

Resource Types View the resource types available in the configuration and related 
detailed information.

See “Viewing resources in the configuration by resource type” on 
page 439.

All Attributes Displays all attributes of the selected resource in a separate 
window. You can edit the attributes from this window.

See “Editing resource attributes” on page 428.

Table 7-28 Resources Simulation menu commands

Command Description

Fault Resource Simulates a resource fault.

See “Faulting a resource using the Simulator” on page 433.

Clear Fault and 
Online

Repairs a faulted resource and brings it online.

See “Repairing a resource using the Simulator” on page 434.
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Disaster Recovery operations
Clicking the Disaster Recovery menu item displays the task menu bar which is 
located in the right pane below the breadcrumb bar. Each menu contains 
commands which you can use to perform disaster recovery operations.

Summary information on the Disaster Recovery default view
The Disaster Recovery default view displays the list of remote clusters in a table 
form. The list of remote clusters that are displayed also depends on your 
privileges.

For each remote cluster, the table contains the following information:

■ The name of the remote cluster. 

■ The state of the remote cluster. 

■ Whether the remote cluster is enabled or not.

■ The connection details of the remote cluster.

■ The link status of the remote cluster.

■ The port of the remote cluster.

You can choose which columns display by changing the table settings. 

See “To change the table settings” on page 128.

Table 7-29 Disaster Recovery menus

Menu Description

Operations Contains commands to perform operations such enabling or disabling a 
connection, taking over a composite service group, bringing a CSG online, 
taking a CSG offline, and requesting authority.

See “Disaster Recovery operations menu commands” on page 167.

Configuration Contains commands for adding a remote cluster, modifying a remote 
cluster, removing a remote cluster, and configuring global CSGs.

See “Disaster Recovery configuration menu commands” on page 168.

Views Contains the command to view all attributes of a selected resource.

See “Disaster Recovery view menu command” on page 168.

Simulation Contains commands to perform simulation operations such as inducing a 
fault in the remote cluster, faulting one or more links, and clearing one or 
more simulated link faults.

See “Disaster Recovery simulation menu commands” on page 169.
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Disaster Recovery operations menu commands
In the Disaster Recovery view, the Operations menu has commands for 
managing connections and composite service groups.

Table 7-30 Disaster Recovery Operations menu commands

Command Description

Enable 
Connection(s)

Enables connections between VCS One clusters.

See “Enabling connections between clusters” on page 600.

Disable 
Connection(s)

Disables connections between VCS One clusters.

See “Disabling connections between clusters” on page 601.

Take Over CSG(s) Takes over a global composite service group. A takeover operation 
brings the global CSG online on the local VCS One cluster. 

See “Taking over a global CSG” on page 619.

Online CSG(s) Brings the selected global composite service groups online.

See “Bringing a global CSG online” on page 616.

Offline CSG(s) Takes the selected global composite service groups offline.

See “Taking a composite service group offline” on page 419.

Flush CSG(s) Cancels the online or offline operation that is currently being 
performed on the composite service group.

See “Flushing a pending action on a composite service group” on 
page 420.

Request Authority Requests authority for a global composite service group.

See “Requesting authority for a global CSG” on page 615.

Switch CSG Switches the selected composite service group. When you switch a 
composite service group it is taken offline from its current system 
and brought online on another system.
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Disaster Recovery configuration menu commands
In the Disaster Recovery view, the Configuration menu has commands for 
configuring remote VCS One clusters.

Disaster Recovery view menu command
In the Disaster Recovery view, the Views menu has the command for viewing 
remote cluster attributes.

Table 7-31 Disaster Recovery Configuration menu command

Command Description

Add Remote Cluster Adds a remote VCS One cluster.

See “Adding remote clusters” on page 594.

Modify Remote 
Cluster

Modifies a remote VCS One cluster.

See “Modifying remote cluster configuration” on page 604.

Delete Remote 
Cluster(s)

Deletes one or more remote VCS One clusters.

See “Deleting remote clusters” on page 600.

Configure Global 
CSG

Configures a global CSG.

See “Configuring a global CSG” on page 614.

Table 7-32 Disaster Recovery Views menu command

Command Description

All Attributes Displays all attributes of the selected resource in a separate 
window. You can edit the attributes from this window.

See “Editing resource attributes” on page 428.
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Disaster Recovery simulation menu commands
Simulation operations are available only in the VCS One Simulator and not in 
real-time product deployment. In the Disaster Recovery view, the Simulation 
menu has commands for simulating remote VCS One cluster operations.

PFrames operations
Clicking the PFrames menu item displays the task menu bar which is located in 
the right pane below the breadcrumb bar. Each menu contains commands which 
you can use to perform virtualization-related operations.

Table 7-33 Disaster Recovery Simulation menu commands

Command Description

Fault Remote 
Cluster(s)

Simulates a fault in the remote VCS One cluster.

See “Faulting a remote cluster using the Simulator” on page 610.

Fault Link(s) Simulates a link fault.

See “Simulating a link fault” on page 611.

Clear Link Fault(s) Clears a link fault.

See “Clearing a simulated link fault” on page 612.

Table 7-34 PFrames menus

Menu Description

Operations Contains commands to perform operations such as freezing or 
unfreezing PFrames, and stopping PFrames.

See “PFrames operations menu commands” on page 170.

Configuration Contains commands to perform operations such as adding or deleting a 
PFrame, and associating or disassociating management consoles.

See “PFrames configuration menu commands” on page 171.

Views Contains commands to view the PFrames in a map view or workload 
view.

See “PFrames view menu commands” on page 172.

Simulation Contains commands to perform simulation operations such as inducing 
a system fault.

See “PFrames simulation menu commands” on page 172.
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Summary information on the PFrames default view
The PFrames default view displays the list of physical frames in a table form. 
The list of physical frames that are displayed also depends on your privileges.

For each physical frame, the table contains the following information:

■ The name of the physical frame. 

■ The status of the physical frame. 

■ The load and capacity details of the physical frame.

■ The number of VFrames configured on the physical frame.

■ The management console associated with the physical frame.

■ The technology of the physical frame such as ESX.

You can choose which columns display by changing the table settings. 

See “To change the table settings” on page 128.

PFrames operations menu commands
In the right pane of the PFrames view, the Operations menu has commands for 
managing physical frames.

Table 7-35 PFrames Operations menu commands

Command Description

Stop PFrame(s) Stops the client daemon on a PFrame.

See “Stopping the client daemon on a PFrame” on page 497.

Freeze Freezes one or more PFrames.

See “Freezing a PFrame” on page 495.

Unfreeze Unfreezes one or more frozen PFrames (removes the restriction of 
the frozen state).

See “Unfreezing a PFrame” on page 496.

Mark as Faulted Marks one or more PFrames as faulted.

See “Faulting a PFrame in the DDNA state” on page 497.
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PFrames configuration menu commands
In the right pane of the PFrames view, the Configuration menu has commands 
for configuring physical frames.

Table 7-36 PFrames Configuration menu commands

Command Description

Add PFrame Adds a PFrame to the VCS One cluster.

See “Adding an PFrame” on page 492.

Delete PFrame(s) Deletes one or more PFrames. Deleting a PFrame removes it from 
the configuration.

See “Deleting a PFrame” on page 495.

Edit Attribute(s) Edits the attributes of selected PFrames. Use this command to 
edit common attributes of multiple PFrames in a single batch 
operation.

See “Editing an attribute for a instance of a PFrame” on 
page 498.

Edit Extended 
Attribute(s)

Edits the extended attributes of selected PFrames. Use this 
command to edit common extended attributes of multiple 
PFrames in a single batch operation.

See “Editing the extended attributes of a PFrame” on page 499.

Associate 
Management Console

Associates the PFrame with a VMware vCenter Server 
Management Console.

See “Associating a vCenter Server management console to a 
PFrame” on page 486.

Disassociate 
Management Console

Disassociates the PFrame from a VMware vCenter Server 
Management Console.

See “Disassociating a vCenter Server Management console from 
an ESX server” on page 487.

Move PFrame(s) Moves one or more PFrames to another node in the organization 
tree.

See “Moving a PFrame in the organization tree” on page 501.

Add Management 
Console

Adds a VMware vCenter Server Management Console.

See “Adding a management console” on page 482.
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PFrames view menu commands
In the right pane of the PFrames view, the Views menu has commands for 
viewing physical frames.

PFrames simulation menu commands
Simulation operations are available only in the VCS One Simulator and not in 
real-time product deployment. 

In the right pane of the PFrames view, the Simulation menu has commands for 
simulating physical frames operations.

Discover Virtual 
Infrastructure

Discovers your existing VMware ESX-based environment. You 
can use this command to add PFrames and VFrames rather than 
doing it manually.

See “Importing objects from an existing VMware virtual 
environment into the VCS One configuration” on page 478.

Table 7-37 PFrames Views menu commands

Command Description

Map View Displays the PFrame’s relationship with other objects in a 
graphical way.

Workload Displays PFrames in the workload view.

VTypes Displays a list of all virtual server types. To view all attributes for a 
virtual server type, click the virtual server type name.

All Attributes Displays all attributes of the selected PFrame.

Table 7-38 PFrames Simulation menu commands

Command Description

Start PFrame(s) Simulates a PFrame-based physical server booting in the cluster.

See “Starting a PFrame in the Simulator” on page 503.

Fault PFrame(s) Simulates a fault in the selected PFrame.

See “Faulting a PFrame in the Simulator” on page 503.

Table 7-36 PFrames Configuration menu commands

Command Description
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Simulate Daemon 
Dead

Simulates the Daemon Dead Node Alive (DDNA) state of a PFrame.

See “Simulating a PFrame in ddna state” on page 504.

Table 7-38 PFrames Simulation menu commands

Command Description
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VFrames operations
Clicking the VFrames menu item displays the task menu bar which is located in 
the right pane below the breadcrumb bar. Each menu contains commands which 
you can use to perform virtualization-related operations.

Summary information on the VFrames default view
The VFrames default view displays the list of virtual frames in a table form. The 
list of virtual frames that are displayed also depends on your privileges.

For each virtual frame, the table contains the following information:

■ The name of the virtual frame.

■ The status of the virtual frame.

■ The priority of the virtual frame.

■ The technology of the virtual frame such as Solaris/Sparc.

■ The composite service group to which the virtual frame belongs.

■ The load and capacity details of the virtual frame.

■ The dependency.

■ Other information such as whether the virtual frame is probed on any 
physical frame.

■ The linked system.

Table 7-39 VFrames menus

Menu Description

Operations Contains commands to perform operations such as freezing or 
unfreezing VFrames, and bringing a VFrame online or taking it offline.

See “VFrames operations menu commands” on page 175.

Configuration Contains commands to perform operations such as adding or deleting a 
VFrame, and associating or disassociating management consoles.

See “VFrames configuration menu commands” on page 176.

Views Contains commands to view the VFrames in a map view or workload 
view.

See “VFrames view menu commands” on page 178.

Simulation Contains commands to perform simulation operations such as inducing 
a system fault.

See “VFrames simulation menu commands” on page 178.
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■ The guest operating system.

You can choose which columns display by changing the table settings. 

See “To change the table settings” on page 128.

VFrames operations menu commands
In the right pane of the VFrames view, the Operations menu has commands for 
managing virtual frames.

Table 7-40 VFrames Operations menu commands

Command Description

Online Brings a VFrame online on a PFrame.

See “Bringing a VFrame online” on page 525.

Offline Takes a VFrame offline from a PFrame.

See “Taking a VFrame offline” on page 526.

Probe All Resources Probes the resources in a VFrame. You must enable the resources 
before you can probe them.

See “Probing a VFrame” on page 527.

Enable All Resources Enables all the resources in a VFrame.

See “Enabling all resources in a VFrame” on page 528.

Disable All 
Resources

Disables all the resources in a VFrame.

See “Disabling all resources in a VFrame” on page 529.

Enable Enables a VFrame so that it can be actively managed by VCS One.

See “Enabling a VFrame” on page 527.

Disable Disables a VFrame. When a VFrame is disabled, it remains in the 
configuration but is not available to be managed by VCS One.

See “Disabling a VFrame” on page 528.

Freeze Freezes a VFrame. Freezing a VFrame is useful when you want to 
stop actions, such as maintenance activities, from triggering a 
virtual machine failover.

See “Freezing a VFrame” on page 532.

Unfreeze Unfreezes a VFrame. Unfreezing a VFrame removes the 
restrictions of the frozen condition.

See “Unfreezing a VFrame” on page 532.
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VFrames configuration menu commands
In the right pane of the VFrames view, the Configuration menu has commands 
for configuring virtual frames.

Clear Fault Clears the fault in a VFrame.

See “Clearing a VFrame fault” on page 533.

Clear All Faults 
under OU

Clears all the VFrame faults in the branch of the organization tree.

See “Clearing all VFrame faults by organization unit” on page 534.

Refresh PFrame List Refreshes the PFrame list of a VFrame.

See “Refreshing the PFrame list of a VFrame” on page 523.

Switch Switches a VFrame from one PFrame to another PFrame.

See “Switching a VFrame between PFrames” on page 530.

Table 7-41 VFrames Configuration menu commands

Command Description

Add VFrame Adds a VFrame.

See “Adding a VFrame” on page 507.

Modify VFrame Modifies the Priority and Advanced Workload Management 
values for a VFrame.

See “Modifying a VFrame” on page 511.

Delete VFrame(s) Deletes a VFrame. Deleting a VFrame deletes all the resources 
configured on the VFrame, and removes the VFrame from the 
VCS One configuration.

See “Deleting a VFrame” on page 514.

Add/Modify Resource Adds or modifies VFrame resources.

See “Adding or modifying VFrame resources” on page 512.

Edit Attribute(s) Edits the attributes of selected VFrames. Use this command to 
edit common attributes of multiple VFrames in a single batch 
operation.

See “Editing attributes for a instance of a VFrame” on page 519.

Table 7-40 VFrames Operations menu commands

Command Description



177Using the VCS One console
Manage menu options
Edit Extended 
Attribute(s)

Edits the extended attributes of selected VFrames. Use this 
command to edit common extended attributes of multiple 
VFrames in a single batch operation.

See “Editing the extended attributes of a VFrame” on page 520.

Edit Fault Policy Edits the actions a VFrame takes after a fault.

See “Modifying the fault policy of a VFrame” on page 521.

Edit PFrame List Modifies the list of ESX servers on which an ESX virtual machine 
may run.

See “Modifying the Pframe list of an ESX virtual machine” on 
page 522.

Edit Compatibility Modifies the compatibility of a VFrame.

See “Modifying compatibility of a VFrame” on page 523.

Link System Links a VFrame to a system.

See “Linking a VFrame to a system” on page 516.

Unlink System Unlinks a VFrame from a system.

See “Unlinking a VFrame from a system” on page 518.

Associate 
Management Console

Associates the VFrame with a VMware vCenter Server 
Management Console.

See “Associating a vCenter Server management console to a 
PFrame” on page 486.

Disassociate 
Management Console

Disassociates the VFrame from a VMware vCenter Server 
Management Console.

See “Disassociating a vCenter Server Management console from 
an ESX server” on page 487.

Move VFrame(s) Moves one or more VFrames to another node in the organization 
tree.

See “Moving a VFrame in the organization tree” on page 524.

Manage Dependencies Creates dependencies to a VFrame or removes dependencies 
from a VFrame.

See “Modifying Vframe dependencies” on page 515.

Add to CSG Adds a VFrame to a composite service group.

See “Adding a VFrame to a composite service group” on 
page 529.

Table 7-41 VFrames Configuration menu commands

Command Description
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VFrames view menu commands
In the right pane of the VFrames view, the Views menu has commands for 
viewing virtual frames.

VFrames simulation menu commands
Simulation operations are available only in the VCS One Simulator and not in 
real-time product deployment. 

Delete from CSG Deletes a VFrame from a composite service group.

See “Deleting a VFrame from a composite service group” on 
page 530.

Add Management 
Console

Adds a VMware vCenter Server Management Console.

See “Adding a management console” on page 482.

Discover Virtual 
Infrastructure

Discovers your existing VMware ESX-based environment. You 
can use this command to add PFrames and VFrames rather than 
doing it manually.

See “Importing objects from an existing VMware virtual 
environment into the VCS One configuration” on page 478.

Table 7-42 VFrames Views menu commands

Command Description

Resource 
Dependencies

Displays the resource dependencies for a selected service group in 
a separate window.

Group/VFrame 
Dependencies

Displays the VFrame dependencies for a selected VFrame in a 
separate window.

Workload Displays VFrames in the workload view.

Map View Displays the VFrame’s relationship with other objects in a 
graphical way.

All Attributes Displays all attributes of the selected VFrame.

VTypes Displays a list of all virtual server types. To view all attributes for a 
virtual server type, click the virtual server type name.

GTQ View Displays the Group Transition Queue for VFrames.

Table 7-41 VFrames Configuration menu commands

Command Description
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In the right pane of the VFrames view, the Simulation menu has commands for 
simulating virtual frames operations.

Management Consoles operations
Clicking the Management Consoles menu item displays the task menu bar which 
is located in the right pane below the breadcrumb bar. Each menu contains 
commands which you can use to perform virtualization-related operations.

Summary information on the Management Consoles default 
view
The Management Consoles default view displays the list of management 
consoles in a table form. The list of management consoles that are displayed also 
depends on your privileges.

For each management console, the table contains the following information:

■ The name of the management console.

■ The technology of the management console such as VMWareVC.

■ The date on which the management console was created.

■ The OU value.

You can choose which columns display by changing the table settings. 

See “To change the table settings” on page 128.

Table 7-43 VFrames Simulation menu commands

Command Description

Fault VFrame(s) Simulates a fault in the selected VFrame.

See “Faulting a VFrame in the Simulator” on page 534.

Migrate Migrates a VFrame from one simulated DR site to another.

See “Migrating a VFrame to a different PFrame” on page 531.

Table 7-44 Management Consoles menu

Menu Description

Configuration Contains commands to perform operations such as adding and deleting 
a management console, and discovering virtual infrastructure.

See “Management Consoles configuration menu commands” on 
page 180.
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Management Consoles configuration menu commands
In the right pane of the Management Consoles view, the Configuration menu has 
commands for configuring management consoles.

Jobs operations
Clicking the Jobs menu item displays the task menu bar which is located in the 
right pane below the breadcrumb bar. Each menu contains commands which you 
can use to perform job operations.

Table 7-45 Management Consoles Configuration menu commands

Command Description

Add Management 
Console

Adds a VMware vCenter Server Management Console.

See “Adding a management console” on page 482.

Discover Virtual 
Infrastructure

Discovers your existing VMware ESX-based environment. You 
can use this command to add PFrames and VFrames rather than 
doing it manually.

See “Importing objects from an existing VMware virtual 
environment into the VCS One configuration” on page 478.

Delete Management 
Console(s)

Deletes a VMware vCenter Server Management Console.

See “Deleting a management console” on page 489.

Synchronize Synchronizes the virtual environment with the VCS One 
configuration.

See “Synchronizing the virtual environment” on page 483.

Table 7-46 Jobs menus

Menu Description

Operations Contains commands to perform operations such exporting or importing 
a job.

See “Job operations menu commands” on page 181.

Configuration Contains commands to perform operations such as adding and deleting 
a job.

See “Job configuration menu commands” on page 182.

Views Contains commands to view event types that are associated with a job.

See “Job view menu commands” on page 182.



181Using the VCS One console
Manage menu options
Summary information on the Jobs default view
The Jobs default view displays the list of jobs for a selected OU node. The list of 
displayed jobs also depends on your privileges.

For each job, the table contains the following information:

■ The name of the job. 

■ The rules count. 

■ The OU value to which the job belongs.

■ The name of the user who created the job.

■ The job description.

You can hide or show columns by changing the table settings. 

See “To change the table settings” on page 128.

The complete information for a particular job can be viewed by clicking the job 
name on the jobs listing page. From the job details page, you can perform 
operations such as running the job, modifying the job, cloning the job, and 
deleting the job.

More information is available about how to perform job operations. 

See “Managing automated tasks” on page 453.

Job operations menu commands
In the right pane of the Jobs view, the job Operations menu has commands for 
managing jobs.

Table 7-47 Job Operations menu commands

Command Description

Run Job Runs a job.

See “Running a job” on page 469.

Export Job(s) Exports one or more jobs.

See “Exporting a rule or a job to an XML file” on page 473.

Import Job Imports an existing job.

See “Importing a rule or a job from an XML file” on page 474.
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Job configuration menu commands
In the right pane of the Jobs view, the job Configuration menu has commands for 
configuring jobs.

Job view menu commands
The job Views menu contains the following command: 

■ Event Types

Displays the event types that are associated with a job.

Business Rules and Notification Rules operations
Clicking the Business Rules menu item or the Notification Rules item displays 
the task menu bar which is located in the right pane below the breadcrumb bar. 
Each menu contains commands which you can use to perform rule operations.

Table 7-48 Job Configuration menu commands

Command Description

Add Job Adds a new job.

See “Creating a job” on page 466.

Modify Job Modifies the selected job.

See “Modifying a job” on page 468.

Delete Job(s) Deletes one or more jobs.

See “Deleting a job” on page 469.

Clone Job Creates one or more copies of the selected job.

See “Cloning a job” on page 468.
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Note: Although rules are classified under the business and notification 
categories, most of the commands and wizards are common to both types of 
rules.

Summary information on the Business Rules and Notification 
Rules default view
Based on the organization tree node that is selected in the left pane, the relevant 
information is displayed for all the rules that are defined for that node. You can 
display additional information by changing the table settings.

See “To change the table settings” on page 128.

The complete information for a particular rule can be viewed by clicking the rule 
name on the rules listing page. From the rule details page, you can perform 
operations such as modifying the rule, cloning the rule, and deleting the rule.

More information is available about how to perform rule operations. 

See “Managing automated tasks” on page 453.

Table 7-49 Business Rules and Notification Rules menus

Menu Description

Operations Contains commands to perform operations such enabling or disabling a 
rule.

See “Rule operations menu commands” on page 184.

Configuration Contains commands to perform operations such as adding and deleting a 
rule.

See “Rule configuration menu commands” on page 184.

Views Contains commands to view event types that are associated with a rule.

See “Rule view menu commands” on page 185.
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Rule operations menu commands
In the right pane of the Business Rules and Notification Rules view, the rule 
Operations menu has commands for managing rules.

Rule configuration menu commands
In the right pane of the Business Rules and Notification Rules view, the rule 
Configuration menu has commands for configuring rules.

Table 7-50 Rule Operations menu commands

Command Description

Enable Rule(s) Enables one or more rules.

See “Enabling a rule” on page 470.

Disable Rule(s) Disables one or more rules.

See “Disabling a rule” on page 471.

Export Rule(s) Exports one or more rules.

See “Exporting a rule or a job to an XML file” on page 473.

Import Rule Imports an existing rule.

See “Importing a rule or a job from an XML file” on page 474.

Take Rule 
Ownership

Changes rule ownership.

See “Changing the owner of a rule” on page 470.

Table 7-51 Rule Configuration menu commands

Command Description

Add Rule Adds a new rule.

See “Creating a business rule” on page 456.

Modify Rule Modifies the selected rule.

See “Modifying a rule” on page 471.

Delete Rule(s) Deletes one or more rules.

See “Deleting a rule” on page 472.

Clone Rule Creates one or more copies of the selected rule.

See “Cloning a rule” on page 465.
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Rule view menu commands
The Business Rules and Notification Rules Views menu contains the following 
command:

■ Event Types

Displays the event types that are associated with a rule.

Logs menu options
The Logs menu provides access to various types of VCS One log messages. The 
log messages, time-stamped and labeled by severity, are displayed in the right 
pane.

About log message filters
You can use various types of filters to filter the log messages. The log message 
filters are available in the left pane. You can use either a single filter or a 

Add/Modify 
Conditions

Adds or modifies conditions for the selected business rule.

See “Adding or modifying conditions and filters for the rule” on 
page 462.

Table 7-51 Rule Configuration menu commands

Command Description

Table 7-52 Commands under the Logs menu

Command Description

Policy Master Logs Contain messages that are generated on the Policy Master by the 
Policy Master daemon, VCS One console, and VCS One commands.

Command Logs Contain messages that are generated by running commands from 
the VCS One console.

Event Logs These logs are associated with Business Policy Automation (BPA) 
and contain messages that are related to events.

Business Rules 
Execution Logs

These logs are associated with Business Policy Automation (BPA) 
and contain messages that are related to business rules.

Notification Rules 
Execution Logs

These logs are associated with Business Policy Automation (BPA) 
and contain messages that are related to notification rules.
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combination of multiple filters. The filters vary according to the log message 
type.

You can view the following types of filters from the VCS One console:

■ Policy Master log message filters

■ Event log message filters

■ Rule execution log message filters

About Policy Master log message filters
You can view specific Policy Master log messages using the following filters:

■ Severity

The severity filter uses the severity level which includes critical, error, 
warning, notice, and information.

See “Viewing log messages based on severity” on page 186.

■ Time

The time filter uses a period which includes the date and time.

See “Viewing log messages based on time” on page 187.

■ Data

The data filter uses a text filter or an object filter which filters messages 
using various object types such as systems, service groups, resources, users, 
composite service groups, and remote VCS One clusters. You can also 
choose to sort the results by relevance to the filter. You also have the option 
of filtering the messages using either all the filter keywords or at least one 
of the keywords.

See “Viewing log messages based on data” on page 187.

Viewing log messages based on severity

To view log messages based on severity

1 In the left pane, under Severity Filter, do one of the following: 

■ Click All to view log messages for all severities. 

■ Click None to clear all the currently selected log message severities. If 
you select this option, go to step 3.

■ Check the box that corresponds to the log message severity level that 
you want to view. Severity levels include Critical, Error, Warning, 
Notice, and Information.

2 If required, under Time Based Filter and Data Based Filter, enter the 
relevant search criteria.

3 Click Apply. 
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All log entries for the specified severity and time are displayed. 

Viewing log messages based on time

To view log messages based on time

1 In the left pane, under Time Based Filter, enter the start and the end date 
and time.

2 Click Apply. 

All log entries for the specified time period are displayed.

Viewing log messages based on data

To view log messages based on data

1 In the left pane, under Data Based Filter, select either the Text Filter or 
Object Filter option.

2 If you select Text Filter, enter the text string to be used as the filter.

3 If you select Object Filter, enter the relevant information against each of the 
object type boxes.

4 Click Apply. 

All log entries that match the specified data are displayed.

About event log message filters
You can view specific event log messages using the following filters:

■ Event category

The category filter uses the event source which includes events generated 
by the Policy Master and the scheduler, and manual events.

See “Viewing log messages based on event category” on page 188.

■ Event status

The status filter uses the event status which includes missed, in-process, 
and processed events.

See “Viewing log messages based on event status” on page 188.

■ Event severity

The severity filter uses the message type which includes critical, error, 
warning, and information.

See “Viewing log messages based on severity” on page 188.

■ Time

The time filter uses a period which includes the date and time.

See “Viewing log messages based on time” on page 189.
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■ Data

The data filter uses objects and event names to filters messages.

See “Viewing log messages based on data” on page 189.

Viewing log messages based on event category

To view log messages based on event category

1 In the left pane, under Event Category, do one of the following: 

■ Click All, to view log messages for all event categories.

■ Click None, to clear all the currently selected log message event 
categories. If you select this option, go to step 3.

■ Check the box that corresponds to the log message event category that 
you want to view. Category types include PM, Scheduler, and Manual.

2 If required, under Event Category, Event Severity, Time Based Filter, and 
Data Based Filter, enter the relevant search criteria.

3 Click Apply. 

All log entries for the specified filter information are displayed. 

Viewing log messages based on event status

To view log messages based on event status

1 In the left pane, under Event Status, do one of the following: 

■ Click All, to view log messages for all event status types.

■ Click None, to clear all the currently selected log message event status 
types. If you select this option, go to step 3.

■ Check the box that corresponds to the log message event status that 
you want to view. Status types include Missed, In Process, and 
Processed.

2 If required, under Event Category, Event Severity, Time Based Filter, and 
Data Based Filter, enter the relevant search criteria.

3 Click Apply. 

All log entries for the specified filter information are displayed. 

Viewing log messages based on severity

To view log messages based on severity

1 In the left pane, under Event Severity, do one of the following: 

■ Click All, to view log messages for all severities. 
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■ Click None, to clear all the currently selected log message severities. If 
you select this option, go to step 3.

■ Check the box that corresponds to the log message severity level that 
you want to view. Severity levels include Critical, Error, Warning, 
Notice, and Information.

2 If required, under Event Category, Event Status, Event Severity, and Data 
Based Filter, enter the relevant search criteria.

3 Click Apply. 

All log entries for the specified severity and time are displayed. 

Viewing log messages based on time

To view log messages based on time

1 In the left pane, under Time Based Filter, enter the start and the end date 
and time.

2 Click Apply. 

All log entries for the specified time period are displayed.

Viewing log messages based on data

To view log messages based on data

1 In the left pane, under Data Based Filter, select either the Event name Filter 
or Object Filter option.

2 If you select Event name Filter, enter the event name.

3 If you select Object Filter, enter the object name.

4 Click Apply. 

All log entries that match the specified data are displayed.

About rule execution log message filters
You can view specific rule execution log messages using the following filters:

■ Status

The status filter uses the event status which includes scheduled, successful, 
failed, running, and missed events.

See “Viewing log messages based on status” on page 190.

■ Time

The time filter uses a period which includes the date and time.

See “Viewing log messages based on time” on page 190.

■ Data
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The data filter uses owners, objects, rules, and jobs to filters messages.

See “Viewing log messages based on data” on page 190.

Viewing log messages based on status

To view log messages based on status

1 In the left pane, under Status Filter, do one of the following: 

■ Click All, to view log messages for all status types. 

■ Click None, to clear all the currently selected log message status types. 
If you select this option, go to step 3.

■ Check the box that corresponds to the log message status type that you 
want to view. Status types include Scheduled, Success, Failure, 
Running, and Missed Events.

2 If required, under Time Based Filter and Data Based Filter, enter the 
relevant search criteria.

3 Click Apply. 

All log entries for the specified filter information are displayed.

Viewing log messages based on time

To view log messages based on time

1 In the left pane, under Time Based Filter, enter the start and the end date 
and time.

2 Click Apply. 

All log entries for the specified time period are displayed.

Viewing log messages based on data

To view log messages based on data

1 In the left pane, under Data Based Filter, enter the relevant information in 
the data text boxes.

2 Click Apply. 

All log entries that match the specified data are displayed.

About log message deletion
You can delete command, rule, and job log messages to recover disk space or 
improve message retrieval performance. More information is available about 
deleting log messages.

See “Deleting event and rule log entries” on page 707.



191Using the VCS One console
Administration menu options
See “Deleting job log entries” on page 707.

Administration menu options
You can use the Administration menu to configure and administer All VCS One 
cluster users, roles, extended attributes, sets, and organization tree objects. You 
can use the menu items on the Administration menu to perform various 
operations and tasks on these objects.

Table 7-53 Commands under the Administration menu

Command Description

Users Provides access to the user-related commands.

See “Users operations” on page 192.

Roles Provides access to the roles-related commands.

See “Roles operations” on page 193.

Organization Units Provides access to the organization units-related commands.

See “Organization Units operations” on page 194.

Extended Attributes Provides access to the extended attributes-related commands.

See “Extended Attributes operations” on page 195.

Sets Provides access to the sets-related commands.

See “Sets operations” on page 197.

Global Settings Provides access to the global settings-related commands.

See “Settings operations” on page 198.

Automation Settings Provides access to the automation settings-related commands.

User Preferences Provides access to user settings such as showing the Welcome 
screen of VCS One wizards.
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Users operations
Clicking the Users menu item displays the Configuration menu which is located 
in the right pane below the breadcrumb bar. The Configuration menu contains 
commands which you can use to perform user and user group operations such as 
adding, deleting, moving, and enabling or disabling users and user groups.

See “Users and user groups configuration menu commands” on page 193.

Summary information on the Users default view
The Users default view displays a tabular list of users and user groups for a 
selected OU node or set. 

For each user or each user group, the table contains the following information:

■ The name of the user or user group. 

■ The type of user. VCS One supports both users and user groups. 

■ The organization unit to which the user or the user group is attached. 

■ The first name and last name of the user.

■ The date and time when the user last logged on to the console.

■ The logon status of the user.

■ The email address of the user or user group. 

■ The SNMP details of the user or user group. 

How to locate specific users 
You can use the organization tree to view users or user groups. To view all users 
and user groups that are attached to a specific Organization Tree node, navigate 
to that node.

You can click the Show all users link in the right pane to display all the VCS One 
users. This display also includes the users that VCS One uses internally. 
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Users and user groups configuration menu commands
In the right pane of the Users view, the Configuration menu has commands for 
configuring users and user groups.

Roles operations
Clicking the Roles menu item displays the Configuration menu which is located 
below the breadcrumb bar. The Configuration menu contains commands which 
you can use to perform role operations such as adding, deleting, and assigning 
or unassigning roles.

See “Roles configuration menu commands” on page 194.

Summary information on the Roles default view
The Roles default view displays a tabular list of predefined and user-defined 
roles for a selected OU node or set. 

Table 7-54 User and user group Configuration menu commands

Command Description

Add Users/User 
Groups

Adds a user or a user group to an organization tree node.

See “Adding or deleting a user or usergroup” on page 646.

Delete Users/User 
Groups

Deletes one or more users or user groups.

See “Adding or deleting a user or usergroup” on page 646.

Assign/Unassign 
Roles

Assigns or unassigns a role to one or more users or user groups.

See “Assigning or unassigning a role and objects to a user or 
usergroup” on page 649.

Enable Users/User 
Groups

Enables currently disabled users or user groups.

See “Enabling a user or usergroup” on page 655.

Disable Users/User 
Groups

Disables currently enabled users or user groups.

See “Disabling a user or usergroup” on page 656.

Move Users/User 
Groups

Moves one or more users or user groups to another node in the 
organization tree.

See “Moving a user to another Organization Tree node” on 
page 655.

Clone User/User 
Groups

Clones a user or a user group to an organization tree node.

See “Cloning a user or user group” on page 648.
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For each roles, the table contains the following information:

■ The name of the role. 

■ The type of VCS One objects that can be assigned to the role. 

■ The description of the role.

Roles configuration menu commands
In the right pane of the Roles view, the Configuration menu has commands for 
configuring roles.

Organization Units operations
Clicking the Organization Units menu item displays the Configuration menu 
which is located in the right pane below the breadcrumb bar. The Configuration 
menu contains commands which you can use to perform organization unit 
operations such as adding and deleting OUName and OUValue.

See “Organization units configuration menu commands” on page 195.

How to locate organization units
In the left pane of the Organization Units section, you can use the organization 
tree to locate organization units. Select the organization tree, and then navigate 
to a specific organization tree node to view the organization units that are 
associated with it.

If you select an OUName node from the organization tree, the associated 
OUValues are displayed in the right pane, under OUValues applicable for this 
OUName. The fully qualified name is also displayed for each OUValue.

Table 7-55 Role Configuration menu commands

Command Description

Add Role Adds a new role to the VCS One cluster.

See “Adding custom roles” on page 650.

Delete Role Deletes an existing role from the VCS One cluster.

See “Deleting a role” on page 653.

Clone Role Clones an existing role.

See “Cloning a role” on page 652.
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If you select an OUValue node from the organization tree, the associated 
OUNames are displayed in the right pane, under OUNames applicable for this 
OUValue. The fully qualified name is also displayed for each OUName.

Organization units configuration menu commands
In the right pane of the Organization Units view, the Configuration menu has 
commands for configuring organization units.

Extended Attributes operations
Clicking the Extended Attributes menu item displays the Configuration menu 
which is located in the right pane below the breadcrumb bar. The Configuration 
menu contains commands which you can use to perform extended attribute 
operations such as adding and deleting extended attributes.

See “Extended attributes configuration menu commands” on page 196.

Summary information on the Extended Attributes default 
view
The Extended Attributes default view displays a tabular list of all the VCS One 
cluster extended attributes for a selected OU node. 

For each extended attribute, the table contains the following information:

■ The name of the extended attribute. 

Table 7-56 Organization units Configuration menu commands

Command Description

Delete OUName Deletes an organization unit name from the organization tree.

See “Deleting an OUName node from the organization tree” on 
page 628.

Add OUName Adds an organization unit name to the organization tree.

See “How to build an organization tree” on page 624.

Delete OUValue Deletes an organization unit value from the organization tree.

See “Deleting OUValue nodes from the organization tree” on 
page 629.

Add OUValue Adds an organization unit value to the selected organization unit 
name node.

See “How to build an organization tree” on page 624.
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■ The extended attribute category. Categories include common, system, and 
group.

■ The extended attribute type. Extended attributes can be of type enumerated 
or freeform.

■ The valid values that can be applied to the extended attribute. 

■ The default value of the extended attribute. This value is assigned to the 
object if no other value is specified. 

■ The path of the organization tree node that is associated with the default 
value of the extended attribute. 

■ The description of the extended attribute. 

How to view extended attributes
In the left pane of the Extended Attributes section, you can use the organization 
tree to locate extended attributes. In the organization tree, navigate to a specific 
OUValue node to view the extended attributes that are associated with it. 

All the extended attributes are displayed in the right pane under the following: 

■ Locally-defined Extended Attributes 

All the extended attributes that are defined specifically for the selected 
organization tree node are displayed under Locally-defined Extended 
Attributes. The name, category, type, valid values, default values, and 
description of the extended attribute is displayed. 

■ Inherited Extended Attributes 

All the extended attributes that the selected organization tree node inherits 
from its preceding organization tree nodes are displayed under Inherited 
Extended Attributes. The name, category, type, valid values, default values, 
organization unit name where it is defined, and description of the extended 
attribute is displayed. 

Extended attributes configuration menu commands
In the right pane of the Extended Attributes view, the Configuration menu has 
commands for configuring extended attributes.

Table 7-57 Extended attributes Configuration menu commands

Command Description

Add Extended 
Attribute

Adds an extended attribute.

See “Defining an extended attribute” on page 634.
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Sets operations
Clicking the Sets menu item displays the Configuration menu which is located 
below the breadcrumb bar. The Configuration menu is also available on the sets 
details page. The Configuration menu contains commands which you can use to 
perform set operations such as adding, deleting, and modifying sets, and adding 
a custom view.

See “Sets list page configuration menu commands” on page 197.

See “Sets details page configuration menu commands” on page 198.

Summary information on the Sets default view
The Sets default view displays a tabular list of sets. Each VCS One user has a 
default set called My Objects. This set comprises all the VCS One objects that the 
user has privileges to view. This set cannot be edited or deleted.

For each set, the table contains the following information:

■ The name of the set. 

■ The description of the set. 

You can also create custom views for each set from the default view or from the 
details page of a set. You can add, delete, or modify custom views from the 
details page.

Sets list page configuration menu commands
In the sets list page the Configuration menu has commands for adding, 
modifying, removing sets, and for adding a custom view.

Delete Extended 
Attribute(s)

Deletes one or more extended attribute.

See “Deleting an extended attribute” on page 637.

Table 7-57 Extended attributes Configuration menu commands

Command Description

Table 7-58 Sets list page Configuration menu commands

Command Description

Add Set Adds a set.

See “Building a set” on page 666.
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Sets details page configuration menu commands
Click the name of a set to view the sets details page.

In the sets details page the Configuration menu has commands for configuring 
and removing sets, and for adding and removing custom views.

Settings operations
The Settings section under the Administration menu provides access to two 
types of VCS One settings—global settings and automation settings.

The global settings are available in the form of individual attributes which you 
can edit. 

See “Editing VCS One cluster attributes” on page 632.

Modify Set Modifies the selected set.

See “Modifying a set” on page 669.

Delete Set(s) Deletes one or more sets.

See “Deleting a set” on page 668.

Add Custom View Adds a custom view.

See “Configuring a custom view of the organization tree and 
extended attributes” on page 669.

Table 7-59 Sets details page Configuration menu commands

Command Description

Modify Set Modifies the selected set.

See “Modifying a set” on page 669.

Delete Set Deletes the selected set.

See “Deleting a set” on page 668.

Add Custom View Adds a custom view.

See “Configuring a custom view of the organization tree and 
extended attributes” on page 669.

Delete Custom View Removes a custom view.

Table 7-58 Sets list page Configuration menu commands

Command Description
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The global settings page also has the Configuration menu which is located in the 
right pane below the breadcrumb bar. The Configuration menu contains the 
commands which you can use to modify the precedence order and refresh the 
catalog files.

See “Global settings configuration menu commands” on page 200. 

The automation settings include the SMTP settings, SNMP settings, syslog 
notifications, and the script settings. The automation settings page also has the 
Operations and Configuration menus which are located in the right pane below 
the breadcrumb bar. The Operations menu contains commands which you can 
use to enable or disable notifications. The Configuration menu contains 
commands which you can use to edit and test the settings.

See “Automation settings operations menu commands” on page 200.

Summary information on the Global Settings default view
The Global Settings default view depends on the privileges of the logged-in user. 
For users having privileges at the VCS One cluster level the default view displays 
a tabular list of all the attributes of the VCS One cluster. 

For global settings, the table contains the following information:

■ The name of the attribute.

■ The value of the attribute.

■ The indication about whether the attribute must be configured or not.

Values of attributes which are editable can be changed by clicking the icon in the 
Edit column.
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Global settings configuration menu commands
In the right pane of the Global Settings view, the Configuration menu has 
commands for configuring the global settings.

Automation settings operations menu commands
In the Automation Settings view, the Operations menu has commands for 
enabling notifications and script execution.

Table 7-60 Global settings Configuration menu commands

Command Description

Modify Precedence 
Order

Changes the precedence order of the existing load dimensions that 
are defined in the VCS One cluster. You can also add or delete new 
load dimensions, if required. 

See “Defining the VCS One cluster’s load and capacity keys” on 
page 450.

Refresh Catalog 
Files

Reloads the catalog files. The catalog files have the .bmc and 
.bmcmap extensions and contain the attribute definitions. Use 
this command whenever the catalog files are updated or added; for 
example, after you install a new agent.

Back up Database Backs up the VCS One database.

Table 7-61 Automation settings Operations menu commands

Command Description

Enable SMTP 
Notifications

Enables the SMTP notifications.

See “Enabling notification settings” on page 641.

Enable SNMP 
Notifications

Enables the SNMP notifications.

See “Enabling notification settings” on page 641.

Enable Syslog 
Notifications

Enables the syslog notifications.

See “Enabling syslog notifications” on page 642.

Enable Script 
Execution

Enables the script execution.

See “Enabling script execution” on page 642.
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Automation settings configuration menu commands
In the Automation Settings view, the Configuration menu has commands for 
editing and testing the settings.

Summary information on the Search menu
The Search menu enables you to search for any object in the VCS One cluster 
such as systems, service groups, composite service groups, and resources. The 
search functionality is useful to locate specific objects in a densely populated 
VCS One cluster.

To search for an object

1 Click the Search menu.

2 In the Search text box, enter the search string. 

3 Click the Show Options link to change search options. You can search for an 
exact match, or search for all or at least one of the words that is specified in 
the search string.

4 Click Search.

The objects that match the search criteria display in the Results table. 

The links that are located below the search options enable you to view the 
search results for specific categories such as cluster, groups, composite service 
groups, virtual objects, and so on. The links also show information about the 
number of hits for that particular object type. For example, to view the search 
results for all service groups, click the Groups link.

The search operation scans both attributes and their values. For example, if you 
specify "State = online" as the search criteria, a search is performed on the State 
attribute as well as its value ("online").

For composite service groups, in addition to the list of matching composite 
service groups for the given string, the service groups contained inside the 
composite service groups also display.

Table 7-62 Automation settings Configuration menu commands

Command Description

Edit Settings Changes SMTP and SNMP settings.

See “Modifying notification settings” on page 639.

Test Settings Tests the SMTP notification settings.

See “Testing notification settings” on page 643.
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Note: If the Search menu is not visible in the console, it is possible that the 
search functionality has been made unavailable by the VCS One administrator.
See “WebserverSubsystems” on page 830.
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Using the Simulator

This chapter includes the following topics:

■ About the Simulator

■ Installing the Simulator

■ Accessing the Simulator

■ About the Simulator’s start-up modes

■ About multiple Simulator instances

■ Using the Simulator Launch Pad

■ Accessing the Simulator through the Windows CLI

■ Setting up a disaster recovery configuration in the Simulator

■ Simulating disaster recovery operations using the Simulator

■ Uninstalling the VCS One Simulator



204 Using the Simulator
About the Simulator
About the Simulator
The VCS One Simulator is available for Windows. You can install the VCS One 
Simulator on one or more Windows systems.

The Simulator lets you simulate a VCS One cluster. It lets you view, modify, and 
test the VCS One cluster configuration and behavior. 

The Simulator includes the following features:

■ Runs a simulated version of the same Policy Master that is used in a real 
VCS One cluster. The simulated Policy Master behaves the same as the one 
in an real VCS One cluster.

■ Lets you import the configuration from a real VCS One cluster into the 
Simulator to troubleshoot configuration issues and perform root cause 
analysis without impacting the production environment.

■ Lets you induce faults and view the resulting behavior to create and fine-
tune the VCS One cluster configuration, including the failover policy, 
without using a production environment. Then, you can import the 
simulated configuration into your production environment.

■ Lets you test configurations from different operating systems. For example, 
you can run the VCS One Simulator on a Windows system and test 
configurations for Linux, Solaris, and Windows VCS One clusters. 

■ Lets you train and educate VCS One users in a protected environment. The 
Simulator has the same look and feel as the actual VCS One software. You 
can reproduce your own environment for realistic lab scenarios. 

■ Supports multiple Simulator instances. 

■ Lets you simulate disaster recovery operations within and across sites. 

■ Runs on a stand-alone system.

The Simulator does not require any additional storage or networking 
hardware. 

■ Runs in non-secure mode only.

■ Lets you perform operations from either the GUI or the command line.
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The difference between a real and a simulated VCS One cluster
A real VCS One cluster is based on a client-server model. The Policy Master is 
the server-side center of logic that is hosted on independent hardware. Systems 
in a VCS One cluster connect to the Policy Master through a client-side process. 
This process is named vcsoneclientd and it runs locally on each system in a VCS 
One cluster. 

In a simulated VCS One cluster, the client-side connections with the Policy 
Master are simulated. For every simulated system in a VCS One cluster, a 
vcsonesim process opens two communication channels: one for communication 
and the other for establishing a heartbeat with other systems. As a result, the 
Simulator can simulate the load of real clients on the Policy Master. 

All code paths and logic decisions in the Simulator are the same as those in an 
actual VCS One cluster installation.

Choosing a configuration for the Simulator
To use the VCS One Simulator to simulate a VCS One environment, perform one 
of the following tasks to create the configuration in the Simulator:

■ Create a custom configuration using the Simulator.

■ Import an existing configuration into the Simulator.

When the Simulator starts, select one of the following configurations:

■ The default configuration

If you do not specify a configuration, the Simulator loads the default 
configuration when you start the database. The Simulator starts the 
database, loads the default configuration in the database, and starts the 
Policy Master, the proxy Simulator, and the Web server.

■ A specific configuration

Discards all configuration and state changes from the previous session and 
uses the specified configuration. If you want to save the existing 
configuration, export it before you use this option.

See “Backing up and restoring VCS One data” on page 694.

The specified configuration can be either a sample or a custom 
configuration that you create.

■ Sample configuration

VCS One includes a few sample configurations. These sample 
configurations are in the following directory:

installation_location\VCSOne\Simulator\conf



206 Using the Simulator
About the Simulator
The installation_location is the location where you installed the 
Simulator. If you installed the Simulator in the default location, the 
sample configurations are on your desktop under:

\VCSOne\Simulator\conf

■ Custom configuration that you create

You can create a custom configuration that simulates your VCS One 
cluster configuration.

Use the configuration named “emptyconf” as a starting point for 
creating a custom configuration.

Use the configurations named “emptyDR_Site1” and “emptyDR_Site2” 
as a starting point for creating custom configurations to simulate 
disaster recover operations within and across sites.

See “Loading or changing a configuration in the Simulator” on 
page 221.

Components of the Simulator
Figure 8-1 depicts the Simulator’s components and how they interact.

Figure 8-1 The Simulator’s components
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The Simulator has the following main components:

Installing the Simulator
For instructions about installing the Simulator, see the Veritas Cluster Server 
One Installation Guide.

Accessing the Simulator
You can access the Simulator using any of the following methods:

■ The Launch Pad

The Launch Pad provides a graphical user interface (GUI) which you can use 
to manage Simulator instances. For information about how to use the 
Launch Pad, see “Using the Simulator Launch Pad” on page 209.

■ The Windows Command Line Interface (CLI)

You can also use the Windows CLI as an alternative method to manage 
Simulator instances. For information about how to use the CLI, see 
“Accessing the Simulator through the Windows CLI” on page 215.

About the Simulator’s start-up modes
The Simulator has three start-up modes. In all start-up modes, the Simulator 
reads state information from the specified configuration. The modes differ in 
what happens after the Simulator reads the configuration.

vcsonesim The Simulator process. It simulates real systems 
in a simulated VCS One cluster, and simulates 
system faults.

hasim The command line interface to vcsonesim.

Policy Master The Policy Master runs the same code in a real or 
simulated VCS One cluster. 
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Table 8-1 describes the command options to start the Simulator in each of the 
start-up modes.

To change between these modes, you must stop the Simulator and then restart it 
in the chosen mode.

Table 8-1 Simulator start-up modes

No command option 
(default mode)

Starts the Simulator from the specified configuration. 

The Simulator automatically moves all service groups and 
resources to an OFFLINE state and moves systems to a 
RUNNING state regardless of their stored state. Starts the 
Policy Master in cold start-up mode.

-extended Starts the Simulator from the specified configuration.

The Simulator preserves the systems, resources, and 
groups’ states/istates defined in the configuration. You can 
see the state/istate information for all objects in the 
database.

The Simulator completes commands that involve systems, 
resources, and groups that have an outstanding intended 
online state (such as INTENT_ONLINE or WAITING 
FOR_ONLINE).

-extended 

-no_operation

Using -no_operation with -extended starts the 
Simulator from the specified configuration in read-only 
mode. You cannot perform write operations.

Starting the Simulator in read-only mode is useful for 
debugging.

The Simulator preserves the systems, resources, and 
groups’ states/istates defined in the configuration. You can 
see the state/istate information for all of the objects in the 
database.

The Simulator does not complete commands that involve 
systems, resources, and groups that have outstanding 
intended states.
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About multiple Simulator instances
You can create and run any number of VCS One Simulator instances at the same 
time.

A Simulator instance consists of a set of processes (such as the database, Policy 
Master, ProxySim, and WebServer processes) that are required to simulate VCS 
One.

Multiple Simulator instances let you:

■ Simulate disaster recovery operations within a site.

You can use the Simulator to fault and repair a remote cluster. You can also 
simulate a link fault and clear it.

For more information, see “Managing remote clusters” on page 593.

■ Simulate disaster recovery operations across sites. 

A VCS One global cluster links individual VCS One clusters at separate sites, 
and enables wide-area failover and disaster recovery for applications.

You can create a Simulator instance for each VCS One cluster to simulate a 
global cluster. 

If you create multiple Simulator instances to simulate global clusters, you 
must manually change the ClusterName attribute. By default, the Simulator 
assigns VCSOneFarm as the cluster name.

For more information, see “Setting up VCS One global clusters” on 
page 579.

■ Simulate failover behavior before and after a configuration change.

■ Simulate different Organization Tree setups.

■ Simulate multiple clusters with separate configurations.

Using the Simulator Launch Pad
The Veritas Cluster Server One (VCS One) Simulator Launch Pad enables you to 
manage multiple instances of the VCS One Simulator. The Launch Pad has a 
graphical user interface which you can use to perform tasks such as starting and 
stopping a simulator instance, managing configuration for an instance, 
duplicating a simulator instance, and so on.

The Launch Pad interface consists of two panes—the left pane contains a list of 
configured instances, while the right pane contains the basic commands for 
managing a particular instance. The right pane also has a drop-down menu, 
named Advance, which contains additional commands for managing the 
instance. After installation, the Launch Pad displays the default Simulator 
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instance, which is the only simulator instance shipped with the VCS One 
Simulator. You can add more Simulator instances as required.

Starting the Launch Pad
You can start the Launch Pad using either of the following options:

■ Double-click the VCS One Simulator Launch Pad shortcut located on the 
desktop.

■ Alternatively, you can click the file VCSOneSimLaunchPad.hta located in 
directory installation_location\VCSOne\.

Quitting the Launch Pad

To quit the Launch Pad: 

■ Click Exit.

Note that quitting the Simulator Launch Pad does not stop the Simulator 
instances that are running. The Exit command just quits the Launch Pad.

List of Simulator instances and their states
The left pane of the Launch Pad displays the list of available Simulator instances 
and their states. The current state of an instance is indicated by a colored dot 
next to the instance name.

The states and their colors are as follows:

■ Green: The state is Running. All processes of the Simulator instance are 
running.

■ Red: The state is Not Running. All processes of the Simulator instance are 
not running.

■ Orange: The state is Partial. Some processes of the Simulator instance are 
not running.

Note: When the Simulator starts in the Extended and No Operation mode, the 
proxysim process is not started; hence, the Launch Pad detects the instance as 
being in the Partial state and displays an orange colored dot next to the instance 
name.
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Starting or stopping a Simulator instance
The start and stop operations are complementary to each other.

After the Simulator instance is started, the same button displays as Stop and 
vice versa.

To start or stop a Simulator instance:

1 Click the instance name.

2 Click Start or Stop.

Accessing the GUI for a Simulator instance

To access the graphical user interface (GUI) for a Simulator instance:

1 Click the instance name.

2 Click Launch GUI.

Accessing the CLI for a Simulator instance

To access the Command Line Interface (CLI) for a Simulator instance:

1 Click the instance name.

2 Click Launch CLI.

A command prompt displays for the selected instance. After the command 
prompt opens, you will be able to execute all the haXXX commands for that 
Simulator instance.

Saving the configuration for a Simulator instance
To save the configuration, the Simulator instance should be in running state.

To save the configuration for a Simulator instance:

1 Click the instance name.

2 Click Advanced, and then select Save Configuration As. 

3 Enter or select the directory name where the configuration file will be 
stored.

The Simulator saves the configuration file in the selected directory. 
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Changing the configuration of a Simulator instance

To change the configuration for a Simulator instance:

1 Click the instance name.

2 Click Advanced, and then select Simulator Config Setting.

3 Select the configuration that you want to load. The Simulator contains a 
number of sample configurations.

If you want to select your own configuration, use the Browse button.

To verify the validity of a configuration, use the Verify button.

To change the mode for a simulator instance:

1 Click the instance name.

2 Click Advanced, and then select Simulator Config Setting.

3 To start the Policy Master in the extended mode, check the Extended check 
box.

4 To start the Policy Master in the extended and no_operation mode, check the 
No Operation check box as well. 

Note: For information about the modes, see “Simulator start-up modes” on 
page 208.

Duplicating a Simulator instance

To duplicate an existing Simulator instance:

1 Click the instance name.

2 Click Advanced, and then select Duplicate Simulator.

3 In the New Simulator Name box, enter a name for the new instance.

4 Click Ok.

A duplicate instance having the same configuration is created.

Viewing the log files for a Simulator instance

To view the log files for a Simulator instance:

1 Click the instance name.

2 Click Advanced, and then select View Log.
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A Windows Explorer window opens which contains the log files for the selected 
instance. The log files are useful for debugging issues with the Simulator.

About the ports used by a Simulator instance
A Simulator instance uses certain ports by default. When you start a new 
Simulator instance the ports are set up automatically. If a Simulator instance is 
already using the default port and you start up another Simulator instance, the 
new instance starts on the next available port. 

Because the ports are set up automatically, there is typically no reason for you to 
specify the Simulator ports. Symantec recommends setting the ports 
automatically. If, however, you have another application that is already using 
one of the ports required by a Simulator instance, you can manually specify 
alternative ports for the instance before you start it. Make sure that the ports a 
Simulator instance uses are not being used by any other process.

If you set non-default ports when you start a Simulator instance and if that port 
is not available, then the Simulator instance starts on the next available port.

Changing the ports used by a Simulator instance

To change the ports used by a Simulator instance:

1 Click the instance name.

2 Click Advanced, and then select Simulator Config Setting.

3 Click on Port Configuration.

4 Change the following ports to an unique value. The Simulator uses these 
ports to start the corresponding process for that instance.

[dbport]

Starts the database on the specified port. If you do not specify a port, 
the database starts on port 14157 by default. If this port is not 
available, it starts on the next available port.

[pmport]

Starts the Policy Master on the specified port. If you do not specify a 
port, the Policy Master starts on port 14151 by default. If this port is 
not available, it starts on the next available port.

[proxysimport]

Starts the proxysimport on the specified port. If you do not specify a 
port, the proxysimport starts on port 14156 by default. If this port is 
not available, it starts on the next available port.
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[sslport]

Used for secure and encrypted https communication between the Web 
server and the browser. If you do not specify an SSL port, the Web 
server starts on port 14171 by default. If this port is not available, it 
starts on the next available port. 

[adminport]

Starts the Web server on the specified admin port. If you do not specify 
a port, the Web server starts on port 14172 by default. If this port is not 
available, it starts on the next available port.

[wssslport]

Used by the Web server for secure and encrypted communication for 
Web services. If you do not specify a wssslport port, the Web server 
starts on port 14173 by default. If this port is not available, it starts on 
the next available port.

Adding a Simulator instance

To add a Simulator instance:

1 Click Add (located on the top of the left pane).

2 In the Simulator Instance box, enter the new instance name.

3 To specify a default configuration for the instance, check the Configuration 
check box. 

The Launch Pad ships with a few sample configurations that you can select. 
If you want to load your own configuration, click Browse, and then select 
the configuration file from your computer. To verify if the selected 
configuration is okay, click Verify.

4 To use the extended mode, check the Extended check box.

5 To use the no operation mode, check the No Operation check box.

6 To specify the default ports for the instance, click Port Configuration, and 
then enter the port values.

7 Click Ok.

The Simulator instance is created and is displayed in the left pane.

Removing a Simulator instance
You can remove a simulator instance which is not in running state.

To Remove a Simulator instance:

1 Click on the Simulator instance that you want to remove.
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2 Click on the Remove button. 

The Simulator instance is removed.

Accessing the Simulator through the Windows CLI
Apart from using the Simulator Launch Pad, you can also use the Windows CLI 
to manage the Simulator instances. This section describes how to use the 
Simulator scripts and commands for performing Simulator operations such as 
starting and stopping a Simulator instance.

About Simulator scripts and commands
The hasim command performs operations on a Simulator instance from the 
Windows command line for that instance. The hasim command is in the 
installation_location\VCSOne\Simulator\bin\ directory.

You can find the batch file scripts in the VCS One directory where the Simulator 
is installed. The batch file scripts are as follows:

Viewing Simulator command usage
Use the following procedure to view the command usage for hamultisim.

To view the command usage for hamultisim

1 Open the Windows command prompt by selecting Start > Run.

2 In the field, enter cmd and click OK.

3 Change directories to the following location:

cd installation_location\VCSOne

where installation_location is the directory where you installed the 
Simulator. 

4 Enter the following command:

hamultisim -help

startsim.bat Starts the default Simulator instance.

stopsim.bat Stops the default Simulator instance.

cli_prompt.bat Opens a command prompt for the default Simulator instance.

hamultisim.bat Adds, removes, starts, and stops Simulator instances. Opens the 
GUI or Windows command line for a specific Simulator instance. 
Use this command to control multiple Simulator instances.
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To view the command usage for hasim

1 Open the Windows command prompt by selecting Start > Run.

2 In the field, enter cmd and click OK.

3 Change directories to the following location:

cd installation_location\VCSOne

where installation_location is the directory where you installed the 
Simulator.

4 At the Windows command prompt, run the following command to list 
Simulator instances:
hamultisim -list

5 At the Windows command prompt, run the following command to open the 
command line for the specifies Simulator instance:
hamultisim -cliprompt instance_name

where instance_name is the name of the Simulator instance.

6 At the new Windows command prompt, enter the following command:

hasim -help

Starting the default Simulator instance
Starting a Simulator instance consists of starting the configuration database, 
loading the configuration, and starting the Web server (GUI) and Policy Master.

You can only start and stop the Simulator from the system on which it is 
installed. You can connect to the Simulator from a remote system. If you 
connect remotely, some options may not be available to you.

VCS One includes one default Simulator instance. The name of the default 
Simulator instance is default.

You can start the Simulator by running a script or entering a command.

To start the default Simulator instance by running a script

◆ Double click on the following batch file script to start the default Simulator 
instance:

installation_location\VCSOne\startsim.bat

where installation_location is the directory where you installed the 
Simulator. 

The script asks you if you want to use the default configuration. If you do 
not want to use the default configuration, the script asks you to enter the 
directory for the XML configuration files you want to use.

The Simulator launches in your Web browser.
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To start the default Simulator instance using a command

◆ At the Windows command prompt, enter the following command: 

installation_location\VCSOne\hamultisim -startsim default \
[-d xml_dir]

If you want to load a configuration other than the default configuration, use 
-d xml_dir to specify the configuration you want to load. xml_dir is the 
directory that contains the XML configuration files. 

The Simulator includes different sample configurations. They are in the 
following directory:

installation_location\VCSOne\Simulator\conf

The Simulator launches in your Web browser.

Adding a Simulator instance
Before you can start a Simulator instance, you must add it. 

To add a new Simulator instance

◆ At the Windows command prompt, enter the following command:

installation_location\VCSOne\hamultisim -addsim instance_name

where installation_location is the directory where you installed the 
Simulator and instance_name is the name of the Simulator instance. 

After you add and start a Simulator instance, you can access the GUI using 
the following URL:

https://127.0.0.1:ssl_port/instance_name

Starting a Simulator instance
Before you can start a new Simulator instance, you must add it. If you have not 
already added the Simulator instance that you want to start, add it. 

See “Adding a Simulator instance” on page 217.

Starting a Simulator instance
Use the following procedure to start a Simulator instance.

To start a Simulator instance

◆ At the Windows command prompt, enter the following command: 

installation_location\VCSOne\hamultisim -startsim \
instance_name [-d xml_dir]
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where installation_location is the directory where you installed the 
Simulator, instance_name is the name of the Simulator instance, and 
xml_dir is the configuration directory that you want to load in the 
Simulator. If you do not provide a configuration directory, the Simulator 
starts with the default configuration or the previously loaded configuration.

Starting a Simulator instance with the same state 
information that is in the database
Use the following procedure to start a Simulator instance with the same state 
information that is in the database.

To start a Simulator instance with the same state information that is in the 
database

◆ At the Windows command prompt, enter the following command: 

installation_location\VCSOne\hamultisim -startsim \
instance_name -extended

where installation_location is the directory where you installed the 
Simulator and instance_name is the name of the Simulator instance.

When you start the Simulator with the -extended option, the Simulator 
preserves the systems, resources, and groups’ states/istates defined in the 
configuration. You can see the state/istate information for all objects in the 
database. The Simulator completes commands that involve systems, 
resources, and groups that have an outstanding intended online state (such 
as INTENT ONLINE or WAITING FOR ONLINE).

Starting a Simulator instance in read-only mode
Read-only mode is useful for debugging.

To start a Simulator instance in read-only mode

◆ At the Windows command prompt, enter the following command: 

installation_location\VCSOne\hamultisim -startsim \
instance_name -extended -no_operation

where installation_location is the directory where you installed the 
Simulator and instance_name is the name of the Simulator instance.

When you start the Simulator with both the -extended and the
-no_operation options, the Simulator starts in read-only mode. You 
cannot perform write operations.

The Simulator preserves the systems, resources, and groups’ states/istates 
defined in the configuration. You can see the state/istate information for all 
objects in the database.
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The Simulator does not complete commands that involve systems, 
resources, and groups that have outstanding intended states.

Starting a Simulator instance with non-default ports
A Simulator instance uses certain ports by default. When you start a new 
Simulator instance, the ports are set up automatically. If a Simulator instance is 
already using the default port and you start up another Simulator instance, it 
starts on the next available port. 

After you start two Simulator instances, the ports look similar to the following 
example. 
installation_location\VCSOne\hamultisim -list -ports
Instances: dbport pmport proxysimport sslport adminportwssslport
sim1 14157 14151 14156 14171 14172 14173
sim2 14158 14152 14159 14174 14175 14176

Because the ports are set up automatically, there is typically no reason for you to 
specify the Simulator ports. Setting the ports automatically is recommended. If, 
however, you have another application that is already using one of the ports 
required by a Simulator instance, you can manually specify alternate ports for 
the instance when you start it. The ports a Simulator instance uses should not be 
used by any other process.

If you set non-default ports when you start a Simulator instance and a port is 
not available, the Simulator instance starts on the next available port.

Caution: If you set non-default ports for a Simulator instance, it is not possible 
to reset the ports to default values. In addition, disaster recovery configurations 
will not work if you start Simulator instances in a different order than that 
indicated by their port number assignments.

To start a Simulator instance with non-default ports

1 At the command prompt, enter the following command to display the port 
information for each process:

installation_location\VCSOne\hamultisim -list -ports

where installation_location is the directory where you installed the 
Simulator. 

2 Enter the following command to start a Simulator instance with non-default 
ports:



220 Using the Simulator
Accessing the Simulator through the Windows CLI
installation_location\VCSOne\hamultisim -startsim \
-instance_name [-d xml_dir] [-dbport port] [-pmport port] \
[-proxysimport port] [-sslport port] [-adminport port] \
[-wssslport wsssl_port]

where installation_location is the directory where you installed the 
Simulator. Use the -d xml_dir option to load a specific XML configuration 
into the database and start it.

Table 8-2 shows the port-related options for hamultisim -startsim.

Table 8-2 hamultisim port options

Option Default 
port

Description

-dbport port 14157 Starts the database on the port provided. If you 
do not specify a port, the database starts on port 
14157 by default. If this port is not available, it 
starts on the next available port.

-pmport port 14151 Starts the Policy Master on the port provided. If 
you do not specify a port, the Policy Master starts 
on port 14151 by default. If this port is not 
available, it starts on the next available port.

-proxysimport port 14156 Starts the proxysimport on the port provided. If 
you do not specify a port, The proxsimport starts 
on port 14156 by default. If this port is not 
available, it starts on the next available port.

-sslport port 14171 Used for secure and encrypted https 
communication between the Web server and the 
browser. If you do not specify an SSL port, the 
Web server starts on port 14171 by default. If this 
port is not available, it starts on the next 
available port.

-admin port 14172 Starts the Web server on the admin port 
provided. If you do not specify a port, the Web 
server starts on port 14172 by default. If this port 
is not available, it starts on the next available 
port.

-wssslport port 14173 Used by the Web server for secure and encrypted 
communication for Web services. If you do not 
specify an wssslport port, the Web server starts 
on port 14173 by default. If this port is not 
available, it starts on the next available port.
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Loading or changing a configuration in the Simulator
You can load a sample or custom configuration into a Simulator instance or 
change the configuration.

Loading a sample configuration and starting a Simulator 
instance
The Simulator includes sample configurations. They are in the following 
directory:

installation_location\VCSOne\Simulator\conf

To load a sample configuration and start a Simulator instance

◆ At the Windows command prompt, enter the following command: 

installation_location\VCSOne\hamultisim -startsim \
instance_name -d xml_dir

where installation_location is the directory where you installed the 
Simulator, instance_name is the name of the Simulator instance, and 
xml_dir is the directory that contains the XML configuration files.

Loading a custom configuration and starting a Simulator 
instance
Use the following procedure to load a custom configuration into a Simulator 
instance.

To load a custom configuration and start a Simulator instance

◆ At the Windows command prompt, enter the following command: 

installation_location\VCSOne\hamultisim -startsim \
instance_name -d xml_dir

where installation_location is the directory where you installed the 
Simulator, instance_name is the name of the Simulator instance, and 
xml_dir is the directory that contains the XML configuration files.

Loading the real Policy Master configuration into a 
Simulator instance
Use the following procedure to load the real Policy Master configuration into a 
Simulator instance.

To load a the real Policy Master configuration into a Simulator instance

1 At the Windows command prompt, enter the following command: 



222 Using the Simulator
Accessing the Simulator through the Windows CLI
installation_location\VCSOne\hamultisim -startsim \
instance_name -d xml_dir

where installation_location is the directory where you installed the 
Simulator, instance_name is the name of the Simulator instance, and 
xml_dir is the directory that contains the real Policy Master configuration 
files.

2 Open a Windows command prompt for the specified instance using the 
following command:
installation_location\VCSOne\hamultisim -cliprompt \
instance_name

3 Because the real Policy Master configuration does not contain the user 
simuser, manually add simuser. Run the following command at the 
command prompt that you opened in the previous step.

hauser -add simuser@domain

4 Add the ServerFarmAdministrator and ServerFarmObjectAdministrator 
roles for simuser:

hauser -addrole simuser@domain ServerFarmAdministrator
hauser -addrole simuser@domain ServerFarmObjectAdministrator

You may now log on to the Simulator as simuser.

Changing the configuration that is loaded in a Simulator 
instance
To change the configuration that is loaded in a Simulator instance, you must 
stop the Simulator instance and restart it, specifying the configuration to load.

To change the configuration that is loaded in a Simulator instance

1 Check if the Simulator instance is running by entering the following 
command:

installation_location\VCSOne\hamultisim -status

where installation_location is the directory where you installed the 
Simulator. 

2 If the Simulator instance is running, stop it by using one of the following 
methods:

■ Double click on the following batch file script to stop the default 
Simulator instance:

installation_location\VCSOne\stopsim.bat

This script is in the directory where you installed the Simulator.
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■ At the Windows command prompt, enter the following command to 
stop a Simulator instance other than the default instance:

installation_location\VCSOne\hamultisim -stopsim \
instance_name

where instance_name is the name of the Simulator instance. Use 
default as the instance name to specify the default instance.

3 Restart the Simulator instance by using one of the following methods:

■ Double click on the following batch file script to start the default 
Simulator instance:

installation_location\VCSOne\startsim.bat

This script is in the directory where you installed the Simulator.

When you are prompted, enter the name of the configuration you want 
to load. 

■ At the Windows command prompt, enter the following command:

installation_location\VCSOne\hamultisim -startsim \
instance_name -d xml_dir

where instance_name is the name of the Simulator instance and 
xml_dir is the directory of the XML configuration files. Use default 
as the instance name to specify the default instance.

The Simulator includes different sample configurations. They are in the 
following directory:

installation_location\VCSOne\Simulator\conf\confxml

The Simulator launches in your Web browser.

About logging on to the Simulator
When the Simulator launches in your Web browser in non-secure mode, it 
prompts you to enter the following information:

User Name The word simuser is entered by default. You may user 
simuser or enter an alternate valid VCS One user name.

To use the Simulator fully, assign other users 
ServerFarmAdministrator and 
ServerFarmObjectAdministrator privileges.

The user simuser is part of the predefined Simulator 
configurations and has ServerFarmAdministrator and 
ServerFarmObjectAdministrator privileges.
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Accessing the GUI for a Simulator instance
Use the following procedures to access the GUI for the default Simulator or to 
access the GUI for a specific Simulator instance.

Accessing the GUI for the default Simulator
Use the following procedure to access the GUI for the default Simulator.

To access the GUI for the default Simulator

◆ Do one of the following:

■ Start the default Simulator by running the startsim script. The GUI 
automatically opens in the Web browser.

■ Access the GUI for the default Simulator by going to the following URL:

https://127.0.0.1:14171

To access the GUI if the default Simulator uses a port other than the default 
port (14171)

1 At the Windows command prompt, get the SSL port (sslport) for the default 
Simulator instance:

installation_location\VCSOne\hamultisim -list -ports

where installation_location is the directory where you installed the 
Simulator. 

2 Go to the following URL:

https://127.0.0.1:sslport

where sslport is the SSL port you obtained in step 1.

Accessing the GUI for a Simulator instance
Use the following procedure to access the GUI for a Simulator instance.

To access the GUI for a Simulator instance

1 Display the SSL port (sslport) of the Simulator instance you want to access:

installation_location\VCSOne\hamultisim -list -ports

Password You do not need to enter a password to log on to the 
Simulator.

Domain The word domain is entered by default. You may use 
domain or enter an alternate valid domain name.
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where installation_location is the directory where you installed the 
Simulator. 

2 After you get the SSL port, access the GUI using the following URL:

https://127.0.0.1:ssl_port/instance_name

Accessing the command line for a Simulator instance
Use the following procedures to access the command line for the default 
Simulator or a specific Simulator instance.

Accessing the command line for the default Simulator 
instance
Use the following procedure to access the command line for the default 
Simulator.

To access the command line for the default Simulator

◆ Do one of the following:

■ Double click on the following batch file script to start the default 
Simulator instance:

installation_location\VCSOne\cli_prompt.bat

where installation_location is the directory where you installed 
the Simulator. 

■ At the Windows command prompt, enter the following command:

installation_location\VCSOne\hamultisim -cliprompt default

where installation_location is the directory where you installed 
the Simulator. 

The VCS One “ha” commands that you run from this command line 
apply to the default Simulator instance. After you access the command 
line for the default Simulator instance, you may use the hasim 
command to perform operations on that Simulator instance. To see all 
hasim operations, use hasim -help.

Accessing the command line for a Simulator instance
Use the following procedure to access the command line for a specific Simulator 
instance.
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To access the command line for a Simulator instance

◆ At the command prompt, enter the following command:

installation_location\VCSOne\hamultisim -cliprompt \
instance_name

where installation_location is the directory where you installed the 
Simulator and instance_name is the name of the Simulator instance.

The VCS One “ha” commands that you run from this command line apply to 
the specified Simulator instance. After you have accessed the command line 
for this Simulator instance, you may use the hasim command to perform 
operations on that Simulator instance. To see all hasim operations, use 
hasim -help.

Creating and saving a custom configuration in the Simulator
Configuration files that you load into the Simulator must be in XML. 

To create a custom configuration

1 Start with a sample configuration that is included with the Simulator. 

The sample configurations are in the following directory: 

installation_location\VCSOne\Simulator\conf

2 Use the Simulator to modify the configuration.

To save the custom configuration

◆ Save the new configuration with a new name. To save the configuration, you 
must export the information in the VCS One cluster’s configuration 
database before you stop the Simulator. After you have opened a command 
prompt for a Simulator instance, enter the following command:

installation_location\VCSOne\Simulator\bin\haconf -dbtoxml \
xml_dir

where installation_location is the directory where you installed the 
Simulator and xml_dir is the directory that contains the XML 
configuration files.

See “Backing up and restoring VCS One data” on page 694.

Displaying the status of a Simulator instance
You can use hamultisim -status to display the status of the specified 
Simulator instance. If you do not specify an instance name, the status is 
displayed for all Simulator instances. You can also use the command to display 
the status of all the processes of individual Simulator instances. 
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A Simulator instance has one of the following states:

The hamultisim -status -processes command displays the status of each 
process for the specified instance. If no instance is specified, the -processes 
option displays the status of all the processes for all instances.

The process status of a Simulator instance can be one of the following states:

To display the status of a Simulator instance

◆ At the command prompt, enter the following command:

installation_location\VCSOne\hamultisim -status [-processes] \
instance_name

where installation_location is the directory where you installed the 
Simulator. 

Use -processes to display the status of all processes for a specific 
Simulator instance.

To display the status of all Simulator instances

◆ At the command prompt, enter the following command:

installation_location\VCSOne\hamultisim -status [-processes]

where installation_location is the directory where you installed the 
Simulator. 

Use -processes to display the status of the processes for all instances.

Listing Simulator instances

To list Simulator instances

◆ At the command prompt, enter the following command:

RUNNING All the processes for the specified instance are up and the instance is 
running.

NOT RUNNING All the processes for the specified instance are down and the instance is 
not running.

PARTIAL Some of the processes for the specified instance are up and the instance 
is in a PARTIAL state.

UP The process is running.

DOWN The process is not running.
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installation_location\VCSOne\hamultisim -list

where installation_location is the directory where you installed the 
Simulator. 

Listing port information for a Simulator instance
Use the following procedure to list port information for a Simulator instance.

To list port information for a Simulator instance

◆ At the command prompt, enter the following command:

installation_location\VCSOne\hamultisim -list -ports

where installation_location is the directory where you installed the 
Simulator. 

This command lists the port information for each process. The -ports 
option lists the instances, processes, and ports on which the process is 
configured.

Stopping a Simulator instance
Use the following procedures to stop the default Simulator or a specific 
Simulator instance.

Stopping the default Simulator instance
Use the following procedure to stop the default Simulator.

To stop the default Simulator instance

◆ Do one of the following:

■ Double click on the following batch file script to stop the default 
Simulator instance:

installation_location\VCSOne\stopsim.bat

where installation_location is the directory where you installed 
the Simulator. 

■ At the Windows command prompt, enter the following command:

installation_location\VCSOne\hamultisim -stopsim default

Stopping a Simulator instance
Use the following procedure to stop a specific Simulator instance.
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To stop a Simulator instance

◆ At the command prompt, enter the following command:

installation_location\VCSOne\hamultisim -stopsim instance_name

where installation_location is the directory where you installed the 
Simulator and instance_name is the name of the Simulator instance. 

This command stops all the processes for the Simulator instance.

Removing a Simulator instance
Use the following procedure to remove a Simulator instance.

To remove a specific Simulator instance 

◆ At the command prompt, enter the following command:

installation_location\VCSOne\hamultisim -removesim \
instance_name

where installation_location is the directory where you installed the 
Simulator and instance_name is the name of the Simulator instance. This 
command removes the Simulator instance.

For instructions on how to uninstall the Simulator, see the Veritas Cluster Server 
One Installation Guide.

Setting up a disaster recovery configuration in the 
Simulator

To simulate a disaster recovery operations using the VCS One Simulator, you 
must first set up a disaster recovery configuration. In a disaster recovery 
configuration, two simultaneous instances of the Simulator are running on the 
same system.

The steps for setting up a disaster recover configuration in the Simulator are the 
same as the steps for setting up a real disaster recovery configuration, except 
that you need to use 127.0.0.1 as the IP address and you do not need to set up 
trust between the two Simulator instances.

In this procedure, seattle is the name of the primary VCS One cluster and tucson 
is the name of the secondary VCS One cluster.

To set up a disaster recovery configuration in the Simulator

1 If you have a single configuration that you want to use, make two copies of 
the configuration files in two separate directories.
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2 Open the first main.xml file and edit it as follows:

a Find the following line: 
<cluster name="name1">

b Note the cluster name.

c Change all occurrences of this cluster name to another name. This VCS 
One cluster is the primary one. In this procedure, seattle is used as the 
name of the primary VCS One cluster.
<cluster name="seattle">

3 Open the second main.xml file and edit it as follows:

a Find the following line: 
<cluster name="clus2">

b Note the cluster name.

c Change all occurrences of this cluster name to another name. This VCS 
One cluster is the secondary one. In this procedure, tucson is used as 
the name of the secondary VCS One cluster.
<cluster name="tucson">

4 Add two Simulator instances:
installation_location\VCSOne\hamultisim -addsim seattle
installation_location\VCSOne\hamultisim -addsim tucson

The Simulator instance’s name do not need to match the cluster names, but 
it is helpful if they do.

5 List the ports for the Simulator instances:
installation_location\VCSOne\hamultisim -list -ports

The output looks similar to the following:
Instances: dbport pmport proxysimportsslportadminport wssslport

default 14157 14151 14156 14171 14172 14173

seattle 14157 14151 14156 14171 14172 14173

tucson 14157 14151 14156 14171 14172 14173

The ports for the two instances are the same before you start the Simulator 
instances.

6 Start the first Simulator instance:
installation_location\VCSOne\hamultisim -startsim seattle -d \
xml_dir

7 Start the second Simulator instance:
installation_location\VCSOne\hamultisim -startsim tucson -d \
xml_dir
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8 List the ports for the Simulator instances to see that the ports for the second 
Simulator instance have been changed from the original default values:
installation_location\VCSOne\hamultisim -list -ports

The output looks similar to the following:
Instances: dbport pmport proxysimportsslportadminport wssslport

default 14157 14151 14156 14171 14172 14173

seattle 14157 14151 14156 14171 14172 14173

tucson 14158 14152 14159 14174 14175 14176

9 Open command prompts for both Simulator instances:
installation_location\VCSOne\hamultisim -cliprompt seattle
installation_location\VCSOne\hamultisim -cliprompt tucson

10 View the cluster name on the first Simulator instance:
installation_location\VCSOne\haclus -list

11 View the cluster name on the second Simulator instance:
installation_location\VCSOne\haclus -list

12 Add the second cluster to the first Simulator instance:
installation_location\VCSOne\haclus -add tucson
installation_location\VCSOne\haclus -list

The output looks similar to the following:
seattle*
tucson

The asterisk denotes the local cluster.

13 Add the first cluster to the second Simulator instance:
installation_location\VCSOne\haclus -add seattle
installation_location\VCSOne\haclus -list

The output looks similar to the following:
seattle
tucson*

The asterisk denotes the local cluster.

14 Display the second cluster on the first Simulator instance:
installation_location\VCSOne\haclus -display tucson

The output looks similar to the following:
#Attribute               Value
ClusterName              tucson
ClusterState             INIT
ConnectionRole           Acceptor
ConnectionTimeout        5
ConsolidatedLinkStatus
DRPort                   14151
EnableConnections        0
LinkStatus
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MaxHeartbeatInterval     5
MissedHeartbeatThreshold 5
NetworkConnections
RClusterUUID
ReconnectInterval        5
RunningDRVersion         0
SourceFile               main.xml
TransitionTimeout        300

15 Display the first cluster on the second Simulator instance:
installation_location\VCSOne\haclus -display seattle

The output looks similar to the following:
#Attribute               Value
ClusterName              seattle
ClusterState             INIT
ConnectionRole           Initiator
ConsolidatedLinkStatus
EnableConnections        0
LinkStatus
MaxHeartbeatInterval     5
MissedHeartbeatThreshold 5
RClusterUUID
RunningDRVersion         0
SourceFile               main.xml
TransitionTimeout        300

The Initiator and Acceptor are determined by the alphabetical order of the 
two cluster names. The first cluster name becomes the Initiator.

16 For the cluster that initiates the connection request (seattle), perform the 
following steps:

a Type the following command:
installation_location\VCSOne\haclus -modify \
NetworkConnections 127.0.0.1 -clus tucson

b Type the following command:
installation_location\VCSOne\haclus -modify \
DRPort 14152 -clus tucson

The DRPort is the Policy Master port (pmport) number for the remote 
(tucson) Simulator instance. The pmport number is displayed in the 
output for hamultisim -list -ports.

c Type the following command:
installation_location\VCSOne\haclus -modify \
EnableConnections 1 -clus tucson

17 For the cluster that accepts the connection (tucson), type the following 
command:
installation_location\VCSOne\haclus -modify \
EnableConnections 1 -clus seattle
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18 Display cluster information for the first cluster:
installation_location\VCSOne\haclus -display seattle

The output looks similar to the following:
#Attribute               Value
ClusterName              rc1
ClusterState             RUNNING
ConnectionRole           Initiator
ConsolidatedLinkStatus   LINK_UP
EnableConnections        1
LinkStatus               127.0.0.1 UP
MaxHeartbeatInterval     5
MissedHeartbeatThreshold 5
RClusterUUID             8b18e8c4-1dd2-11b2-8f0b-aaf14f23bc3d
RunningDRVersion         1.0
SourceFile               main.xml
TransitionTimeout        300

19 On the first Simulator instance, display cluster information for the second 
cluster:
installation_location\VCSOne\haclus -display tucson

The output looks similar to the following:
#Attribute               Value
ClusterName              rc2
ClusterState             RUNNING
ConnectionRole           Acceptor
ConnectionTimeout        5
ConsolidatedLinkStatus   LINK_UP
DRPort                   14152
EnableConnections        1
LinkStatus               127.0.0.1 UP
MaxHeartbeatInterval     5
MissedHeartbeatThreshold 5
NetworkConnections       127.0.0.1
RClusterUUID             8b18e8c4-1dd2-11b2-8f0b-aaf14f23bc3d
ReconnectInterval        5
RunningDRVersion         1.0
SourceFile               main.xml
TransitionTimeout        300

The link is now up and running. If you have loaded the same configuration 
into both Simulator instances, you can set up global composite service 
groups (CSGs), bring service groups online, and switch them from one 
cluster to the other with the Simulator.

In a real disaster recovery configuration, the clusters would have different 
storage locations and definitions for running the applications on the 
disaster recovery site.

20 Save the configuration to the same or a new location to preserve the disaster 
recovery configuration settings so that you can reload the databases in the 
future.
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Perform the following steps for the first Simulator instance:

a Change directories to the location where the configuration is located.

b Save the configuration by running the following command:
haconf -dbtoxml .

Perform the following steps for the second Simulator instance:

a Change directories to the location where the configuration is located.

b Save the configuration by running the following command:
haconf -dbtoxml .

See the following chapters for information about configuring clusters for 
disaster recovery and setting up global CSGs:

■ “Setting up VCS One global clusters” on page 579

■ “Managing global composite service groups” on page 613.

Simulating disaster recovery operations using the 
Simulator

See the following sections for information about simulating disaster recovery 
operations:

■ “Faulting a remote cluster using the Simulator” on page 610

■ “Clearing a simulated cluster fault using the Simulator” on page 610 

■ “Simulating a link fault” on page 611

■ “Clearing a simulated link fault” on page 612

Uninstalling the VCS One Simulator
For instructions about installing the Simulator, see the Veritas Cluster Server 
One Installation Guide.
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This section includes the following chapters:

■ “Design overview” on page 237

■ “Designing roles and privileges for users” on page 249.

■ “Designing actions taken after a fault” on page 259.

■ “Designing attribute values using variables” on page 267.

■ “Designing service groups” on page 277

■ “Designing application and virtual machine placement policy” on page 311.
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Design overview

This chapter includes the following topics:

■ Introduction

■ Planning

■ Preparing

■ Implementing

■ Configuring and verifying
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Introduction
The purpose of the implementation checklist is to make sure the administrator 
considers all aspects of the VCS One implementation, and no steps are 
inadvertently missed. The checklist does not attempt to explain all the steps, but 
instead offers references of where to go for more information.

Note: These instructions assume the tasks are performed by an administrator 
with full permissions to all aspects of the VCS One cluster and applications.

Before designing and implementing your VCS One installation, be familiar with 
the architecture and concepts of VCS One.

Planning
Planning the VCS One cluster consists of determining your goals, your current 
environment and the differences between the two. In addition, coordination of 
the implementation is an important task.

Define your goals
The first step in planning is to define your goals. There are two ways to 
accomplish this. Either approach the question from a hardware perspective or 
approach the question from a software perspective. With the hardware 
perspective, first evaluate the existing IT hardware infrastructure to decide 
which systems will be part of the VCS One cluster, and note the applications 
running on them. With the software perspective, first evaluate what 
applications are going to be managed by VCS One, and note the systems those 
applications are running on. With either approach, the result is that you have 
the following:

■ The set of systems that will be controlled by VCS One

■ The list of applications that will be managed by VCS One

Remember to list any systems that will be included as spares for maintenance, 
expansion, or mobility of the managed applications.

Note: Often the end goal changes over the course of planning because of 
hardware requirements or available resources. It is a best practice to estimate 
the priority of your goals in case adjustments must be considered later in the 
process.
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Determine the current environment
The second step in planning is a process of discovery of what currently exists in 
your environment. 

Collect system information
You will need information about both the Policy Master cluster nodes and the 
client systems. For each system that will be controlled by VCS One, collect the 
following information:

■ Systems: Document the name, OS, OS version, number of CPUs, speed of 
CPUs, and memory available on the system(s).

■ Network requirements: Determine the network connectivity of the systems. 
Document the NICs available on each system and what subnets they are on.

■ Storage requirements, if applicable: Determine the storage topology of the 
systems. Document the HBA(s) available on each system. Also document 
which systems have shared storage between them if you are considering a 
VCS One cluster configuration that has application failover capability, either 
manual or automated.

For example, all VCS One cluster systems may be connected to shared 
storage, or subsets of the VCS One cluster systems may be connected to 
their own storage.

Collect application information
For each application that will be controlled by VCS One, collect the following 
information:

■ Failover capability: Determine if the application will have failover capability, 
either manual or automated.

■ Hardware requirements: Determine the hardware architecture and version 
of the operating system that the application requires.

■ Resource requirements: Determine the logical and physical components 
that are used by the application, and how they depend on each other. These 
components will become your list of VCS One resources, and will determine 
the start and stop order of the resources.

See “About resources and resource dependencies” on page 31.

■ Application dependencies: Determine if this application is dependent on 
other applications. 

For example, a web based application may require an Oracle application 
backend database.
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Plan organizational tasks
Depending on the practices and procedures of the environment, you may need to 
get approvals, schedule down time in advance or request change orders.

Planning your user privilege model
Determine if the predefined roles for users match to the requirements of your 
environment.

See “Pre-defined roles in VCS One” on page 754.

About the names of your VCS One cluster objects and attributes
The following criteria describe the requirements of VCS One object names.

■ The space character and the following special characters are not allowed in 
names of systems, PFrames, VFrames, VObjects, service groups, resources, 
and agents:

`'\"/\=*+?(){}[]$#^!%&,.:;<>|~@ 

■ User names and user group names can contain a space. They can not 
contain the following special characters:

`'\"/\\=*+?(){}[]$#^!%&,:;<>|~

■ User and user group names are case insensitive. For example, 
username@domain.com is treated the same as USERNAME@DOMAIN.COM. 

This could have an impact if there are two distinct users that have the same 
names except for the case. If one user has been added to VCSOne 
ServerFarm, the other user would gain the same privileges. 

■ Attribute and object names are case-insensitive.

■ Attribute values are case-sensitive by default but can be configured 
otherwise.

■ The description text of any VCS One object can not use a single quotation 
mark. 

■ An attribute value that contains an escape sequence for a special character 
must be enclosed in double quotation marks.

■ A group extended attribute can not have the same name as an already 
existing group attribute or common extended attribute.

■ A system extended attribute can not have the same name as an already 
existing system attribute or common extended attribute.

■ A vframe, pframe, or vobject extended attribute can not have the same name 
as an already existing attribute or common extended attribute.
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■ A set name is local to a user. Set names do not have to be unique across the 
VCS One cluster.

■ A fully qualified resource name is in the format group.resource. For 
example, oracle_group.ip_resource

■ During a Vframe discovery operation, the name of the Vframe object will be 
same as the name of the associated virtual machine in the VMware 
VirtualCenter, with the following exceptions:

■ Special characters are replaced by an underscore character ( _ ). 

■ The percent character (“%”) is replaced with “_25”.

■ Duplicate names are suffixed with an increasing number. 

For example: If a virtual machine, VM1 appears in more than one 
VirtualCenter Management console, two frame objects of type ESXVM 
will be created in the VCS One configuration: VM1 and VM1_1. The 
second virtual machine discovered has the name VM1_1.

Table 9-1 Maximum permissible size for VCS One objects

Object Maximum permissible size

VCS One cluster name 128 characters

System name 128 characters

Group name 128 characters

OUName node name 128 characters

OUValue node name 128 characters

Depth of the Organization Tree 512 OUname=OUvalue pairs

Length of the fully qualified path of a OUNode
(from root of the tree to the node)

4096 characters

Resource name 128 characters

Resource type name 128 characters

Fully qualified resource name Group name + Resource name + 2

User name 64 characters

User group name 64 characters

Fully qualified user name 
(name@domain)

128 characters

Domain name 64 characters
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Including special characters in attribute values
When you manually edit the XML configuration file, use standard XML escape 
sequences to include special characters in attribute values. 

Enclose attribute values that have XML escape sequences in double-quotation 
marks. For example:

<attribute name="StartProgram"><scalar>"start in bg -- &amp;"
</scalar></attribute>

The escape character for a resource attribute variable is the caret character (ˆ).

Caution: Symantec recommends using the escape sequences instead of the 
special characters. If you use the special character, you may encounter errors 
depending on the location of the special character.

Preparing
Now that you have identified what you need, in this phase you use that 
knowledge to prepare for installation and implementation. In this step, do the 
following:

■ Gather reference material.

Product documentation and other reference material can help 
implementation go more smoothly when questions arise.

Role name 128 characters

String attribute name 32 characters

Table 9-2 Examples of escape sequences for special characters

Special character Escape sequence

“ (double quotes) &quot;

& (ampersand) &amp;

< (less than) &lt;

> (greater than) &gt;

‘ (single quote) &#39;

Table 9-1 Maximum permissible size for VCS One objects

Object Maximum permissible size



243Design overview
Implementing
■ Validate agent requirements. 

Determine if the agents bundled with VCS One meet your resource 
management requirements. 

If you have a resource that can not be managed by existing agents, it may be 
necessary to create a custom agent, or to use the application agent with 
custom start and stop scripts.

■ Collect agent specific attributes.

Most agents required specific information at the individual resource level in 
order to control the resource. For example, the Mount agent requires a 
specific file system name, and the IP agent requires a specific IP address. 

■ Set up your Policy Master cluster hardware.

See Veritas Cluster Server One Installation Guide.

■ Collect information about the Policy Master cluster for the installation 
scripts. 

■ Identify the names of the systems in the Policy Master cluster.

■ Choose a number (0-65535) to represent the Policy Master cluster ID.

If there are other Veritas Cluster Server (VCS) clusters in the 
environment, choose a unique cluster ID to differentiate this Policy 
Master cluster.

■ Verify network connectivity, and collect network information for the 
installation scripts.

■ Test the Policy Master can connect to the client systems with operating 
system tools, such as the ping command.

■ Identify the names of the two Policy Master cluster interconnect NICs 
on each Policy Master system.

■ Identify the virtual IP address for the Policy Master cluster systems.

Implementing
This phase summarizes the steps for implementation and installation of VCS 
One. This phase should occur only after planning is complete and all 
preparations have been completed. 

See Veritas Cluster Server One Installation Guide.

Steps are slightly different depending on whether you are installing a Windows 
or UNIX Policy Master.
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Implementing on UNIX
The following are the general steps for implementation with a UNIX Policy 
master:

■ Enable secure shell communications on each client system.

This is one of the few tasks that may require accessing every system of the 
VCS One cluster.

■ Configure shared storage on the Policy Master nodes, and test the disks for 
SCSI-3 compliance. 

Before installation, collect the storage information you will need to 
configure shared storage:

■ Identify the name of the mount point for the shared storage.

If you need a mount point for the Network Appliance Filer (NetApp 
Filer), mount the NFS point on a local directory on the system where 
you will install the Policy Master.

■ Identify the type of file system used on the shared storage.

■ Identify the name of the disk group to store the database (if Storage 
Foundation configuration is not performed by the installer).

■ Identify the name of the disk that will be part of the disk group to store 
the database (if Storage Foundation configuration is not performed by 
the installer). Use short disk names.

■ Identify the name and size of the volume where the database is to be 
created on external storage (if Storage Foundation configuration is not 
performed by the installer).

■ Set up I/O fencing on the Policy Master nodes.

Note: A response file can be used to allow for unattended installations on 
multiple client systems. 

■ Install the Policy Master

The installation names the Policy Master cluster vcsone_cluster. 

If you do not already have Veritas Storage Foundation installed, you will be 
prompted to install it when you install the VCS One Policy Master. There is 
no need to separately install Storage Foundation. 

If you will use the Network Appliance Filer (NetApp Filer), you will be 
prompted to configure this during the installation of the VCS One Policy 
Master.

■ Install the VCS One client daemon software on the client systems.

■ Install the high availability agents.
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■ Verify the installation.

■ [Optional] Configure shared storage hardware as appropriate if the managed 
applications will be configured to move between systems.

Implementing on Windows
The following are the general steps for implementation with a Windows Policy 
Master:

■ Install and configure the Policy Master and verify the installation

■ Install and configure the VCS One client software on the client systems

■ Install the high availability agents

■ [Optional] Configure shared storage hardware as appropriate if the managed 
applications will be configured to move between systems

Configuring and verifying
This topic outlines the process the administrator can follow in configuring the 
Policy Master cluster and the VCS One cluster. 

Configuring the Policy Master cluster
Make the following considerations to configure the Policy Master cluster:

■ The VCSOneWeb resource in the Policy Master service group is not set as a 
critical resource by default. This means that if the VCSOneWeb resource 
crashes, VCS One does not initiate failover of the Policy Master service 
group.

◆ Type the following commands when the VCS cluster is up and running to 
make the VCSOneWeb resource a critical resource.

On UNIX:
/opt/VRTSvcs/bin/haconf -makerw 
/opt/VRTSvcs/bin/hares -modify VCSOneWeb Critical 1 
/opt/VRTSvcs/bin/haconf -dump -makero 

On Windows:
%VCS_HOME%\bin\haconf -makerw 
%VCS_HOME%\bin\hares -modify VCSOneWeb Critical 1 
%VCS_HOME%\bin\haconf -dump -makero 

Where %VCS_HOME% is the VCS installation directory. The default 
installation directory for VCS is C:\Program Files\Veritas\cluster 
server.

■ Tune attributes of the Policy Master service group.
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See “Tuning attributes of the Policy Master service group on UNIX” on 
page 679.

Configuring the VCS One cluster
The VCS One cluster configuration can be modified via the following methods:

■ Graphical user interface, also known as the console.

■ Command line interface

■ XML files edit followed by importing the new files into the database.

If you edit the XML files directly, the vcsoneencrypt command can be used 
to generate encrypted passwords. 

Each step should be verified as it is completed.

■ Start VCS One.

■ Start the VCS One Web Console.

■ Log in to the VCS One software.

■ Configure VCS One cluster level attributes.

■ Set or accept the default value of the PrecedenceOrder attribute.

■ Set or accept the default value of the FragmentationPolicy attribute.

■ Add systems.

■ [Optional] Set system Capacity attribute.

■ [Optional] Set DefaultPlatform attribute.

See “DefaultPlatform” on page 822.

■ [Optional] Define the organizational units and extended attributes, if 
needed.

■ In a VCS One cluster that contains more than a few thousand resources, 
you may decide to change the default monitoring of the PMSG

See “Tuning attributes of the Policy Master service group on UNIX” on 
page 679.

■ Configure the VCS One cluster systems.

■ [Optional] Define Capacity for each client system.

■ Start vcsoneclientd on each client system. Verify it is running.

■ Configure the managed applications.

■ Add resources.

■ Define resource dependencies.

■ Create service groups and then add resources.

■ [Optional] Define Load for each service group.
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■ [Optional] Define Priority for each service group.

■ [Optional] Define Compatibilities or Incompatibilities for each service 
group.

■ [Optional] Link service groups as necessary for service group 
dependencies.

■ [Optional] Define the organizational unit and extended attribute 
values, if you have not already done so, and move them under the 
pre-defined Organization Tree.

Note: It is a best practice to manually move the application outside of 
VCS One control before testing movement under VCS One control.

■ Configure Notification.

■ SMTP

■ SNMP

■ Assign User Permissions.

■ Designate privileges to users based on their job tasks, such as operator 
level privileges. 

■ Configure Log Files

■ Configure the level of logs to collect.

■ Custom configuration tasks for your environment.

Other common configuration decisions
The following configuration decisions are examples of other possible 
configuration options.

■ Agent version check.

The ability to check that the version of the agent running is compatible with 
the Policy Master version.

See “About the control of agent versions” on page 57.

■ Sets

Create sets to filter applications by custom criteria, such as department or 
line of business.

See “Administering sets of objects” on page 665.



248 Design overview
Configuring and verifying



Chapter
 10
Designing roles and 
privileges for users

This chapter includes the following topics:

■ About designing roles and privileges for users

■ About users and the Organization tree

■ How you manage users using the Organization Tree

■ About user permissions in the organization tree
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About designing roles and privileges for users
When a user is created, the user must be assigned a role. A role is a named 
collection of privileges. Privileges define what actions the user can perform, 
such as adding a system to the VCS One cluster or modifying a service group.

When a user tries to perform an operation, VCS One authorizes the user’s action 
against the privileges associated with the user’s role.

VCS One has both predefined roles and the ability to create custom roles. A 
reference is available of all the VCS One cluster privileges and pre-defined roles.

See “Reference of privileges” on page 753.

About user groups
VCS One allows existing groups of users already configured in the data center, 
such as with NIS or LDAP, to be represented by a user group object. VCS One 
identifies the membership of the external user to a VCS One user group using 
Symantec Authentication Services (AT). Roles and privileges are assigned to a 
user group in the same manner as they are assigned to an individual user.

The association of a user with a user group is dynamic. The user is implicitly 
associated with all the groups specified in the user credentials. The credentials 
of the user includes the credentials of the user group to which the user belongs.

About privileges
Because every action in VCS One requires a privilege, the privileges are 
organized into privilege categories for ease of administration. The privilege 
categories sort the individual actions the role can perform by the type of object 
the action is related to. 

For example, the System Privilege category contains privileges to freeze a 
system or change the value of the SystemList attribute; the Notifier Privilege 
category contains the privilege to change the notification settings.

The user’s total privileges are a union of the privileges explicitly granted to the 
user and the privileges granted to any user group of which the user is a member.

To give a user every available privilege, assign the user both the 
ServerFarmAdministrator and ServerFarmObjectAdministrator roles.

For business policy automation rules, note the following guidelines:

■ A user can own a rule if that user or at least one of that user’s user groups 
are explicitly added to the VCS One configuration. 

This holds true even if the user is root on the Policy Master node, that user 
or its user groups should be added explicitly.
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■ Assign explicit privileges to that user to perform the actions the rule 
invokes.

A user with sufficient privileges may disable a user or user group. A disabled 
user or any user belonging to a disabled user group has the following 
characteristics:

■ Will have all privileges revoked.

■ Will not be able to perform any of the actions associated with the user or 
user group. 

■ Will not be able to log in through the VCS One console. 

At the point the effective privileges of the user is zero, the user is logged out 
of the console.

A user with sufficient privileges may re-enable a disabled user to reinstate 
privileges.

What information identifies a user or user group
When an administrator adds a user or user group to the VCS One cluster, the 
following information is configured:

■ Username - identifies a specific user in the format name@domain

■ First name and last name of the user 

■ Email address - allows a user to be notified by email

■ SNMP IP address - allows the user to receive notification of VCS One events

Additionally each user has an associated role and is attached to an organization 
unit node in the Organization Tree.

About roles 
A role signifies a set of privileges for a user. You may assign predefined roles or 
create new custom roles. A user may be assigned various roles. The privileges 
contained in the role provide the ability to perform an operation, such as add, 
modify or delete, on an object, such as a group, resource or organization tree 
node.

See “Pre-defined roles in VCS One” on page 754.

You may not update the operations that can be performed by the predefined 
roles, but you can develop a custom role to accommodate the needs of your 
environment.
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About users and the Organization tree
Privileges are sorted into privilege categories, also called role types, which 
describe to what type of object the privileges correspond. The privilege 
categories are as follows:

In order to receive notification about an object, a user must have both Notifier 
privileges and some other privilege on that object. A user that has only the 
Notifier privilege on an object will not receive notifications. 

About users and the Organization tree
An Organization Tree is a logical hierarchical structure of the VCS One cluster 
that is used to delineate user views and privileges.

Systems, service groups, and users are placed into particular areas of the 
Organization Tree. The user privileges for those systems and service groups 
depend on where they are in the tree. As the tree changes, privileges are 
dynamically updated.

For example, in the sample Organization Tree in Figure 10-1, an operator can 
have the privilege to online or offline a service group on any system in the 
Wholesale branch of the tree. If additional systems are added to the Wholesale 
branch, that user’s privileges are automatically updated to include the new 
systems.

Additionally, a user in the Wholesale branch of the tree has no visibility into the 
Retail branch of the tree, unless privileges are explicitly granted.

Farm Object System

Group Composite Service Group

VObject PFrame VFrame

Resource User Organization tree

Automation Notifier
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Figure 10-1 Sample Organization Tree

How you manage users using the Organization Tree
The following structure of the Organization Tree help you manage what a user 
can see and do in the VCS One cluster:

■ The Organization Tree subdivides the VCS One cluster into OUNames 
(branches) and OUValues (nodes).

The sample Organization Tree in Figure 10-2 has three top-level division 
branches, Marketing, Retail, and Wholesale. Inside the Wholesale division 
branch, there are two projects under the B2B branch called Development 
and Production. 

Retail branch

Wholesale branch
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Figure 10-2 Organization Tree branches and nodes

■ Objects are attached to the Organization Tree at particular nodes.

In this example, some systems and service groups are attached to the 
Development node, and other systems and service groups are attached to 
the Production node. 

■ Attach a user to the organization tree at the node that corresponds to the 
level of privilege you want them to have to view and perform operations in 
the VCS One cluster.

■ A user can be assigned privileges over objects and OUs at or below the 
node where the user or user group is attached.

■ The operations the user is able to perform are in accordance with the 
role and corresponding privileges assigned to the user.

■ A user is able to view the direct path back to the top of the tree, the 
ServerFarm (/) node.

For example, if you want UserA to have privileges only on systems attached 
to the Production node, you must ensure the following:

■ Attach UserA at the Production node.

■ Assign related system privileges to UserA. 

■ Determine UserA is not a member of a user group that is attached at or 
above the Development node.

UserA would not be able to see that the Development node exists. You may 
want this type of configuration if a user has the role of GroupOperator, and 
you only want to user to be able to online or offline the service groups 
running on the production systems.

Retail branch

Wholesale branch
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If you want UserB to have privileges on both the Production and the 
Development systems, you must attach the user to the Wholesale node and 
assign relevant system privileges for UserB on the Wholesale node. 

An example of this configuration is a user that has the role of 
ServerFarmObjectAdministrator. UserB can move systems from 
Development to Production if there is a business need. 

In this case, UserB privileges would be dynamically updated to have 
SystemOperator privileges on any new systems attached at or below the 
Wholesale node.

About the architecture of the Organization Tree
Figure 10-3 shows the architecture of an Organization Tree.

Figure 10-3 Architecture of the Organization Tree

About organization units
Each VCS One cluster may have one Organization Tree, which is built in the 
order of a tree hierarchy. The tree hierarchy is made up of multiple organization 
units that form the nodes of the Organization Tree. 

Each organization unit node in the Organization Tree is one of the following 
types:

■ OrgUnitName (OUName)

OUNames define the branches or categorization of the Organization Tree. 
An OUName has one or more OUValues as child objects in the Organization 
Tree. An OUName can not have another OUName as a direct child object.

In the sample Organization Tree the OUName nodes are VCSOneCO, Dept, 
and B2B.

■ OrgUnitValue (OUValue)
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An OUValue denotes the value of an OUName. An OUValue can have at 
most one OUName node as a child object in the Organization Tree.

In the sample Organization Tree the OUValue nodes are Marketing, Retail, 
Wholesale, Internet, Voice, Development, and Production.

Users, user groups, systems, PFrames, VFrames, Vobjects, service groups, 
and composite service groups are attached only at OUValue nodes in the 
Organization Tree.

The number of OUName and OUValue nodes appropriate for your environment 
is determined by how you want to limit user privileges on systems and service 
groups: 

Use the following guidelines to help you decide whether to create an 
Organization tree hierarchy.

■ If you want to have all administrators in your organization have 
ServerFarmAdministrator privileges on all systems and service groups, you 
can attach all systems and service groups at the ServerFarm(/) level. 

■ If you want to compartmentalize a user to only have privileges on a specific 
set of systems, you must create an organization unit structure. 

In VCS One, the Serverfarm(/) is an implied OUValue. To build an organization 
unit structure, create an OUName as the first object under this OUValue. Add 
additional OUValues as needed to the first level OUName. In Figure 10-3, 
VCSOneCO is the first level OUName under the implicit OUValue of (/). 

More information is available on building an Organization Tree.

See “How to build an organization tree” on page 624.

About paths in the Organization Tree
An Organization Tree path is denoted by a list of OUName=OUValue pairs, 
separated by a forward slash (/). 

The following examples are valid paths in the Organization Tree in Figure 10-3.

■ /VCSOneCO=Retail

■ /VCSOneCO=Wholesale

■ /VCSOneCO=Wholesale/B2B=Development

About user permissions in the organization tree
User permissions operate with the following criteria:

■ A user’s permissions are relevant to the node in the organization tree where 
the user, or a user group that the user is a member of, is attached.
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The level of privileges assigned is for the node the user is attached at and all 
the nodes below that node in the organization tree. 

In Figure 10-4, if a user is attached at the Production node, then privileges 
can be assigned only to objects and OUs at or under the Production node. 
So, the user can be made a GroupAdministrator for the Production node but 
not the Development node. Similarly, a user attached at the Wholesale node 
can be made a GroupAdministrator for either the Development node or the 
Production node or the Wholesale node, or for all the three nodes.

Figure 10-4 Sample organization tree

■ Movement of objects in the organization tree from one node to another can 
change the users that have permission to perform actions on those objects.

■ A user’s view of the organization tree is filtered by where they are attached. 
A user can view all of the organization tree below where they are attached. 
Above the user, the only part of the organization tree a view will view is the 
direct line back to the root of the tree. In Figure 10-4, a user attached at 
Development node will see following path /VCSOneCO=Wholesale/
B2B=Development. This same user would not be able to view the Retail 
branch of the tree or even the Production node unless given separate 
specific permissions.
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This chapter includes the following topics:

■ About designing the actions taken after a fault

■ Configuration examples of fault handling behavior
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About designing the actions taken after a fault
Controlling the actions of VCS One when a fault occurs is configurable with 
attributes of the following objects:

■ Resource

■ Service Group 

■ System 

■ VFrame

■ PFrame

When a fault occurs the settings control the immediate offline actions. The 
related subsequent online actions and any necessary kick out actions can be 
controlled manually or be automatically executed.

See “About designing application and virtual machine placement policy” on 
page 312.

You can use the VCS One Simulator to simulate actions that are taken after a 
fault.

See “About the Simulator” on page 204.

Resource level control after a fault
The resource level attribute ResFaultPolicy controls the behavior of a resource 
in the event of a fault. 

You can set a fault policy uniformly on all resources in a service group or set 
fault policy for each individual resource.
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Table 11-1 lists the possible values for ResFaultPolicy.

Table 11-1 ResFaultPolicy values for resource level control of fault behavior

Value Behavior of resource when faults

FaultPropagateAll Default value of ResFaultPolicy.

Agent calls clean entry point. The value of the resource 
attribute RestartLimit is checked:

If RestartLimit is zero (default value), the resource state is 
marked as FAULTED. The fault is propagated and all group 
resources transition to the OFFLINE state. The service group 
changes to the OFFLINE | FAULTED state. 

If RestartLimit is greater than zero, VCS One attempts to 
restart the resource RestartLimit number of times. 

If the resource does not successfully restart, the fault is 
propagated and all group resources transition to the 
OFFLINE state. The service group changes to the OFFLINE | 
FAULTED state.

The value of the GrpFaultPolicy attribute determines 
failover of the group

FaultPropagateParent If RestartLimit is greater than 0, VCS One attempts to 
restart the resource RestartLimit number of times. 

If the resource does not successfully restart, the fault is 
propagated to the parent resources. Parent resources are 
the resources that are higher up in the resource 
dependency tree.

Fault is propagated to parent resources in the ONLINE state. 
If there are any parent resources in the OFFLINE state, the 
fault is not propagated beyond that resource.

If the fault is propagated to a resource where 
ResFaultPolicy = FaultPropagateAll, then all group 
resources transition to the OFFLINE state, and the service 
group changes to the OFFLINE | FAULTED state. 

FaultHold Agent calls clean entry point. 

If RestartLimit is greater than 0, VCS One attempts to 
restart the resource RestartLimit number of times. 

If RestartLimit is 0, the resource is reported as faulted to 
the Policy Master. The service group state changes to 
PARTIAL. The fault is not propagated further.



262 Designing actions taken after a fault
About designing the actions taken after a fault
If two resources in the same service group have different values for 
ResFaultPolicy, the value of the most recently faulted resource determines the 
behavior of all of the group’s resources. 

■ Assume the policy for the child resource is FaultPropagateAll and for the 
parent resource is FaultHold. If the child faults, VCS One brings the service 
group offline, whereas if the parent faults, the FaultHold policy prevails.

■ If resourceA with ResFaultPolicy=FaultNone faults, it goes into ADMIN_WAIT 
state, and waits for action by an administrator. If resourceB in the same 
service group faults with ResFaultPolicy=FaultPropagateAll, VCS One 
automatically clears the ADMIN_WAIT state of resourceA. This logic enables 
VCS One to take action that is based on the FaultPropogateAll setting.

Service group level control after a fault
The group level attribute GrpFaultPolicy controls whether or not a service group 
attempts to fail over to another system. This policy is active only after the 
resource level policy setting of ResFaultPolicy=FaultPropagateAll concludes 
with a faulted group.

Table 11-2 lists the possible values for GrpFaultPolicy.

FaultNone Agent does not call the clean entry point. The resource 
state is marked as ADMIN_WAIT, and the group waits for 
administrative action. 

The service group does not failover until the resource fault 
is removed and the ADMIN_WAIT state is cleared.

See “Clearing resources in the ADMIN_WAIT state” on 
page 436.

Table 11-1 ResFaultPolicy values for resource level control of fault behavior

Value Behavior of resource when faults

Table 11-2 GrpFaultPolicy values for group level control of fault behavior

Value Behavior of group when faults

Failover Default value of GrpFaultPolicy.

The service group attempts to failover to the next best 
target system. Target choice is based on Advanced 
Workload Management policy.

NoFailover  The service group does not attempt to failover to another 
server.
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In case of a group fault, the process to take the faulted group offline is initiated 
only after all of its firm and hard parent groups are taken offline.

In a virtualization environment, the group level attribute PropagateFaultPolicy 
controls whether or not a service group fault is propagated to the VFrame. 

Table 11-3 lists the possible values for PropagateFaultPolicy.

The group level attribute OnlineRetryLimit controls whether or not a service 
group attempts to restart on a system. This policy is active only after the 
resource level policy setting of ResFaultPolicy=FaultPropagateAll concludes 
with a faulted group. The value of this attribute indicates the number of 
attempts the Policy Master makes to restart a faulted service group.

System level control after a fault
The service group attribute NodeFaultPolicy controls whether or not a service 
group attempts to fail over in the event of the fault of a system object. 

Table 11-4 lists the possible values for NodeFaultPolicy.

Table 11-3 PropagateFaultPolicy values for propagation of service group fault 
to a VFrame

Value Behavior of group when faults

Propagate A service group fault propagates the fault to the VFrame.

Use this option when want a service group fault to initiate 
a virtual machine failover to another PFrame.

NoPropagate  The service group does not propagate the fault to the 
VFrame. 

Use this option when you do not want a service group fault 
to initiate a virtual machine failover.

This is the default value of PropagateFaultPolicy.

Table 11-4 NodeFaultPolicy values for system level control of fault behavior

Value Behavior of group when system faults

Failover Default value of NodeFaultPolicy.

Set the state of the group as offline and fail over the group.

NoFailover Set the state of the groups as offline, but do not attempt 
failover
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The NodeFaultPolicy supersedes GrpFaultPolicy. For example, if a service group 
is taken offline or faults on a system and does not fail over because the value of 
GrpFaultPolicy=NoFailover, that group is still be targeted for failover if the 
system faulted.

VFrame level control 
The VFrame attribute OnlineRetryInterval has the following characteristic:

Configuration examples of fault handling behavior
The following examples outline how to set attribute values to configure various 
behaviors.

OnlineRetryInterval Indicates the minimum time interval between consecutive 
restart attempts of a virtual machine due to hosted 
application fault

Must be between 300 seconds and 86400 seconds.

Default = 300

Table 11-5 Attribute values to configure fault handling behavior 

To configure this behavior... Set these attribute values...

To configure a group in the VCS One cluster to not 
failover without manual intervention.

Set the following attributes:

■ GrpFaultPolicy=Nofailover

■ NodeFaultPolicy=NoFailover

To configure a group to not fail over a group in the event 
of a fault, but if the system faults fail over all groups on 
that system.

Set the following attributes:

■ GrpFaultPolicy=Nofailover

■ NodeFaultPolicy=Failover

To configure that when a resource faults, the group is 
taken offline but not failed over

Set the following attributes:

■ ResFaultPolicy=FaultPropogateAll

■ GrpFaultPolicy=NoFailover

or

■ ResFaultPolicy=FaultPropogateAll
and have only one system designated in the 
group’s SystemList attribute.
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To configure that when a service group that is running in 
the virtual machine faults, failover the VFrame to 
another PFrame.

Set the following attributes:

■ Service group: PropagateFaultPolicy = Propagate

■ VFrame: VFrameFaultPolicy = Failover 

To configure that when a service group that is running in 
a virtual machine faults, make three attempts to restart 
the VFrame. (provided successive faults occur after five 
minutes). 

Set the following attributes:

■ VFrame: OnlineRetryLimit = 3

■ VFrame: OnlineRetryInterval = 300 (5*60)

■ Service group: PropagateFaultPolicy = Propagate

To configure that when a service group that is running in 
a virtual machine faults, make three attempts to restart 
the service group. (provided successive faults occur after 
five minutes). 

After three attempts, propagate the service group fault to 
the VFrame, and failover the VFrame to another PFrame.

Set the following attributes:

■ Service group: OnlineRetryLimit = 3

■ Service group: OnlineRetryInterval = 300 (5*60)

■ Service group: PropagateFaultPolicy = Propagate

■ VFrame: VFrameFaultPolicy = Failover

Table 11-5 Attribute values to configure fault handling behavior 

To configure this behavior... Set these attribute values...
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 12
Designing attribute values 
using variables

This chapter includes the following topics:

■ About designing attribute values using variables

■ Examples of using a resource variable

■ What can be defined using a resource variable

■ Where a variable can be used

■ Where a variable cannot be used

■ Design implications of resource variables
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About designing attribute values using variables
VCS One allows you to use a variable to define an attribute value. This variable is 
called a resource variable. 

The use of variables in attribute definitions has the following benefits:

■ You can use extended attributes with predefined mandatory values as 
variables to obtain standardization and consistency of terminology.

■ You can more easily manage resources by decreasing the number of 
localized attributes.

Examples of using a resource variable
This topic includes three examples for how you might use resource variables in 
your environment to reduce the need to enter the same information multiple 
times, minimize the risk of typographical errors, and simplify configuration 
edits.

Example 1
A typical service group contains one disk group with multiple volume resources 
and mount resources. When you set up this configuration, you must provide the 
name of the disk group several times.

Table 12-1 shows an example of this configuration.

To improve your efficiency, you can define an extended attribute for a group 
that contains a DiskGroup resource. Use a resource variable in place of the disk 
group name in each of the resource definitions. The disk group name is entered 
once for the extended attribute. As you create new volume resources and mount 
resources, you do not need to retype the disk group name. Additionally, if the 
disk group name changes, you only need to make one update at common 
extended attribute definition. Without using this method, you would have to 
update each of the DiskGroup, Volume and Mount resources. 

Table 12-1 Typical service group configuration example

Type of resource Attribute of resource Sample value of attribute

DiskGroup DiskGroup exmpldg

Volume DiskGroup exmpldg

Mount BlockDevice /dev/vx/dsk/exmpldg/volume



269Designing attribute values using variables
Examples of using a resource variable
Table 12-2 shows the same example using resource variables and the common 
extended attribute “DGName = exmpldg”.

Example 2
When you use localized attributes, the attributes become harder to maintain as 
the number of objects grow. Resource variables can make localized attributes 
easier to maintain.

This example is of a service group that has a Mount resource that runs on the 
Solaris operating system. 

In a non-failover environment, you may define the required resource attributes 
of the Mount resource using the following definitions:

Mount resource name = mount_app01

Block device = /dev/hda

FsckOpt = —y

FSType = vxfs

MountPoint = /mnt/solaris/10

In an environment where the application may move between systems, you may 
want the value of the MountPoint attribute to be different on different systems. 
In this case, you can localize the MountPoint attribute. 

To localize the MountPoint attribute means that you make a local value for the 
MountPoint attribute for each system on which the service group may be online. 
When you localize the attribute, the value of the MountPoint attribute can 
change depending on which system the service group is online on. 

In this environment, you may define the required attributes using the following 
definitions:

Mount resource name = mount_app01

Block device = /dev/hda

FsckOpt = —y

FSType = vxfs

MountPoint = /mnt/solaris/10 (definition on sys1)

MountPoint = /mnt/solaris/9 (definition on sys2)

Table 12-2 Service group example using resource variables

Type of resource Attribute of resource Sample value of attribute

DiskGroup DiskGroup @{DGName}

Volume DiskGroup @{DGName}

Mount BlockDevice /dev/vx/dsk/@{DGName}/volume
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When there are many systems that the Mount resource may run on, the list of 
localized resource attributes becomes long and hard to manage.

When you add the use of resource variables to this example, you may define an 
system extended attributes that is named OS_VERSION on each system. Then 
you may define the attributes using the following definitions:

Mount resource name = mount_app01

Block device = /dev/hda

FsckOpt = —y

FSType = vxfs

MountPoint = /mnt/solaris/@{OS_VERSION}

In this example, on each system where the Mount resource runs, the value of the 
extended attribute OS_VERSION would replace the variable @{OS_VERSION} 
when the MountPoint value is parsed.

When a new system is added to the SystemList, you only need to set the 
extended attribute values for the system. You do not need to edit the Mount 
resources.

Figure 12-1 shows how the multiple values of the MountPoint attribute can be 
converted into one value that uses resource variables.

Figure 12-1 Example of using resource variables

Example 3
Consider a parallel service group containing NIC resources that may run on five 
different systems. 
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Table 12-3 shows the resources in this example configuration.

The next added system requires that you edit the Device attribute for each NIC 
resource to add to the localized attribute. The configuration is simplified if you 
define a system level extended attribute and use a resource variable inside the 
NIC resource definition.

Define the system extended attribute “ProdNIC = en0.”

Table 12-4 shows an example of how to use the resource variable in this 
configuration.

When a new system is added to the SystemList of the parallel service group, you 
only need to set the extended attribute value for the system. You do not need to 
edit the NIC resources.

What can be defined using a resource variable
This topic describes the criteria for which you can define resource variables. You 
can define resource variables at the Type level or at the resource level, as long as 
they adhere to specific design criteria.

The following attributes can be defined using a resource variable instead of a 
static value:

■ System, service group, PFrame or VFrame built-in attributes

Must be of type-dimension: string-scalar or string-association.

Table 12-3 NIC resource configuration example

Type of 
resource

Attribute of resource System Sample value of 
attribute

NIC Device System1 en0

NIC Device System2 en1

NIC Device System3 en0

NIC Device System4 en2

NIC Device System5 en1 

Table 12-4 NIC resource variable configuration example

Type of 
resource

System Attribute and Value of attribute

NIC SystemN Device = @{ProdNIC}
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The following syntax denotes a resource variable of dimension 
string-scalar:

■ @{object.attribute_name}

For example: @{vframe.FirstLocalOnline}

The following syntax denotes a resource variable of dimension 
string-association:

■ @{object.association_attribute_name%key}

For example: @{system.SysInfo%OsVersion}

■ System, service group, PFrame, of VFrame extended attributes.

Extended attributes can be specified as resource variables at the resource 
level, but not at the type level.

The following syntax denotes a resource variable using an extended 
attribute:

■ @{object.ea}

For example: @{pframe.MyLocation}

■ VType attributes in the form VType:Attribute

The following syntax denotes a VType type resource variable of dimension 
string-scalar:

■ @{frame.vtype:attribute}

For example: @{vframe.ESXVM:PropagatePMDetails}

The following syntax denotes a VType type resource variable of dimension 
string-association:

■ @{frame.vtype:attribute%key}

For example: @{vframe.ESXVM:NetworkDetails%DNS}

■ Common extended attributes that pertain to system, service group, PFrame, 
or VFrame values.

See “About extended attributes” on page 632.

Use the following information to replace the appropriate variables:

object The type of object. Options are system, group, pframe, or vframe.

The default value is system. When using a system object, you may leave off 
the object classification and use the syntax @{attribute_name}.

key The key-value pair of an attribute of dimension association.

attribute_name The name of the built-in system, service group, pframe, or vframe attribute 
whose value this variable replaces.

association_attribute_name If the attribute is of dimension association, the format of this variable is 
attribute_name%association_key.
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You can use the ^ symbol as an escape character in the VCS One console and 
command-line interfaces. To escape a variable in the resource attribute value, 
place the ^ symbol before the variable. 

For example, in the following command, SysName not treated as a variable. 

hares -modify r1 pathname /tmp/^@{SysName}

hares -value r1 pathname
/tmp/@{SysName}

More information is available on how to configure resource variables.

See “Defining an attribute value with a resource variable” on page 439.

Where a variable can be used
A variable can be used in the definition of a resource value if the resource 
attribute has one of the following dimensions:

ea The name of the extended attribute whose value this variable replaces. Must 
be one of the following types of extended attributes:

■ System extended attribute

■ Group extended attribute

■ PFrame extended attribute

■ VFrame extended attribute

■ Common extended attribute 
If it is a common extended attribute, it must pertain to a system, service 
group, PFrame, or VFrame value.

frame The type of frame. Options are pframe or vframe.

vtype:attribute A VType attribute is in the form VType:Attribute.

Options for VType are ESXServer, ESXVM, LDomsServer, LDomVM, 
ManagementConsole, PFrame, VFrame, VMwareVC.

scalar A scalar has only one value. 

If the data-type is string, you may define this value using a resource 
variable, and the type level resource variable is supported.

association An association is an unordered list of key-value pairs. 

If the data-type is string, the value field of the association may be defined 
using a resource variable. The key (name) field may not be a variable. 

If the value field is defined using a resource variable, then the value may 
not be deleted until the reference to the variable is removed.

This dimension does not support type level resource variables.
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Attribute values may not use the following dimensions:

The type and dimension of predefined resources in VCS One can be found in 
reference tables in the following documents:

■ Engine resources.

See “Attributes reference” on page 815.

■ Resources that are part of the agents that are shipped with VCS One

See Veritas Cluster Server One Bundled Agent’s Reference Guide.

■ Resources that are part of the specific enterprise agent that are not shipped 
with VCS One.

See specific agent guides. An example of a specific enterprise agent guide is 
the Veritas Cluster Server One Agent for Oracle Configuration Guide for 
Windows Server 2003.

A variable can also be used at the type level, as the default value for the 
resource. The value of the variable becomes the default value of each resource 
created. Use a variable for the default value for the resource when you need to 
create many resources that have the same default value.

If you subsequently change the default value, subsequent resources that are 
created inherit the new default value. Previous resources created are not 
affected by the change in the default value.

The following examples use variables at the type level:

■ FileOnOff PathName /tmp/@{SysInfo%OsType}

■ ESXVM Netmask @{vframe.ESXVM:NetworkDetails%Netmask}

Where a variable cannot be used
You cannot use a variable in localized resource attributes. 

The following list outlines the items that cannot be used as a resource variable:

■ Built in attributes other than those of one of the following types:

■ System

■ Group 

■ PFrame

■ VFrame

vector A vector is an ordered list of values. Each value is indexed using a positive 
integer [zero or higher]. 

keylist A keylist is an unordered list of unique strings in that list.
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■ Common extended attributes that pertain to other than system, service 
group, pframe, or vframe values.

■ Extended attributes cannot be specified as a resource variable at the type 
level

■ Static attributes cannot have a resource variable at the type level.

Design implications of resource variables
When a static value of a resource is replaced with a resource variable, some 
operations affect the value of the variable. 

For example, you define an extended attribute at a node in the organization tree. 
The definition of the extended attribute applies to objects, such as systems and 
service groups, that are attached at that node and below in the organization 
tree.

If an extended attribute is used as part of a resource variable definition, 
operations that change or invalidate the value of the extended attribute also 
change or invalidate the value of the resource.

If an extended attribute is used as part of a resource variable definition, the 
following rules apply:

■ You may not delete any organization tree node that has that an extended 
attribute defined using a resource variable.

To delete, you must remove the reference to the resource variable.

■ You may not move a system, group, PFrame, or VFrame between nodes in the 
organization tree unless the extended attribute is defined at both nodes.

■ If you move a system, group, PFrame, or VFrame between nodes in the 
organization tree where the extended attribute is defined, you must also 
explicitly update the value of the resource variable to ensure the value 
reflects the move.

See “Updating the value of a resource variable” on page 441.

■ Using variables in association keys and keylists may lead to duplicate or 
empty keys. After you modify the values, you may use the following 
command to verify the issue is fixed.
hares -verifyvars resource attribute

■ If a group or system attribute is specified at the Type level and the resource 
is added for a VFrame, then the resource variable is converted to a VFrame 
or PFrame resource variable.

For example, if at the Type level we have specified 

@{group.CSGName} 
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and the resource of that type is created for a VFrame then the value of the 
resource variable is changed to 

@{vframe.CSGName}

The reverse is also true when a VFrame or PFrame attribute is specified but 
the resource is created for a service group or system.

If the attribute is not valid, the resource variable is completely removed 
from the attribute value.

Once the resource is created, the resource has that attribute’s local copy. 
Modifying the type level attribute value does not affect the created 
resource’s resource variable. Only the resources which are created 
afterwards are affected.
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Designing service groups

This chapter includes the following topics:

■ About designing service groups

■ Designing the type of service group

■ Designing the name of a service group

■ Designing the Priority of a service group

■ Designing application movement within a local site

■ Designing multi-tier applications

■ Design rules of composite service groups

■ Designing service groups that use off-host resources

■ Designing service groups that run in Solaris zones

■ Designing service groups that run in AIX WPARs
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About designing service groups
A service group is a virtual container that contains all the hardware resources 
and software resources that are required to run the managed application.

A composite service group is a collection of objects. Use composite service 
groups to control several objects as one managed business service. 

CSGs may contain service groups and VFrames. 

Managed applications planning
Use the information collected from the applications in your current 
environment and this topic to outline the plan for your managed applications.

For each application that will be managed by VCS One, do the following:

■ Determine the list of system(s) the application will run on. This list of 
systems will become the value for the SystemList attribute of the managed 
application’s service group. The following considerations will determine this 
list:

■ System configuration. 

Choose the appropriate operating system, number and speed of CPUs, 
and memory requirements of the application. Consider any 
performance criteria or service level agreements (SLA) that must be 
met.

■ The capability of the application to move between systems for 
maintenance or availability. 

If the application is to be managed locally on one server, for start, stop, 
and monitor activities, this list will be one system. If there are 
additional systems that will be included as spares for the managed 
application (the application will be capable of movement, either 
manual or automated), there will be multiple systems identified.

Choose systems that have shared storage between them if the 
application has movement capability, either manual or automated.

■ When a service group runs inside a virtual machine, list only one 
system in the SystemList attribute. A one-to-one mapping exists 
between the system object and the virtual machine object. It is 
advisable to configure one service group within the system on the 
virtual machine, because migration or failover of the virtual machine 
will take the Priority and Load of the service group into account.

■ Use the application resource requirements information you collected to 
build a resource dependency tree.

See “Collect application information” on page 239..
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■ Determine the resource type of each VCS One resource.

Note: The list of resource types necessary for each resource will become the 
list of agents required to support the managed application.

See “Designing service groups” on page 277.

Defining a service group
Once you have figured out your resource dependency tree, you are ready to 
move to the next step to create your service group. When you create a service 
group, you define the following items:

■ A unique name of the service group across the VCS One cluster

■ The list of systems on which the group is allowed to run

■ Definitions of the key service group attributes that define, for example, its 
priority, its compatibility with other service groups, and its load 
requirements

■ The list of resources that establish the managed application, and any 
specific configuration information that is required for those resources

■ The dependency relationship between the resources

■ The dependency relationship with other service groups, if applicable

Consider the following design principles when building your service groups:

■ A service group can have multiple resources of the same type. For 
example, two different disk resources can exist in the same service 
group. 

■ Resource names must be unique within a service group. However, it is 
not necessary for them to be unique across service groups in the same 
VCS One cluster. Two different service groups can have resources with 
the same name.

■ If there is more than one service group that is defined on a system, one 
group may fail over without affecting the others.

Defining service group dependencies
Use the application dependency information you collected to build an service 
group dependency tree. For example, a web based application may require that 
an Oracle application backend database is running before it starts up.

Consider the following design principles when designing your service groups 
dependencies:



280 Designing service groups
About designing service groups
■ The type of the service group dependency affects how the service group may 
start, stop, and move to another system.

See “Types of service group dependencies” on page 286.

Service group dependencies have the following general characteristics:

■ Five tiers of service group dependencies are supported. 

■ A service group can depend on up to five child service groups.

■ A service group can have any number of parent service groups.

Shared storage
A service group can only be started on a client system that has access to its 
associated data files.

If application movement is configured in the VCS One cluster, the associated 
data files needed by the managed application must be available from any system 
configured to host service group. Typically, this requires some form of shared 
storage. VCS One supports shared storage on NAS and SAN. To provide the best 
possible data integrity, configure shared storage to allow VCS One to restrict 
access to only the active node hosting an application. On NAS based storage, 
VCS One provides the ability to control NFS exports from a NetApp based NAS 
filer. On SAN based storage, VCS One uses Veritas Storage Foundation to control 
SCSI-III reservations at the disk group level.

Additional planning for applications in failover environments
The following attributes may be independently set for a service group:

■ Load

■ Compatibility

■ Priority

One or more of the following tasks may be appropriate if the application is 
configured to be able to move between servers for maintenance or availability: 

■ Determine the resources required by the application (Load) with respect to 
the resources available on the servers (Capacity).

Typically the Load of an application represents the number of CPUs and the 
amount of physical memory required for the application.

See “About service group Load and system Capacity for physical systems” 
on page 320.

Note: These settings become the values of the Load attribute of the service 
group and the Capacity attribute of the client systems.
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■ Determine the compatibility of each application with other applications in 
the VCS One cluster. Compatibility is defined with one of the following 
criteria:

■ Compatible with all other applications

■ Compatible with no other applications

■ Compatible with a specific list of other applications

■ Not Compatible with a specific list of other applications

See “Application relationships through service group compatibility” on 
page 318.

Note: Group compatibility privilege is effective only at the root (/) of the 
Organization Tree. This means that compatibility privilege granted at other 
OU nodes does not have any effect. You may not modify group compatibility 
at OUValues other than / even if you have the privileges at those OUValues 
unless you also have the privilege at /.

■ Determine the fault behavior of the resources, service groups and systems.

See “Designing actions taken after a fault” on page 259.

About bringing running applications under VCS One control
You can bring applications that are currently up-and-running under the control 
of VCS One without stopping the application or incurring additional application 
downtime. 

Once you create and configure the appropriate service groups and resources for 
the application, VCS One starts the respective application agents, detects that 
the application is currently running, and brings the service group and its 
resources online. 

If certain resources are not brought online, check the resource attributes and 
probe the resources. The probe operation restarts the agent monitor cycle, 
which detects that the resource is running and marks the resource as online. 

Designing the type of service group
You must decide what type of service group your application requires. All VCS 
One service groups are one of the following types:

■ Failover service groups

Failover service groups are brought online on only one system at a time. 
They are used with applications that do not support simultaneous 
application data access by multiple systems.
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■ Parallel service groups

Parallel service groups are brought online on multiple systems 
simultaneously. They are used with applications that manage multiple 
application instances, which run at the same time without data corruption. 

The service group attribute called Parallel defines the type of service group.

See “Parallel” on page 855.

Designing the name of a service group
The following criteria describe the requirements of VCS One service group and 
composite service group names:

■ The space character and the following special characters are not allowed in 
names of service groups or composite service groups:

`'\"/\=*+?(){}[]$#^!%&,.:;<>|~@ 

■ Service group names, VFrame names, and composite service group names 
must be unique with in the VCS One cluster in which they run.

■ Service group and composite service group names are case-insensitive.

■ The description text of any VCS One object can not use a single quotation 
mark. 

Note the definition of the composite service groups is placed after the definition 
of all other service groups in the main.xml file. This information is only 
important if you are a very experienced VCS One administrator and you edit the 
configuration file directly.

Designing the Priority of a service group
The Priority of the service group is a value that reflects the importance of the 
application to the business. 

The priority of the service group is considered for allocation of VCS One cluster 
resources and failover target policy. 

The service group attribute called Priority defines the priority of the service 
group. The Priority attributes uses a scale of 1 to 5, where Priority =1 is the 
highest priority.

See “About Priority” on page 316.
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Designing application movement within a local site
Local application mobility considers whether or not the application will move 
between multiple systems or virtual machines in the same site.

Edit the SystemList attribute to configure the systems on which the service 
group may run.

■ If the application will start and stop on one system, the SystemList attribute 
will have one system listed.

■ If the application has failover or migrate capability, the SystemList attribute 
contains a list of all the systems on which the service group may run.

Several service group attributes provide the capability to custom design your 
failover policy.

See “Designing actions taken after a fault” on page 259.

Designing multi-tier applications
Multi-tier application design considers whether or not the application is 
dependent on other applications. If one application depends on another 
application’s state, you need to design service group dependencies between the 
service groups that represent each application.

A composite service groups does not have dependencies. Service group 
dependencies remain at the individual service group level.

See “Defining service group dependencies” on page 279. 

About designing service group dependencies
A service group can be dependent on one or more other service groups. 

Service group dependencies are used to configure multi-tier, inter-dependent 
stacks of applications. A common service group dependency is to have a web 
front-end application dependent on a finance application. If that same finance 
application is dependent on a database application, that comprises a three-tier 
service group dependency.

Because the service group is the complete stack of hardware and software 
components that are required to provide an application service to an end user, 
service group dependencies create more complex design and failover 
configurations.



284 Designing service groups
Designing multi-tier applications
Design rules of service group and VFrame dependencies
Design rules of service group dependencies vary by the type of service group 
dependency configuration you use.

Design rules of VFrame dependencies are equivalent to those of service groups, 
except VFrames can not be parallel.

Table 13-5 depicts supported and unsupported service group dependency 
configurations.

Rules that apply to all service group dependencies:
■ Five levels of service group dependencies are supported.

■ A parent service group can depend on up to five child service groups.

■ A child service group can have unlimited parent service groups.

■ A service group can be both a parent service group and a child service group, 
creating a multi-tier configuration.

■ If a child service group has a hard service group dependency between itself 
and one parent, all the parent dependencies must be of type hard. A child 
must have all hard group dependencies or all non-hard group dependencies.

See “Types of service group dependencies” on page 286.

Table 13-5 Supported service group dependency configurations

Parent Child Local Global

Failover Failover Soft Firm Hard SOFT Firm Hard

Failover Parallel SOFT FIRM Hard SOFT Firm Hard

Parallel Failover Soft Firm Hard SOFT FIRM Hard

Parallel Parallel SOFT FIRM Hard Soft Firm Hard

SOFT Bold text with green background dependencies are allowed under 
any condition

Soft Plain text with red background dependencies are not allowed 
under any condition

Soft Italics text with yellow background dependencies are allowed with 
restrictions. 
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■ If a parent service group has a hard service group dependency between itself 
and a child service group, the parent service group may have only one child 
service group.

■ Parallel parent service groups cannot be dependent on a global parallel child 
service group.

■ Parallel parent service groups cannot be dependent on a local failover child 
service group. Cyclic service group dependencies can not exist.

■ The following attributes should be the same for both child and parent 
groups when there is a local dependency between them:

■ CompatibleGroups

■ IncompatibleGroups 

■ The following attributes should always be the same for both child and 
parent groups:

■ Priority

■ Evacuate

■ Frozen

■ NodeFaultPolicy

■ GroupFaultPolicy

■ The following attributes should be the same for both child and parent 
groups when the child and parent are of the same service group type 
[Failover or Parallel]:

■ SystemList

■ SystemZones

■ The child group’s SystemList attribute must always include all the systems 
in the parent group’s SystemList attribute.

More information is available about service groups, service group dependencies, 
and how to design service group failover policy.

See “About service groups and service group dependencies” on page 32.

See “About designing the actions taken after a fault” on page 260.

See “Mapping an application placement decision” on page 326.

See “Managing service groups” on page 355.

See “Service group attributes” on page 848.
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Types of service group dependencies 
The dependency relationship between a parent service group and a child service 
group is called a link. The link between a parent service group and a child 
service group is characterized by the location of the service groups and the type 
of dependency.

■ A dependency can be local or global. 

■ A dependency can be soft, firm, or hard with respect to the rigidity of the 
constraints that exist between parent and child service groups when they 
are brought online or taken offline. A soft dependency specifies minimum 
constraints. A hard dependency specifies maximum constraints.

Local and global dependencies
The relative location of the parent service group and child service group 
determines whether the dependency between them is local or global.

Local dependency
In a local dependency, the parent service group depends on the child service 
group being online on the same system.

Global dependency
In a global dependency, an instance of the parent service group depends on one 
or more instances of the child service group being online on any system.

Soft, firm, and hard dependencies
The type of dependency defines the rigidity of the link between parent and child 
service groups.

Soft dependency
A soft dependency specifies minimum constraints while bringing the parent and 
child service groups online. The only constraint imposed by a soft dependency, 
whether the dependency is local or global, is that the child service group must be 
brought online before the parent service group is brought online. For example, 
in a local soft dependency, an instance of the child service group must be 
brought online on the same system before the parent service group can be 
brought online.

A soft dependency has the following characteristics:

■ If the child service group faults, VCS One does not immediately take the 
parent service group offline. If the child service group cannot fail over, the 
parent service group remains online.
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■ When both service groups are online, either the child service group or the 
parent service group, can be taken offline, while the other remains online.

■ If the parent service group faults, the child service group can remain online.

■ When a link is created, the child service group need not be online if the 
parent service group is online. However, when both the service groups are 
online, their online state must not conflict with the type of link created.

Firm dependency
A firm dependency specifies more constraints when VCS One brings the parent 
or child service groups online or takes them offline. In addition to the constraint 
that the child service group must be online before the parent service group is 
brought online, the other constraints include the following:

A firm dependency has the following characteristics:

■ If the child service group faults, the parent service group is taken offline, 
unless it is frozen at the time of the fault, in which case, it remains in its 
original state. If the child service group cannot fail over to another system, 
the parent service group remains offline.

■ If the parent service group faults, the child service group can remain online.

■ The child service group cannot be taken offline if the parent service group is 
online. The parent service group can be taken offline while the child service 
group is online.

■ When a link is created, if both the parent and child service groups are 
online, their online state must not conflict with the type of link created.

Hard dependency
A hard dependency specifies maximum constraints when VCS One brings the 
parent or child service groups online or takes them offline. 

A hard dependency has the following characteristics: 

■ If the child service group faults, the parent service group is taken offline 
before the child service group is taken offline. If the child service group fails 
over, the parent service group fails over to another system (or the same 
system for a local dependency). If the child service group cannot fail over, 
the parent service group remains offline.

■ If the parent service group faults, the child service group is taken offline. If 
the child service group fails over, the parent service group fails over to 
another system (or the same system for a local dependency). If the child 
service group cannot fail over, the parent service group remains offline.
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Service group dependency configurations
This section discusses service group dependency configurations. In the 
following tables, the term instance applies to parallel service groups only. For 
example, if a parallel service group is online on three systems, an instance of the 
service group is online on each system. 

For failover service groups, only one instance of a group is online at any time. 
The default dependency type is Firm.

Failover parent / Failover child
Table 13-6 depicts the failover behavior for a failover parent and a failover child.

Table 13-6 Failover parent/Failover child

Link Failover 
parent 
depends on 
…

Failover 
parent is 
online if …

If failover child 
faults …

If failover 
parent faults …

local soft Failover child 
online on the 
same system.

Child must be 
online in order 
to online the 
parent. Once 
the parent is 
online, child 
group can 
migrate

Parent stays online.

If child cannot fail 
over, parent remains 
online.

Child stays 
online.

local firm Failover child 
online on the 
same system.

Child is online 
on the same 
system.

Parent taken offline.

If child fails over to 
another system, 
parent migrates to 
the same system.

If child cannot fail 
over, parent remains 
offline.

Child stays 
online.
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local hard Failover child 
online on the 
same system.

Child is online 
on the same 
system.

Parents taken offline 
before the child is 
taken offline.

If child fails over to 
another system, 
parent migrates to 
another system.

If child cannot fail 
over, parent remains 
offline.

Child taken 
offline. 

If child fails over, 
parent migrates 
to the same 
system.

If child cannot 
fail over, parent 
remains offline.

global soft Failover child 
online 
somewhere in 
the VCS One 
cluster.

Child is online 
somewhere in 
the VCS One 
cluster.

Parent stays online.

If child fails over to 
another system, 
parent remains 
online.

If child cannot fail 
over, parent remains 
online.

Child stays 
online.

Parent fails over 
to any available 
system.

If no system is 
available, parent 
remains offline.

global firm Failover child 
online 
somewhere in 
the VCS One 
cluster.

Child is online 
somewhere in 
the VCS One 
cluster.

Parent taken offline 
before the child is 
offline. 

If child fails over to 
another system, 
parent is brought 
online on any 
system.

If child cannot fail 
over, parent remains 
offline.

Child stays 
online.

Parent fails over 
to any available 
system.

If no system is 
available, parent 
remains offline.

Table 13-6 Failover parent/Failover child

Link Failover 
parent 
depends on 
…

Failover 
parent is 
online if …

If failover child 
faults …

If failover 
parent faults …
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global hard Failover child 
online 
somewhere in 
the VCS One 
cluster.

Child is online 
somewhere in 
the VCS One 
cluster.

Parents taken offline 
before the child is 
taken offline.

If child fails over to 
another system, 
parent is brought 
online on any 
system.

If child cannot fail 
over, parent remains 
offline.

Child taken 
offline. 

If child fails over, 
parent migrates 
to another 
system.

If child cannot 
fail over, parent 
remains offline.

Table 13-6 Failover parent/Failover child

Link Failover 
parent 
depends on 
…

Failover 
parent is 
online if …

If failover child 
faults …

If failover 
parent faults …
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Failover parent / Parallel child
Table 13-7 depicts the failover behavior for a failover parent and a parallel child.

Table 13-7 Failover parent/Parallel child

Link Failover 
parent 
depends on 
…

Failover 
parent is 
online if …

If parallel child 
faults on a system 
…

If failover parent 
faults …

local soft Instance of 
parallel child 
service group 
on the same 
system.

Child 
instance 
must be 
online to 
online the 
parent 
group.

Parent does not 
failover.

Parent fails over to 
another system and 
depends on the child 
instance there.

Child instance 
remains online 
where the parent 
faulted.

local firm Instance of 
parallel child 
service group 
on the same 
system.

Instance is 
online on 
same 
system.

Parent fails over to 
another system and 
depends on the child 
instance there.

Parent fails over to 
another system and 
depends on the child 
instance there.

Child instance 
remains online 
where the parent 
faulted.

global soft All online 
instances of 
parallel child 
service group 
remaining 
online.

One or more 
instances of 
the child 
service 
group are 
online 
somewhere 
in the VCS 
One cluster.

Parent remains 
online if child faults 
on any system.

Parent fails over to 
another system, 
maintaining 
dependence with all 
child instances.
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global firm All online 
instances of 
parallel child 
service group 
remaining 
online.

One or more 
instances of 
the child 
service 
group are 
online 
somewhere 
in the VCS 
One cluster.

Parent remains 
online if there are 
other instances of 
parallel child that 
are online.

Parent is brought 
offline if no 
instances of child are 
online. 

Parent fails over if 
child fails over to 
any system.

Parent fails over to 
another system, 
maintaining 
dependency with all 
child instances.

Table 13-7 Failover parent/Parallel child

Link Failover 
parent 
depends on 
…

Failover 
parent is 
online if …

If parallel child 
faults on a system 
…

If failover parent 
faults …
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Parallel parent / Failover child
Table 13-8 depicts the failover behavior for a parallel parent and a failover child.

Table 13-8 Parallel parent/Failover child

Link Parallel 
parent 
instances 
depend on 
…

Parallel 
parent 
instances 
are Online 
if …

If failover child 
faults on a system 
…

If parallel parent 
faults …

global soft Failover child 
service group 
somewhere in 
the VCS One 
cluster.

Failover 
child must 
be online 
somewhere 
in the VCS 
One cluster 
to online the 
parent 
group.

Parent remains 
online if child faults 
on any system.

If faulted child fails 
over to another 
system, parent 
remains online.

If child cannot fail 
over to another 
system, parent 
remains online.

Child stays online.

global firm Failover child 
service group 
somewhere in 
the VCS One 
cluster.

Failover 
child is 
online 
somewhere 
in the VCS 
One cluster.

All instances of the 
parent are brought 
offline.

If child fails over 
then all instances of 
the parent are 
brought online.

 Child stays online.
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Parallel parent / Parallel child
Table 13-9 depicts the failover behavior for a parallel parent and a parallel child.

Table 13-9 Parallel parent/Parallel child

Link Parallel 
parent 
depends on 
…

Parallel 
parent is 
online if …

If parallel child 
faults …

If parallel parent 
faults …

local soft Parallel child 
instance 
online on the 
same system.

Child must 
be online to 
online the 
parent.

If child cannot fail 
over, parent remains 
online.

Child instance stays 
online.

Parent instance can 
fail over only to a 
system where the 
child instance is 
running and another 
parent instance is 
not running.

local firm Parallel child 
instance 
online on the 
same system.

Parallel 
child 
instance is 
online on 
same 
system.

Parent taken offline.

If child fails over to 
another system, VCS 
One brings an 
instance of the 
parent online on the 
same system as 
child.

If child cannot fail 
over, parent remains 
offline.

Child stays online.

Parent instance can 
fail over only to a 
system where the 
child instance is 
running and another 
parent instance is 
not running.
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Design rules of composite service groups 
The following design rules apply to composite service groups:

■ A composite service group contains one or more service groups and 
VFrames.

A composite service group may not contain a composite service group.

■ A group may only be part of one composite service group.

■ The service groups contained in a composite service group may or may not 
have dependencies between them.

■ A service group in a composite service group may have a dependency on a 
service group in a different composite service group.

■ If this dependency exists, and disaster recovery is setup for both CSGs, 
then both CSGs must fail over to the DR location at the same time.

■ If this dependency exists, and DR is setup of one CSG but not the other, 
then cross-site failover will not occur.

■ Composite service groups and service groups can not have any dependency 
relationship.

local hard Parallel child 
instance 
online on the 
same system.

Parallel 
child 
instance is 
online on 
the same 
system.

Parent instance 
taken offline before 
the child is taken 
offline.

If child instance fails 
over to another 
system, VCS One 
brings an instance of 
the parent online on 
the same system as 
the child.

If child cannot fail 
over, parent remains 
offline.

Child taken offline. 

If child fails over, 
parent migrates to 
the same system.

If child cannot fail 
over, parent remains 
offline.

Table 13-9 Parallel parent/Parallel child

Link Parallel 
parent 
depends on 
…

Parallel 
parent is 
online if …

If parallel child 
faults …

If parallel parent 
faults …
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A service group can not have a dependency on a composite service group, 
and a composite service group can not have a dependency on a service 
group.

Figure 13-2 displays valid composite service group design.

Figure 13-2 Valid composite service group design
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Designing service groups that use off-host 
resources

Off-host resource design considers whether or not your service group uses local 
resources.

About off-host resources in service groups
VCS One enables you to create local and off-host resources. 

A local resource satisfies the following conditions: 

■ The resource, the agent that monitors the resource, and the respective 
service group reside on the same physical or local system. The resource is 
controlled (brought online, taken offline, and monitored) on the same 
system where the service group is brought online or configured. 

■ The resource’s ControlGroup attribute value is empty. 

An off-host resource satisfies the following conditions: 

■ The resource and its respective service group reside on the local system, but 
the agent that monitors it is located on a remote or control system. The 
resource is controlled (brought online, taken offline, and monitored) from a 
different system (where the control group is online), and not the system on 
which its service group is brought online or configured. 

■ The resource’s ControlGroup attribute value is set to the name of the control 
group located on a remote system. 

■ Only a resource of type NetAppExport can be configured as an off-host 
resource.

In other words, an off-host resource is a resource that is defined and located on 
the local system but is monitored and operated from a remote system. 

The remote system that hosts the agent, which monitors the off-host resource is 
called the control system. The control system also hosts a service group called 
the control group, which primarily consists of the agent that monitor the off-
host resource. The control group can only be a FailOver service group and can be 
online or partially online on one control system at a time. 

A local resource is converted into an off-host resource by setting its 
ControlGroup attribute value to the control group name, which is located on the 
control system. If the ControlGroup attribute value is empty, the resource is a 
local resource. 

Off-host resources enable resource sharing and at the same time restricts local 
users from gaining administrative access on the remote system, which monitors 
the off-host resource. 
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How off-host resources work
Figure 13-3 depicts the off-host resource architecture.

Figure 13-3 Off-host resource architecture

As illustrated in the figure, the off-host resource is part of a local service group, 
which resides on the local system. The local service group, in addition to the off-
host resource can contain other local resources. 

The control or remote system hosts the control group. The control group 
contains an off-host definition resource. The resource type of the off-host 
definition resource must be the same as the off-host resource. The ControlMode 
attribute of the off-host definition resource must be set to 1. You do not need to 
specify any other required attributes. After setting the ControlMode attribute, 
you must enable the off-host definition resource. Note that it is mandatory to 
first set the ControlMode attribute and then enable the resource. 

The sole purpose of the off-host definition resource is to start the respective 
agent on the control system. The off-host resource reference is a hidden 
resource name with the resource_name@system_name format. resource_name is 
the fully qualified resource name, which also includes the group name in the 
group.resource format. It is used by the agents on the control system to monitor 
the respective off-host resources. 

You can not delete the off-host definition resource if it is the last resource type 
in the control group. This is because at least one off-host definition resource is 
required to keep the agent running.
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On the local system, the off-host resource’s ControlGroup attribute value is set 
to control group name that resides on the control system. All online, offline, and 
monitor commands issued by users, on the local system, are performed by the 
agent located on the control system. The off-host resource’s ControlMode 
attribute must be set to 0, all the required resource attributes should be 
specified, and it must be enabled. 

If the control group faults, the local service group does not failover, and the off-
host resource status is displayed as UNKNOWN. If the control system faults, the 
status of the off-host resource in the local service group is displayed as either 
SYSTEM FAULT, AGENT FAULT, NETWORK DISCONNECTED, or DDNA. 

The local service group and the control group can be failed over or switched to 
another system, similar to regular service groups. The off-host resource 
displays the same behavior in the VCS One Simulator.

The online, offline, and probe operations cannot be performed on the off-host 
resource if the control group is not online on any system. Similarly, the online 
and offline operations cannot be performed on the local service group if the 
control group is not online on any system. In the event of a control group 
concurrency violation, take the control group offline on all nodes and bring the 
control group online or partially online on only one node.

More information is available about how to create an off-host resource. 

See “Creating an off-host resource in a service group” on page 398.

Counting off-host resources managed by an agent 
The agent on the control system monitors the off-host resources when the 
control group is either in the ONLINE or PARTIAL state. The agent monitors the 
off-host resource on each system, which is listed in the SystemList of the service 
group, for which the off-host resource is configured. 

If multiple service groups have off-host resources of the same resource type, 
and each off-host resource specifies the same control group, the number of off-
host resources monitored by the agent is equal to the total number of systems 
listed in the SystemList of all the service groups. 

For example, consider the off-host resources R1, R2, and R3, which are of the 
same resource type, and belong to the service groups SG1, SG2, and SG3 
respectively. Each of these service groups have five systems listed in their 
SystemList. If all the off-host resources that belong to these service groups 
specify the same control group, the total number of off-host resources managed 
by the agent is 15 (5 + 5 + 5). 

In other words, the agent monitors all the off-host resources on all the systems, 
which are listed in the SystemList attribute of all the service groups. 
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Optimizing the off-host resource setup 
The number of off-host resources monitored by an agent is directly proportional 
to the number of systems, which are listed in the SystemList of the service 
groups, for which off-host resources are configured. In large VCS One cluster 
environments, the number of off-host resources that are managed by a single 
agent can be large. 

Hence, it is imperative that you perform the following tasks to ensure optimum 
resource utilization: 

■ Calculate the actual and projected number of off-host resources that a single 
agent manages. 

See “Counting off-host resources managed by an agent” on page 299.

■ Select a system with adequate capability and resources. 

The control system must be able to provide sufficient CPU and memory 
resources, for the agent, to effectively manage a large number of off-host 
resources. 

■ Set the value of the NumThreads attribute for the off-host resource.

The NumThreads attribute specifies the number of threads that an agent 
can create and use to schedule the agent entry points. Specify a large value 
if the agent monitors a large number of off-host resources. This ensures 
that more worker threads are available to schedule the agent entry points.

More information is available about the NumThreads attribute. 

See “Resource type attributes” on page 859. 

It is recommended that an agent must not manage more than 600 
resources. This number is deduced based on the maximum permissible 
NumThreads value, which is 30. This translates into each worker thread 
managing not more than 20 resources.

Note that the value for NumThreads must be set as per the available system 
resources (CPU, memory) on the system that hosts the control group. The 
optimal configuration for the NumThreads attribute and the number of off-
host resources that use the same control group, differ on each system, and 
must be set appropriately. 

Using multiple control groups to improve scalability
In order to maximize system resources, it is recommended that off-host 
resources must be split across multiple control groups. This facilitates better 
off-host resource load management and distributes the off-host resources 
across multiple systems. Consequently, agent responsiveness is also improved. 
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Off-host resources: user privileges
In order to perform various operations on the off-host resource, you require the 
following privileges: 

■ You require Read and Modify privileges on the service group in order to 
assign or unassign the service group as a control group for an off-host 
resource. 

■ You require Modify privileges on the control group, to modify an off-host 
resource, after a valid ControlGroup value is specified. 

■ You do not need to have any privileges on the control group to delete an off-
host resource from a local service group. However, you require appropriate 
Delete privileges on the local service group to delete an off-host resource 
from a local service group. 

■ You require Online, Offline, and Probe privileges on the local service group 
in order to perform operations on an off-host resource.

Designing service groups that run in Solaris zones
Solaris zones provide multiple independent isolated environments for running 
applications in the same Solaris instance. Zones provides resource management, 
fault isolation, and security isolation.

Overview of how VCS One works with zones
VCS One provides application management and high availability to applications 
running in zones by extending its management and failover capability to zones.

Configuration options for using zones with VCS One include the following:

■ Manage a local zone, including start, stop, monitor, and failover.

■ Manage an application running inside a zone. 

The Solaris zone must be installed and configured before it can be brought 
under VCS One control.

Create the service group with the standard managed application resource types 
(Application, Storage, Networking) with the addition of a Zone resource. 
Configure the service group’s ContainerInfo attribute, and each resource’s 
ContainerOpts attribute.

The VCS One client daemon, vcsoneclientd, and the necessary agents run in the 
global zone. Agents may execute commands in both the global and the local 
zones. For applications running within zones, agents run entry points inside the 
zones. 
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VCS One runs in a secure environment using Symantec Product Authentication 
Service, therefore communication from non-global zones to global zones is 
secure.

See the Veritas Cluster Server One Bundled Agents Reference Guide and 
Enterprise agent guides for more information on agents that are zone-aware 
and support applications running in non-global zones.

Designing attributes values for zone support
The service group level attribute ContainerInfo specifies information about the 
zone. VCS One defines this information at the service group level to avoid each 
resource in the service group having to define it at the resource level.

The ContainerInfo attribute has the following keys:

■ Name

The name of the zone. Indicates to the resources in the group the name of 
the zone to act upon.

■ Type

Type = Zone for a Solaris zone.

Type = WPAR for an AIX Workload Partition.

The XRM option is not supported.

■ Enabled

Enabled = 1 enables the zone. 

Enabled = 0 disables the zone. 

The resource level attribute ContainerOpts specifies information that can be 
passed to the agent controlling the resources. These values are only effective if 
the ContainerInfo:Enabled attribute enables the zone.

■ RunInContainer

RunInContainer = 1 specifies the resource will run in the local zone.

RunInContainer = 0 specifies the resource runs in the global zone.

■ PassCInfo 

PassCInfo = 1 specifies to pass the container information, defined in the 
service group’s ContainerInfo attribute, to the resource. An example use of 
this value would be to pass the agent the name of the zone to act upon.

PassCInfo = 0 specifies to not pass the container information to the 
resource.

■ PassLoadInfo 

The service group’s Load attribute sets values that indicate the amount of 
system resources the service group requires.
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PassLoadInfo = 1 specifies to pass the service group’s Load values to the 
resource. Use this value to pass the Load values to the Zone agent, which 
will use the values to set the resources available in Solaris Resource 
Manager.

Note: Load values must be set or changed when service group is in the 
OFFLINE state for a zone-enabled service group. Specifically, you may not use 
the hagrp -changeload command unless the zone-enabled service group is 
in the OFFLINE state. 

PassLoadInfo = 0 specifies to not pass the service groups load dimensions to 
the resource. 

Table 13-10 displays the agents available in zones and the associated default 
attribute values that are set for each application and resource type. 

Each resource type also contains the WorkLoad attribute, which is a non-static 
attribute. The value for this attribute is populated from the service group's Load 
attribute, when the resource’s ContainerOpts: PassLoadInfo key is set to 1.

Designing resource dependencies
The following diagrams illustrates different examples of resource dependencies.

Figure 13-4 depicts the dependency diagram when the zone root is set up on 
local storage with the loop back file system.

Table 13-10 Zones capable agents and associated default attribute values

Resource Type RunInContainer PassCInfo PassLoadInfo

Application 1 0 0

Mount 1 0 0

IP 0 1 0

IPMultiNICB 0 1 0

Process 1 0 0

Zone 0 1 1

Oracle 1 0 0

Netlsnr 1 0 0
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Figure 13-4 Zone root on local disks with loop back file system

Figure 13-5 depicts the dependency diagram for a zone root on is set up on local 
storage with the direct mount file system.

Figure 13-5 Zone root on local disks with direct mount file system

Figure 13-6 depicts the dependency diagram for a zone root is set up on shared 
storage with the loop back file system.
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Figure 13-6 Zone root on shared disks with loop back file system

Figure 13-7 depicts the dependency diagram for a zone root is set up on shared 
storage with the direct mount file system.

Figure 13-7 Zone root on shared disks with direct mounted file system

Use the following principles when you create the service group: 

■ Set the MountPoint attribute of the Mount resource to the mount path.

■ If the application requires an IP address, configure the IP resource in the 
service group. 

■ If the zone root file system is on shared storage, you can configure separate 
mounts for the zone and the application (as shown in the illustration), but 
you can configure the same disk group for both.

Application

IP

Zone

Mount

DiskGroup

NIC

Mount

DiskGroup

Mount

DiskGroup

Application

IP

Zone

Mount

NIC

DiskGroup



306 Designing service groups
Designing service groups that run in AIX WPARs
Designing service groups that run in AIX WPARs
An AIX workload partition (WPAR) is a virtualized operating system 
environment within an instance of the AIX operating system. AIX WPARs 
provide an isolated and secure environment for running applications. 

VCS One provides application management and high availability to applications 
running in WPARs. 

See “About managing service groups in AIX Workload Partitions” on page 566.

Note: VCS One provides support for system WPARs. VCS One does not provide 
support for application WPARs.

Overview of how VCS One works with WPARs
Configuration options for using WPARs with VCS One include the following:

■ Manage a WPAR, including start, stop, monitor, and failover.

■ Manage an application running inside a WPAR. 

If a WPAR faults, VCS One fails over the entire service group that contains the 
WPAR to another system.

While applications may run in a WPAR, system resources are managed only at 
the global partition level. These system resources included CPUs, I/O, and 
adapters. The VCS One client daemon, vcsoneclientd, and the necessary agents 
run in the global partition. 

VCS One runs in a secure environment using Symantec Product Authentication 
Service, therefore communication from the global partition to the WPAR is 
secure.

See the Veritas Cluster Server One Bundled Agents Reference Guide and VCS One 
Enterprise agent guides for more information on agents that are WPAR-aware 
and support applications inside WPARs.

About the WPAR agent
The WPAR agent monitors WPARs, brings WPARs online, and takes them 
offline. For more information about the agent, see the Veritas Cluster Server 
Bundled Agents Reference Guide.
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Designing attributes values for WPAR support
The service group level attribute ContainerInfo specifies information about the 
WPAR. VCS One defines this information at the service group level to avoid each 
resource in the service group having to define it at the resource level.

The ContainerInfo attribute has the following keys:

■ Name

The name of the WPAR where you want the application to run. Indicates to 
the resources in the group the name of the WPAR to act upon.

■ Type

Type = WPAR runs the application in the AIX WPAR specified in the Name 
key.

■ Enabled

■ Enabled = 1 

Enables the WPAR resource. 

■ Enabled = 0 

Disables the WPAR resource. 

The resource level attribute ContainerOpts specifies information that can be 
passed to the agent controlling the resources. These values are only effective if 
the ContainerInfo:Enabled attribute enables the WPAR.

■ RunInContainer

RunInContainer = 1 specifies the resource will run in the WPAR.

RunInContainer = 0 specifies the resource runs in the global partition.

■ PassCInfo 

PassCInfo = 1 specifies to pass the container information, defined in the 
service group’s ContainerInfo attribute, to the resource. An example use of 
this value would be to pass the agent the name of the WPAR to act upon.

PassCInfo = 0 specifies to not pass the container information to the 
resource.

■ PassLoadInfo 

PassLoadInfo = 0. This key is not used with WPAR technology.
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Designing resource dependencies for WPAR-enabled service groups
The following diagrams illustrates different examples of resource dependencies. 
In one case the WPAR root is set up on local storage. In the other, WPAR root is 
set up on shared storage.

Resource dependency diagrams: WPAR root on local disks

Figure 13-8 WPAR root on local disks (with direct mount file system)

Figure 13-9 WPAR root on local disks (file system mounted from inside WPAR)
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Resource dependency diagrams: WPAR root on shared 
storage

Figure 13-10 WPAR root on shared storage (with namefs file system)
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Chapter
 14
Designing application and 
virtual machine placement 
policy

This chapter includes the following topics:

■ About designing application and virtual machine placement policy

■ About application and virtual machine placement configurations

■ Start and stop configurations

■ Manual application switch configuration

■ About automated failover configurations

■ About Priority

■ About disruption factor and kickout

■ Application relationships through service group compatibility

■ About service group Load and system Capacity for physical systems

■ About Load and Capacity values with VFrame and PFrame objects

■ About guaranteed resource reservations in virtualization environments

■ Breaking the tie: the FragmentationPolicy attribute

■ Mapping an application placement decision
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About designing application and virtual machine 
placement policy

You can configure attributes to control where a managed application or a virtual 
machine runs.

You can use the VCS One Simulator to test and simulate where an application or 
virtual machine runs given certain circumstances and configurations. 

See “About the Simulator” on page 204.

If you configure a managed application or a virtual machine to be able to move 
between systems, the movement can be controlled in the following ways. 

■ Operator-initiated process

An operator or administrator can perform the move. 

■ VCS One-initiated process

The Policy Master initiates the process automatically. The Policy Master 
determines and executes the plan without administrative interaction. 

The more attributes that are configured, the more sophisticated the control of 
where the application runs. 

See “Designing actions taken after a fault” on page 259.

See “About automated failover configurations” on page 315.

Service group and VFrame dependencies are considered when the Policy Master 
determines where a service group or VFrame runs.

See “Design rules of service group and VFrame dependencies” on page 284.

About application and virtual machine placement 
configurations

The following use cases describe possible configurations for service groups and 
virtual machines:

■ A service group running on a physical system. 

The service group can have one or more systems in its SystemList attribute. 
The SystemList attribute defines the systems in the VCS One cluster on 
which the service group can potentially come online.

■ A virtual machine running on a physical system.

In the VCS One configuration, the virtual machine is a black box VFrame 
running on a PFrame. The VFrame can have one or more PFrames in its 
PFrameList attribute.

■ A service group configured to run on a virtual machine.
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Start and stop configurations
In the VCS One configuration, the service group runs on a system object 
that is linked to a VFrame. Whether or not VMHA policy is enabled 
determines fault policy.

You can individually configure a managed application on a virtual machine in 
the VCS One cluster to run in the most appropriate configuration for your 
environment, such as the following:

■ Start and stop configurations

The application runs on one system, or the virtual machine runs on one 
PFrame.

■ Manual switch configurations

Multiple systems may host an application or virtual machine.

■ Advanced highly-available configurations. 

In these configurations multiple systems may host an application or virtual 
machine and multiple criteria are dynamically considered when choosing a 
failover target. 

Start and stop configurations
Basic application management uses VCS One to start, stop, and monitor 
applications or virtual machines, but does not enact switch or failover actions 
between systems.

In this configuration, most often you do not need to define application 
management-related attributes such as Load, Priority, Compatibility, or 
FragmentationPolicy. These attributes may remain at their default values.

One exception would be when using resource reservations.

In the start and stop configuration, you can apply the following design:

■ A service group running on a physical system. 

Configure the service group to have only one system in its SystemList 
attribute. 

■ A virtual machine running on a physical system.

In the VCS One configuration, the virtual machine is a black box VFrame 
running on a PFrame. Configure the VFrame to have only one PFrames in its 
PFrameList attribute.

■ A service group configured to run inside a virtual machine.

In the VCS One configuration, the service group runs on a system object 
that is linked to a VFrame. For the start and stop configuration, disable 
VMHA policy.
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Manual application switch configuration
Configure the group level attribute PropagateFaultPolicy to determine the 
restart policy of service groups and virtual machines.

See “Service group level control after a fault” on page 262.

Manual application switch configuration
This configuration is similar to start and stop management, with the addition of 
switchover capability. A switch is an administrator-initiated movement of the 
object for maintenance or availability purposes.

In the switch configuration, you can apply the following design:

■ A service group running on a physical system. 

Configure the service group’s SystemList attribute to contain all the 
systems on which the service group can potentially come online. During 
startup, a service group will attempt to come online on each system in the 
order they are listed in the SystemList. 

Additionally, the service group GrpFaultPolicy and NodeFaultPolicy 
attributes should be set to NoFailover. This allows an operator-initiated 
switch instead of a VCS One-initiated failover.

■ A virtual machine running on a physical system.

In the VCS One configuration, the virtual machine is a black box VFrame 
running on a PFrame. Configure the VFrame’s PFrameList attribute to 
contain all the PFrames on which the VFrame can run. During startup, a 
virtual machine will attempt to come online on each PFrame in the order 
they are listed in the PFrameList.

Additionally, the VFrame’s VFrameFaultPolicy and NodeFaultPolicy

attributes should be set to NoFailover. This allows an operator-initiated

switch instead of a VCS One-initiated failover.

■ A service group configured to run inside a virtual machine.

In the VCS One configuration, the service group runs on a system object 
that is linked to a VFrame. Whether or not VMHA policy is enabled 
determines fault policy.

■ If VMHA policy is disabled, the policy acts the same as if the service 
group runs on a physical system.

■ If VMHA policy is enabled, the service group must only have one 
system in it’s SystemList. Perform the switch operation on the VFrame. 
The VFrame and the service group switch together.

Advanced management configurations options, such as Load and Capacity, can 
also be configured with a manual switch configurations.
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About automated failover configurations
The most simple of the highly-available configurations has multiple systems 
listed in the SystemList. In this configuration, you can configure a service group 
that faults to attempt to come online on a system without manual intervention. 
The service group GrpFaultPolicy attribute default value of Failover is 
appropriate for this configuration. 

Use the VFrameFaultPolicy attribute to configure this same behavior for virtual 
machines.

For a service group running on a VFrame, the service group fault can be 
propagated to VFrame using the PropagateFaultPolicy attribute.

See “About designing the actions taken after a fault” on page 260.

More advanced management configurations use one or more components of 
VCS One’s Advanced Workload Management (AWM) feature to determine on 
which system a service group or a virtual machine will come online.

AWM is an integrated policy-based mechanism that automates placement both 
when a group or virtual machine is brought online, and in the event of a failover 
in response to a resource, group, system, VFrame, or PFrame fault. AWM’s core 
functionality is to make the best effort to keep high priority applications up and 
running.

You may also configure the following attributes to control where a service group 
or virtual machine may run.

 

SystemList The list of systems the application is approved to run on.

ResFaultPolicy The fault policy of the resources in the service group.

GrpFaultPolicy The fault policy of the service group, if the service group fails.

VFrameFaultPolicy The fault policy of the VFrame, if the VFrame fails.

NodeFaultPolicy The fault policy of the service group or VFrame, if the system fails.

PropagateFaultPolicy Determines whether or not the fault of a service group that runs 
on a virtual machine is propagated to the virtual machine.

Load, Capacity The amount of system resources the application requires with 
respect to the amount of resources available on a given system.

CompatibleGroups, 
IncompatibleGroups

The compatibility or incompatibility of the application with 
respect to other managed applications.

Compatible VFrames, 
Incompatible VFrames

The compatibility or incompatibility of the VFrame with respect to 
other managed VFrames.
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About Priority
The following factors contribute to AWM application placement decisions:

■ The priority of the service group or virtual machine and the related level of 
disruption it will cause if it is failed over.

■ The compatibility of the application’s service group with other service 
groups.

■ The load of the service group or virtual machine in relation to the capacity, 
or available resources, defined on the physical system.

■ The value of the cluster’s FragmentationPolicy attribute, if set to 
BiggestAvailable or BestFit.

■ Any relevant local service group dependencies that are defined, if the value 
of the FragmentationPolicy attribute is set to Heuristic.

At the highest level, the AWM algorithm will choose the target system for the 
service group that has the following elements:

■ Enough value in the capacity-related attributes to support the values needed 
for the service group’s load-related attributes.

■ The least disruption factor.

■ No incompatible service groups that have equal or higher priority.

If the elements are equal, the value of the cluster level attribute, 
FragmentationPolicy, will determine the target system.

If the FragmentationPolicy attribute does not determine a unique system, the 
target system will be the first system listed in the SystemList that meets all the 
requirements.

About Priority
The Priority attribute enables you to ensure the most important service groups 
and virtual machines have the greatest opportunity to remain online in the VCS 
One cluster. 

Each service group and virtual machine has an assigned Priority value.

Priority The priority of the application as compared to other managed 
applications. Equivalently, the priority of a black box VFrame as 
compared to other black box VFrames.
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About Priority
The Priority value is set in the following manner:

There are five levels of priority. The highest priority value is 1. The default 
priority value is the lowest priority value, which is 5.

Higher priority objects can be configured to take over the resources used by 
lower priority objects. Failure to define different levels of priority will result in 
every object of that type having equal access to VCS One cluster resources.

Table 14-11 shows the possible values for the Priority attribute and the 
associated disruption values.

Service group Set by an administrator that has appropriate permissions. Priority 
value should be set to reflect the level of importance of that group 
relative to other groups in the VCS One cluster.

VFrame linked 
to a system object 
with VMHA enabled

Automatically set by the Policy Master. Set to the maximum priority 
value among all the groups that are configured to run on the system 
object associated with the VFrame.

VFrame linked 
to a system object 
with VMHA disabled

Set by the administrator with appropriate permissions. Priority 
value should be set to reflect the level of importance of that virtual 
machine relative to other virtual machines in the VCS One cluster.

If VMHA is subsequently enabled, the Priority value may change.

VFrame not linked 
to a system object 
(Black box VFrame)

Set by the administrator with appropriate permissions. Priority 
value should be set to reflect the level of importance of that virtual 
machine relative to other virtual machines in the VCS One cluster. 

If a VFrame that is not linked to a system object is subsequently 
linked to a system object, the Priority value may change.

Table 14-11 Priority levels and associated disruption values

Priority level Disruption value

Priority = 1
(highest priority)

No value, service group can not 
be kicked out

Priority = 2 1000

Priority = 3 100

Priority = 4 10

Priority = 5 (default) 1
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About disruption factor and kickout
Lower priority groups or virtual machines (VFrames) may be taken offline or 
switched to make room for higher priority objects. Taking lower priority objects 
offline or switching them is referred to as kickout. Each service group and 
VFrame has an associated disruption value based on its priority level. The 
Disruption Factor (DF) for a system is the sum of the disruption values of all 
objects that will be kicked out in order to make room for higher priority service 
groups. 

The system that can host the object and has the lowest disruption factor will be 
chosen as the target for bringing the object online. If equal candidate systems 
have identical disruption factors, the system is chosen based on the value of the 
cluster-level attribute FragmentationPolicy.

See “About service group Load and system Capacity for physical systems” on 
page 320.

See “Breaking the tie: the FragmentationPolicy attribute” on page 325.

Equal priority service groups will never kickout one another. For a kickout to 
occur, one service group must be of higher priority. Service groups that have the 
highest priority, 1, can never be kicked out.

With respect to disruption factor and kickout, virtual machines conform to the 
same rules as service groups.

Application relationships through service group 
compatibility

Application relationships refer to the compatibility or incompatibility of two 
applications online on the same system at the same time. You can configure one 
of the following relationships between two service groups:

■ Compatible — two applications can be online on the same system at the 
same time.

■ Incompatible — two applications can not be online on the same system at 
the same time.

The service group level attribute CompatibleGroups can be defined to list the 
service groups that can co-exist with a particular group. Similarly, the attribute 
IncompatibleGroups can be defined to list the service groups that cannot co-
exist with a particular service group. Only one of these two attributes can be 
defined for a group.

The following service group compatibility examples are valid:
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■ Compatible with all other service groups in the VCS One cluster, including 
those that will be added in the future (default):

CompatibleGroups = {ALLGROUPS}

■ Not compatible with any other service groups in the VCS One cluster, and 
will not be compatible with service groups added in the future:

IncompatibleGroups = {ALLGROUPS}

■ Compatible with the service groups named G2 and G3, and incompatible 
with all other groups, including any groups added in the future:

CompatibleGroups = {G2, G3}

■ Not compatible with the service groups named G2 and G3, but compatible 
with all other groups, including any groups added to in the future:

IncompatibleGroups = {G2, G3}

The following service group compatibility examples are invalid:

■ The ALLGROUPS value should not be defined with any other group name.

CompatibleGroups = {ALLGROUPS, G2}

■ CompatibleGroups and IncompatibleGroups are mutually exclusive 
attributes. Both can not be set for a particular service group. The following 
definition will give an error when loading the configuration:

CompatibleGroups = {G2, G3}

IncompatibleGroups = {G4, G5}

In an environment that has four service groups, named G1, G2, G3, and G4, the 
following two examples are not equal in the definition of service group G1:

CompatibleGroups = {G2}

IncompatibleGroups = {G3, G4}

The first definition indicates that G1 is compatible only with G2; the second 
definition means that G1 is compatible with G2 and all future groups.

Take the following considerations into account when planning service group 
compatibility definitions:

■ Service groups named in the definition must already exist in the VCS One 
cluster, and cannot include the name of the service group being defined (can 
not self-reference.)

■ All service groups that share a local group dependency must be compatible 
with each other as well as compatible or incompatible with the same set of 
groups.

■ Consistent compatibility definitions across all service groups in the VCS One 
cluster are verified and enforced.
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For example, if a modification to the compatibility of a group in a local 
service group dependency is made, the Policy Master ensures that all 
service groups in the dependency tree are changed accordingly.

■ When changing the value of CompatibleGroups or IncompatibleGroups:

■ The service groups must not be in transition, it must be completely 
online or completely offline.

■ Two service groups must be completely offline on a system before they 
can be defined to be incompatible.

■ Empty brackets in the definition imply an ALLGROUPS value. The following 
two examples are equal:

CompatibleGroups = { }

CompatibleGroups = {ALLGROUPS}

About service group Load and system Capacity for 
physical systems

The Load and Capacity construct allows the administrator to define a fixed 
amount of resources a system provides (Capacity), and a fixed amount of 
resources a specific service group is expected to utilize (Load). 

The Load and Capacity construct is configured using the cluster attribute 
PrecedenceOrder, which enables definition of up to four prioritized keys, 
typically representing CPU, memory, network, and storage (I/O) resources. 

These attributes define both Load and Capacity, and the two values are always 
considered in tandem. When a service group is started on a system, the values 
attributed to the Load of the service group are subtracted from the values 
attributed to the Capacity of the system that the service group is placed on. 

If a service group has no Load related attributes values set, then the group can 
go online on any system for which it is configured, provided the compatibility 
criteria is met. If a service group has a Load configured, then it can only go 
online on a system that has a Capacity value defined and sufficient to 
accommodate the Load value.
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Defining Load and Capacity
The following keys are the default keys of the cluster attribute PrecedenceOrder:

The names and ranking of the four keys can be customized or eliminated. For 
example, using all four keys for PrecedenceOrder may look like the following 
example:

If the keys are customized, update the ResourceKeys attribute.

See “ResourceKeys” on page 829.

These keys define a relative ranking of Load and Capacity across the VCS One 
cluster. For example, if PrecedenceOrder is defined with two keys, CPU and 
MEM, values for the Capacity attribute for two systems in that VCS One cluster 
could be:

These values may indicate that sys1 has four processors, and sys2 has two 
processors, or they may indicate that sys1 has processors that are twice as fast 
as the sys2 processors. These settings could also indicate that sys1 has twice as 
much memory as sys2. As long as the values are consistently relative, the 
measurement remains normalized across the VCS One cluster.

Load and Capacity values are hard values, meaning the values are strictly 
enforced. The total of the Load values of the service groups online on a system 
can not exceed the systems’s Capacity value.

PrecedenceOrder CPU

MEM

STBW

NTBW

PrecedenceOrder CPU

MEMORY

STORAGE

NETBANDWIDTH

On sys1: Capacity CPU: 400

MEM: 200

On sys2: Capacity CPU: 200

MEM: 100
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The order of precedence of the four attributes affects the calculation of the 
target system to host a service group as well as the calculation of disruption 
factor. 

See “PrecedenceOrder” on page 827.

About Load and Capacity values with VFrame
and PFrame objects

PFrame objects have Capacity values that work in relationship to the Load 
values of VFrames to allow enforcement of your application placement policy.

See “About Load and Capacity” on page 55.

These values also work with the virtualization feature that guarantees 
reservation of CPU and memory resources.

See “Configuring guaranteed resource reservations for a VFrame” on page 514.

The following relationships exist:

PFrame The user sets the value of the PFrame Capacity attribute.

The Capacity of a PFrame is shared by all VFRames running within 
it. If there is not available capacity to run a VFrame, the VFrame 
will not start on that PFrame.

VFrame The value of the VFrame Load attribute is dependent on whether a 
system object is linked to the VFrame:

■ If a system object is linked to a VFrame, and VMHA policy is 
enabled for that system, the Load value of the VFrame is equal 
to the sum of the all the Load attributes of all the service 
groups that are configured to run on the VFrame.
All the service groups that are configured to run on the 
VFrame is equivalent to all the service groups that have this 
linked system in their SystemList attribute.
You may not have more than one system object linked to a 
VFrame.

■ If no system objects are linked to a VFrame, or if VMHA policy 
is disabled for the linked system, the Load value of the VFrame 
is set by the user. 

The Load value of the VFrame denotes the load that the VFrame 
exerts on the PFrame.
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About guaranteed resource reservations in 
virtualization environments

In virtualization environments, certain virtualization technologies allow you to 
configure the guaranteed reservation of CPU and memory resources for a virtual 
machines. Such technologies ensure that these resources are available to the 
virtual machines even when the physical server is under heavy load.

About resource reservations in VCS One 
VCS One can also reserve the CPU and memory resources available to virtual 
machine object in the VCS One cluster. 

See “Configuring guaranteed resource reservations for a VFrame” on page 514.

VCS One uses the following attributes to set up these reservations:

The Load value of the VFrame is subtracted from the 
AvailableCapacity value of the PFrame when the VFrame is 
running. The VFrame does not exert a load on the PFrame when the 
VFrame is not running.

System When VMHA policy is enabled, the Capacity of the linked system is 
always same as the Load of the linked VFrame.

When VMHA policy is disabled, the Capacity of the linked system 
can be manually set by the user. By default, the Capacity is set to 
zero.

EnableReservation The user sets this attribute to set the whether or not guaranteed 
reservations are configured for each VFrame VType.

See “EnableReservation” on page 823.

Capacity The user sets this attribute to indicate the Capacity value of the 
PFrame.

See “Capacity” on page 841.

Load The user sets this attribute to indicate the Load value of the 
service groups running inside the VFrame, or the Load value of the 
VFrame itself.

See “Load” on page 853.

PrecedenceOrder See “PrecedenceOrder” on page 827.

ResourceKeys See “ResourceKeys” on page 829.
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About guaranteed resource reservations in virtualization environments
The Policy Master determines the AWM fraction for the reservation based on 
the Load of the VFrame and the Capacity of the PFrame.

The actual reservation calculation is based on the AWM fraction, but is specific 
to each technology.

For VMware, the AWM fraction is multiplied by the Max resources available for 
the virtual machine reservations on the PFrame to get the actual reservation 
value. 

For Logical Domains, the AWM fraction is multiplied by the number of available 
VCPUs to get the actual reservation value. LDoms do not support VCPU fraction, 
so VCS One defaults to floor whole number. [If the AWM fraction is 2.3, VCS One 
reserves 2 VCPUs].

In all technologies, if the calculated actual value comes out to be greater than 
the maximum allowed for the VFrame, VCS One reserves the maximum allowed 
value. 

About operations when using guaranteed reservations
When using reservations, the VCS One operates as outlined in the following 
situations:

■ Bringing a vframe online

The online operation initiates only if all the reservations are successful. If 
any of the reservations fail, the online operation is aborted. 

Additionally, the VFrame for which the reservation failed is added to the 
PFrame’s FailedReservation attribute value.

Reservations would fail if there is not enough available Capacity in the 
PFrame.

In the case of a failover, the Policy Master attempts to bring the VFrame 
online on another Pframe in it's PframeList.

■ Modifying a SystemList

When adding a VMHA-enabled system to the SystemList of a service group, 
the operation completes only if all the reservations are successful. If any of 
the reservations fail, the SystemList modification is rejected.

■ Taking a VFrame offline

When a VFrame is brought offline, VCS One attempts to release the 
reservations for that VFrame. 

The following events initiate or recalculate the CPU and memory reservations 
for a VFrame:

DynamicReservation
Action

See “DynamicReservationAction” on page 824.
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■ Modify the Load of a service group

When modifying the Load of a service group that is configured on a 
VMHA-enabled linked system, the Policy Master updates the Load of the 
PrecedenceOrder keys for which the reservations were done successfully.

For example, if the user modifies both the cpu and the mem keys, the Policy 
Master initiates or recalculates reservations for both cpu and memory. 
However, if cpu reservations fail but memory reservation succeeds, only the 
memory Load values are updated.

■ Modify the Load of a black box VFrame

When modifying the Load of a black box VFrame, the Policy Master updates 
the Load of the PrecedenceOrder keys for which the reservations were done 
successfully.

■ Enable VMHA policy

When VMHA policies are enabled for a linked system, the Policy Master 
recalculates the reservations required for the VFrame and updates the Load 
value. 

■ Switch and migrate operations.

Breaking the tie: the FragmentationPolicy attribute
If two systems have an equivalent Disruption Factor, the best target system to 
run the service group or virtual machine is chosen based on the value set for the 
cluster wide attribute FragmentationPolicy. 

This attribute can have the following values:

■ BiggestAvailable — The system chosen is the one with the largest value for 
the first key in the PrecedenceOrder attribute, by default CPU, as defined in 
the Capacity attribute of the system.

For example, if the cluster attribute PrecedenceOrder is defined with two 
keys, named CPU and MEM, and three systems have the value of their 
Capacity attribute are as follows:

On sys1: Capacity CPU: 400

MEM: 300

On sys2: Capacity CPU: 200

MEM: 100

On sys3: Capacity CPU: 100

MEM: 100
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and the service group Load attribute is:

FragmentationPolicy set to BiggestAvailable would choose sys1 because it 
has the largest value for CPU.

■ BestFit — The system chosen is the one with the value for the first key of the 
PrecedenceOrder attribute that is at least equal to as well as closest to the 
value for the corresponding Load attribute of the service group or virtual 
machine. In the above example, FragmentationPolicy set to BestFit would 
choose sys2, because the CPU value of 200 in the Load attribute of the 
service group is the closest match to the CPU value of 200 in the Capacity 
attribute of sys2.

■ Heuristic — The system chosen is based on whether or not the service group 
has a local service group dependency with another service group:

■ If it does not, then choose target system as if BestFit was set.

■ If it does, then choose target system as if BiggestAvailable was set.

The Heuristic option increases the chances for both the parent and 
child groups with a local service group dependency to meet the load 
requirements on the same system.

The default setting for the FragmentationPolicy attribute is BiggestAvailable.

Mapping an application placement decision 
The search for a system to host a service group or virtual machine can happen 
for the following reasons:

■ A service group or a virtual machine configured for failover faults.

■ A system faulted that was hosting a service group or a virtual machine 
configured for failover.

■ You issue a command to online a service group or virtual machine but do not 
indicate a specific system to target.

Fault policy determines if a service group or virtual machine will failover. More 
information on fault policy is available.

See “Designing actions taken after a fault” on page 259.

In any of these cases, the following high level steps occur. 

■ The object enters the Group Transition Queue (GTQ).

Load CPU: 200

MEM: 200
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■ Advanced Workload Management policy determines a plan for the best 
target system to run every object in the GTQ before it directs any actions to 
be taken. More than one object may be in the GTQ at the same time because:

■ An entire system went down and there were multiple objects that failed 
simultaneously.

■ An object was not able to be placed in the VCS One cluster, and is 
waiting for placement.

■ After the plan is finalized for all GTQ entries all objects are automatically 
brought online and taken offline according to the plan.

If entries remain in the GTQ because no eligible target systems are 
identified, these entries are designated as intent-online GTQ entries. The 
corresponding state for the service groups is OFFLINE.

■ Intent-online GTQ entries are re-evaluated to see if a target system can be 
identified when certain events occur:

See “Events that re-examine intent-online GTQ entries” on page 330.

About the Group Transition Queue
The Group Transition Queue (GTQ) is an internal structure that keeps track of 
planned online and offline actions for service groups and virtual machines, as 
well keeps track of which service groups and virtual machines are intended to be 
online in the VCS One cluster.

The Group Transition Queue is the heart of the AWM placement decision. You 
can perform actions on service groups inside the GTQ.

See “Stopping the current action for an object in the GTQ” on page 382.

See “Flushing the plan of action on all service groups in the GTQ” on page 381.

Note: For the purposes of GTQ decision logic, PFrame objects are treated the 
same as system objects and VFrame objects are treated the same as service 
group objects.

The GTQ is stored in the Policy Master configuration database and consists of 
the following items:

■ List of service groups that need to be brought online

■ Service group planned actions

■ Service group action dependencies

■ Service group action status
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Even though the terminology is that a service group enters the GTQ, a service 
group never actually moves to the GTQ, but rather an entry is made of an action 
planned on the service group.

Service groups are prioritized as they enter the Group Transition Queue, in the 
following order:

■ Priority attribute value with the higher priority value given precedency. 
Priority = 1 is placed ahead of Priority = 2.

■ Load attribute value with the smaller value given precedence.

■ If child-parent service group dependency exists between two service groups 
in a GTQ, the child is given precedence over the parent.

■ Time order of entry in the GTQ. Newer entries are added after existing 
entries, when everything else is equal.

Choosing the best target system for groups without dependencies
The best target system selection process for a service group without service 
group dependencies is as follows:

■ Consider a system in the service group’s SystemList attribute. A system 
must be present in the system list to be a valid failover target. A sample 
system list would be:
<SystemList>

<val key="SystemA">0</val>
<val key="SystemB">1</val>
<val key="SystemC">2</val>

</SystemList>

Each system in the system list is considered based on the 
FragmentationPolicy setting. 

■ Check if the system meets the basic criteria to run the service group. Basic 
criteria include the following:

■ The system is in a RUNNING state.

■ The system is not in the FROZEN state.

■ The service group is enabled on the system.

■ The service group is probed on the system.

■ Agents for the resources in the group have not failed on the system.

■ Another instance of the service group is not already running on the 
system.

■ All defined Capacity attribute values of the system meet or exceed the 
related Load attribute values of the service group.
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■ Check if the system is running any incompatible service groups that have 
equal or higher priority values. If so, eliminate the system from 
consideration and return to considering the next system in the system list.

■ Check if the system has adequate available resources on all defined system 
Capacity attribute values for the corresponding Load attribute values of the 
service group.

■ If a target system selection process is initiated due to a service group or 
system fault, this step determines if lower priority groups need to be 
kicked out either for compatibility conflicts or to make available 
system capacity resources to run a higher priority service group.

■ If a target system selection process is initiated due to a normal service 
group online operation, no service group kickout is considered. In this 
case, the only acceptable target system is one that provides adequate 
capacity and compatibility without kickout (DF=0).

The normal service group online operation can be changed to behave as 
if in response to a fault with the following command:
hagrp -online [-ejectlowpri] <group> -sys <system>

■ Calculate Disruption Factor of system.

■ Determine the current best target system.

■ Lowest disruption factor is always the determining factor for choice of 
best target system.

■ If the least disruption factor is 0, and more than one system offers a 0 
disruption factor, the system is selected based on the 
FragmentationPolicy attribute setting.

■ If least disruption factor is non-zero, and more than one system has the 
same least disruption factor, then the first system in the SystemList 
that has that disruption factor value is selected.

■ When policy transitions the virtual machine due to kickout then the policy 
first transitions the application service group that are online on the virtual 
machine.

■ If no systems exist that meet the criteria, the service group will not go 
online, and will remain as a persistent action in the GTQ.

Choosing the best target system for groups with dependencies
The best target system selection process for a service group with local service 
group dependencies is the following:

■ Equal priority groups of same group type (failover or parallel)

Groups are placed in a single GTQ entry for processing. The service group 
load calculation is evaluated as a combined total. The best target system 
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must accept the entire set of groups bounded by the local group dependency 
as a single requirement.

If no such target system can be identified, AWM attempts to find a target 
system for every group individually. For example, a child service group may 
online and the parent service group may remain in the GTQ with an intent 
online entry.

■ Parent groups have lower priority than child groups

Groups are placed in the GTQ as multiple entries for processing, with the 
child group always ahead of the parent group. The best target system is 
planned for the child group as usual except that the FragmentationPolicy 
attribute BiggestAvailable is applied. This provides the highest probability 
for adequate capacity to remain for the parent group to come online.

■ Child groups have lower priority than parent groups

This configuration is not supported in VCS One.

■ Child group is of a different type (failover or parallel) than parent group

Groups are placed in the GTQ as multiple entries for processing, with the 
child group always ahead of the parent group. The best target system is 
planned for the child group as usual except that the FragmentationPolicy 
attribute BiggestAvailable is applied. This provides the highest probability 
for adequate capacity to remain for the parent group to come online.

The best target system selection process for a service group with global service 
group dependencies is the following:

■ AWM evaluates each group independently. The decision for a child service 
group and the decision for a global parent group are not considered together.

■ Groups are placed in the GTQ as multiple entries for processing, with the 
child group always ahead of the parent group. If a target system can not be 
determined for the child, and another instance of the child group is not 
online in the VCS One cluster, then a target system for the parent will not be 
identified.

Events that re-examine intent-online GTQ entries
If entries remain in the GTQ because no eligible target systems are identified, 
these entries are designated as intent-online GTQ entries. 

Intent-online GTQ entries are re-evaluated to see if a target system can be 
identified when the following events occur:

■ The value of the Capacity attribute is increased.

■ The value of the Load attribute is decreased

■ A service group, that is incompatible with another group, is taken offline.
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■ A child group is brought online.

■ All the groups on a system are probed.

■ A service group is enabled on one or more systems.

■ A persistent resource recovers from a fault.

■ A faulted resource is cleared.

■ A system is added to the SystemList attribute of a service group.

■ A new system joins the VCS One cluster.

■ A system rejoins the VCS One cluster after reboot.

■ A system is unfrozen.

■ An agent registers with the Policy Master.

Any potential target system for an intent-online GTQ entry must have the 
service group completely offline. 

The intent-online entry is removed for a failover service group if either of the 
following is true:

■ If the service group is not completely offline on all systems in the VCS One 
cluster, and there is a reconnect of the Policy Master to the VCS One 
environment. 

■ If the service group is partially online on a system as the system joins the 
VCS One environment. In this case the Policy Master will not fully online the 
service group in case you want the group to remain in the partially online 
state.
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 IV

Tasks: Managing 
components

This section includes the following chapters:

■ “Managing systems” on page 335

■ “Managing service groups” on page 355

■ “Managing composite service groups” on page 405

■ “Managing resources” on page 423

■ “Managing application placement” on page 443

■ “Managing automated tasks” on page 453
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 15
Managing systems

This chapter includes the following topics:

■ Adding a system to the VCS One cluster

■ Locating a system

■ Viewing system attributes

■ Viewing details about a system

■ Editing system attributes

■ Adding a system to the VCS One cluster using the Simulator

■ Deleting a system from the VCS One cluster

■ Freezing a system

■ Unfreezing a system

■ Faulting a system using the Simulator

■ Repairing a system using the Simulator

■ Moving a system to another organization tree node

■ Viewing a selected list of systems

■ Displaying system information

■ Putting a system in the offline state

■ Simulating a system in DDNA state

■ Simulating a system heartbeat failure

■ Simulating a system heartbeat recovery
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Adding a system to the VCS One cluster
This topic describes how to add a physical system to the VCS One cluster. 
Adding a system to the VCS One cluster involves physically connecting the 
system to the VCS One cluster network and installing the VCS One client 
software. The VCS One installation program configures the system as part of the 
VCS One cluster.

Checking installation prerequisites
Before installing the VCS One client, you must ensure that the following 
prerequisites are met:    

■ The target installation system runs one of the supported platforms as listed 
in the Veritas Cluster Server One Release Notes.

■ The target installation system is physically connected to the VCS One 
network using at least one TCP/IP connection. The system’s IP address (or 
on Windows, system name) is known.

■ The clocks are in sync between the Policy Master and the system to be 
added.

■ The Policy Master daemon is running. Execute the following command on 
the active Policy Master cluster node, to ensure that the Policy Master 
daemon is running: 
haadmin -state 

On Windows, the Policy Master daemon runs as a service.

■ You have the virtual IP address of the Policy Master cluster. 

■ Symantec Product Authentication Service is functional on the Policy Master 
systems and the authentication broker is running.

On Windows, the service is named Veritas Cluster Server One Product 
Authentication Service.

■ ssh or rsh communication is configured and functional. 

More information is available about setting up ssh or rsh communication. 
This requirement does not apply on Windows.

See the Veritas Cluster Server One Installation Guide.

■ You have logged on to the system (which runs the installation process) with 
root user credentials, on UNIX. On a Windows system, refer to the 
installation guide for the privileges required.

See the Veritas Cluster Server One Installation Guide.

■ You have mounted the VCS One installation disc on a system connected to 
the same network as the target installation system. 
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■ If the system on which you are installing the VCS One client daemon uses a 
DHCP IP address, ensure that the address has a long-term lease and is not 
relinquished while the VCS One client daemon is running. Loss of network 
connectivity results in VCS One client daemon failures.

Installing the VCS One client 
See the Veritas Cluster Server One Installation Guide for instructions on how to 
install the VCS One client. 

After the installation process completes, the VCS One client daemon 
(vcsoneclientd) starts on the system, and the system is part of the VCS One 
cluster.

Adding a configured system to the VCS One cluster
This section describes how to add a system to the VCS One cluster, which has the 
VCS One client daemon installed, but is not currently part of the VCS One 
cluster.

 Such a situation may arise if the system was previously configured and added to 
the VCS One cluster, but was removed from the VCS One cluster.

Prior to adding the system to the VCS One cluster, ensure that it meets the 
following prerequisites: 

■ The system runs a platform that VCS One supports. 

■ The VCS One client software is installed.

■ The system is connected to the VCS One cluster by a TCP/IP network.

■ If the system on which you are installing the VCS One client daemon uses a 
DHCP IP address, ensure that the address has a long-term lease and is not 
relinquished while the VCS One client daemon is running. Loss of network 
connectivity results in VCS One client daemon failures.

To add a system using the VCS One console

1 In the VCS One console, click Manage > Systems.

2 Click Configuration > Add System. 

3 In the Add System Wizard screen, click Next. 

4 In the Add System screen, perform the following steps in the order 
presented: 

■ In the Name box, enter the name of the system. The name of the system 
cannot exceed 128 characters. 

■ In the Platform box, select the platform the system runs.
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If you do not specify a platform, the system is added with the default 
platform. 

See “DefaultPlatform” on page 822.

See “PlatformName” on page 845.

■ Check Configure advanced workload management if you want to 
configure AWM.

Advanced workload management is a feature that allows you to define 
the amount of resources a system has (Capacity) with respect to the 
amount of resources that a service group needs (Load).

Enter the values that correspond to the amount of resources that this 
service group needs. 

Note: It is strongly recommended that you understand the AWM 
feature before entering values. You need to define Capacity on a system 
as well as Load on a service group for this feature.

See “About Load and Capacity” on page 55.

■ Click Next or Finish.

Clicking Finish in any intermittent screen of the Add System Wizard 
results in adding the system to the default organization unit node for 
the logged on user. The system inherits the default extended attribute 
values, which are defined at the default organization unit node.

5 In the Organization Unit Selection screen, under Organization Tree, expand 
the ServerFarm node, and then select the organization unit node where you 
want the system to reside. 

6 Click Next.

7 In the Assign Values to Extended Attributes screen, perform the following 
steps in the order presented, for each extended attribute: 

■ Under Extended Attributes, select the extended attribute. 

■ In the Value box, select or enter a value for the extended attribute. 

8 In the Assign Values to Extended Attributes screen, click Finish. 

9 In the Summary screen, click Close. 

To add a system from the command line

1 Add the system to the VCS One cluster. At the command prompt, type the 
following: 
hasys -add system [-platform platform] [ouvaluepath]
[-user user@domain] [-domaintype domaintype]

If you do not specify a platform, the system is added with the default 
platform. 
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See “DefaultPlatform” on page 822.

Once the system is added, a message displays that prompts you to set the 
system’s capacity before configuring any service groups on it. 

If you do not specify an OUvaluepath, the system is added to the root (/) of 
the Organization Tree.   

2 List and display information about the system, which you have added. At the 
command prompt, type the following:
hasys -display system 

To modify the system’s capacity attribute from the command line

◆ At the command prompt, type the following:
hasys -modify [refreshvars] system Capacity -update key value 
key value ...

Example
hasys -modify solsys20 Capacity -update cpu 8 memory 3096 

Locating a system
Use this procedure to locate a system.

You can use one or more of the following structures to locate a system in VCS 
One:

■ Organization Tree 

■ Extended Attributes

■ Sets 

To locate a system using the organization tree

1 In the VCS One console, click Manage > Systems.

2 In the left pane, select Organization Tree from the drop-down list. 

3 In the left pane, select the appropriate Organization Tree Node (OU Name 
node or OU Value node). 

4 In the right pane, view all the system associated with the selected 
organization tree node. 

To locate a system using extended attributes 

1 In the VCS One console, click Manage > Systems.

2 In the right pane, use the EA Filter to view system by extended attribute.

See “Filtering results in a table” on page 129.
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To locate a system using sets 

1 In the VCS One console, click Manage > Systems.

2 In the left pane, select either My Objects or a user-defined set from the list. 

3 In the right pane, view all the systems associated with the selected set. 

To locate a system using multiple filtering methods

1 In the VCS One console, click Manage > Systems.

2 In the left pane, select Organization Tree from the drop-down list

3 Click a node in the organization tree. 

4 In the right pane, view all the systems associated with that organization tree 
node.

5 In the right pane, use the EA Filter box to further filter the systems.

Click the down arrow next to EA Filter to choose extended attributes.

6 Enter text in the Keyword text box to further limit the search within the 
systems currently displayed. 

To display the Keyword text box, click the + next to EA Filter.

7 Click Go. 

8 In the right pane, view all the systems that match the search criteria. 

Viewing system attributes
This topic describes how to view system attributes. 

To view system attributes using the VCS One console 

1 In the VCS One console, locate the system to view.

See “Locating a system” on page 339.

2 Click a system in the Name column.

3 In the right pane, click All Attributes. 

Click the arrow symbol in the Attribute Name column to sort the list in 
ascending or descending alphabetical order.

To view system attributes from the command line

◆ At the command prompt, type the following: 
hasys -value system attribute [-user user@domain] [-domaintype 
domaintype] 
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Viewing details about a system
The detail page of a system provides low-level information about the system .

To view details about a service group using the VCS One console

1 In the VCS One console, click Manage > Systems.

2 Click a system in the Name column to go to the detail page for that system.

Editing system attributes
This section describes how to edit system attributes.

To edit system attributes using the VCS One console

1 In the VCS One console, locate the system to edit. 

See “Locating a system” on page 339.

2 Check one or more systems to edit.

3 Click Configuration > Edit Attribute. 

4 In the The Edit Attribute dialog box, perform the following steps for each 
system attribute to modify: 

■ In the Attribute Name box, select the system attribute to modify. Only 
attributes that can be modified are displayed in this list.

■ In the Value box, enter or select a value for the specified attribute. 

5 Click OK > Close.

To edit a system attribute from the command line

◆ At the command prompt, type the following: 
hasys -modify [refreshvars] system attribute value [-user 
user@domain]
[-domaintype domaintype]

More information is available about system attributes. 

See “System attributes” on page 840. 

Adding a system to the VCS One cluster using the 
Simulator

This task is only available using the Simulator, to simulate a system add 
operation.
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To simulate adding a system to the VCS One cluster

Note: Clicking Finish in any intermittent screen of the Add System Wizard adds 
the system to the default organization unit node for the logged on user. The 
system inherits the default extended attribute values, which are defined at the 
default organization unit node. 

1 In the VCS One console, click Manage > Systems.

2 Click Configuration > Add System. 

3 In the Add System Wizard screen, click Next. 

4 In the Add System screen, perform the following steps in the order 
presented: 

■ In the Name box, enter the name of the system. The name of the system 
cannot exceed 128 characters.

■ In the Platform box, select the system platform.

■ Under Capacity, enter values for the system’s capacity dimensions. 
These dimensions are based on the capacity dimensions that are 
specified in the VCS One cluster. 

■ In the Add System screen, click Next.

5 In the Organization Unit Selection screen, under Organization Tree, expand 
the ServerFarm node, and select the organization unit node where you want 
the system to reside. Click Next.

6 In the Assign values to Extended Attributes screen, for each extended 
attribute perform the following steps in the order presented: 

■ Under Extended Attributes, select the extended attribute. 

■ In the Value box, select or enter a value for the extended attribute. 

7 In the Assign Values to Extended Attributes screen, click Finish. 

8 In the Summary screen, click Close. 

Deleting a system from the VCS One cluster
This topic describes how to remove a system from the VCS One cluster. To 
remove a system, perform the following tasks in the order presented: 

■ Ensure no service groups are online on the system.

■ Stop the vcsoneclientd daemon on the system

■ Delete the system using the VCS One console or the CLI.
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Deletion of the system removes it from the configuration database.

To ensure no service groups are online on the system

1 In the VCS One console, locate the system on which you want to take the 
service groups offline. 

See “Locating a system” on page 339.

2 Click a system in the Name column.

3 In the right pane, under Details of Privileged Groups Configured in this 
system, check the status of each service group and determine the service 
groups that are online on the system. The Status column displays the status 
of the service group. 

4 For each online service group, perform the following steps in the order 
presented: 

■ Under Service Group Name, click the name of the service group. 

■ In the right pane, from the Operations menu, do one of the following: 

■ Click Offline to take the service group offline.

■ Click Switch, to move and bring the service group online on 
another system. 

■ Click OK.

5 In the Web browser, click Back, to return to the system details page. 

To stop the vcsoneclientd from the command line 

1 Log on to the system to delete with root user credentials. 

2 At the command prompt, type the following: 
hastop -client -local

To delete a system using the VCS One console

1 In the VCS One console, locate the system to delete. 

See “Locating a system” on page 339.

2 Check one or more systems to delete.

3 Click Configuration > Delete System(s). 

4 Click OK > Close.

To delete a system from the command line

◆ From the active Policy Master cluster node, at the command prompt, type 
the following:   
hasys -delete system [-user user@domain] [-domaintype 
domaintype]
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Freezing a system 
Freezing a system enforces the following conditions: 

■ A service group hosted on the system can not failover to another system.

■ A service group hosted on another system can not come online on the frozen 
system through a failover operation. 

■ A manual switch of a service group to or from the frozen system is not 
allowed.

Freezing a system is useful when you want to stop your operations, such as 
maintenance activities, from triggering a service group failover.

To freeze a system

1 In the VCS One console, locate the system to freeze. 

See “Locating a system” on page 339.

2 Check one or more systems to freeze.

3 Click Operations > Freeze. 

4 In the Freeze System dialog box, select the Evacuate all online service 
groups check box, if you want to move all the existing online service groups 
to other systems in the VCS One cluster. 

5 Click OK.

To freeze multiple systems 

1 In the VCS One console, locate the systems to freeze. 

See “Locating a system” on page 339.

2 Check one or more systems to freeze.

3 Click Operations > Freeze. 

4 In the Freeze Systems dialog box, select the Evacuate all online service 
groups check box, if you want to move all the existing online service groups 
to other systems in the VCS One cluster. 

5 Click OK > Close.

To freeze multiple systems using the organization tree 

1 In the VCS One console, click Manage > Systems.

2 In the left pane, select Organization Tree from the list. Select the 
appropriate OU Value node associated with the systems to freeze.

3 Right-click the selected OU Value node, and then click Freeze. 
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4 Click OK > Close.

To freeze multiple systems using sets 

1 In the VCS One console, click Manage > Systems.

2 In the left pane, select the set associated with the systems to freeze.

3 Right-click the set, and then click Freeze. 

4 Click OK.

To freeze multiple systems using custom views 

1 In the VCS One console, click Manage > Systems.

2 In the left pane, select the set associated with the custom view. A set can 
contain one or more custom views. Expand the appropriate custom view, and 
then select the extended attribute value associated with the systems to 
freeze.

3 Right-click the extended attribute value, and then click Freeze. 

4 Click OK.

To freeze a system from the command line

◆ At the command prompt, type the following:   
hasys -freeze [-evacuate] {system | -ou expression | -ea 
expression | -ou expression -ea expression | -setname setname} 
[-user user@domain] [-domaintype domaintype] [-info] 

Unfreezing a system 
Unfreeze a frozen system to allow service groups to failover and be brought 
online on the system. 

To unfreeze a system 

1 In the VCS One console, locate the system to unfreeze. 

See “Locating a system” on page 339.

2 Check one or more systems to unfreeze.

3 Click Operations > Unfreeze. 

4 Click OK.

To unfreeze multiple systems 

1 In the VCS One console, locate the systems to unfreeze. 

See “Locating a system” on page 339.
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2 Check the box corresponding to one or more systems to unfreeze.

3 Click Operations > Unfreeze. 

4 Click OK > Close.

To unfreeze multiple systems using the organization tree 

1 In the VCS One console, click the Manage tab.

2 In the left pane, select Organization Tree from the list. Select the 
appropriate OU Value node associated with the systems to unfreeze.

3 Right-click the selected OU Value node, and then click Unfreeze. 

4 Click OK > Close.

To unfreeze multiple systems using sets 

1 In the VCS One console, click Manage > Systems.

2 In the left pane, select the set associated with the systems to unfreeze.

3 Right-click the set, and then click Unfreeze. 

4 Click OK.

To unfreeze multiple systems using custom views 

1 In the VCS One console, click Manage > Systems.

2 In the left pane, select the set associated with the custom view. A set can 
contain one or more custom views. Expand the appropriate custom view, and 
then select the extended attribute value associated with the systems to 
unfreeze.

3 Right-click the extended attribute value, and then click Unfreeze. 

4 Click OK.

To unfreeze a system from the command line

◆ At the command prompt, type the following:   
hasys -unfreeze {system | -ou expression | -ea expression | -ou 
expression -ea expression | -setname setname}
[-user user@domain] [-domaintype domaintype] 

Starting and stopping the VCS One client daemon on 
a system 

This section describes how to start and stop the VCS One client daemon 
(vcsoneclientd) processes using the hastart and hastop commands. Use this 
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procedure for maintenance and before you delete a system from the VCS One 
configuration.

This procedure does not stop the service groups that are online on the system.

You can stop the vcsoneclientd processes on one or more systems in the VCS 
One cluster. However, the vcsoneclientd processes must be started on each 
system locally. 

To start the vcsoneclientd processes on a local system 

◆ At the command prompt, type the following: 
hastart -client

To stop the vcsoneclientd processes on a local system and take the service 
groups offline 

◆ At the command prompt, type the following: 
hastop -client -local

Note: The hastart and hastop commands are not supported on the Windows 
platform. Use the net start vcsoneclientd command to start the VCS One 
client daemon, and the net stop vcsoneclientd command to stop the VCS One 
client daemon.

See the Veritas Cluster Server One Command Reference Guide.

To stop the vcsoneclientd processes on a local system, take the service 
groups offline, and offline any service groups connected with a global parent 
service group dependency

◆ At the command prompt, type the following: 
hastop -client -local -propagate [-user user@domain] [-
domaintype domaintype]

The -propagate  option propagates the offline action to the parent 
service groups.

To stop the vcsoneclientd processes on a local system and keep the service 
groups online

◆ At the command prompt, type the following: 
hastop -client -local -force [-user user@domain] [-domaintype 
domaintype]

The -force option ensures that the currently online service groups 
continue to remain online on the same system. 
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To stop the vcsoneclientd processes on a local system and move the online 
service groups to another system

◆ At the command prompt, type the following: 
hastop -client -local -evacuate [-user user@domain] [-domaintype 
domaintype]

The -evacuate option moves all the online service groups to another 
system.

To stop the vcsoneclientd processes on a local system, move the online 
service groups to another system, and move any online global parent service 
group to another system

◆ At the command prompt, type the following: 
hastop -client -local -propagate -evacuate [-user user@domain] 
[-domaintype domaintype]

The -evacuate option moves all the online service groups to another 
system. The -propagate option propagate the action to the parent service 
groups.

To stop the vcsoneclientd processes on one or more remote systems and 
failover the online service groups after a system fault

◆ At the command prompt, type the following: 
hastop -client -sys systems [[-actonnodefault] -force|-evacuate]            
[-user user@domain] [-domaintype domaintype]

If the system faults after the VCS One client daemon is stopped, and you 
want the currently online service groups to failover to another system, 
specify the -actonnodefault option. The online service groups are failed 
over only after the system faults and not when the VCS One client daemon 
stops.

To stop the vcsoneclientd processes on all systems in the VCS One cluster 

◆ On the Policy Master, at the command prompt, type the following: 
hastop -client -all

Faulting a system
Use this procedure to change the state of the system from DDNA or UNKNOWN to 
FAULTED.

In the DDNA state, the system on which the VCS One client daemon is installed 
is functional (up and running), however, the VCS One client daemon process has 
stopped.
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If a system is in the DDNA state or the UNKNOWN state, the Policy Master does not 
failover service groups that are running on the system. The administrator must 
manually failover the service groups.

Use this procedure to move a system to the FAULTED state, and allow VCS One to 
respond with automated fault policy.

1 In the VCS One console, locate the systems to fault. 

See “Locating a system” on page 339.

2 Check one or more systems to fault.

3 Click Operations > Mark as Faulted. 

4 Click OK > Close.

Faulting a system using the Simulator
This operation changes the state of the system to FAULTED to simulate a system 
fault in the Simulator.

To simulate a fault for one or more systems 

1 In the VCS One console, locate the systems to fault. 

See “Locating a system” on page 339.

2 Check one or more systems to fault.

3 Click Simulation > Fault System. 

4 Click OK > Close.

To simulate a system fault from the command line

◆ At the command prompt, type the following:

hasim -faultsys system(s) [-user user@domain -domaintype 
domaintype] 

Repairing a system using the Simulator
This task is only available using the Simulator, to simulate a system repair 
operation.

To simulate a repair operation for one or more systems

1 In the VCS One console, locate the faulted systems to repair. 

See “Locating a system” on page 339.

2 Check one or more systems to repair.
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3 Click Simulation > Start Systems. 

4 Click OK > Close.

To simulate a repair operation from the command line

◆ At the command prompt, type the following:

hasim -startsys system(s) [-user user@domain -domaintype 
domaintype]

Moving a system to another organization tree node
You may move a system to any OUvalue node in the organization tree if you 
have appropriate privileges.

See “Modify OU” on page 759.

If the system has an extended attribute that is a variable, and that attribute 
value is invalid at the new organization tree location, the move operation is 
rejected and an error message is generated.

To override this behavior and move the system, use the —refreshvars option. 
Doing so will update value of the resource attribute.

To move one or more systems to another organization tree node 

1 In the VCS One console, locate the systems to move. 

See “Locating a system” on page 339.

2 Check the system to move.

3 Click Configuration > Move System(s). 

4 In the Organization Unit Selection dialog box, perform the following steps 
in the order presented:

■ Under Organization Tree, expand the ServerFarm node, and select the 
OU Value node to which you want to move the system. 

■ Consider the Allow changes even if any EA’s are used in attribute 
values of resources check box.

Check this option to confirm to allow the move of the system even if it 
changes the resource attribute values due to the use of resource 
variables.

When a system is moved to another OU, it is possible that the value of 
an extended attribute which is attached to the system is no longer 
valid. In this case the extended attribute value for the object changes. 

If the extended attribute is used as resource variable, then the change 
in value of the extended attribute can also change a resource attribute 
value. 
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■ Consider the Modify Privileges if move violates the assigned Roles 
check box.

Consider this option in the use case when the user moves to an OUvalue 
node that is not in the subtree of his original organization tree node. In 
this case, you must check this option to remove privileges from the 
user that are no longer valid due to the move, or the move is rejected.

This option is equivalent to the -updateroles option in the command 
line.

■ Click Next. 

5 In the Assign Values to Extended Attributes dialog box, assign extended 
attribute values for the system. This dialog box displays only if extended 
attributes are defined for the selected node or any other preceding nodes in 
the organization tree hierarchy. 

6 Click Finish.

To move a system to another organization tree node from the command line

◆ At the command prompt, type the following:   
hasys -move [-updateroles] [-refreshvars] systems -ou 
ouvaluepath [-user username@domain] [-domaintype domaintype] 

Viewing a selected list of systems
This section describes how to filter systems based on status. 

To filter systems based on status 

1 In the VCS One console, click Manage > Systems.

2 In the left pane, select Organization Tree from the list, and then select the 
ServerFarm node or any other organization tree unit node. Note that you 
can also select an extended attribute or a set. 

3 In the right pane, in the Status of all systems area, do one of the following 
to filter systems based on status: 

■ Click the number corresponding to Running, to view all the systems 
that are currently in the RUNNING state. 

■ Click the number corresponding to Offline, to view all the systems that 
are currently in the OFFLINE state. 

■ Click the number corresponding to Faulted, to view all the systems that 
are currently in the FAULTED state. 

■ Click the number corresponding to Deploying, to view all the systems 
that are currently in the DEPLOYING state. 
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You can sort systems in ascending or descending alphabetical order by clicking 
any of the column headings under Systems.    

Displaying system information
This section describes the VCS One commands that are used to view system 
information. The hasys command provides several options to display system 
information. 

To list all the systems by name 

◆ At the command prompt, type the following: 
hasys -list

To list all the systems using a common attribute 

◆ At the command prompt, type the following: 
hasys -list PlatformName=~linux

You can use a conditional statement. For example, to list all the systems 
where the PlatformName attribute value contains linux.

To display system specific attribute information

◆ At the command prompt, type the following: 
hasys -display system

To display the value of a specific attribute for a specific system

◆ At the command prompt, type the following: 
hasys -display system -attribute Capacity

More information is available about VCS One commands. 

See the Veritas Cluster Server One Command Reference Guide.

Putting a system in the OFFLINE state
In the Simulator, this task simulates a system state change to OFFLINE. In an 
actual VCS One cluster, this task takes the VCS One client daemon offline on 
that system.

You require Stop System privileges to offline a system. 

To simulate the offline operation for one or more systems

1 In the VCS One console, locate the systems which you want to take offline. 

See “Locating a system” on page 339.
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2 Check one or more systems to take offline.

3 Click Operations > Stop Systems. 

4 Click OK > Close.

Simulating a system in DDNA state
This task is only available using the Simulator to simulate the Daemon Dead 
Node Alive state (DDNA) of a system. In the DDNA state, the system on which 
the VCS One client daemon is installed is functional (up-and-running), however, 
the VCS One client daemon process has stopped. 

If a system is in the DDNA state, the Policy Master does not failover service 
groups that are running on the system. The administrator must manually 
failover the service groups. 

To simulate the DDNA state for one or more systems 

1 In the VCS One console, locate the systems for which you want to simulate 
the DDNA state. 

See “Locating a system” on page 339.

2 Check one or more systems on which to simulate the DDNA state.

3 Click Simulation > Simulate Daemon Dead. 

4 Click OK > Close.

To simulate the DDNA state for a system from the command line

◆ At the command prompt, type the following:

hasim -killclient system(s) [-user user@domain -domaintype 
domaintype] 

To restore a system that is currently in the DDNA state, you must perform a 
system repair operation. 

More information is available about how to simulate a system repair operation. 
See “Repairing a system using the Simulator” on page 349.

Simulating a system heartbeat failure
This task is only available using the Simulator to simulate a system heartbeat 
failure. You must use the command line to simulate a heartbeat failure.

To simulate a system heartbeat failure

◆ At the command prompt, type the following: 
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hasim -disablelink system [-hb] 
[-user user@domain -domaintype domaintype] 

The simulator creates two links for each simulated system; one for 
communication and the other for heartbeats. This command simulates a 
hardware failure by stopping data flow over the communication link. Use 
the -hb option to stop the data flow on the heartbeat link.

Simulating a system heartbeat recovery
This task is only available using the Simulator to simulate a system heartbeat 
recovery. You must use the command line to simulate a heartbeat recovery.

To simulate a system heartbeat recovery 

◆ At the command prompt, type the following: 

hasim -enablelink system [-hb]
[-user user@domain -domaintype domaintype]

This command restarts data flow on the faulted link and simulates a 
heartbeat recovery operation. 
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Managing service groups

This chapter includes the following topics:

■ About managing service groups

■ Adding a service group or an infrastructure service group

■ Locating a service group

■ Viewing details about a service group

■ Using the Group Dependency View

■ Editing service group attributes

■ Editing attributes using the All Attributes link

■ Editing extended attributes of a service group

■ Refreshing a service group’s SystemList

■ Adding a service group to a composite service group

■ Deleting a service group

■ Deleting a service group from a composite service group

■ Modifying a service group

■ Moving a service group to another organization tree node

■ Bringing a service group online

■ Taking a service group offline

■ Switching a service group

■ Flushing a pending action on a service group

■ Flushing the plan of action on all service groups in the GTQ

■ Stopping the current action for an object in the GTQ

■ Freezing a service group
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■ Unfreezing a service group

■ Enabling a service group

■ Disabling a service group

■ Faulting a service group in the Simulator

■ Clearing a service group fault

■ Managing service group dependencies

■ Adding or modifying resources in a service group

■ Enabling service group resources

■ Disabling service group resources

■ Probing service group resources

■ Bringing service group resources online

■ Taking service group resources offline

■ Cloning service groups

■ Changing a service group’s priority value

■ Changing a service group’s load value

■ Configuring a service group’s SystemList with a list of systems

■ Configuring a service group’s SystemList with an expression

■ Configuring a service group’s compatibility list

■ Configuring a service group’s fault policy

■ Creating an off-host resource in a service group
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About managing service groups
A service group is a virtual container that contains all the hardware resources 
and software resources that are required to run the managed application.

See “About service groups and service group dependencies” on page 32.

Service groups can be dependent on each other to create more complex managed 
applications. 

See “About designing service group dependencies” on page 283.

Service groups can run inside a Solaris Zone.

See “Designing service groups that run in Solaris zones” on page 301.

More information is available about service groups.

See “About designing application and virtual machine placement policy” on 
page 312.

See “About designing the actions taken after a fault” on page 260.

See “Service group attributes” on page 848.

About managing infrastructure service groups
An infrastructure service group (ISG) is a service group that runs on PFrames. 
An infrastructure service group has only PFrames in its SystemList.

Infrastructure service groups are intended primarily for hosting replication 
resources, but they can also be used for hosting resources that are used to 
monitor network and storage components on the PFrame, that is, monitor the 
VMKernel and Service Console Port Groups on an ESX host.

Adding a service group or an infrastructure service 
group

Use this procedure to add a service group or an infrastructure service group.

Note that the GrpFaultPolicy attribute and the NodeFaultPolicy attribute 
determine the VCS One functional mode.

See “About Veritas Cluster Server One” on page 26.
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Note: The procedure for adding an infrastructure service group is almost the 
same as that for adding a service group except that a service group runs on 
systems while an infrastructure service group runs on PFrames. The Service 
Group Configuration wizard screens slightly differ accordingly.

To add a service group or an infrastructure service group using the VCS One 
console

1 In the VCS One console, click Manage > Service Groups.

2 To add a service group, click Configuration > Add Service Group. 

To add an infrastructure service group, click Configuration > Add ISG. 

3 Click Next.

4 In the Service Group Configuration screen, perform the following steps in 
the order presented: 

■ In the Name box, enter the name of the service group. 

The name of the service group cannot not exceed 128 characters. It can 
not start with a number or contain special characters. 

■ In the Type section, select either Failover or Parallel. 

A failover service group is brought online on only one system at a time. 
A parallel service group is simultaneously brought online on multiple 
systems.

■ In the Priority box, select the priority for the service group. 

1 denotes highest priority while 5 denotes lowest priority.

■ In the Platform box, select the platform on which the service group will 
run. 

Platform comprises the operating system and the recommended 
hardware architecture. For example, Windows/x86 or Solaris/SPARC. 

For infrastructure service groups, select the virtualization platform. 
For example, ESX or Solaris.

Note: For the Solaris/x64 platform, select the solaris/x86 entry.

See “PlatformName” on page 855.

See “About the configuration files” on page 685.

■ Check Configure advanced workload management if you want to 
configure AWM. This option is not applicable to infrastructure service 
groups; instead, select the load values.

Advanced workload management is a feature that allows you to define 
the amount of resources a system has (Capacity) with respect to the 
amount of resources that a service group needs (Load).
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Enter the values that correspond to the amount of resources that this 
service group needs. 

Note: It is strongly recommended that you understand the AWM 
feature before entering values. You need to define Capacity on a system 
as well as Load on a service group for this feature.

See “About Load and Capacity” on page 55.

You can modify the service group’s load dimensions after the service 
group is created. 

See “Changing a service group’s load value” on page 393.

■ In the Service Group Configuration screen, do one of the following: 

■ Click Finish > Close, to create an empty service group with no 
systems and resources. 

You can add systems and resources to the service group at a later 
stage. 

See “Configuring a service group’s SystemList with a list of 
systems” on page 394.. 

See “Adding a resource to a service group” on page 426.

■ Click Next. 

5 In the Organization Unit Selection panel, under Organization Tree, expand 
the ServerFarm (/) node, and select an organization unit node which will 
contain the service group. 

Service groups can be assigned to only Organization Unit Values (OU 
Values) and not Organization Unit Names (OU Names). This panel will not 
appear if there is only one node, the root node, in your Organization tree.

6 Click Next.

7 In the Assign Values to Extended Attributes panel, select an extended 
attribute from the Extended Attributes box, and then in the Value box, 
select or enter a value for the extended attribute. 

Repeat this step for each extended attribute that you want to change. 

This panel will not appear if extended attributes are not configured.

8 Click Next.

9 In the SystemList configuration panel, you determine the list of systems (or 
PFrames in the case of infrastructure service groups) on which the service 
group can run. To easily find systems, you can filter the list of systems in the 
Available Systems table using one of the following filters. The appropriate 
filter screen displays depending on your filter criteria selection. 

The following table outlines the steps to perform for each filter criteria.
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Note: Filter names might vary slightly for infrastructure service groups.

Filter Criteria Procedure 

Name Enter the name of a service group. Click Search.

Extended Attributes In the Select box, select Extended Attributes. 

Under Extended Attributes, select an extended attribute, and 
then select a value for the extended attribute. For free form 
extended attributes, select a node from the Extended 
Attributes tree and enter a value in the EA Expression: text 
box.

You can select only one value per extended attribute. However, 
you can use multiple extended attributes. 

The appropriate EA expression is built and displayed in the EA 

Expression box. You can edit this expression. 

Click Apply. 

Organization Tree In the Select box, select Organization Tree.

Under OU Tree, select an organization tree node. The 
appropriate OU expression displays in the OU Expression box. 
You can edit this expression. 

Click Apply. 

Sets In the Select box, select Sets. 

Under Sets, select either Default or a custom view. 

In the OU Expression box, enter an OU Expression, if required. 

In the EA Expression box, enter an EA Expression, if required. 

Click Apply. 

Expression In the Select box, select Expression. 

In the OU Expression box, enter an OU Expression, if required. 

In the EA Expression box, enter an EA Expression, if required. 

Click Apply. 

Attribute In the Select box, select Attribute. 

Under Capacity, select either Total or Available. 

Enter values for the load dimensions defined in the VCS One 
cluster, and then click Apply. 
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Systems displayed under Available Systems (Available PFrames for 
infrastructure service groups) with an asterisks sign (*) indicate that they 
were selected as part of the previous expression. 

10 In the SystemList Configuration panel, build the SystemList (PFrameList for 
infrastructure service groups) of the service group. Use the following 
information to perform this task.

11 Click Next.

12 Skip to step 14 if the service group does not run on a container-enabled 
platform.

13 In the Container Information panel, do one of the following: 

■ Click Next, if you do not want to specify a container resource for the 
service group. 

■ Select the Associate Service Group with a Container check box, if you 
want to specify a container resource. 

A container resource is used when you configure a service group that is 
associated with a Solaris Zone or an AIX WPAR. VCS One manages the 
container as part of the service group and propagates the service 
group's load dimension values to the respective resource so that limits 
can be set at the container level. In the Specify container type for the 
service group screen, perform the following steps in the order 
presented: 

■ In the Type box, select either Zone or WPAR.

The XRM option refers to directly using Solaris projects without 
using Solaris containers. This support has been deprecated in this 
release.

■ In the Name box, enter the name of the container. 

■ In the Enabled box, select Yes to enable the container association 
or select No to disable the container association.

■ Click Add Container resource to Service Group.

Arrange the order of the systems Click the table heading to arrange the 
systems in ascending or descending 
alphabetical order.

Move a system between the Available System 
table and the SystemList table

Click the single right arrow or left 
arrow.

Move all systems between the Available 
System table and the SystemList table

Click the double right or left arrow.
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■ In the Resource Name box, enter the name of the container 
resource. 

■ Click Next. 

More information is available on Solaris zones.

See “Managing objects in Solaris zones” on page 549.

14 In the Add Resources screen, perform the following steps for each resource 
that you want to add:

■ In the Type box, select the resource type. 

■ In the Name box, enter the name of the resource. 

■ Check Enable Resource to enable the resource.

■ Click Add Resource to add the resource to Resource List. 

■ Under Resource List, select the resource, and then click the Edit icon.

■ In the Edit Resource screen, under Attribute List, click a resource 
attribute and do one of the following: 

■ Under Apply to, select the All systems in the systemlist option, 
and then in the Value box enter a value for the resource attribute. 
The resource attribute value is global and is the same on all 
systems defined in the service group’s SystemList attribute. 

■ Click OK to return to the Add Resources screen. 

■ Under Apply to, select the Selected systems option, select a 
system, then in the Value box enter a value for the resource 
attribute. The resource attribute value is local and is applicable 
only to the selected system. Repeat this step for each system. 

■ Click OK to return to the Add Resources screen. 

■ Click Next. 

15 In the Link/Unlink Resources screen, perform the following steps for each 
resource dependency that you want to create: 

■ In the Parent box, select the parent resource.

■ In the Child box, select the child resource. 

Only available child resources that can be linked are displayed. 

■ Click Add Link to create a dependency link between the parent and 
child resources.

■ After a resource dependency is created, the parent and child resources 
are displayed under Currently linked. 

To remove the resource dependency, click the corresponding Remove 
icon in the row.
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16 In the Link/Unlink Resources screen, click Next.

17 In the Result panel, click Close or Advanced.

■ Click Close, to exit the Service Group Configuration Wizard. If errors 
are encountered while creating the service group, click Error Details for 
more information about the errors. 

■ Click Advanced to configure the service group’s compatibility list and 
failover policy. This option will not appear for an infrastructure service 
group.

■ You can configure the service group’s compatibility list and failover 
policy at a later stage. 

See “Configuring a service group’s compatibility list” on page 396.

See “Configuring a service group’s fault policy” on page 398.

After you configure the service group’s compatibility list and failover 
policy, in the Configure Fault Policy screen, click Finish. 

To add a service group from the command line

◆ At the command prompt, type the following: 
hagrp -add service_group [-platform platform] [ouvaluepath]
[-user user@domain] [-domaintype domaintype] 

To specify the service group’s SystemList from the command line

◆ At the command prompt, type the following: 
hagrp -modify service_group SystemList -add system_1 0 system_2 
1 ... system_n (n-1)

where 0, 1, are the priorities for the systems.

To specify the service group type (parallel or failover) from the command line

◆ At the command prompt, type the following: 
hagrp -modify service_group Parallel 0

A failover service group runs only on one system at a time; a parallel service 
group runs concurrently on multiple systems.

To specify the service group’s load dimensions from the command line

◆ At the command prompt, type the following: 
hagrp -modify service_group Load -update cpu 2 memory 2 stbw 2 
nwbw 2

To specify the service group’s compatibility list from the command line

◆ At the command prompt, type the following: 
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hagrp -incompatible service_group1 service_group2 [-user 
user@domain] [-domaintype domaintype]

For example, if group SG1 cannot co-exist with group SG2, type the 
following:
hagrp -incompatible SG1 SG2 

To specify the failover policy for the service group from the command line

◆ At the command prompt, type the following: 
hagrp -modify service_group GrpFaultPolicy policy

where, policy can be either Failover or NoFailover. 

After the service group is created, you need to add resources to the service 
group.

Locating a service group
Use this procedure to locate a service group. 

You can use one or more of the following structures to locate a service group in 
VCS One:

■ Organization Tree 

■ Extended Attributes

■ Sets

To locate a service group using the organization tree

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select Organization Tree from the drop-down list. 

3 In the left pane, select the appropriate organization tree node (OU Name 
node or OU Value node). 

4 In the right pane, view all the service groups associated with the selected 
organization tree node.

To locate a service group using extended attributes 

1 In the VCS One console, click Manage > Service Groups.

2 In the right pane, use the EA Filter to view service groups by extended 
attribute.

See “Filtering results in a table” on page 129.

To locate a service group using sets 

1 In the VCS One console, click Manage > Service Groups.
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2 In the left pane, select either My Objects or a user-defined set from the 
drop-down list. 

3 In the right pane, view all the service groups associated with the selected 
set.

To locate a service group multiple filtering methods 

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select Organization Tree from the drop-down list

3 Click a node in the organization tree. 

4 In the right pane, view all the service groups associated with that 
organization tree node.

5 In the right pane, use the EA Filter box to further filter the service groups.

Click the down arrow next to EA Filter to choose extended attributes.

6 Enter text in the Keyword text box to further limit the search within the 
service groups currently displayed. 

To display the Keyword text box, click the + next to EA Filter.

7 Click Go. 

8 In the right pane, view all the service groups that match the search criteria. 

Viewing details about a service group
The detail page of a service group provides low-level information about the 
service group.

To view details about a service group using the VCS One console

1 In the VCS One console, click Manage > Service Groups.

2 Click a service group in the Name column to go to the detail page for that 
service group.

Using the Group Dependency View
The VCS One console provides various views to effectively manage the VCS One 
cluster. This section provides information about the different views related to 
service group administration.

Additional information is available about how to use the dependency view.

See “Summary information on the dependency view” on page 152.
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Viewing service group dependencies
Use this procedure to view the service group dependencies. You require at least 
Read privileges on the service group to view its dependencies.

To locate the group dependency view

1 In the VCS One console, locate the service group, which you want to view. 

See “Locating a service group” on page 364.

2 Check one service group on which to view dependencies.

3 Click Views > Group/VFrame Dependencies. 

Performing operations from the Group Dependency View
The group dependency view displays the dependencies for the selected service 
group. 

You can perform the following operations in the service group dependency view:

■ Bring a service group online

See “Bringing a service group online” on page 373.

■ Take a service group offline 

See “Taking a service group offline” on page 376.

■ Switch service groups

See “Switching a service group” on page 379.

■ Freeze the service group

See “Freezing a service group” on page 382.

■ Unfreeze the service group

See “Unfreezing a service group” on page 383.

■ Enable the service group

See “Enabling a service group” on page 384.

■ Disable the service group

See “Disabling a service group” on page 385.

■ Flush the service group

See “Flushing a pending action on a service group” on page 380.

■ Fault a service group

See “Faulting a service group in the Simulator” on page 385.

■ Clear a service group fault

See “Clearing a service group fault” on page 386.

■ Manage dependencies
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See “Viewing service group dependencies” on page 366.

Editing service group attributes
Use this procedure to edit service group attributes.

To edit service group attributes using the VCS One console

1 Locate the service group that you want to modify. 

See “Locating a service group” on page 364.

2 Check the service group to edit.

3 Click Configuration > Edit Attribute(s). 

4 In the Edit Attribute dialog box, perform the following steps for each service 
group attribute that you want to edit: 

■ In the Attribute(s) column, select the attribute that you want to modify. 
Only attributes that can be modified are displayed in this list.

■ Click For all Group(s) to configure the same value for all the selected 
groups, or click For selected Group(s) if you want to configure different 
values for each selected group.

■ Click the pencil icon to edit the value.

■ Check Propagate to propagate the change to all service groups in the 
local dependency tree. 

Note that the Propagate check box displays only for specific attributes. 

5 Click Next > Finish > Close.

Editing attributes using the All Attributes link
Use this procedure to view and edit service group attributes using the All 
Attributes link from the service group’s detail page. 

To view and edit service group attributes using the VCS One console

1 In the VCS One console, locate the service group that you want to view.

See “Locating a service group” on page 364.

2 Click a service group in the Name column.

3 In the right pane, click All Attributes. 

4 Click the arrow symbol in the Attribute Name column to sort the list in 
ascending or descending alphabetical order.
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5 In the All Attributes page, click the pencil icon corresponding to the 
attribute, which you want to edit. 

You may only edit attributes of global scope from this page.

6 In the Edit Attribute dialog box, perform the following steps: 

■ In the Value box, enter or select a value for the specified attribute. 

■ Select the Propagate check box to propagate the change to all service 
groups in the local dependency tree. 

Note that the Propagate check box displays only for specific attributes. 

7 Click OK.

To view service group attributes from the command line

◆ At the command prompt, type the following: 
hagrp -display [service_group(s) | -ou expression | -ea 
expression | -ou expression -ea expression | -setname setname] 
[-attribute attribute(s) [-sys system(s)] [-user user@domain] [-
domaintype domaintype]]

Editing extended attributes of a service group
Use this procedure to edit the value of extended attributes of a service group. If 
this service group inherits extended attributes, this panel allows you to modify 
the value from the default

You can not add extended attributes from this wizard.

See “About extended attributes” on page 632.

See “Defining an extended attribute” on page 634.

To edit the extended attributes of a VFrame using the VCS One console

1 In the VCS One console, click Manage > Service Groups.

2 In the right pane, check one or more service group. 

3 Click Configuration > Edit Extended Attribute(s).

4 In the Edit Extended Attribute(s) panel, use the following information to 
edit attributes:

Extended Attributes Select the attribute to modify. Only attributes 
that can be modified are displayed in this list.



369Managing service groups
Refreshing a service group’s SystemList
5 Click Next.

6 In the Summary panel, click Finish to execute the commands.

7 Click Close.

To edit an extended attribute for a service group using the command line

◆ Use the following command 
hagrp -modify

Refreshing a service group’s SystemList
The SystemList attribute of a service group denotes the list of systems on which 
the service group is configured to run. The SystemList value may be an explicit 
list of systems. The SystemList value can also be derived from an expression 
containing either or both of extended attributes and an OUValue node.

See “SystemListExpr” on page 858. 

This operation is used to refresh the system list of a service group by evaluating 
the system list expression. This operation results in addition of systems to the 
system list of the service group which satisfy the system list expression, and 
removal of systems which do not satisfy the expression. 

Invoke this operation after changing the system list expression attribute of a 
service group. 

To refresh a service group’s SystemList

1 In the VCS One console, locate the service group whose SystemList you want 
to refresh. 

See “Locating a service group” on page 364.

Select service groups Click Apply to all Service Groups to configure the 
same value for all the selected service groups.

Click individual service groups to configure 
different values for each selected service group

Updated Value Click to edit the value of the corresponding attribute.

Set Default Values Click to set the default value of the extended 
attribute for all service groups selected in step 2

Restore Old Values Click to restore the value of the currently 
selected attribute to the configured value 
before starting this instance of the wizard for 
all service groups selected in step 2
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2 Click Operations > Refresh System List.

3 Click OK > Close.

Adding a service group to a composite service group
Add a service group to a composite service group to manage a group of objects as 
a single logical object. A composite service group is also the unit of failover 
between two cluster sites.

See “About composite service groups” on page 35.

To add a service group to a composite service group using the VCS One 
console

1 In the VCS One console, click Manage > Service Groups.

2 Click Configuration > Add to CSG. 

3 Select the composite service group to add this service group to.

4 Click OK > Close.

To add a service group to a composite service group using the command line

◆ At the command prompt, type the following: 
hacsg -addgrp csg service_group [service_group...]

Deleting a service group
Use this procedure to delete a service group. You may not delete a service group 
that is online.

See “Deleting a resource from a service group” on page 427.

To delete a service group using the VCS One console

1 In the VCS One console, locate the service group that you want to delete.

See “Locating a service group” on page 364.

2 Check one or more service groups to delete.

3 Click Configuration > Delete Service Group(s). 

4 Click OK.

To delete multiple service groups using the VCS One console

1 In the VCS One console, locate the service groups that you want to delete. 

See “Locating a service group” on page 364.
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2 Check one or more service groups to delete.

3 Click Configuration > Delete Service Group(s). 

4 Check the Remove Group dependencies, if any, before deletion check box to 
remove any dependency links to this service group. 

5 Click OK.

To delete a service group from the command line

◆ At the command prompt, type the following: 
hagrp -delete service_group

To delete a service group and its resources from the command line

◆ At the command prompt, type the following: 
hagrp -delete -force service_group

Deleting a service group from a composite service 
group

Deleting a service group from a composite service group does not delete the 
service group from the VCS One configuration. It also does not delete the 
composite service group itself.

To delete a service group from a composite service group using the VCS One 
console

1 In the VCS One console, click Manage > Service Groups.

2 Click Configuration > Delete from CSG. 

3 Click OK > Close.

To delete a service group from a composite service group using the command 
line

◆ At the command prompt, type the following: 
hacsg -deletegrp csg service_group

Modifying a service group
Use this procedure to modify a service group. Using this wizard, you may not 
modify the name, the platform, or the type of this service group.

To modify a service group using the VCS One console

1 In the VCS One console, locate the service group that you want to modify. 
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See “Locating a service group” on page 364.

2 Check the service group to modify.

3 Click Configuration > Modify Service Group. 

The Service Group Configuration Wizard is used for adding and modifying a 
service group. An in-depth explanation of this wizard is covered in the 
Adding a service group section. 

See “Adding a service group or an infrastructure service group” on 
page 357.

To modify a service group from the command line

◆ At the command prompt, type the following: 
hagrp -modify [-propagate] [-refreshvars] group attribute {key 
value} ... [-sys system] [-user user@domain] 
[-domaintype domaintype]

Moving a service group to another organization tree 
node

You may move a service group to any OUvalue node in the organization tree if 
you have appropriate privileges.

See “Modify OU” on page 760.

If the service group has an extended attribute that is a variable, and that 
attribute value is invalid at the new organization tree location, the move 
operation is rejected and an error message is generated.

To override this behavior and move the service group, use the —refreshvars 
option. Doing so will update value of the resource attribute.

To move one or more service groups to another organization tree node 

1 In the VCS One console, locate the service groups that you want to move. 

See “Locating a service group” on page 364.

2 Check one or more service groups to move.

3 Click Configuration > Move Service Group(s). 

4 In the Organization Unit Selection dialog box, perform the following steps 
in the order presented:

■ Under Organization Tree, expand the ServerFarm node, and select the 
OU Value node to which you want to move the service groups. 

■ Consider the Modify Privileges if move violates the assigned roles of 
users option.
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Consider this option in the use case when the service group moves to an 
OUValue node that is not in the subtree of the original organization 
tree node. In this case, you must check this option to remove privileges 
from users attached at the original node that are no longer valid due to 
the move of the service group. Otherwise, the move is rejected.

This option is equivalent to the -updateroles option in the command 
line.

■ Click Next. 

■ Click Close.

5 In the Assign Values to Extended Attributes dialog box, assign extended 
attribute values for the service groups. This dialog box displays only if 
extended attributes are defined for the selected node or any preceding nodes 
in the organization tree hierarchy. 

6 Click OK. 

To move one or more service groups to another organization tree node from 
the command line

◆ At the command prompt, type the following: 
hagrp -move [-updateroles] service_groups -ou ouvaluepath [-user 
user@domain] [-domaintype domaintype]

Bringing a service group online
Use this procedure to bring a service group online.

To bring a service group online 

1 In the VCS One console, locate one or more service groups that you want to 
bring online. 

See “Locating a service group” on page 364.

2 Click Operations > Online.
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3 In the Online Service Group panel, one or more of the following options 
displays. Use the following information to fill in the fields:

4 Click OK.

To bring a Parallel service group online on all configured systems using the 
command line 

◆ At the command prompt, type the following: 
hagrp -online [-ejectlowpri][-nointent] group -everywhere
[-user user@domain] [-domaintype domaintype] 

To bring a service group online from the Group Dependency view

1 In the VCS One console, locate the service group that you want to bring 
online. 

Select the system you 
want to online this 
service group

System_Name: To online the service group on a that single 
system.

Anywhere: To online a failover service group on any valid 
system.

Everywhere: To online a parallel service group on all valid 
systems.

Evacuate lower 
priority service group

Check if you want service groups with a lower Priority 
attribute value to go offline if their resources are needed in 
order to bring this service group online. 

Low priority service groups are evacuated if the total Load of 
all service groups exceeds the system’s Capacity.

Do not add Intent 
Online entries

Check if you do not want the state of the service group set to 
INTENT-ONLINE in the GTQ if this group can not be brought 
online.

See “Mapping an application placement decision” on 
page 326.

Propagate If you want this online action to apply to all service groups in 
the same service group dependency tree.

For example, to bring a parent service group online and 
propagate the command to child service groups. 

Ignore the standby 
relationship while 
onlining

The online operation will fail if the service group has a 
standby group running on a different system than the target 
system. 

Check this option to change this behavior and ignore the 
standby group relationship.
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See “Locating a service group” on page 364.

2 Check one service group to bring online.

3 Click Views > Group Dependencies. 

4 Right-click the service group to be brought online, and then click Online. 

Options are available for the online command.

See “Bringing a service group online” on page 373.

5 Click OK.

To online multiple service groups using the organization tree 

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select Organization Tree from the list. 

3 Select the appropriate OU Value node associated with the service groups 
that you want to bring online.

4 Right-click the selected OU Value object, and then click Online. 

Options are available for the online command.

See “Bringing a service group online” on page 373.

5 Click OK > Close.

To online multiple service groups using sets

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select the set associated with the service groups that you 
want to bring online.

3 Right-click the set, and then click Online. 

Options are available for the online command.

See “Bringing a service group online” on page 373.

4 Click OK.

To online multiple service groups using custom views 

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select the set associated with the custom view. A set can 
contain one or more custom views. Expand the appropriate custom view, and 
select the extended attribute value associated with the service groups that 
you want to bring online.

3 Right-click the selected extended attribute value, and then click Online. 

Options are available for the online command.

See “Bringing a service group online” on page 373.
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4 Click OK > Close.

To bring a service group online on a specific system from the command line 

◆ At the command prompt, type the following: 
hagrp -online [-ejectlowpri] group -sys system
[-user user@domain] [-domaintype domaintype]

To bring the service group online on any system from the command line 

◆ At the command prompt, type the following: 
hagrp -online [-ejectlowpri][-nointent] group -any
[-user user@domain] [-domaintype domaintype] 

To bring all the service groups online from the command line

◆ At the command prompt, type the following: 
hagrp -online [-ejectlowpri][-nointent] -all [-user user@domain] 
[-domaintype domaintype]

To bring parent and child service groups online concurrently from the 
command line

◆ At the command prompt, type the following:
hagrp -online [-ejectlowpri | -propagate] group -sys system
[-user user@domain] [-domaintype domaintype]

Taking a service group offline
Use this procedure to take a service group offline.

To take a service group offline using the VCS One console

1 In the VCS One console, locate one or more service groups that you want to 
take offline. 

See “Locating a service group” on page 364.

2 Click Operations > Offline.

3 In the Online Service Group panel, one or more of the following options 
displays. Use the following information to fill in the fields:

Select the system you 
want to offline this 
group from

Click the name of the system on which you want the service 
group to be offline.
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4 Click OK.

To take a service group offline from the group dependency view

1 In the VCS One console, locate the service group that you want to take 
offline. 

See “Locating a service group” on page 364.

2 Check one service group to take offline.

3 Click Views > Group/VFrame Dependencies. 

4 Right-click the service group that you want to take offline, click Offline. 

Options are available for the offline command.

See “Taking a service group offline” on page 376.

5 Click OK.

To take multiple service groups offline using the organization tree 

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select Organization Tree from the list. 

3 Select the appropriate OU Value node associated with the service groups 
that you want to take offline.

4 Right-click the selected OU Value object, and then click Offline. 

If you are using the Firefox Web browser on a Linux computer, right-click 
the OU Value node, keep the right mouse button pressed, point to Offline, 
and then release the right mouse button. 

Options are available for the offline command.

See “Taking a service group offline” on page 376.

Forcefully offline the 
group if the system is 
in DDNA state.

Check to offline the service group on a system in the DDNA 
state. 

Daemon Dead Node Alive state indicates the vcsoneclientd 
process on the system, which is still alive, does not send 
heartbeats to the Policy Master.

Propagate Check if you want this offline action to apply to all service 
groups in the same service group dependency tree.

For example, to take a parent service group offline and 
propagate the command to all child service groups. 

Offline VFrame with 
the Service Group if it 
is the last online 
Service Group.

If the service group you take offline is the last service group 
that is online on a virtual machine, check this option if you 
also want to simultaneously take the virtual machine offline.
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5 Click OK > Close.

To take multiple service groups offline using sets

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select the set associated with the service groups that you 
want to take offline.

3 Right-click the set, and then click Offline. 

Options are available for the offline command.

See “Taking a service group offline” on page 376.

4 Click OK > Close.

To take multiple service groups offline using custom views 

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select the set associated with the custom view. A set can 
contain one or more custom views. Expand the appropriate custom view, and 
then select the extended attribute value associated with the service groups 
that you want to take offline.

3 Right-click the selected extended attribute value, and then click Offline. 

Options are available for the offline command.

See “Taking a service group offline” on page 376.

4 Click OK > Close.

To take a service group offline on a specific system from the command line

◆ At the command prompt, type the following: 
hagrp -offline [-propagate] group -sys system
[-user user@domain] [-domaintype domaintype] 

To take a service group offline on all systems using the command line

◆ At the command prompt, type the following:
hagrp -offline -propagate group -everywhere
[-user user@domain] [-domaintype domaintype] 

This command takes the specified service group and all its dependent 
service groups offline from all the systems on which they are currently 
online.

To take child and parent groups offline concurrently from the command line

◆ At the command prompt, type the following: 
hagrp -offline -propagate group -sys system
[-user user@domain] [-domaintype domaintype] 
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To take child and parent service groups offline on all systems from command 
line

◆ At the command prompt, type the following:
hagrp -offline -propagate group -everywhere
[-user user@domain] [-domaintype domaintype] 

This command takes the specified service group and all its dependent 
service groups offline from all the systems on which they are currently 
online.

Switching a service group
Use this procedure to switch a service group. When you switch a service group it 
is taken offline from its current system and brought online on another system.

To switch a service group 

1 In the VCS One console, locate the service group that you want to switch. 

See “Locating a service group” on page 364.

2 Check the service group to switch.

3 Click Operations > Switch. 

4 In the Switch Service Group dialog box, select the system where you want 
the service group to be switched. 

To switch the service group to any system listed in the service group’s 
SystemList, select Anywhere. In case of parallel service groups, the 
Anywhere option is replaced by the All Systems option.

5 Select the Evacuate lower priority service groups check box to evacuate 
other low priority service groups on the specified system. 

Low priority service groups will be evacuated if the total load of all service 
groups exceeds the system’s capacity.

6 Consider the Ignore the standby relationship option. 

The switch operation will fail if the service group has a standby group 
running on a different system than the target system. Check this option to 
change this behavior and ignore the standby group relationship.

7 Consider the Propagate option.

If you want this switch action to apply to all service groups in the same 
service group dependency tree.

For example, to switch a parent service group and propagate the command 
to child service groups. 

8 Click OK > Close.
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To switch a service group from the group dependency view

1 In the VCS One console, locate the service group that you want to switch. 

See “Locating a service group” on page 364.

2 Check the service group to switch.

3 In the left pane, under Views, click Group Dependencies. 

4 Right-click the service group, click Switch. 

5 In the Switch Service Group dialog box, select the system where you want 
the service group to be switched. To switch the service group to any system 
listed in the service group’s SystemList, select Anywhere. In case of parallel 
service groups, the Anywhere option is replaced by the All Systems option.

6 Select the Evacuate lower priority service groups check box, if you want to 
evacuate other low priority service groups on the specified system. Low 
priority service groups will be evacuated if the total load of all service 
groups exceeds the system’s capacity.

7 Click OK.

To switch a service group to a specific system from the command line

◆ At the command prompt, type the following: 
hagrp -switch [-ejectlowpri | -propagate] group -to system
[-user user@domain] [-domaintype domaintype]

When the -propagate option is specified and the service group has a local 
soft parent group online, the switch operation fails. However, if the service 
group has a global soft parent group online, the switch operation succeeds, 
but the global soft parent group is not switched and remains online on the 
same system. 

To switch a service group to any system from the command line

◆ At the command prompt, type the following: 
hagrp -switch [-ejectlowpri] group -any
[-user user@domain] [-domaintype domaintype] 

Flushing a pending action on a service group
You flush a pending action on a service group to cancel the online or offline 
operation that is currently being performed on the service group. 

A flush is useful if the online or offline operation of the service group is not 
successful. In this case, you can flush the service group, resolve the error, and 
restart the online or offline operation.
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You may also need to flush the GTQ to cancel the intent online entry for the 
service group.

See “Flushing the plan of action on all service groups in the GTQ” on page 381.

To flush a service group using the VCS One console

1 In the VCS One console, locate the service group that you want to flush. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the service group’s Details 
page.

3 Click Operations > Flush. 

4 In the Flush Service Group dialog box, select the system on which you want 
to flush the service group. 

5 Consider the Flush corresponding actions option.

Check this box to also flush the corresponding actions for this service group 
in the GTQ.

6 Click OK. 

To flush a service group from the command line

◆ At the command prompt, type the following: 
hagrp -flush [-action] group -sys system
[-user user@domain] [-domaintype domaintype]

Flushing the plan of action on all service groups in 
the GTQ

You can flush the plan of action on all service groups in the GTQ if you do not 
want the Policy Master to execute the planned GTQ actions.

See “Mapping an application placement decision” on page 326.

To flush the plan of action on a service group in the GTQ

1 In the VCS One console, click Manage > Workload.

2 In the right pane, in the Waiting Groups panel, use the right-click mouse 
button to click Flush all groups.

3 In the Confirmation window, click Yes.
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Stopping the current action for an object in the GTQ
Every object in the GTQ has an action plan. You may abort the action in progress 
without affecting the remainder of the plan. 

To stop the current action for an object in the GTQ

1 In the VCS One console, click the Manage tab.

2 Click Workload > Views > GTQ View

3 In the Group Transition Queue panel, place the cursor over the object on 
which you want to operate.

4 Right-click Abort Action.

5 In the Confirmation window, click Yes.

Freezing a service group
Freezing a service group enforces the following conditions: 

■ Online and offline operations are not allowed on the service group.

■ The service group can not failover to another system.

■ A manual switch of the service group is not allowed.

Freezing a service group is useful when you want to stop your operations, 
such as maintenance activities, from triggering a service group failover.

To freeze a service group 

1 In the VCS One console, locate the service group that you want to freeze. 

See “Locating a service group” on page 364.

2 Check the service group to freeze.

3 Click Operations > Freeze. 

4 In the Freeze Service Group dialog box, select the Propagate to dependent 
groups check box, if you want to propagate the freeze operation to the 
dependent service groups.

5 Click OK.

To freeze multiple service groups

1 In the VCS One console, locate the service groups that you want to freeze. 

See “Locating a service group” on page 364.

2 Check one or more service groups to freeze.
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3 Click Operations > Freeze. 

4 In the Freeze Service Group(s) dialog box, select the Propagate to 
dependent groups check box, if you want to propagate the freeze operation 
to the dependent service groups.

5 In the Freeze Service Group(s) dialog box, review the list of service groups to 
be frozen. 

6 Click OK > Close.

To freeze multiple service groups using custom views 

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select the set associated with the custom view. A set can 
contain one or more custom views. Expand the appropriate custom view, and 
select the extended attribute value associated with the service groups that 
you want to freeze.

3 Right-click the selected extended attribute value, and then click Freeze. 

4 Click OK > Close.

To freeze a service group from the command line

◆ At the command prompt, type the following: 
hagrp -freeze [-propagate] group [-user user@domain]
[-domaintype domaintype]

Unfreezing a service group
You may only unfreeze a service group that is already in the FROZEN state.

Unfreezing a service group enforces the following conditions: 

■ All service group online and offline operations can once again occur.

■ The service group can once again failover to another system, per policy 
configuration.

■ A manual switch of the service group is allowed.

To unfreeze a service group 

1 In the VCS One console, locate the service group that you want to unfreeze. 

See “Locating a service group” on page 364.

2 Check the service group to unfreeze.

3 Click Operations > Unfreeze. 
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4 In the Unfreeze Service Group dialog box, select the Propagate to 
dependent groups check box, if you want to propagate the unfreeze 
operation to the dependent service groups.

5 Click OK.

To unfreeze multiple service groups

1 In the VCS One console, locate the service groups that you want to unfreeze. 

See “Locating a service group” on page 364.

2 Check one or more service groups to unfreeze.

3 Click Operations > Unfreeze. 

4 In the Unfreeze Service Group(s) dialog box, select the Propagate to 
dependent groups check box, if you want to propagate the unfreeze 
operation to the dependent service groups.

5 Click OK > Close.

To unfreeze multiple service groups using custom views 

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, select the set associated with the custom view. A set can 
contain one or more custom views. Expand the appropriate custom view, and 
select the extended attribute value associated with the service groups that 
you want to unfreeze.

3 Right-click the selected extended attribute value, and then click Unfreeze. 

4 Click OK > Close.

To unfreeze a service group from the command line

◆ At the command prompt, type the following: 
hagrp -unfreeze [-propagate] group
[-user user@domain] [-domaintype domaintype]

Enabling a service group
Use this procedure to enable a service group. You need to enable a service group 
before it can be brought online. During maintenance operations, if a service 
group is manually disabled, it must be enabled prior to being brought online 
after the maintenance operation is completed. 

To enable a service group using the VCS One console

1 In the VCS One console, locate the service groups that you want to enable. 
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See “Locating a service group” on page 364.

2 Check the service group to enable. 

3 Click Operations > Enable. 

4 In the Enable Service Group dialog box, specify the system on which you 
want to enable the service group. 

5 Click OK. 

To enable a service group from the command line

◆ At the command prompt, type the following: 
hagrp -enable group [-sys system]
[-user user@domain] [-domaintype domaintype]

Disabling a service group
Use this procedure to disable a service group. When a service group is disabled, 
it cannot be brought online or taken offline. The disable operation temporarily 
stops VCS One from monitoring the service group. 

To disable a service group using the VCS One console

1 In the VCS One console, locate the service groups that you want to disable. 

See “Locating a service group” on page 364.

2 Check the service group to disable. 

3 Click Operations > Disable. 

4 In the Disable Service Group dialog box, specify the system on which you 
want to disable the service group. 

To disable the service group on all the systems, select All Systems.

5 Click OK. 

To disable a service group from the command line

◆ At the command prompt, type the following: 
hagrp -disable group [-sys system]
[-user user@domain] [-domaintype domaintype]

Faulting a service group in the Simulator
This task is only available using the Simulator, to simulate a service group fault.



386 Managing service groups
Clearing a service group fault
To simulate a fault for one or more service groups 

1 In the VCS One console, locate the service groups for which you want to 
simulate a fault. 

See “Locating a service group” on page 364.

2 Check one or more service groups to fault.

3 Click Simulation > Fault Service Groups.

4 In the Fault Service Groups dialog box, select the system on which you want 
to fault the service groups. 

5 Click OK > Close.

To simulate a service group fault from the command line

◆ At the command prompt, type the following:

hasim -faultgrp group [-sys system] 
[-user user@domain -domaintype domaintype]

Clearing a service group fault
Use this procedure to clear a service group fault. When a service group faults on 
a system, you need to clear the service group fault, before attempting to bring 
the service group online on the same system.

You can clear one fault, multiple faults or all the faults in a node of the 
organization tree.

To clear a service group fault

1 In the VCS One console, locate the faulted service group. 

See “Locating a service group” on page 364.

2 Check one or more faulted service group. 

3 Click Operations > Clear Fault. 

4 In the Clear fault for Service Group dialog box, select the system on which 
you want to clear the service group fault. Select All Systems, to clear the 
service group fault on all the systems. 

5 Click OK.

To clear all the faults in a node of the organization tree

1 In the VCS One console, click Manage > Service Groups.

2 In the left pane, click the organization tree node.

3 Click Operations > Clear All Faults under OU.
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4 Click OK > Close.

To clear a service group fault from the command line

◆ At the command prompt, type the following: 
hagrp -clear {group | -setname setname | -ou expression | -ea 
expression | -ou expression -ea expression} [-sys system] [-user 
user@domain] [-domaintype domaintype] 
[-info]

Managing service group dependencies
Use this procedure to link and unlink service groups. When service groups are 
linked, a dependency is created between them. As a result of this dependency, 
one service group becomes the parent service group and other becomes the child 
service group. The child service group must be brought online before the parent 
service group is brought online.

See “About service groups and service group dependencies” on page 32.

To link service groups using the VCS One console

1 In the VCS One console, locate the service groups that you want to link. 

See “Locating a service group” on page 364.

2 Click Configuration > Manage Dependencies. 

3 Use the following information to fill in the fields of the Create/Remove 
Dependencies panel:

Service Group Click to manage service group dependencies

VFrame Click to manage VFrame dependencies

Filter Box Enter text to filter the contents of the Objects table. 
Click the magnifying glass to search.
Click the red X to clear the filter.

Objects Select one or more objects to create dependency links 
with the service group selected.

Arrowhead Click the appropriate arrowhead to move the object. 
You may move the object to or from either a parent or 
child dependency.

Set dependency for all Use this option to set the same dependency 
relationship for all parents or all child dependencies 
that are configured.
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4 Click OK > Close.

To link service groups from the group dependency view

1 In the VCS One console, locate the service groups that you want to link. 

See “Locating a service group” on page 364.

2 Check the service group to link. 

3 Click Views >Group/VFrame Dependencies. 

4 Right-click on the background, click Manage Dependencies.

You may click one of the graph items for other action options.

To create locally linked service groups from the command line

◆ At the command prompt, type the following: 
hagrp -link parentgroup childgroup local [soft|firm|hard]
[-user user@domain] [-domaintype domaintype]

To create globally linked service groups from the command line

◆ At the command prompt, type the following: 
hagrp -link parentgroup childgroup global [soft|firm|hard]
[-user user@domain] [-domaintype domaintype]

To unlink a service group from the command line

◆ At the command prompt, type the following: 
hagrp -unlink parentgroup childgroup
[-user user@domain] [-domaintype domaintype]

Adding or modifying resources in a service group
1 In the VCS One console, locate the service groups that you want to link. 

See “Locating a service group” on page 364.

2 Check one service group on which to operate. 

3 Click Configuration > Add/Modify Resource. 

4 In the Add Resources screen, use the following information to add or 
modify resources in the service group:

■ In the Type box, select the resource type. 

■ In the Name box, enter the name of the resource. 

Dependency Type Select the type of dependency for each parent and 
child individually with the drop-down menu.

See “Designing multi-tier applications” on page 283. 



389Managing service groups
Enabling service group resources
■ Check Enable Resource to enable the resource.

■ Click Add Resource to add the resource to Resource List. 

5 In the Resource List table, use the following information to modify or delete 
a resource in the service group: 

■ To delete the resource, click the delete icon in the Del column of the 
row.

■ To modify the resource, click the edit icon in the Edit column of row.

In the Edit Resource screen, under Attribute List, click a resource 
attribute and do one of the following: 

■ Under Apply to, select the All systems in the systemlist option, 
and then in the Value box enter a value for the resource attribute. 
The resource attribute value is global and is the same on all 
systems defined in the service group’s SystemList attribute. 

■ Click OK to return to the Add Resources screen. 

■ Under Apply to, select the Selected systems option, select a 
system, then in the Value box enter a value for the resource 
attribute. The resource attribute value is local and is applicable 
only to the selected system. Repeat this step for each system. 

■ Click OK to return to the Add Resources screen. 

■ Click OK. 

Enabling service group resources
Use this procedure to enable one or more service group resources. Service group 
resources must be enabled before they can be brought online. 

To enable one or more resources in a service group

1 In the VCS One console, locate the service group that contains the resources, 
which you want to enable. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column.

3 Under Resources, check one or more resources. 

4 Click Operations > Enable Resources. 

5 Click OK > Close.

To enable all the resources in a service group 

1 In the VCS One console, locate the service group that contains the resources, 
which you want to enable. 
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See “Locating a service group” on page 364.

2 Check one or more service groups that contains the resources that you want 
to enable. 

3 Click Operations > Enable All Resources. 

4 Click OK > Close.

To enable all the resource in a service group from the command line

◆ At the command prompt, type the following: 
hagrp -enableresources service_group [-user user@domain] [-
domaintype domaintype]

Disabling service group resources
Use this procedure to disable one or more service group resources. Service 
group resources are disabled to prevent them from coming online. This is done 
when you want VCS One to temporarily stop monitoring the resources (rather 
than delete them) while the service group is still online. Make sure that the 
resources are offline before you disable them.

To disable one or more resources in the service group

1 In the VCS One console, locate the service group that contains the resources, 
which you want to disable. 

See “Locating a service group” on page 364.

2 Check the service group that contains the resources to disable.

3 In the right pane, under Resources, select one or more resources. 

4 Click Operations > Disable Resources. 

5 Click OK > Close.

To disable all the resources in the service group

1 In the VCS One console, locate the service group that contains the resources, 
which you want to disable. 

See “Locating a service group” on page 364.

2 Check the service group that contains the resources to disable.

3 Click Operations > Disable All Resources. 

4 Click OK.

To disable all the resource in a service group from the command line

◆ At the command prompt, type the following: 
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hagrp -disableresources service_group [-user user@domain] [-
domaintype domaintype]

Probing service group resources
Use this procedure to probe service group resources. Resources are probed to 
determine if they are configured correctly and are ready to go online. You can 
also probe resources to determine their current status. 

To probe all resources in a service group using the VCS One console

1 In the VCS One console, locate the service group that contains the resources, 
which you want to probe. 

See “Locating a service group” on page 364.

2 Check the service group that contains the resources to probe. 

3 Click Operations > Probe All Resources. 

4 Select All Systems to probe the resources on all systems.

You may also select a system on which you want to probe all enabled 
resources.

5 Click OK > Close.

Bringing service group resources online
Use this procedure to bring one or more service group resources online.

To bring one or more service group resources online

1 In the VCS One console, locate the service group that contains the resources 
to bring online. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column.

3 In the right pane, under Resources, select one resource.

4 Click Operations > Online. 

5 Select the system on which you want to bring the resources online. 

6 Click OK > Close.

Taking service group resources offline
Use this procedure to take one or more service group resources offline.
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To take one or more service group resources offline

1 In the VCS One console, locate the service group that contains the resources, 
which you want to take offline. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column.

3 In the right pane, under Resources, select one or more resources. 

4 Click Operations > Offline. 

5 Select the system on which you want to take the resources offline. 

6 Consider the Ignore state of parent Resource option.

This option allows the parent resources to remain online.

7 Click OK > Close.

Cloning service groups
Use this procedure to clone a service group. Clone a service group to make 
several similar service groups without repeating all the steps each time.

Once you have created the service group clone, customize the service group. For 
example, add values for the resources.

To clone a service group

1 In the VCS One console, locate the service group that you want to clone. 

See “Locating a service group” on page 364.

2 Check the service group to clone. 

3 Click Configuration > Clone Service Group. 

4 In the Clone Service Group dialog box, perform the following steps in the 
order presented: 

■ In the Select number of box, click the up arrow to increase the number 
of clones that you want to create. 

The default names of the clones will appear in the Group Name box.

■ If you want to change the default names of the clones, in the Group 
Name box, click the default clone name and enter a new name. 

The default clone name is the name of the service group that you are 
cloning suffixed with _num, where _num is increasing integers starting 
at 0.

5 Click OK > Close.
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Changing a service group’s priority value
Use this procedure to change the service group’s priority value. The service 
group’s priority value determines its importance over other service groups in 
the VCS One cluster. Service groups with higher priority take precedence over 
service groups with lower priority while contending for VCS One cluster 
resources.

To change a service group’s priority value using the VCS One console

1 In the VCS One console, locate the service group for which you want to set 
the priority value. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column.

3 In the right pane, click Priority to edit the Priority attribute. 

4 In the Edit Attribute dialog box, perform the following steps in the order 
presented: 

■ In the Value box, enter a priority value between 1 to 5. 1 denotes 
highest priority while 5 denotes lowest priority.

■ Select the Propagate check box, if you want the new priority value to 
propagate to all service groups in the local dependency tree.

5 Click OK > Close.

To change a service group’s priority value from the command line

◆ At the command prompt, type the following: 
hagrp -modify service_group Priority Priority_value

The priority value must be between 1 and 5. 1 denotes highest priority while 
5 denotes lowest priority.

Changing a service group’s load value
Use this procedure to change the service group’s load value. The service group’s 
load value determines the extent of system resource that the service group 
utilizes. 

To change a service group’s load value using the VCS One console

1 In the VCS One console, locate the service group for which you want to set 
the load value. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column.
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3 In the right pane, click Load to edit the Load attribute. 

4 In the Edit Attribute dialog box, enter a value for each load dimension. 

5 Click OK > Close.

To change a service group’s load value from the command line

◆ At the command prompt, type the following: 
hagrp -changeload [-ejectlowpri|-tryswitch] service_group {key 
value} ... [-user user@domain] [-domaintype domaintype] 

Configuring a service group’s SystemList with a list 
of systems

Use this procedure to define a service group’s SystemList attribute value with a 
list of systems. The service groups’s SystemList determines the systems on 
which the service group can be brought online.

You may also define the SystemList attribute using an organization unit or 
extended attribute expression.

See “Configuring a service group’s SystemList with an expression” on page 395.

To configure the SystemList for a service group using the VCS One console

1 In the VCS One console, locate the service group for which you want to 
configure the SystemList attribute. 

See “Locating a service group” on page 364.

2 Check the service group to configure.

3 Click Configuration > Edit System List. 

4 Move the appropriate systems from the Available Systems list to the 
Selected Systems list using the arrows.

The Available Systems list are the systems that are valid SystemList 
candidates for the service group and for which you have appropriate 
privileges. You can also use the Filter option to filter systems in this view.

The Selected Systems list comprise the systems of the service group’s 
SystemList value. 

5 Use the up and down arrow to sort the systems in the Selected System(s) list 
by priority.

The order of the systems in the SystemList affects some VCS One policy, 
such as the order in which the Policy Master looks for a failover target 
system.



395Managing service groups
Configuring a service group’s SystemList with an expression
6 Select the Propagate check box to propagate the new SystemList to all 
service groups in the local dependency tree. 

7 Click Next > OK > Close. 

To configure the SystemList for a service group using the command line

◆ At the command prompt, type the following: 
hagrp -modify [-propagate] service_group SystemList [-add/-
delete/-update/-refresh] system_name value

See the Veritas Cluster Server One Command Reference Guide.

Configuring a service group’s SystemList with an 
expression

You may configure a service group’s SystemList attribute using an OUValue or 
extended attribute expression. The expression that defines the SystemList 
attribute value is stored in the SystemListExpr attribute.

Using an expression allows the SystemList value to be dynamically updated to 
be any system that matches the expression. 

Note: After you define the SystemList expression, you must refresh the 
SystemList attribute value.

You may also define the SystemList attribute using list of systems.

See “Configuring a service group’s SystemList with a list of systems” on 
page 394.

To configure a service group’s SystemList with an expression using the VCS 
One console

1 Locate the service group for which you want to configure the SystemList 
attribute. 

See “Locating a service group” on page 364.

2 Check one or more service groups to configure.

3 Click Configuration > Edit Attribute(s). 

4 In the Edit Attribute(s) panel, in the list of attributes, click SystemListExpr. 

5 Click For all Group(s) to configure the same value for all the selected groups, 
or click For selected Group(s) if you want to configure different values for 
each selected group.

6 Click the pencil icon to edit the value.
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7 Type the OUValue or extended attribute expression. 

Click + to add a line or - to remove a line in the expression.

8 Click OK.

9 Check the Propagate check box, to propagate the new system list to all 
service groups in the local dependency tree. 

10 Click Next > Finish > Close.

11 Click Operations > Refresh System List.

When you close the Edit Attribute(s) panel, the service groups that you 
selected in step 2 remain checked. These are the same service groups on 
which you perform the Refresh System List operation.

Configuring a service group’s compatibility list 
Use this procedure to configure the compatibility list for a service group. The 
service group’s compatibility list specifies the list of service groups that can 
remain online, on the same system and at the same time, along with the 
specified service group. 

To configure the compatibility list for a service group using the VCS One 
console

1 In the VCS One console, locate the service group for which you want to 
configure the compatibility list. 

See “Locating a service group” on page 364.

2 Check the service group to configure.

3 Click Configuration > Edit Compatibility. 

4 In the Service Group Workload Configuration dialog box, select either the 
Compatible or Incompatible option depending on whether you want to 
specify a list of compatible or incompatible service groups.

■ If you select the Compatible option, do one of the following: 

■ Select the ALLGROUPS check box, to make all the existing service 
groups and the new service groups that you add in future, 
compatible with the service group. 

■ Click Select Service Groups, to add specific service groups that can 
co-exist or are compatible with the service group. Ensure that the 
ALLGROUPS check box is clear. 

In the Service Group Workload Configuration screen, under 
Available Groups, select one or more service groups that you want 
to make compatible with the service group, and then click the 
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right-arrow symbol. Ensure that the selected service groups are 
displayed under Group List. 

■ Click OK. 

If you do not click the Select all groups check box, all the other 
existing service groups as well as new service groups that you add 
in future, are incompatible with the service group. 

■ If you select the Incompatible option, do one of the following: 

■ Select the Select all groups check box, to make all the existing 
service groups and the new service groups that you add in future, 
incompatible with the service group. 

■ Click Edit Selection, to add specific systems that are incompatible 
with the service group. Ensure that the Select all groups check box 
is clear. 

In the Service Group Workload Configuration screen, under 
Available Groups, select one or more service groups that you want 
to make incompatible with the service group, and then click the 
right-arrow symbol. Ensure that the selected service groups are 
displayed under Group List. 

■ Click OK. 

If you do not click the Select all groups check box, all the other 
existing service groups as well as new service groups that you add 
in future, are compatible with the service group. 

■ Click the Propagate check box, to propagate the compatibility or 
incompatibility setting to other service groups that belong to the same 
local dependency tree. 

5 Click OK > Close.

To configure the compatibility list for a service group from the command line

◆ At the command prompt, type one of the following: 

hagrp -[in]compatible [-propagate] group1 group2
[-user user@domain] [-domaintype domaintype]

hagrp -[in]compatible [-propagate] -setname set_name -with -
setname set_name [-user user@domain] [-domaintype domaintype] [-
info]

hagrp -[in]compatible [-propagate] {-ou expression | -ea 
expression | -ou expression -ea expression} -with {-ou 
expression | -ea expression | -ou expression -ea expression} [-
user user@domain] [-domaintype domaintype] [-info]
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The -propagate option propagates the compatibility list values to local 
child and local parent service groups. This includes local service groups 
with soft, firm, and hard group dependencies. 

See “MaxGrpCompatMatrixSize” on page 826.

Configuring a service group’s fault policy 
Use this procedure to configure the fault policy for a service group. The service 
groups’s fault policy defines the service group behavior during a failover 
operation.

Before you perform this task, you must understand the meaning of the values of 
the fault policy attributes.

See “Designing actions taken after a fault” on page 259.

To configure the fault policy for a service group 

1 In the VCS One console, locate the service group for which you want to 
configure the fault policy. 

See “Locating a service group” on page 364.

2 Check one or more service groups.

3 Click Configuration > Edit Fault Policy.

4 In the Edit Fault Policy panel, click GrpFaultPolicy.

5 To set the same value for all selected groups, click Apply to all Groups and 
select a value from the Select Value drop-down menu.

6 To set individual values for each selected group, select the new value on the 
group’s row in the table.

7 Click Propagate to change the value for all service groups linked to this 
service group with a service group dependency.

8 Click NodeFaultPolicy and set values in a similar manner, as appropriate.

9 Click ResFaultPolicy and set values in a similar manner, as appropriate.

10 Click Finish > Close. 

Creating an off-host resource in a service group
A resource is called an off-host resource if the resource and its respective 
service group reside on the local system, while the agent that monitors it is 
located on a remote system. In other words, an off-host resource is a resource 
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that is defined and located on the local system but is monitored and operated 
from a remote system. 

Only a resource of type NetAppExport can be configured as an off-host resource. 
More information is available about off-host resources. 

See “About off-host resources in service groups” on page 297.

See “ControlGroup” on page 876.

See “ControlMode” on page 876.

More information is available about the NetAppExport resource type. 

See Veritas Cluster Server One Bundled Agents Reference Guide.

Note: Not all platforms support the NetAppExport resource type. 
See Veritas Cluster Server One Release Notes.

Creating an off-host resource with NetApp Filer
The following example describes the process to create and configure an off-host 
resource for use with a NetApp Filer. This example uses password free SSH to 
access and update the NetApp Filer. 

Note: You can also set up off-host resources using API access. For API access, it 
is not necessary to setup password free SSH access to the Filer.

Figure 16-1 depicts the off-host resource with NetApp Filer.
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Figure 16-1 Off-host resource with NetApp Filer

Preparing the NetApp Filer
Perform the following tasks on the NetApp Filer: 

■ Create the shared volumes.

■ Add SSH keys to the /etc/sshd/root/.ssh/authorized_keys file. 
Ensure that you add the SSH keys on all the nodes that are listed in the 
control group’s SystemList attribute. This enables VCS One clients to SSH 
into the Filer and update the exports list.

Creating the control group
To create the control group, perform the following steps: 

1 Add the base IP address of all the systems listed in the control group’s 
SystemList attribute to the /etc/hosts file on the Network Appliance 
Filer. This ensures that VCS One clients can communicate with the NetApp 
Filer without depending on an external name service, such as DNS or NIS.
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2 Create a control service group. The SystemList attribute for the control 
group includes VCS One clients with password free SSH access to the 
NetApp Filer.

3 Run the following command on each system listed in the control group's 
SystemList attribute. At the command prompt, type the following: 

ssh netappfilername exportfs

Here netappfilername is the name of the Filer. 

This command verifies password free SSH access for the systems listed in 
the control group's SystemList attribute. It also creates entries for the Filer 
in the list of known hosts in the SSH configuration on the systems that are 
part of the control group’s system list. 

4 Create the following resources in the control group:

■ NetAppFiler 

This resource verifies that the node, which hosts the control group has 
connectivity to the NetAppFiler.

■ NetAppExport

This is a stub resource that notifies VCS One clients to start the 
NetAppExport agent on the host. Set the ControlMode attribute for the 
off-host definition resource to 1 and enable it. This ensures that the 
off-host resource is managed only from the system where the control 
group is currently online. Note that it is mandatory to first set the 
ControlMode attribute value to 1 and then enable the resource.

Creating the local group
To create the local group, perform the following steps: 

1 Add the base IP address of all the systems listed in the local group’s 
SystemList attribute to the /etc/hosts file on the Network Appliance 
Filer. This ensures that VCS One clients can communicate with the NetApp 
Filer without depending on an external name service, such as DNS or NIS. 
Clients that mount the exported file systems must have their base IP 
address listed in the /etc/hosts file on the Network Appliance Filer.

2 Create a local service group with nodeA, nodeB, and nodeC listed in the 
service group’s SystemList attribute. Configure all the resource attributes.

At a minimum, the local service group consists of the following resources:

■ NetAppFiler 

This resource verifies that the application node has connectivity to the 
NetAppFiler. The application node requires connectivity to mount the 
NFS shares.

■ NetAppExport
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This resource defines the parameters that update the exports list on 
the NetApp Filer.

■ Mount

This resource mounts the NFS file systems. Each NFS file system that is 
exported on the NetApp Filer has its own corresponding Mount 
resource.

Linking the local and control service groups
Link the NetAppExport resource in the local service group such that it points to 
the NetApp resource in the control group.

To link the local and control service groups

◆ At the command prompt, type the following:

hares -modify NetAppExport ControlGroup ControlGroup

NetAppExport is the name of the NetAppExport type resource in the local 
service group. ControlGroup is the name of the control group.

Bringing the local group online
Before performing operations on the local group, you must bring the control 
group online. When the NetAppExport resource is brought online it relays the 
online command to the control node. The control node then reaches into the 
NetApp Filer to update the exports list with the appropriate client name. It then 
returns control back to the VCS One client where the rest of the local service 
group is brought online.

Viewing off-host resource sample configuration
The following sample configuration describes an off-host NetAppExport 
resource that is configured for a service group called sg. The SystemList has 
SysA and SysB. The resource specifies sg.filer for the FilerResName attribute. 
All communication with the Filer uses API-access for updating the export option 
for /vol/agentvol/p5 on the Filer.

If the ControlGroup attribute is omitted, the resource definition changes to a 
non-off-host or a local resource definition.
<resource name="hgexport" type="NetAppExport">

<attribute name="ControlGroup"><scalar>"cg"</scalar>
</attribute>
<attribute name="FilerPathName"><scalar>"/vol/agentvol/p5"
</scalar></attribute>
<attribute name="FilerResName"><scalar>"sg.filer</scalar>
</attribute>
<attribute name="ExportACL">
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<val key="SysA">"SysA"</val>
<val key="SysB">"SysB"</val>

</attribute>
</resource>
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Managing composite 
service groups

This chapter includes the following topics:

■ About managing composite service groups

■ Creating a composite service group

■ Listing composite service groups

■ Viewing details about a composite service group

■ Modifying the list of groups in the CSG

■ Modifying the list of VFrames in the CSG

■ Editing a composite service group’s attributes

■ Deleting a composite service group

■ Moving a local composite service group in the organization tree

■ Bringing a composite service group online

■ Taking a composite service group offline

■ Flushing a pending action on a composite service group
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About managing composite service groups
A composite service group is a collection of objects. Use composite service 
groups to manage a group of objects as a single logical object. 

See “About composite service groups” on page 35.

Creating a composite service group
Create a local composite service group when you want to manage multiple 
service groups and VFrames as one logical unit within a single VCS One cluster.

A service group or VFrame may only be part of one composite service group at a 
time.

To add a composite service group using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Click Configuration > Add CSG.

3 Click Next.

4 In the Name text box, enter a name for the composite service group.

5 In the CSG belongs to: field, click the ellipsis to select an organization unit 
to associate with the composite service group. 

In the Select Organization Unit panel, select the organization tree OUValue 
node to which to attach the composite service group.

By default, the CSG is added at /. The ellipsis is disabled if no OUPath has 
been added to the organization tree.

6 Click OK.

7 Click Next.

You may click Finish > Close and configure the rest of the composite service 
group later.

8 In the GroupList Configuration panel, add service groups to the composite 
service group.

The GroupList is the list of service groups contained in the composite 
service group.
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Use the following information to configure the GroupList:

9 Check or uncheck Force.

Use the following information to determine the Force option:

10 Click Next

You may click Finish > Close and configure the rest of the composite service 
group later.

11 In the VFrameList Configuration panel, configure one or more virtual 
machines which are members of the composite service group.

Filter By Use different filters or expressions to narrow the list of 
groups that appear in the Available Groups field. 

If you filter by Name or OUValue, the service groups that 
appear are ones that the user has appropriate permissions 
to view and do not belong to another CSG.

If you filter by a set or an expression, consider the user of 
the Force option.

Available Group(s) Select groups from this area that you want to add to the 
GroupList.

Click the arrow to move the groups to the Selected Groups 
column.

Selected Group(s) Groups that comprise the composite service group’s 
GroupList attribute.

To remove groups from this list, select the group and click 
the arrow to move the groups to the Available Groups area. 

If none of the service groups selected can be added to the 
CSG, an empty CSG is created.

Check Force Even if some of the selected service groups can not be added to 
the GroupList, the remaining service groups are added.

This option can be useful if you use an expression or set name 
for adding groups.

Uncheck Force If some of the selected service groups can not be added to the 
GroupList then the new CSG is not added.
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Use the following information to configure the VFrameList:

12 Check or uncheck Force.

Use the following information to determine the Force option:

13 Click Next

14 In the Cluster List Configuration panel, configure one or more VCS One 
clusters on which the composite service group can run.

If no VCS One cluster, or only the local VCS One cluster, is listed in the 
ClusterList attribute, the composite service group is local. If there are more 
than one VCS One clusters in the ClusterList attribute the composite service 
group may be global.

See “About VCS One global clusters” on page 74.

Filter By Use different filters or expressions to narrow the list of 
VFrames that appear in the Available VFrames field. 

If you filter by Name or OUValue, the VFrames that appear 
are ones that the user has appropriate permissions to view 
and do not belong to another CSG.

If you filter by a set or an expression, consider the user of 
the Force option.

Available VFrames(s) Select VFrames from this list that you want to add to the 
VFrameList.

Click the arrow to move the VFrames to the Selected 
VFrames column.

Selected VFrames(s) VFrames that comprise the composite service group’s 
VFrameList attribute.

To remove VFrames from this list, select the VFrame and 
click the arrow to move the VFrame to the Available 
VFrames area. 

If none of the VFrames selected can be added to the CSG, an 
empty CSG is created.

Check Force Even if some of the selected VFrames can not be added to the 
VFrameList, the remaining VFrames are added.

This option can be useful if you use an expression or set name 
for adding VFrames.

Uncheck Force If some of the selected VFrames can not be added to the 
VFrameList then the new CSG is not added.
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Use the following information to configure the Cluster List:

15 Click Next.

16 Click Finish to execute the operations, or click Back to make changes to the 
commands to be executed.

17 Click Close.

To add a composite service group using the command line

◆ Type the following command to 
hacsg -add csg [ou][-grp [-force] list

Use the following information to replace the appropriate variables:

Listing composite service groups 
The composite service group page lists all the composite service groups that the 
user has permissions to view. 

Available Cluster(s) Select VCS One clusters from this column that you want to 
add to the ClusterList.

Click the arrow to move the VCS One clusters to the Selected 
Cluster(s) column.

Selected Cluster(s) VCS One clusters that comprise the composite service group’s 
ClusterList attribute.

To remove a VCS One cluster from this list, select the VCS One 
cluster and click the arrow to move the cluster to the Available 
Cluster(s) column. 

csg The name of the composite service group.

ou The full path of the OUValue node in the organization tree where the 
composite service group is attached.

list The following formats are valid for the list variable:

■ list of groups or list of VFrames

■ -ea extended attribute expression

■ -ou organization unit expression

■ -setname name of a set

force Add as many groups or VFrames as possible.

See step 9 on page 407
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More information is available on navigation tools, filtering tools, and views in 
the VCS One console.

See “Using the VCS One console” on page 121.

To list composite service group using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

To list composite service groups using the command line

◆ Type the following command
hacsg -list

To view the groups or VFrames in a composite service group using the 
command line

◆ Type one of the following commands
hacsg -groups csg 
hacsg -vframes csg 

Use the following information to replace the appropriate variables

To view the name of a composite service group that a service group or 
VFrame belongs to using the command line

◆ Type one of the following commands:
hagrp -value group CSGName
havframe -value vframe CSGName

Use the following information to replace the appropriate variables

Viewing details about a composite service group

The detail page of a CSG provides the following details about the composite 
service group:

■ Service groups 

■ VFrames

■ VCS One clusters

■ Automation information

csg The name of the composite service group.

group The name of the service group.

vframe The name of the VFrame.
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■ Attributes and their values configured

■ CSG-related logs

To view details about a composite service group using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Click a composite service group in the Name column to go to the detail page 
for that CSG.

Use the following information to view detailed information about 
composite service group:

Service Groups Lists the service groups that are associated with the 
CSG.

Click the name of the service group to go to the details 
page of that service group. Service groups that are not 
hyperlinks indicate a group to which the user does not 
have appropriate privileges.

Click the Groups link to scroll the view to this table.

See “About composite service groups” on page 35.

VFrames Lists the VFrames that are associated with the CSG.

Click the name of a VFrame to go to the details page of 
that VFrame. VFrames that are not hyperlinks indicate a 
VFrame to which the user does not have appropriate 
privileges.

Click the VFrames link to scroll the view to this table.

See “About VFrames” on page 66.

CSG’s Status on 
Configured Clusters

The status of the CSG across all VCS One clusters that 
may run this CSG are listed.

Click the Remote Status link to scroll the view to this 
table.

Click the name of the VCS One cluster to go to the 
details page of that VCS One cluster. 

See “About VCS One global clusters” on page 74.

Automation Information Lists the rules and jobs that are associated with this 
CSG. 

See “About managing automated tasks” on page 455.
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To view a composite service group using the command line

◆ Type the following command
hacsg -display csg

Use the following information to replace the appropriate variable

Modifying the list of groups in the CSG
The GroupList attribute defines the list of service groups that comprise the 
composite service group.

To perform this operation the user must have the following privileges:

■ Modify CSG privilege on the composite service group.

■ Add Group to GroupList privilege or Delete Group from GroupList privilege 
on the service group, depending on the modification.

To modify the group list of the CSG using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Check a composite service group to modify. 

3 Click Configuration > Edit GroupList.

4 In the GroupList Configuration panel, modify the list of service groups that 
comprise the composite service group.

Use the following information to modify the GroupList:

Attributes Lists the attributes that are associated with the CSG. 

Click the pencil icon to edit the value of an attribute. 

Logs The logs link shows the Policy Master logs with an 
applied filter for the CSG name.

csg The name of the composite service group.

Filter By Select different filters to narrow the list of groups that appear 
in the Available Groups field.

Only service groups that the user has appropriate permissions 
to view appear.
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5 Check or uncheck Force.

Use the following information to determine the Force option:

6 Click Finish > Close.

To modify the group list of the CSG using the command line

◆ Type the following command
hacsg -addgrp [-force] csg grouplist 
hacsg -deletegrp [-force] csg grouplist 

Use the following information to replace the appropriate variables

Available Group(s) Select groups from this area that you want to add to the 
GroupList.

Click the arrow to move the groups to the Selected Groups 
column.

Selected Group(s) Groups that comprise the composite service group’s GroupList 
attribute.

To remove groups from this list, select the group and click the 
arrow to move the groups to the Available Groups area.

Check Force Even if some of the selected service groups can not be added to 
the GroupList, the remaining service groups are added.

This option can be useful if you use an expression or set name 
for adding groups.

Uncheck Force If some of the selected service groups can not be added to the 
GroupList then none of the service groups are added.

csg The name of the composite service group.

grouplist The following formats are valid for the grouplist variable:

■ list of groups

■ -ea extended attribute expression

■ -ou organization unit expression

■ -setname name of a set

force Add as many groups as possible.

See step 5 on page 413
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Modifying the list of VFrames in the CSG
The VFrameList attribute defines the list of VFrames (virtual machines) that 
comprise the composite service group.

To perform this operation the user must have the following privileges:

■ Modify privilege on the composite service group.

■ Add VFrame to VFrameList privilege or Delete VFrame from VFrameList 
privilege on the VFrame, depending on the modification.

To modify the Vframe list of the CSG using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Check a composite service group to modify. 

3 Click Configuration > Edit VFrameList.

4 In the VFrameList Configuration panel, modify the list of VFrames that 
comprise the composite service group.

Use the following information to modify the VFrameList:

5 Check or uncheck Force.

Filter By Use different filters or expressions to narrow the list of 
VFrames that appear in the Available VFrames field. 

If you filter by Name or OUValue, the VFrames that appear are 
ones that the user has appropriate permissions to view and do 
not belong to another CSG.

If you filter by a set or an expression, consider the user of the 
Force option.

Available VFrames(s) Select VFrames from this list that you want to add to the 
VFrameList.

Click the arrow to move the VFrames to the Selected VFrames 
column.

Selected VFrames(s) VFrames that comprise the composite service group’s VFrame 
List attribute.

To remove VFrames from this list, select the VFrame and click 
the arrow to move the VFrame to the Available VFrames area. 

If none of the VFrames selected can be added to the CSG, the 
CSG is not created.
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Use the following information to determine the Force option:

6 Click Finish > Close.

To modify the group list of the CSG using the command line

◆ Type the following command
hacsg -addvframe [-force] csg vframelist 
hacsg -deletevfrane [-force] csg vframelist 

Use the following information to replace the appropriate variables

Editing a composite service group’s attributes
Attributes specify the characteristics of the composite service group, and define 
how VCS One controls it.

See “Composite service group attributes” on page 831.

To edit a composite service group’s attributes

1 In the VCS One console, click Manage > Composite Service Groups.

2 Click a composite service group in the Name column to go to the detail page 
for that CSG.

3 In the right pane, click All Attributes.

Check Force Even if some of the selected VFrames can not be added to the 
VFrameList, the remaining VFrames are added.

This option can be useful if you use an expression or set name 
for adding VFrames.

Uncheck Force If some of the selected VFrames can not be added to the 
VFrameList then the new CSG is not added.

csg The name of the composite service group.

vframelist The following formats are valid for the vframe list variable:

■ list of vframes

■ -ea extended attribute expression

■ -ou organization unit expression

■ -setname name of a set

force Add as many vframes as possible.

See step 5 on page 414
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4 In the Edit column, click the pencil icon next to the attribute name you want 
to edit, and modify the value of the attribute.

If there is no pencil icon, you may not edit the attribute.

5 Click Next.

6 On the Summary page, review the prepared edits.

7 Click Finish to execute the changes.

8 Click Close.

To edit a composite service group’s attributes using the command line

◆ Type the following command
hacsg -modify csg attribute [action] value

Use the following information to replace the appropriate variables

Deleting a composite service group
Deleting a composite service group deletes the logical container of the CSG. It 
does not delete the individual service groups or VFrames that are contained in 
the composite service group. 

To delete a composite service group

1 In the VCS One console, click Manage > Composite Service Groups.

2 Check one or more composite service groups to delete. 

3 Click Configuration > Delete CSG(s).

4 Click OK > Close.

To delete a composite service group using the command line

◆ Type the following command
hacsg -delete csg 

Use the following information to replace the appropriate variables

csg The name of the composite service group.

attribute The name of the attribute you want to modify.

action The action for the command, for example, -add or -delete

value The new value for the attribute.

csg The name of one composite service group. 
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Moving a local composite service group in the 
organization tree

A composite service group is attached to the organization tree at an OUValue 
node. The node where the composite service group is attached determines the 
user privileges that are associated with it.

See “About designing roles and privileges for users” on page 250.

To move a composite service group in the organization tree using the VCS 
One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Check one or more composite service groups to move. 

3 Click Configuration > Move CSG(s).

4 In the Organization Unit Selection panel, select the organization tree 
OUValue node to which to attach the composite service group.

5 Consider the Modify Privileges if move invalidates the assigned role of 
users option.

Consider this option in the use case when the composite service group 
moves to an OUValue node that is not in the subtree of the original 
organization tree node. In this case, you must check this option to remove 
privileges from users attached at the original node that are no longer valid 
due to the move of the composite service group. Otherwise, the move is 
rejected.

This option is equivalent to the -updateroles option in the command line.

6 Click Finish > Finish > Close.

To move one or more composite service groups using the command line

◆ Type the following command
hacsg -move csg [csg1] [updateroles] -ou node

Use the following information to replace the appropriate variables:

csg, csg1 The name of the composite service group or groups.

node The full path of the OUValue node in the organization tree to which the 
composite service group is moved.
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Bringing a composite service group online
A composite service group may have a mixture of service groups and VFrames. A 
composite service group is online when all the service groups or Vframes that 
are contained in the composite service group are online. The online operation 
for a CSG performs an online action for each service group or VFrame that is 
contained in the CSG.

If a CSG contains a parallel service group, the online operation will attempt to 
bring online as many instances of the service group as possible, everywhere that 
it can go online.

The propagate option, when used with the online option, initiates the online of 
child service groups or VFrames outside the composite service group on which 
service groups or VFrames inside the CSG depend. The exception to this case is 
if a group inside the CSG is running on an application-aware VFrame that is 
outside the CSG, the propagate option does not bring the VFrame online.

The following conditions result in the rejection of the online operation of the 
composite service group:

■ The GroupList and VFrameList is empty.

■ The composite service group is already online, either in the local cluster, or 
in another cluster in a global cluster environment.

See “About VCS One global clusters” on page 74.

■ The composite service group has the PENDING flag set, which means the 
constituent service groups or VFrames are in transition within the cluster.

■ Any group or VFrame in the CSG is frozen.

■ Any group or VFrame in the CSG has no configured resources.

■ Any group or VFrame in the CSG has all resources disabled.

To perform this operation the user must have the following privilege on the 
composite service group:

■ Online CSG

To bring a composite service group online using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Select one or more composite service groups to bring online.

3 Click Operations > Online CSG(s).

4 The Force option is only valid for global composite service groups.

Use the force option to take over Authority as part of the online operation if 
the cluster on which the CSG had Authority set has gone down.

See “Taking over a global CSG” on page 619.
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5 Consider the Evacuate lower priority Service Groups/VFrames option.

Check this option to offline lower priority service groups or VFrames in 
order to bring a higher priority object online.

This option is the same as the ejectlowpri option in the command line.

6 Check Propagate if you want VCS One to also attempt to bring online all 
child service groups and VFrames outside the CSG that have a dependency 
with service groups inside the CSG.

7 Click OK > Close.

To bring a composite service group online using the command line

◆ Type the following command
hacsg -online [-propagate][ejectlowpri][-force] csg 

Use the following information to replace the appropriate variables:

Taking a composite service group offline
A composite service group is offline when all the service groups and VFrames 
that are contained in the composite service group are offline.

The online operation for a CSG performs an offline action for each service group 
and VFrame that is contained in the CSG. 

If a CSG contains a parallel service group, the offline operation will attempt to 
take offline as many instances as possible, everywhere that it can go offline.

The propagate option, when used with the offline option, initiates the offline of 
child service groups and VFrames outside the composite service group on which 
service groups and VFrames inside the CSG depend. The exception to this case is 
if an service group outside the CSG is running on an application-aware VFrame 
that is inside the CSG, the propagate option does not take offline this service 
group or the VFrame.

csg The name of the composite service group.

propagate The propagate option initiates the online of service groups and 
VFrames outside the composite service group on which service groups 
inside the CSG depend.

ejectlowpri Offline lower priority service groups or VFrames in order to bring a 
higher priority object online.

See “About Priority” on page 316.

force Transfer authority for the CSG to the local VCS One cluster. Only the 
VCS One cluster that has the authority for the CSG may bring it online. 
Applicable to global CSG only.
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To perform this operation the user must have the following privileges on the 
composite service group:

■ Offline CSG

To take a composite service group offline using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Select one or more composite service groups to take offline.

3 Click Operations > Offline CSG(s).

4 Check Propagate if you want VCS One to also take offline all parent service 
groups or VFrames outside the CSG that have a dependency with service 
groups or VFrames inside the CSG.

This option is equivalent to the -propagate option in the command line.

5 Consider the Do not offline application aware VFrames option.

This option takes offline as many service groups and black-box VFrames as 
possible, but does not take offline any application-aware VFrames.

This option is the same as the -novframes option in the command line.

6 Click OK > Close.

To bring a composite service group offline using the command line

◆ Type the following command
hacsg -offline [-propagate] [-novframes] csg 

Use the following information to replace the appropriate variables

Flushing a pending action on a composite service 
group

You flush a pending action on a composite service group to cancel the online or 
offline operation that is currently being performed on the CSG. 

A flush is useful if the online or offline operation of the CSG is not successful. In 
this case, you can flush the CSG, resolve the error, and restart the online or 
offline operation.

csg The name of the composite service group.

propagate Option to also take offline all parent service groups outside the CSG that 
have a dependency with service groups inside the CSG.

novframes Option to take offline service groups and black box VFrames, but to not 
take offline application-aware VFrames.
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The flush operation removes the IntentOnline entry for all groups in the CSG’s 
GroupList and all VFrames in the CSG’s VFrameList. Removing the IntentOnline 
entry prevents VCS One from bringing the CSG online automatically.

In the following conditions, an IntentOnline entry is added for the service group 
or VFrame in the Group Transition Queue (GTQ):

■ A service group or VFrame faults everywhere in the VCS One cluster

■ A service group or Vframe is unable to failover to a different system

■ If a service group or VFrame can not come online from an offline state

See “AttnInfo” on page 831.

You may also need to flush the GTQ to cancel the intent online entry for the 
service groups or VFrames contained in the CSG.

See “Flushing the plan of action on all service groups in the GTQ” on page 381.

To flush a composite service group using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Select one or more composite service groups to flush.

3 Click Operations > Flush CSG(s).

4 Click OK.

5 Take care of the issue that prevented the CSG from coming online.

6 Clear the faults on any service groups or VFrames inside the CSG

See “Clearing a service group fault” on page 386.

See “Clearing a VFrame fault” on page 533.

7 Online the CSG

See “Bringing a composite service group online” on page 418.

To flush a composite service group using the command line

◆ Type the following command
hacsg -flush csg 

Use the following information to replace the appropriate variables

csg The name of the composite service group.
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Managing resources

This chapter includes the following topics:

■ Using the Resource Dependency View

■ Adding a resource to a service group

■ Deleting a resource from a service group

■ Editing resource attributes

■ Modifying zone resource attributes

■ Enabling resources in a service group

■ Disabling resources in a service group

■ Bringing a resource online

■ Taking a resource offline

■ Taking parent and child resources offline concurrently

■ Probing a resource

■ Faulting a resource using the Simulator

■ Repairing a resource using the Simulator

■ Clearing a resource fault
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■ Updating the value of a resource variable
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Using the Resource Dependency View 
The VCS One console provides various views to effectively manage the VCS One 
cluster. This section discusses the different views related to resource 
administration. 

Locating the Resource Dependency View
Use this procedure to locate the Resource Dependency View. You require at least 
Read privileges on the service group to view its resource dependencies.

To locate the resource dependency view

1 In the VCS One console, locate the service group that contains the resources, 
which you want to view. 

See “Locating a service group” on page 364.

2 Check the service group to view.

3 Click Views > Resource Dependencies. 

Performing operations from Resource Dependency View
The resource dependency view displays the existing resource dependencies for a 
service group. 

You can perform the following operations on resources in this view:

■ Bring a resource online

See Bringing a resource online.

■ Take a resource offline 

See Taking a resource offline.

■ Clear resource faults 

See Clearing a resource fault.

■ Link resources 

See Linking resources.

■ Unlink resources

See Unlinking resources.

In large VCS One cluster configurations, the dependency view has many service 
groups and resources on display. You can use the Navigator to increase or 
decrease both the vertical and horizontal space between the objects displayed in 
the dependency view. 

More information is available about how to arrange the dependency view using 
the navigator. 
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See “About the Navigator” on page 154.

Arranging the Resource Dependency View using the Navigator 
In large VCS One cluster configurations, the dependency view has many service 
groups and resources on display. You can use the Navigator to pan or zoom into 
the view. 

See “Summary information on the dependency view” on page 152.

Adding a resource to a service group
Use this procedure to add a resource to a service group.

To add a resource to a service group using the VCS One console

1 In the VCS One console, locate the service group to which you want to add 
the resource. 

See “Locating a service group” on page 364.

2 Check the service group for which to add a resource.

3 Click Configuration > Add/Modify Resource. 

4 In the Add Resource dialog box, perform the following steps for each 
resource to add: 

■ In the Type box, select the resource type.

■ In the Name box, enter the name of the resource. The name of the 
resource cannot exceed 128 characters. 

■ Select the Enable Resource check box, to enable the resource.

■ Click Add Resource, to add the resource to the service group. After the 
resource is added to the service group it displays in the Resource List.

■ In the Resource List, click the Edit icon corresponding to the newly 
added resource. 

■ In the Edit Resource dialog box, do one of following: 

■ Under Attribute List, select the resource attribute. Under Apply to, 
select All Systems in the system list, if the attribute is a global 
attribute and its value is the same for all the systems listed in the 
service group’s SystemList. In the Value box, enter the common 
attribute value. 

■ Under Attribute List, select the resource attribute. Under Apply to, 
select Selected Systems, if the attribute is a local attribute and its 
value is different for all the systems listed in the service group’s 
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SystemList. In the Value box, enter the attribute value for each 
system. 

■ Click OK. 

If any of the mandatory resource attributes are not specified, a warning 
icon displays next to the resource.

■ Click OK > Close.

To add a resource to a service group from the command line

◆ At the command prompt, type the following: 
hares -add resource type group
[-user user@domain] [-domaintype domaintype]

Viewing details about a resource
The detail page of a resource provides low-level information about the resource .

To view details about a resource using the VCS One console

1 In the VCS One console, click Manage > Resources.

2 Click a resource in the Name column to go to the detail page for that 
resource.

Deleting a resource from a service group
Use this procedure to delete a resource from a service group. Prior to deleting a 
resource all the resource dependencies are removed. 

By default, you may not delete an online resource, but you may configure this 
behavior.

See “AllowedOnlineOps” on page 862. 

To delete a resource from a service group using the VCS One console

1 In the VCS One console, locate the service group that contains the resources 
to delete. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the detail page for that 
service group.

3 Check the resource to delete.

4 Click Configuration > Delete Resource. 

5 Click OK > Close.
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To delete a resource from a service group from the command line

◆ At the command prompt, type the following: 
hares -delete resource [-user user@domain] [-domaintype 
domaintype]

Editing resource attributes
You may edit attributes of global scope from the All Attributes page of an 
attribute.

To edit resource attributes using the VCS One console

1 In the VCS One console, locate the service group that contains the resources, 
which you want to modify. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the detail page for that 
service group.

3 In the Resource Name table, click the resource to modify. 

4 Click All Attributes. 

5 In the All Attributes table, locate the attribute to modify.

6 Click the attributes pencil icon. 

The resource attributes that can be modified have a pencil icon. If the pencil 
icon is absent, you may not edit that resource attribute from this page.

7 Use the following information to edit the attribute:

8 Click OK > Close.

Resource Name of the resource

Attribute Name of the resource’s attribute.

Description A short description of the attribute. A more detailed 
description is available.

See “Attributes reference”

All systems in the 

SystemList

Select this option to modify the resource attribute value for all 
the systems listed in the service group’s SystemList attribute.

Selected system Select this option to modify the resource attribute value 
individually for each system. 

Value Type the new resource attribute value for the selected system.
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To edit resource attributes from the command line

◆ At the command prompt, type the following: 
hares -modify resource attribute value [-sys system]
[-user user@domain] [-domaintype domaintype]

Modifying zone resource attributes
Use this procedure to modify zone resource attributes.

To modify zone resource attributes using the VCS One console

1 In the VCS One console, locate the service group that contains the zone 
resource, which you want to modify. 

See “Locating a service group” on page 364.

2 Check the service group to modify.

3 Click Configuration > Add/Modify Resource. 

4 Click OK.

5 In the Results dialog box, click Advanced. 

6 In the Edit Attribute dialog box, under Value, locate the zone resource 
attribute to modify and change its value.

7 Click OK > Close.

Enabling resources in a service group
Use this procedure to enable the resources in a service group. Before you bring a 
resource online, ensure that the resource is enabled and probed. 

To enable resources in a service group using the VCS One console

1 In the VCS One console, locate the service group that contains the resources, 
which you want to enable. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the detail page for that 
service group.

In the service group detail view, options under the menu bar are service 
group-specific operations; options accessed by a right-click are resource-
specific operations.
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3 Use the following information to choose the next step:

4 Click OK > Close.

To enable a resource in a service group using the command line

◆ At the command prompt, type the following: 
hares -modify servicegroup.resource Enabled 1

Disabling resources in a service group
Disable a resource in a service group to prevent it from starting up, or going 
online. You may also use this procedure when you want VCS One to stop 
monitoring the resource while the service group is still online.

You may only disable an online resource. To disable an offline resource, first 
bring the resource online.

To disable resources in a service group using the VCS One console

1 In the VCS One console, locate the service group that contains the resources, 
which you want to disable. 

See “Locating a service group” on page 364.

2 Check the service group to disable.

3 Use the following information to choose the next step:

4 Click OK > Close.

To resources in a service group from the command line

◆ At the command prompt, type the following: 

To enable one or more 
resources

1 Right-click the resource in the Resource Name 
table 

2 Click Operations > Enable Resources

To enable all resources ■ Click Operations > Enable All Resources

To disable one or more 
resources

1 Right-click the resource in the Resource Name 
section 

2 Click Operations > Disable Resources

To disable all resources ■ Click Operations > Disable All Resources
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hagrp -disableresources service_group [-user user@domain] [-
domaintype domaintype]

Bringing a resource online
Use this procedure to bring a resource online. 

To bring a resource online from the Service Groups section

1 In the VCS One console, locate the service group that contains the resource, 
which you want to bring online. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the detail page for that 
service group.

3 Under Resources, right-click the resource to bring online.

4 Click Operations > Online. 

5 In the Online Resource panel, select the system on which you want to bring 
the resource online. 

6 Click OK. 

To bring a resource online from the Resource Dependency View

1 In the VCS One console, locate the service group that contains the resource, 
which you want to bring online. 

See “Locating a service group” on page 364.

2 Check the service group that contains the resource to bring online.

3 Click Views > Resource Dependencies. 

4 In the Resource Dependency View, right-click the resource to be brought 
online

5 Click Online.

6 In the Online Resource panel, select the system on which you want to bring 
the resource online. 

7 Click OK.

To bring a resource online from the command line

◆ At the command prompt, type the following: 
hares -online resource -sys system
[-user user@domain] [-domaintype domaintype] 
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Taking a resource offline

When you take a resource offline, VCS One executes the stop procedure for the 
resource.

To take a resource offline using the VCS One console

1 In the VCS One console, click Manage > Resources.

2 In the right pane, click Operations > Offline

3 In the Offline Resource dialog box, select the system from which you want 
to take the resource offline. 

4 Check the Ignore state of parent resource box, if appropriate.

This option allows the parent resources to remain online. 

5 Click OK. 

To take a resource offline from the command line

◆ At the command prompt, type the following: 
hares -offline [-ignoreparent] resource -sys system
[-user user@domain] [-domaintype domaintype]

The ignoreparent option lets the parent resources remain online. 

Taking parent and child resources offline 
concurrently 

Use this procedure to take a parent resource offline and propagate the command 
to child resources. You can use the Offline Propagate feature to propagate the 
offline state of a parent resource to the child resources. If a parent resource is 
taken offline, all the resources that are dependent on it must be taken offline as 
well.

To take parent and child resources offline concurrently 

1 In the VCS One console, click Manage > Resources.

2 In the right pane, click Operations > Offline Propagate

3 In the Offline Resource dialog box, select the system from which you want 
to take the resource offline. 

4 Click OK. 
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To take a resource offline from the command line

◆ At the command prompt, type the following: 
hares -offline -propagate resource -sys system
[-user user@domain] [-domaintype domaintype]

Probing a resource
Use this procedure to probe a resource. Each resource is periodically monitored 
at specific time interval. The probe operation instantaneously initiates a 
monitor cycle and checks the resource configuration, current resource state, 
and determines if the resource is ready to be brought online. 

To probe a resource using the VCS One console

1 In the VCS One console, locate the service group that contains the resource, 
which you want to probe. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the detail page for that 
service group.

3 In the right pane, under Resources, click the resource to probe.

4 Click Operations > Probe. 

5 In the Probe Resource dialog box, select either all the systems or a 
particular system on which you want the resource to be probed. 

6 Click OK. 

To probe a resource from the command line

◆ At the command prompt, type the following: 
hares -probe resource -sys system
[-user user@domain] [-domaintype domaintype]

More information is available about probing selected resources in a service 
group.

See “Probing service group resources” on page 391.

Faulting a resource using the Simulator
This task is only available using the Simulator, to simulate the fault of a 
resource.
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To simulate a resource fault

1 In the VCS One console, locate the service group that contains the resource 
you want to fault. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the detail page for that 
service group.

3 Check the resource for which you want to simulate a fault. 

4 Click Simulation > Fault Resource. 

5 In the Fault Resource dialog box, select the system on which you want to 
fault the resource. 

6 Click OK.

To simulate a resource fault from the command line

◆ At the command prompt, type the following:

hasim -faultres resource [-sys system] [-grp group]
[-user user@domain -domaintype domaintype] 

Repairing a resource using the Simulator
This task is only available using the Simulator, to simulate a resource repair 
operation.

To simulate a resource repair operation

1 In the VCS One console, locate the service group that contains the faulted 
resource. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the detail page for that 
service group.

3 Check the faulted resource for which you want to simulate a repair 
operation. 

4 Click Simulation > Clear Fault and Online. 

5 In the Simulate Clear Resource dialog box, select the system on which you 
want to clear the resource fault. 

6 Click OK. 

To simulate a resource repair operation from the command line

◆ At the command prompt, type the following:
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hasim -clearresfault resource -sys system [-grp group]
[-user user@domain -domaintype domaintype]

Clearing a resource fault
Use this procedure to clear a resource fault. A resource fault may occur due to 
various reasons, such as a power failure or a faulty configuration. In such a 
situation, you need to clear the resource fault in order to remove the fault and 
make the resource available to go online again. 

To clear a resource fault from the Service Groups section

1 In the VCS One console, locate the service group that contains the faulted 
resource. 

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the detail page for that 
service group.

3 In the right pane, under Resources, click the faulted resource.

4 Click Operations > Clear Fault. 

5 In the Clear Resource dialog box, select the system on which you want to 
clear the resource fault. 

6 Click OK. 

To clear a resource fault from the Resource Dependency View

1 In the VCS One console, locate the service group that contains the faulted 
resource.

See “Locating a service group” on page 364.

2 Check one or more service groups on which to clear resource faults.

3 Click Views > Resource Dependencies. 

4 In the Resource Dependency View, right-click the faulted resource, and then 
click Clear Fault.

5 In the Clear Resource dialog box, select the system on which you want to 
clear the resource fault. 

6 Click OK. 

To clear a resource fault from the command line

◆ At the command prompt, type the following: 
hares -clear resource [-sys system]
[-user user@domain] [-domaintype domaintype]
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hares -clearadminwait [-fault] resource -sys system
[-user user@domain] [-domaintype domaintype]

Clearing resources in the ADMIN_WAIT state
When VCS One sets a resource in the ADMIN_WAIT state, it invokes the 
resadminwait trigger according to the reason the resource entered the state.

You can configure policy regarding a resource in the ADMIN_WAIT state.

See Table 11-1, “ResFaultPolicy values for resource level control of fault 
behavior,” on page 261. 

To clear a resource in the ADMIN_WAIT state using the VCS One console 

1 In the VCS One console, click Manage > Resources.

2 Check one or more resources to clear.

3 Click Operations > Clear Admin Wait. 

4 Click OK. 

To clear a resource in the ADMIN_WAIT state using the command line

1 Take the necessary actions outside VCS One to bring all resources into the 
required state.

2 Verify that resources are in the required state by issuing the command:
hagrp -clearadminwait group -sys system

This command clears the ADMIN_WAIT state for all resources. If VCS One 
continues to detect resources that are not in the required state, it resets the 
resources to the ADMIN_WAIT state.

3 If resources continue in the ADMIN_WAIT state, repeat step 1 and step 2, or 
issue the following command to stop VCS One from setting the resource to 
the ADMIN_WAIT state:
hagrp -clearadminwait -fault group -sys system

This command has the following results:

■ If the resadminwait trigger was called for reasons 0 or 1, the resource 
state is set as ONLINE|UNABLE_TO_OFFLINE.

■ If the resadminwait trigger was called for reasons 2, 3, or 4, the 
resource state is set as FAULTED. Please note that when resources are 
set as FAULTED for these reasons, the clean entry point is not called. 
Verify that resources in ADMIN-WAIT are in clean, OFFLINE state 
prior to invoking this command.

When a service group has a resource in the ADMIN_WAIT state, the following 
service group operations cannot be performed on the resource: online, offline, 
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switch, and flush. Also, you cannot use the hastop command when resources are 
in the ADMIN_WAIT state. When this occurs, you must issue the hastop 
command with -force option only.

Linking resources
Use this procedure to link resources. You can link two or more resources in a 
service group. After you link resources, one resource becomes the parent 
resource and the other the child resource. A child resource must be brought 
online before the parent resource is brought online. 

To link resources from the Service Groups section

1 In the VCS One console, locate the service group that contains the resources, 
which you want to link. 

See “Locating a service group” on page 364.

2 Check the service group that contains the resources to link.

3 Click Configuration > Link/Unlink Resource. 

4 In the Link/Unlink Resource dialog box, perform the following steps for each 
resource pair to create: 

■ In the Parent Resource box, select the parent resource. 

■ In the Child Resource box, select the child resource. Only resources 
that are available as child resources are displayed. 

■ Click Add Link. After the resource dependency between the parent and 
child resources are created they are displayed in the Currently Linked 
list.

5 Click OK. 

To link resources from the Resource Dependency View

1 In the VCS One console, locate the service group that contains the resources, 
which you want to link. 

See “Locating a service group” on page 364.

2 Check the service group that contains the resources to link.

3 Click Views > Resource Dependencies. 

4 In the Resource Dependency View, right-click the parent resource, and then 
click Link.

5 Move the mouse pointer to the child resource. A grey line extends as you 
move the mouse pointer. When the mouse pointer changes to a hand 
symbol, click the child resource.
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6 In the Question dialog box, click Yes.

To link resources from the command line

◆ At the command prompt, type the following: 
hares -link parentresource childresource
[-user user@domain] [-domaintype domaintype]

Unlinking resources
Use this procedure to unlink resources. You can unlink resources only if they are 
previously linked. 

To unlink resources from the Service Groups section

1 In the VCS One console, locate the service group that contains the resources, 
which you want to unlink. 

See “Locating a service group” on page 364.

2 Check the service group that contains the resources to unlink.

3 Click Configuration > Link/Unlink Resource. 

4 In the Link/Unlink Resource dialog box, under Currently Linked, select the 
parent and child pair, and then click the corresponding Remove icon. Repeat 
this step for all the resources to unlink.

5 Click OK.

To unlink resources from the Resource Dependency View

1 In the VCS One console, locate the service group that contains the resource, 
which you want to unlink. 

See “Locating a service group” on page 364.

2 Check the service group that contains the resources to unlink.

3 Click Views > Resource Dependencies. 

4 Right-click the link between the resources to be unlinked, and select Unlink.

5 In the Question dialog box, click Yes.

To unlink resources from the command line

◆ At the command prompt, type the following: 
hares -unlink parentresource childresource
[-user user@domain] [-domaintype domaintype]
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Viewing resources in the configuration by resource 
type

You can view the resources in use in the VCS One cluster by their resource type. 
You can also view the following information in this view:

■ The state of the resources of that type

■ The service groups that contain that resource type

■ The platform on which the resource type runs

■ The date and time the resource type’s configuration was updated

■ The date and time the resource type was created.

To view resources in the configuration by resource type

1 In the VCS One console, click Manage > Resources.

2 Click Views > Resource Types

3 Use the following information to perform further actions:

Defining an attribute value with a resource variable
VCS One allows you use a variable in the definition of certain attribute values. 

See “Designing attribute values using variables” on page 267.

When variables are used in resource attribute values, and you have to change 
what those variables represent, you must refresh the value of the attribute.

See “About designing attribute values using variables” on page 268.

To define an attribute value with a variable using the VCS One console

1 In the VCS One console, locate the service group or the system that contains 
the resources to which you want to define the variable.

See “Locating a service group” on page 364.

2 Click a service group in the Name column to go to the detail page for that 
service group.

To sort the view of the resource types Click the column heading of the table to 
sort by that category.

To view the resources of that type, their 
state, and the corresponding service 
groups

Click the resource type in the name 
column.
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3 Click the resource to which you want to add the variable. 

4 In the right pane, click All Attributes. 

5 In the All Attributes list, locate the resource attribute to modify, and then 
click its corresponding pencil icon to change its value. 

The pencil icon displays next to attributes that are editable.

6 In the Edit Attribute dialog box, under Value, specify the variable in one of 
the supported syntax formats

See “What can be defined using a resource variable” on page 271.

7 Click OK.

To define an attribute value with a variable using the command line

◆ Type the following command 
hares -modify rname aname @{variable}

Use the following information to replace the appropriate variables:

For example, to use the system attribute SysName as a variable in the 
resource attribute MountPath, enter the following:
hares -modify r1 pathname /tmp/@{system.SysName}

Displaying values to be affected by a change in a
resource variables definition

Before you change a built-in attribute value or an extended attribute value, use 
this procedure to ensure you know what resources are affected.

You can not perform this task using the VCS One console.

To display values to be affected using the command line

◆ Type the following command before you modify an attribute value that may 
contain a resource variable. 
hacmd -infovars obj attribute

rname The name of resource.

aname The name of the attribute of the resource that will have a 
variable as a value.

@{variable} The variable that determines the value of the attribute. 

See “What can be defined using a resource variable” on 
page 271.
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Use the following information to replace the appropriate variables:

Updating the value of a resource variable
When variables are used to define the value of an attribute, you must refresh or 
update the value of the attribute under the following conditions:

■ When you move a system, PFrame, VFrame, or service group between nodes 
in the organization tree.

The object is not moved and an error message is logged if one of the 
following items is true:

■ The object has extended attributes that are variables.

■ The values of the variables are not valid in the new location.

To override this behavior and move the object, use the —refreshvars option 
of the command. Doing so will update value of the resource attributes.

■ When you modify the value of a system, PFrame, VFrame, or service group 
attribute that is a resource variable.

The value is not modified and an error message is logged if the object has 
built-in or extended attributes that are variables.

To override this behavior and modify an extended attribute value that is a 
variable, use the —refreshvars option. Doing so will modify the value of the 
resource attributes that use the variable.

To update the value of a resource variable because of a move a system in the 
organization tree 

◆ Type the following command:
hacmd -move -refreshvars objects -ou oupath 

Use the following information to replace the appropriate variables:

hacmd Type hagrp for a group-related attribute or hasys for a 
system-related attribute.

obj The name of the group or the system.

attribute The name of the attribute.

hacmd Replace with hasys to move systems. 
Replace with hagrp to move service groups
Replace with havframe to move VFrames
Replace with hapframe to move PFrames
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To update the value of a resource variable because of modification of an 
attribute value using the command line

◆ Type the following command:
hacmd -modify -refreshvars object attribute value 

Use the following information to replace the appropriate variables:

More options are available for the hasys command and the hagrp command.

See The Veritas Cluster Server One Command Reference Guide.

objects A list of one or more objects. The objects may be systems, 
PFrames, VFrames, or service groups.

oupath The new OUValue path for the object.

hacmd Replace with hasys to move systems. 
Replace with hagrp to move service groups
Replace with havframe to move VFrames
Replace with hapframe to move PFrames.

object The object that the attribute describes. The objects may be 
systems, PFrames, VFrames, or service groups.

attribute The attribute whose value you are editing.

value The new value of the attribute.
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Managing application 
placement

This chapter includes the following topics:

■ About managing application placement

■ Viewing the application placement
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About managing application placement
VCS One enables you to manually designate, or have VCS One automate, the 
decision of where an application will run based on the configuration of certain 
service group, system, and cluster attributes. The set of configuration settings 
that affect this behavior is referred to as the application placement policy. 

This set contains the following attributes:

■ Service group attributes

■ SystemList

■ Priority

■ CompatibleGroups

■ IncompatibleGroups

■ Load

■ System attributes

■ Capacity 

■ Cluster attributes

■ PrecedenceOrder

■ FragmentationPolicy

More information is available on how application placement policy settings 
affect where a service group will run.

See “Designing application and virtual machine placement policy” on page 311.

Additionally, the failover behavior of a service group is decided by the following 
attributes:

■ ResFaultPolicy

■ GrpFaultPolicy

■ NodeFaultPolicy

■ FrameRestartPolicy

Applicable if the service group runs in a virtual machine.

More information is available on the values of these attributes.

See “Designing actions taken after a fault” on page 259.



445Managing application placement
Defining the SystemList attribute for a service group
Defining the SystemList attribute for a service 
group

The SystemList attribute is an ordered list of the names of the systems that the 
service group may run on. The SystemList attribute is the only attribute related 
to application placement policy that must be configured for all service groups. 

If you use a set name in the definition of the SystemList, and an OUValue path is 
not explicitly specified, the service group’s home organization unit is the 
default.

See “Service group attributes” on page 848.

To define the SystemList attribute using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Service Groups tab.

3 From the list of service groups, click the link that is the name of the service 
group you wish to edit.

4 In the right pane, from the Configuration menu, click Edit SystemList.

5 Under Available Systems, select one or more systems, and then click the 
right-arrow icon to add the systems to the service group’s SystemList. 

■ Click the heading Available Systems to arrange the systems in 
ascending or descending alphabetical order. 

■ Select the Filter button if you want to filter the systems that are shown 
in the Available Systems windows based on extended attributes, system 
attributes, organization units, sets or expressions. 

■ Select the No Filter button, if you do not want to set a filter criteria. 

6 Once you have all the required systems in the SystemList box, order the 
SystemList.

To move a system earlier or later in the SystemList, click the name of a 
system. Click the up arrow to the right of the SystemList box to move the 
system earlier in the SystemList, click the down arrow to move the system 
later in the SystemList.

7 If required, click the Propagate check box to make sure the change is 
propagated to all service groups in the same dependency tree.

8 Click OK.

9 Click Close.
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To define the SystemList attribute from the command line

◆ Type the following on the command line:
hagrp -modify <group> SystemList [ -add | -delete ] <system 
value>

Defining service group priority
You define service group priority with the Priority attribute. Valid values are 1 
to 5. 1 is the highest priority, 5 is the lowest priority.

To define service group priority using the VCS One console

1 In the VCS One console, click Manage > Service Groups.

2 From the list of service groups, select the check box corresponding to the 
service group you wish to edit.

3 Click Configuration > Edit Attribute. 

4 From the Attribute Name drop-down list, select the Priority attribute.

5 In the Values box, click the current value, and type in the new value.

6 Consider the Propagate option.

Click the Propagate option to make sure the change is propagated to all 
service groups in the local dependency tree.

7 Click OK > Close.

To define service group priority from the command line

◆ Type the following on the command line:
hagrp -modify <group> Priority <priority_value>

Defining service group compatibility or 
incompatibility

To specify the definition of CompatibleGroups and IncompatibleGroups using 
an expression, you must use the command line interface. If an OUValue path is 
not explicitly specified in the expression, the search for service group begins at 
the user’s home organization unit path node.

To define service group compatibility using the VCS One console

1 In the VCS One console, click Manage > Service Groups.

2 Check the service group on which to define service group compatibility or 
incompatibility.
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3 Click Configuration > Edit Compatibility. 

4 Choose the Compatibility Type. 

Chose Compatible if you want to designate groups in the next step that can 
run on the same system at the same time as the group you are modifying. 
The remaining service groups, and all service groups added in the future, 
will be incompatible with the group being configured.

Choose Incompatible if you want to designate groups in the next step that 
can not run on the same system at the same time as the group you are 
modifying. The remaining service groups, and all service groups added in 
the future, will be compatible with the group being configured.

5 Select the groups you want to apply your chosen Compatibility Type.

■ Click the ALLGROUPS check box to designate all the service groups in 
the VCS One cluster are compatible (if you chose the Compatible 
option) or incompatible (if you chose the Incompatible option) with the 
group being modified.

■ Click the Select Service Groups check box to chose specific service 
groups to apply your chosen Compatibility Type.

Under Available Groups, select one or more groups, and then click the 
right-arrow icon to add the groups to the GroupList. 

■ Click the heading Available Groups to arrange the groups in 
ascending or descending alphabetical order. 

■ Select the Filter button if you want to filter the groups that are 
shown in the Available Groups windows based on extended 
attributes, the Organization Tree, sets or expressions. 

■ Select the No Filter button, if you do not want to set a filter criteria. 

6 Once you have all the required groups in the GroupList box, click OK.

7 Select the Propagate check box if the groups you selected in the previous 
step are part of a local dependency tree. This ensures that all the groups that 
are part of the local dependency have the same set of compatible or 
incompatible groups.

8 Click OK > Close.

To define service group compatibility from the command line

◆ Type the following on the command line:
hagrp -compatible [-propagate] <group1> <group2>
hagrp -compatible [-propagate] <group> ALLGROUPS -force
hagrp -incompatible [-propagate] <group1> <group2>
hagrp -incompatible [-propagate] <group> ALLGROUPS -force

See the Veritas Cluster Server One Command Reference Guide.
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Defining a resource’s fault policy
The failover behavior of a service group, in the event of a service group, a 
system, or a resource fault is decided by taking into consideration the service 
group fault policy, the system fault policy, and the resource fault policy. 

See “Defining a service group’s fault policy” on page 448.

See “Defining a system’s fault policy” on page 449.

To define the resource fault policy

1 In the VCS One console, click Manage > Service Groups.

2 Click a service group in the Name column to go to the detail page for that 
service group.

3 Click the resource for which you wish to specify the resource fault policy.

4 On the right side, click All Attributes.

5 In the list of attributes, click the pencil icon for the ResFaultPolicy attribute.

6 In the Edit Attribute window, in the Value box, select the new value

The attribute value will be one of the following: 
FaultNone, FaultHold, FaultPropagateAll, FaultPropagateParent. 

More information is available on these values. 

See “ResFaultPolicy” on page 880.

7 Click Next.

8 Click Finish > Close.

Defining a service group’s fault policy
The failover behavior of a service group, in the event of a service group, a 
system, or a resource fault is decided by taking into consideration the service 
group fault policy, the system fault policy, and the resource fault policy. 

See “Defining a resource’s fault policy” on page 448.

See “Defining a system’s fault policy” on page 449.

To define the service group fault policy

1 In the VCS One console, click Manage > Service Groups.

2 From the list of service groups, click one or more service groups for which 
you wish to specify the service group fault policy.

3 In the right pane, click Configuration > Edit Fault Policy. 

4 From the Fault Policy box, select GrpFaultPolicy.
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5 Click All Groups or Selected Groups.

If you click Selected Groups, you may set different values for each group. If 
you click All Groups, you set the same value for each group.

6 In the Select Value box, choose Failover or NoFailover. 

More information is available on these values.

See “GrpFaultPolicy” on page 852.

7 Click the Propagate check box if you want the change to be propagated to all 
service groups in the local dependency tree.

8 Click Next.

9 Click Finish > Close.

Defining a system’s fault policy
The failover behavior of a service group, in the event of a service group, a 
system, or a resource fault is decided by taking into consideration the service 
group fault policy, the system fault policy, and the resource fault policy. 

See “Defining a resource’s fault policy” on page 448.

See “Defining a service group’s fault policy” on page 448.

To define the system fault policy

1 In the VCS One console, click Manage > Service Groups.

2 From the list of service groups, click one or more service groups for which 
you wish to specify the service group’s system fault policy.

3 In the right pane, click Configuration > Edit Fault Policy. 

4 From the Fault Policy box, select NodeFaultPolicy.

5 Click All Groups or Selected Groups.

If you click Selected Groups, you may set different values for each group. If 
you click All Groups, you set the same value for each group.

6 In the Select Value box, choose Failover or NoFailover. 

More information is available on these values.

See “NodeFaultPolicy” on page 854.

7 Click the Propagate check box if you want the change to be propagated to all 
service groups in the local dependency tree.

8 Click Next.

9 Click Finish > Close.
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Defining the VCS One cluster’s load and capacity 
keys

The server-farm-wide keys used to designate the values of service group load 
and system capacity are defined in the VCS One cluster’s PrecedenceOrder 
attribute:

To define the VCS One cluster’s load and capacity keys using the VCS One 
console

1 From the VCS One console, click Administration > Settings.

2 In the left pane, click the Global Settings link. 

3 In the right pane, in the Name column, find the PrecedenceOrder attribute.

4 Click the pencil icon in the Edit column of the PrecedenceOrder row.

5 In the Edit Attribute panel, perform one of the following tasks:

■ Click the name of a key in the value column to edit or change the name 
of a key

■ Click the plus sign to add a key. 

There can be a maximum of four keys defined.

■ Click a key name and then click the minus sign to delete a key. You may 
delete a PrecedenceOrder key only if all group loads and system 
capacities have zero values associated with the key.

6 Click OK > Close.

To define the VCS One cluster’s load and capacity keys from the command 
line

◆ Type the following on the command line:
haclus -modify PrecedenceOrder [-add | -delete] key value

Defining service group load
You define service group load with the Load attribute.

To define service group load using the VCS One console

1 In the VCS One console, click Manage > Service Groups.

2 Check one or more service groups to configure.

3 Click Configuration > Edit Attribute.

4 From the Attribute Name drop-down list, select the Load attribute.

The Values box will contain the keys set by the PrecedenceOrder attribute.
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5 In the Values box, click in the value column to edit value of the key.

6 Click OK.

To update a service group load value from the command line

◆ Type the following on the command line:
hagrp -modify <group> Load -update key value

Defining system capacity
You define system capacity with the Capacity attribute.

To define system capacity using the VCS One console

1 In the VCS One console, click Manage > Systems.

2 Check one or more systems to configure.

3 Click Configuration > Edit Attribute. 

4 From the Attribute Name drop-down list, select the Capacity attribute.

5 In the Values box, click in the value column to edit value of the key.

6 Click OK.

To update a system capacity value from the command line

◆ Type the following on the command line:
hasys -modify <sys> Capacity -update key value

Defining the VCS One cluster’s FragmentationPolicy 
attribute

This attribute defines how VCS One automates the choice of a target host system 
for a service group when more than one system is equally qualified in all other 
aspects. 

See “Breaking the tie: the FragmentationPolicy attribute” on page 325.

To define the VCS One cluster’s FragmentationPolicy attribute using the VCS 
One console

1 From the VCS One console, click the Administration tab.

2 In the left pane, click the Global Settings link. 

3 In the right pane, in the Attribute Name column, find the 
FragmentationPolicy attribute.
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4 Click the pencil icon in the Edit column of the FragmentationPolicy row.

5 In the Edit Attribute panel, perform one of the following tasks:

■ Click BiggestAvailable, Heuristic, or BestFit to choose your desired 
behavior.

See “Breaking the tie: the FragmentationPolicy attribute” on page 325.

■ Click <Blank Value> to remove any value from FragmentationPolicy.

6 Click OK > Close.

To define the VCS One cluster’s FragmentationPolicy attribute from the 
command line

◆ Type the following on the command line:
haclus -modify FragmentationPolicy value

Viewing the application placement 
The Workload tab shows service groups arrayed on systems in a variety of 
possible views. This allows the administrator to graphically view the many 
aspects of workload management, including the relative capacity and available 
capacity of systems, or the utilization of a particular system.

The groups listed in the Waiting Groups table on the Workload tab are groups 
that are in the Group Transition Queue (GTQ), waiting for an available resource 
to online as set by the application placement policy.

More information is available on the Workload tab.

See “Workload menus” on page 136.

More information is available on the GTQ

See “About the Group Transition Queue” on page 327.
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Managing automated 
tasks

This document includes the following topics:

■ About managing automated tasks

■ Creating a rule

■ Adding or modifying conditions and filters for the rule

■ Listing rules

■ Displaying the details of a rule

■ Viewing rules and jobs that are associated with an object

■ Cloning a rule

■ Creating a job

■ Associating a job with a rule

■ Cloning a job

■ Modifying a job

■ Running a job

■ Deleting a job

■ Changing the owner of a rule

■ Enabling a rule

■ Disabling a rule

■ Modifying a rule

■ Deleting a rule

■ About configuring tasks
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■ Exporting a rule or a job to an XML file

■ Importing a rule or a job from an XML file
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About managing automated tasks
Automated tasks are configured by setting up rules. Rules can be either business 
rules or notification rules. The components of rules are events, rules, jobs, tasks, 
and notifications.

A rule will not execute unless it is enabled and error-free.

Automated business rules
The following steps describe how an automated business rule flows:

■ An event occurs

■ Conditions are checked

■ A rule is triggered

■ A job is run

■ Tasks in the job are executed

Events are not part of a workflow; the order of job execution in a business rule 
may not be the same as the order of the events that invoke the job. However, 
multiple tasks associated with a job are executed in sequence.

More information is available on the types of tasks you can automate.

See “How you can configure automated tasks and group operations” on page 58. 

The following steps describe the configuration process at a high level:

■ Create a rule

■ Define events that trigger the rule

■ Specify object filtering that can trigger the rule (event-based rules)

■ Define conditions for the rule

■ Create jobs or associate an existing job with the rule 

■ Create a job

■ Define tasks of the job

Further details are available about each of these items.

See “Automated tasks reference” on page 769.

Automated notification rules
The following steps describe how an automatic notification rule flows:

■ An event occurs

■ Notification is sent
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Creating a rule
A rule can be either a business rule or a notification rule.

Creating a business rule 
Business rules are triggered by a Policy Master or a scheduled event, and result 
in the execution of a job. You can also create rules that result in a form of 
notification that the event occurred.

See “Creating a notification rule” on page 459.

To create a business rule using the VCS One console

1 In the VCS One console, click Manage > Business Rules tab.

2 Click Configuration > Add Rule.

3 Click Next.
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4 In the Configure Rule details panel, enter the following information:

5 Click Next.

The type of event you chose in the Trigger using field determines the next 
window. Use the following information to determine your next step:

Name The name for the rule.

Trigger using The type of the event that will trigger the rule. 

Choose one of the following types based on how the event is generated:

■ Click Event for a Policy Master generated event

■ Click Schedule for a schedule generated event.

Description The description for the rule.

Rule belongs to: The path of the OU Node associated with the rule. Click the pencil icon 
to select a path from the organization tree view.

The rule can only access objects in the scope of this organization unit 
path. The scope of this path includes the objects attached at or below 
this OU Node.

Run using 
privilege of:

The owner of the rule. Choose the owner from the drop-down menu.

The owner of the rule determines the user whose privileges will be 
applied when the rule is run.

See “About privileges” on page 250.

Quiet time Controls how often a rule may be triggered for the same object and the 
same event.

The number of seconds to wait after the rule has been triggered, and 
before the rule may be triggered again for the same object and the 
same event. Use this option to prevent overrun of logs or notifications.

Enable this Rule Check to make the rule active. A rule will not execute unless it is 
enabled. 

Type of event in 
Trigger using field

Action

Event See “To define an event that triggers a rule using the VCS 
One console” on page 458.

Schedule See “To define a schedule that triggers a rule using the VCS 
One console” on page 459.
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To define an event that triggers a rule using the VCS One console

1 In the Event Selection window, enter the following information:

2 Click Next.

3 In the Conditions panel, you have the option to define conditions for the 
rule.

See “Adding or modifying conditions and filters for the rule” on page 462.

4 In the Job details panel, you specify the details of a job

See “Creating a job” on page 466.

5 Click Next.

6 Click Finish.

In the Summary panel, you can view the pending commands before they are 
executed. Reverse back through the wizard to modify the commands.

7 Click Close.

Events involving The type of object that will trigger the event. Options are
Group, Composite Service Group (CSG), System, Resource, User, 
UserGroup, PFrame, VFrame, Organization Unit, and Farm.

Select all events Check if you want to select all events of this object type.

Select specific 
events

Check the box next to each event that will trigger this rule. The 
rule will trigger when any one of these checked events occurs.

More information is available about each event.

See Table 32-1, “VCS One Cluster level events and associated 
parameters,” on page 771.  

Specify objects Click the pencil icon to select the specific objects that will 
trigger this rule. 

If you select specific objects, only those objects undergoing the 
selected event triggers the rule.

If you do not select specific objects, any object undergoing the 
selected event triggers the rule.

If you specify an OU expression, any object under that OU node 
that undergoes the selected event triggers the rule.
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To define a schedule that triggers a rule using the VCS One console

1 In the Schedule Configuration window, enter the following information:

2 Click Next.

3 In the Conditions panel, you have the option to define conditions for the 
rule.

See “Adding or modifying conditions and filters for the rule” on page 462.

4 In the Job details panel, you specify the details of a job

See “Creating a job” on page 466.

5 Click Next.

6 Click Finish.

In the Summary panel, you can view the pending commands before they are 
executed. Reverse back through the wizard to modify the commands.

7 Click Close.

Creating a notification rule 
Notification rules are triggered by a Policy Master event, and result in a form of 
notification that the event occurred. You can also create rules that result in the 
execution of a job.

See “Creating a business rule” on page 456.

To create a notification rule using the VCS One console

1 In the VCS One console, click Manage > Notification Rules.

2 Click Configuration > Add Rule 

3 Click Next.

Start Date A start date for the rule.

Start Time The hour and minutes the rule goes into effect. Time is based on 
a 24-hour clock. Rule is run per the time on the web server host.

Create recurrence Check this box to automated repeated execution of the rule.

Daily

Weekly

Monthly

Click one of the recurrence patterns, Daily, Weekly, or Monthly, 
and then select the options that you want relative to that 
pattern.

End recurrence 
by Date

A stop date for the rule.
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4 In the Configure Rule details panel, enter the following information:

5 Click Next.

Name The name for the rule.

Description The description for the rule.

Rule belongs to: The path of the OU Node associated with the rule. Click the pencil icon 
to select a path from the organization tree view.

The rule can only access objects in the scope of this organization unit 
path. The scope of this path includes the objects attached at or below 
this OU Node.

Run using 
privilege of:

The owner of the rule. Choose the owner from the drop-down menu.

The owner of the rule determines the user whose privileges will be 
applied when the rule is run.

See “About privileges” on page 250.

Quiet time Controls how often a rule may be triggered for the same object and the 
same event.

The number of seconds to wait after the rule has been triggered, and 
before the rule may be triggered again for the same object and the 
same event. Use this option to prevent overrun of logs or notifications.

Enable this Rule Check to make the rule active. A rule will not execute unless it is 
enabled. 



461Managing automated tasks
Creating a rule
6 In the Event Selection panel, enter the following information:

7 Click Next.

8 In the Notification Recipients panel, enter the following information:

9 Click Next.

10 Click Finish > Close.

To create a rule using the command line

1 Type the following command to create the rule

Events involving The type of object that will trigger the event. Options are
Group, Composite Service Group (CSG), System, Resource, User, 
UserGroup, PFrame, VFrame, Vobject, Organization Unit, and 
Farm.

Select all events Check if you want to select all events of this object type.

Select specific 
events

Check the box next to each event that will trigger this rule. The 
rule will trigger when any one of these checked events occurs.

More information is available about each event.

See Table 32-1, “VCS One Cluster level events and associated 
parameters,” on page 771.  

Specify objects Click the pencil icon to select the specific objects that will 
trigger this rule. 

If you select specific objects, only those objects undergoing the 
selected event will trigger the rule.

If you do not select specific objects, any object undergoing the 
selected event will trigger the rule.

Specify Email 
recipients

The email address of each person you want to receive an email 
notification if the event occurs.

Check Use Owner’s Email if you want the owner of the rule to 
receive an email notification.

Specify SNMP 
consoles

The name or IP address of the SNMP consoles to which you wish 
to write a log message if the event occurs.

Check Use Owner’s SNMP if you want to include the SNMP 
console of the owner of the rule.

Specify Syslog 
hosts

The name or IP address of the Syslog hosts to which you wish to 
write a log message if the event occurs.



462 Managing automated tasks
Adding or modifying conditions and filters for the rule
harule -add rule objType -oupath path

Use the following information to replace the appropriate variable:

2 Use the harule -modify command to add filtering criteria and specify 
recipients to the newly created rule.

Adding or modifying conditions and filters for the 
rule

Within the rule definition, you can define conditions to evaluate before the job is 
executed. If you define conditions on a rule, the rule only gets executed if the 
conditions are met.

A condition is created in the form of a condition expression, and can be one of 
the following types:

■ Attribute-based condition

See “To add or modify an attribute-based condition to a rule using the VCS 
One console” on page 462.

■ Schedule-based condition

See “To add an scheduled-based condition to a rule using the VCS One 
console” on page 463.

You may define both attribute-based conditions and scheduled-based conditions 
for the same rule.

If you arrive at this procedure from the Rule Configuration Wizard, you start at 
step 3.

To add or modify an attribute-based condition to a rule using the VCS One 
console

1 In the VCS One console, click Manage > Business Rules.

2 Click Configuration > Add/Modify Conditions.

rule The name of the rule.

objType The type of object that will trigger the notification.

path The organization tree node where this rule is attached, 
denoted by the organization tree path
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3 From the Conditions page, enter conditions for the rule. Use the following 
information to perform this task.

4 Click Add.

5 Repeat step 3 and step 4 until you define all your conditions.

6 Click Next or OK > Finish > Close.

The text of this step depends on whether you enter this procedure from the 
Rule Configuration Wizard or from the Add/Modify Conditions menu item.

To add an scheduled-based condition to a rule using the VCS One console

1 In the VCS One console, click Manage > Business Rules.

2 Click Configuration > Add/Modify Conditions.

3 From the Conditions page, enter conditions for the rule. Use the following 
information to perform this task.

Removed the word Frame for Phase One. In 5.0 Phase 2 Add back in Frame 
objects, as appropriately named, to the Specify Object list. -CHECK WITH 
SIM Dawn

Select Condition Type Click Attribute based

Specify Object Click CSG, Group, PFrame, System, or VFrame to select the 
type of object.

Click the pencil icon to select the specific objects of that 
type that apply to this condition.

If you select specific objects, only those objects undergoing 
the selected event will trigger the condition. 

Specify Condition The conditions you can configure depend on the type of 
object you select in the Specify Object field.

Each object has multiple attributes that you can use to 
define a condition. Select the attribute in the first menu.

Select = (equal to) or != (not equal to) in the second menu.

Select the value of the attribute that should cause the 
condition to be true in the third menu.

Select Condition Type Click Time based

Event occurs before Use this option if you want the automation engine to only 
consider this condition true if the event occurs before the 
time you specify.
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4 Click Add.

5 Repeat step 3 and step 4 until you define all your conditions.

6 Click Next or OK > Finish > Close.

The text of this step depends on whether you enter this procedure from the 
Rule Configuration Wizard or from the Add/Modify Conditions menu item.

Listing rules
By default, the VCS One console lists all rules. You may filter the view to limit 
the list of rules. 

To list rules using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Business Rules tab to display the rules that specify what job is 
executed. The rule is triggered by an event or a schedule. The job is a 
collection of one or more actions.

3 Click the Notification Rules tab to display the rules that specify where 
notifications for an event will be sent or logged.

To list rules using the command line

◆ Type the following command to list notification rules
harule -list 

Displaying the details of a rule
The details page of a rule displays the attributes associated with the rule.

To display the details of a rule using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Business Rules tab to display the rules that specify an action that 
is triggered by an event or a schedule.

Event occurs after Use this option if you want the automation engine to only 
consider this condition true if the event occurs after the 
time you specify.

Event occurs between Use this option if you want the automation engine to only 
consider this condition true if the event occurs between two 
designated points in time.
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3 Click the Notification Rules tab to display the rules that specify recipients 
that will receive notification for an event.

To display the details of a rule using the command line

◆ Type the following command to display a notification rule
harule -display rule

Use the following information to replace the appropriate variables:

Viewing rules and jobs that are associated with an 
object

You can view the following automation-related information about objects:

■ Rules defined on the object

■ Rules that refer to the object

■ Jobs that refer to the object

To view rules and jobs that are associated with an object

1 Go to the details page of the object.

2 In the right pane, click Automation Info.

Cloning a rule
Use this procedure to create a new rule that closely resembles a rule already in 
the configuration. Once you clone the rule, edit the new rule as appropriate.

See “Modifying a rule” on page 471.

You may only clone a rule if you are the owner of the rule. You must also have 
the privilege to add a rule.

To clone a rule using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Business Rules tab or the Notification Rules tab.

rule The name of the notification rule to display. If you do not 
specify the rule name, all policy rules and all attributes 
display. Does not display business rules.
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Business rules specify an action that is triggered by an event or a schedule. 
Notification rules specify recipients that will receive notification for an 
event.

3 Click the name of the rule you wish to clone to go to the rule details page.

4 Click Configuration > Clone Rule.

5 In the Clone Rule panel, enter the number of clones of the rule to create.

6 In the Rule Names box, you may select and edit the auto-generated names of 
the clone rules.

7 Click OK.

8 Click Finish > Close.

Creating a job
A job is associated with one or more business rules. Jobs are not associated with 
notification rules.

If you arrive at this procedure from the Rule Configuration Wizard, you start at 
step 4.

To create a job using the VCS One console

1 In the VCS One console, click Manage > Jobs.

2 Click Configuration > Add Job.

3 Click Next.

4 In the Job details page, enter the following information:

Job Name The name for the job.

If the job you want to associate with the event already exists, click the 
down arrow and select the job.

Description The description for the job.

Job belongs 
to:

The path of the OU Node associated with the job. Click the pencil icon 
to select a path from the organization tree view.

The job can only access objects in the scope of this OU Path. The scope 
of this OU Path includes the objects attached at or below this OU Node.

When you create a job from the Add Rule wizard, this field is 
automatically populated with the OU Node configured with the rule.

Add Task Click to go to the Task Details Page, where you can add a new task as 
described in step 5.
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5 In the Task Details Page, use the following information to configure the 
details of the task:

Note: When using action type Execute HA Command, click the Validate 
button to ensure the command is valid and supported.

6 To add this task and return to the Job details page, click OK.

7 Repeat step 5 and step 6 until you define all your tasks for the job.

8 Click Next.

9 Click Finish > Close.

Clone Task Click to duplicate a task. This option is useful to shorten the procedure 
to create a new task that closely resembles a task that already exists.

You can click the pencil icon to edit the details of the task.

Import Job 
Task

Click to import tasks that already exist as part of other jobs.

Select Action Type The action types list the available tasks. 

Once you choose an action type, the panel changes to show the 
configuration details specific to that task.

See Table 32-2, “Predefined task actions and required task 
parameters,” on page 800. 

Halt on Error Click Yes if the job should end if the task fails or does not 
complete by the value in the Timeout field.

Click No if the job should continue even if this task fails.

Timeout Enter the number of seconds to wait for the task to complete. If 
this time period is exceeded, the Halt on Error field is evaluated.

Wait after 
invoking

Enter the number of seconds to wait between invoking this task 
and invoking the next task.

This field can be useful when the task executes a process and you 
want to give the process time to complete.

Task Details The information that appears in the remainder of the panel is 
custom to the selection in the Select Action Type field.

Enter the configuration options specific to the Action Type 
selected.
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Associating a job with a rule
You may create jobs independently from creating rules. A rule can only have one 
job associated with it. A job can be associated to multiple rules.

A job should be attached to the organization tree at the same OU node where the 
rule is attached.

You associate jobs with a rule as part of the procedure to create a rule.

See “Creating a business rule” on page 456. 

Cloning a job
Use this procedure to create a new job that closely resembles a job already in the 
configuration. Once you clone the job, edit the new job as appropriate.

See “Modifying a job” on page 468.

To clone a job using the VCS One console

1 In the VCS One console, click Manage > Jobs.

2 In the right pane, click the link of the job you wish to clone.

3 Click Configuration > Clone Job.

4 In the Clone Job panel, specify the number of clones of the job to create.

5 In the Job Names box, you may select and edit the auto-generated names of 
the clone jobs.

6 Click OK.

7 Click Finish > Close.

Modifying a job
Modify a job using the job details panel. If the job is associated with a Rule, 
modifying the job may invalidate Rules associated to that Job.

More information about the job details page is available.

See “Creating a job” on page 466.

To modify a job using the VCS One console

1 In the VCS One console, click Manage > Jobs.

2 In the right pane, click the link of the job you wish to clone.

3 Click Configuration > Modify Job.
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4 View the impact analysis of modifying this job. Understand the implications 
of modifying this job.

Rules can become invalid due to job modification. This panel displays the 
rules associated with the selected job.

5 Click Next.

6 In the Job details panel, edit the properties of the job.

7 Click Next.

8 Click Finish > Close.

Running a job
Use this procedure to manually initiate the job to run immediately.

To run a job using the VCS One console

1 In the VCS One console, click Manage > Jobs.

2 In the right pane, check the box of job you wish to run.

3 Click Operations > Run Job.

4 In the Job panel, select the number of runs of the job to be executed.

5 If the job has variables defined, enter the values for the variables.

6 Click Next.

7 Click Finish > Close.

Deleting a job
Use this procedure to delete a job. If rules are configured for a job you attempt to 
delete, the list of affected rules are shown.

To delete a job using the VCS One console

1 In the VCS One console, click Manage > Jobs.

2 In the right pane, check one or more jobs that you wish to delete.

3 Click Configuration > Delete Job(s).

4 Click OK > Close.
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Changing the owner of a rule
You can assign the owner of a rule to be any user that is explicitly added to the 
configuration, or any configured user groups.

To change the owner of a rule using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Business Rules tab or the Notification Rules tab.

Business rules specify an action that is triggered by an event or a schedule. 
Notification rules specify recipients that will receive notification for an 
event.

3 Check the rules for which you want to change the owner.

4 Click Operations >Take Rule Ownership.

5 Select the user that you want to own the rule.

6 Click OK > Close.

Enabling a rule
Enabling a rule activates it. Perform the following procedure to enable a new 
rule or re-enable a rule that has been disabled. The Rules console window lists 
the total number of rules, the number of enabled rules, and the number of 
disabled rules.

To enable a rule using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Business Rules tab or the Notification Rules tab.

Business rules specify an action that is triggered by an event or a schedule. 
Notification rules specify recipients that will receive notification for an 
event.

3 Check the rules to enable.

4 Click Operations > Enable Rule.

5 Click OK > Close.

To enable a rule using the command line

◆ Type the following command
harule -enable rule 
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Use the following information to replace the appropriate variable:

This command line is applicable only for notification rules.

Disabling a rule
Disabling a rule deactivates the rule without deleting it. Events cannot trigger a 
disabled rule. 

The Rules console window lists the total number of rules, the number of enabled 
rules, and the number of disabled rules.

To disable a rule using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Business Rules tab or the Notification Rules tab.

Business rules specify an action that is triggered by an event or a schedule. 
Notification rules specify recipients that will receive notification for an 
event.

3 Check the rules to disable.

4 Click Operations > Disable Rule.

5 Click OK > Close.

To disable a rule using the command line

◆ Type the following command
harule -disable rule 

Use the following information to replace the appropriate variable:

This command line is applicable only for notification rules.

Modifying a rule
When you modify a rule using the VCS One console, you follow a similar 
procedure to when the rule was created. When you modify a rule using the 
command line, you modify attribute values.

rule The name of the rule to enable.

rule The name of the rule to disable.
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To modify a rule using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Business Rules tab or the Notification Rules tab.

Business rules specify an action that is triggered by an event or a schedule. 
Notification rules specify recipients that will receive notification for an 
event.

3 Check the rule name to modify.

4 Click Configuration > Modify Rule.

5 Click Next.

6 In the Configure Rule details panel, modify the desired characteristics.

See “To create a business rule using the VCS One console” on page 456.

7 Click Finish > Close.

To modify a rule using the command line

◆ Type the following command
harule -modify rule attribute value

Use the following information to replace the appropriate variable:

Deleting a rule
When you delete a rule, the rule is removed from the VCS One configuration. 
You cannot undo the rule delete command. You may disable a rule to deactivate 
it without deleting it.

See “Disabling a rule” on page 471.

To delete a rule using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Business Rules tab or the Notification Rules tab.

Business rules specify an action that is triggered by an event or a schedule. 
Notification rules specify recipients that will receive notification for an 
event.

3 Check one or more rules to delete.

rule The name of the rule to modify.

attribute The name of the attribute to modify.

value The new value of the attribute.
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4 Click Configuration > Delete Rule.

If the jobs associated with this rule are also associated with other rules they 
will not be deleted.

5 Click OK > Close.

To delete one or more rules using the command line

◆ Type the following command
harule -delete rule

Use the following information to replace the appropriate variables:

About configuring tasks
A task does not exist by itself. It is always part of a job. Define tasks as part of 
the job definition.

See “Creating a job” on page 466.

Exporting a rule or a job to an XML file
You can export rules, jobs, tasks, and their properties to an XML file. This file 
can later be imported for use.

You may use the bpa.xml file to accomplish the following tasks:

■ Edit the rules, jobs, and tasks using an XML editor, rather than the GUI 
interface.

■ Transfer rule definitions and properties between the Simulator and the 
running VCS One installation.

■ Upgrade purposes

To export rule or a job to XML using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click one of the following menu items to select which object type you wish to 
import.

■ Click Jobs to export jobs.

■ Click Business Rules to export rules that result in a task.

■ Click Notification Rules to export rules that result in a notification.

rule The name of the rule to delete. 
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3 In the right pane, check one or more rules or jobs you wish to export.

4 Click Operations.

5 Click Export Rules or Export Job(s) as appropriate.

6 In the File Download popup, click Save.

7 Enter a location to save the file.

8 In the Download complete pane, click Close.

Importing a rule or a job from an XML file
You can import an XML file to the Simulator or an existing VCS One installation. 

You can only import rules or jobs for which the logged in user is the owner.

To import a rule or a job to an XML file using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click one of the following menu items to select which object type you wish to 
import.

■ Click Jobs to import jobs.

■ Click Business Rules to import rules that result in a task.

■ Click Notification Rules to import rules that result in a notification.

3 Click Operations.

4 Click Import Rules or Import Job as appropriate.

5 In the Select file to Import pane, enter or browse to the XML file name to 
import.

6 Click OK.

7 In the Import Rule and/or Jobs pane, select each rule or job you wish to 
import or check Select All.

8 Click OK > Close.
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This section includes the following chapters:

■ “Managing management consoles” on page 477

■ “Managing physical frames (PFrames)” on page 491

■ “Managing virtual frames (VFrames)” on page 505

■ “Managing objects in a VMware environment” on page 537

■ “Managing objects in Solaris zones” on page 549

■ “Managing objects in an LDOM environment” on page 561

■ “Managing objects in AIX Workload Partitions (WPARs)” on page 565
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Managing management 
consoles 

This chapter includes the following topics:

■ About managing management consoles

■ Viewing details of a management console

■ Importing objects from an existing VMware virtual environment into the 
VCS One configuration

■ Adding a management console

■ Synchronizing the virtual environment

■ Moving a management console in the organization tree

■ Associating a vCenter Server management console to a PFrame

■ Disassociating a vCenter Server Management console from an ESX server

■ Associating a management console and a VFrame

■ Dissociating a management console and a VFrame

■ Deleting a management console

■ Editing attributes of a Management Console
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About managing management consoles
You can put a management console, such as VMware vCenter Server under VCS 
One control. 

Configure a management console in VCS One for the following operations:

■ Discovery of the virtual environment

■ Migration of VFrames from one PFrame to another

Viewing details of a management console 
You may view management console in the following views:

■ List view

■ Details view

To view details of a management console in the VCS One console 

1 In the VCS One console, click Manage > Management Consoles.

In the left pane, you may click an organization tree node to filter the view 
the list of management console objects at or below that node. 

2 Click the name of the management console to go to Details view.

Importing objects from an existing VMware virtual
 environment into the VCS One configuration

Use this procedure to allow VCS One to discover your existing VMware 
ESX-based environment rather than manually adding PFrames and VFrames as 
VCS One managed objects.

This procedure is a point-in-time discovery. If the management console that 
corresponds to the ESX environment already exists in the VCS One 
configuration, the import wizard runs in sync mode. Sync mode presents the 
delta between the current ESX environment configuration and the VCS One 
configuration to the user. 

Changes in the virtual environment that occur out of VCS One control must be 
synchronized with the VCS One configuration.

See “Synchronizing the virtual environment” on page 483.

To import objects from an existing virtual environment into the VCS One 
configuration using the VCS One console

1 In the VCS One console, click the Manage > Management Consoles.
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2 Click Configuration > Discover Virtual Infrastructure.

3 Use the following information to fill in the fields:

4 Click Next.

5 In the vCenter Server tree structure, use the following information to view 
and import objects 

Virtualization Technology Choose VMwareVC for a VMware vCenter Server 
management console.

Virtual Center Name Choose a name for the VMwareVC object.

Use the fully-qualified domain name of the system 
on which VMware vCenter Server is installed.

API URL The location of the VMware vCenter Server as 
defined by VMware. This URL may be secure or non-
secure. Typically this URL is:

https://vCenter_Server_name/sdk

You may enter any information in this field when 
using the simulator.

User Name The user name that is used to log in to the VMware 
vCenter Server, for example, Administrator. This 
user must have the following privileges in the 
vCenter Server server:

Perform all operations on all ESX servers

Perform all operations on all virtual machines

You may enter any information in this field when the 
simulator.

Password The password that authenticates the user name.

You may enter any information in this field when 
using the simulator.

Select OU path to which VMware 
vCenter Server will be attached

Click the ellipsis to select an organization unit to 
associate with the management console. 

DataCenter node Click a DataCenter node to view the list of PFrames, 
and the corresponding VFrames configured on each 
PFrame.
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6 Click Next.

7 The commands to be executed display.

8 Click Finish > Close.

To import objects from an existing virtual environment into the VCS One 
configuration using the command line

Perform the following steps in the order presented:

■ Add the object

■ Configure the username 

■ Configure the password

■ Configure the API URL

To add the object that corresponds to the vCenter Server to the VCS One 
configuration using the command line

◆ Type the following command
havobject -add managementconsole VMwareVC

Use the following information to replace the appropriate variables:

To configure the Username attribute for the VMware vCenter Server frame 
object using command line

◆ Type the following command
havobject -modify managementconsole Username logon

PFrame node Click a PFrame node to view the following tabs:

General: Displays value of important attributes of 
PFrame or corresponding VFrame.

Datastores: Displays datastores associated with the 
PFrame.

Network: Displays networks associated with the 
PFrame.

{...} Click the ellipsis to select the organization unit in 
VCS One to associate with all the discover objects 
from the ESX environment.

managementconsole The name of the VMwareVC Management Console in the VCS 
One configuration.
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Use the following information to replace the appropriate variables:

To configure the Password attribute for the VMware vCenter Server frame 
object using command line

You must encrypt the password. 

1 Encrypt the password. Type the following command:
haencrypt -agent

2 Enter your choice of password at the Enter New Password prompt.

3 Re-enter your password at the Enter Again prompt.

4 Write down the output of the command to use in step 5.

5 Type the following command
havobject -modify managementconsole Password epassword

Use the following information to replace the appropriate variables:

To configure the APIUrl attribute for the VMware vCenter Server frame object 
using command line

◆ Type the following command
havobject -modify managementconsole APIUrl path

Use the following information to replace the appropriate variables:

managementconsole The name of the VMwareVC Management Console in the VCS 
One configuration.

logon The user name that is used to log in to the VMware Virtual 
Center. For example, Administrator

managementconsole The name of the VMwareVC Management Console in 
the VCS One configuration.

epassword The password that is generated from the output of the 
haencrypt command in step 4.

managementconsole The name of the VMwareVC Management Console in the 
VCS One configuration.

path The path that is used to log in to the VMware Virtual 
Center. For example, https://vCenter Server.domain.com/
sdk
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Adding a management console
VCS One can interface with one or more VMware vCenter Server Management 
consoles to monitor and control its associated ESX servers and virtual machines. 

Before you add a management console to the VCS One configuration,   
understand the relationship between virtualized objects.

See “How VCS One manages a virtualized environment” on page 66.

An example management console is a VMware vCenter Server. 

To add a management console to the configuration using the VCS One 
console

1 In the VCS One console, click the Manage > Management Consoles.

2 Click Configuration > Add Management console.

3 Use the following information to fill in the fields:

Virtualization Technology Choose VMwareVC for a VMware vCenter Server 
management console.

Virtual Center Name Choose a name for the vCenter Server.

Use the fully-qualified domain name of the system 
on which vCenter Server is installed.

API URL The location of the VMware vCenter Server as 
defined by VMware. This URL may be secure or non-
secure. Typically this URL is:

https://vCenter_Server_name/sdk

You may enter any information in this field when 
using the simulator.

User Name The user name that is used to log in to the VMware 
vCenter Server, for example, Administrator. This 
user must have the following privileges in the 
vCenter Server server:

■ Perform all operations on all ESX servers

■ Perform all operations on all virtual machines

You may enter any information in this field when the 
simulator.

Password The password that authenticates the user name.

You may enter any information in this field when 
using the simulator.
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4 Click Finish.

5 In the Summary panel, click Finish to run the commands.

6 Click Close.

To add a management console to the configuration using the VCS One 
command line

1 Type the following command to add the management console
havobject -add vc_name VMwareVC path

2 Type the following command to set the URL to the management console
havobject -modify vc_name APIUrl URL

3 Type the following command to set the user name to the management 
console
havobject -modify vc_name Username username

4 Type the following command to set the password to the management 
console
havobject -modify vc_name Password password

Use the following information to replace the appropriate variables:

Synchronizing the virtual environment
Use this procedure to synchronize your virtual environment with the VCS One 
configuration. 

Synchronize when changes exist in the VMware configuration that VCS One 
manages. The following events are examples of such changes:

■ A new virtual machine is created

Select OU path to which Virtual 
Center will be attached

Click the ellipsis to select an organization unit to 
associate with the management console. 

vc_name The name of the management console.

path The node where the management console is attached in the organization 
tree.

URL The location of the management console. 

As defined by VMware, typically this URL is: https://vc_name/sdk

username The user name that is used to log in to the management console 

password The password that authenticates the Username.
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■ A new ESX host is added to the datacenter

■ A new datastore or network is added to an existing virtual machine.

To synchronize the virtual environment using the VCS One console

1 In the VCS One console, click the Manage > Management Consoles.

2 Click Configuration > Synchronize.

3 Use the following information to fill in the fields:

4 Click Next.

VCS One now tries to discover the virtual center configuration, then it 
compares the virtual center configuration with the VCS One configuration. 
The following results are possible:

Virtualization Technology Choose VMwareVC for a VMware vCenter Server 
management console.

Virtual Center Name Choose a name for the vCenter Server.

Use the fully-qualified domain name of the system 
on which vCenter Server is installed.

API URL The location of the VMware vCenter Server as 
defined by VMware. This URL may be secure or non-
secure. Typically this URL is:

https://vCenter_Server_name/sdk

You may enter any information in this field when 
using the simulator.

User Name The user name that is used to log in to the VMware 
vCenter Server, for example, Administrator. This 
user must have the following privileges in the 
vCenter Server server:

■ Perform all operations on all ESX servers

■ Perform all operations on all virtual machines

You may enter any information in this field when the 
simulator.

Password The password that authenticates the user name.

You may enter any information in this field when 
using the simulator.

Select OU path to which Virtual 
Center will be attached

Click the ellipsis to select an organization unit to 
associate with the management console. 
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■ No change: This is indicated by the respective object icons, for example, 
PFrame icon or VFrame icon.

■ Object added: This is indicated by a ‘+’ icon overlaid on the respective 
object icon.

■ Object modified: This is indicated by a pencil icon overlaid on the 
respective object icon.

■ Object deleted: This is indicated by an ‘x’ icon overlaid on the 
respective object icon.

5 After the discovery is complete: 

a Select one of the datacenters to be synced with the VCS One 
configuration, and then click Next. 

The wizard lists the appropriate commands.

b Click Finish to run the commands.

6 Click Close.

Moving a management console in the organization 
tree

This procedure moves a ManagementConsole object from one organization tree 
node to another.

To move a management console in the Organization Tree using the VCS One 
console

1 In the VCS One console, click the Manage > Management Consoles.

2 Check the name of the vCenter Server Management Server you wish to 
move.

3 Click Configuration > Move Management Console(s).

4 In the Organization Unit Selection panel, click the OUValue node where you 
want to move the selected management console.

5 Click Next.

The Assign values to Extended Attributes page displays. It shows common 
EA values if they are defined on the target OUValue node selected.

6 In the Assign values to Extended Attributes page, click the Value drop-down 
arrow and select the EA value.

7 Click Next > Finish > Close.
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To move a management console in the Organization Tree using the VCS One 
command line

◆ Type the following command 
havobject -move managementconsole -ou path

Use the following information to replace the appropriate variables:

Associating a vCenter Server management console 
to a PFrame 

Associate a PFrame to a Management Console to use the following features:

■ Live migration

See “Migrating a VFrame to a different PFrame” on page 531.

■ CPU and memory reservations

See “Configuring guaranteed resource reservations for a VFrame” on 
page 514.

To associate a VMware vCenter Server Management console to a PFrame 
using the VCS One console

1 In the VCS One console, click the Manage > PFrames.

2 Click the PFrame you wish to associate.

3 Click Configuration > Associate Management Console.

4 Select the management console to associate with this PFrame.

5 Click OK > Close.

To associate a VMware vCenter Server Management console to a PFrame 
using the command line

◆ Type the following command
hapframe -associate pframe managementconsole

Use the following information to replace the appropriate variables:

managementconsole The name of vCenter Server Management console object.

path The new OUvalue path for the object.

pframe The name of the PFrame object that represents the ESX server.

managementconsole The name of the VMware vCenter Server Management console.
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Disassociating a vCenter Server Management
console from an ESX server

Dissociate a PFrame from a Management Console when you no longer use the 
following features:

■ Live migration

■ CPU and memory reservations

To disassociate a VMware vCenter Server Management console from a 
PFrame using the VCS One console

1 In the VCS One console, click the Manage > PFrames.

2 Click the management console you wish to unlink.

3 Click Configuration > Dissociate Management Console.

4 Click the PFrame you wish to dissociate.

5 Click OK > Close.

To disassociate a VMware vCenter Server Management console from a 
PFrame using the command line

◆ Type the following command
hapframe -dissociate pframe managementconsole

Use the following information to replace the appropriate variables:

Associating a management console and a VFrame
Associating a management console and a VFrame enables you to migrate a 
VFrame directly from VCS One. If there is no association, then you have to 
perform the migration from the Virtual Center.

To associate a VMware vCenter Server Management console to a VFrame 
using the VCS One console

1 In the VCS One console, click the Manage > VFrames.

2 Check the VFrame you wish to associate.

3 Click Configuration > Associate Management Console.

4 Select the management console to associate with this VFrame.

pframe The name of the PFrame object that represents the ESX server.

managementconsole The name of the VMware vCenter Server Management console.
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5 Click OK > Close.

To associate a VMware vCenter Server Management console to a VFrame 
using the command line

◆ Type the following command
havframe -associate vframe managementconsole

Use the following information to replace the appropriate variables:

Dissociating a management console and a VFrame
Dissociating a management console and a VFrame disables the migrate 
operation of a VFrame from VCS One.

To dissociate a management console and a VFrame using the VCS One 
console

1 In the VCS One console, click Manage > VFrames.

2 Check the VFrame you wish to dissociate.

3 Click Configuration > Dissociate Management Console.

4 Click OK > Close.

To dissociate a VMware vCenter Server Management console to a VFrame 
using the command line

◆ Type the following command
havframe -dissociate vframe managementconsole

Use the following information to replace the appropriate variables:

vframe The name of the VFrame object that represents the virtual 
machine.

managementconsole The name of the VMware vCenter Server Management console.

vframe The name of the VFrame object that represents the virtual 
machine.

managementconsole The name of the VMware vCenter Server Management console.
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Deleting a management console
Deleting a management console deletes the VMware Management Console 
object from the VCS One configuration. You may also delete the management 
console from the management console’s detail page.

This operation does not delete the PFrames and VFrames objects associated with 
the management console.

To delete a management console from the configuration using the VCS One 
console

1 In the VCS One console, click the Manage > Management Consoles.

2 Click Configuration > Delete Management console(s).

3 Consider the Forcefully dissociate all the associated PFrame(s) and 
VFrame(s) option.

Check this option if you want to unlink the management console from any 
PFrames and VFrames before deletion. 

This option is equivalent to the -force option.

4 Click OK > Close.

To delete a management console using the command line

◆ Type the following command
havobject -delete mc_name [-force]

Use the following information to replace the appropriate variables:

Editing attributes of a Management Console
Attributes specify the characteristics of the VCS One object, and define how VCS 
One controls it.

From the All Attributes page of an object, you may edit attributes of global 
scope. 

To edit attributes of a Management Console

1 In the VCS One console, click Manage > Management Consoles.

2 Click a Management Console to go to the details page.

managementconsole The name of the ManagementConsole.

force Use the force option to dissociate any PFrames or VFrames to 
this management console.
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3 In the right hand side, click the All Attributes link.

4 In the Edit column, click the pencil icon next to the attribute name you want 
to edit, and modify the value of the attribute.

If there is no pencil icon, you may not edit the attribute.
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Managing physical frames 
(PFrames)

This chapter includes the following topics:

■ About managing physical frames

■ Viewing virtualization types

■ Adding an PFrame

■ Viewing details about a PFrame

■ Deleting a PFrame

■ Freezing a PFrame

■ Unfreezing a PFrame

■ Stopping the client daemon on a PFrame

■ Faulting a PFrame in the DDNA state

■ Editing an attribute for a PFrame type

■ Editing an attribute for a instance of a PFrame

■ Editing the extended attributes of a PFrame

■ Editing a PFrame attributes from the All Attributes page

■ Moving a PFrame in the organization tree

■ Moving an ESX Server from one VMware VirtualCenter to another

■ Starting a PFrame in the Simulator

■ Faulting a PFrame in the Simulator

■ Simulating a PFrame in ddna state
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About managing physical frames
A PFrame is a virtualization-based object. A PFrame is a VCS One object that 
represents an operating system that is capable of running one or more virtual 
machines.

PFrames are categorized by the type of virtualization technology they run. 

The following objects are examples of PFrames:

■ VMware ESX Server

ESXServer object type.

■ LDom Server

LDomsServer object type

See “How VCS One manages a virtualized environment” on page 66.

Viewing virtualization types
Use this procedure to display all the types of VCS One virtual objects.

To view virtualization types using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, click Views > VTypes.

Adding an PFrame 
Use this procedure to add a PFrame manually. If you place VMware ESX Servers 
under VCS One control, you may also add PFrames through a discovery process.

See “Importing objects from an existing VMware virtual environment into the 
VCS One configuration” on page 478.

To add a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 Click Configuration > Add PFrame.

3 Use the following information to fill in the fields of the Add PFrame panel:

Name Enter a name for the PFrame object in the VCS One 
configuration.



493Managing physical frames (PFrames)
Adding an PFrame
4 Click Next.

You may also click Finish to jump to the Summary panel, as denoted in 
step 9. If you click Finish, the Pframe has the following characteristics:

■ It is attached at the root (/) OU Node.

■ Extended attributes have the default value.

■ No fault policy is configured.

5 Select an organization unit to associate with the PFrame.

6 In the Organization Unit Selection panel, click an OUValue node to associate 
with this PFrame.

See “About the Organization Tree” on page 36.

7 Assign values to applicable extended attributes.

If this panel does not appear, there are no extended attributes applicable for 
this PFrame.

8 Click Next.

9 In the Summary panel, click Finish to run the commands.

10 Click Close.

To add a PFrame using the command line

◆ Type the following command
hapframe -add name -vtype type [path]

Use the following information to replace the appropriate variables:

VType Choose one of the following virtualization types, 
depending on the PFrame technology:

■ ESXServer

■ LDomsServer

Management Console [optional] If the PFrame is an ESX Server, you may 
optionally enter the name of the corresponding 
VMware VirtualCenter management console.

Migration of a VFrame from one PFrame to another 
requires the VFrame and the PFrame to have a 
management console association.

Configure advanced workload 
management

Check if you want to configure Capacity settings for 
this PFrame.

See “About Load and Capacity” on page 55. 

name The name of the PFrame.
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Viewing details about a PFrame
The detail page provides the following details about the PFrame:

■ State

■ Workload management 

■ VFrames, including their state and workload management

■ Service groups

■ Storage 

■ Extended attributes

To view details about a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 Click the name of the PFrame to go to the detail page for that PFrame. 

Use the following information to view detailed information about the 
PFrame:

type The vtype of the PFrame.

path The organization tree path at which to attach the PFrame. The default 
value is the root node /.

Privileged Infrastructure 
VFrames configured on this 
Pframe

Lists the VFrame that are associated with this PFrame.

Click the name of the VFrame to go to the details page of 
that VFrame. VFrame that are not a hyperlink indicate a 
VFrame to which the user does not have appropriate 
privileges.

Privileged Infrastructure 
Service Groups configured 
on this PFrame

Lists the infrastructure service groups that are 
associated with this PFrame.

Click the name of the service group to go to the details 
page of that service group. Service groups that are not a 
hyperlink indicate a group to which the user does not 
have appropriate privileges

Storage Configured Storage configured on this PFrame.

Network Configured Networks configured on this PFrame.
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To view details about a PFrame using the command line

◆ Type the following command
hapframe -display pframe

Use the following information to replace the appropriate variable

Deleting a PFrame
Deleting a PFrame removes it from the configuration.

You can not delete a PFrame that is in the RUNNING state, or has one or more 
VFrames running on it. Before deleting a PFrame, you must first stop the client 
daemon running on the PFrame.

See “Stopping the client daemon on a PFrame” on page 497.

To delete a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, select one or more PFrames. 

3 Click Configuration > Delete PFrame(s).

4 Click OK > Close.

To delete a PFrame using the command line

◆ hapframe -delete pframe

Freezing a PFrame
Freezing a PFrame enforces the following conditions: 

■ A virtual machine hosted on the PFrame can not failover to another system.

■ A virtual machine hosted on another PFrame or system can not come online 
on the frozen PFrame through a failover operation. 

Extended Attributes Lists the extended attributes that are associated with 
this PFrame

All Attributes Lists all the attributes that are associated with this 
PFrame. 

Logs Click this link to go view the Policy Master logs with the 
filter of this PFrame applied.

pframe The name of the pframe.
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■ A manual switch of a virtual machine from the frozen PFrame is allowed.

■ A manual switch of a virtual machine to the frozen PFrame is not allowed.

Freezing a PFrame is useful when you want to stop actions, such as 
maintenance activities, from triggering a virtual machine failover.

See “Freezing a VFrame” on page 532.

To freeze a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, select one or more PFrames. 

3 Click Operations > Freeze.

4 Consider the Evacuate all running VFrames option.

Check this option if all virtual machines running on this PFrame should be 
evacuated.

Evacuation will take the virtual machines offline and VCS One will search 
for new PFrame target hosts. View the logs and the GTQ to ascertain the 
results of the evacuation operation.

5 Click OK > Close.

To freeze a PFrame using the command line

◆ hapframe -freeze [-evacuate] pframe

Unfreezing a PFrame
Unfreezing a PFrame removes the restrictions of the frozen condition.

See “Freezing a PFrame” on page 495. 

To unfreeze a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, select one or more PFrames. 

3 Click Operations > Unfreeze.

4 Click OK > Close.

To unfreeze a PFrame using the command line

◆ hapframe -unfreeze pframe
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Stopping the client daemon on a PFrame
Use this procedure to stop the client daemon on a PFrame. Stop the client 
daemon on a PFrame before you delete the server from the configuration, or for 
certain maintenance tasks.

This procedure does not stop the virtual machines and corresponding service 
groups that are online on the PFrame unless you use the propagate option.

To stop the client daemon on a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, select one or more PFrames. 

3 Click Operations > Stop PFrame(s).

4 Consider the Propagate option.

Select Propagate while stopping the PFrame client to also simultaneously 
accomplish the following tasks:

■ Take offline the VFrames running on the PFrame.

■ Take offline any service groups that are dependent on those VFrames.

5 Click OK > Close.

To stop the client daemon using the command line

◆ Type the following command. 
hastop -client -pframe pframe(s) [[-actonnodefault] -force | 
[-propagate] -evacuate]

Faulting a PFrame in the DDNA state
Use this procedure to fault a PFrame that is in the DDNA state. 

When a PFrame is in DDNA state, VCS One can no longer manage the virtual 
machines and corresponding applications. 

See “Policy Master detects loss of heartbeat, ping command responds” on 
page 54.

When you fault the PFrame, the virtual machines running on the PFrame will 
follow the fault policy configured for the cluster, which should allow VCS One to 
resume management operations.

To fault a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, select one or more PFrames. 



498 Managing physical frames (PFrames)
Editing an attribute for a PFrame type
3 Click Operations > Mark as Faulted.

4 Click OK.

To fault a PFrame using the command line

◆ hapframe -fault pframe

Editing an attribute for a PFrame type
When you change the value of an attribute at the type level, you affect the 
definition of all future objects of that type added to the cluster.

For example, if you change the FrameRestartPolicy attribute in the ESXServer 
Type definition, you change FrameRestartPolicy attribute default value for all 
future objects of Type ESXServer added to the server farm. 

You may also change the value of an attribute only for an individual instance of 
an object. If you want to change the value of an attribute for only one specific 
object of Type PFrame. 

See “Editing an attribute for a instance of a PFrame” on page 498.

To edit an attribute for a PFrame type using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, click Views > VTypes.

3 Click ESXServer.

4 Click the pencil icon in the Edit column next to the attribute name you wish 
to edit.

If there is no Edit icon, the attribute is not editable.

5 In the Edit Attribute window, enter a value in the Value text box.

6 Click Next > Close.

Editing an attribute for a instance of a PFrame 
Use this procedure to edit the value of an attribute only for one or more 
individual instances of the PFrame. If you want to change the value of an 
attribute for all future objects of type PFrame do not use this procedure.

See “Editing an attribute for a PFrame type” on page 498.

To edit an attribute for a instance of a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, check one or more PFrames. 
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3 Click Configuration > Edit Attribute(s).

4 In the Edit Attribute(s) panel, perform the following steps for each attribute 
that you want to edit: 

■ In the Attribute(s) column, select the attribute that you want to modify. 
Only attributes that can be modified are displayed in this list. The 
current value of the attribute displays.

■ Click For all PFrame(s) to configure the same value for all the selected 
PFrames. Click the pencil icon to edit the value.

■ Click individual PFrames if you want to configure different values for 
each selected PFrame. Click the pencil icon in the corresponding row to 
edit the value.

5 Click Next.

6 In the Summary panel, click Finish to execute the commands.

7 Click Close.

To edit an attribute for an instance of a PFrame using the command line

◆ Use the following command 
hapframe -modify

See “PFrame attributes” on page 906.

Editing the extended attributes of a PFrame
Use this procedure to edit the extended attributes of a PFrame object. 

You can not add extended attributes from this wizard.

See “About extended attributes” on page 632.

See “Defining an extended attribute” on page 634.

To edit the extended attributes of a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, check one or more PFrames. 

To change the extended attributes of more than one PFrame 
simultaneously, they must have common extended attributes.

3 Click Configuration > Edit Extended Attribute(s).

4 In the Edit Extended Attribute(s) panel, perform the following steps for 
each attribute that you want to edit: 
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■ In the Extended Attribute(s) column, select the attribute that you want 
to modify. Only attributes that can be modified are displayed in this 
list.

■ Click Apply to all PFrame(s) to configure the same value for all the 
selected PFrames. Select a new value from the drop-down menu

■ Click individual PFrames if you want to configure different values for 
each selected PFrame. Select a new value from the drop-down menu in 
that row.

5 Click Set Default Values to convert the value of the selected PFrame to the 
default value. 

6 Click Restore Old Values to restore the value of the currently selected 
extended attribute to the configured value before starting this instance of 
the wizard for all PFrames.

7 Click Next.

8 In the Summary panel, click Finish to execute the commands.

9 Click Close.

To edit an attribute for a PFrame using the command line

◆ Use the following command 
hapframe -modify

Editing a PFrame attributes from the All Attributes 
page

Attributes specify the characteristics of the PFrame, and define how VCS One 
controls it.

See “PFrame attributes” on page 906.

To edit a PFrame’s attributes from the All Attributes page using the VCS One 
console

1 In the VCS One console, click Manage > PFrames.

2 Click the name of a PFrame to go to the details page. 

3 In the right pane, click All Attributes.

4 In the Edit column, click the pencil icon next to the attribute name you want 
to edit, and modify the value of the attribute.

If there is no pencil icon, you may not edit the attribute.

5 Click Next.
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6 On the Summary page, review the prepared edits.

7 Click Finish to execute the changes.

8 Click Close.

To edit a PFrame’s attributes from the All Attributes page using the command 
line

◆ Type the following command
hapframe -modify pframe attribute [action] value

Use the following information to replace the appropriate variables

Moving a PFrame in the organization tree
Use this procedure to move a PFrame object in the organization tree.

To move a PFrame in the organization tree using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, select one or more PFrames. 

3 Click Configuration > Move PFrame(s).

4 In the Organization Unit Selection panel, click an OUValue node.

5 Consider the Allow changes even if any EA’s are used in attribute values of 
Resources option.

Check this option to allow the move of the PFrame even if it changes the 
resource attribute values due to the use of resource variables. 

When a PFrame is moved to another OU, it is possible that the value of an 
extended attribute which is attached to the PFrame is no longer valid. In 
this case the extended attribute value for the object changes. If the 
extended attribute is used as resource variable, then the change in value of 
the extended attribute can also change a resource attribute value.

This option is equivalent to the -refreshvars option in the command line.

6 Consider the Modify Privileges if move invalidates the assigned Roles of 
Users option.

pframe The name of the PFrame.

attribute The name of the attribute you want to modify.

action The action for the command, for example, -add or -delete

value The new value for the attribute.
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This option applies in the use case when the PFrame moves to an OUvalue 
node that is not in the subtree of its original organization tree node. In this 
case, you must check this option to remove privileges from users that are no 
longer valid due to the move, or the move is rejected. 

This option is equivalent to the -updateroles option in the command line.

7 Click Next.

8 In the Summary panel, click Finish to execute the commands.

9 Click Close.

To move a PFrame in the organization tree using the command line

◆ hapframe -move [-refreshvars] [-updateroles] ESX_server -ou 
OUValue_path

Moving an ESX Server from one VMware 
VirtualCenter to another

Use the following procedure if:

■ A virtual machine is not shared (that is, it cannot run on more than one 
PFrame) and you would like to move it to another PFrame.

■ A virtual machine is moved to a PFrame that is part of another VC.

To move an ESX Server from one VMware VirtualCenter (VC) to another:

1 Type the following command to stop the VCS One client on the PFrame.
hastop -frame ESXServerFQDN -force

2 Type the following command to disassociate the PFrame from the 
Management Console
hapframe -disassociate

3 Move the PFrame

4 [Optional] Type the following command to associate the PFrame with 
another management console.
hapframe -associate

5 On the PFrame node, restart the VCS One client.
/opt/VRTSvcsone/bin/hastart -client
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Starting a PFrame in the Simulator
This task is only available using the Simulator to simulate a PFrame-based 
physical server booting in the cluster. 

To start a PFrame using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, check the box next to the name of one or more PFrames 
that you want to start.

3 Click Simulation > Start PFrame(s).

4 Click OK > Close.

To start a virtual server using the command line

◆ Type the following command
hasim -startpframe name

Use the following information to replace the appropriate variables:

Faulting a PFrame in the Simulator
This task is only available using the Simulator to simulate the fault of a PFrame. 

In an actual server farm, this action is done automatically VCS One monitors the 
PFrames for changes in their state. 

To clear the fault of a simulated PFrame, use the Start PFrame menu item.

See “Starting a PFrame in the Simulator” on page 503.

To fault a PFrame in the Simulator using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, check the box next to the name of one or more PFrames 
that you want to fault.

3 Click Simulation > Fault PFrame(s).

4 Click OK > Close.

To fault a PFrame using the command line

◆ Type the following command
hasim -faultpframe name

name The name of the PFrame object in the VCS One configuration.
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Use the following information to replace the appropriate variables:

Simulating a PFrame in DDNA state
This task is only available using the Simulator to simulate the Daemon Dead 
Node Alive state (DDNA) of a PFrame. 

In the DDNA state, the PFrame on which the VCS One client daemon is installed 
is functional (up-and-running), however, the VCS One client daemon process 
has stopped. 

If a PFrame is in the DDNA state, the Policy Master does not failover virtual 
machines that are running on the PFrame. The administrator must manually 
initiate the failover operation.

To clear the DDNA state of a simulated PFrame, use the Start PFrame menu 
item.

To restore an actual PFrame that is in the DDNA state, you must perform a 
system repair operation. 

To simulate a PFrame in DDNA state 

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, check one or more PFrames for which you want to 
simulate the DDNA state.

3 Click Simulation > Simulate Daemon Dead.

4 Click OK > Close.

To simulate the DDNA state for a system from the command line

◆ Type the following command
hasim -killclient pframe 

Use the following information to replace the appropriate variables:

name A space-separated list of the names of the PFrame objects in the VCS One 
configuration.

pframe A space-separated list of the names of the PFrame objects in the VCS One 
configuration.
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Managing virtual frames 
(VFrames)

This chapter includes the following topics:

■ About managing virtual frames

■ Adding a VFrame

■ Viewing details about a VFrame

■ Modifying a VFrame

■ Adding or modifying VFrame resources

■ Configuring VFrame high availability

■ Configuring guaranteed resource reservations for a VFrame

■ Deleting a VFrame

■ Modifying Vframe dependencies

■ Linking a VFrame to a system

■ Unlinking a VFrame from a system

■ Editing an attribute for a VFrame type

■ Editing attributes for a instance of a VFrame

■ Editing the extended attributes of a VFrame

■ Modifying the fault policy of a VFrame

■ Modifying the Pframe list of an ESX virtual machine

■ Refreshing the PFrame list of a VFrame

■ Modifying compatibility of a VFrame

■ Moving a VFrame in the organization tree
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■ Bringing a VFrame online

■ Taking a VFrame offline

■ Probing a VFrame

■ Enabling a VFrame

■ Disabling a VFrame

■ Enabling all resources in a VFrame

■ Disabling all resources in a VFrame

■ Adding a VFrame to a composite service group

■ Deleting a VFrame from a composite service group

■ Switching a VFrame between PFrames

■ Migrating a VFrame to a different PFrame

■ Freezing a VFrame

■ Unfreezing a VFrame

■ Flushing a VFrame

■ Clearing a VFrame fault

■ Clearing all VFrame faults by organization unit

■ Faulting a VFrame in the Simulator
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About managing virtual frames
A virtual frame, or VFrame, is a VCS One object that represents a virtual 
machine in the cluster. VCS One can manage the virtual machine itself, or a 
virtual machine that hosts service groups. 

A blackbox VFrame is a virtual machine that does not have a VCS One system 
object linked to it, and therefore no service groups can come online on the 
VFrame.

See “How VCS One manages a virtualized environment” on page 66.

The following objects are examples of VFrames:

■ ESX virtual machine

ESXVM object type

■ LDom virtual machine

LDOMsVM object type

Adding a VFrame
Use this procedure to add a VFrame manually. If you place VMware ESX-based 
virtual machine under VCS One control, you may also add VFrames through a 
discovery process.

See “Importing objects from an existing VMware virtual environment into the 
VCS One configuration” on page 478.

VCS One can manage a VFrame whether or not it has service groups running on 
it.

To add a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 Click Configuration > Add VFrame.

3 Use the following information to fill in the fields of the Add VFrame panel:

Name Enter a name for the VFrame object in the VCS One 
configuration.

Priority Select a Priority value for the VFrame.

See “About Priority” on page 316.
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4 Click Next.

You may also click Finish to jump to the Summary panel, as denoted in 
step 14. If you click Finish, the VFrame has the following characteristics:

■ It is attached at the root (/) OU Node.

■ It is compatible with all other VFrames.

■ Extended attributes have the default value.

■ No PFrames are configured in its SystemList.

■ No fault policy is configured.

5 Select an OUValue node to associate with the VFrame.

See “Moving a VFrame in the organization tree” on page 524. 

6 Click Next.

7 Assign values to applicable extended attributes.

If this panel does not appear, there are no inherited extended attributes for 
this VFrame.

8 Click Next.

9 Configure the SystemList attribute for this VFrame. The SystemList for a 
VFrame is the list of PFrames on which it may run.

Use the following information to fill in the panel:

VType Choose one of the following virtualization types, 
depending on the VFrame technology:

■ ESXVM

■ LDomsVM

Configure advanced workload 
management

Check if you want to configure a Load for this 
VFrame.

See “About Load and Capacity” on page 55. 

Filter Box Filter your view of Available PFrames using one of 
the filter options.

Available PFrames Select the name of the PFrame to add to the Selected 
PFrame list.

Arrowhead Click the appropriate arrowhead to move the object. 
You may move the object to or from the Selected 
PFrame list.

Selected PFrames This table lists the PFrames selected for the VFrame.
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10 Click Next.

11 Add resources to the VFrame.

See “Adding or modifying VFrame resources” on page 512. 

12 Link the resources in the VFrame.

Use the following information to fill in the panel. Repeat this operation for 
each link needed.

After a resource dependency is created, the parent and child resources are 
displayed under Currently linked. To remove the resource dependency, 
click the corresponding Remove icon.

13 Click Next.

14 In the Summary panel, click Finish to run the commands.

15 Click Close.

To add a VFrame using the command line

◆ Type the following command
havframe -add vframe -vtype type path

Use the following information to replace the appropriate variables:

Viewing details about a VFrame

The detail page of a VFrame provides the following details about the Vframe:

■ Service groups 

■ PFrames configured to run this VFrame

■ Resources of this VFrame

Parent Select the name of the parent resource.

Child Select the name of the child resource. The child resource comes online 
before the parent resource.

Add Link Click to create a dependency between the child and the parent resource.

vframe The name of the VFrame.

type The vtype of the VFrame.

path The organization tree path at which to attach the VFrame.
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■ Extended Attributes and their values configured

■ Compatible and Incompatible VFrames

To view details about a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 Click the name of the VFrame to go to the detail page for that VFrame. 

Use the following information to view detailed information about the 
VFrame:

To view details about a VFrame using the command line

◆ Type the following command
havframe -display vframe

Use the following information to replace the appropriate variable

Dependency Click to reposition the window to the Hosting PFrames 
section of this page. 

Resources Click to reposition the window to the Resources section 
of this page. 

Compatible VFrames Click to reposition the window to the Compatible and 

Incompatible VFrames section of this page. 

Extended Attributes Click to reposition the window to the Extended 

Attributes section of this page. 

Click the pencil icon to edit the value of an attribute. 

Automation Info Lists the rules and jobs that are associated with this 
CSG. 

See “About managing automated tasks” on page 455.

All Attributes Click to go to the All Attributes page of this VFrame. 

Click the pencil icon to edit the value of an attribute. 

Logs Click to go to directly to the Logs tab. 

vframe The name of the VFrame.
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Modifying a VFrame
You can not change the name or the VType of the VFrame after it has been 
created. To change the name or VType of the VFrame, delete the VFrame from 
the configuration and recreate it.

Use the Modify VFrame menu item to modify the Priority and Advanced 
Workload Management values for the VFrame.

To modify a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, select one or more VFrames. 

3 Click Configuration > Modify VFrame.

4 Use the following information to fill in the fields of the VFrame 
Configuration panel:

5 To modify other aspects of the VFrame, click Next.

You may also click Finish at any time to go directly to the Summary panel. 

6 Modify extended attributes of the VFrame.

7 Click Next.

8 Modify the PFrames on which this VFrame may run.

9 Click Next.

10 Modify the resources and associated values of this VFrame.

11 Click Next.

12 Modify the resource dependency links of this VFrame.

13 Click Next.

14 In the Summary panel, click Finish to run the commands.

15 Click Close.

You may also click Advanced to configure Compatibility and Fault Policy for 
this VFrame.

Priority Select a Priority value for the VFrame.

See “About Priority” on page 316.

Configure advanced workload 
management

Check if you want to modify the keys of the Load 
attribute for this VFrame.

See “About Load and Capacity” on page 55. 
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To modify a VFrame using the command line

◆ Use the following command
hares -modify 

Adding or modifying VFrame resources
VCS One manages services groups and VFrames by managing their respective 
resources.

To add or modify VFrame resources

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, select one VFrame. 

3 Click Configuration > Add/Modify Resource.

4 To add a resource, use the following information to fill in the fields of the 
VFrame Resource panel:

5 To modify the attributes of a resource, click the pencil icon in the Edit 
column, and use the following information to fill in the Edit Attribute panel:

6 To return to the VFrame Resource panel, click OK.

Type Select a resource type for this resource. Only 
resources valid for this VFrame will appear.

See “About agents and resource types” on page 48.

Name Enter a name for the resource.

See “About the names of your VCS One cluster 
objects and attributes” on page 240.

Enable Resource Check to enable the resource. Only an enabled 
resource can come online.

Add Resource Click to add the resource to the Resource List.

Attribute Click the attribute to modify from the Attribute(s) 
table.

Global Value Click if you want to change the value of this resource 
everywhere it is used in the cluster.

Local Value(s) Click if you want to change the value of this resource 
on specific systems.
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7 Click Next.

You may also click Finish to go directly to the Summary panel. 

8 The Link/Unlink Resource panel allows you to modify the resource 
dependencies.

9 In the Summary panel, click Finish to execute the commands.

10 Click Close.

To modify a VFrame resource using the command line

◆ Use the following command
hares -modify 

Configuring VFrame high availability
Use this procedure to either enable or disable virtual machine high availability 
(VMHA).

See “About virtual machine high availability” on page 68.

To configure VFrame high availability using the VCS One console

1 In the VCS One console, click Manage > Systems.

2 Check one or more system on which to enable or disable VMHA.

3 In the right pane, click Configuration.

4 Click Enable VMHA or Disable VMHA.

5 Click Finish > Close.

To enable high availability for a black-box VFrame using the command line 

1 Ensure the VFrame has a linked system.

2 Type the following command to set the UseForPolicy key of the 
LinkedVFrame system attribute.
hasys -enablevmha 

To enable high availability for an application running inside a VFrame using 
the command line

1 Ensure only one system is in the SystemList of the service group

2 Type the following command to set the UseForPolicy key of the 
LinkedVFrame system attribute.
hasys -enablevmha 

See “LinkedVFrame” on page 843.
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To disable high availability for a VFrame using the command line

3 Type the following command
hasys -disablevmha 

Configuring guaranteed resource reservations for a 
VFrame

You must understand the Load and Capacity features of VCS One in order to 
implement resource reservations.

See “About Load and Capacity” on page 55.

VCS One reserves resources for a virtual machine (VFrame) based on the 
following design:

■ A VFrame with a linked system - reservations are calculated based on the 
Load values of the service groups that run inside the virtual machine

■ A black box VFrame - reservations are calculated baed on the Load value 
assigned to the VFrame,

To configure guaranteed resource reservations for a VFrame

1 Set the EnableReservation attribute to include the VFrame type on which to 
enable guaranteed reservations.

See “EnableReservation” on page 823.

2 Confirm that the value of the key cpu_key of the ResourceKeys attribute is 
equivalent to the value of the PrecedenceOrder key that represents the CPU 
resource.

For example, if the CPU resource in the PrecedenceOrder attribute is “cpu” 
then the cpu_key value of the ResourceKeys attribute must also be "cpu".

The default values of these attribute are set to be equivalent.

See “PrecedenceOrder” on page 827.

See “ResourceKeys” on page 829.

3 Set the Capacity attribute for the PFrame.

4 Set the Load attribute for each service group that will run inside a VFrame 
on the PFrame.

Set the Load attribute of the VFrame in the black box VFrame use case.

Deleting a VFrame
Deleting a VFrame deletes all the resources configured on the VFrame, and 
removes the VFrame from the VCS One configuration.
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You can not delete a VFrame that is online or linked to a system.

To delete a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, select one or more VFrames. 

3 Click Configuration > Delete VFrame(s).

4 Consider the Remove dependencies, if any, before deletion option.

Check this option if you want to remove any existing dependency links 
between this VFrame and other VFrames.

This option is equivalent to the -force option in the command line.

5 Click OK > Close.

To delete a VFrame using the command line

◆ Type the following command
havframe -delete [-force] vframe 

Use the following information to replace the appropriate variable:

Modifying Vframe dependencies
Use this procedure to create dependencies to a VFrame or remove dependencies 
from a VFrame.

This procedure is equivalent to the task to create or remove dependencies 
between service groups.

Service group and VFrames can be linked with global (soft|firm|hard) 
dependency only. Local dependency is not supported between a service group 
and a VFrame.

If a VFrame is linked to a system, best practice indicates to use a ‘global soft’ 
child dependency from the VFrame that is linked to a system to a service group 
that contains replication resources.

This restriction has been relaxed. A vframe can be part of a dependency even 
if it is linked to a system. We recommend that only "global soft" child 
dependency be created from a vframe which is linked to a system to a service 
group that contains replication resources e.g. HTC

To modify VFrame dependencies using the VCS One console

1 In the VCS One console, click Manage > VFrames.

vframe The name of the VFrame.
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2 In the right pane, check one VFrame. 

3 Click Configuration > Manage Dependencies.

4 Use the following information to fill in the fields of the Create/Remove 
dependencies panel:

5 Click Next. 

6 In the Summary panel, click Finish to execute the commands.

7 Click Close.

To modify VFrame dependencies using the command line

◆ Use the following command
havframe -link 

See Veritas Cluster Server One Command Reference Guide.

Linking a VFrame to a system 
Use this procedure to link a VFrame to a system. Link a system to a VFrame in 
order to accomplish one of the following tasks:

■ Running a service group (application) inside the virtual machine.

Service Group Click to manage service group dependencies

Blackbox VFrame Click to manage VFrame dependencies

Filter Box Enter text to filter the contents of the Objects table. 
Click the magnifying glass to search.
Click the red X to clear the filter.

Objects Select one or more objects to create dependency links 
with the Vframe selected in step 2 

Arrowhead Click the appropriate arrowhead to move the object. 
You may move the object to or from either a parent or 
child dependency.

Set dependency for all Use this option to set the same dependency 
relationship for all parents or all child dependencies 
that are configured.

Dependency Type Select the type of dependency for each parent and 
child individually with the drop-down menu.

See “Designing multi-tier applications” on page 283. 
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■ Failing over a virtual machine to another PFrame (VMHA)

You do not need to link a system to a black-box VFrame.

You may also configure VCS One to automatically link a system to all VFrames 
using the VType attribute EnableAutoLinkSys.

Before performing this link manually, put the system in the running state and 
the VFrame in the online state. 

You can also perform this task from the Manage > System > Configuration > 
Link VFrame menu.

In the simulator, the EnableAutoLinkSys attribute is not active, and auto-linking 
does not occur. The user needs to manually link systems and vframes.

See “About VFrames with linked systems” on page 67.

See “EnableAutoLinkSys” on page 905.

To link a VFrame to a system using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Configuration > Link System.

4 In the System Configuration panel, enter one system in the System Name 
column to be associated with each VFrame.

You may enter the name in the text box, or click the pencil icon to choose 
systems from a list, and click OK.

5 Consider the Forcefully link VFrame to System even if VFrame is already 
linked option.

This option is equivalent to the -force option in the command line.

6 Click Next > Finish > Close.

To link a VFrame to a system using the command line

◆ Type the following command
havframe -linksys vframe sysname

Use the following information to replace the appropriate variables:

vframe The name of the VFrame.

sysname The name of the system to link to the VFrame.
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Unlinking a VFrame from a system
Use this procedure to unlink a VFrame from a system. You can also perform this 
task from the Manage > System > Configuration > Unlink VFrame menu.

This task is only available in the simulator, or when the VType attribute 
EnableAutoLinkSys = 0. 

See “About VFrames with linked systems” on page 67.

See “EnableAutoLinkSys” on page 905.

To unlink a VFrame to a system using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Configuration > Unlink System.

4 Click OK > Close.

To unlink a VFrame from a system using the command line

◆ Type the following command
havframe -unlinksys vframe sysname

Use the following information to replace the appropriate variables:

Editing an attribute for a VFrame type
When you change the value of an attribute at the type level, you affect the 
definition of all future objects of that type added to the cluster.

For example, if you change the FrameRestartPolicy attribute in the ESXServer 
Type definition, you change FrameRestartPolicy attribute default value for all 
future objects of Type ESXServer added to the server farm. 

You may also change the value of an attribute only for an individual instance of 
an object. 

See “Editing attributes for a instance of a VFrame” on page 519.

To edit an attribute for a VFrame type using the VCS One console

1 In the VCS One console, click Manage > PFrames.

2 In the right pane, click Views > VTypes.

vframe The name of the VFrame.

sysname The name of the system to link to the VFrame.



519Managing virtual frames (VFrames)
Editing attributes for a instance of a VFrame
3 Click VFrame.

4 Click the pencil icon in the Edit column next to the attribute name you wish 
to edit.

If there is no Edit icon, the attribute is not editable.

5 In the Edit Attribute window, enter a value in the Value text box.

6 Click Next.

7 Click Close.

Editing attributes for a instance of a VFrame
Use this procedure to edit the value of an attribute only for one or more 
individual instances of a VFrame. If you want to change the value of an attribute 
for all future objects of type VFrame do not use this procedure.

See “Editing an attribute for a VFrame type” on page 518.

To edit an attribute for a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Configuration > Edit Attribute(s).

4 In the Edit Attribute(s) panel, use the following information to edit 
attributes:

5 Click Next.

Attributes Select the attribute to modify. Only attributes 
that can be modified are displayed in this list.

Select VFrames Click For all VFrames to configure the same value 
for all the selected VFrames.

Click individual VFrames to configure different 
values for each selected VFrame

Pencil icon Click to edit the value of the corresponding attribute.

Click OK to return to the Edit Attribute panel.

Restore Old Values Click to restore the value of the currently 
selected attribute to the configured value 
before starting this instance of the wizard for 
all VFrames selected in step 2
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6 In the Summary panel, click Finish to execute the commands.

7 Click Close.

To edit an attribute for a VFrame using the command line

◆ Use the following command 
havframe -modify

See “VFrame attributes” on page 914.

Editing the extended attributes of a VFrame
Use this procedure to edit the value of extended attributes of a VFrame object. If 
this VFrame inherits extended attributes this panel allows you to modify the 
value from the default

You can not add extended attributes from this wizard.

See “About extended attributes” on page 632.

See “Defining an extended attribute” on page 634.

To edit the extended attributes of a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Configuration > Edit Extended Attribute(s).

4 In the Edit Extended Attribute(s) panel, use the following information to 
edit attributes:

Extended Attributes Select the attribute to modify. Only attributes 
that can be modified are displayed in this list.

Select VFrames Click Apply to all VFrames to configure the same 
value for all the selected VFrames.

Click individual VFrames to configure different 
values for each selected VFrame

Updated Value Click to edit the value of the corresponding attribute.

Set Default Values Click to set the default value of the extended 
attribute for all VFrames selected in step 2

Restore Old Values Click to restore the value of the currently 
selected attribute to the configured value 
before starting this instance of the wizard for 
all VFrames selected in step 2



521Managing virtual frames (VFrames)
Modifying the fault policy of a VFrame
5 Click Next.

6 In the Summary panel, click Finish to execute the commands.

7 Click Close.

To edit an extended attribute for a VFrame using the command line

◆ Use the following command 
havframe -modify

Modifying the fault policy of a VFrame
Use this procedure to edit the actions a VFrame takes after a fault.

To modify fault policy of a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Configuration > Edit Fault Policy.

4 In the Edit Fault Policy panel, use the following information to configure 
fault policy:

5 Click Next.

6 In the Summary panel, click Finish to execute the commands.

7 Click Close.

Fault Policy One or more of the following options will 
appear, depending on the type of VFrame:

■ FaultPolicy

■ NodeFaultPolicy

■ PropagateFaultPolicy

■ ResFaultPolicy

See “Designing actions taken after a fault” on 
page 259.

Apply to all VFrames If you selected more than one VFrame on which to 
edit fault policy, check this option to configure the 
same value for each of them. Use the corresponding 
Select Value drop-down to select the value.

Propagate Check this option to apply the new fault policy 
settings to all VFrames in the dependency tree.
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Modifying the Pframe list of an ESX virtual machine
Use this procedure to modify the list of ESX servers on which an ESX virtual 
machine may run. 

To modify the PFrame list of an ESX virtual machine using the VCS One 
console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Configuration > Edit PFrame List.

4 Use the following information to fill in the Edit PFrame List panel:

5 Click Next.

6 Review the summary page of designated changed.

7 Click Finish > Close. 

To modify the PFrame list of an ESX virtual machine using the command line

◆ Type the following command
havframe -modify [-propagate] vframe PFramelist -op pframe

Vframe name Select the name of the VFrame for which you want to 
change the PFrame list.

Filter Box Enter text to filter the contents of the Available 
Pframes table. Click the magnifying glass to search.
Click the red X to clear the filter.

Available PFrames Select the name of the PFrame to add to the Selected 
PFrame list.

Arrowhead Click the appropriate arrowhead to move the object. 
You may move the object to or from the Selected 
PFrame list.

Selected PFrames This table lists the PFrames selected for the VFrame.

Propagate Check to configure this PFrame list for all the 
VFrames at or below the organization tree node of 
the VFrame selected.

This option is equivalent to the -propagate option in 
the command line.
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Use the following information to replace the appropriate variables:

Refreshing the PFrame list of a VFrame
Use this procedure to refresh the PFrameList of a VFrame. 

To refresh the PFrame list of a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operations > Refresh PFrame List.

4 Click OK > Close.

To refresh the PFrame list of a VFrame using the command line

◆ Type the following command
havframe -modify vframe PFramelist -refresh

Use the following information to replace the appropriate variables:

Modifying compatibility of a VFrame
Use this procedure to modify the compatibility of a VFrame.

See “Application relationships through service group compatibility” on 
page 318.

To modify the compatibility of a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one VFrames. 

3 Click Configuration > Edit Compatibility.

vframe The name of the VFrame.

op The operator, such as -add or -delete

pframe A list of one or more PFrames.

vframe The name of the VFrame.
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4 Use the following information to fill in the Edit Compatibility panel:

5 Click Finish > Close.

To modify the compatibility of a VFrame using the command line

◆ Type the following command
havframe -compatible|-incompatible vframe vframelist

Use the following information to replace the appropriate variables:

Moving a VFrame in the organization tree
Use this procedure to move a VFrame object in the organization tree.

To move a VFrame in the organization tree using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, select one or more VFrames. 

3 Click Configuration > Move VFrame(s).

4 In the Organization Unit Selection panel, click the new OUValue node at 
which to attach the VFrame.

Select Compatibility Select one of the following options:

Compatible to designate VFrames that can run 
concurrently on the same PFrame as this VFrame.

Incompatible to designate VFrames that can not run 
concurrently on the same PFrame as this VFrame

ALLVFRAMES Check to universally designate all existing and future 
VFrames to the compatibility selection.

Search Use the search box to filter the VFrames names

Select Check next to each VFrame to designate.

Propagate Check to apply the compatibility or incompatibility 
to all VFrames that are attached at or below the same 
node in the organization tree.

vframe The name of the VFrame.

vframelist A list of VFrames to designate the compatible or incompatible 
relationship.
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5 Consider the Allow changes even if any EA’s are used in attribute values of 
resources option.

Check this option to allow the move of the VFrame even if it changes the 
resource attribute values due to the use of resource variables. 

When a VFrame is moved to another OU, it is possible that the value of an 
extended attribute which is attached to the VFrame is no longer valid. In 
this case the extended attribute value for the object changes. If the 
extended attribute is used as resource variable, then the change in value of 
the extended attribute can also change a resource attribute value.

This option is equivalent to the -refreshvars option in the command line.

6 Consider the Modify Privileges if move invalidates the assigned roles of 
users option.

This option applies in the use case when the VFrame moves to an OUvalue 
node that is not in the subtree of its original organization tree node. In this 
case, you must check this option to remove privileges from users that are no 
longer valid due to the move, or the move is rejected. 

This option is equivalent to the -updateroles option in the command line.

7 Click Next.

8 In the Summary panel, click Finish to execute the commands.

9 Click Close.

To move a VFrame in the organization tree using the command line

◆ Type the following command
havframe -move [-refreshvars] [-updateroles] vframe -ou path

Use the following information to replace the appropriate variables:

Bringing a VFrame online
Use this procedure to bring a VFrame online on a PFrame.

To bring a VFrame online using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operation > Online.

vframe The name of the VFrame.

path The organization tree path that denotes a OUValue node.



526 Managing virtual frames (VFrames)
Taking a VFrame offline
To bring a VFrame online using the command line

◆ Type the following command
havframe -online vframe sysname

Use the following information to replace the appropriate variables:

Taking a VFrame offline
AWM policy brings offline all the service groups that are online on a virtual 
machine when user issues the offline operation for the virtual machine.

If the VFrame has a linked system, the state of the linked system is set to 
LEAVING when the VFrame is being brought offline.

Use this procedure to take a VFrame offline from a PFrame. 

To take a VFrame offline using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operation > Offline.

4 Use the following information to fill in the Offline VFrame panel:

5 Click Next > Close.

To take a VFrame offline using the command line

◆ Type the following command
havframe -offline [-force][-propagate] vframe pframe

vframe The name of the VFrame.

sysname The name of the system to link to the VFrame.

Select the PFrame you want to 
offline this VFrame from

The PFrames available are the ones in the 
VFrame’s SystemList.

Forcefully offline the VFrame 
if the PFrame is in DDNA 
state.

If the PFrame is in the DDNA state, the offline action 
will fail unless you check this box.

See “How the Policy Master and client systems 
resolve failures in communication” on page 54.

Propagate Check to apply the offline action to all VFrames that 
have a dependency link with this VFrame.

See “Designing multi-tier applications” on page 283.
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Use the following information to replace the appropriate variables:

Probing a VFrame
Use this procedure to probe the resources in the VFrame.

Resources must be enabled before they are probed.

See “Enabling all resources in a VFrame” on page 528.

To probe a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operations > Probe All Resources.

4 Select either All PFrames or a specific PFrame on which to probe all enabled 
resources.

5 Click OK.

To probe a VFrame using the command line

◆ Type the following command
havframe -enable vframe 

Use the following information to replace the appropriate variables:

Enabling a VFrame
Enable a Vframe in order for it to be actively managed by VCS One. 

To enable a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operations > Enable.

4 Select either All PFrames or a specific PFrame to enable.

5 Click OK.

vframe The name of the VFrame.

pframe The name of the PFrame from which to take the VFrame offline. 

vframe The name of the VFrame.
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To enable a VFrame using the command line

◆ Type the following command
havframe -enable vframe 

Use the following information to replace the appropriate variables:

Disabling a VFrame
Use this procedure to disable a VFrame. When a Vframe is disabled, it remains in 
the configuration but is not available to be managed by VCS One.

To disable a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operations > Disable.

4 Select either All PFrames or a specific PFrame on which to probe all enabled 
resources.

5 Click OK.

To disable a VFrame using the command line

◆ Type the following command
havframe -disable vframe 

Use the following information to replace the appropriate variables:

Enabling all resources in a VFrame
Use this procedure to enable all of the resources in a VFrame.

To enable resources in a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operation > Enable All Resources.

4 Click OK.

vframe The name of the VFrame.

vframe The name of the VFrame.
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To enable resources in a VFrame using the command line

◆ Type the following command
havframe -enableresources vframe

Use the following information to replace the appropriate variables:

Disabling all resources in a VFrame
Use this procedure to disable all resources in a VFrame.

To disable resources in a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operation > Disable All Resources.

4 Click OK.

To disable resources in a VFrame using the command line

◆ Type the following command
havframe -disableresources vframe

Use the following information to replace the appropriate variables:

Adding a VFrame to a composite service group
Use this procedure to add a VFrame to a composite service group.

To add a VFrame to a composite service group using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 Check the VFrame to add to the CSG.

3 In the right pane, click Configuration > Add to CSG

4 Select the composite service group.

5 Click OK > Close.

vframe The name of the VFrame.

vframe The name of the VFrame.
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Deleting a VFrame from a composite service group
Use this procedure to delete a VFrame from a composite service group.

To delete a VFrame from a composite service group using the VCS One 
console

1 In the VCS One console, click Manage > VFrames.

2 Check the VFrame to delete from the CSG.

3 In the right pane, click Configuration > Delete from CSG.

4 Click OK > Close.

Switching a VFrame between PFrames
Use this procedure to switch a VFrame between two PFrames. 

To switch a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operation > Switch.

4 Use the following information to fill in the Edit PFrame List panel:

5 Click OK.

To switch a VFrame using the command line

◆ Type the following command

Select the PFrame you want to 
switch this VFrame on:

Select Anywhere or the name of the PFrame to which 
you want to switch the VFrame.

Evacuate lower priority 
VFrames

Check to kick out lower priority VFrames to allow 
this VFrame to come online on the designated target 
PFrame. Kickout is only necessary if there are not 
enough resources to support all VFrames.

See “About disruption factor and kickout” on 
page 318.

Propagate Check to switch all VFrames in the VFrame 
dependency tree.

This option is equivalent to the -propagate option in 
the command line.
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havframe -switch [-ejectlowpri | -propagate] [-ignorestandby] 
vframe -to pframe

Use the following information to replace the appropriate variables:

Migrating a VFrame to a different PFrame 
Migration of a virtual machine, or VFrame object in VCS One, is specific to the 
VMware feature that allows a user to migrate a running virtual machine from 
one ESX server to another without having to take it down on the source ESX 
server and start it on the target ESX server. VMware calls this feature VMotion.

The VFrame must be online to perform this migration task, and each PFrame 
must be in the VFrame’s PFrameList.

This command sends a migration request to the vCenter Server. Although the 
vCenter Server may accept the migration request, acceptance is not a guarantee 
that the VFrame migrates to the target PFrame.

In such a scenario, where the vCenter Server accepts the request but for some 
reason it does not migrate the VFrame, the VFrame remains in the offline state 
on the target PFrame, and the GTQ has an entry for the VFrame to go online on 
the target PFrame that the user should remove.

See “Stopping the current action for an object in the GTQ” on page 382.

Alternatively, the switch operation in VCS One takes the VFrame offline on one 
PFrame and brings it online on a different PFrame.

“Switching a VFrame between PFrames” on page 530.

A VFrame must be associated with a management console for this operation.

To migrate a VFrame to a different PFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, check one or more VFrames. 

3 Click Operation > Migrate.

If you are simulating the migration, click Simulation > Migrate.

To migrate a VFrame to a different PFrame using the command line

◆ Type the following command
havframe -migrate [-ejectlowpri | -propagate] [-ignorestandby] 
vframe -to pframe

vframe The name of the VFrame.

pframe The name of the PFrame.
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Use the following information to replace the appropriate variables:

Freezing a VFrame
Freezing a VFrame enforces the following conditions: 

■ A service group hosted on the VFrame can not failover to another system.

■ A service group hosted on another VFrame or system can not come online 
on the frozen VFrame through a failover operation. 

■ A manual switch of a service group from the frozen VFrame is allowed.

■ A manual switch of a service group to the frozen VFrame is not allowed.

Freezing a VFrame is useful when you want to stop actions, such as 
maintenance activities, from triggering a virtual machine failover.

To freeze a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, select one or more VFrames. 

3 Click Operations > Freeze VFrames.

4 Consider the Propagate option.

Check Propagate to also freeze all the service groups or VFrames in this 
VFrames dependency tree.

This option is equivalent to the -propagate option in the command line.

5 Click OK > Close.

To freeze a VFrame using the command line

◆ Type the following command
havframe -freeze [-propagate] vframe 

Use the following information to replace the appropriate variables:

Unfreezing a VFrame
Unfreezing a VFrame removes the restrictions of the frozen condition.

vframe The name of the VFrame.

pframe The name of the PFrame.

vframe The name of the VFrame.
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See “Freezing a VFrame” on page 532. 

To unfreeze a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the right pane, select one or more VFrames. 

3 Click Operations > Unfreeze.

4 Consider the Propagate option.

Check Propagate to also unfreeze all the service groups or VFrames in this 
VFrames dependency tree.

This option is equivalent to the -propagate option in the command line.

5 Click OK > Close.

To unfreeze a VFrame using the command line

◆ Type the following command
havframe -unfreeze [-propagate] vframe 

Use the following information to replace the appropriate variables:

Flushing a VFrame

To flush a VFrame using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 Click a VFrame to go to the VFrame details page.

3 In the right pane, click Operations > Flush.

Clearing a VFrame fault
Use this procedure to clear one or more VFrame faults.

You may also use this procedure when a VFrame is in DDNA state. In the DDNA 
state, VCS One can not manage the virtual machines and corresponding 
applications. 

When you force the VFrame fault, the virtual machines running on the VFrame 
will follow the fault policy configured for the cluster, which should allow VCS 
One to resume management operations.

vframe The name of the VFrame.
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To clear a VFrame fault using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 Check one or more VFrames. 

3 Click Operations > Clear Fault.

4 Click OK > Close.

To clear all VFrame fault by organization unit using the command line

◆ Type the following command
havframe -clear vframe

Use the following information to replace the appropriate variables:

Clearing all VFrame faults by organization unit
Use this procedure to clear all the VFrame faults in a branch of the organization 
tree.

To clear all VFrame fault by organization unit using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 In the left pane, right-click a node in the organization tree. 

3 Click Clear All Faults.

4 Click OK > Close.

To clear all VFrame fault by organization unit using the command line

◆ Type the following command
havframe -clear -ou ounode

Use the following information to replace the appropriate variables:

Faulting a VFrame in the Simulator
Use this procedure to fault a VFrame. This task is only available using the 
Simulator. In an actual server farm, this action is done automatically. VCS One 
monitors the VFrames for changes in their state. 

vframe The name of the VFrame.

vframe The name of the VFrame.

ounode The node in the organization tree.
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When you fault a VFrame, the VFrame follows the VFrame fault policy. By 
default, the fault policy is set to failover, where the VFrame fails over to another 
PFrame.

To clear the fault of a simulated VFrame, use the Clear Fault menu item.

See “Clearing a VFrame fault” on page 533.

To fault a VFrame in the Simulator using the VCS One console

1 In the VCS One console, click Manage > VFrames.

2 Check the name of one or more VFrames to fault.

3 Click Simulation > Fault VFrame(s).

4 Click OK > Close.

To fault a simulated VFrame using the command line

◆ Type the following command
hasim -faultvframe name -pframe pframe

Use the following information to replace the appropriate variables:

name A space-separated list of the names of the VFrame objects in the VCS One 
configuration.

pframe The name of the PFrame object to on which to fault the VFrame.
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Chapter
 25
Managing objects in a 
VMware environment

This chapter includes the following topics:

■ About managing a VMware environment

■ Configuring VCS One to manage VMware-based objects

■ Discovering the VMware environment

■ Loading the VCS One client daemon on the ESX servers

■ Tune your virtual machine OfflineWaitLimit attribute

■ Configuring CPU and MEM resource reservations for a virtual machine

■ Configuring an ESX virtual machine for disaster recovery
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About managing a VMware environment
VCS One can interface with one or more VMware vServer Management consoles 
to monitor and control its associated ESX servers and virtual machines. VCS One 
can also manage the applications running inside the virtual environment.

Before you configure VCS One to manage a VMware environment, be familiar 
with the VCS One virtualization-related terms and concepts, such as PFrames 
and VFrames.

See “How Veritas Cluster Server One works with virtualization” on page 63. 

You may add and manage the following types of VMware-related virtual objects 
to the VCS One cluster:

■ A vCenter Server Management console.

See “Managing management consoles” on page 477.

■ An ESX server 

See “Managing physical frames (PFrames)” on page 491.

■ A virtual machine running on an ESX server

See “Managing virtual frames (VFrames)” on page 505.

Configuring VCS One to manage VMware-based 
objects

To configure VCS One to manage VMware-based objects, you must perform both 
deployment level actions and object-model level actions. It is important to 
distinguish between these actions because deployment level actions, such as 
installing binaries, often have complex dependencies which are out of the realm 
of VCS One, such as setting up hardware or configuring virtual machines.

Object level actions, such as configuring a virtual machine object in the VCS One 
configuration database, are actions contained in the VCS One realm.

When using the simulator, you only perform the object model steps.
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Table 25-1 describes the actions required to manage VCS One VMware-based 
objects across both the deployment level and the object level to provide you with 
a high-level overview of the complete process.

Table 25-1 Overview of configuring VCS One to manage VMware-based objects

# Step Description

1 Deploy VCS One 
client-related 
binaries on ESX 
servers.

[deployment]
ESX: Install and configure on each ESX server to be managed by VCS One.

ESXi: First install and configure the Management Virtual Machine in the VMware 
environment, and then install and configure the VCS One client-related binaries on this 
control node.

See “Loading the VCS One client daemon on the ESX servers” on page 544.

See the Veritas Cluster Server One Installation Guide for your applicable Policy Master 
platform.

2 Modify the firewall [deployment]

The firewall on each ESX server must be modified to allow the vcsoneclientd daemon to 
connect with the Policy Master in a persistent way.

See Veritas Cluster Server One Installation Guide.

3 Create objects in the 
VCS One 
configuration that 
correspond to 
VMware entities. 

[object model]

Add the Management frame, ESX servers, and virtual machines objects to the VCS One 
configuration. You may do this step manually using either the GUI or the command line 
interface.

■ See “Adding a management console” on page 482.

■ See “Adding an PFrame” on page 492.

■ See “Adding a VFrame” on page 507.

You may use a discovery process to add and link the virtualization-based objects to the 
configuration.

■ See “Discovering the VMware environment” on page 541.

4 Link and associate 
objects 

[object model]

If you manually created objects in step , link and associate the objects together.

■ See “Associating a vCenter Server management console to a PFrame” on page 486.

■ See “Associating a management console and a VFrame” on page 487.

5 Deploy VCS One 
client-related 
binaries inside the 
virtual machines 
that will run 
applications.

[deployment]

The VCS One client daemon must run on each of the application-aware virtual 
machines that VCS One manages. If VCS One is managing a virtual machine without 
any applications running inside it (black-box VM), skip this step.

Deployment instructions are specific to the operating system of the virtual machine.

See Veritas Cluster Server One Installation Guide.
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6 [Optional]

Create systems and 
link systems to 
VFrames

[object model]

The default setting of the EnableAutoLinkSys attribute configures VCS One to 
automatically create and link a system object to each VFrame in the configuration. 

If you have changed this default setting, create and link a system to a VFrame in order 
to accomplish one of the following tasks:

■ Running a service group (application) inside the virtual machine.

■ Failing over a virtual machine to another PFrame (VMHA)

You may also accomplish the link manually. You must perform the manual operation 
when using the simulator.

See “Adding a system to the VCS One cluster” on page 336.

See “Linking a VFrame to a system” on page 516.

7 Create service 
groups

[object model]

■ UNIX Policy Master
Create the service group for any applications running inside virtual machines.
See “Adding a service group or an infrastructure service group” on page 357.

■ Windows Policy Master
Run the application-specific configuration wizard.
See the application’s configuration guide.

8 Edit the SystemList 
or PFrameList 
attribute 

If the service group runs inside a virtual machine and you want to do VMHA, list only 
one system in the SystemList.

If the VFrame is enabled for VMHA, populate the PFrameList appropriately.

See “Modifying the Pframe list of an ESX virtual machine” on page 522.

9 [Optional] Set 
applicable 
attributes, such as 
for failover policy 

Consider the following attributes:

■ Set the Priority attribute for the service groups and black-box virtual machines. 
Higher priority objects take precedence over lower priority objects when the 
objects contend for resources.
See “Priority” on page 856.

■ Set the PropagateFaultPolicy attribute to determine whether or not a service 
group fault should propagate to the virtual machine.
See “Service group level control after a fault” on page 262.

■ Tune the OfflineWaitLimit attribute for your environment.
See “Tune your virtual machine OfflineWaitLimit attribute” on page 545.

■ Set the LinkedVFrame system attribute to determine whether or not VMHA policy 
is enabled.
See “About virtual machine high availability” on page 68.

Table 25-1 Overview of configuring VCS One to manage VMware-based objects

# Step Description
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Discovering the VMware environment
VCS One can discover and import an VMware environment. The discovery is a 
point-in-time process used to reduce the initial configuration effort when 
bringing VMware resources under VCS One control. You may also use 
synchronize the VMware environment at a later time.

See “Synchronizing the virtual environment” on page 483.

The process to discover and import an a VMware vCenter Server Management 
console under VCS One control consists of the following phases.

10 [Optional]
Set Load and 
Capacity

Set the CPU and MEM keys in the PrecedenceOrder attribute to configure guarantee 
reservation of resources in the virtual machine.

See “Configuring CPU and MEM resource reservations for a virtual machine” on 
page 546.

11 [Optional]
Configure disaster 
recovery

Disaster recovery allows the VFrames to fail over to a remote cluster.

See “Configuring an ESX virtual machine for disaster recovery” on page 547.

Table 25-1 Overview of configuring VCS One to manage VMware-based objects

# Step Description

Table 25-2 Process to discover and import the VMware environment

Phase

Phase 1 Prerequisites Collect information and prepare the VMware 
environment.

See “Prerequisites to the VMware discovery process” on 
page 542.

Phase 2 Configure 
communications 

Give VCS One security privileges to access the VMware 
vCenter Server by adding a keystore file and certificate. 
See “Configuring communications between VCS One 
and the vCenter Server Management console” on 
page 543.

If you do not provide a keystore file, the discovery 
process uses VMware’s dummy certificate for 
communication.
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Prerequisites to the VMware discovery process
Perform the following actions before configuring VCS One to discover the 
VMware vCenter Server environment.

Evaluate names of ESX objects
The discovery process eliminates special characters from the names of your 
Management consoles, ESX Servers and virtual machines.

The following special characters are not allowed in names of systems, frames, 
service groups, resources, and agents:

`'\"/\=* +?(){}[]$#^!%&,.:;<>|~@ 

See “About the names of your VCS One cluster objects and attributes” on 
page 240.

Collect access information
Collect the information to configure the user name, password, and API URL 
necessary to log in to the vCenter Server Management console.

To discover and import the components that are associated with the VMware 
vCenter Server into the server farm configuration, VCS One needs to be able to 
log in to the VMware vCenter Server. Acquire the following information before 
you perform this procedure:

Phase 3 [Optional} 
Auto-discover the 
VMware vCenter 
Server 
environment

This optional step allows you to pull a point-in-time 
snapshot of the ESX environment into your VCS One 
configuration. 

See “Auto-discovering the VMware environment” on 
page 544.

Table 25-2 Process to discover and import the VMware environment

Phase

user name The user name that is used to log in to the VMware vCenter Server, for 
example, Administrator. This user must have the following privileges in the 
vCenter Server server:

■ Perform all operations on all ESX servers

■ Perform all operations on all virtual machines

password The password that authenticates the user name.

API URL The location of the VMware vCenter Server as defined by VMware. This URL 
may be secure or non-secure. Typically this URL is:

https://vCenter Server_name/sdk
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Configuring communications between VCS One and the 
vCenter Server Management console

To discover the VMware environment, the Policy Master must have security 
privileges to access the VMware vCenter Server. 

In this task, you acquire a VMware certificate for each vCenter Server server 
under VCS One control and load the certificate into the Policy Master keystore 
file. This process is only done one time for each vCenter Server Management 
console.

To configure communications between VCS One and the vCenter Server 
Management console

1 On the current Policy Master system, log in as the root user.

You must be the root user on the current Policy Master to create the 
keystore file. These steps can only be performed using the command line.

2 Acquire the certificate file for the vCenter Server Management Server. 

The administrator for the server should be able to provide this file. The 
name of the certificate file has a .crt extension, for example rui.crt.

3 Copy the certificate file locally to the Policy Master system.

Perform this step using a copy program such as ftp. If you copy the 
certificate file to /tmp, the full path to the certificate file used in step 5 is
 /tmp/rui.crt

4 Choose a directory on the Policy Master to store the keystore file.

To enable the keystore file to be highly available, locate it on the shared 
storage of the Policy Master cluster. The recommended location for the 
keystore file is 
VCSOne configuration database mount point/keystore

5 From the keystore directory you chose in step 4, type the following 
command to create the keystore file on the Policy Master. If VCS One 
manages more than one vCenter Server, import the certificate from each 
vCenter Server to the same keystore file.
/opt/VRTSvcsone/jre/bin/keytool -import -file
path -keystore vmware.keystore -alias vcname

where

path The local path where the certificate file for the vCenter Server has 
been copied in step 3. The certificate file is generally available under 
the following location on the vCenter Server server:

C:\Documents and Settings\All Users\Application 
Data\VMware\VMware vCenter Server\SSL
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6 Type a password for the keystore. As with all passwords, you must 
remember this password and store it in a safe place.
Enter keystore password:  Your_password  

7 Type yes to indicate acknowledgment if you trust this certificate
Trust this certificate? [no]:  yes  

8 View the following message that confirms success.
Certificate was added to keystore

9 Assign the location of the keystore file to the KeyStoreFile attribute. 

In this example, /vcsonedb is the shared database mount point
havtype -modify VMwareVC KeystoreFile /vcsonedb/keystore/
vmware.keystore

10 Check the value of the KeyStoreFile attribute
havtype -value VMwareVC KeystoreFile 
/vcsonedb/keystore/vmware.keystore

Auto-discovering the VMware environment
Perform this procedure after you have performed the following steps:

■ Prerequisites to the VMware discovery process

■ Configuring communications between VCS One and the vCenter Server 
Management console

Use this procedure to allow VCS One to discover your existing VMware 
ESX-based environment rather than manually adding PFrames and VFrames as 
VCS One managed objects.

See “Importing objects from an existing VMware virtual environment into the 
VCS One configuration” on page 478.

Loading the VCS One client daemon on the ESX 
servers

The VCS One client daemon must run on each of the ESX servers. The client 
daemon allows VCS One to determine the state of both the ESX server and any 
associated virtual machines. This determination is important in order to report 
the state accurately and provide the ability to start, stop, and failover virtual 
machines.

After VCS One the ESX-related objects are configured into the VCS One 
configuration database, the state of these objects are accurate only when the 
client daemon is running on the ESX server.
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Information is available on how to install the VCS One client daemon on the ESX 
servers.

See the Veritas Cluster Server One Installation Guide.

Tune your virtual machine OfflineWaitLimit 
attribute

When you offline a virtual machine resource, it may fault unnecessarily if the 
guest operating system on the virtual machine takes a long time to shutdown. 
Tune the OfflineWaitLimit resource type attribute to your environment.

You may only tune this attribute using the command line interface.

To estimate the OfflineWaitLimit value for your environment, use the following 
calculation:

To tune your virtual machine OfflineWaitLimit attribute using the command 
line

1 Locate the group that manages the virtual machine. To do this, you must 
find the internal group that corresponds to this virtual machine. Type the 
following command:
haframe -value vm1 InternalObjectList

2 View the output to find the internal group. The value corresponding to 
group_name key is the internal group that manages this virtual machine. 
group_name ESXVM_vm1_50106d15-641d-d243-ecf3_grp

3 Use the group_name key value from step 2, locate the resource within the 
group that monitors the virtual machine. Type the following command:
hagrp -resources group_name

For example:
hagrp -resources ESXVM_vm1_50106d15-641d-d243-ecf3_grp

4 Find the resource that starts with the name VM within the output of step 3.

This is the resource that monitors the virtual machine.

In the sample output, the bold entry is the resource:
ESXVM_vm1_50106d15-641d-d243-ecf3-1a53a0a0f19c_grp.Network_VM_Network
ESXVM_vm1_50106d15-641d-d243-ecf3-1a53a0a0f19c_grp.Datastore_457345d8-8243a9b6-2976

Maximum time for virtual 
machine operating 

system to shutdown 
(in minutes)

 

         =   OfflineWaitLimit value

MonitorInterval value 
(convert to minutes)
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ESXVM_vm1_50106d15-641d-d243-ecf3-1a53a0a0f19c_grp.VM_vm1_50106d15-641d-d243-ecf3

5 Override the OfflineWaitLimit attribute for the resource that monitors the 
virtual machine within the group. Type the following command:
hares -override resource OfflineWaitLimit

Use the following information to replace the appropriate variables:

For example:
hares -override VM_vm1_50106d15-641d-d243-ecf3 OfflineWaitLimit

6 Modify the OfflineWaitLimit to a new value calculated using the formula 
provided.
hares -modify resource OfflineWaitLimit value

Use the following information to replace the appropriate variables:

For example:
hares -modify VM_vm1_50106d15-641d-d243-ecf3 OfflineWaitLimit 10

Configuring CPU and MEM resource reservations for 
a virtual machine

You can configure VCS One to account for the guaranteed CPU and memory 
reservations made in virtualization technologies.

You must understand the Load and Capacity features of VCS One in order to 
implement resource reservations.

See “About Load and Capacity” on page 55.

VCS One reserves resources for a virtual machine (VFrame) based on the 
following design:

■ A VFrame with a linked system - reservations are calculated based on the 
Load values of the service groups that run inside the virtual machine

■ A black box VFrame - reservations are calculated baed on the Load value 
assigned to the VFrame,

See “Configuring guaranteed resource reservations for a VFrame” on page 514.

resource The name of the resource identified in step 4.

resource The name of the resource identified in step 4.

value OfflineWaitLimit value
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See “About guaranteed resource reservations in virtualization environments” 
on page 323.

Configuring an ESX virtual machine for disaster 
recovery

When you have multiple cluster sites and you want ESX-based virtual machines 
to fail over between clusters, you can configure the VCS One disaster recovery 
feature.

See “How VCS One disaster recovery works in virtual environments” on page 82.

See “About setting up virtual machines for disaster recovery” on page 586.
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 26
Managing objects in 
Solaris zones 

This chapter includes the following topics:

■ About managing objects in Solaris zones

■ Zone configuration prerequisites

■ Deciding on the zone root location

■ Creating a Solaris zone

■ About installing applications in a zone

■ Configuring the application service group for the zone

■ Viewing zone operations

■ Modifying zone resource attributes

■ Configuring the local zone to run VCS One commands

■ Configuring Zone-Policy Master communication within a local site

■ Configuring a Zone for disaster recovery
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About managing objects in Solaris zones
Solaris zones allow you to create one or more isolated virtual environments on a 
single operating system instance. The application that runs inside a zone runs 
with exclusive access to resources configured for that zone. The application also 
has its own file system name space, users, and network. 

VCS One enables high availability for an application configured in a zone by 
making the zone itself highly available. 

To manage non-global or local zones on VCS One Solaris systems, you need to 
perform the following tasks in the order given.

Table 26-1

Step Action

1 Before you configure objects in Solaris zones in the VCS One cluster, be 
familiar with the design principles.

See “Designing service groups that run in Solaris zones” on page 301.

2 Review the prerequisites for configuring zones. 

See “Zone configuration prerequisites” on page 551.

3 Decide on the location of the zone root. 

See “Deciding on the zone root location” on page 552.

4 Decide how to configure the file system on shared storage that stores the 
application’s data. 

The file system can be directly mounted relative the global zone’s root 
directory or it can be loop back mounted. For the loop back mount, the mount 
is configured within the non-global zone.

More information is available about Veritas file systems. 

Refer to Veritas File System (VxFS) documentation. 

5 Configure, install, and boot the zone.

See “Creating a Solaris zone” on page 552.

6 Install the application in the zone.

See “About installing applications in a zone” on page 554.

7 Create the service group for the application and configure its resources.

See “Configuring the application service group for the zone” on page 555.

8 Configure the local zone to run ha-commands.

See “Configuring the local zone to run VCS One commands” on page 556.
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Zone configuration prerequisites 
Zone configuration prerequisites are as follows:

■ Each system on which applications will be configured in zone must run the 
same version of Solaris. The Solaris version must be a VCS One supported 
version.

See Veritas Cluster Server One Release Notes

■ VCS One supports UFS and VxFS file system mounts for the zone root. 

CFS mounts are not supported.

■ The autoboot property for the zone must be set to False.

■ Mounts must meet one of the following conditions:

■ Loop-back file system

All mounts used by the application must be part of the zone 
configuration and must be configured in the service group. For 
example, you can create a zone called z-ora, and define the file system 
that contains the application’s data to have the mount point as 
/oradata. When you create the zone, you can define a path in the 
global zone, such as /export/home/oradata, that the mount 
directory in the non-global zone maps to. The MountPoint attribute of 
the Mount resource for the application should be set to 
/export/home/oradata.

■ Direct mount file system

All file system mount points used by the application running in a zone 
must be set relative to the zone’s root. For example, if the Oracle 
application uses /oradata, and you create the zone with the zonepath 
as /z_ora, the mount must be /z-ora/root/oradata. The 
MountPoint attribute of the Mount resource must be set to this path.

More information is available about how to configure the application 
service group for the zone. 

9 Configure zone-specific resources and set up communication between the 
zone and Policy Master.

See “Configuring Zone-Policy Master communication within a local site” on 
page 558.

10 [Optional] Configure the zone to be disaster-recovery enabled.

See “Configuring a Zone for disaster recovery” on page 558.

Table 26-1

Step Action
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See “Configuring the application service group for the zone” on page 555.

Custom agent requirements 
If you use custom agents to monitor the applications that run in zones, make 
sure that the agents use script-based entry points. VCS One does not support 
running C++ entry points in non-global zones.

Deciding on the zone root location
The zone root is a top-level directory in a particular section of the file system 
hierarchy where the non-global zone is configured. 

Each non-global zone has its own section in the file system hierarchy. Processes 
running in the zone can access files only within the zone root.

You can set the zone root in two ways:

■ Zone root on local storage 

In this configuration, create a zone on each system listed in the service 
group’s SystemList attribute.

■ Zone root on shared storage 

If the zone root resides on shared storage, it can exist in the same disk 
group that contains the application’s data.

In this configuration, create a zone in shared storage from one system and 
then create identical configurations on each system listed in the service 
group’s SystemList attribute.

Setting the zone root on shared storage involves installing the non-global 
zone on shared storage from only one system. The non-global zone and the 
zone root can fail over to the other systems. The system software, including 
the patches, must be identical on each system during the existence of the 
zone.

Creating a Solaris zone
To create a zone with the zone root on local or shared storage, perform the 
following tasks: 

■ Configure the zone

■ Install the zone

■ Boot the zone

Ensure that the zone has been completely installed, including an initial boot of 
the zone, before you install the VCS One client.
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To configure a Solaris zone

1 Create the zone using the zonecfg command. At the command prompt, type 
the following:

zonecfg -z newzone
zonecfg:newzone> create

2 Set the zonepath parameter to the location of the zone root. At the 
command prompt, type the following:

zonecfg:newzone> set zonepath=/export/home/newzone

3 Set the zone autoboot parameter to false
zonecfg:newzone> set autoboot=false

4 Application data can reside on the loop back mounted file system or the 
direct mount file system. The loop back file system must reside inside the 
zone configuration. The direct mount file system must reside outside the 
zone configuration. Both the loop back file system and direct mount file 
system must be under VCS One control. 

The zonecfg command displays information about the zone’s properties 
and values. The zone information for a zone root created on local storage 
using the loop back file system (for application data) should be similar to 
the following: 

zonecfg -z newzone info
zonepath: /export/home/newzone
autoboot: false
pool:
inherit-pkg-dir:

dir: /lib
inherit-pkg-dir:

dir: /platform
inherit-pkg-dir:

dir: /sbin
inherit-pkg-dir

dir: /usr
fs:

dir: /oradata
special: /export/home/oradata

The zone information for a zone root created on shared storage using the 
direct mount file system (for application data) should be similar to the 
following: 

zonecfg -z newzone info
zonepath: /export/home/newzone
autoboot: false
pool:
inherit-pkg-dir:

dir: /lib
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inherit-pkg-dir:
dir: /platform

inherit-pkg-dir:
dir: /sbin

inherit-pkg-dir
dir: /usr

To install a Solaris zone

◆ Install the non-global zone using zoneadm command. At the command 
prompt, type the following:

zoneadm -z newzone install
Preparing to install zone <newzone>.
.....
Zone <newzone> is initialized.
...

If you want to configure the zone root on shared storage, you need to 
configure but not install the zone on all the systems listed in the service 
group’s SystemList attribute. For all other cases, you must configure and 
install the zone on all the system listed in the service group’s SystemList 
attribute.

To boot a Solaris zone 

◆ At the command prompt, type the following:

zoneadm -z newzone boot

More information is available about how to configure, install, and boot zones. 

Refer to Sun Microsystems documentation. 

About installing applications in a zone 
Perform the following tasks in the order provided to install the application in a 
zone:

■ If you have created zones locally on each system, install the application in 
the zone, identically on each system. 

■ Install the agent. 

Agent packages are installed in the global zone and the currently existing 
non-global zones. The operating system installs the agents in future 
non-global zones when they are created. 

More information is available about how to install the Oracle agent. 

Refer to the Veritas Cluster Server One Agent for Oracle Installation and 
Configuration Guide. 
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■ Mounts that are used by the application and accessed from within the zone, 
must be defined in the service group’s configuration.

Configuring the application service group for the 
zone

Configure the application service group and the required resource 
dependencies. 

More information is available about how to add a service group. 

See “Adding a service group or an infrastructure service group” on page 357. 

Viewing zone operations
The operation privileges within the zone apply only to the service group 
configured for the zone. 

The ZoneUserGroup role entails group and resource level administrative and 
operator privileges.

The ZoneUserFarm role includes only the Add Log privilege, which is required 
by the agents controlling the service group’s resources.

To view the ZoneUserGroup and ZoneUserFarm role privileges 

1 In the VCS One console, click Administration > Roles.

2 In the All Roles table, click ZoneUserGroup. 

3 View the group and resource privileges associated with the Zone User Group 
role. 

4 Click VCS One Roles in the upper-left corner of the screen. 

5 In the All Roles table, click ZoneUserFarm. 

6 View the group and resource privileges associated with the Zone User Farm 
role. 

Modifying zone resource attributes
This topic describes how to modify zone resource attributes.

To modify zone resource attributes using the VCS One console

1 In the VCS One console, locate the service group that contains the zone 
resource, which you want to modify. 
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See “Locating a service group” on page 364.

2 Check the service group that contains the resource to modify.

3 Click Configuration > Add/Modify Resource.

4 Click OK.

5 In the Results dialog box, click Advanced. The Edit Attribute dialog box is 
displayed. 

6 In the Edit Attribute dialog box, under Value, locate the zone resource 
attribute that you want to modify and change its value.

7 Click OK > Close.

Configuring the local zone to run VCS One 
commands

To execute VCS One commands within a local zone, such as the commands used 
to monitor, start, and stop an application, the agent needs to communicate with 
the client daemon running in the global zone. To communicate, a connection is 
made to the VCS One client daemon that runs in the global zone.

To allow this connection, secure communication must be established between 
the zone and the Policy Master cluster, and a long-term service user credential is 
cached in the local zone. The Zone agent renews the zone user credential after 
every 180 day period of time. The zone must be ONLINE or the renewal will not 
occur.

Additionally, before you execute VCS One commands from the local zone, you 
must either create a vcsone.conf file manually or configure environment 
variables in the local zone. If you configure environment variables in the local 
zone, you do not also need to configure the vcsone.conf file for this operation.

How you configure Zone-Policy Master communication varies slightly 
depending on whether your configuration is set up for a local site only or 
whether your configuration includes a disaster recovery site.

To configure the local zone to run VCS One commands using a vcsone.conf file

1 Configure Zone to Policy Master communications.

See “Configuring Zone-Policy Master communication within a local site” on 
page 558.

See “Configuring a Zone for disaster recovery” on page 558.

2 Create a file called vcsone.conf in the $VCS ONE_CONF directory.

The variable $VCSONE_CONF is usually set to the /etc/VRTSvcsone 
directory.
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3 Insert the following information in the vcsone.conf file.
PM_IPS=[pm_ip]:port:[src_ip] [pm_ip2]:port:[src_ip]
Username=zone_user_name

Use the following information to replace the appropriate variables

To configure the local zone to run VCS One commands using environment 
variables

1 Configure Zone to Policy Master communications.

See “Configuring Zone-Policy Master communication within a local site” on 
page 558.

See “Configuring a Zone for disaster recovery” on page 558.

2 Use the following information to set these environment variables in the 
local zone.

pm_ip, pm_ip2 The list of virtual IP addresses of the Policy Master.

src_ip [optional] Local IP address on the client node as the source IP 
address to bind.

zone_user_name The fully qualified name of the zone user. In the following format:

zone@VCSONE_CONTAINER_USERS@vcsone_cluster

VCSONE_SERVER_IP The virtual IP address of the Policy Master cluster. The 
virtual IP address of the Policy Master remains static 
during a Policy Master switch or failover operation. 
For example: 192.168.1.2.

VCSONE_SERVER_PORT The port configured for the Policy Master as defined in 
vcsone.ini. This port is the port on which the Policy 
Master is listening for connections. For example: 14151.

VCSONE_DOMAINTYPE The domain type of the domain in which the Zone user is 
created. For example: vx.

VCSONE_USERNAME The user name assigned to the Zone user. For example: 
Z1zone1@VCSONE_CONTAINER_USERS@vcsone_cluster

VCSONE_LOCAL_NAME The name of the global zone.

PATH Add the path /opt/VRTSvcsone/bin to your PATH 
variable.
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Configuring Zone-Policy Master communication 
within a local site

This procedure is one of the steps required to configure the local zone to run 
VCS One commands.

See “Configuring the local zone to run VCS One commands” on page 556.

To configure Zone-Policy Master communication within a local site

1 Set up network identity and capability for the zone.

The non-global zone requires a virtual IP address and a hostname to 
communicate on the network, independent of the global zone in which it 
exists. Modify the network specific files in the non-global zone’s /etc 
directory. For example, the network hostname used by Z1 is Z1zone.

2 Type the following command to bring the zone resource to the ONLINE state.
hares -online zoneres -sys globalzonesys

3 Ensure the application resource is not ONLINE or enabled.

4 Provision a new user for the local zone and deploy a user credential for that 
user inside the local zone.

Type the following command 
hares -action zoneres provision_zuser -actionargs password -sys 
globalzone

Use the following information to replace the appropriate variables

Configuring a Zone for disaster recovery
To configure a Zone for disaster recovery, you must configure Zone to Policy 
Master communication appropriately.

In a disaster recovery configuration, the zone root may or may not be replicated 
from a primary site to a secondary site.

To configure Zone-Policy Master communication with a disaster recovery 
configuration if the zone root is replicated

◆ Configure the Zone attribute DROpts at each site.

zoneres The name of the zone resource

password The password of the zone user

globalzone The name of the global zone

globalzonesys The name of the system that runs the global zone.
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When DROpts is configured correctly, the Zone agent manages the user 
credential provisioning at each site.

The value of this attribute consists of the following keys that define the 
disaster recovery (DR) options for the Zone.

■ DNSDomain

The domain name to use within the Zone at this site.

■ DNSSearchPath

The domain search path used by this Zone at this site.

■ DNSServers

The list of DNS servers used by this Zone at this site.

■ Gateway

The default Gateway used by this Zone at this site.

In a DR configuration, if one or more of these keys are set, the resource is 
considered to be DR-enabled. If all the keys stay at their default value (''), 
then the resource is not DR-enabled even if it is in a disaster recovery 
configuration.

The agent modifies the networking files inside the Zone during a cross-site 
failover if the resource is considered to be DR-enabled.

See the Veritas Cluster Server One Bundled Agent’s Reference Guide.

To configure Zone-Policy Master communication with a disaster recovery 
configuration if the zone root is not replicated

You must manually provision a new user for the local zone and deploy a user 
credential for that user inside the local zone at each disaster recovery site. 

See “To configure Zone-Policy Master communication within a local site” on 
page 558.
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This chapter includes the following topics:

■ About managing objects in a logical domains environment

■ Designing a managed LDom

■ About managing an LDom using VCS One

■ Configuring an LDom for disaster recovery
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About managing objects in a logical domains 
environment

Logical Domains are a Sun Microsystem’s product that allows a single physical 
server to be virtualized into multiple independent operating system instances.

VCS One provides application management and high availability to LDoms and 
applications running in LDoms.

As a best practice, create and boot the LDom in the Solaris environment before 
putting the LDom under VCS One control.

Designing a managed LDom
An LDom is a VFrame object in the VCS One configuration that contains one 
LDom resource, and at least one network resource and storage resource.

Each of these resources must have particular attributes defined in order for the 
LDom agent to monitor the LDom.

See the LDom agent in the Veritas Cluster Server One Bundled Agents Reference 
Guide.

About managing an LDom using VCS One
Use this process to put an LDom under VCS One control.

If you use the GUI, the Add VFrame wizard allows you to also configure the 
following aspects of the LDom:

■ Resources in the LDom

■ PFrames on which the LDom may run (PFrameList)

■ Organization Tree node to which the LDom is attached

■ Advanced workload management

Use the following process to configure a managed LDom:

Add a VFrame Use the Add VFrame menu item in the GUI. Specify the VType 
LDomsVM.

VCS One can not auto-discover an LDom environment.

See “Adding a VFrame” on page 507.
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Configuring an LDom for disaster recovery
When you have multiple cluster sites and you want LDoms to fail over between 
clusters, you can configure LDoms for disaster recovery.

See “How VCS One disaster recovery works in virtual environments” on page 82.

See “About setting up virtual machines for disaster recovery” on page 586.

Configure LDom 
resources

The resources of the LDom VFrame must have particular attributes 
defined in order for the LDom agent to monitor it.

See “Logical Domain virtual machine attributes” on page 928.

See the Veritas Cluster Server One Bundled Agents Reference Guide.
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Managing objects in AIX 
Workload Partitions 
(WPARs)

This chapter includes the following topics:

■ About managing service groups in AIX Workload Partitions

■ Prerequisites for configuring VCS One in WPARs

■ Setting the WPAR root path

■ Installing the application

■ Creating the WPAR-enabled service group

■ Maintenance tasks

■ Configuring the WPAR to run VCS One commands

■ Configuring WPAR-Policy Master communication within a local site

■ Configuring a WPAR for disaster recovery
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About managing service groups in AIX Workload 
Partitions

An AIX workload partition (WPAR) is a virtualized operating system 
environment within an instance of the AIX operating system. AIX WPARs 
provide an isolated and secure environment for running applications. 

The WPAR must be installed and configured before it can be brought under VCS 
One control.

Before you configure VCS One with WPARs, be familiar with proper VCS One 
WPAR service group design.

See “Designing service groups that run in AIX WPARs” on page 306.

Note: VCS One provides support for system WPARs. VCS One does not provide 
support for application WPARs.

Table 28-1 Steps to configure VCS One using WPARs

Step Description

1 Review the prerequisites. 

See “Prerequisites for configuring VCS One in WPARs” on page 567.

2 Decide on the location of the WPAR root. 

A WPAR root is the topmost directory in a section of the file system 
hierarchy in which the WPAR is configured. 

See“Setting the WPAR root path” on page 568.

3 Install the application in the WPAR. 

See “Installing the application” on page 571. 

4 Create the application service group and configure its resources.

See “Creating the WPAR-enabled service group” on page 571.

5 Configure the WPAR to run ha-commands.

See “Configuring the WPAR to run VCS One commands” on page 572.

6 Configure WPAR-specific resources and set up communication between the 
WPAR and Policy Master.

See “Configuring WPAR-Policy Master communication within a local site” 
on page 573.
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Prerequisites for configuring VCS One in WPARs
Check the following prerequisites before configuring WPARS:

■ All systems hosting applications configured in WPARs must be running the 
same version and a supported version of the operating system.

See Veritas Cluster Server One Release Notes.

■ The WPAR root must be installed on JFS, JFS2, or NFS.

■ Configure the WPAR to not auto start on boot of the global environment.

■ Mounts must meet one of the following two conditions:

■ Use a namefs file system

In this condition, the file system mount point used by the application 
running in a WPAR is mounted from a directory that exists inside the 
Global environment. 

For example, in the global environment you have the directory /export/
home/oradata which is to be used by the WPAR to store application 
data. When you create the WPAR, provide the directory path from the 
global environment (e.g /export/home/oradata) along with the mount 
location inside the WPAR (i.g. /oradata), specifying the vfs type of 
'namefs'. 

■ Use a direct mount file system. 

In this condition, the file system mount point used by the application 
running in a WPAR is mounted inside the global environment relative 
to the WPAR’s root. 

For example, if the Oracle application uses /oradata, and you create the 
WPAR with the WPARpath as /wpars/w_ora, then inside the global 
environment the file system must be mounted to /wpars/w_ora/
oradata. The MountPoint attribute of the Mount resource must be set 
to this path. 

Using custom agents in WPARs
■ If you use custom agents to monitor applications running in WPARs, make 

sure the agents use script-based entry points. VCS One does not support 
running C++ entry points inside a WPAR. 

7 [Optional] Configure the WPAR to be disaster-recovery enabled.

See “Configuring a WPAR for disaster recovery” on page 574.

Table 28-1 Steps to configure VCS One using WPARs

Step Description
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■ If you want the custom agent to monitor an application in the WPAR, for the 
custom agent type, set the following values for the ContainerOpts attribute: 
RunInContainer = 1 and the PassCInfo = 0.

■ If you don't want the custom agent to monitor an application in the WPAR, 
for the custom agent type, set the following values for the ContainerOpts 
attribute: RunInContainer = 0 and the PassCInfo= 0. 

Setting the WPAR root path
Each WPAR has its own section of the file system hierarchy in the WPAR root 
directory. Processes running in the WPAR can access files only within the 
WPAR root. 

You can set the WPAR root in two ways:

■ WPAR root on local storage—In this configuration, you must create a WPAR 
on each client system in the VCS One cluster. 

■ WPAR root on NFS—In this configuration, create a WPAR on the NFS 
storage. In this case, you need to duplicate the configuration across all the 
client systems.

When you set the WPAR root on NFS, install the WPAR from one client 
system only. The WPAR root can fail over to the other client systems. The 
system software, including the patches, must be identical on each client 
system during the existence of the WPAR.

Creating a WPAR root on local disk   
Use the following steps to create a WPAR root on the local disk of each client 
system. 

To create a WPAR root on local disks of each client system

1 Create the actual WPAR root directory.

2 Use the mkwpar command to create the WPAR.
mkwpar -n wpar -h host -N ip_info -d wroot -o /tmp/wpar.log

Use the following information to replace the appropriate variables:

wpar The name of the WPAR.

hostname The name of the system on which the WPAR is created.
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3 Repeat the command in step 2 to create the WPAR on each system in the 
service group’s SystemList.

4 On one of the systems in the SystemList, mount the shared file system 
containing the application data. 

5 Start the WPAR.

Creating WPAR root on shared storage using NFS
Use the following steps to create a WPAR root on shared storage using NFS. 

To create WPAR root on shared storage using NFS 

1 Create a file system on NFS storage for the WPAR root. The file system that 
is to contain the WPAR root may be in the same file system as the file system 
containing the shared data.

2 Type the following mkwpar command to create the WPAR: 
mkwpar -n wpar -h host -N ip_info -r -M r_fs -M v_fs 
-M h_fs -M t_fs -d wroot

Use the following information to replace the appropriate variables:

ip_info Replace this variable with the information to set the virtual IP address of the
system to be the IP address of the WPAR. This value also defines the device 
name for the NIC associated with the IP address.

If you don't specify the value of the interface or netmask, the global 
partition’s values are used.

Use the following format to replace ip_info:

interface=interface netmask=netmask address=IPaddress

For example:

interface=’en0’ address=’172.16.0.0’ 

netmask=’255.255.255.0’

wroot Replace this variable with the location of the WPAR root directory,
for example, /wpars.

wpar The name of the WPAR.

host The name of the system on which the WPAR is created.
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3 Use the lswpar command to display information about the WPAR’s 
properties and their values.

4 On the system where you created the WPAR, run the command: 
mkwpar -w -o config_file_name -e wparname_just_created

5 On all the other systems copy the configuration file, run the command:
mkwpar -p -f config_file_name -n wparname_just_created

6 List the WPAR.

7 Start the WPAR.

8 On one system, mount the shared file system containing the application 
data. 

9 Make sure the WPAR created from the first system is in the D state on all 
other systems in the service group’s System List.

ip_info Replace this variable with the information to set the virtual IP address of the 
system to be the IP address of the WPAR. This value also defines the device 
name for the NIC associated with the IP address.

If you don't specify the value of the interface or netmask, the global 
partition’s values are used.

Use the following format to replace ip_info:

interface=interface netmask=netmask address=IPaddress

For example:

interface=’en0’ address=’172.16.0.0’ netmask=’255.255.255.0’

r_fs Replace this variable with the information to specify the NFS volume to use 
for the root private file system for the WPAR. For example:

directory=/ vfs=nfs host=host123 dev=/root01

v_fs Replace this variable with the information to specify the NFS volume to use 
for the /var private file system for the WPAR. For example:

directory=/ var vfs=nfs host=host123 dev=/var01

h_fs Replace this variable with the information to specify the NFS volume to use 
for the /home private file system for the WPAR. Examples of values:

directory=/home vfs=nfs host=host123 dev=/home01 

t_fs Replace this variable with the information to specify the NFS volume to use 
for the root private file system for the WPAR. Examples of values:

directory=/tmp vfs=nfs host=host123 dev=/tmp01

wroot Replace this variable with the location of the WPAR root directory,
for example, /wpars.
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Installing the application
Install the application in the WPAR. 

■ If you have created WPARs on each client system, install the application 
identically on each client system. If you are installing an application 
supported by a VCS One enterprise agent, see the installation and 
configuration guide for the agent. 

■ Install the agent. 

Agent packages are installed in the global environment as well as the 
currently existing WPARs. The operating system installs the agents in 
future WPARs when they are created. 

■ In the WPAR, configure all mount points used by the application. 

■ If you use namefs mounts, verify the global directories are properly 
mounted inside the WPAR.

■ If you use a direct mount, verify the mount points used by the 
application have been mounted relative to the WPAR’s root. 

For example, if a WPAR w_ora needs to use 
/oracle, mount the drive at /wpars/w_ora/oracle. 

Creating the WPAR-enabled service group
Create a service group with the standard managed application resource types 
(Application, Storage, Networking) with the addition of a WPAR resource. 

See “Adding a service group or an infrastructure service group” on page 357.

Use the following information to customize the service group to be 
WPAR-enabled:

■ Configure the service group’s ContainerInfo attribute.

■ Configure each resource’s ContainerOpts attribute.

■ If the application requires an IP address, set the ContainerInfo:Name 
attribute for the IP resource to the name of the WPAR. 

■ Set the ContainerInfo:Type attribute = WPAR for the Application resource.

■ Set the ContainerInfo:Name attribute for the Application resource to the 
name of the WPAR in which the application runs.

■ Set the MountPoint attribute of the Mount resource to the mount path.

■ Modify the resource dependencies to reflect your WPAR configuration. 

See “Designing resource dependencies for WPAR-enabled service groups” 
on page 308.
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■ Where the WPAR root file system is on shared storage, you can configure 
separate mounts for the WPAR and the application but you may configure 
the same disk group for both.

Save the service group configuration and bring the service group online. 

Maintenance tasks 
■ Make sure that the WPAR configuration files are consistent on all the client 

systems at all times. 

Run the mkwpar -e wparname -w -o config_filename command to view 
the file.

■ When you add a patch or upgrade the operating system on one client 
system, make sure to upgrade the software on all client systems. Use the 
syncwpar command to upgrade the software in the WPAR.

In configurations where the WPAR moves between systems, sure that the 
application configuration is identical on all system. If you update the application 
configuration on one system, apply the same updates to all systems.

Configuring the WPAR to run VCS One commands
To execute VCS One commands within a WPAR, such as the commands used to 
monitor, start, and stop an application, the agent needs to communicate with 
the client daemon running in the global environment (global WPAR). To 
communicate, a connection is made to the VCS One client daemon that runs in 
the global environment.

To allow this connection, secure communication must be established between 
the WPAR and the Policy Master cluster, and a long-term service user credential 
is cached in the local WPAR. The WPAR agent renews the user credential after 
every 180 day period of time. The WPAR must be ONLINE or the renewal will not 
occur.

Additionally, before you execute VCS One commands from the WPAR, you must 
configure environment variables in the WPAR.

How you configure WPAR-Policy Master communication varies slightly 
depending on whether your configuration is set up for a local site only or 
whether your configuration includes a disaster recovery site.

To configure the WPAR to run VCS One commands

1 Configure WPAR to Policy Master communications.

See “Configuring WPAR-Policy Master communication within a local site” 
on page 573.
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See “Configuring a WPAR for disaster recovery” on page 574.

2 Use the following information to set these environment variables in the 
WPAR.

Configuring WPAR-Policy Master communication 
within a local site

This procedure is one of the steps required to configure the local WPAR to run 
VCS One commands.

See “Configuring the WPAR to run VCS One commands” on page 572.

To configure WPAR-Policy Master communication within a local site

1 Set up network identity and capability for the WPAR.

The WPAR requires a virtual IP address and a hostname to communicate on 
the network, independent of the WPAR in which it exists. Modify the 
network specific files in the WPAR’s /etc directory. For example, the 
network hostname used by WP1 is WP1wpar.

2 Type the following command to bring the WPAR resource to the ONLINE 
state.
hares -online wpar_res -sys globalwpar

3 Ensure the application resource is not ONLINE or enabled.

4 Provision a new user for the WPAR and deploy a user credential for that user 
inside the WPAR.

VCSONE_SERVER_IP The virtual IP address of the Policy Master cluster. The 
virtual IP address of the Policy Master remains static 
during a Policy Master switch or failover operation. 
For example: 192.168.1.2.

VCSONE_SERVER_PORT The port configured for the Policy Master as defined in 
vcsone.ini. This port is the port on which the Policy Master 
is listening for connections. For example: 14151.

VCSONE_DOMAINTYPE The domain type of the domain in which the WPAR user is 
created. For example: vx.

VCSONE_USERNAME The user name assigned to the WPAR user. For example: 
W1wpar1@VCSONE_CONTAINER_USERS@vcsone_cluster

VCSONE_LOCAL_NAME The name of the global environment.

PATH Add the path /opt/VRTSvcsone/bin to your PATH variable.
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Type the following command 
hares -action wpar_res provision_container_user -actionargs 
password -sys globalwpar

Use the following information to replace the appropriate variables

Configuring a WPAR for disaster recovery
To configure a WPAR for disaster recovery, you must configure WPAR to Policy 
Master communication appropriately.

In a disaster recovery configuration, the WPAR root may or may not be 
replicated from a primary site to a secondary site.

To configure WPAR-Policy Master communication with a disaster recovery 
configuration if the WPAR root is replicated

◆ Configure the DROpts attribute for the WPAR resource at each site.

When DROpts is configured correctly, the WPAR agent manages the user 
credential provisioning at each site.

The value of this attribute consists of the following keys that define the 
disaster recovery (DR) options for the WPAR.

■ DNSDomain

The domain name to use within the WPAR at this site.

■ DNSSearchPath

The domain search path used by this WPAR at this site.

■ DNSServers

The list of DNS servers used by this WPAR at this site.

■ Gateway

The default Gateway used by this WPAR at this site.

The agent modifies the networking files inside the WPAR during a cross-site 
failover if the resource is considered to be DR-enabled.

See the Veritas Cluster Server One Bundled Agent’s Reference Guide.

To configure WPAR-Policy Master communication with a disaster recovery 
configuration if the WPAR root is not replicated

You must manually provision a new user for the local WPAR and deploy a user 
credential for that user inside the local WPAR at each disaster recovery site. 

wpar_res The name of the WPAR resource

password The password of the WPAR user

globalwpar The name of the global WPAR
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See “To configure WPAR-Policy Master communication within a local site” on 
page 573.
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Section
 VI

Tasks: Setting up and 
managing global clusters

This section includes the following chapters:

■ “Setting up VCS One global clusters” on page 579

■ “Managing remote clusters” on page 593

■ “Managing global composite service groups” on page 613
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Setting up VCS One global 
clusters

This chapter includes the following topics:

■ About setting up VCS One global clusters

■ Setting up a global cluster configuration

■ About setting up virtual machines for disaster recovery

■ Configuring LDoms for disaster recovery

■ Configuring ESX servers for disaster recovery

■ Testing VCS One disaster recovery support
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About setting up VCS One global clusters
Figure 23-1 depicts the high-level workflow to set up a global cluster where VCS 
One cluster is already configured at the primary site s1, and has application set 
up for high availability. For virtual environments: See “About setting up virtual 
machines for disaster recovery” on page 586.

Figure 23-1 High-level workflow to set up VCS One global clusters
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Before you set up the global cluster, make sure you completed the following:

■ Review the concepts.

See “About VCS One global clusters” on page 74.

■ Plan the configuration and verify that you have the required physical 
infrastructure.

See “Typical VCS One global cluster setup” on page 76.

See “About global cluster building blocks” on page 75.

■ If you plan to set up disaster recovery for virtual environments such as 
LDoms or ESX servers, review the DR concepts and typical setup 
information for virtual environments.

See “How VCS One disaster recovery works in virtual environments” on 
page 82.

See “About setting up virtual machines for disaster recovery” on page 586.

■ Verify that you have the required software to install VCS One and the 
appropriate replication agent.
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This procedure assumes that you have configured a VCS One cluster at the 
primary site and have set up application for high availability.

Note: For disaster recovery on Windows clients, VCS One requires that the 
primary and secondary site and corresponding Policy Master clusters be in the 
same domain.

Table 23-1 lists the high-level tasks to set up VCS One global clusters.

Configuring application and replication
Perform the following steps to configure application at the secondary site. This 
procedure assumes that you have already set up application for high availability 
at the primary site.

To configure application and replication

1 At the secondary site, install and configure the application that you want to 
make highly available.

See the corresponding application documentation for instructions.

2 At each site, set up data replication using a replication technology that VCS 
One supports.

See the corresponding replication documentation for instructions.

Configuring clusters
Perform the following steps to configure the Policy Master clusters for disaster 
recovery.

Table 23-1 Task map to set up VCS One global clusters

Task Reference

Task A See “Configuring application and replication” on page 582.

Task B See “Configuring clusters” on page 582.

Task C See “Configuring service groups” on page 585.

Task D See “Configuring global CSGs” on page 585.
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To configure clusters

1 If you want to use the Policy Master virtual IPs for inter-cluster 
communication, then skip to step 2.

At the primary site, configure the virtual IP addresses for inter-cluster 
communication, as follows:

2 At the secondary site, install and configure VCS One cluster.

Note the following points for Policy Master installation and configuration:

■ Enter a unique cluster name.

■ Unless you want to use the Policy Master virtual IPs for inter-cluster 
communication, configure unique virtual IP addresses for inter-cluster 
communication.

See the Veritas Cluster Server One Installation Guide for instructions.

For the Windows Policy Master, see step 1 for instructions on configuring 
unique virtual IP addresses for inter-cluster communication.

3 At each site, verify the cluster configuration. Perform the following steps:

■ Make sure that the PMSG and DRSG is up and running.

On UNIX If you have not already completed these steps during the VCS One 
cluster configuration, run the following command on one of the 
systems in the Policy Master and follow the prompts:

# /opt/VRTS/install/installvcsonepm -configuredr

The -configuredr option of the installvcsonepm program creates a 
DRSG service group.

See the Veritas Cluster Server One Installation Guide for instructions.

On Windows After the Policy Master has already been installed and configured on 
the primary site, run the Policy Master Disaster Recovery 
Configuration Wizard as follows: 

■ Launch the Policy Master Disaster Recovery Configuration 
Wizard (Start > All Programs > Symantec > VCS One > Policy 
Master Disaster Recovery Configuration Wizard).

■ Use the wizard to specify a unique virtual IP address and subnet 
mask to be used for Policy Master communications between the 
two sites and select a public NIC (static IP address) on each Policy 
Master system. 

On UNIX Use the following command:

# /opt/VRTSvcsone/bin/haadmin -state
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The output must show the PMSG state as ONLINE.

If you had configured unique virtual IPs for inter-cluster 
communication, then the output must also show the DRSG state as 
ONLINE.

4 At each site, set up trust with the root broker of the remote cluster. You must 
set up trust for each IP address that is used for inter-cluster 
communication.

5 At each site, configure the remote cluster object. 

Add a remote cluster and set up communication between the clusters. VCS 
One requires you to specify the remote cluster connection details only on 
the cluster that VCS One designates to initiate the connection request 
between the clusters.

See “Adding remote clusters” on page 594.

See “How VCS One global clusters communicate with each other” on 
page 77.

On Windows Use the following command:

%VCSONE_HOME%\bin\haadmin -state

On UNIX Use the following command:

# /opt/VRTSvcsone/bin/haat setuptrust \

–b remote_broker_ip:remote_broker_port –s 

securitylevel

For securitylevel, use one of the following values: low, medium, 
or high. 

The default value for remote_broker_port is 14159.

See the Veritas Cluster Server One Installation Guide for instructions.

On Windows Use the following command. 

Note: If UAC is enabled and you are logged in as a non-default 
administrator, ensure that you use Run as administrator mode to 
execute the command.

%VCSONE_HOME%\bin\haat setuptrust \

–b remote_broker_ip:remote_broker_port –s 

securitylevel

For securitylevel, use one of the following values: low, medium, 
or high. 

The default value for remote_broker_port is 14159.
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6 At each site, enable the connectivity to the remote cluster.

See “Enabling connections between clusters” on page 600.

Configuring service groups
Perform the following steps to configure the service groups for disaster 
recovery.

To configure service groups

1 At the secondary site, set up the application for high availability.

Configure VCS One service groups for the application.

See “Adding a service group or an infrastructure service group” on 
page 357.

2 At each site, configure a composite service group. 

Perform the following steps:

■ Create a CSG.

You must create the CSG at the same OU node (or at a higher OU node) 
as that of the service groups that it will contain.

The CSG name must be the same as the one that you configured at the 
primary site. However, the service group names need not be the same 
at both the sites.

■ Add the application service group to the CSG.

■ Verify the state of the CSG.

■ Configure users and privileges for the CSG.

See “Creating a composite service group” on page 406.

3 At each site, install and configure the VCS One agent for replication.

See the Installation and Configuration Guide for the corresponding VCS 
One replication agent for instructions.

Configuring global CSGs
Perform the following steps to configure global composite service groups (CSGs) 
for disaster recovery.

To configure global CSGs

1 On each site, configure the CSGs for disaster recovery. 

Perform the following steps:

■ Make the CSG a global CSG.

■ Verify the state of the global CSG.

The global CSG must be online at the primary site. 
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See “Configuring a global CSG” on page 614.

2 If your setup uses BIND DNS, add a resource of type DNS to the application 
service group at each site.

Refer to the Veritas Cluster Server One Bundled Agent’s Reference Guide for 
more details.

About setting up virtual machines for disaster 
recovery 

Figure 23-2 depicts a typical setup of VCS One client systems for disaster 
recovery in virtual environments. Each site has two physical servers with three 
virtual machines. The boot image of each virtual machine is on shared storage 
and is replicated using a VCS One supported replication technology. 

Figure 23-2 Typical setup of VCS One client systems for disaster recovery in 
virtual environments
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Figure 23-3 illustrates a dependency chart for the global CSG in virtual 
environments. 

Figure 23-3 Typical dependency chart for the global CSG in virtual environments

To configure LDoms for DR:

See “Configuring LDoms for disaster recovery” on page 587.

To configure ESX servers for DR:

See “Configuring ESX servers for disaster recovery” on page 589.

Configuring LDoms for disaster recovery
This procedure assumes that you want to configure LDoms for disaster recovery 
where the boot image of the LDom is replicated to the remote site.

To configure LDoms for disaster recovery

1 Make sure that VCS One Policy Master clusters are set up for inter-cluster 
communication.

See “Configuring clusters” on page 582.

2 On the local cluster, perform the following steps:

■ Make sure you configured VCS One to manage LDoms.

See “About managing an LDom using VCS One” on page 562.

■ From the VCS One software disc, install the network reconfiguration 
package (VRTSvcsnr) in each guest domain.
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3 On the remote cluster, perform the following steps:

■ Make sure that the LDom has access to replicated storage.

■ Install and configure VCS One client daemon on the control domain of 
each LDom.

See the Veritas Cluster Server One Installation Guide.

■ Create PFrame object for each LDom.

See “Adding an PFrame” on page 492.

■ Create VFrame object for each guest domain.

See “Adding a VFrame” on page 507.

If you want to fail over the guest domain between LDoms, then add the 
PFrame object name to the PFrameList attribute of the VFrame 
corresponding to that LDom.

■ If you have set up VCS One at the primary site to monitor applications 
in the guest domain, then do the following:

■ Add a System object corresponding to this guest domain to the 
Policy Master at the secondary site.

■ Link each guest domain’s System object and VFrame object.

See “Linking a VFrame to a system” on page 516.

■ Create a service group to monitor the application and add the 
name of the System object of this guest domain to the service 
group’s SystemList attribute.

4 At each site, set up data replication using a replication technology that VCS 
One supports. 

See the corresponding replication documentation for instructions.

5 At each site, install and configure the VCS One agent for replication. While 
configuring: 

■ Create an infrastructure service group (ISG).

See “Adding a service group or an infrastructure service group” on 
page 357.

■ Add the replication resource to the ISG. You can also add any other 
resources that are common to the guest domains to this ISG.

■ Add the appropriate PFrame objects to the SystemList.

See the Installation and Configuration Guide for the corresponding VCS 
One replication agent for instructions.

6 At each site, configure a CSG:

■ Create dependency between the ISG and the VFrames that depend on it.

■ For application-aware VMs, create dependency between the application 
service group and the corresponding VFrame.
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■ Add VFrames to the VFrameList.

■ Add the ISG and any application service groups to the GroupList.

7 At each site, make the CSG a global CSG.

See “Configuring global CSGs” on page 585.

8 At each site, edit the NetworkDetails attribute of the VFrame object 
corresponding to each guest domain.
havframe -modify -refreshvars vframe_name LDomsVM:NetworkDetails 
-update IPAddress ipaddr Netmask netmask Gateway gateway 
[DNS list_DNS_servers]

Configuring ESX servers for disaster recovery
This procedure assumes that you want to configure ESX virtual machines for 
disaster recovery where the boot image of the ESX server is replicated to the 
remote site.

To configure ESX servers for disaster recovery

1 Make sure that VCS One Policy Master clusters are set up for inter-cluster 
communication.

See “Configuring clusters” on page 582.

2 On the local cluster, perform the following steps:

■ Make sure you configured VCS One to manage ESX servers.

See “Configuring VCS One to manage VMware-based objects” on 
page 538.

■ Make sure you installed the VMware Tools in each ESX virtual 
machine.

■ From the VCS One software disc, install the network reconfiguration 
package (VRTSvcsnr) in each ESX virtual machine.

3 On the remote cluster, perform the following steps:

■ Make sure that the ESX servers have access to replicated storage.

■ Install and configure VCS One client daemon on the ESX servers. For an 
ESXi server, first install the Management VM in the ESX server, and 
then install the VCS One client on this Management VM.

See the Veritas Cluster Server One Installation Guide.

■ Create PFrame object for each ESX server.

See “Adding an PFrame” on page 492.

■ Create VFrame object for each ESX virtual machine.

See “Adding a VFrame” on page 507.
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If you want to fail over the ESX virtual machines between ESX servers, 
then add the PFrame object name to the PFrameList attribute of the 
VFrame corresponding to that ESX server.

■ If you have set up VCS One at the primary site to monitor applications 
in the ESX virtual machine, then do the following:

■ Add a System object corresponding to this ESX virtual machine to 
the Policy Master at the secondary site.

■ Link each ESX virtual machine’s System object and VFrame object.

See “Linking a VFrame to a system” on page 516.

■ Create a service group to monitor the application and add the 
name of the System object corresponding to this ESX virtual 
machine to the service group’s SystemList attribute.

4 At each site, set up data replication using a replication technology that VCS 
One supports. 

See the corresponding replication documentation for instructions.

5 At each site, install and configure the VCS One agent for replication. 

While installing:

■ For ESX 3.5 and ESX 4.0: Install the agent in the Console OS of the ESX 
server.

■ For ESX 4.0i: Install the agent in the Management VM.

While configuring:

■ Create an infrastructure service group (ISG).

See “Adding a service group or an infrastructure service group” on 
page 357.

■ Add the replication resource to the ISG. You can also add any other 
resources that are common to the ESX virtual machines to this ISG.

■ Add the appropriate PFrame objects to the SystemList.

See the Installation and Configuration Guide for the corresponding VCS 
One replication agent for instructions.

6 At each site, configure a CSG:

■ Create dependency between the ISG and the VFrames that depend on it.

■ For application-aware VMs, create dependency between the application 
service group and the corresponding VFrame.

■ Add VFrames to the VFrameList.

■ Add the ISG and any application service groups to the GroupList.

7 At each site, make the CSG a global CSG.

See “Configuring global CSGs” on page 585.
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8 At each site, edit the NetworkDetails attribute of the VFrame object 
corresponding to each ESX virtual machine.
havframe -modify -refreshvars vframe_name ESXVM:NetworkDetails -
update IPAddress ipaddr Netmask netmask Gateway gateway 
[DNS list_DNS_servers]

Testing VCS One disaster recovery support
After you have set up VCS One global clusters, test the HA/DR support. This test 
is to perform a planned switchover and a switchback of the global CSG and the 
test requires some planned downtime.

See “Switching a global CSG” on page 618.

Note: Depending on the replication technology, you may have to update the data 
on the primary site before you switch back the global CSG.

To test VCS One disaster recovery support

1 Perform a planned switchover.

Switch over the global CSG from the primary site to the secondary site.
# hacsg -switch csg_name -clus secondary_clus 

2 Perform a planned switchback.

Depending on whether the replication technology requires you to manually 
update the data at the primary site, perform the following steps:

Data requires manual 
update on the 
primary

■ Take the global CSG offline at the primary site.

■ Perform the replication agent’s update action at the 
primary site.

■ Bring the global CSG online on the primary site.

Refer to the Installation and Configuration Guide for the 
corresponding VCS One replication agent for details.

Data is automatically 
updated on the 
primary

Run the following command to switch back the global CSG 
from the secondary site to the primary site:

# hacsg -switch csg_name -clus primary_clus
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Managing remote clusters

This chapter includes the following topics:

■ About managing remote clusters

■ Adding remote clusters

■ Determining the connection role of clusters

■ Viewing remote clusters

■ Viewing remote cluster details

■ Editing remote cluster attributes

■ Deleting remote clusters

■ Enabling connections between clusters

■ Disabling connections between clusters

■ Viewing the status of individual network links

■ Viewing the consolidated status of network links

■ Viewing the state of the clusters

■ Modifying remote cluster configuration

■ Changing the local cluster’s DR port value

■ Changing the local cluster’s DR address value

■ Setting up and removing trust with the remote cluster

■ Faulting a remote cluster using the Simulator

■ Clearing a simulated cluster fault using the Simulator

■ Simulating a link fault

■ Clearing a simulated link fault
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About managing remote clusters
In a global cluster setup, a remote cluster object defines the other clusters to 
which the local cluster connects and communicates over an IP network.

See “About VCS One global clusters” on page 74.

Adding remote clusters
You must have Add Cluster privilege in the farm category to add a remote 
cluster to the VCS One cluster. 

See “Catalog of farm privileges” on page 756.

Before you add a remote cluster, make sure that you have set up trust with the 
root broker of the remote cluster.

See “Setting up and removing trust with the remote cluster” on page 608.

You must provide the following details for the remote cluster that you want to 
add. 

See “Remote cluster attributes” on page 836.

See “How VCS One global clusters communicate with each other” on page 77.

Use the following procedure to add a remote cluster.

To add a remote cluster using the VCS One console

1 In the VCS One console, click the Manage tab.

ClusterName Name of the cluster at the remote site

The name of the remote cluster must not exceed 128 characters. 
The name cannot start with a number or contain any special 
characters.

DRPort Port address on which the remote cluster listens for connections

If you do not specify the port address, the default value 14151 is 
used.

NetworkConnections Network connection details for the remote cluster

Note: Symantec recommends that you configure at least two 
network connections in a VCS One global cluster setup.

You must specify a value for the destination IP address. If you do 
not specify a source IP address, VCS One uses any of the 
available IP addresses on the local cluster to connect to the 
remote cluster.
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2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed.

3 Click Configuration > Add Remote Cluster.

The Remote Cluster Configuration wizard is displayed.

4 In the Specify Remote Cluster Details screen, enter the name of the remote 
cluster in the Remote Cluster Name box.

Based on the cluster name, VCS One designates either the local or the 
remote cluster to initiate connection between the clusters.

5 In the Remote Cluster's DR Listening Port box, retain the default port 
address or enter a value for the remote cluster listening port.

6 In the Network Connections area, provide the network connection details 
for the local cluster to establish connection with the remote cluster:

■ Click Add.

■ In the Add Connection dialog box, enter the following details:

■ In the Remote Cluster IP box, enter the IP address of the remote 
cluster. 

■ In the Source IP box, enter the IP address of the local cluster if you 
do not want VCS One to use any of the available IP addresses.

Repeat this step if you want to add more network links that the local cluster 
can use to connect to the remote cluster.

7 Click Next.

8 In the Summary screen, click Finish.

9 In the Results screen, click Close.

To add a remote cluster from the command line

1 Type the following command to add a remote cluster:
haclus -add remotecluster_name 
[-user user@domain] [-domain domaintype]

where remotecluster_name is the name of the remote cluster.

2 Type the following command to specify the network connection details of 
the remote cluster:
haclus -modify NetworkConnections -add destinationIP:sourceIP 
-clus remotecluster_name 
[-user user@domain] [-domain domaintype]
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where:

3 To specify a different remote cluster port other than the default port 14151, 
type the following command:
haclus -modify DRPort remotecluster_port 
-clus remotecluster_name 
[-user user@domain] [-domain domaintype]

where:

See the Veritas Cluster Server One Command Reference Guide.

Determining the connection role of clusters
VCS One stores the connection role information of the remote cluster in the 
ConnectionRole attribute of the remote cluster object at each site.

See “How VCS One global clusters communicate with each other” on page 77.

You must have Read Only privilege in the object category to determine the 
connection role of clusters.

See “Catalog of object privileges” on page 757.

Use the following procedure to determine the connection role of a cluster.

To determine the connection role of a cluster from the command line

◆ Type the following command to display the value of the ConnectionRole 
attribute of a remote cluster:
haclus -display remotecluster_name -attribute ConnectionRole
[-user user@domain] [-domain domaintype]

destinationIP The IP address of the remote cluster.

You must specify a value for the destination IP address.

sourceIP The IP address of the local cluster.

If you do not specify a source IP address, VCS One uses any of 
the available IP addresses on the local cluster to connect to 
the remote cluster.

remotecluster_name Name of the remote cluster. 

remotecluster_port The remote cluster port on which the local cluster listens for 
incoming connections from the remote clusters.

remotecluster_name Name of the remote cluster. 
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where:

See the Veritas Cluster Server One Command Reference Guide.

■ If the command displays the output as Initiator, then the cluster at the 
local site accepts network connections from the cluster at the remote 
site.

■ If the command displays the output as Acceptor, then the cluster at the 
local site initiates network connections to the cluster at the remote site.

Viewing remote clusters
You must have Read Only privilege in the object category to view the remote 
clusters.

See “Catalog of object privileges” on page 757.

Use the following procedure to view remote clusters in your disaster recovery 
setup.

To view remote clusters using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed with the list of remote cluster 
objects.

To view remote clusters from the command line

◆ Type the following command:
haclus -list
[-user user@domain] [-domain domaintype]

The command lists the local cluster and the remote clusters that form the 
VCS One global cluster. The local cluster is indicated with an asterisk.

See the Veritas Cluster Server One Command Reference Guide.

Viewing remote cluster details
You must have Read Only privilege in the object category to view the remote 
cluster attributes and its details.

See “Catalog of object privileges” on page 757.

Use the following procedure to view remote cluster attributes.

remotecluster_name Name of the remote cluster. 
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To view remote cluster attributes using the VCS One console

1 In the VCS One console, navigate to the Disaster Recovery page to view the 
remote clusters.

See “Viewing remote clusters” on page 597.

2 In the Remote Clusters pane, click the appropriate remote cluster.

The details page for the remote cluster is displayed with the following 
information:

■ Details of the remote cluster such as name, state, and consolidated 
network link status

■ Details of the global CSGs that are configured to run on this remote 
cluster

■ Details on the network links between the clusters

To view remote cluster attributes from the command line

◆ Type the following command:

■ To display the values of all the attributes of a remote cluster:
haclus -display remotecluster_name 
[-user user@domain] [-domain domaintype]

■ To display the value of a specific attribute of a remote cluster:
haclus -display remotecluster_name -attribute attribute 
[-user user@domain] [-domain domaintype]

where:

See the Veritas Cluster Server One Command Reference Guide.

Editing remote cluster attributes
You must have Modify Cluster privilege in the farm category to edit the remote 
cluster attributes. Review the remote cluster attributes description to find 
whether the attribute is editable.

See “Catalog of farm privileges” on page 756.

See “Remote cluster attributes” on page 836.

remotecluster_name Name of the remote cluster. 

If you do not specify the remote cluster name, the command 
displays the values for the local cluster.

attribute Name of the specific remote cluster attribute.

See “Remote cluster attributes” on page 836.
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Use the following procedure to edit remote cluster attributes.

To edit remote cluster attributes using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed.

3 In the Remote Clusters area, click the appropriate remote cluster.

The details page for the remote cluster is displayed.

4 In the right pane, click All Attributes.

5 In the All Attributes page, click the Edit icon for the attribute that you want 
to edit.

6 In the Edit Attribute dialog box, perform the following steps:

■ In the Value box, select or enter a value for the attribute.

■ If the attribute stores a list of values, you can change or delete the 
existing values and add new values in the Values table.

■ To change a value, select the appropriate row in the Values table 
and enter the value.

■ To delete a value, select the appropriate row in the Values table 
and click the - icon in the right corner of the table.

■ To add a value, click the + icon in the right corner of the Values 
table and enter the value in the new row.

■ Click OK.

■ Click Close.

To edit remote cluster attributes from the command line

◆ Type the following command to modify the attribute value of type SCALAR 
for a remote cluster:
haclus -modify attribute value -clus remotecluster_name
[-user user@domain] [-domain domaintype]

where:

attribute Name of the specific attribute for a remote cluster.

value Value for the specified attribute.

remotecluster_name Name of the remote cluster. 

If you do not specify the -clus option, the command 
modifies the values for the local cluster.
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See the Veritas Cluster Server One Command Reference Guide for details on 
how to modify the attribute of type VECTOR, KEYLIST, and ASSOCIATION.

Deleting remote clusters
You must have Delete Cluster privilege in the farm category to delete a remote 
cluster from the VCS One cluster.

See “Catalog of farm privileges” on page 756.

Use the following procedure to delete a remote cluster.

Before you delete a remote cluster, ensure that the local cluster is not connected 
to the remote cluster.

See “Disabling connections between clusters” on page 601.

After you delete a remote cluster, you must also remove trust with the root 
broker of the remote cluster.

See “Setting up and removing trust with the remote cluster” on page 608.

To delete a remote cluster using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed.

3 In the Remote Clusters area, select a remote cluster that you want to delete.

4 Click Configuration > Delete Remote Cluster(s).

The Delete Remote Cluster wizard is displayed.

5 In the Delete Remote Cluster(s) screen, click OK.

6 Click Close.

To delete a remote cluster from the command line

◆ Type the following command:
haclus -delete remotecluster_name 
[-user user@domain] [-domain domaintype]

where remotecluster_name is the name of the remote cluster.

See the Veritas Cluster Server One Command Reference Guide.

Enabling connections between clusters
After you have specified the network connection details of the remote cluster, 
you can enable network connectivity between the clusters. You must perform 
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this procedure from both the local and the remote clusters between which you 
want to initiate connection.

You must have Modify Cluster privilege in the farm category. 

See “Catalog of farm privileges” on page 756.

Use the following procedure to enable connections between clusters.

To enable connections between clusters using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed.

3 In the Remote Clusters area, select a remote cluster to which you want the 
local cluster to establish connection.

4 Click Operations > Enable Connection(s).

5 In the Enable connections with Remote Cluster(s) screen, click OK.

6 Click Close.

To enable connections between clusters from the command line

◆ Type the following command:
haclus -modify EnableConnections 1 -clus remotecluster_name

where remotecluster_name is the name of the remote cluster.

See the Veritas Cluster Server One Command Reference Guide.

Disabling connections between clusters
You can disable network connectivity between the clusters.

You must have Modify Cluster privilege in the farm category. 

See “Catalog of farm privileges” on page 756.

Use the following procedure to disable connections between clusters.

To disable connections between clusters using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed.

3 In the Remote Clusters area, select a remote cluster from which you want 
the local cluster to remove connection.

4 Click Operations > Disable Connection(s). 
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5 In the Disable connection with Remote Cluster(s) screen, click OK.

6 Click Close.

To disable connections between clusters from the command line

◆ Type the following command:
haclus -modify EnableConnections 0 -clus remotecluster_name

where remotecluster_name is the name of the remote cluster.

See the Veritas Cluster Server One Command Reference Guide.

Viewing the status of individual network links
You must have Read Only privilege in the object category to view the status of 
network links.

See “Catalog of object privileges” on page 757.

The status of the network links between the clusters can be UP, DOWN, or 
DISABLED. The status of the links are not displayed if the initiator cluster has not 
yet established connection with the remote cluster.

See “Network link states in VCS One global clusters” on page 933.

Use the following procedure to view the status of individual network links 
between the clusters.

To view the status of individual network links using the VCS One console

1 In the VCS One console, navigate to the Disaster Recovery page to view the 
remote clusters.

See “Viewing remote clusters” on page 597.

2 In the Remote Clusters pane, click the appropriate remote cluster.

The details page for the remote cluster is displayed.

3 View the status of each network link that you configured between the local 
and the remote clusters in the Link Status area of the details page.

To view the status of network links from the command line

◆ Type the following command to display the status of the individual network 
links between the local and the remote clusters:
haclus -display remotecluster_name -attribute LinkStatus 
[-user user@domain] [-domain domaintype]
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where:

See the Veritas Cluster Server One Command Reference Guide.

Viewing the consolidated status of network links
You must have Read Only privilege in the object category to view the status of 
network links.

See “Catalog of object privileges” on page 757.

The consolidated status of the network links between the clusters can be UP, 
DOWN, PARTIAL UP, DISABLED, or DISABLED DOWN. The status of the links are not 
displayed if the initiator cluster has not yet established connection with the 
remote cluster.

See “Network link states in VCS One global clusters” on page 933.

Use the following procedure to view the consolidated status of network links 
between the clusters.

To view the consolidated status of network links using the VCS One console

1 In the VCS One console, navigate to the Disaster Recovery page to view the 
remote clusters.

See “Viewing remote clusters” on page 597.

2 View the Link Status column for the remote cluster in the Remote Clusters 
pane.

To view the consolidated status of network links from the command line

◆ Type the following command to display the consolidated status of the 
network links between the local and the remote clusters:
haclus -display remotecluster_name 
-attribute ConsolidatedLinkStatus 
[-user user@domain] [-domain domaintype]

remotecluster_name Name of the remote cluster. 

If you do not specify the remote cluster name, the command 
displays the values for the local cluster.
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where:

See the Veritas Cluster Server One Command Reference Guide.

Viewing the state of the clusters
You must have Read Only privilege in the object category to view the state of 
clusters.

See “Catalog of object privileges” on page 757.

See “Cluster states in VCS One global clusters” on page 932.

Use the following procedure to view the state of the clusters.

To view the state of the cluster from the command line

◆ Type the following command to display the state of the clusters:
haclus -state
[-user user@domain] [-domain domaintype]

See the Veritas Cluster Server One Command Reference Guide.

Modifying remote cluster configuration
You can modify the remote cluster configuration only on the cluster that VCS 
One has designated to initiate connection request. 

You must have Modify Cluster privilege in the farm category to modify the 
remote cluster configuration.

See “Catalog of farm privileges” on page 756.

Before you use the following procedure to modify remote cluster configuration, 
you must disable the network connections to the remote cluster for which you 
want to modify the network connection settings.

See “Disabling connections between clusters” on page 601.

Use the following procedure to modify the remote cluster configuration.

To modify remote cluster configuration using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Disaster Recovery tab.

remotecluster_name Name of the remote cluster. 

If you do not specify the remote cluster name, the command 
displays the values for the local cluster.
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The Disaster Recovery page is displayed.

3 In the Remote Clusters area, select a remote cluster that you want to 
modify.

4 Click Configuration > Modify Remote Cluster.

The Remote Cluster Configuration wizard is displayed.

5 In the Remote Cluster Port box of the Specify Remote Cluster Details 
screen, retain the default port address or enter a value for the remote cluster 
port.

6 In the Network Connections area, modify the network connection details 
that the local cluster uses to connect to the remote cluster:

■ To add more network connections, do the following:

■ Click Add.

The Add Connection dialog box appears.

■ In the Remote Cluster IP box, enter the IP address of the remote 
cluster. 

■ In the Source IP box, enter the IP address of the local cluster if you 
want VCS One to use a specific IP address.

■ To edit an existing network connections, do the following:

■ In the Remote Cluster IP column, enter the IP address of the 
remote cluster. 

■ In the Source IP column, enter the IP address of the local cluster if 
you want VCS One to use a specific IP address.

7 Click Next.

8 In the Summary screen, click Finish.

9 In the Results screen, click Close.

To modify remote cluster configuration from the command line

1 Disable network connections to the remote cluster for which you want to 
modify the network connection settings.
haclus -modify EnableConnections 0 -clus remotecluster_name

2 Type the following command to change the remote cluster port:
haclus -modify DRPort remotecluster_port 
-clus remotecluster_name

3 Modify the network connection details for the remote cluster:

■ To specify network connection values for the first time after you added 
the cluster:
haclus -modify NetworkConnections key 
-clus remotecluster_name
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■ To add additional network connections:
haclus -modify NetworkConnections -add key \
-clus remotecluster_name

■ To delete a particular network connection:
haclus -modify NetworkConnections -delete key \
-clus remotecluster_name

■ To delete all the network connections:
haclus -modify NetworkConnections -delete -keys \
-clus remotecluster_name

where:

See the Veritas Cluster Server One Command Reference Guide.

remotecluster_port The remote cluster port on which the local cluster listens for 
incoming connections from the remote clusters.

remotecluster_name Name of the remote cluster. 

key Value for the NetworkConnections attribute.
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Changing the local cluster’s DR port value
Use the following procedure to modify the local cluster’s DRListeningPort 
attribute.

Warning: If you change the DRListeningPort value for the cluster that accepts 
the connection requests, make sure you make the equivalent changes to the 
DRPort attribute for the remote cluster object that represents this cluster.
See “Modifying remote cluster configuration” on page 604.

To change the local cluster’s DR port values

1 Stop the Policy Master daemon; take the Policy Master resource offline.
hastop -pm

2 Export the information in the cluster configuration database to XML-
formatted files.
haconf -dbtoxml location_of_the_xml_directory 

3 Edit the main.xml file.

Add DRListeningPort attribute to the local cluster’s cluster object. 

For example, the bold text in the following sample cluster object indicates 
the line you must add to define the DRListeningPort attribute with the value 
60000:

<cluster name="seattle">
<attributes>

<attribute name="DefaultPlatform"><scalar>"linux/x86"</scalar></attribute>
<attribute name="DRListeningPort"><scalar>60000</scalar></attribute>
<attribute name="FarmUUID"><scalar>"15e15b64-1dd2-11b2-b76a-b60f6c745dd1"

</scalar></attribute>
<attribute name="LogDbg"></attribute>

</attributes>
</cluster>

4 Validate the configuration information in the XML files.
haconf -verify location_of_.xml_config_files 

5 Clean the configuration database.
haconf -cleandb

6 Load the XML configuration into the database.
haconf -loaddb location_of_the_xml_directory

where location_of_the_xml_directory is the location you specified in step 2.

7 Start the Policy Master daemon; bring the Policy Master resource online.
hastart -pm
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Changing the local cluster’s DR address value
Use the following procedure to modify the local cluster’s DRAddress attribute.

To change the local cluster’s DR address value

1 Make sure that the Policy Master daemon vcsoned is running in the Policy 
Master cluster.
haclus -display -attribute ClusterState

The output must show the cluster state as RUNNING.

2 Run the following command to add an IP address for the Policy Master to 
start listening on this IP address for inter-cluster connection.
haadmin -adddrip ipaddress nic netmask

The command updates the cluster-level attribute DRAddress and also 
updates the IP resource in the DRSG service group. The variable nic 
represents the NIC device that is used for the disaster recovery IP address.

Setting up and removing trust with the remote 
cluster

Before you add a remote cluster, you must set up trust with the root broker of 
the remote cluster. Similarly, after you delete a remote cluster, you must remove 
the trust relationship with the root broker of the remote cluster.

Use the following procedures to set up or remove trust with the root broker of 
the remote cluster.

To set up trust with the root broker of the remote cluster

◆ At each site, set up trust with the root broker of the remote cluster. You must 
set up trust for each IP address that is used for inter-cluster 
communication.

On UNIX Use the following command:

# /opt/VRTSvcsone/bin/haat setuptrust \

–b remote_broker_ip:remote_broker_port \

–s securitylevel

For securitylevel, use one of the following values: low, medium, 
or high. 

The default value for remote_broker_port is 14159.

See the Veritas Cluster Server One Installation Guide for instructions.
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To remove trust with the root broker of the remote cluster

◆ At each site, remove trust with the root broker of the remote cluster. You 
must remove trust for each IP address that is used for inter-cluster 
communication.

On Windows Use the following command. 

Note: If UAC is enabled and you are logged in as a non-default 
administrator, ensure that you use Run as administrator mode to 
execute the command.

%VCSONE_HOME%\bin\haat setuptrust \

–b remote_broker_ip:remote_broker_port –s 

securitylevel

For securitylevel, use one of the following values: low, medium, 
or high. 

The default value for remote_broker_port is 14159.

On UNIX Use the following command:

# /opt/VRTSvcsone/bin/haat removetrust \

–b remote_broker_cluster_name:remote_broker_port \

–n root_broker_name

where:

■ remote_broker_cluster_name is the output of the 
command haat showrootbroker.

■ The default value for remote_broker_port is 14159.

■ root_broker_name is the output of the command haat 
showrootbroker -n.

On Windows Use the following command. 

Note: If UAC is enabled and you are logged in as a non-default 
administrator, ensure that you use Run as administrator mode to 
execute the command.

%VCSONE_HOME%\bin\haat setuptrust \

–b remote_broker_ip:remote_broker_port –n 

root_broker_name

where:

■ remote_broker_cluster_name is the output of the 
command haat showrootbroker.

■ The default value for remote_broker_port is 14159.

■ root_broker_name is the output of the command haat 
showrootbroker -n.
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Faulting a remote cluster using the Simulator
This task is only available using the Simulator to simulate a remote cluster fault.

This procedure assumes that two simultaneous instances of the Simulator are 
running on the same system and that you already have a remote cluster set up 
and running. Faulting the remote cluster stops the Policy Master of the remote 
cluster.

See “How global clusters work” on page 77.

To simulate a remote cluster fault

1 In the VCS One Simulator console, click the Manage tab.

2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed.

3 In the Remote Clusters area, select a remote cluster which you want to fault.

4 Click Simulation > Fault Remote Cluster(s).

5 In the Fault Remote Cluster(s) screen, click OK.

6 Click Close.

To fault a remote cluster from the command line

◆ Type the following command:
hasim -faultcluster remotecluster_name

where remotecluster_name is the name of the remote cluster.

See the Veritas Cluster Server One Command Reference Guide.

Clearing a simulated cluster fault using the 
Simulator

This task is only available using the Simulator to clear a simulated remote 
cluster fault.

To clear the fault, you must start the Policy Master of the remote cluster. 
Because the user interface is unavailable for the Simulator instance of a faulted 
remote cluster, you must use the command line to clear the fault. 

To clear a faulted remote cluster from the command line

◆ Type the following command:
hasim -start -pm

This command must be invoked from the command line of the faulted 
remote cluster.
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See the Veritas Cluster Server One Command Reference Guide.

Simulating a link fault
This task is only available using the Simulator to simulate a link fault.

A remote cluster can have multiple link connections and you can fault one or 
more links at the same time. The link fault can be induced only on the cluster 
that VCS One has designated to initiate connection request. The link status for a 
faulted link is displayed as DOWN. If you fault all links of a remote cluster then 
the remote cluster appears faulted from the local cluster; however, the Policy 
Master of the remote cluster will still be in a running state.

To simulate a link fault

1 In the VCS One Simulator console, click the Manage tab.

2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed.

3 In the Remote Clusters area, select a remote cluster whose links you want to 
fault. Alternatively, you can click the remote cluster name to navigate to the 
Link Status page and then select the links.

4 Click Simulation > Fault Link(s).

5 In the Fault Link for Cluster screen, select one of the following options:

■ Fault any Link

Select this option to fault the main link.

■ Fault specific Link(s)

Select this option to fault specific links. In the Available Links area, 
select the check box next to each of the links which you want to fault.

6 Click OK.

To simulate a link fault from the command line

◆ Type the following command:
hasim -faultrlink remotecluster_name [rlink]

where remotecluster_name is the name of the remote cluster and rlink is the 
name of the remote link. If rlink is not specified, then the first available link 
which is in the UP state is faulted.

See the Veritas Cluster Server One Command Reference Guide.
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Clearing a simulated link fault
This task is only available using the Simulator to clear a simulated link fault. 

If all links are in a Down state then the remote cluster appears faulted from the 
local cluster. Clearing a fault on any one of the faulted links brings the link up 
and the state of the remote cluster again changes to RUNNING. The link fault can 
be cleared only from the cluster that VCS One has designated to initiate 
connection request.

To clear a simulated link fault

1 In the VCS One Simulator console, click the Manage tab.

2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed.

3 In the Remote Clusters area, select a remote cluster whose link fault you 
want to clear. Alternatively, you can click the remote cluster name to 
navigate to the Link Status page and then select the links.

4 Click Simulation > Clear Link Fault(s).

5 In the Clear Link Fault for Cluster screen, select one of the following 
options:

■ Clear Fault on any Link

Select this option to clear the fault on the first available link as listed in 
the NetworkConnections attribute.

■ Clear Fault on specific Link(s)

Select this option to clear the fault on specific links. In the Available 
Links area, select the check box next to each of the links whose fault 
you want to clear.

6 Click OK.

To clear a link fault from the command line

◆ Type the following command:
hasim -clearrlinkfault remotecluster_name [rlink]

where remotecluster_name is the name of the remote cluster and rlink is the 
name of the remote link. If rlink is not specified, then the first available link 
which is in the DOWN state is cleared.

See the Veritas Cluster Server One Command Reference Guide.
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This chapter includes the following topics:

■ About managing global composite service groups

■ Configuring a global CSG

■ Requesting authority for a global CSG

■ Bringing a global CSG online

■ Switching a global CSG

■ Taking over a global CSG
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About managing global composite service groups
A composite service group (CSG) is a container that combines one or more 
objects into a single logical object. A global CSG is a CSG with wide-area failover 
capability in a global cluster environment.

See “About composite service groups” on page 35.

See “About managing composite service groups” on page 406.

Configuring a global CSG
Use this procedure to make a composite service group (CSG) local or global. 

When you create a CSG, the CSG is local by default. The CSG is confined to the 
cluster on which you created the CSG. In a global cluster environment, you must 
configure this CSG as a global CSG to enable wide-area failover across the 
clusters.

See “Creating a composite service group” on page 406.

The ClusterList attribute value determines whether the CSG is local or global. A 
global CSG must meet the following characteristics:

■ The ClusterList attribute must include the cluster names on which the CSG 
can run.

■ The ClusterList attribute must include at least one remote cluster.

■ The ClusterList attribute value must match across the local and the remote 
clusters.

When you configure a composite service group as global, VCS One adds the local 
cluster name to the ClusterList attribute by default. You cannot remove the local 
cluster from a global composite service group.

Note: When you delete a remote cluster, VCS One removes the cluster name 
from the ClusterList attribute of the corresponding CSG.

To configure a global CSG using the VCS One console

1 In the VCS One console, locate the CSG for which you want to configure the 
ClusterList attribute.

See “Listing composite service groups” on page 409.

2 In the right pane, under Composite Service Groups, click the CSG.

3 From the Configuration menu, click Configure Global CSG.
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The Composite Service Group Configuration Wizard (Configure Global CSG) 
dialog box is displayed.

4 In the Cluster List Configuration screen, add or remove the appropriate 
clusters from the Available Clusters or the Selected Clusters list.

5 Click Finish.

6 In the Results screen, click Close.

To configure a global CSG from the command line

◆ At the command prompt, type the following command:

■ To add a remote cluster to the ClusterList attribute:
hacsg -modify csg_name ClusterList \
 -add remotecluster_name 

■ To remove a remote cluster from the ClusterList attribute:
hacsg -modify globalcsg_name ClusterList \
-delete remotecluster_name 

■ To remove all remote cluster from the ClusterList attribute:
hacsg -modify globalcsg_name ClusterList \
-delete -keys

where:

See the Veritas Cluster Server One Command Reference Guide.

Requesting authority for a global CSG
The value of the Authority attribute must be set to 1 for VCS One to be able to 
bring a global composite service group (CSG) online on a local cluster.

You must perform the request authority operation in the following cases:

■ The remote cluster where the global CSG was online has faulted and you 
must bring the global CSG online on the local cluster.

■ You want to bring online the service groups within the global CSG on the 
local cluster.

You must have Request Authority privilege in the CSG category to request 
authority.

See “Catalog of composite service group privileges” on page 761.

remotecluster_name Name of the remote cluster. 

globalcsg_name Name of the global CSG.
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To request authority for a global CSG using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Composite Service Groups tab.

3 Select one or more global CSGs for which you want to request authority.

You can also click the name of the CSG to go to the detail page to request 
authority for the selected CSG. 

4 From the Operations menu, click Request Authority.

5 Select the Force option to acquire authority for the global CSG on the local 
cluster when the remote cluster is not running or is disconnected from the 
local cluster.

6 Click OK.

7 Click Close.

To request authority for a global CSG from the command line

◆ At the command prompt, type the following command:
hacsg -requestauth globalcsg_name 

If the remote cluster on which the global CSG that has authority is not 
running or is disconnected from the local cluster, you can use the -force 
option to acquire authority for the global CSG on the local cluster. Run the 
following command:
hacsg -requestauth -force globalcsg_name

where:

Bringing a global CSG online
When you bring a composite service group (CSG) online, the operation brings all 
the service groups or VFrames that are contained in the CSG online and then 
brings the CSG online. This operation has the following additional options:

globalcsg_name The name of the global CSG.

Propagate option Initiates the online operation on the service groups or VFrames 
outside the CSG on which service groups or VFrames inside the 
CSG depend.
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The following conditions result in the rejection of the online operation of the 
CSG:

■ The GroupList and VFrameList are empty.

■ The CSG is already online in one of the clusters.

■ The CSG has the PENDING flag set, which means the constituent service 
groups or VFrames are in transition within the cluster.

■ Any group or VFrame in the CSG is frozen.

■ Any group or VFrame in the CSG has no configured resources

■ Any group or VFrame in the CSG has all resources disabled.

You must have the Online CSG privilege on the CSG to perform this operation.

To bring a CSG online using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Select one or more CSGs that you want to bring online.

If you select multiple CSGs with service groups or VFrames that have inter-
dependencies, then you must first perform the request authority operation 
for each CSG before you bring the CSGs online.

See “Requesting authority for a global CSG” on page 615.

3 From the Operations menu, click Online CSG(s).

4 If you want to take over a global CSG from a remote cluster that is in INIT or 
in FAULTED state, then select the Force option.

5 Select the Propagate option if you want VCS One to also attempt to bring 
online all child service groups or VFrames outside the CSG that have a 
dependency with service groups inside the CSG.

6 Click OK > Close.

To bring a CSG online from the command line

◆ Type the following command
hacsg -online [-propagate] [-force] csg_name 

Force option Takes over the global CSG from the remote cluster that is in INIT or 
in FAULTED state.

In a global cluster setup, the local cluster acquires authority for 
the global CSG from the remote cluster and then brings the global 
CSG online on the local cluster.

See “Taking over a global CSG” on page 619.



618 Managing global composite service groups
Switching a global CSG
where

See the Veritas Cluster Server One Command Reference Guide.

Switching a global CSG
A switch operation is a planned failover, which takes the global CSG offline on 
the local cluster and brings the global CSG online on the cluster that you specify. 
You must perform the switch operation on a CSG that is online or partially 
online. You must switch the global CSG to a cluster that is running.

Note: The switch operation on a global CSG fails for CSGs with service groups or 
VFrames that have parent service groups or VFrames outside the CSG which are 
online.

To switch a global CSG using the VCS One console

1 In the VCS One console, click Manage > Composite Service Groups.

2 Select a global CSG that you want to switch.

You can also click the name of the CSG to go to the detail page to switch the 
selected CSG. 

3 From the Operations menu, click Switch CSG.

4 In the Switch Composite Service Group screen, select the cluster on which 
you want to bring the CSG online.

5 Click OK.

6 In the Results screen, click Close.

To switch a global CSG from the command line

◆ At the command prompt, type the following command:
hacsg -switch csg_name -clus cluster_name 

where:

See the Veritas Cluster Server One Command Reference Guide.

csg_name Name of the global CSG.

csg_name Name of the global CSG.

cluster_name Name of the cluster where you want to switch the global CSG. 
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Taking over a global CSG
A takeover operation brings the global CSG online on the local cluster. You can 
perform a takeover operation if the remote cluster where the global CSG was 
online has faulted. You can take over multiple global CSGs using the VCS One 
console.

You must have Online CSG privilege to perform this operation.

Perform the following procedure on the cluster where you want to bring the 
global CSG online.

To take over global CSGs using the VCS One console

1 In the VCS One console, click the Manage tab.

2 Click the Disaster Recovery tab.

The Disaster Recovery page is displayed.

3 In the Remote Clusters area, select the remote cluster from which you want 
to take over the global CSG.

4 Click Operations > Take Over CSG(s).

5 In the Select the Composite Service Groups for the local cluster to take 
over screen, perform the following:

■ To select specific CSGs, select the CSGs from the list that is displayed.

■ To select all CSGs, select the option Select All Composite Service 
Groups.

6 Click OK > Close.

To take over global CSGs from the command line

◆ At the command prompt, type the following command:
hacsg -online [-propagate] -force globalcsg_name

where:

If the CSG has service groups or VFrames with other dependant service 
groups or VFrames that are outside the CSG, then use the -propagate 
option to bring those child service groups or VFrames online.

The takeover operation fails or partially succeeds if the child service groups 
or VFrames that are outside of the CSG are not brought online.

See the Veritas Cluster Server One Command Reference Guide.

globalcsg_name Name of the global CSG.
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This section includes the following chapters:

■ “Administering the organization tree” on page 623.

■ “Administering attributes and settings” on page 631.

■ “Administering users and roles” on page 645.

■ “Administering sets of objects” on page 665.
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This chapter includes the following topics:

■ About administrating the organization tree

■ Administering the organization tree
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About administrating the organization tree 
Before building an organization tree, analyze your environment and user 
requirements.

See “About users and the Organization tree” on page 252.

An organization tree is a logical hierarchical structure of the VCS One cluster 
that is used to delineate user views and privileges.

About building an organization tree
The organization tree is built in the order of a tree hierarchy. To build an 
organization tree, perform the following steps in the order presented:

■ The first node you add to the organization tree is an OUName node that is 
attached to the top-level ServerFarm node. 

■ Next add one or more OUValue nodes to the initial OUName node.

■ Continue adding OUName and OUValue nodes until your organization tree 
is complete.

Indicate where in the organization tree to attach the next node by 
specifying the organization tree path. The organization tree path is denoted 
by a list of OUName=OUValue pairs, separated by a forward slash (/).

You may add extended attribute definitions to your OUValue nodes at any time.

See “Moving objects between organization tree nodes” on page 626.

How to build an organization tree
Use alphanumeric characters, along with the underscore character when 
defining organization unit nodes.

To add an OUName node to the organization tree using the VCS One console

1 In the VCS One console, click Administration > Organization Units.

In the left pane, the organization tree displays in a hierarchical view. 

In the right pane, the full path of the current organization unit displays. 
When building the first node in the organization tree, the value will be /.

2 In the left pane, click the OUValue node in the organization tree where you 
want to attach the OUName node.

When building the first node in the organization tree, click the top-level 
OUValue node ServerFarm(/).

3 Click Configuration > Add OUName. 

Alternatively, from the left pane, you can right-click the OUValue node in 
the organization tree and click Add OUName
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The Add OUName dialog box appears. The Parent OUValue displays.

4 In the OUName text box, type the name of the OUName node to add to the 
organization tree.

5 Click OK

In the left pane view of the organization tree, the new node appears.

In the right pane, the name appears in the OUNames applicable for this 
OUValue table.

To add an OUName node to the organization tree from the command line

◆ The following command adds a OUName node to the organization tree:

haou -add OUName OUValuePath
where 

OUName is the name of the OUName node to be added.

OUValuePath is the location in the tree to add the node, as denoted by an 
organization tree path. The organization tree path is denoted by a list of 
OUName=OUValue pairs, separated by a forward slash (/).

To add an OUValue node to the organization tree using the VCS One console

1 In the left pane, click the OUName node where you want to attach the 
OUValue node.

In the right pane, the full path of the current organization unit displays.

2 Click Configuration > Add OUValue. 

Alternatively, from the left pane, you can right-click the OUName node in 
the organization tree and click Add OUValue.

The Parent OUName displays.

3 In the OUValue(s) box, click the + to add an OUValue node to the 
organization tree.

4 Type the name of the OUValue node.

You may add multiple OUValue nodes at this point. To add multiple nodes, 
click the + after adding each node and before moving to the next step.

5 Click OK.

In the left pane view of the organization tree, the new node appears. In the 
right pane, the name appears in the OUValues applicable for this OUName 
table.

To add an OUValue node to the organization tree from the command line

◆ The following command adds OUValue to the list of valid values for the 
OUName node specified by OUNamePath in the organization tree
haou -addvalue OUValue OUNamePath
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where 

OUValue is one or more value(s) of the OUName node above it in the 
organization tree.

OUNamePath is the location in the tree to add the value, as denoted by an 
organization tree path that ends in an OUName. The organization tree path 
is denoted by a list of OUName=OUValue pairs, separated by a forward 
slash (/).

Administering the organization tree
You can do the following tasks on an organization tree:

■ View the organization tree hierarchy

■ List the current defined set of OUNames

■ List the defined set of objects associated with an OrgUnit

■ Delete an OUName from the organization tree

■ Delete an OUValue from the organization tree

Viewing the organization tree hierarchy

To view the organization tree hierarchy using the VCS One console

◆ In the VCS One console, click Administration > Organization Units.

The organization tree displays in the left pane.

To view the organization tree hierarchy from the command line

◆ Type the following command to list the entire organization tree hierarchy:

haou -list [-tree]
The -tree option displays that hierarchy in tree format.

◆ Type the following command to list the organization tree hierarchy from the 
node (OuName or OUValue) specified by OUNamePath or OUValuePath:
haou -list OUNamePath
haou -list OUValuePath

Appropriate privileges are required to view a part or the whole of the 
organization tree.

Moving objects between organization tree nodes

To move systems between nodes in the organization tree

See “Moving a system to another organization tree node” on page 350.
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To move service groups between nodes in the organization tree

See “Moving a service group to another organization tree node” on page 372.

To move composite service groups between nodes in the organization tree

See “Moving a local composite service group in the organization tree” on 
page 417.

To move users between nodes in the organization tree

See “Moving a user to another Organization Tree node” on page 655.

To move a Management Console between nodes in the OrgTree

See “Moving a management console in the organization tree” on page 485.

To move an pframe between nodes in the OrgTree

See “Moving a PFrame in the organization tree” on page 501.

To move a virtual machine between nodes in the OrgTree

See “Moving a VFrame in the organization tree” on page 524.

List the OUName for an OUValue 
There can not be more than one OUName for each OUValue.

There is no CLI equivalent for this console command.

To list the OUName for an OUValue using the VCS One console

1 In the VCS One console, click Administration > Organization Units.

2 In the left pane, click the applicable OUValue node.

View the list in the OUNames applicable for this OUValue table.

List the set of OUValues for an OUName 

To list the set of OUValues for an OUName node using the VCS One console

1 In the VCS One console, click Administration > Organization Units.

2 In the left pane, click the applicable OUName node.

View the list in the OUValues applicable for this OUName table.

To list the current defined set of OUValues for an OUName from the command 
line

◆ The following command lists the OUValues in the OUNamePath:
haou -displayval OUNamePath
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List the defined set of objects associated with an organizational unit
You may filter the display of objects by the organization unit to which they are 
associated.

To list the set of objects associated with an organizational unit using the VCS 
One console

1 In the VCS One console, navigate to the type of object you wish to list.

Click objects under the Manage or Administration tabs.

2 In the left pane, click the organization unit node in the organization tree 
where you want to list the set of objects.

3 The objects listed in the right pane as the objects associated with the 
organization unit chosen in step 2.

To list the current defined set of objects associated with an OrgUnit from the 
command line

◆ The following command lists all the objects that are associated with an 
individual OrgUnit in the OrgUnitPath.

haou -displayobj -exclusive [-grp] [-sys][-frame] [-userobject] 
[-usergroup]OUValuePath

◆ The following command lists all the objects that are associated with an 
OrgUnit in the OrgValuePath, including the objects in the subtrees.

haou -displayobj [-grp] [-sys] [-frame] [-userobject] 
[-usergroup]OUValuePath

Deleting an OUName node from the organization tree
You can not delete an OUName node that has child OUValue nodes unless you 
use the -force option.

You may not delete a node from the organization tree if an extended attribute is 
used as a resource variable at or below the node.

To delete an OUName node from the organization tree using the VCS One 
console

1 In the VCS One console, click Administration > Organization Units.

2 Check the OUName node to delete.

3 Click Configuration > Delete OUName. 

Alternatively, from the left pane, you can right-click the OUName node in 
the organization tree and click Delete.

The Delete OUName dialog box appears, asking for confirmation.

4 Select or deselect the Delete the complete subtree check box.
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5 Click OK.

To delete an OUName from the organization tree using the command line

◆ The following command deletes an OUName node from the organization 
tree:
haou -delete OUNamePath

where OUNamePath is the location in the tree to delete the node.

◆ The following command deletes the OUName node and the complete subtree 
from the organization tree:
haou -delete -force OUNamePath

Deleting OUValue nodes from the organization tree
You can not delete an OUValue node that has child OUName nodes, or that has 
objects attached unless you use the -force option. If an OUValue node is deleted, 
the objects that are attached to that OUValue node are automatically reattached 
to the parent OUValue node.

You can not delete a node from the organization tree if an extended attribute is 
used as a resource variable at or below the node.

To delete OUValue nodes from the organization tree using the VCS One 
console

1 In the VCS One console, click Administration > Organization Units.

2 Perform one of the following actions to select the node(s) to delete:

3 Click Configuration > Delete OUValue(s). 

4 Check or uncheck the Delete the complete subtree check box.

Check this box to also delete all the nodes below this node in the 
organization tree.

5 Click OK > Close.

To delete one OUValue node In the left pane, click the OUValue node to 
delete.

To delete multiple OUValue nodes In the left pane, click the OUName node above 
the OUValue nodes to delete.

In the right pane, check the boxes next to the 
OUValue nodes to delete.
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To delete OUValue nodes from the organization tree using the command line

◆ Type the following command to delete an OUValue node from the 
organization tree:
haou -deletevalue path

◆ Type the following command to delete an OUValue node and all the nodes 
below it from the organization tree. You must also use the -force option if 
objects are attached at this node:
haou -deletevalue -force path

Use the following information to replace the appropriate variables:

path The location of the node in the organization tree; denoted 
by the OUValue path for the object.
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This chapter includes the following topics:

■ About administering attributes and settings

■ Editing VCS One cluster attributes

■ About extended attributes

■ Defining an extended attribute

■ Assigning an extended attribute a value

■ Combining extended attributes in an expression

■ Deleting an extended attribute

■ Modifying the value of an inherited extended attribute

■ Modifying the value of a locally defined extended attribute

■ Modifying notification settings

■ Enabling notification settings

■ Disabling notification settings

■ Enabling syslog notifications

■ Disabling syslog notifications

■ Enabling script execution

■ Disabling script execution

■ Testing notification settings
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About administering attributes and settings
Attributes consist of a name and value. The following types of attributes exist in 
VCS One:

■ Attributes that are pre-defined in the product. They define the properties of 
the objects in the configuration. 

■ Extended attributes that the user defines. They allow you to attach metadata 
to the objects in the configuration for more sophisticated administration 
capabilities.

Analyze your environment and design a plan for the use of extended 
attributes.

Settings consist of values that you can set for notifications, including SMTP, 
SNMP, Syslog, and test.

Each object has a procedure on how to edit attributes of that object type.

See “Editing VCS One cluster attributes” on page 632.

See “Editing a composite service group’s attributes” on page 415.

See “Editing resource attributes” on page 428.

See “Editing system attributes” on page 341.

See “Editing user or user group attributes” on page 654.

See “Editing attributes of a Management Console” on page 489.

See “Editing an attribute for a instance of a PFrame” on page 498.

See “Editing attributes for a instance of a VFrame” on page 519.

Editing VCS One cluster attributes
Attributes at the cluster level define properties across the entire VCS One 
cluster.

To view VCS One cluster attributes

1 In the VCS One console, click Administration > Global Settings.

2 In the All Attributes table, click the pencil icon of an attribute to edit it.

If there is not a pencil icon next to the attribute name, the attribute is not 
editable. You may only edit attributes of global scope from this page.

About extended attributes 
The extended attribute is given a value for a specific object. Extended attributes 
are defined at an OUValue node. An extended attribute definition applies to 
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objects that are attached to the OUValue node where they are defined, and 
objects below that node in the organization tree. 

Extended attributes can be one of the following types:

■ System extended attribute– defines a characteristic for a system object that 
is attached to that OUValue node.

■ Service group extended attribute – defines a characteristic for a service 
group object that is attached to that OUValue node.

■ Physical frame extended attribute - defines a characteristic for a pframe 
object that is attached to that OUValue node. This includes objects of type 
ESXServer and LDOMsServer.

■ Virtual frame extended attribute - defines a characteristic for a vframe 
object that is attached to that OUValue node. This includes objects of type 
ESXVM and LDOMsVM.

■ Management console - defines a characteristic for a vobject that is attached 
to that OUValue node. This includes objects of type VMwareVC and TBD

■ Common extended attribute – defines a characteristic for all system, pframe, 
vframe, vobject, and service group objects attached to that OUValue node.

Note: Extended attributes can not be associated with user objects.

About values of extended attributes
The value of an extended attribute can be one of the following:

■ Enumerated

An enumerated extended attribute has a set of valid values called a 
validation set. The value of the extended attribute at an object must be one 
of the values in the validation set.

A default value can be specified for an enumerated extended attribute at an 
OUValue path.

■ Freeform

A freeform extended attribute does not have a predefined set of valid values 
or a default value. You can specify any value for the extended attribute at an 
object.

About names of extended attributes
The name of an extended attribute can use alphanumerics and the underscore 
character, and can be up to 32 characters. 
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See “About the names of your VCS One cluster objects and attributes” on 
page 240.

Defining an extended attribute
An extended attribute is defined at a particular OUValue node in the 
Organization Tree. All subnodes of that OUValue node also inherit the extended 
attribute definition.

To define an extended attribute using the VCS One console

1 In the VCS One console, click Administration > Extended Attributes.

2 In the left pane, click the OUValue node where you want to define the 
extended attribute.

In the right pane, the full path of the current organization unit displays.

3 Click Configuration > Add Extended Attribute. 

Alternatively, from the left pane, you can right-click the OUValue node in 
the Organization Tree and click Add Extended Attribute.

4 Use the following information to fill in the Add Extended Attribute panel:

Name Name of the extended attribute

Description Description of the extended attribute

Category Select one of the following values:

Common: The extended attribute is associated with service 
groups, systems, pframes, vframes, and vobjects.

Group: The extended attribute is associated with service 
groups.

System: The extended attribute is associated with systems.

Pframe: The extended attribute is associated with pframes.

Vframe: The extended attribute is associated with virtual 
machines.

Vobject: The extended attribute is associated with a 
management console.
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5 Click OK > Close.

In the right pane view of the Organization Unit window, the new extended 
attribute appears in the Locally-defined Extended Attributes table.

To define an extended attribute from the command line

Use the haea -add command to add an extended attribute from the command 
line. More information is available on the haea command.

See Veritas Cluster Server One Command Reference Guide.

Assigning an extended attribute a value 
You can change an extended attribute value in the details page of the attribute.

To assign an extended attribute a value using the VCS One console

1 In the VCS One console, choose one of the following depending on which 
object you want to assign an extended attribute value:

 Type Click one of the following radio buttons:

Freeform: When the extended attribute is given a value, 
freeform text is used. The value of the extended attribute does 
not have a preset list of possible options. 

Enumerated: The extended attribute has a preset list of 
possible values that is enforced.

Value If the Value Type for the extended attribute is Enumerated, 
this box defines the preset list of values. 

To add a value: Click + and type the value in the box. 

To delete a value: Click the value, then click -

Caution: Do not use commas in an extended attribute value. If 
a single extended attribute (EA) value contains a comma, the 
value is interpreted as multiple values.

Default Value If Enumerated is the Value Type, one of the preset values can 
be designated as a default value for the extended attribute.

Click twice to select the default value from the drop down list.

Click Manage > Service Groups For a service group type extended attribute

Click Manage > Systems For a system type extended attribute

Click Manage > Virtualization For a frame type extended attribute.
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2 In the right pane, click the name of the object that you want to define an 
extended attribute value. 

3 In the right pane, find the row in the Extended Attributes table that has the 
extended attribute whose value you wish to define or edit.

4 Click the Edit button of that attribute row.

5 In the Edit Extended Attribute window, in the Value box, enter the value of 
the extended attribute.

Either type in a freeform value, or click predefined enumerated value from 
the drop-down list.

6 Click OK > Close.

To assign an extended attribute a value using the command line

◆ Type the following command 
ha_command -modify object ea value

Use the following information to replace the appropriate variables:

Combining extended attributes in an expression
Extended attributes can be combined into an expression using either an AND or 
an OR logical operator. 

The following examples are valid extended attribute expressions:

■ osname=solaris

■ osname=solaris AND location=london AND building=bldg_a

■ osname=solaris OR osname=linux AND building=bldg_a

An expression can have a maximum of 65536 name=value pairs.

If you combine extended attributes using the console, the AND operator will be 
populated in the expression. To use the OR operator, manually edit the 
expression.

ha_command The command used depends on the object that the 
extended attribute describes. Use the following guideline:

■ Use hasys for system extended attributes

■ Use hagrp for group extended attributes

object The name of the group or system object.

ea The name of the extended attribute.

value The value to assign the extended attribute.
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Deleting an extended attribute

To delete an extended attribute using the VCS One console

1 In the VCS One console, click Administration > Extended Attributes.

2 In the organization tree in the left pane, click the OUValue node that 
contains the extended attribute you wish to delete.

3 In the Locally-defined Extended Attributes table, find the rows that 
contains the extended attribute in the Name column.

4 Check each extended attribute to delete.

5 Click Configuration > Delete Extended Attribute(s).

To delete an extended attribute from the command line

◆ Type the following command:
haea -delete [-sys | -grp | -frame ] attribute

where attribute is the name of the attribute to be deleted.

Modifying the value of an inherited extended 
attribute

You can modify the value of an extended attribute in the following ways:

■ Reset the default value of an extended attribute:

■ Reset the valid values of the extended attribute

You may only override the valid values of inherited extended attributes if the 
new list of valid values of the inherited extended attribute is a subset of the list 
of valid values of its parent.

Modifying the default value of an extended attribute at an OUValue node does 
not change the value of the extended attributes of objects that are already 
attached at that node. The new value will be applied to the new objects that get 
attached.

To reset the values of a inherited extended attribute using the VCS One 
console

1 In the VCS One console, click Administration > Extended Attributes.

2 In the organization tree in the left pane, click the OUValue node that 
contains the extended attribute you wish to reset.

3 In the Inherited Extended Attributes table, find the rows that contains the 
extended attribute in the Name column.
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4 Click the pencil icon to edit.

5 In the Modify Extended Attribute window, in the Value table, modify the list 
of inherited attribute values.

6 Click the Reset valid values button to redefine the valid values of the 
extended attribute

7 Click the Reset default value button to change the value of the extended 
attribute to the default value.

8 Choose a propagate option, if appropriate

9 Click OK > Close.

To reset the values of an extended attribute from the command line

◆ Type the following command:

haea -reset [-sys | -grp | -frame][-validvalues] OUValuePath 
attribute [-user user@domain] [-domaintype domaintype]

where 

OUValuePath is the location in the tree the attribute is attached.

attribute is the attribute name to be reset.

If —validvalues option is specified, the list of valid values for the 
extended attribute is synced up with the list of valid values of the attribute 
in the parent node of OUValuePath.

Modifying the value of a locally defined extended 
attribute

To modify the value of a locally defined extended attribute

1 In the VCS One console, click Administration > Extended Attributes.

Propagate (add the value to EAs 

in the OU sub-tree)

Use this option to propagate your modification to 
this extended attribute to all the nodes below this 
node in the organization tree.

Deleting an extended attribute value will always 
propagate.

Propagate (change the default 

value for EAs in the sub-tree)

Use this option to propagate your modification to 
this extended attribute to all the nodes below this 
node in the organization tree that use the default 
value.
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2 In the organization tree in the left pane, click the OUValue node that 
contains the extended attribute you wish to modify.

3 In the Locally-defined Extended Attributes table, find the rows that 
contains the extended attribute in the Name column.

4 Click the pencil icon to edit.

5 In the Modify Extended Attribute window, in the Value table, modify the list 
of extended attribute values.

6 Choose a propagate option, if appropriate

7 Click OK > Close.

Modifying notification settings
The Simple Mail Transfer Protocol (SMTP) is an application layer protocol, that 
is used to send emails over the Internet. 

Simple Network Management Protocol (SNMP) is a component of the TCP/IP 
protocol. It enables network devices to exchange management information with 
each other and facilitates the node management over an IP network. 

VCS One enables you to send SMTP email notifications for specific events in the 
VCS One cluster to the recipients configured in the rules. VCS One also enables 
you to send SNMP notifications for specific events in the VCS One cluster to an 
SNMP management station. 

Use this procedure to configure or edit the SMTP and SNMP settings.

A user with Modify Notifier privileges can configure SMTP notification settings. 

A user with Notify SNMP privileges can configure SNMP settings. A user with 
either Modify Notifier privileges or Notify SNMP privileges can configure SNMP 
notification settings. 

A user with ModifyAutomationSettings privileges can modify these settings.

To modify notification settings

1 In the VCS One console, click Administration > Automation Settings.

Propagate (add the value to EAs 

in the OU sub-tree)

Use this option to propagate your modification to 
this extended attribute in all the node below this 
node in the organization tree.

Propagate (change the default 

value for EAs in the sub-tree)

Use this option to propagate your modification to 
this extended attribute in all the nodes below this 
node in the organization tree that use the default 
value.
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2 Click Configuration > Edit Settings.

3 Use the following information to enter information in the Edit Settings 
panel.

SMTP Server Enter the name or IP address of the SMTP server. 

All email notifications are disabled until you specify an 
SMTP server. 

Secondary SMTP Server Enter the name or IP address of the secondary SMTP 
server

Server timeout After sending SMTP commands to the mail server, the 
notifier waits for this number of seconds for a response 
from the mail server.

If this timeout happens, the rule will report an error.

SMTP From Path Enter the SMTP from path. 

The default value is VCSOne-Notifier.

SMTP Return Path Enter a valid email address for the SMTP return path. If 
delivery of an email fails, the bounced email is delivered 
to this email address.

Web Console Address Enter the IP address of the Web console.

If the Policy Master has multiple IP addresses, enter the 
IP address that is accessible to all the email recipients. If 
you do not specify an IP address, the base IP address that 
is used in the Web console URL appears in the 
notifications.

Maximum Emails Limit The maximum number of emails that will be sent in a 
given hour per email address.

When this limit is reached, a message is sent out with the 
subject line “Notifications are halted”

SNMP Trap Port Enter the number of the port on which the SNMP traps 
are sent. 

An SNMP trap is an alert message, which is sent to the 
management station. 
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4 Click OK.

5 Use the following information to enable notifications.

6 Test the new configuration.

See “Testing notification settings” on page 643.

Enabling notification settings
Use this procedure to enable SMTP or SNMP. In an actual installation these 
values are enabled by default. In simulated environments, these values are 
disabled by default.

To enable notification settings

1 In the VCS One console, click Administration > Automation Settings.

2 Use the following information to enable SMTP and SNMP.

3 Click Yes.

SNMP Community Enter the name of the SNMP community, which includes 
the SNMP management station. 

An SNMP community is a group of SNMP enabled 
network devices and management stations. An SNMP 
device can belong to one or more SNMP communities, and 
responds only to requests from the management stations 
that belong to one of its communities. The default SNMP 
communities are private and public.

Default value = public

Default SNMP Console Enter the name or IP address of the default SNMP 
management station to which you want to send SNMP 
notifications. 

Used as the default value for SNMP Consoles field when 
adding a Notification Rule. User may erase this default 
value or specify a new value.

Enable SMTP notifications Click Operations > Enable SMTP Notifications.

Enable SNMP notifications Click Operations > Enable SNMP Notifications.

Enable SMTP notifications Click Operations > Enable SMTP Notifications.

Enable SNMP notifications Click Operations > Enable SNMP Notifications.
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Disabling notification settings
Use this procedure to disable SMTP or SNMP. If disabled, rules and jobs that 
have email or SNMP tasks will be marked as error and not execute.

To disable notification settings

1 In the VCS One console, click Administration > Automation Settings.

2 Use the following information to disable SMTP and SNMP.

3 Click Yes.

Enabling syslog notifications
A user with the Syslog privileges in the Notifier privilege category can configure 
syslog notifications. 

To enable syslog notifications

1 In the VCS One console, click Administration > Automation Settings.

2 Click Operations > Enable Syslog Notifications.

3 Click Yes. 

Disabling syslog notifications
A user with the Syslog privileges in the Notifier privilege category can configure 
syslog notifications. 

To disable syslog notifications

1 In the VCS One console, click Administration > Automation Settings.

2 Click Operations > Disable Syslog Notifications.

3 Click Yes. 

Enabling script execution
Use this procedure to enable automation policy to execute a script.

Disable SMTP notifications Click Operations > Disable SMTP Notifications.

Disable SNMP notifications Click Operations > Disable SNMP Notifications.
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To enable script execution

1 In the VCS One console, click Administration > Automation Settings.

2 Click Operations > Enable Script Execution.

3 Click Yes.

Disabling script execution
Use this procedure to disable automation policy’s ability to execute a script. If 
disabled, all rules and job that have script tasks will be marked as error and will 
not execute.

To disable script execution

1 In the VCS One console, click Administration > Automation Settings.

2 Click Operations > Disable Script Execution.

3 Click Yes.

Testing notification settings
Use this procedure to test SMTP, SNMP, or Syslog notification settings. After 
you configure notification settings, test the settings to ensure that they work 
correctly. 

If the SMTP server is not configured correctly, email notifications are disabled.

To test notification settings

1 In the VCS One console, click Administration > Automation Settings.

2 Click Configuration > Test Settings.

3 Enter the following information in the Test Setting window:

4 Click OK > Close.

Notification Type Click Email, SNMP, or Syslog to identify the type of test.

Recipient Enter the following information depending on what Notification 
Type option you selected:

■ The email address of the recipient

■ The hostname to send the SNMP traps

■ The hostname to send the log messages
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roles

This chapter includes the following topics:

■ About administering users and roles

■ Adding or deleting a user or usergroup

■ Cloning a user or user group

■ Deleting a user or usergroup

■ Assigning or unassigning a role and objects to a user or usergroup

■ Adding custom roles

■ Cloning a role

■ Editing a role

■ Deleting a role

■ Modifying user or usergroup settings

■ Editing user or user group attributes

■ Moving a user to another Organization Tree node

■ Enabling a user or usergroup

■ Disabling a user or usergroup

■ Viewing a user’s or user group’s settings, roles and associated objects

■ Authenticating VCS One users
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About administering users and roles
When a user performs an operation, VCS One authorizes the action and the 
objects the user can act upon using the user’s configured privileges. If the user 
does not have appropriate privileges, the operation will not execute.

VCS One has both predefined roles and the ability to create custom roles. 

See “About users, user groups, and their roles” on page 37.

Checking your VCS One cluster privileges
Privileges define what actions the user can perform, such as adding a system to 
the VCS One cluster or modifying a service group.

When a user tries to perform an operation, VCS One authorizes the user’s action 
against the privileges associated with the user’s role(s).

To check your VCS One cluster privileges

1 In the VCS One console, click Administration > Users.

2 In the right pane, click your login name in the User Name column.

3 In the User privilege details table, view the objects and roles associated with 
your login.

4 In the Roles Associated column, click the role to view the specific privileges 
granted.

A granted privilege has a check mark next to it.

See “Reference of privileges” on page 753.

Adding or deleting a user or usergroup
Defining a VCS One usergroup allows you to assign privileges and roles to a user 
group that is external to VCS One, for example an LDAP defined user group.

Usergroup functionality is not supported in the VCS One simulator when it is 
running in non-secure mode.

You may clone a usergroup if there is a usergroup already in the configuration 
that closely resembles the usergroup you wish to create.

Add a user or usergroup via the console or the command line. You may assign 
one or more roles to a user or usergroup after adding it.

To add a user using the VCS One Console

1 In the VCS One console, click Administration > Users.
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2 Click Configuration > Add User / User Group.

3 Click Next.

4 If adding a user, click Add User. 
If adding a User Group, click Add User Group.

5 Enter the name of the user or usergroup in the following format: 

■ User: username@domain

■ User Group: usergroupname@domain

6 Enter the first name of the user or usergroup in the First Name text box. 
Enter the last name of the user or usergroup in the Last Name text box.

7 If using notification, enter the email address (SMTP) of the user or 
usergroup.

8 If using notification, enter the Message (SNMP) address of the user or 
usergroup. 

9 In the Add User / Usergroup window, do one of the following tasks:

■ Click Finish 

This will add the user or usergroup to the configuration.

■ Click Next to select the organization unit to associate with the user.

From the organization tree, select the OUValue node where you want to 
attach the user.

When choosing the OUValue node, keep in mind the privileges assigned 
to a user are valid for the node the user is attached to and all the nodes 
below that node in the Organization Tree.

10 Click Finish.

11 From the Summary window, do one of the following tasks:

■ Click Assign Roles to assign roles to the newly added user or usergroup.

This will launch the Assign-Roles wizard. 

See “Assigning or unassigning a role and objects to a user or 
usergroup” on page 649

■ Click Close. 

To add a user using the command line

◆ Use the hauser command with -add option to add user as user@domain
hauser -add username@domain

To add a usergroup using the command line

◆ Use the hauser command with the -add and -usergroup option to add 
usergroup as usergroup@domain
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hauser -add -usergroup usergroupname@domain

Cloning a user or user group
Use this procedure to create a new user or user group that closely resembles a 
user or user group already in the configuration. Once you clone the user or user 
group, edit it as appropriate.

See “Assigning or unassigning a role and objects to a user or usergroup” on 
page 649.

To clone a user or usergroup using the VCS One console

1 In the VCS One console, click Administration > Users.

2 In the right pane, select a user or user group to clone.

3 Click Configuration > Clone User/UserGroup.

4 In the New User or User Group Name box, enter a name for the new user or 
user group.

5 Click OK.

Deleting a user or usergroup
A user can not delete his or her self.

To delete a user or usergroup using the VCS One console

1 In the VCS One console, click Administration > Users.

2 Click the box to the left of the user or usergroup.

Locate the user or usergroup under the User Name heading. Use the Table 
filter to restrict the view if needed.

3 Click Configuration > Delete Users / User Groups. 

4 Click OK.

To delete a user using the command line

◆ Use the hauser command with the -delete option. 
hauser -delete user@domain

To delete a usergroup using the command line

◆ Use the hauser command with the -delete and -usergroup options. 
hauser -delete -usergroup usergroupname@domain
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Assigning or unassigning a role and objects to a user 
or usergroup

You can view existing roles, assign predefined roles to users or create and assign 
custom roles to users. Predefined roles have specific names and prescribe a 
specific set of operations for each role type. Custom roles allow for flexibility in 
defining roles specific to your environment. 

When assigning roles to a user or user group, the role must be a subset of the 
union of all privileges of the current user and the user’s associated user groups.

If you have just added a user and launched the Assign-Roles wizard, continue 
with assigning the role at step 5 of “To assign or unassign a role and objects to a 
user or usergroup using the VCS One console”.

See “Displaying roles” on page 657.

See “Adding custom roles” on page 650.

To assign or unassign a role and objects to a user or usergroup using the VCS 
One console

1 In the VCS One console, click Administration > Users.

2 Check one or more users.

3 Click Configuration > Assign / Unassign Roles.

4 Click Next.

5 In the Select Roles panel, if you selected multiple users, choose For all 
User(s)/User Groups to assign or unassign roles for all selected users. 
Choose For selected User(s)/ User Group(s) to select individual or subsets of 
users.

6 Use the following information to select roles for the user.

Add From the Available Roles table, click the role to add to the user, 
and click the add arrow. The new role appears in the Selected 
Roles table.

Remove From the Selected Roles table, click the role to remove from 
the user and click the remove arrow. The role is removed from 
the Selected Roles table.
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7 Click Next > Finish > Close.

To assign a role to a user using the command line

◆ Use the hauser command with the -addrole option. 

The following example adds the SystemAdministrator role for three 
systems to username@example.com.
hauser -addrole username@example.com SystemAdministrator 
sysA sysC sysE

The following example adds the SystemAdministrator role to 
username@example.com for the organization unit 
/Division=retail/Dept=internet
hauser -addrole username@example.com SystemAdministrator 
-ou Division=retail/Dept=internet

To assign a role to a usergroup using the command line

◆ Use the hauser command with the -addrole and -usergroup options. 
hauser -addrole -usergroup usergroupname rolename object 

To delete a role for a usergroup using the command line

◆ Use the hauser command with the -deleterole and -usergroup options. 
hauser -deleterole -usergroup usergroupname rolename object 

Adding custom roles
VCS One provides predefined roles, but also enables you to define new roles. For 
example, you may want to identify roles by the name of an application, limit a 
role to a subset of systems, or tailor the set of operations you assign to a user.

You may clone a role if there is a role that closely resembles the role you wish to 
create.

See “Cloning a role” on page 652.

To add a new role with the VCS One console

1 In the VCS One console, click Administration > Roles.

Objects Select a row in the Selected Roles column to view the 
corresponding objects in this area.

To configure the object(s) for which the user has the privileges, 
click the pencil icon in the Objects column.

In the Selected Role Details page, select the Objects or 
Organization Units, as appropriate. Click OK.
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2 Click Configuration > Add Role.

3 Specify a name for the new role. For example, FinanceGroupOperators.

4 Specify a description for the new role. For example, “Role for finance group 
operators only.”

5 Select a role type. For example Group.

6 The role type you select will filter the types of privilege categories available 
to that role.

7 Select the privileges for the role type. Select all privileges, specific 
privileges, or none.

8 Click Add New Role.

The All Roles view displays and shows the new role under Role Name.

9 To assign the new role to users, click Configuration > Assign / Unassign 
Roles. 

See “Assigning or unassigning a role and objects to a user or usergroup” on 
page 649.

To create a new role with custom privilege set with the command line

The following example shows adding a custom System type role called 
MySysAdmin that has a subset of system operation privileges. 

1 Add the role using the following command:
harole -add MySysAdmin -type System -desc “Custom System Admin 
role”

To display the role types available, use the harole -listtypes command.

2 Define custom privileges for the new role using the following command:
harole -addpriv MySysAdmin S_AddSystemtoSystemList 
S_DeleteSystemfromSystemList S_FreezeSystem S_EvacuateSystem 
S_UnFreezeSystem

You can display all privileged operations for a role type.

See “Displaying the permitted operations for a role type:” on page 658.

To create a role with inherited privileges from the command line

In this example, the new role inherits GroupAdministrator role privileges but 
has a new role name for purposes of assigning it to specific users to perform 
operations on specific system objects. 

1 Use the harole command with the -add option and the -inherit option.
harole -add MyGroupAdmin -inherit GroupAdministrator

2 Display information about the new role:
harole -display MyGroupAdmin
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The display shows operations the new role permits a user to perform. The 
list of operations is identical to that for the GroupAdministrator role. 
Operations can be added or deleted using the -addpriv or -deletepriv option 
of the harole command.

See the Veritas Cluster Server One Command Reference Guide.

Cloning a role
Use this procedure to create a new role that closely resembles a role already in 
the configuration. Once you clone the role, edit the new role as appropriate.

See “Editing a role” on page 652.

To clone a role using the VCS One console

1 In the VCS One console, click Administration > Roles.

2 From the All Roles table, select a role to clone.

3 Click Configuration > Clone Role.

4 In the Clone role panel, in the New Role Name box, enter a name for the new 
role.

5 Click OK.

You may have to refresh the screen to see the new role in the All Roles list.

To clone a role using the command line

◆ Type the following command
harole -add role1 -inherit role2

Use the following information to replace the appropriate variables:

Editing a role
You may modify the list of privileges for either a custom role that you create or 
certain predefined roles.

See “About roles” on page 251.

role1 The name of the new role.

role2 The name of the role to clone from the configuration.
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To edit a role using the VCS One console

1 In the VCS One console, click Administration > Roles.

All roles display in a list. Use the Table filter box to filter the results shown 
on the page.

2 Click the name of role under the Role Name column. 

3 Click the Description link to edit the description of the role.

4 Click each link in the Privilege Category list to view the privileges available 
in that category for that role.

The privileges identified with checked boxes indicate the permitted 
operations for the role.

5 Check or uncheck privileges for the role.

Greyed out check boxes indicate you may not modify the list of privileges 
for that role. Click All to select all privileges in that privilege category.

6 At the far right or the window, click Update Role.

Deleting a role
A role may not be deleted if it is assigned to a user.

To delete a role using the VCS One console

1 In the VCS One console, click Administration > Roles.

2 From the All Roles table, select one or more roles to delete.

3 From Configuration menu, click Delete Role(s).

4 Click OK > Close.

To delete a role using the command line

◆ Type the following command
harole -delete role

Use the following information to replace the appropriate variables:

role The name of the role to delete from the VCS One configuration.
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Modifying user or usergroup settings
You may modify a user’s or usergroups’s name, email, and SNMP address 
information. To modify other user attributes, go to “Editing user or user group 
attributes” on page 654.

To modify user or usergroup settings using the VCS One console

1 In the VCS One console, click Administration > Users.

2 Locate the user or usergroup under the User Name heading. 

3 For the specified user, click the corresponding pencil symbol at the 
beginning of the row. 

4 Modify the First name, Last name, E-mail or SNMP Address.

5 Click OK.

To modify user settings using the command line

◆ Use the hauser command with -modify option.

For example, if the user will receive notifications, you can modify the user’s 
Email attribute and SnmpAddress attribute to assign values.
hauser -modify username@example.com Email “username@example.com”
hauser -modify username@example.com SnmpAddress “snmp_address”

Enclose the attribute values in quotes if the values have delimiters such as 
“.” or “@”.

To modify usergroup settings using the command line

◆ Use the hauser command with -modify and -usergroup option.

For example, you can modify the usergroup’s Email attribute.
hauser -modify -usergroup usergroupname@domain Email 
“usergroupname@domain”

Editing user or user group attributes
You can modify some attributes of a user. More information is available on user 
level attributes.

See “User attributes” on page 886.

To modify a user’s attributes using the VCS One console

1 In the VCS One console, click Administration > Users.

2 In the All Users table, click the user name link under the User Name 
heading.
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3 Click the All Attribute link to the far right of window.

4 In the All Attributes table, click the Edit button for any editable attributes.

You may only edit attributes of global scope from this page.

5 In the Edit Attribute box, type a new value in the Value box.

6 Click OK.

Moving a user to another Organization Tree node
The privileges a user is given correspond to the objects, systems or service 
groups, at the nodes the user is attached, and all the nodes below that node in 
the Organization Tree. 

To move a user to another organization unit node

1 In the VCS One console, click Administration > Users.

2 Select an existing user by clicking the check box to the left of the user.

3 Click Configuration > Move Users / User Groups.

4 From the Organization Unit Selection window, click the new OUValue node.

5 Consider the Modify Privileges if move violates the assigned roles check 
box.

6 Click Finish.

To move a user to another organization unit node using the command line

◆ Type the following command at the prompt:
hauser -move user@domainname -ou ounode_path

Enabling a user or usergroup
You can enable users or usergroups using the console or the command line. A 
newly added user or usergroup is enabled by default. Enabling a user or 
usergroup enables all the associated privileges.

To enable a user or usergroup using the console

1 In the VCS One console, click Administration > Users.

2 Click the link of an existing user or usergroup from the User Name column. 

3 Click Configuration > Enable User / User Group.

4 Click OK.
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To enable multiple users or usergroups using the console

1 In the VCS One console, click Administration > Users.

2 In the Users and UserGroups window, click the box to the left of each 
existing user you wish to enable, or click the box in the blue heading row of 
the table to select all users.

You may use the Table filter to filter the list of users viewed.

3 Click Configuration > Enable Users / User Groups.

4 Click OK.

To enable a user using the command line

◆ Type the following command at the prompt:
hauser -enable user@domainname

To enable a usergroup using the command line

◆ Type the following command at the prompt:
hauser -enable -usergroup usergroup@domainname

Disabling a user or usergroup
You can disable users in VCS One using the console or the command line. 
Disabling a user revokes all privileges of the user, including read privileges, 
without deleting the user. A disabled user will not be able to log in.

To disable a user or usergroup using the console

1 In the VCS One console, click Administration > Users.

2 Click the link of the user you wish to disable from the User Name column. 

3 Click Configuration > Disable User / User Group.

4 Click OK.

To disable multiple users or usergroups using the console

1 In the VCS One console, click Administration > Users.

2 In the Users and UserGroups window, click the box to the left of each 
existing user you wish to disable, or click the box in the blue heading row of 
the table to select all users.

You may use the Table filter to filter the list of users viewed.

3 Click Configuration > Disable Users / User Groups.

4 Click OK.
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To disable users using the command line

◆ Type the following command at the prompt:
hauser -disable user@domainname

To disable a usergroup using the command line

◆ Type the following command at the prompt:
hauser -disable -usergroup usergroup@domainname

Viewing a user’s or user group’s settings, roles and 
associated objects

Perform the following steps to view a user’s or user group’s settings.

To view a user’s or user group’s settings using the console

1 In the VCS One console, click Administration > Users.

The users and usergroups are listed that are relative to the node selected in 
the Organization Tree in the left pane.

To filter the view, use the Table filter box.

2 Click the user name link to display the user’s settings, including assigned 
roles and associated objects. 

To view a user’s or user group’s settings using the command line

◆ Type the following command to display a user.
hauser -display user@domainname

◆ Type the following command to display a user group.
hauser -display -usergroup user@domainname

Displaying roles
You can view both predefined and custom-created roles. 

To display roles using the console

1 In the VCS One console, click Administration > Roles.

All roles display in a list. To filter the view to find a specific role, use the 
Table filter box.

2 Click the name of role under the Role Name column. 

View the role name, role type, and description. The privileges identified 
with checked boxes indicate the permitted operations for the role. 
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3 Click each link in the Privilege Category list to view the privileges available 
in that category for that role.

To display roles using the command line

◆ Type the following command to display the list of custom-created roles and 
pre-defined roles:
harole -list -all

To display information about a role using the command line

◆ Type the following command to display information about a role:
harole -display MySysAdmin

Included in the output are the operations the role permits a user to perform.

Displaying role types

To display role types

◆ User the harole command to display the role types, or privilege categories.
harole -listtypes

Displaying the permitted operations for a role type:
◆ User the harole command to list the permitted operation for a role type.

harole -listoperations -type system

The display lists all privileged operations for the system role type in VCS 
One, with output lines similar to the following example.
S_AddSystemtoSystemList 
S_DeletSystemfromSystemList
S_FreezeSystem

Note that privileges are denoted as operations prefixed with letters that 
indicate the role type.

Table 26-1 denotes the prefix and the corresponding role type.

Table 26-1 Role prefix and corresponding role type

Prefix of role Role type

F Cluster

S System

PF Pframe 

VF Vframe



659Administering users and roles
Authenticating VCS One users
Authenticating VCS One users
In VCS One, you can issue commands to perform tasks associated with your 
assigned roles. To ensure security in a VCS One environment, a user executing a 
command requires a credential acceptable to the Policy Master. A VCS One user 
is one who has been added by the administrator or is part of a usergroup that 
has been added to the VCS One configuration.

Authentication in a VCS One environment is controlled by the Symantec 
Product Authentication Service (AT). The Policy Master, the VCS One clients, 
and the services obtain credentials from the authentication broker running on 
the Policy Master system. These credentials enable secure communication 
between users and services in the VCS One cluster.

For information about supported authentication service types and setting up 
authentication plug-ins in a VCS One environment, see the Veritas Cluster 
Server One Installation Guide.

Issuing commands from the command line
In VCS One, you may issue commands from different contexts, depending on 
your identity and domain type. The context of a logged-in user is the default 
user context on an VCS One cluster system. Some logged-in users may already 
have credentials to issue commands, others may not.

Logged-in users may authenticate with the authentication broker and obtain a 
credential, enabling them to successfully issue VCS One commands from client 
systems using the following methods:

V Vobject

O Object

G Group

R Resource

U User

T Organization tree

N Notifier

A Automation

C Composite Service Group

Table 26-1 Role prefix and corresponding role type

Prefix of role Role type
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■ Use the -user and -domaintype options with each command to specify the 
user profile. For example:
hasys -display SysC -user user@domain -domaintype unixpwd

Accepted values for -domaintype domaintype are unixpwd, nis, nisplus, 
ldap, pam, and vx. These values are case sensitive.

You will be prompted for a password for the first time you issue the 
command. You will not be prompted for a password for the next 24 hours, 
after which you will be required to re-enter the password. 

See “Issuing commands with an explicit user profile” on page 660.

■ Set VCSONE_USERNAME and VCSONE_DOMAINTYPE environment 
variables on the client system to specify the user’s profile. The first VCS One 
command issued after setting these variables requires a user password. 
Subsequently, a user may execute commands without the -user and 
-domaintype options until the credential expires. 

See “Issuing commands with environment variables set” on page 661.

■ Use the halogin command to specify an explicit user profile to store, along 
with a credential, in the user’s home area, and use as a default context. After 
running halogin, you may issue commands from the system without having 
to use the -user and -domaintype options or having to enter passwords for 
a duration, typically 24 hours. The default context set by halogin may be 
overridden using the -user and -domaintype options or by resetting the 
environment variables. The order of preference for determining the user 
context is:

-user/-domaintype option over environment variables over halogin

See “Issuing commands using halogin” on page 661.

Issuing commands with an explicit user profile
Perform the following steps to issue commands with an explicit user profile.

To issue commands with an explicit user profile

A VCS One user can enter a command by providing a fully qualified domain user 
name, a valid domain type, and a password when prompted. In the following 
example, a VCS One user, username@example.com of a valid domain type 
unixpwd, with SystemAdministrator privileges can enter a command to freeze a 
system:

1 Enter the command, providing the user and domain type information:
hasys -freeze [-evacuate] sys [-user username@domainname] 
[-domaintype domaintype]

For example:
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hasys -freeze SysA -user username@example.com -domaintype 
unixpwd

2 When prompted, enter the password for the user.

Issuing commands with environment variables set
Perform these steps on all systems from where you wish to run VCS One 
commands.

To issue commands with environment variables set

1 Set the VCSONE_USERNAME and VCSONE_DOMAINTYPE environment 
variables. For example:
export VCSONE_USERNAME=username@example.com
export VCSONE_DOMAINTYPE=unixpwd

2 Issue the VCS One command. For example:
hasys -freeze SysA

3 If prompted, enter the password for the user.

Issuing commands using halogin
Use the halogin command on all systems from where you wish to run VCS One 
commands. You should obtain the user credentials, issue the VCS One 
commands, and delete the user credentials. The obtained credentials are 
typically valid for 24 hours.

The user with login username should have an account on all systems that will 
host the Policy Master. You do not have to be logged in with the same username 
as you are using with halogin.

See the Veritas Cluster Server One Command Reference Guide.

To obtain a credential by using halogin

1 Enter the halogin command, providing a fully qualified user name and 
domain type. For example:
halogin -user username@name_of_PolicyMaster.example.com 
-domaintype unixpwd

2 You are prompted to enter the password. Use the password for the username 
account on the Policy Master.

You may also include the password using the -passwd option in the original 
command, for example:
halogin -passwd password -user username@example.com 
-domaintype unixpwd

You obtain the credentials after the command is successful. These credentials 
are stored in the .vcsoneprofile file, in the user’s home directory, on the system 
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where the command was run. This user profile is used for communicating with 
the Policy Master.

To end the halogin session

◆ Type the following command at the prompt:
halogin -endsession IP_address of Policy Master

For example:
halogin -endsession 192.168.10.15

Usually the Policy Master IP address is a virtual IP address.

Issuing commands through a script from client systems
A user with the appropriate privileges can create users with credentials to issue 
commands from within scripts on client systems. Typically, logged-in users 
have a credential that expires in 24-hours, whereas users who can run 
commands from within scripts may require long-term credentials.

To obtain long-term credentials, the user must be added to the cluster private 
domain repository (PDR). 

For instructions about how to add a user to the cluster private domain for any of 
the authentication service types supported by VCS One, see “Setting up 
authentication plug-ins in VCS One” in the Veritas Cluster Server One 
Installation Guide.

Thereafter, the user with the credential can authenticate by using one of the 
following methods:

■ Running halogin to set up the user profile

■ Including the -user and -domaintype options with the commands from 
within the scripts

■ Setting the environment variables within the scripts

To run commands from within a script with authentication

The following methods are available to run commands from within a script with 
authentication:

■ Method 1 — Include -user and -domaintype options with each command in 
the script. 

See “Issuing commands with an explicit user profile” on page 660.

■ Method 2 — Before running the scripts, create a user profile on the system 
for the user in whose context the scripts will be run. With profile set, the 
user can run the scripts and the commands are authenticated. 

See “Issuing commands using halogin” on page 661.
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■ Method 3 — Use environment variables.

See “Issuing commands with environment variables set” on page 661.
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Administering sets of 
objects

This chapter includes the following topics:

■ About administrating sets of objects

■ Building a set

■ Viewing objects in a set

■ Viewing the details of a set definition

■ Deleting a set

■ Modifying a set

■ Configuring a custom view of the organization tree and extended attributes

■ Deleting a custom view

■ Modifying a custom view
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About administrating sets of objects
A set specifies a collection of VCS One objects. Valid objects to include in a set 
are systems, PFrames, VFrames, VObjects, or service groups.

You should have at least one of the following structures in use before you define 
a set:

■ An Organizational Tree structure defined.

See “About users and the Organization tree” on page 252.

■ Extended attributes defined and assigned value for system or service group 
objects.

See “About extended attributes” on page 632.

Building a set
A set is a named collection of objects.

A set is created using a combination of OUValue nodes in the organization tree 
and extended attributes. You may create a set using the procedure in this topic 
or by applying table filters and using the Save as Set button.

See “Filtering results in a table” on page 129.

This named set expression is stored in the Policy Master database, specific to the 
user that defines it. The user that creates the set name must have the proper 
permissions configured to see all of the OrgTree specified by the OUValuePath.

■ OUvalue node

An OUValue nodes is represented by an organization tree path. The set is 
defined as all systems or groups that are at this node unless extended 
attribute are used to further filter the selection criteria.

An organization tree path is denoted by a list of OUName=OUValue pairs, 
separated by a forward slash (/). 

For example, a sample organization tree path could be: 
LOB=Enterprise/Division=WebHosting/Department=Engineering

■ Extended attributes

Extended attributes can be combined with the AND or the OR logical 
operator.

When using a set expression as part of a predefined attribute definition, 
explicitly specify an OUValuePath.

To build a set using the VCS One console

1 In the VCS One console, click the Administration > Sets.

2 Click Configuration > Add Set.
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3 Click Next.

4 In the Add Set panel, use the following information to fill in the fields:

5 Click OK to create the set.

6 Click Add Custom View to create a custom view for the newly created set or 
click Close to finish the wizard.

See “Configuring a custom view of the organization tree and extended 
attributes” on page 669.

To build a set using the command line

◆ You can specify a set with a name by typing any of the following commands 
at the command prompt:
haset -add set_name -ea expression 
haset -add set_name -ou expression 
haset -add set_name -ea expression -ou expression 

where

set_name is the name of the set

expression is a expression using extended attributes or using an OrgTree 
path, as appropriate to the flag.

for example:
haset -add UKRetailSolaris -ou “LineofBusiness=Retail” -ea 
“OSname=Solaris AND Location=London” 

Would allow you to replace the command:
hasys -display -ou “LineofBusiness=Retail” 
-ea “OSname=Solaris AND Location=London”

with the command:
hasys -display -setname UKRetailSolaris

Name The name of the set.

Description A description for the set.

OU Expression To add an OUValue node to the set, enter an OUValue node path in 
this text box. You may also click the edit ellipse to select an 
OUValue node from the organization tree view.

Click OK to return to the Add Set panel.

EA Expression To add an extended attribute expression to the set, enter an 
expression in the text box. You may also click the edit ellipse to 
build an extended attribute expression.

Click OK to return to the Add Set panel.
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Viewing objects in a set
Use this procedure to view the objects in a set.

1 In the VCS One console, Administration > Sets.

2 Click the name of the set.

Viewing the details of a set definition 
The following information displays when you view a set:

■ Name

■ Description

■ Associated OU expression

■ Associated extended attributes expressions

■ Custom view defined for the set

To view the details of a set with the console

1 In the VCS One console, click Administration > Sets.

2 In the right pane, click the link that is the name of the set you wish to view.

To view the details of a set with the command line

◆ Type the following at the command prompt:
haset -display SetName

To view the details of all sets that you have the permissions to display

◆ Type the following at the command prompt:
haset -display 

Deleting a set 
Deleting a set removes it from the Policy Master database.

To delete a set using the VCS One console

1 In the VCS One console, click the Administration > Sets.

2 Check one or more sets that you wish to delete.

3 Click Configuration > Delete Set(s).

4 Click OK > Close.
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To delete a set using the command line

◆ Type the following at the command prompt:
haset -delete SetName

Modifying a set

To modify a named set with the console

1 In the VCS One console, click the Administration > Sets.

2 In the right pane, click the link that is the name of the set you wish to 
modify.

3 Click Configuration > Modify Set.

You may also right click the name of the set in the left pane, and click Edit.

4 In the Modify Set window, you may modify the Description, OU Expression 
or EA Expression related to the set.

5 Click OK.

To modify a named set with the command line

◆ Type the following at the command prompt:
haset -modify setname attribute value 

Configuring a custom view of the organization tree
and extended attributes

A custom view allows you to create a specialized view for a given set. Custom 
views can be used to organize objects under a set by filtering the view using 
organization units and extended attributes. 

View the custom view in the tree under the set name in the left pane of the 
console. The custom view displays the selected expressions in the order that 
they are listed in the custom view definition.

To configure a custom views using the VCS One console

1 In the VCS One console, click the Administration > Sets.

2 In the right pane, click the name of the set for which you wish to add a 
custom view. 

3 Click Configuration > Add Custom View.

4 Click Next.



670 Administering sets of objects
Deleting a custom view
5 Fill in the Add Custom View window text box with the following values:

6 Click OK > Close.

The custom view is presented in the form of a tree under the set name in the 
left pane of the console.

Deleting a custom view
When you delete a custom view, it is removed from the VCS One configuration.

To delete a custom view

1 In the VCS One console, click Administration > Sets.

Name Name of the custom view

Description Description of the custom view

Type Click one of the following choices:

Group: The custom view is associated with service groups.

System: The custom view is associated with systems.

Frame: The custom view is associated with frames.

OU: The custom view is associated with organization units

Extended Attributes
or
Organization Tree

The left table lists different text depended in the Type 
selected:

Group: The group extended attributes are listed

System: The system extended attributes are listed

Frame: The frame extended attributes are listed.

OU: The Organization Tree displays

Click the objects in the left table that you wish to have in your 
custom view.Click the right arrow to move the selections to the 
Selected Expression table.

Selected Expression Lists the selected expressions or organization units for the 
custom view.

To remove a selection, click the expression and click the left 
arrow.

The custom view displays the selected expressions in the 
order that they are listed in this table.

To move a selection higher in the table: Click the up arrow. 

To move a selection lower in the table: Click the down arrow.
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2 Click the name of the set for which you wish to delete a custom view. 

3 From the Custom Views defined table, check the custom view you wish to 
delete.

4 Click Configuration > Delete Custom View.

5 Click OK > Close.

Modifying a custom view
Use this procedure to make changes to an existing custom view.

To modify a custom view

1 In the VCS One console, click the Administration > Sets.

2 Click the link that is the name of the set for which you wish to modify a 
custom view. 

3 From the Custom Views defined window, find the name of the custom view 
you wish to modify under the Name column.

4 Click the pencil icon to edit.

5 Fill in the Modify Custom View window text box with the following values:

Name Name of the custom view. You may not modify this field.

Description Description of the custom view

Type Click one of the following choices:

Group: The custom view is associated with service groups.

System: The custom view is associated with systems.

Frame: The custom view is associated with frames.

OU: The custom view is associated with organization units

Extended Attributes
or
Organization Tree

The left table lists different text depended in the Type 
selected:

Group: The group extended attributes are listed

System: The system extended attributes are listed

Frame: The frame extended attributes are listed

OU: The Organization Tree displays

Click the objects in the left table that you wish to have in your 
custom view.Click the right arrow to move the selections to the 
Selected Expression table.
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6 Click OK > Close.

The custom view displays in the form of a tree under the set name in the left 
pane of the console.

Selected Expression Lists the selected expressions or organization units for the 
custom view.

To remove a selection, click the expression and click the left 
arrow.

The custom view displays the selected expressions in the 
order that they are listed in this table.

To move a selection higher in the table, click the up arrow. 

To move a selection lower in the table, click the down arrow.
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This section includes the following chapters:

■ “Administering the Policy Master service group” on page 675

■ “Administering the VCS One cluster configuration database” on page 683.

■ “Troubleshooting VCS One issues” on page 701.
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This chapter include the following topics:

■ About administering the Policy Master service group

■ About the Policy Master service group on UNIX

■ About the Policy Master service group on Windows

■ Monitoring the state of the Policy Master service group

■ Tuning attributes of the Policy Master service group on UNIX

■ Bringing the PMSG online

■ Taking the PMSG offline
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About administering the Policy Master service 
group

Some administration tasks require the Policy Master service group to be offline.

See “Taking the PMSG offline” on page 680.

You can configure notification to be sent if certain events happen to the Policy 
Master service group.

See “Policy Master events reference” on page 771.

Information regarding installation and uninstallation of the Policy Master 
service group is available.

See Veritas Cluster Server One Installation Guide.

About the Policy Master service group on UNIX
The resources in the policy master service group vary depending on whether 
you use Storage Foundation-based or NFS-based storage for the configuration 
database.

Table 29-1 describes the resources in Policy Master service group when the 
Policy Master uses Storage Foundation for storing configuration information.

Note: If you are using local-dir, the pmdg, pmvol, or pmmount resources may not 
exist. If you are using Network Appliance filer, the pmdg resource may not exist.

Table 29-1 PMSG resources when the Policy Master uses Storage Foundation

Resource Description

pmip Policy Master virtual IP address

pmnic Policy Master virtual IP NIC device

vcsonedb VCS One database

pm Policy Master daemon

vxss Symantec Product Authentication Service daemon

VCSOneWeb VCS One web console

pmdg The database and repository disk group

pmvol The volume for the file system containing the database
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Table 29-2 describes the resources in the Policy Master service group when the 
Policy Master uses NFS for storing configuration information.
.

About the Policy Master service group on Windows
Table 29-1 describes the resources in the Windows Policy Master service group.

Note: If you are using local-dir, the pmdgor pmvol resources may not exist. 

pmmount The file system mount point

Table 29-2 PMSG resources when the Policy Master uses NFS

Resource Description

pmip Policy Master virtual IP address

pmnic Policy Master virtual IP NIC device

vcsonedb VCS One database

pm Policy Master daemon

atd Symantec Product Authentication Service daemon

pmmount Mount point for the volume/qtree exported from NetApp filer 
when NFS is selected for shared storage

pmexport Exports and deports the volume/qtree on NetApp filer to active 
and passive Policy Master nodes, respectively

pmfiler Monitors ICMP connectivity between the Policy Master and the 
NetApp filer

VCSOneWeb VCS One web console

Table 29-1 PMSG resources when the Policy Master uses Storage Foundation

Resource Description

Table 29-3 PMSG resources on Windows Policy Master

Resource Description

pmip Policy Master virtual IP address

pmnic Policy Master virtual IP NIC device
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Monitoring the state of the Policy Master service 
group

The Policy Master service group has the following states:

■ ONLINE

The Policy Master service group is running as expected.

■ OFFLINE

The Policy Master service group is not running

■ UNKNOWN

The agent is not able to determine if the Policy Master process is running or 
not. For example, if insufficient memory is available, the Policy Master 
agent fails to function and declares an UNKNOWN state.

To monitor the state of the Policy Master agent using the command line

◆ Type the following command to display the status of the groups configured 
in the VCS Policy Master cluster. 

On UNIX:
/opt/VRTSvcs/bin/hagrp -state

On Windows:
%VCS_HOME%\bin\hagrp -state

◆ Type the following command to display the status of the resources 
configured in the VCS Policy Master cluster.

On UNIX:
/opt/VRTSvcs/bin/hares -state

On Windows:
%VCS_HOME%\bin\hares -state

vcsonedb VCS One database

pm Policy Master daemon

atd VCS One Product Authentication Service

VCSOneWeb VCS One web console

pmdg The disk group containing the database and repository

pmvol The volume for the file system containing the database

Table 29-3 PMSG resources on Windows Policy Master

Resource Description



679Administering the Policy Master service group
Tuning attributes of the Policy Master service group on UNIX
Tuning attributes of the Policy Master service group 
on UNIX

Depending on your configuration, you may decide to change the default values 
of the attributes of the Policy Master service group (PMSG).

Use the following information to determine whether you need to tune the 
attributes of resources in the Policy Master service group

Tuning the DetailMonitoring attribute of the Policy Master resource
The DetailMonitoring attribute determines the monitor type and frequency for 
the Policy Master resource in the PMSG. Detail monitoring is also called 
second-level monitoring.

In some cases, the Policy Master monitor action may not return in the allocated 
time configured in the MonitorTimeout interval. This may result in the agent 
declaring the Policy Master resource OFFLINE when it is not.

Tune this attribute to a higher number if you have monitor time out issues on 
the Policy Master resource. This may be caused by a VCS One cluster with 
thousands of resources, where the Policy Master system is heavily loaded. Or 
any reason that the Policy Master system has less capacity for processing.
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See “DetailMonitoring” on page 680. 

Bringing the PMSG online
The PMSG must be online in order for VCS One to manage your applications.

To bring the PMSG online using the command line

◆ Type the following command on UNIX
/opt/VRTSvcs/bin/hagrp -online -sys vcs_PM_cluster_system

◆ Type the following command on Windows
%VCS_HOME%\bin\hagrp -online -sys vcs_PM_cluster_system

Taking the PMSG offline

To take the PMSG offline using the command line

◆ Type the following command on UNIX
/opt/VRTSvcs/bin/hagrp -offline -sys vcs_PM_cluster_system

◆ Type the following command on Windows
%VCS_HOME%\bin\hagrp -offline -sys vcs_PM_cluster_system

Table 29-4

VCS One cluster 
Attribute

Description

DetailMonitoring Determines the monitor type and frequency for the Policy Master 
resource in the PMSG. Set the value with consideration to the 
system load. 

See “Tuning the DetailMonitoring attribute of the Policy Master 
resource” on page 679.

The following values are valid for this attribute:

0 – the agent checks if the Policy Master resource is running every 
monitor cycle.

N – where N is an integer, the agent checks if the Policy Master 
resource is running every monitor cycle. In addition, checks if the 
resource is responding every Nth monitor cycle using the 
hadebug -pingnw command.

Default value = 1

You may edit the value of this attribute using the haattr -modify 
command.
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This chapter includes the following topics:

■ About the VCS One configuration

■ About the configuration files

■ Starting the Policy Master in Cold mode on UNIX

■ Managing the configuration database

■ Backing up and restoring VCS One data
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About the VCS One configuration
VCS One maintains the VCS One cluster configuration information in a highly-
available configuration database. When VCS One is first installed, the database 
is created and initialized. At this point, the database is empty; it contains no VCS 
One cluster configuration. 

The database is populated with a VCS One cluster configuration when you:

■ Create VCS One cluster objects from the VCS One console (GUI)

■ Create VCS One cluster objects using commands from the command line 
interface (CLI)

■ Load a pre-existing configuration from XML files or a previous backup of a 
VCS One database

During VCS One cluster startup, the Policy Master obtains configuration 
information from the configuration database. When changes are made to the 
VCS One cluster configuration, they are stored in the database. You can back up 
the configuration database or export the database information to XML-
formatted files.

Exporting the configuration database to XML-formatted files can be a powerful 
tool when used along with the VCS One Simulator. The Simulator can be used to 
create and test a VCS One cluster configuration. Once the testing is complete 
with the Simulator, the configuration database can be exported to XML files. 
Those XML files can be loaded into an actual VCS One database. Similarly, you 
can export a live VCS One configuration database to XML-formatted files and 
import those XML files to the Simulator to test VCS One cluster operations.
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About the configuration files
The VCS One configuration is stored in a configuration database. The 
configuration database can not be edited directly, but you can import it from or 
export it to the following files:

main.xml Defines the instances of specific objects in the VCS One cluster, 
including the system, pframe, vframe, vobject, service group, and 
resource objects. The definable attributes for these instances come 
from the types.platform.xml, vcsone.xml, and vtypes.xml files.

vcsone.xml Defines the attributes for specific object types in the VCS One 
cluster, including the cluster, group, system, user, user group, and 
user role objects.

Note: Do not edit this file.

types.platform.xml Defines bundled Resource Types. Resource Types are a template 
that define a set of attributes and default values for controlling a 
resource object, such as Mount or NIC.

See “About the types file” on page 686.

The following files are examples of these files:

■ types.win.xml

■ types.hpux.xml

■ types.aix.xml

■ types.sun.xml

■ types.sunx86.xml

■ types.linux.xml

vtypes.xml Defines Virtualization Types. Virtualization Types are templates 
that define a set of attributes and default values for virtualization-
related objects, such as PFrames and VFrames.

See “Virtualization type attributes” on page 904.

AgentTypes.xml Defines Types specific to the agent Agent, such as OracleTypes.xml 
for the Oracle agent.

otherTypes.xml Used only with the Simulator.

orgtree.xml Defines the organization tree structure and extended attribute 
definitions in the configuration.

simuser.xml Used only with the Simulator.

ext/prefs.xml Defines the user preferences and custom views.

ext/bpa.xml Define the instances of business and notification rules, jobs, and 
automation settings.
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Location of the configuration files
In an actual VCS One installation, these files reside in the following directory:

$VCSONE_CONF/conf/confxml

On UNIX, the default path is:

/etc/VRTSvcsone/conf/confxml

On Windows, the default path is %VCSONE_HOME%\conf\confxml where 
%VCSONE_HOME% is the installation directory; the default installation 
directory is C:\Program Files\Veritas\Cluster Server One.

For the VCS One Simulator, the configuration files are located in the following 
directory:

installed_location\VCSOne\Simulator\conf

where installed_location is the location where the Simulator is installed.

If the Simulator is installed in the default location, the configuration files are 
located here:

C:\Documents and Settings\UserName\Desktop\VCSOne\

Simulator\conf

More information is available on how the configuration is used in the VCS One 
cluster.

See “How the Policy Master and the VCS One clients start up” on page 50.

More information is available on administration of the configuration.

See “Managing the configuration database” on page 689.

About the types file
The types.platform.xml file contains the types definition, which are used for the 
following functions:

■ To define the set of attributes that control that type of object.

■ To define the default values of each attribute.

■ To define the type of values that can be set for each attribute. 

In the DiskGroup example, the NumThreads and OnlineRetryLimit 
attributes are both classified as integer. The DiskGroup, StartVolumes, and 
StopVolumes attributes are defined as strings. In the IP example, the 
Address attribute is classified as string.

■ To define the parameters passed through the ArgList attribute. 

The line static str ArgList[] = { xxx, yyy, zzz } defines the order in which 
parameters are passed to the agents for starting, stopping, and monitoring 
resources. The sequence of arguments indicates the online command, the 
name of the resource, then the contents of the ArgList. Since MonitorOnly 
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is not set, it is passed as a null. This is always the order: command, resource 
name, ArgList.

The following text shows the correlation between the names of the type file and 
the name of the platform(s) represented.

Table 28-1 Platform-related type files and corresponding platform support

Type file Platform support

types.aix.xml AIX, AIX/RS6000

types.hpux.xml HPUX/IA64, HPUX/PA

types.linux.xml Linux, Linux/x86

RHEL and SLES

x86 and x86_64

types.sun.xml Solaris/sparc

types.sunx86.xml Solaris/x86 or Solaris/x64

types.win.xml Windows, Windows/x86, 
Windows/x86_64
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Starting the Policy Master in COLD mode on UNIX
In cold start mode, the Policy Master enforces the configuration in the 
configuration database, but does not enforce state information. The Policy 
Master probes all resources on all systems, determines their current state, and 
accepts that state as the correct state. Any existing GTQ entries are eliminated. 
This mode is used when you do not want to treat new state information as a 
fault.

See “Cold start up mode” on page 51.

Cold start mode is not available on a Windows Policy Master.

The procedure to start the Policy Master in COLD mode differs depending on the 
state of the Policy Master cluster.

To start the Policy Master in cold mode when the Policy Master cluster is 
down

1 Start the machine running the Policy Master service group (PMSG) in single-
user mode.

This is to avoid running VCS and to have the PMSG remain offline.

2 Edit the PM resource in the main.cf file in the Policy Master VCS cluster.

3 Use your favorite editor to set the Mode attribute to cold in the PM resource. 
The change appears similar to the following example:

PM PM_resource_name(
StartProgram = "/opt/VRTSvcsone/bin/vcsoned"
StopProgram = "/opt/VRTSvcsone/bin/hastop.bin -pm -block"
MonitorProcess = "/opt/VRTSvcsone/bin/vcsoned.bin"
Mode = "-cold"

4 Boot the machine running the PMSG to multi-user mode so that VCS and 
PMSG start up.

5 Optionally, type the following command to modify the Mode attribute back 
to normal using the VCS command line
haconf -makerw
hares -modify pm Mode ""
haconf -dump

To start the Policy Master in COLD mode when the Policy Master cluster is 
running but the Policy Master service group is in the OFFLINE state.

1 Type the following command to modify the Mode attribute of the PM 
resource to the value COLD.
hastart -pm -cold

2 Bring the PMSG online.

See “Bringing the PMSG online” on page 680.
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3 Optionally, type the following command to modify the Mode attribute back 
to normal using the VCS command line.
haconf -makerw
hares -modify pm Mode ""
haconf -dump

Managing the configuration database
To manage the configuration database, you perform administrative tasks on the 
database, such as start, clean, seed, and stop.

Note: Under most circumstances you will not need to manage the configuration 
database.

Starting the database
Starting the database starts the database processes. 

To start the database

◆ At the command prompt, type the following: 

hadb -up [-quiet|-verbose]

If you execute this command after the database has started, an information 
message is displayed, which states that the database is already started. 

Cleaning the database
Cleaning the database entails flushing the database. The best practice is to clean 
the database before loading the VCS One cluster configuration. Stop the Policy 
Master before cleaning the database. 

To clean the database

◆ At the command prompt, type the following:

hadb -cleandb [-quiet |-verbose]

You can also clean the database using the haconf utility before loading the VCS 
One cluster configuration into the database. 

More information is available about the hadb command. 

See the Veritas Cluster Server One Command Reference Guide.
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Caution: Use this command with care. Cleaning the database flushes the existing 
data and creates a blank database. 

Verifying the configuration
Verifying the database configuration involves validating the configuration 
information present in the XML files before loading it into the database, or 
validating the database itself.

To verify the configuration

◆ At the command prompt, type the following:

haconf -verify location of .xml config files

To verify the configuration after loading it into the database

◆ At the command prompt, type the following:

haconf -verify -db

Seeding the database using XML files
Seeding the database using XML files entails reading the configuration 
information stored in the XML files and writing it to the database.

Use this command if you have an XML backup of the database configuration 
which you want to load. Information about backing up the configuration 
database is available.

See “Backing up the VCS One configuration database” on page 694.

To seed the database using XML files

◆ At the command prompt, type the following:

hadb -loaddb [-quiet|-verbose]

The hadb utility reads the configuration information from the XML files 
located at $VCSONE_CONF/conf/confxml. You can also seed the database 
using the haconf utility. 

If you reload the Policy Master configuration database from saved XML files, 
and you have ESX servers in the configuration, the ESX Server systems will 
report an offline state when the Policy Master restarts. You must restart the 
client daemon on the ESX servers.

To restart the client daemon on the ESX Server systems:

1 In the VCS One console, click Manage > Virtualization.
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2 Click Show Management Consoles and ensure the Management console 
reports an online state.

3 Click Show Physical Hosts, and determine which systems report an offline 
state.

4 Log on to each physical host and restart the daemon using the 
hastart -client command

See the Veritas Cluster Server One Command Reference Guide.

Seeding the database using existing database files
Seeding the database using existing database files entails reading and using the 
configuration information stored in existing database files. These database files 
comprise the database file itself and the database transaction log files.

Use this command if you have a backup of the database configuration which you 
want to load. Information about backing up the configuration database is 
available.

See “Backing up the VCS One configuration database” on page 694.

To seed the database using existing database files 

◆ At the command prompt, type the following:

hadb -reloaddb db_file_dir [-quiet|-verbose]

Here, db_file_dir is the location of the existing database and transaction log 
files.

Stopping the database
Stopping the database stops the configuration database along with its processes. 
Ensure that you stop the Policy Master before stopping the database. 

To stop the database

◆ At the command prompt, type the following:

hadb -down [-quiet|-verbose]

If you execute this command after the database has stopped, an information 
message is displayed, which states that the database is already stopped. 

Restarting the database
Restarting the database stops and starts the configuration database. Ensure that 
you stop the Policy Master before restarting the database. 



692 Administering the VCS One cluster configuration database
Managing the configuration database
To restart the database

◆ At the command prompt, type the following:

hadb -restart [-quiet|-verbose]

Viewing the database status
Viewing the database status enables you to determine if the database is 
currently running or not running and if it is loaded or clean.

The database status command returns one of the following messages:

■ The database engine is not running. Start the database 

engine.

■ Database engine is RUNNING and configuration is not 

loaded.

■ Database engine is RUNNING and loaded with configuration 

/xxx/yyy/zzz

To view the database status

◆ At the command prompt, type the following:

hadb -status

Changing the database password
Change the database password using the hadb -dbpasswd command.

Then copy the odbc.ini file (located at /etc/VRTSvcsone/odbc.ini) to all 
the other Policy Master cluster nodes. For a Windows Policy Master, copy the 
odbc.dns file (located at %VCSONE_HOME%\VRTSvcsone\odbc.dns) to all 
the other Policy Master cluster nodes.

Caution: Initializing the database creates a blank database. 

To change the database password

◆ At the command prompt, type the following:

hadb -dbpasswd [-quiet | -verbose]
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Initializing the database

Caution: Use the database initialization command with extreme care. Under 
normal circumstances you will not need to initialize the database. One possible 
case when you might have to use this command is when the database is corrupt 
and you do not have a backup database.

When the database is initialized, VCS One creates a blank database (vcsone.db 
and vcsone.log) and resets the database password to its default value. After 
the database is initialized, if you want to change the database password, start 
the database. 

To start the database, use the hadb -up command. Change the database 
password using the hadb -dbpasswd command, and then copy the odbc.ini file 
(located at /etc/VRTSvcsone/odbc.ini) to all the other Policy Master 
cluster nodes.

The default database location on Windows computers is 
$VCSONE_HOME%\conf\db. 

where %VCSONE_HOME% is the installation directory; the default installation 
directory is C:\Program Files\Veritas\Cluster Server One.

For the VCS One Simulator instance using the default configuration, the 
database location is:

installed_location\VCSOne\Simulator\multisim\default\

conf\db\vcsone.db

where installed_location is the location where the Simulator is installed.

If the VCS One Simulator instance is installed in the default location, the 
database location is:

C:\Documents and Settings\UserName\Desktop\VCSOne\

Simulator\multisim\default\conf\db\vcsone.db

The database location for other Simulator instances that are not using the 
default configuration is:

installed_location\VCSOne\Simulator\multisim\

instance_name\conf\db\vcsone.db

To initialize the database

◆ At the command prompt, type the following:

hadb -initdb [-quiet|-verbose]
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Warning: Use this command with care. Initializing the database creates a blank 
database. 

Backing up and restoring VCS One data
Backing up and restoring VCS One data includes the following activities:

■ See “Backing up the VCS One configuration database” on page 694.

■ See “Restoring the VCS One configuration database” on page 696.

■ See “Backing up Symantec Product Authentication Service configuration 
information on UNIX” on page 697.

■ See “Restoring Symantec Product Authentication Service configuration 
information on UNIX” on page 698.

Backing up the VCS One configuration database
Backing up the database entails creating an additional, secondary copy of the 
entire database. Symantec highly recommends to periodically back up the 
configuration database using the online method.

You can back up the database in the following ways on UNIX:

■ Offline backup

Copy the database files vcsone.db and vcsone.log when the database server 
is not running. Also copy the /etc/VRTSvcsone/odbc.ini file. Symantec 
recommends that you back up the database using the online method instead 
of the offline method.

■ Online backup

Copy the database files when the database server is running. Online backup 
can be a “full” or an “incremental” backup.

See “Full and incremental backups” on page 695.

■ XML backup

Back up the database configuration to XML files.

See “XML backup” on page 695.

You can back up the database in the following ways on Windows:

■ Full and incremental backup

This can be done with the database server either online or offline. Symantec 
recommends that you back up the database using the online method instead 
of the offline method.

See “Full and incremental backups” on page 695.
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■ XML backup

Back up the database configuration to XML files.

See “XML backup” on page 695.

XML backup
An XML backup involves backing up the database configuration to XML files. 
You can read and edit the XML files before using them to restore the database 
configuration. Refer to the documentation for the hadb and haconf utilities in 
the Veritas Cluster Server One Command Reference Guide.

To back up the database to XML files

◆ At the command prompt, type the following: 

haconf -dbtoxml backup_dir [-quiet|-verbose]

Here, backup_dir is the location where the backed-up XML files are created.

Full and incremental backups
A full backup is an online backup that backs up the entire database, that is, all 
database files and transaction log files. Restoring from such backups is easier 
and quicker as it involves restoring all the backed up files. However, backing up 
the entire database can take a lot of storage.

Incremental backup is also an online backup that backs up only the transaction 
log files. As a result, an incremental backup must be preceded by a full backup. 
The time taken to restore from an incremental backup depends on the time since 
the last full backup.

Both full and incremental backups have their advantages. Hence, Symantec 
recommends using both the options to intelligently back up your configuration 
database. For example, you could do a full backup once a week and backup the 
transaction log files during the week.

Restoring the database involves restoring or retrieving data from a previously 
backed up database.

See “Restoring the VCS One configuration database” on page 696.

To back up the database using the VCS One console:

1 In the VCS One console, click Administration > Global Settings.

2 Click Configuration > Back up Database. 

To back up the database from the command line:

◆ At the command prompt, type the following: 
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haadmin -backup -db fullpathname_backup_dir

Here, fullpathname_backup_dir is the location where the backed up 
database and transaction log files are created.

To perform an incremental database backup

◆ At the command prompt, type the following:

haadmin -backup -db -incremental fullpathname_backup_dir

Here, fullpathname_backup_dir is the location where the backed up 
database and transaction log files are created. 

You can perform an incremental database backup only after performing a 
full database backup.

Restoring the VCS One configuration database 
Restoring the database involves restoring or retrieving data from a previously 
backed-up database. Restoring from the database using the online method is 
faster than restoring from the XML configuration.

Ensure that the pm resource (Policy Master daemon) is offline.

Restoring from the database
Before you restore the database, please ensure that the pm resource (Policy 
Master daemon) and vcsonedb resource (VCS One database) are both offline. 

To restore the database

◆ At the command prompt, type the following:

haadmin -restore -db fullpathname_backup_dir

Here, fullpathname_backup_dir is the location of the backed up database 
and transaction log files from which data is restored.

Symantec recommends that you perform a full database backup to a 
different directory, after successfully restoring it.

Restoring from the XML backup
Before you load a configuration from XML, the cluster must have the 
ClusterName attribute defined. To define the ClusterName attribute, add a 
<cluster> tag definition in the main.xml file. 

The following text is an example ClusterName definition from the main.xml file.
<cluster name="Test_Farm">
<attributes>
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<attribute name="DefaultPlatform"><scalar>linux/x86</scalar>
</attribute>

</attributes>
</cluster>

To restore the database from the XML backup

◆ At the command prompt, type the following:

haconf -loaddb [-force] backup_dir

Here, backup_dir is the location where the backed-up XML files are stored.

Backing up Symantec Product Authentication Service configuration 
information on UNIX

You can back up the Symantec Product Authentication Service (AT) 
configuration information and data using the haadmin command. Backing up 
the AT configuration information entails creating a second copy of the 
configuration information.

On the Windows Policy Master, the service is named Veritas Cluster Server One 
Product Authentication Service and the procedure is slightly different.

See“Backing up and restoring the VCS One Product Authentication Service 
configuration on Windows” on page 698.

Back up the authentication configuration information from the active Policy 
Master system. The active Policy Master system is the one that has the Policy 
Master service group online.

In the event of a Policy Master cluster failure, you can use the backup to restore 
the security information to the last known good state. 

To back up authentication configuration information

1 Ensure that the vcsoneatd process is up and running.

2 Back up the authentication configuration information. At the command 
prompt, enter the following command:
# /opt/VRTSvcsone/bin/haadmin -backup -vss backup_directory_name

This command creates a compressed backup file called 
vcsone_vxssbackup.tar that contains the authentication service 
configuration information and data. If a file named vcsone_vxssbackup.tar 
already exists, it is renamed with the suffix .old.
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Restoring Symantec Product Authentication Service configuration 
information on UNIX

You can restore Symantec Product Authentication Service (AT) configuration 
information using the haadmin command. The restore operation enables you to 
retrieve and reconstruct the VCS One authentication configuration information 
from the backup.

The backup and restore directory structure of the mount point should be the 
same.

Restore the authentication configuration to the active Policy Master cluster 
system. The active Policy Master system is the one that has the Policy Master 
service group online.

To restore the authentication configuration information

1 Enter the following command on the active Policy Master node to stop the 
authentication daemon, vcsoneatd. 
# /opt/VRTSvcsone/bin/hares -offline atd 

2 Ensure that the shared storage is mounted. Use the mount point that you 
specified during the Policy Master installation. 

3 Restore the authentication configuration information that was backed up 
earlier. At the command prompt, enter the following command: 
# /opt/VRTSvcsone/bin/haadmin -restore -vss \
backup_directory_name

4 Start the vcsoneatd process. At the command prompt, enter the following 
command:
# /opt/VRTSvcsone/bin/vcsoneatd

Backing up and restoring the VCS One Product Authentication 
Service configuration on Windows

You should back up the authentication service configuration. If one of the Policy 
Master systems is lost, you can use the backup directory to replace the faulted 
system and restore the authentication service configuration. It is time-
consuming to manually recreate the configuration.

To back up the VCS One Product Authentication Service configuration 

1 Determine where to back up the Policy Master cluster authentication 
information. Choose a safe location, such as a removable storage device. 
Avoid backing up to the system (C:) drive since a system crash can make the 
backup data unavailable.

2 Back up the configuration. Enter the following:
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%VCSONE_HOME%\bin\haadmin -backup -vss 
full_path_to_backup_directory

The command creates a directory with the information necessary to restore 
the authentication configuration if a Policy Master cluster system fails.

To restore the VCS One Product Authentication Service configuration 

1 Locate the backup directory.

2 Mount the shared storage where the configuration storage will be restored.

3 Restore the authentication configuration. Enter the following:
%VCSONE_HOME%\bin\haadmin -restore -vss 
full_path_to_backup_directory

The haadmin utility correctly places the files on the new system.
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This chapter includes the following topics:

■ About VCS One log messages

■ Troubleshooting VCS One issues

■ Troubleshooting Simulator issues

■ Troubleshooting VCS One global cluster issues

■ Troubleshooting authentication issues

■ About the hagetcf utility on UNIX

■ About the hagetcf utility on Windows

■ About Symantec Technical Support
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About VCS One log messages
The Policy Master and client system logs provide messages that can help with 
the following tasks:

■ Monitor the health of the VCS One cluster

■ Track the events and operations of the VCS One cluster 

■ Troubleshoot issues

Adding custom log messages to the log file
In addition to the logs that VCS One generates, a user with 
ServerFarmAdministrator privileges may add messages to the log file with the 
halog command. 

Adding a manual entry allows the log file to be used as an administrative 
notebook to add more context to the log files as well as a reminder of actions 
performed.

To add a custom log message to the log file using the command line

◆ Type the following command
halog -add “log message” -sev C | E | W | N | I [-sys system]

Use the following information to replace the appropriate variables and 
option:

For example, the following command could log a maintenance action:
halog -add “replace NIC card on system systemname.” -sev N

log message The text of the message you want to appear in the logs. Note the 
message must begin and end with a double quotation mark.

sev Adds a message of a specified severity to the log file.

The severity values C, E, W, N, and I have the following significance: C 
= Critical E = Error W = Warning N = Notice, I = Information

system Specifies the system. The user must have Modify System privileges 
or system administrator privileges to use this option.
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Policy Master logs
Log messages are generated on the Policy Master by the Policy Master daemon, 
VCS One console, and VCS One commands.

Log messages generated on the Policy Master daemon are saved in the 
engine_A.log file. On Unix, this log file is located in the /var/VRTSvcsone/
log/ directory. (Also the $VCSOne_Log directory.) On Windows, the log 
directory is %VCSONE_HOME%\log where %VCSONE_HOME%\is the VCS One 
installation directory; the default is C:\Program Files \Veritas\Cluster 
Server One. You can view the policy master logs in the VCS One console from 
the Logs tab.

See “Logs menu options” on page 185.

The size of the engine_A.log file can be specified using the cluster’s LogSize 
attribute and cannot exceed 33 MB (33554432 bytes). If the log file exceeds the 
specified maximum value, the existing engine_A.log file is renamed to 
engine_B.log, and a new engine_A.log file is created. The most recent log 
messages are recorded in the new engine_A.log file. VCS One maintains three 
engine log files, engine_A.log, engine_B.log, and engine_C.log. The engine_A.log 
file contains the most recent log messages while the engine_C.log file contains 
the oldest log messages. Unauthorized access attempts are not logged in the 
engine logs.

Log messages generated by the VCS One management console are saved in the 
log files that start with the name vcsonems-. These log files are located in the 
/var/VRTSvcsone/log/directory on Unix, %VCSONE_HOME%\log on 
Windows.

Error messages generated by VCS One commands are saved in the stderr file. 
These messages are also recorded in the engine_A.log file and are displayed in 
the Logs tab of the VCS One console.

VCS One log messages are structured in such a way so as to enable easy 
troubleshooting. Additional information about how to interpret the log 
messages is available.

See “Interpreting VCS One log messages” on page 708.

VCS One client logs
Log messages are generated on the VCS One client systems by the VCS One 
client daemon (vcsoneclientd) and resource agents. You cannot view client log 
entries from the VCS One console.

Log messages that are generated by the VCS One client daemon are saved in the 
vcsoneclientd file. This file is located in: 
/var/VRTSvcsone/log/vcsoneclientd_A.log
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Log messages generated by the agents are saved in the agent_name_A.log file. 
This file is located in:

/var/VRTSvcsone/log/agent_A.log

On Windows, log files are located in o%VCSONE_HOME%\log.

Simulator logs
Log messages generated by the VCS One Simulator are saved in the following 
files: 

■ On Windows computers, if the Simulator is installed in the default location, 
the Simulator log messages are saved in the vcsonesim_A.txt file. 

This file is located in the following location:
C:\Documents and Settings\UserName\Desktop\VCSOne\

Simulator\multisim\instance_name\log\vcsonesim_A.txt

where instance_name is the name of the Simulator instance whose log 
files you are searching. In case of the default instance, replace 
instance_name with “default”.

If the Simulator is installed in a different location, the log messages are 
saved in the following location:

installed_path\VCSOne\Simulator\multisim\instance_name\

log\vcsonesim_A.txt

where installed_path is the location where the Simulator is installed.

You can also view the Simulator log files by using the Simulator Launch 
Pad. To view the log files for a particular instance, on the Simulator Launch 
Pad, click the instance name, then click Advanced, and then select View 
Simulator Log.

Symantec Web server logs
The Symantec Web server must be installed on the same system as the Policy 
Master. 

You can not view web server log entries from the VCS One console. Log files 
generated by the Symantec Web server are located in the following directory: 

To set the log level for the Web Server to maximum logging (verbose mode) 

◆ Type the following command in the URL bar of the browser.
https://ipaddress:14171/LoggerAdmin.do?logLevel=TRACE5
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Use the following information to replace the appropriate variable

■ On Linux computers, the log files are located at /var/VRTSweb/log/. 

■ On Windows computers, the log files are located at C:\Program 
Files\Veritas\VRTSweb\log.

Turning on Symantec Product Authentication Service logs
The Symantec Product Authentication Service (AT) logs report information 
about the authentication service. AT manages secure communications between 
the Policy Master and the client nodes.

To turn on the authentication logs

◆ Type the following command
# /opt/VRTSvcsone/bin/haat setloglevel -l 0|1|2|3|4 \
[-f log_file_name]

Use the following information to choose the log level and indicate the name 
of the file for client-side log messages

ipaddress The IP address of the host where the Web server is running. This is also 
the host where the Policy Master service group is online.

0|1|2|3|4 To indicate the level of detail of the authentication logs, 
specify a number from 0 to 4. The higher the number, the 
greater the level of detail. 

Client-side logging has 5 log levels. By default, the client-
side log level is 0 (no logging).

Server-side logging has 4 log levels. By default, the server-
side log level is 1.

The following log levels exist:

■ Log level 0 does not log anything in the log files.

■ Log level 1 logs only critical error messages that 
require administrator attention.

■ Log level 2 logs all errors.

■ Log level 3 logs all errors and warnings.

■ Log level 4 logs everything, including trace messages.
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Viewing logs from commands generated by the VCS One console 
Log files generated by modules such as BPA and VALD are located as follows: 

■ On Linux computers, the log files are located at /var/VRTSvcsone/log/. 

■ On Windows computers, the log files are located at %VCSONE_HOME%\log.

About logs generated from events
Event logs are associated with Business Policy Automation (BPA). The list of 
events that generate logs is available.

See Table 32-1, “VCS One Cluster level events and associated parameters,” on 
page 771.  

When an event is missed because the BPA scheduler is down, they will be logged 
as ‘Missed events.”

Viewing an event’s details
View the details page of an event to view more information about the event, 
including event parameters and recent rule executions. 

To view an event’s details

1 In the VCS One console, click Logs > Event Logs.

2 In the right pane, from the Event Name column, click the name of the event.

About logs generated from rules
Rule execution logs are associated with Business Policy Automation (BPA). Logs 
generated from rules can be either from a business rule or from a notification 
rule.

By default, business log rules display in the console. To view notification rule 
logs, click the drop-down arrow and select from the list.

-f log_file_name Specify the -f option for client-side logging and indicate 
the name of the file to store the client-side log messages. 
When the log file size reaches the maximum, the file is 
moved to filename.1, filename.2, filename.3, filename.4, 
and filename.5.
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Deleting event and rule log entries
You delete log entries based on a date and time boundary. You can not filter the 
view to delete only subset of entries within the boundary you provide.

To delete log entries

1 In the VCS One console, click one of the following options, depending on 
which entries to delete.

2 Click Configuration > Purge Logs.

3 Specify the date and time to delineate the boundary of the purge.

All the event logs, job logs, and rule logs that are older than the specified 
date will be deleted.

4 Click OK.

Deleting job log entries
Use this procedure to purge the logs of a specific job. You may also delete logs of 
events and rules.

See “Deleting event and rule log entries” on page 707.

To delete log entries

1 In the VCS One console, click Manage > Jobs.

2 In the right pane, click the link of the job for which you wish to delete the 
logs to go to the job details page.

3 Click Operations > Purge Job Logs.

4 Specify the date and time to delineate the boundary of the purge.

All the job logs that are older than the specified date will be deleted.

5 Click OK.

About the first failure data capture (FFDC) log
The first failure data capture (FFDC) log is enabled by default, and contains the 
most recent 1024 debug logs. This log supplements the system log files with 

Click Logs > Event Logs To delete log entries generated from 
Policy Master events

Click Logs > Rule Execution Logs To delete log entries generated by 
business policy automation rules.
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debug data that may be useful in debugging a Policy Master daemon, vcsoned, 
and the client system daemon, vcsoneclientd, daemon crash.

The FFDC log can be enabled at the system level or the VCS One cluster level.

See “EnableFFDC” on page 842.

To enable the first failure data capture log from the VCS One console

1 In the VCS One console, click Administration > Global Settings.

2 In the right pane, click the pencil icon next to the EnableFFDC attribute.

3 Edit the value of the attribute.

4 Click OK > Close.

Interpreting VCS One log messages
A typical VCS One log message resembles the following:

2007-02-12 13:38:40 VCS One NOTICE V-97-1-10323 Policy Master 
changed state from LOCAL_BUILD to RUNNING

Each log message consists of the following information: 

Item Description Example

Time-stamp Displays the year, month, date, 
and time the log message was 
generated. 

2007-02-12 13:38:40

Mnemonic string Displays the name of the product 
for which the log message was 
generated. 

VCSone

Message severity Displays the severity level 
associated with the log message. 
Severity levels can be classified as 
Critical, Error, Warning, Notice, 
and Information.

NOTICE

Unique message 
identifier (UMI)

Displays the unique message 
identifier code, which comprises 
four parts. The last part of this 
code is the message number. 

V-97-1-10323
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Message text Displays the actual message text. 
The message text for agents is 
preceded by a header, which 
consists of 
name_of_agent:name_of_resource:
entry point. 

Policy Master changed 

state from LOCAL_BUILD 

to RUNNING

Message text for agents:

FileOnOff:MyFile:online

:Resource could not be 

brought up because the 

attempt to create the 

file (/tmp/MyFile) 

failed with error (Is a 

Directory)

Item Description Example
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Troubleshooting VCS One issues
This section describes common VCS One issues and their resolution.

Displaying the version of the client binaries
Some troubleshooting tasks may require you to investigate the version of the 
client-related binaries that are installed on a system or PFrame.

This command is not available through the GUI.

To display the version of the client-related binaries on an object from the 
command line

◆ For systems, type the following command:
hasys -clientversion system(s)

◆ For PFrames, type the following command:
hapframe -display pframe(s) -attribute version

Use the following information to replace the appropriate variables:

State of VMware Virtual Center is UNKNOWN or FAULTED

The VMwareVC object in the configuration has a state of UNKNOWN or FAULTED. 
This can happen when the password that VCS One uses to log in to the VMware 
vCenter Server changes, and needs to be updated in the VCS One configuration.

Workaround
Update the password in the VCS One configuration.

See Configuring VCS One to discover the VMWare vCenter Server environment

Using the Simulator to reproduce issues
In the Simulator configuration you can induce faults and view the resulting 
behavior to create and fine-tune the VCS One cluster configuration without 
using a production environment. The simulated configuration can then be 
imported into your production environment.

You may also import your production environment into the Simulator to 
reproduce an environment for testing or educational purposes. This is done by 
using the database configuration information imported from an actual running 
VCS One cluster. 

system(s) List of one or more systems.

pframe(s) List of one or more pframes
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See “How to use the Simulator to duplicate your live installation” on page 711.

You may use the Simulator to regenerate an environment using the database 
configuration information imported from an actual running VCS One cluster. 

Multiple Simulator start up modes are available to tune the preciseness of the 
simulation.

See “About the Simulator” on page 204.

How to use the Simulator to duplicate your live installation
Use these steps to save the configuration database and reload it into a system. 
You can use this procedure for diagnostic purposes, or to load a configuration 
from an actual VCS One cluster into a Simulator.

1 Back up the configuration with the following command
haadmin -backup -db <backup-dir-location>

2 Copy the database from the backup-dir-location to the test system at new-
backup-dir-location.

3 Copy the database to the new directory
haadmin -restore -db new-backup-dir-location

4 Choose the appropriate start up mode for the Simulator.

See “About the Simulator’s start-up modes” on page 207.

5 Do one of the following tasks:

To start the Simulator in Basic mode using the command line

◆ hasim -start

To start the Simulator in Extended mode using the command line

◆ hasim -start - extended

To start the Simulator in Extended and No Operation mode using the 
command line

◆ hasim -start -extended -no_operation

About disabled menu items
A menu item is disabled, in which it is greyed out and not selectable, if you do 
not have the correct privileges to perform the action.

See “About administering users and roles” on page 646.

A menu item may be enabled but may not complete if the operation is not valid 
for the current state of the object. Check the error generated or the log file for 
more information on why an operation did not complete.
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CLI commands appear unresponsive
CLI commands can sometimes appear unresponsive if the socket connection 
uses a virtual IP configured on the client node as its source IP. The socket 
connection created by CLI commands can use a virtual IP configured on the 
client node as its source IP. Doing so creates an issue if the virtual IP is brought 
down when there is an ongoing connection.

Since the virtual IP is no longer available in this situation, the CLI does not 
receive any further communication with the Policy Master and becomes 
unresponsive indefinitely. This issue can also arise if the virtual IP is already 
plumbed before starting vcsoneclientd. Because vcsoneclientd uses the virtual 
IP as the source IP, it will not receive any Policy Master responses when the 
virtual IP is brought down.

Workaround
Specify a local IP address on the client node as the source IP to bind to while 
connecting to the Policy Master on an IP address specified in vcsone.conf. Doing 
so prevents the socket connection from using the virtual IP as the source IP.

1 Specify the optional source IP for a given Policy Master IP in vcsone.conf as 
follows:
PM_IPS=[pm_ip]:port:[src_ip]

or
PM_IPS=[pm_ip]:port:src_ip

Each PM_IPS record can have an additional source IP separated 
by a colon ( : ).

2 Even if the port is not specified (but a source IP is specified), indicate the 
port with an empty port (port) field:
PM_IPS=[pm_ip]::[src_ip]

Do not use blank spaces in any of the three fields.

Specify the source IP (src_ip) the same way you would specify the Policy 
Master IP. That is, enclose the IP in square brackets [ ] to indicate an IPv6 
IP.

The Search tab does not display
The Search tab does not display if the WebserverSubsystems attribute is edited 
to remove the SEARCH subsystem. You can check the value of the 
WebserverSubsystems attribute from the Global Settings page.

See “Settings operations” on page 198.

More information is available about the WebserverSubsystems attribute.

See “WebserverSubsystems” on page 830.
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Tuning the Policy Master to use a higher number of file descriptors 
on UNIX

Each operating system that supports the Policy Master has a default maximum 
limit for the number of file descriptors that can be used per process. 

Table 29-1 shows these default limits.

If you would like to connect a large number of client systems to the Policy 
Master, you may need to increase the default limit for the number of file 
descriptors to allow the Policy Master to accept more connections.

If a large number of clients are connected to the Policy Master and you have not 
increased the limit for the number of file descriptors, commands may not be 
able to connect to the Policy Master to provide status and configuration 
functionality.

On Solaris, increase the maximum limit for the number of file descriptors if you 
would like to connect more than 128 client systems to the Policy Master. 

On Linux, the default limit for the number of file descriptors should be 
sufficient. If a large number of clients are connected and commands are not 
responding, however, increase the value.

To tune the Policy Master to use a higher number of file descriptors

1 Open the /opt/VRTSvcsone/bin/vcsoneenv file in a text editor.

2 Add the following line at the beginning of the vcsoneenv file:
path_to_ulimit/ulimit -n 8192

3 Restart the Policy Master:
hastop -pm
hastart -pm

ha- commands run slowly when NIS or LDAP is unavailable
VCS One commands that begin with “ha” may run slowly when nis or ldap is 
specified as the database source in /etc/nsswitch.conf, and an NIS or a LDAP 
server is unavailable.

Table 29-1 Default limit for the number of file descriptors

Operating system Default limit for 
the number of file 

descriptors

Solaris 256

Linux 1024
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State of service group is UNKNOWN

Delete the Project or Zone resource in a service group before setting the 
ContainerInfo:Enabled =0, otherwise, the state of the service group will be 
reported as UNKNOWN. 

Workaround: Remove the resource using the command line or the VCS One 
console.

To remove the resource using the command line:

1 Delete the resource:
# hares -delete resource_name

2 Change the Service Group’s ContainerInfo:Enabled attribute to 0:
# hagrp -modify sg_name ContainerInfo -update Enabled 0

To remove the resource using the VCS One console:

1 Delete the resource.

2 Change the Service Group’s ContainerInfo:Enabled attribute to 0.

State of service group is incorrect
If a resource goes into UNKNOWN state because the agent is not able to probe the 
resource then the service group state will not change to reflect the UNKNOWN 
state of resource. 

The service group will maintain its previous state. 

Faulted resource state not reflected in service group state
If ResFaultPolicy of a resource is set to FaultHold, then the faulted state of the 
resource is not reflected in the state of service group. 

In this case, the service group has one of the following states:

■ PARTIAL if there are other OnOff type resources that are online 

■ OFFLINE in all other cases

Duplicate TCP line messages

Description
On Red Hat Linux computers, when a TCP connection is rapidly shutting down 
and attempting to re-connect using the same address and port pair, the 
following messages are displayed:
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tcp 0 0 X.X.X.X:80 X.X.X.X:1035 TIME_WAIT
tcp 0 0 X.X.X.X:80 X.X.X.X:2028 TIME_WAIT
warning, got duplicate tcp line
warning, got duplicate tcp line

These messages do not impact or have an adverse effect on VCS One 
performance. 

More information is available about this issue. 

Refer to the Red Hat Linux documentation or the Knowledge Base article located 
at http://kbase.redhat.com/faq/FAQ_80_6180.shtm.

Resolution

To suppress duplicate messages

1 In the sysctl.conf file, located at /etc/sysctl.conf, change the 
following kernel parameter values: 

■ tcp_tw_recycle = 0

■ tcp_tw_resuse = 0

2 Apply the changes. At the command prompt, type the following:

sysctl -p 

VCS One client does not connect to Policy Master 

Description
The Symantec Product Authentication Service may reject connections between 
the Policy Master system and the VCS One client system, if the time differential 
between them is more than 30 minutes. The following error message is 
displayed: 

VCSone ERROR V-97-19-12358 Failed to obtain the credential from 
Local cache, please ensure that the System credential is 
deployed on the node and the System does not lag behind the PM 
node.

Resolution
Use the NTP utility to correct or modify the time settings on the VCS One client 
system and Policy Master system, such that the time differential between the 
systems does not exceed 30 minutes.

http://kbase.redhat.com/faq/FAQ_80_6180.shtm.
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Policy Master service group stuck in PARTIAL state

Description
The Policy Master service group can get stuck in the PARTIAL state and cannot be 
brought online. 

Resolution
Use the hastart command to bring the Policy Master service group online. 

◆ At the command prompt, type the following:

hastart -cluster -sys system 

Here, system is the name of the active Policy Master cluster node. 

Increasing LogFileSize generates error 

Description
Agents create a log file when they write the first log message to the log file. If 
you start VCS One and increase the value of LogFileSize attribute (resource 
type), before the agent creates the log file, the following message appears in the 
place of each log message entry. 

Log File Pointer is NULL

In other words, whenever the agent attempts to write a log message entry to the 
log file, the log message entry is replaced by this message. This problem does 
not occur if you decrease the LogFileSize attribute value.

Resolution 

To resolve this issue, perform the following steps:

1 Decrease the LogFileSize attribute value to a value, which is lower than the 
default value. 

2 On the Policy Master cluster system, modify the LogDbg attribute to enable 
debug logging. This causes the agent to generate a log message and create a 
log file. When the agent writes the first log message it creates a log file.

3 After the agent writes the first log message, change the LogDbg attribute 
value to the default value. The default value is no debug logging.
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Negative values not displayed in the Workload section 

Description
VCS One brings resources in a service group online by using the hagrp 
command. If the resources are brought online manually using the hares 
command, the statistics and graphical representations displayed in the 
Advanced Workload Management (AWM) or Workload view, may not be 
accurate. 

For example, if you bring a service group online manually on a system where 
another service group is already online and uses all or most of the system’s 
capacity, the AWM view does not display the system’s available capacity as a 
negative value. 

Resolution 
Before you manually bring the resources in a service group online, ensure that 
the system’s existing available capacity can accommodate the service group 
online operation. 

User gets unexpectedly logged out from the VCS One console

Description
A user that is currently logged in to the VCS One console will get logged off 
when that user is deleted from the VCS One configuration. In the following 
conditions, the user may log back in again and continue to use VCS One:

■ The user has the same name as a user with root-level permissions of any 
system in the Policy Master cluster.

■ The user is part of a user group that remains in the VCS One configuration.

Resolution 
Log in again to the VCS One console, if you continue to have appropriate 
permissions. 

Small fonts displayed in Flash components 

Description
The VCS One Flash components appear in small fonts due to a Web browser 
plug-in issue. This occurs when the Mozilla Firefox Web browser is used on 
Linux computers. Firefox uses GTK fonts. If these fonts are not available, Firefox 
uses KDE or any other available fonts, which might result in small or un-
initialized fonts.        
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Resolution 
Download and install the gtk2-engines-gtk-qt package. After you install this 
package, GTK styles and fonts are available for use in KDE's Control Center. You 
need to install the required plug-in files (.so files) in the ~/.mozilla/
plugins folder, so that Firefox can use these fonts. 

Organization Tree and Extended Attributes views not click-able 

Description
After you expand and collapse the Organization Tree or the Extended Attributes 
tree views, you cannot use the mouse pointer to select a tree node. This problem 
occurs only when the VCS One console is launched using the Firefox Web 
browser on Linux computers. A Firefox and Macromedia Flash plug-in issue 
causes this behavior. 

The add and move wizards for service groups, systems, and users along with the 
add custom view wizard display this behavior.

Resolution
You may navigate to the nodes in the organization tree using one of the 
following methods:

■ Use the LEFT ARROW and RIGHT ARROW keys to expand and collapse the 
tree views. Use the UP ARROW and DOWN ARROW keys to transverse the 
nodes of the tree.

■ Click Next to move to the next panel, and immediately click Back to return to 
the panel. You may now click on the organization tree nodes.

Summary and Workload sections not automatically refreshed 

Description
Sometimes, console pages might not display up-to-date VCS One cluster 
information. Console pages display VCS One cluster details graphically using 
Macromedia Flash components which continuously poll the Symantec Web 
server for updates. 

Resolution 
Use the refresh option provided in the Web browser to manually refresh these 
pages. 
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Web browser crashes while performing AWM tasks

Description
Sometimes, the Web browser might crash while performing operations in the 
Advanced Workload Management (AWM) or Workload view. This happens if you 
are using Macromedia Flash version 8 or later as the Web browser plug-in. 

Resolution 
None.

Views containing Flash content take a long time to load

Description
Sometimes, the Web browser might take a long time to load views containing 
Flash content, such as the AWM view. An Adobe Flash Player pop-up window 
appears, which contains a confirmation message about whether you want to 
abort the script.

Some of the views that contain Flash content include the Advanced Workload 
Management (AWM) or Workload view, the Resource dependency view, the 
Group dependency view, and the Map view. 

Resolution
In the Adobe Flash Player pop-up window, clicking Yes multiple times might 
solve the issue.

I/O fencing on client system appears to fail

Description
In certain cases, I/O fenced Linux client systems may appear to successfully 
block writes, which are buffered before they are written to the shared disk. 

Resolution 
Choose to write to the corresponding raw device. Writes that are properly I/O 
fenced are reported immediately. 

More information is available about the raw command. 

Refer to Linux documentation.
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Console displays an unexpected error message 

Description
If you are using the Mozilla Firefox Web browser, the following error message 
may be displayed in the VCS One console. 

System_name has received an incorrect or unexpected message. 
Error Code: 12227. 

This message is generated by the Web browser when the Secure Sockets Layer 
(SSL) handshake fails between the Web browser and the Symantec Web server. 
The SSL handshake fails when the client-side SSL certificates are not present in 
the Web browser, or if client-side SSL certificates are present but contain 
incorrect information. Note that this is not an VCS One error message. 

Resolution 
Ensure that the required client-side SSL certificates are present in the Web 
browser and the certificates contain valid information.

Loading XML configuration into the database fails 

Description
If you try to load XML configuration into the database using the haconf –loaddb 
command, while the Policy Master daemon is up-and-running, the operation 
fails. The following error message is displayed: 

VCS One ERROR V-97-1-17433 Cannot initiate this action because 
the Policy Master or another instance of haconf may be running.

Resolution 
To resolve this issue, perform the following steps in the order presented:

1 Stop the Policy Master daemon; take the Policy Master resource offline. At 
the command prompt, type the following:
hastop -pm

2 Clean the configuration database. At the command prompt, type the 
following:
haconf -cleandb

3 Load the XML configuration into the database. At the command prompt, 
type the following: 
haconf –loaddb

4 Start the Policy Master daemon; bring the Policy Master resource online. At 
the command prompt, type the following: 
hastart -pm
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Service group will not go offline

Description
If a parent resource will not go offline until a child resource is forcefully brought 
offline, VCS One will not be able to offline the service group.

Resolution 
To resolve this issue, perform the following steps in the order presented:

1 Type the following comment to flush any actions for the service group.
hagrp –flush –action group -sys system

2 Type the following command to take the child resource offline.
hagrp -offline -ignoreparent child_resource -sys system

Resource stuck in the unable to offline state

Description
A resource can get stuck in the UNABLE TO OFFLINE state. The resource cannot be 
brought online or taken offline when it is in the UNABLE TO OFFLINE state. In such 
a situation, if you execute the hagrp –flush command, the state of the resource 
changes from UNABLE TO OFFLINE to WAITING TO GO OFFLINE. The Policy Master 
does not attempt to take the resource offline and the resource is stuck in the 
WAITING TO GO OFFLINE state.

Resolution
To resolve this issue, do one of the following: 

■ For an off-host resource that is currently in the UNABLE TO OFFLINE state, you 
need to take its control group offline, and then bring the control group 
online again. After the control group is brought online, the Policy Master 
attempts to take the off-host resource offline. If the Policy Master still 
cannot take the off-host resource offline, you need to take the resource 
offline, outside VCS One control. 

■ For resources that are not off-host resources, you need to take the resource 
offline, outside VCS One control. 

A rule does not execute
When a rule becomes invalid, it no longer executes.

Resolution
Check that one of the following criteria is in effect. Any one of these criteria may 
make a rule invalid:
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■ An object referenced by the rule has been deleted.

■ An object reference by the rule has moved in the organization tree such that 
it is no longer in the user’s policy node.

■ An object referenced by the rule has moved out side of the job’s organization 
unit.

■ A user privilege on a referenced object got revoked.

■ The owner of the rule has been disabled or deleted.

VCS One ha- commands do not work in a WPAR

Resolution
Verify your VCS One credentials. Make sure the password is not changed. 

Verify the AT certificate is not expired.

Resource does not come online in the WPAR

Resolution

■ Verify VCS One and the agent packages are installed correctly. 

■ Verify the application is installed in the WPAR.

■ Verify the configuration definition of the group. Make sure the 
ContainerInfo’s properties (Type and Name) are defined.

■ Verify the configuration definition of the resource agent. Make sure the 
ContainerOpts’ property RunInContainer is defined.

Error messages occur when using the command script generated
from the haconf command

Description
You may use the haconf -dbtocmd or the haconf -xmltocmd command to get 
the configuration of your VCS One cluster in the form of a command script.

See “How the Policy Master loads the VCS One cluster configuration” on 
page 52.

When the resulting command script is executed, you may see some error 
messages as a result of redundant commands. 

Resolution
The following examples display error codes that may be ignored.
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■ VCS One ERROR V-97-1-10407
Example: hatype -add DNS -platform linux/x86
VCS One ERROR V-97-1-10407 Unable to add type 'DNS'. Type 
already exists

■ VCS One ERROR V-97-1-11354
Example: hatype -modify NetAppExport ArgList -delete -keys -
platform linux/x86
VCS One ERROR V-97-1-11354 [NetAppExport::ArgList] One or more 
resources depend on the attribute dependency 
'FilerResName:FilerName' defined in the ArgList. Remove these 
before clearing ArgList

■ VCS One ERROR V-97-1-17062

■ VCS One ERROR V-97-1-17063

■ VCS One ERROR V-97-1-17310

■ VCS One ERROR V-97-1-17322

■ VCS One ERROR V-97-1-17361

■ VCS One ERROR V-97-1-17362

■ VCS One ERROR V-97-1-17366

■ VCS One ERROR V-97-1-17367

■ VCS One ERROR V-97-1-17399

Communication failure between virtual VCS One 
clients and the Policy Master 

Description
The time set on the VMware virtual machine on which the VCS One client 
daemon is installed may fall behind the time set on the Policy Master system. If 
the time differential is greater than 30 minutes, communication fails between 
the VCS One client daemon (running on the virtual machine) and the Policy 
Master. However, the functionality of the virtual machine itself is not affected. 

Resolution
Change or modify the time set on the virtual machine to match the time set on 
the Policy Master system. 
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Connection between Policy Master and VMware vCenter Server is not 
successful

Description
Policy Master is unable to connect to vCenter Server. RunTime exception occurs.

Resolution
The process to configure the connection between the Policy Master and the 
vCenter Server must be followed as documented. Specifically, import the 
certificate into the keystore file before creation of the VMwareVC frame object. 
Otherwise the original keystore file is cached into memory, and the connection 
will not be successful.

Workaround
Restart the web server process 

On SFW 5.1 systems importing disk groups using the vxdg command 
fails

Description
This issue occurs on cluster systems having Storage Foundation for Windows 
5.1. On these systems if you install the VCS One client, reboot the system, and 
then run the vxdg command to import any disk group, the server initialization 
error may occur. The Veritas Enterprise Administrator (VEA) GUI may also fail 
to display the storage and action agents and the disk groups available on the 
local host even if the Veritas Storage Agent and the Veritas Action Agent 
services are running.

Workaround
Manually restart the VxBridge service by performing the following steps.

1 Log in as the administrator to the server where you installed the VCS One 
client.

2 Open the Services panel: click the Start button, and then click Run.

3 In the Run window, enter services.msc.

4 From the list of services, right-click on the VxBridge service, and then click 
Start.
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Troubleshooting Simulator issues
This section describes common Simulator issues and their resolution.

Instance states not updated in the Simulator Launch Pad
The simulator instance states in the Simulator Launch Pad do not update 
immediately resulting in an incorrect state being displayed in the Launch Pad. 
This can happen if you start or stop the Simulator process outside of the Launch 
Pad, for example, from the command line. Additionally, the Java process might 
also take a long time to stop.

Workaround
If you see an incorrect instance state in the Simulator Launch Pad, press F5 to 
reload all the states of the Simulator instance.

Non-administrator users cannot start the Simulator on 
Windows Vista

On Windows Vista non-administrator users who have administrator group 
privileges cannot start the VCS One Simulator. The Policy Master log contains 
the following error: VCS One ERROR V-97-1-10042 Command failed. 
The user must be Administrator.

This issue occurs because of Windows Vista's privilege model where non-
administrator users who have administrator group privileges are treated 
differently than the administrator user. 

Workaround
Log in as the administrator and not as a non-administrator user.

Simulator does not start
If the Simulator does not start, check that the configuration is valid.

The Simulator might also not start if you are trying to start the same instance 
from more than one installed location. For example, if you are trying to start the 
default instance from two locations, then the second instance will not start.

To check that a Simulator configuration is valid

1 Using the Windows command line, go to the appropriate configuration 
directory.

If the Simulator is installed in the default location, the directory for VCS 
One Simulator configuration files is located here:
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installation_directory\VCSOne\Simulator\conf

If the Simulator is installed in a different location, the directory for VCS 
One Simulator configuration files is located here:

installation_directory\VCSOne\Simulator\conf

where installation_directory is the location where the Simulator is 
installed.

2 From the configuration directory, type the following command:
haconf -verify .

You should see the following message:
Server farm configuration is valid

If you do not see this message, fix the configuration.

See “Duplicate TCP line messages” on page 714.

Network connection error during Simulator startup

Description
When you start the VCS One Simulator from the command line or the Web 
browser, the following error message may be displayed: 

V-97-1-10057 ClentHandle::net_recvb failed Error (-4)

This error message is displayed when the Policy Master attempts to initiate a 
control connection to the Simulator, and the Simulator is currently in the 
process of registering itself with the Policy Master. 

Resolution
Wait till the Simulator successfully registers itself with the Policy Master. After 
the registration process completes, the Simulator automatically responds to 
subsequent attempts made by the Policy Master to initiate a control connection. 
You do not need to take any corrective action. 

Enterprise users cannot execute non-Simulator commands

Description
Enterprise users can successfully execute Simulator (hasim) commands using 
the Simulator. However, all other VCS One commands issued by Enterprise 
users fail when executed from the Simulator. The following error message is 
displayed: 

VCSone ERROR V-97-1-18079 Command failed. 
User'username@domain_name' does not have privilege on server 
farm 'serverfarm_name'.
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Before executing commands VCS One queries the domain controller and 
retrieves a list of all the global groups. VCS One determines user privileges 
based on the global group privileges assigned to the user. Since the Simulator 
works in a simulated environment, VCS One does not query the domain 
controller, and as a result non-simulator commands issued by Enterprise users 
fail. 

Resolution
Add the Enterprise user to the list of VCS One users and assign 
ServerFarmObjectAdministrator privileges to the user. The user can now 
successfully execute non-simulator commands as the user is now a part of the 
VCS One configuration, and has explicit privileges defined. 

Simuser log on failure with real-time VCS One cluster 
configuration

Description
The VCS One Simulator can load and use real-time VCS One cluster 
configuration. This information is obtained when you execute the haconf –
dbtoxml command, which creates XML configuration files. However, after you 
load the real-time VCS One cluster configuration, you cannot log on to the 
Simulator as the default Simulator user (simuser) in the non-secure mode. The 
following error message is displayed: 

VCSone ERROR V-97-1-18079 Command failed. User 'simuser@domain' 
does not have privilege on server farm 'VCSoneFarm'. Login 
Failed. Please try again. 

The default configuration available with the Simulator has an in-built user 
(simuser) with ServerFarmAdministrator and ServerFarmObjectAdministrator 
privileges. Since simuser is not a real-time user the log on process fails. 

Resolution 1
To resolve this issue, perform the following steps: 

1 Copy the simuser.xml file to the directory that contains the XML 
configuration files for the real-time VCS One cluster. The simuser.xml file 
is located at: 
installation_directory\VCSOne\Simulator\conf\confxml

2 Open the main.xml file, located in the directory that contains the XML 
configuration files for the real-time VCS One cluster.

3 Add the following text to the main.xml file under <!DOCTYPE config 
SYSTEM "main.dtd">:
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<include>simuser.xml</include>

The simuser.xml file must exist in the same directory and must contain 
the definition for simuser@domain.

4 Save the main.xml file. 

5 Restart the Simulator with the real-time VCS One cluster configuration, and 
log on using the following credentials: 

■ User name: simuser

■ Password: none

■ Domain: domain

Resolution 2
You may also log in to the Simulator using one of the following methods:

■ Use a login account of a VCS One user that is already present in the 
configuration of the real VCS One cluster.

■ Use the login account of an operating system user that has administrator 
privileges on the local system.

Resolution 3
To resolve this issue, perform the following steps: 

1 Load the real-time server configuration into the Simulator. At the command 
prompt, type the following:
hamultisim -startsim instance_name -d real_time_config

2 Open a CLI prompt for that instance. At the command prompt, type the 
following:
haomultisim -cliprompt instance_name

3 3) Add the simuser into the configuration. At the command prompt, type the 
following:
hauser -add simuser@domain -user user@domaain -domaaintype nt

where, user is the currently logged in user having administrator privileges, 

domain is the administror domain (the local machine's domain), and 
domaintype is nt

4 Add privileges to the simuser@domain. At the command prompt, type the 
following:
hauser -addrole simuser@domain ServerFarmAdministrator
hauser -addrole simuser@domain ServerFarmObjectAdministrator
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The Simulator Launch Pad does not start

Description
Occasionally, when the Simulator Launch Pad is not closed properly, it might 
not start subsequently. This issue might occur because the Simulator Launch 
Pad process stops responding.

Solution
End the process mshta.exe, which is the Simulator Launch Pad process, using 
Task Manager. After the process is closed, restart the Launch Pad.
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Troubleshooting VCS One global cluster issues
This section describes common VCS One global cluster issues and recommended 
resolutions.

Unable to establish connection between VCS One clusters
Table 29-2 lists the possible causes due to which VCS One is unable to establish 
connection between the VCS One clusters. In such situations, the state of the 
remote cluster is INIT and the state of individual network links is DOWN.

Table 29-2 Possible causes and recommended resolutions

Cause Description and resolution

Security handshake 
failed

You may see the following messages in the VCS One engine logs:

VCS One INFO V-97-1-11359 Initiating connection with remote cluster 
at [192.62.41.2]:14151
VCS One ERROR V-97-1-11370 Security Handshake failed with 
[192.62.41.2]
VCS One ERROR V-97-1-11386 Could not open connection.

Resolution

Set up trust between the remote clusters.

For example, for two VCS One clusters seattle (primary) and tucson (secondary) with two 
different root brokers, you must establish trust between the root brokers of the two 
clusters.

■ On seattle, run the following command:
# /opt/VRTSvcsone/bin/haat setuptrust \
-b IP_address_of_tucson:broker_port -s low

■ On tucson, run the following command:
# /opt/VRTSvcsone/bin/haat setuptrust -b \
IP_address_of_seattle:broker_port -s low

The -s low option indicates that the security level is low. Accepted values for the 
security level are low, medium, and high.
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Connections are not 
enabled

If the EnableConnections attribute is set to 1 on the VCS One cluster that initiates 
connection (initiator) and if the attribute value is set to 0 on the VCS One cluster that 
accepts the connection (acceptor), VCS One logs the following error message:

VCS One ERROR V-97-1-12513 Rejecting connection from remote cluster 
'C1' since attribute 'EnableConnections' is 0 for the remote 
cluster in the local configuration

Resolution

Set the remote cluster object’s EnableConnections attribute to 1 for both the clusters.

See “Enabling connections between clusters” on page 600.

DR port values do not 
match

VCS One rejects the connection request from the remote cluster if the following values do 
not match:

■ DRPort attribute for the remote cluster object on the VCS One cluster that initiates 
the connection request

■ DRListeningPort attribute for the cluster object on the VCS One cluster that accepts 
the connection request

See “How VCS One global clusters communicate with each other” on page 77.

For example, if cluster seattle (initiator) has the value of DRPort attribute as 12345, and if 
the cluster tucson (acceptor) has the value of the DRListeningPort attribute as 23456, 
then the following message is seen in the VCS One log file on tucson:

Rejecting message of type 0x%x from remote cluster 'seattle' on 
port 12345. The message was received on a port other than the 
configured DR port = 23456. Ensure the DRPort on remote cluster 
'seattle' is the same as the DRListeningPort on the local cluster.

Resolution

On the VCS One cluster that initiates the connection request, modify the value of the 
DRPort attribute to match the value of the DRListeningPort attribute at the remote site.

For example, on seattle change the value of the DRPort attribute (of the remote cluster 
object that represents tucson) from 12345 to match the value of the DRListeningPort (of 
the cluster-level attribute on tucson) which is 23456.

See “Modifying remote cluster configuration” on page 604.

Table 29-2 Possible causes and recommended resolutions

Cause Description and resolution
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VCS One cannot online DRSG service group

Description
In a DR configuration, if you stop the web resource and then stop the Policy 
Master using the hastop -pm command, then when you restart the Policy 
Master using the hastart -pm command, the following error message is 
displayed:
VCS WARNING V-16-1-10805 Connection timed out
VCS One ERROR V-97-33-1120 Could not online parent group DRSG on 
<system_name>.
Verify your DR configuration.

VCS One waits for five minutes for the PMSG to come online before it attempts 
to bring the DRSG online. The PMSG service group cannot go online because the 
web resource is offline and hence displays the error messages.

Resolution
When you are ready to bring all the resources online in the PMSG, run the 
hastart -cluster command. This command brings the PMSG and the DRSG 
service groups online.

Unable to view CSG attributes for a remote cluster

Description
When you run the hacsg -display csgname -clus clusname command to 
display the remote cluster attributes for a CSG, only a subset of the CSG 
attributes are displayed.

Configuration is 
incorrect

VCS One fails to establish a connection with the remote cluster if the 
NetworkConnections attribute is incorrectly specified.

Resolution

■ Make sure that you have defined the network connections.

■ Make sure that you have specified the value of the remote cluster’s IP address 
followed by the local cluster’s IP address in the NetworkConnections attribute. The 
local cluster’s IP address is optional.

■ Make sure that the name of the remote cluster you added is the same as the VCS One 
cluster name at the remote site.

See “About managing remote clusters” on page 594.

Table 29-2 Possible causes and recommended resolutions

Cause Description and resolution
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Only some of the CSG attributes such as ClusterList, Authority, CSGState, and 
InTransition are exchanged among the VCS One clusters. So, the command 
displays only these attributes for the CSG for the remote cluster you have 
specified.

See “How VCS One enables wide-area failover of an application” on page 79.

Inter-cluster operations fail for the CSG

Description

■ Display of CSG attributes for the remote cluster fails

When you run the hacsg -display csgname -clus clusname command, 
the following error message is displayed.

For example: 
# hacsg -display csg1 -clus tucson
VCS One ERROR V-97-1-16132 The Policy Master cannot display 
attributes for the composite service group. The composite 
service group 'csg1' is not configured on cluster 'tucson'. 
Please specify names of composite service group objects that are 
configured on the named cluster.

■ CSG switch operation fails

When you perform a CSG switch operation, the following error message is 
displayed:

For example:
# hacsg -switch csg1 -clus seattle
VCS One ERROR V-97-1-16201 The composite service group 'csg1' 
cannot be switched. Either the composite service group 'csg1' 
does not exist on remote cluster 'seattle' or is not configured 
as global on 'seattle'.

Resolution
CSG must be defined and must be global at each site where it can be brought 
online.

See “Managing global composite service groups” on page 613.

No concurrency violation triggered when CSG is online at both sites

Description
CSG is online or partially online at more than one site, however VCS One does 
not trigger a concurrency violation.
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Resolution
Make sure that the CSG is global on all the clusters where it is defined, and that 
the value of the ClusterList attribute matches.

Service groups that belong to a CSG fail to come online

Description
When you run the following commands to bring the service groups online, the 
groups that belong to a global CSG for which there is no authority cannot come 
online:

■ hagrp -online -all

■ hagrp -online -ou -ea

Resolution
Perform the following steps to resolve this issue:

1 Identify the CSGs that the groups belong to. 

2 Acquire authority for the CSGs. 

3 Bring the service groups online.

See “Managing global composite service groups” on page 613.

Resources or groups that belong to a CSG fail to come online

Description
When there is a concurrency violation for a global CSG, the following operations 
fail:

■ Online or switch operation for the CSG

■ Online operation for the resources or service groups that belong to the 
global CSG

■ Switch operation for the service groups that belong to the global CSG

You can only perform an offline operation in this case.

Resolution
When a concurrency violation has occurred for the CSG, you must first resolve 
the concurrency violation before you try to bring the resources, groups, or CSG 
online.

See “CSG concurrency violation when the state of the CSG is up-to-date” on 
page 735.
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CSG concurrency violation when the state of the CSG is up-to-date

Description
When a global CSG is online or partially online at more than one site and when 
the value of the CSG attribute StaleState is 0, VCS One reports a concurrency 
violation at each site.

A message similar to the following is logged:
Concurrency violation occurred for composite service group '%s'. The 
composite service group '%s' is online or partially online on 
cluster objects (%s). Take the composite service group offline on 
all cluster objects but one.

Resolution
Identify the VCS One cluster where you want to have the global CSG online and 
take the global CSG offline on other VCS One clusters. 

See “Taking a composite service group offline” on page 419.

CSG concurrency violation when the state of the CSG is stale

Description
When the value of the CSG attribute StaleState is 1 and when the Policy Master 
is down on the local cluster, then VCS One reports a concurrency violation if a 
takeover of the CSG was performed on the remote cluster.

A message similar to the following is logged:
Concurrency violation occurred for composite service group '%s'. The 
composite service group '%s' is online or partially online on 
cluster objects (%s). This may be due to a takeover of the composite 
service group from a remote cluster when the Policy Master in the 
local cluster '%s' was down and the state of the composite service 
group on the local cluster is not yet up-to-date. To resolve the 
concurrency violation, take the composite service group offline on 
all cluster objects but one.

Resolution
Verify that the CSG takeover operation was performed at the remote cluster. 
Perform the following steps on the local cluster to resolve concurrency violation 
for the CSG:

1 Flush out any pending actions for each group that belong to the CSG.

See “Flushing a pending action on a service group” on page 380.

2 Take the CSG offline on the local cluster.

See “Taking a composite service group offline” on page 419.
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ATTN flag is set for the CSG

Description
The ATTN flag for a CSG is set if a group that belongs to the CSG is faulted, or if 
the group that belongs to the CSG is unable to come online on any system in the 
VCS One cluster.

Resolution
Run the hacsg -infoattn command.

The command displays the reason why the ATTN flag is set in the CSGState 
attribute of a CSG. Perform the following based on the reason that has caused 
the ATTN flag to be set:

■ Unable to Online

The command lists the groups in the CSG that have caused the ATTN flag to 
be set. Fix the issues for the service groups. 

■ Group Fault

The command lists the groups in the CSG that have caused the ATTN flag to 
be set. Fix the issues for the service groups.

■ Concurrency Violation

The command lists the CSG name. Resolve the concurrency violation issue.

See “CSG concurrency violation when the state of the CSG is up-to-date” on 
page 735.

■ State is stale

See “How VCS One resolves authority for application that spans clusters” 
on page 80.

VCS One does not clear the PENDING flag in the CSGState 
attribute

Description
If the CSG is in a steady ONLINE or OFFLINE state (no group or resource in that CSG 
is in transition), the PENDING flag is set in the CSGState attribute if some 
resource in the CSG goes to an UNKNOWN state.

Resolution
Perform the following steps to clear the PENDING flag:

1 Fix the issue that caused the resource to go to an UNKNOWN state.

See the log file of the agent that manages this resource to find the reason.

2 Probe the resource.
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See “Probing a resource” on page 433.

Value of the LinkStatus attribute toggles 
between UP and DISABLED

Description
If the value of the EnableConnections attribute is set to 1 on the initiator cluster 
and is set to 0 on the acceptor cluster, then the initiator cluster continuously 
attempts to connect with the acceptor cluster at periodic intervals. This causes 
the LinkStatus attribute value toggle between UP and DISABLED.

Resolution
Set the EnableConnections attribute to 1 on the acceptor cluster.

See “Enabling connections between clusters” on page 600.
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Troubleshooting authentication issues
This section describes common Symantec Product Authentication Service 
issues.

On Windows, this service is named Veritas Cluster Server One Product 
Authentication Service.

Changing FQDN causes authentication failure

Description
When the fully qualified domain name (FQDN) changes, the authentication 
process might fail. 

The fully qualified domain name may change due to one of the following events:

■ Change in the name of the Policy Master cluster systems.

■ Ethernet connection is closed and the system re-connects via a wireless 
connection.

If the authentication service is not re-started, the following error message is 
displayed:

2006-01-17 11:22:38 VCSone ERROR V-97-1-10014 failed to 
initialize security facade, Exiting

Resolution
To resolve this issue, do one or both of the following tasks:

■ Change the broker name to a name that can be resolved or to the IP address 
of the Policy Master system.

■ Re-start the Symantec Product Authentication Service on the system before 
attempting to log on. 

To restart the authentication service on UNIX systems

On the system where authentication is being attempted, at the command 
prompt, type the following: 

# /opt/VRTSvcsone/bin/vcsoneatd

To restart the authentication service on a Windows system

1 Click Start, point to Programs, point to Administrative Tools, and then click 
Services. The Services dialog box is displayed. 

2 In the Services dialog box, right-click Veritas Cluster Server One Product 
Authentication Service, and then click Restart.
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Authentication broker and Policy Master trust not established

Description 
Each Policy Master cluster system must have an explicit trust relationship with 
an authentication broker.

If you attempt to log on to the VCS One console and you specify an 
authentication broker system for which trust is not set up, the following error 
message is displayed:

VCSone ERROR V-97-11-24583 Peer certificate verification failed.
Login Failed. Please try again.

Resolution
You must set up a trust relationship between the authentication broker system 
and each Policy Master cluster system. Use the following command on UNIX:

# /opt/VRTSvcsone/bin/haat setuptrust -b broker_name:port \
-s low|medium|high

where -b specifies the name and port of the authentication broker to be trusted 
and -s specifies the security level as either low, medium, or high.

For example, if you want to use an authentication broker system named sys01, 
you need to execute the following command on each Policy Master system. At 
the command prompt, type the following:

# /opt/VRTSvcsone/bin/haat setuptrust -b sys01:14159 -s medium

On a Windows computer, at the command prompt, type the following:

%VCSONE_HOME%\bin\haat setuptrust --broker sys01:14159 --
securitylevel medium

If, at a later stage, you add another system to the Policy Master cluster, you must 
set up an explicit trust relationship between the new Policy Master cluster 
system and the authentication broker.

Symantec Web Server log on failure 

Description
At times, the Symantec Web Server may not be able to connect to the Policy 
Master. Attempts to logon to the Symantec Web Server may result in the 
following error message:

VCS One ERROR V-97-11-2 Correct Credentials were not received.
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Resolution
To resolve this issue, restart the Symantec Web Server, and try to log on. If you 
still cannot log on, you need to delete the Symantec Web Server authentication 
credential that resides on the authentication broker system.

To delete current credential of the Symantec Web Server

1 The Symantec Web Server’s principal name is WebServer. At the command 
prompt, type the following if you want to display it:

On UNIX:

# /opt/VRTSvcsone/bin/haat showcred -d vx:VCSONE_WEB_USERS -p \
WebServer

On Windows:
%VCSONE_HOME%\bin\haat showcred -d vx:VCSONE_WEB_USERS -p \
WebServer

2 Delete the current Web Server authentication credential. At the command 
prompt, type the following:

On UNIX:
# /opt/VRTSvcsone/bin/haat deletecred -d vx:VCSONE_WEB_USERS \
-p WebServer -j broker

On Windows:
%VCSONE_HOME%\bin\haat deletecred -d vx:VCSONE_WEB_USERS \
-p WebServer -j broker

VCS One client certificate verification failure

Description
The VCS One client may fail to start due to a credential failure. This issue can be 
caused by a mismatched user name, mismatched credentials, or if no cached 
credentials are on the local disk. It can also be caused if the broker is 
reconfigured after the client is deployed. The following error message is 
displayed in the client log:

ERROR V-97-19-17505 Exiting: Security Initialization failed.

Resolution
In the event of client authentication failure, you need to do one of the following:

■ Run the installer again to re-deploy the client.

■ Manually set up an explicit trust relationship between the authentication 
broker and the VCS One client system.

The steps for performing these procedures follow.
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To re-deploy the client

1 Verify whether the credential exists for the user name in 
/etc/VRTSvcsone/vcsone.conf by entering the following command:
# grep -i user_name /etc/VRTSvcsone/vcsone.conf

where user_name is the user name in this format: 
systemname@VCSONE_USERS. The user name is typically either the host 
name or the fully qualified host name.

2 Display the credential by entering the following command:
# /opt/VRTSvcsone/bin/haat showcred -p user_name

3 Proceed to the next step if one of the following situations applies:

■ The credential does not exist.

■ The credential exists, but the client connection displays the error 
message. In this case, the credential is either invalid or the 
authentication broker was re-configured after the credential was 
issued.

4 To resolve either of these issues, redeploy the client in one of the following 
ways:

◆ Use the installer to create the deployment credential and redcploy the 
client. For instructions on installing the client using a deployment 
credential, see the Veritas Cluster Server One Installation Guide.

◆ Redeploy the client manually by performing the following steps:

a Make sure that the broker is running on the active Policy Master 
node by entering the following command:
# /opt/VRTSvcs/bin/hares -state atd

b On the active Policy Master system, reset the password for the 
client user by entering the following command:
# /opt/VRTSvcsone/bin/haat resetpasswd -t ab -d \
VCSONE_USERS -p user_name [-n new_passwd] \
[-r repnewpasswd]

c On the client system, set up trust with the authentication broker by 
entering the following command:
# /opt/VRTSvcsone/bin/haat setuptrust -b \
broker_host_or_IP:port -s medium -j client

where broker_host_or_IP is the name or IP address of the 
authentication broker host and port is the port number for the 
authentication broker. In VCS One, this port number is 14159. The 
-s option indicates the security level. Accepted values for the 
security level are low, medium, and high.
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d On the client system, reauthenticate the client by running the 
following command:
# /opt/VRTSvcsone/bin/haat authenticate -d \
vx:VCSONE_USERS -p client_name -s password -b \
broker_host_or_IP:port

where client_name is the name of the client, password is the 
password, broker_host_or_IP is the name or IP address of the 
authentication broker host, and port is the port number for the 
authentication broker. In VCS One, this port number is 14159.

To manually set up trust

1 On the active Policy Master system, enter the following command:

# /opt/VRTSvcsone/bin/haat deleteprpl -t ab -p VCSONE_USERS \
-p client_name

where client_name is the name of the client.

2 On the active Policy Master system, enter the following command:
# /opt/VRTSvcsone/bin/haat addprpl -t -p VCSONE_USERS \
-p client_name -s password -b broker_host_or_IP:port -q service

where client_name is the name of the client, password is the password, 
broker_host_or_IP is the name or IP address of the authentication 
broker host, and port is the port number for the authentication broker.

3 On the client system, set up trust with the authentication broker by entering 
the following command:
# /opt/VRTSvcsone/bin/haat setuptrust -b \
broker_host_or_IP:port -s medium -j client

where broker_host_or_IP is the name or IP address of the 
authentication broker host and port is the port number for the 
authentication broker. In VCS One, this port number is 14159. The -s 
option indicates the security level. Accepted values for the security level are 
low, medium, and high.

4 On the client system, reauthenticate the client by running the following 
command:
# /opt/VRTSvcsone/bin/haat authenticate -d vx:VCSONE_USERS \
-p client_name -s password -b broker_host_or_IP:port

where client_name is the name of the client, password is the password, 
broker_host_or_IP is the name or IP address of the authentication 
broker host, and port is the port number for the authentication broker. In 
VCS One, this port number is 14159.
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VCS One console fails to start

Description
If the authentication broker fails or stops responding, you cannot start a new 
VCS One console connection. All the existing console connections continue to 
function in a normal manner and are not affected. All attempts to start a new 
VCS One console connection with the Policy Master fail. 

All command line interface commands that require authentication also fail 
when the authentication broker fails. However, the root user on the active Policy 
Master cluster node can successfully execute VCS One CLI commands and 
perform administration tasks. 

Resolution
To resolve this issue, perform the following steps: 

1 Check the authentication broker for errors. In the event of an authentication 
broker failure, resolve the problem, and ensure that the authentication 
broker is up and running. 

2 Start a new VCS One console connection. 

VCS One CLI commands fail to execute

Description
A VCS One command line interface failure with a security hand-shake error can 
occur for various reasons, including:

■ The credential for the user name that is defined in /etc/VRTSvcsone/
vcsone.conf does not exist. To check to see if the credential exists, enter 
the following command:
# /opt/VRTSvcsone/bin/haat showcred -p user_name

■ The credential for the user name exists but does not match the broker 
credentials. This issue can be caused if the broker is reset after the client is 
deployed.

Resolution
If the credential for the user name exists, but does not match the broker 
credentials, run the installer again to re-deploy the client. See the Veritas Cluster 
Server Installation Guide for instructions.

Business policy automation not working
If Business Policy automation is not working, check the following items:



744 Troubleshooting VCS One issues
About the hagetcf utility on UNIX
■ The Webserver, BPA engine, and Policy Master daemon were all running 
when the event occurred.

The BPA engine runs within the Webserver process, and both the 
Webserver and the BPA engine must be running when an event occurs in 
order for the event to be processed. There is no deferred or offline 
processing.

Additionally, the Policy Master daemon, vcsoned, must be running to 
process an event.

■ The Webserver, BPA engine, and Policy Master daemon did not fail while 
processing the event.

If vcsoned or the BPA engine fails while processing an event, the event will 
not be finished. If there are five tasks in a job and during the third task the 
Webserver fails, when the Webserver is restarted the remaining tasks will 
not run. The execution log will show that the rule was triggered and that 
task three was scheduled to run.

■ The job failed before it completed.

If a job fails before it has completed, it does not restart

■ Could not contact mail server and send notification

Check correct spelling of email address. Note that VCS One does not queue 
the message. After two attempts the attempt logs as a delivery failure.

Check the email server. If the email server is down, you will miss 
notifications.

About the hagetcf utility on UNIX
The hagetcf command generates output about your VCS One cluster 
configuration. Symantec Technical Support might request you to run the 
hagetcf utility and send them the generated output in order to completely 
understand and analyze the VCS One cluster configuration. 

See “About Symantec Technical Support” on page 749.

The hagetcf utility must be executed on one system at a time. 

This utility gathers the following information:

■ Installed software information

■ System information

■ Configuration information

■ If the system is part of the Policy Master cluster, configuration 
information comprises of VCS information, VCS One information, and 
VCS One database information.
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■ If the system is a VCS One client, configuration information comprises 
of information about the agent directories and agent framework.

■ Log information

■ If the system is part of the Policy Master cluster, log information 
includes installation logs, VCS One logs, lock files, and VCS logs.

■ If the system is a VCS One client, log information includes installation 
logs, log messages, and lock files. 

■ Important VCS One file information 

■ Symantec Product Authentication Service configuration backup file 
information

■ Web console information

After gathering this information, the hagetcf utility creates a gzip file. This file 
may be located in the default or user-specified directory. You need to send the 
entire gzip file to Symantec Technical Support.

Caution: The hagetcf utility gathers sensitive information about the VCS One 
cluster environment. Ensure that you secure this information while sending it to 
Symantec Technical Support. 

You can run the hagetcf utility in the interactive or silent mode. In addition, 
you can specify if you want to save the gzip file in the default or user specified 
directory.

To run hagetcf in the interactive mode

◆ At the command prompt, type the following:

hagetcf

When prompted, choose a directory for the gzip file.

To run hagetcf in the silent mode and use the default directory

◆ At the command prompt, type the following:

hagetcf -silent 

The output gzip file is saved in the /var/tmp directory.

To run hagetcf in the silent mode and specify a user-defined directory

◆ At the command prompt, type the following:

hagetcf -silent -d directory_for_gzip

The output gzip file is saved in the directory that you specify.
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hagetcf command usage
The hagetcf command has the following formats:

hagetcf [-h | -help]
hagetcf [-s | -silent] [-d output_directory]
hagetcf [-version]

More information is available about the hagetcf utility. 

See the Veritas Cluster Server One Command Reference Guide.

About the hagetcf utility on Windows
The hagetcf command generates output about your VCS One cluster 
configuration. Symantec Technical Support might request you to run the 
hagetcf utility and send them the generated output in order to completely 
understand and analyze the VCS One cluster configuration. 

More information is available about Symantec Technical Support. 

See “About Symantec Technical Support” on page 749.

Caution: The hagetcf utility gathers sensitive information about the VCS One 
cluster environment. Ensure that you secure this information while sending it to 
Symantec Technical Support. 

The hagetcf utility must be executed on one system at a time. 

This utility gathers the following information:

■ Installed software information

■ System information

■ Configuration information

■ If the system is part of the Policy Master cluster, configuration 
information is comprised of Veritas Cluster Server information, VCS 
One information, and VCS One database information.

■ If the system is a VCS One client, configuration information is 
comprised of information about the agent directories and agent 
framework.

■ Log information

■ If the system is part of the Policy Master cluster, log information 
includes installation logs, VCS One logs, lock files, and Veritas Cluster 
Server logs.
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■ If the system is a VCS One client, log information includes installation 
logs, log messages, and lock files. 

■ Important VCS One file information 

■ Symantec Product Authentication Service configuration backup file 
information

■ Web console information

To access hagetcf

1 At the command prompt, change the directory to %VCSONE_HOME%\bin 
where %VCSONE_HOME% is the VCS One installation directory, typically 
C:\Program Files\Veritas\Cluster Server One.

2 At the command prompt, type the command:
hagetcf [-option]

Running hagetcf displays output similar to the example below:
VERITAS Cluster Server One(TM) 5.1 for Windows 2003 Diagnostics
Copyright (C) Symantec Corporation 2007 All rights reserved.
Dumping output to: C:\Program Files\Veritas\Cluster Server One
\hagetcf\0519_1349

By default, hagetcf writes the output to the directory 
%VCSONE_HOME%\hagetcf\<timestamp>

The <timestamp> format is <month><date>_<hour><minute>.

Use the options in Table 29-3 with the hagetcf command to limit the diagnostic 
information to specific components.

Table 29-3 hagetcf command options

Options Action

-app Dumps the application event log.

-sec Dumps the security event log.

-sys Dumps the system event log.

-allevt Dumps all event logs.

-conf Dumps the VCS One config directory.

-log Dumps the VCS One log directory.

-ldf Dumps the VCS One ldf directory.

-diag Dumps the VCS One diag directory.
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-lock Dumps the lock directory.

-alldir Dumps the config, log, ldf, and lock directories.

-ha Dumps the output of the following commands:

hares -display -all 

hagrp -display -all 

hasys -display

-state Dumps the following system state information: 

■ VCS One diagnosis directory, %VCSONE_HOME%\diag, if 
present

■ Dr. Watson log

■ Drive signature information from the havol utility

■ Network information, including NICs, ipconfig, and 
network-related registry entries

■ The Veritas registry key

■ Output of the nbstat and the netstat commands

■ Licensing information

■ Disk and volume information

■ SCSI and Fibre configuration information

■ Server configuration information

■ Service and device state and configuration information

■ Processes running on the system

■ Information about the privileges of the current user

■ Information about products installed on the system

-sql Dumps information about SQL Server and the VCS One agent 
for SQL Server (if the command is run on client systems).

-exch Dumps information about Exchange Server and the VCS One 
agent for Exchange Server (if the command is run on client 
systems).

-iis Dumps IIS information (if the command is run on client 
systems).

-oracle Dumps information about Oracle and the VCS One agent for 
Oracle (if the command is run on client systems)

-msmq Dumps information about MSMQ

-allagents Dumps information about all enterprise agents (if the 
command is run on client systems).

Table 29-3 hagetcf command options (continued)

Options Action
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Note: If you do not specify any options, the command retrieves diagnostic 
information with the following options: -app, -sys, -ha, -log, -lock, -
conf, -state

About Symantec Technical Support
Visit http://www.symantec.com/enterprise/support/assistance_care.jsp for 
technical assistance. Use the Knowledge Base search feature to access resources 
such as TechNotes, product alerts, software downloads, hardware compatibility 
lists, and the customer email notification service. 

If you encounter an error while using the product, include the error number 
preceding the message when contacting Technical Services. You can also use the 
error number to search for information in TechNotes or documents on the Web 
site.

-haver Dumps version information about all VCS One binaries.

-vxlog Dumps diagnostic information about other Symantec 
products.

-o <outdir> Dumps hagetcf output to <outdir>.

-? or -help Displays the command’s usage information.

Table 29-3 hagetcf command options (continued)

Options Action

http://www.symantec.com/enterprise/support/assistance_care.jsp
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This section includes the following chapters:

■ “Reference of privileges” on page 753.

■ “Automated tasks reference” on page 769.

■ “Configuration file reference” on page 803.

■ “Attributes reference” on page 815.

■ “Virtualization attributes reference” on page 901

■ “State reference” on page 931
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This appendix includes the following topic:

■ Pre-defined roles in VCS One

■ About role categories

■ About privileges categories
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Pre-defined roles in VCS One
Table 31-1 lists the roles that are predefined in VCS One. The roles are listed in 
alphabetical order.

Table 31-1 VCS One built-in user roles

Role Name Role Type Description

CSGAdministrator CSG Composite service group 
administrator role

CSGOperator CSG Composite service group operator role

GroupAdministrator Group Group administrator role

GroupOperator Group Group operator role

PFrameAdministrator Pframe Pframe administrator role

PFrameOperator Pframe Pframe operator role

ResourceAdministrator Resource Resource administrator role

ResourceOperator Resource Resource operator role

ServerFarmAdministrator Farm VCS One cluster administrator role

ServerFarmObjectAdministrator Object VCS One cluster object administrator 
role

ServerFarmObjectGuest Object VCS One cluster object guest role

ServerFarmObjectOperator Object VCS One cluster object operator role

SystemAdministrator System System administrator role

SystemOperator System System operator role

UserAdministrator Object User administrator role

UserOperator User User operator role

VCSOneClientFarm Farm System user role for farm object

VCSOneClientGroup Group System user role for group objects

VCSOneClientPFrame Pframe System user role for Pframe object

VCSOneClientSystem System System user role for system object

VCSOneClientVFrame Vframe System user role for Vframe objects

VFrameAdministrator Vframe Vframe administrator role
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About role categories
Roles fall into a combination of categories, depending on whether and how users 
may display or modify them. Table 31-2 describes VCS One role categories.

Most roles have two categories associated with them. For example, to display the 
Category attribute and its value for the SystemAdministrator role. Enter the 
command:

harole -value SystemAdministrator Category

Notice in the output that the SystemAdministrator role is in both the system 
category (that is, it is VCS One predefined) and in the removable category.

5 [system|removable]

VFrameOperator Vframe Vframe operator role

VObjectAdministrator VObject VObject administrator role

VObjectOperator VObject VObject operator role

ZoneUserFarm Farm Zone administrator role

ZoneUserGroup Group Group administrator role for zones

Table 31-1 VCS One built-in user roles

Role Name Role Type Description

Table 31-2 Role categories in VCS One 

Category Description

System Roles that are pre-defined by VCS One. Examples include 
ServerFarmAdministrator and SystemOperator. Users may 
not create system roles. Note that the term “system” does not 
refer to the system object.

Hidden Roles that are used internally by VCS One and never 
displayed.

Removable Roles that may be deleted. User-defined roles are in the 
removable category. Most predefined roles are not removable.

Modifiable Roles for which privileges may be added and deleted. 
User-defined roles are in the modifiable category.

See “About roles” on page 251.
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The following tables catalog the VCS One role types, and the operations 
available in each one.

Catalog of farm privileges
Table 31-3 displays the privileges in the Farm category:

Table 31-3 Privileges in the Farm category

Operation Privilege Description 

Add Cluster Add a remote cluster definition to the VCS One cluster. 
(Applicable in VCS One global cluster setup)

Delete Cluster Delete a remote cluster definition from the VCS One cluster. 
(Applicable in VCS One global cluster setup)

Modify Cluster Modify the values of VCS One cluster attributes, including 
adding values, updating existing values, deleting values, and 
deleting attribute keys. 

Add Type Add a resource type definition.

Delete Type Delete a resource type definition.

Modify Type Change a resource type definition.

Add / Delete Attributes Add or delete an attribute to an existing type.

For example, the following command would add the attribute 
MyAttribute to the FileOnOff type:

haattr -add FileOnOff MyAttribute

Modify Attributes Modify an attribute of a particular type.

Add Role Create a role definition.

Delete Role Remove a role definition.

Modify Role Change a role definition.

Log Add This privilege is used by agents to log messages.

Modify GTQ Perform GTQ operations, which are actions to abort or flush 
service groups in the GTQ. 

Modify Automation 
Settings

Change the settings for automated tasks.
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Catalog of object privileges
Table 31-4 displays the privileges in the Object category:

Modify VType Change a VObject type definition.

Purge Events Delete notification log message events

Table 31-3 Privileges in the Farm category

Operation Privilege Description 

Table 31-4 Privileges in the object category

Operation Privilege Description 

Add System Add a system to the VCS One cluster.

Delete System Delete a system from the VCS One cluster. 

Add Group Add a service group to the VCS One cluster. 

Delete Group Delete a service group from the VCS One cluster.

Link Group Create a service group dependency. 

Unlink Group Remove a service group dependency. 

Modify Group 
Compatibility

Modify the compatibility specified for groups.

Add User Add a user to the VCS One cluster.

Delete User Delete a user from the VCS One cluster.

Read Only View information about the object.

Add Vobject Add a Vobject to the VCS One cluster.

Delete Vobject Delete a Vobject from the VCS One cluster.

Add Rule Add a rule to automation policy.

Delete Rule Delete a rule from automation policy.

Add Job Add a job to automation policy.

Delete Job Delete a job from automation policy.

Execute Script Execute a script as part of automation policy. 

Add CSG Add a composite service group to the VCS One cluster.
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Catalog of system privileges
Table 31-5 displays the privileges in the System category:

Delete CSG Delete a composite service group from the VCS One cluster.

Add PFrame Add a PFrame to the VCS One cluster.

Delete PFrame Delete a PFrame from the VCS One cluster. 

Add VFrame Add a VFrame to the VCS One cluster. 

Delete VFrame Delete a VFrame from the VCS One cluster.

Link VFrame Create a VFrame dependency. To create a dependency between 
a service group and a VFrame, “Link VFrame” and ‘Link Group’ 
privileges are both required.

Unlink VFrame Remove a VFrame dependency. To remove a dependency 
between a service group and a VFrame, “Unlink VFrame” and 
‘Unlink Group’ privileges are both required.

Modify VFrame 
Compatibility

Modify the compatibility specified for VFrames.

Table 31-4 Privileges in the object category

Operation Privilege Description 

Table 31-5 Privileges in the System category

Operation Privilege Description 

Add System to 
SystemList

Add system to service group’s SystemList attribute. 

To add a system to a service group’s SystemList, you must have 
this privilege on the system in addition to the Modify Group 
privilege on the group.

Delete Systems from 
SystemList

Remove system from a service group’s SystemList attribute. 

To delete a system from a service group’s SystemList, the user 
must have this privilege on the system and the Modify Group 
privilege on the group.

Freeze System Freeze a system

Evacuate System Evacuate a system

Unfreeze System Unfreeze a system

Modify System Modify a system’s attributes
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Catalog of group privileges
Table 31-6 displays the privileges in the group category:

Start Agent Start an agent on a system

Stop Agent Stop an agent on a system

Stop System Stop a system

Modify Capacity Modify a system’s capacity attribute. User with this privilege 
requires Modify System privilege also.

Read Only View information about systems

Modify OU Move a system to a different location in the Organization Tree. 
You also need OU Move to Object and OU Move from Object 
privileges.

See “Catalog of organization tree privileges” on page 763.

Link VFrame Link a VFrame to a system.

Unlink VFrame Unlink a VFrame from a system.

System Agent Dump 
FFDC

Allows the first failure data capture logs to dump on the 
system.

Table 31-5 Privileges in the System category

Operation Privilege Description 

Table 31-6 Privileges in the group category

Operation Privilege Description 

Online Group Bring a group online.

Offline Group Take a group offline.

Switch Group Switch a service group from one system to another.

Freeze Group Freeze a service group, such that it cannot be brought online, 
taken offline, or failed over.

Unfreeze Group Unfreeze a service group.

Enable Group Enable a group, so that it may be brought online or switched, 
for example.

Disable Group Disable a group, such that it may not be brought online or 
taken offline.
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Clear Group Change resources from faulted to offline.

Flush Group Cancel the online or offline operation that is currently being 
performed on the service group. 

Modify Group Modify the attributes of a service group. Users must have also 
this privilege to modify group priority, load, and fault policy.

Clear Admin Wait Clear the ADMIN_WAIT state of resources in a group.

Add Resource Add a resource to a group.

Delete Resource Delete a resource from a group.

Enable Resource Enable all resource in a group; agents start monitoring.

Disable Resource Disable all resource in a group; agents stop monitoring.

Link Resource Create a dependency link between resources.

Unlink Resource Remove the dependency link between resources.

Modify Priority Modify a service group’s Priority attribute. User also requires 
Modify Group privilege

Modify Load Modify a service group’s Load attribute. User also requires 
Modify Group privilege.

Modify Fault Policy Modify a service group’s GrpFaultPolicy, NodeFaultPolicy, or 
ResFaultPolicy attribute. User also requires Modify Group 
privilege. To modify ResFaultPolicy attribute, user requires 
Modify Group and Group Fault Policy privileges for the 
parent resource group.

Read Only View information about groups. This privilege also allows 
read privileges on the group’s resources.

Modify OU Move a group to a different location in the Organization Tree. 
You also need OU Move to Object and OU Move from Object 
privileges.

See “Catalog of organization tree privileges” on page 763.

Add to GroupList Add this group to a composite service group’s GroupList 
attribute.

To add a group to a composite service group, the user must 
have this privilege on the group as well as the Modify CSG 
privilege on the composite service group.

Table 31-6 Privileges in the group category

Operation Privilege Description 
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Catalog of composite service group privileges
Table 31-7 displays the privileges in the composite service group category:

Delete from GroupList Remove this group from a composite service group’s 
GroupList attribute.

To delete a group from a composite service group, the user 
must have this privilege on the group as well as the Modify 
CSG privilege on the composite service group.

Table 31-6 Privileges in the group category

Operation Privilege Description 

Table 31-7 Privileges in the composite service group category

Operation Privilege Description 

Modify CSG Modify the attributes of a composite service group. 

Read Only View information about composite service groups.

Online CSG Bring a composite service group online. 

The user does not also require service group online privileges 
for the constituent service groups to bring a composite 
service group online.

However, this privilege does not allow the user to bring the 
constituent groups online individually. To bring an service 
group online separate from the CSG, the user must have the 
Online Group privilege on the group.

Offline CSG Take a composite service group offline.

The user does not also require service group offline privileges 
for the constituent service groups to bring a composite 
service group offline.

However, this privilege does not allow the user to bring the 
constituent groups offline individually. To bring an service 
group offline separate from the CSG, the user must have the 
Offline Group privilege on the group.

Switch CSG Switch a composite service group from one VCS One cluster 
to another.

Request Authority Take Authority of a composite service group.

See “Authority” on page 831.
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Catalog of resource privileges
Table 31-8 displays the privileges in the resource category:

Modify OU Move a composite service group to a different node in the 
organization tree. 

You also need OU Move to Object and OU Move from Object 
privileges.

See “Catalog of organization tree privileges” on page 763.

Flush CSG Clear any IntentOnline entry for any constituent service 
group of the CSG.

A user with this privilege does not require the Modify GTQ 
privilege to flush the IntentOnline entries.

Table 31-7 Privileges in the composite service group category

Operation Privilege Description 

Table 31-8 Privileges in the resource category

Operation Description

Online Resource Bring a resource online.

Offline Resource Take a resource offline.

Offline Propagate Offline a resource and specify its children be taken offline.

Clear Resource Change a resource’s state from faulted to offline.

Clear Admin Wait Remove resource from the ADMIN_WAIT state.

Probe Resource Monitor a resource and send state to VCS One client daemon.

Modify Resource Change the value of a resource attribute.

Action Direct the agent take the specified action (in a token) on the 
resource.

Event Able to invoke triggers for the resource

Refresh Info Direct the Info entry point to update value of ResourceInfo entry 
point.

Flush Info Clears the current value of ResourceInfo entry point.

Read Only View information about resources.
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Catalog of user privileges
Table 31-9 displays the privileges in the user category:

Catalog of organization tree privileges
Table 31-10 displays the privileges in the OT category:

Table 31-9 Privileges in the user category

Operation Description

Modify User Change the value of a user attribute.

Add Privilege Add to the user’s permitted operations.

Delete Privilege Delete a user’s privilege to perform an operation.

Enable User Restore a disabled user’s privileges.

Disable User Disable a user. A disabled user has no privileges in the farm. 
Disabled users do not have read privileges.

Read Only View information about users

Modify OU Move a user to a different location in the Organization Tree. You 
also need OU Move to Object and OU Move from Object privileges.

See “Catalog of organization tree privileges” on page 763.

Table 31-10 Privileges in the OT category

Operation Description

Read Only View the organization tree.

Add OUName Add an OUName node to the organization tree.

Delete OUName Delete an OUName node from the organization tree.

Modify OUName Modify an OUName node in the organization tree.

Add OUValue Add an OUValue node to the organization tree.

Delete OUValue Delete an OUValue node from the organization tree.

Modify OUValue Modify an OUValue node in the organization tree.



764 Reference of privileges
About privileges categories
Catalog of notifier privileges
Table 31-11 displays the privileges in the notifier category:

Catalog of VObject privileges
Table 31-12 displays the privileges in the VObject category:

Move to Object Move a service group, system, user, user group, or frame object to a 
node in the organization tree.

To move an object the user must also have Modify OU privilege on 
the object that is moved.

Move from Object Move a service group, system, user, user group, or frame object 
away from a node in the organization tree.

To move an object the user must also have Modify OU privilege on 
the object that is moved.

Add EA Add an extended attribute to an OUValue node.

Delete EA Delete an existing extended attribute.

Modify EA Modify an existing extended attribute.

Table 31-10 Privileges in the OT category

Operation Description

Table 31-11 Privileges in the notifier category

Operation Description

Email Specify an email recipient to be notified as part of a notification or 
business rule.

SNMP Specify SNMP console to be notified as part of a notification or 
business rule.

Syslog Specify Syslog to be notified as part of a notification or business 
rule.

Table 31-12 Privileges in the VObject category

VObject Privilege Description 

Modify Vobject Modify a Vobject. 
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Catalog of Pframe privileges
Table 31-13 displays the privileges in the Pframe category:

Modify OU Modify the organization unit to which the VObject is attached. 
User may also need OU privileges Move to Object and Move 
from Object.

Read Only View information about the VObject.

Associate Associate the VObject with another object.

Dissociate Dissociate the VObject from another object.

Action Perform actions on a VObject. Some examples are start and 
stop. Also included are custom scripted actions.

Table 31-12 Privileges in the VObject category

VObject Privilege Description 

Table 31-13 Privileges in the Pframe category

PFrame Privilege Description 

Add Pframe to 
PFrameList

Add this Pframe to a VFrame’s PFrameList attribute value.

Delete Pframe from 
PframeList

Delete this Pframe from a VFrame’s PFrameList attribute value.

Freeze Pframe Freeze a Pframe.

Evacuate Pframe Evacuate a Pframe.

Unfreeze Pframe Unfreeze a Pframe.

Modify Pframe Modify the attributes of a Pframe.

Start Agent Start an agent on the Pframe.

Stop Agent Stop an agent from running on the Pframe.

Stop Pframe Stop the vcsoneclientd daemon from running on the Pframe.

Modify Capacity Modify the Capacity attribute of the Pframe.

Read Only View information about the Pframe. 

Modify OU Modify the organization unit to which the Frame is attached. 
User may also need OU privileges Move to Object and Move 
from Object.
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Catalog of Vframe privileges
Table 31-14 displays the privileges in the Vframe category:

Pframe Agent Dump 
FFDC

Allows the first failure data capture logs to dump on the 
Pframe.

Associate objects Associate a Pframe with a VObject

Dissociate objects Dissociate a Pframe with a VObject.

Table 31-13 Privileges in the Pframe category

PFrame Privilege Description 

Table 31-14 Privileges in the Vframe category

Vframe Privilege Description 

Online Vframe Bring a Vframe online on a Pframe.

Offline Vframe Take a Vframe offline on a Pframe.

Add to VFrameList Add this VFrame to a composite service group’s 
VframeList attribute. 

To add a VFrame to a composite service group, the user must 
have this privilege on the VFrame and the Modify CSG privilege 
on the composite service group.

Delete from VframeList Remove this VFrame from a composite service group’s 
VframeList attribute.

To delete a VFrame from a composite service group, the user 
must have this privilege on the VFrame and the Modify CSG 
privilege on the composite service group.

Switch Vframe Switch a Vframe between two Pframes.

Freeze Vframe Freeze a Vframe.

Unfreeze Vframe Unfreeze a Vframe.

Enable Vframe Enable a Vframe. A Vframe must be enabled before it can be 
used.

Disable Vframe Disable a Vframe. 

Clear Vframe Clear a fault on a frame.

Flush Vframe Flush a Vframe.
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Modify Vframe Modify attributes of a Vframe.

Clear Admin Wait Clear the admin wait condition from a Vframe.

Add Resource Add a resource to a Vframe.

Delete Resource Delete a resource from a Vframe.

Enable Resource Enable a resource for use on a Vframe.

Disable Resource Disable a resource for use on a Vframe.

Link Resource Link a resource to a Vframe.

Unlink Resource Unlink a resource from a Vframe.

Change Priority Change the Priority attribute value on a Vframe.

Change Load Change the Load value on a Vframe.

Change Fault Policy Change the fault policy of a Vframe.

Read Only View information about the frame.

Modify OU Modify the organization unit to which the Frame is attached. 
User may also need OU privileges Move to Object and Move 
from Object.

Link System Link a system object to a vframe object.

Unlink System Unlink a system object from a vframe object.

Associate Objects Associate a Vframe with a VObject

Dissociate Objects Dissociate a Vframe with a VObject.

Perform Action Perform actions on a frame. Some examples are start and stop. 
Also included are custom scripted actions.

Table 31-14 Privileges in the Vframe category

Vframe Privilege Description 
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Catalog of automation privileges
Table 31-15 displays the privileges in the Automation category. The 
ServerFarmObjectAdministrator role has all these privileges by default

Table 31-15 Privileges in the Automation category

Operation Description

Modify Rule Modify a business policy automation rule. This privilege does not 
include the ability to create a rule.

Execute Rule Execute a business policy automation rule.

Modify Job Modify a business policy automation job.

Execute Job Execute a business policy automation job.

Read Only View information about business policy automation rules and jobs 
in the OUPath over which the privilege has been assigned.

Take OwnerShip Assume the ownership of a rule.



Chapter
 32
Automated tasks reference

This chapter included the following topics:

■ About events

■ About rules

■ About jobs

■ About tasks
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About events
A single event triggers one or more rules. 

The event that triggers a rule can be one of the following types:

■ Policy Master (generated) event

These events are initiated by the Policy Master. Events can involve the 
following objects:

The actions taken can be proactive, such as directing a resource to go 
offline, or reactive, such as when a resource has faulted.

A complete list of events is available

See Table 32-1, “VCS One Cluster level events and associated parameters,” 
on page 771. 

■ Scheduled events

These events are initiated by the Business Policy Automation scheduler. 
These events are defined by a day, date, time of day, or range of time. The 
scheduler triggers these events.

Farm (Cluster) System

Service group Composite service group

PFrame VFrame

Organization unit Resource

User User group
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Policy Master events reference
Table 32-1 lists the events generated by the Policy Master, and the parameters 
that will be passed as arguments. These parameters are used to check 
pre-defined conditions before the job is run. They are also used as arguments to 
the tasks.

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed

CLUSTER_SECURITY_
PRINCIPAL_DELETE

E
R

R
O

R

The security principal 
from Symantec Product 
Authentication Service 
(AT) has been deleted.

1 CLUSTER_SECURITY_
PRINCIPAL_DELETE

2 PRPL_NAME

The name of the principal that is 
deleted.

3 DOMAIN_NAME

4 DOMAIN_TYPE

VAL_TECHNOLOGY_
DAEMON_CONNECTED

IN
FO

R
M

A
T

IO
N

A connection was 
established with the 
VAL daemon of type 
VTECH_TYPE.

1 VAL_TECHNOLOGY_
DAEMON_CONNECTED

2 VTECH_TYPE

The virtualization technology type, 
as determined by the cluster 
attribute VALTechnologies.

VAL_TECHNOLOGY_
DAEMON_
DISCONNECTED

IN
FO

R
M

A
T

IO
N

The virtualization 
access layer daemon 
lost connection with the 
virtualization 
management console.

1 VAL_TECHNOLOGY_
DAEMON_DISCONNECTED

2 VTECH_TYPE

The virtualization technology type, 
as determined by the cluster 
attribute VALTechnologies.

PM_STARTED

IN
FO

R
M

A
T

IO
N The Policy Master 

started up
1 PM_STARTED

2 SYS

Name of system where Policy Master 
has started

RCLUSTER_ADD

IN
FO

R
M

A
T

IO
N Remote cluster added 1 RCLUSTER_ADD

2 RCLUSTER
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RCLUSTER_DELETE

IN
FO

R
M

A
T

IO
N Remote VCS One cluster 

deleted
1 RCLUSTER_DELETE

2 RCLUSTER

RCLUSTER_LINK_
FAILOVER

W
A

R
N

IN
G

Remote VCS One cluster 
state changed to 
LINK_FAILOVER.

See “Cluster states in 
VCS One global 
clusters” on page 932.

1 RCLUSTER_LINK_FAILOVER

2 RCLUSTER

RCLUSTER_RUNNING

IN
FO

R
M

A
T

IO
N

Remote VCS One cluster 
state changed to 
RUNNING.

See “Cluster states in 
VCS One global 
clusters” on page 932.

1 RCLUSTER_RUNNING

2 RCLUSTER

RCLUSTER_EXITED

IN
FO

R
M

A
T

IO
N

Remote VCS One cluster 
state changed to EXITED.

See “Cluster states in 
VCS One global 
clusters” on page 932.

1 RCLUSTER_EXITED

2 RCLUSTER

RCLUSTER_FAULTED

E
R

R
O

R

Remote VCS One cluster 
state changed to 
FAULTED.

See “Cluster states in 
VCS One global 
clusters” on page 932.

1 RCLUSTER_FAULTED

2 RCLUSTER

RCLUSTER_
TRANSITIONING

W
A

R
N

IN
G Remote VCS One cluster 

state is TRANSITIONING

1 RCLUSTER_TRANSITIONING

2 RCLUSTER

System events

SYS_ADD

IN
FO

R
M

A
T

IO
N System added to VCS 

One cluster
1 SYS_ADD

2 SYS

3 PLAT

4 OUVPATH

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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SYS_DELETE

IN
FO

R
M

A
T

IO
N System deleted from 

VCS One cluster
1 SYS_DELETE

2 SYS

3 PLAT

4 OUVPATH

SYS_FREEZE

IN
FO

R
M

A
T

IO
N System frozen 1 SYS_FREEZE

2 SYS

3 PLAT

4 OUVPATH

SYS_UNFREEZE

IN
FO

R
M

A
T

IO
N System unfrozen 1 SYS_UNFREEZE

2 SYS

3 PLAT

4 OUVPATH

SYS_MOVE

IN
FO

R
M

A
T

IO
N

System moved to 
different Organization 
Tree node

1 SYS_MOVE

2 SYS

3 PLAT

4 OUVPATH

5 MOVE_FROM

6 MOVE_TO

SYS_EXITED

IN
FO

R
M

A
T

IO
N The vcsoneclient 
daemon is offline on 
this system.

1 SYS_EXITED

2 SYS

3 PLAT

4 OUVPATH

SYS_ATTR_CHANGE

IN
FO

R
M

A
T

IO
N

An attribute has 
changed on a system 
object.

1 SYS_ATTR_CHANGE

2 SYS

3 PLAT

4 OUVPATH

5 ATTRNAME

6 SCOPE

7 DIMENSION

8 DATATYPE

9 VALUE

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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SYS_RESTARTED_
HASHADOW

E
R

R
O

R

The vcsoneclient 
daemon has been 
restarted by the shadow

1 SYS_RESTARTED_HASHADOW

2 SYS

3 PLAT

4 OUVPATH

SYS_JOINED

IN
FO

R
M

A
T

IO
N System joined the VCS 

One cluster.
1 SYS_JOINED

2 SYS

3 PLAT

4 OUVPATH

SYS_DDNA

E
R

R
O

R

System is alive but the 
proxy is not running on 
the system. The state of 
the system is Daemon 
Dead Node Alive 
(DDNA)

1 SYS_DDNA

2 SYS

3 PLAT

4 OUVPATH

SYS_FAULTED

E
R

R
O

R

System has faulted 1 SYS_FAULTED

2 SYS

3 PLAT

4 OUVPATH

SYS_AGENT_FAULTED

E
R

R
O

R

Agent is faulted on the 
system

1 SYS_AGENT_FAULTED

2 SYS

3 PLAT

4 OUVPATH

5 AGENT

SYS_AGENT_RESTART

W
A

R
N

IN
G

Agent has restarted on 
the system

1 SYS_AGENT_RESTART

2 SYS

3 PLAT

4 OUVPATH

5 AGENT

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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SYS_SYSINFO_CHANGED

IN
FO

R
M

A
T

IO
N

System Sysinfo changed 1 SYS_SYSINFO_CHANGED

2 SYS

3 PLAT

4 OUVPATH

Path of the Organization unit value 
node.

5 KEY

6 OVAL

Old value

7 NVAL

New value

PFrame events

PFRAME_ADD

IN
FO

R
M

A
T

IO
N

PFrame added to VCS 
One cluster.

1 PFRAME_ADD

2 PFRAME

3 VTYPE

4 PLAT

5 OUVPATH

PFRAME_DELETE

IN
FO

R
M

A
T

IO
N PFrame deleted from 

VCS One cluster.
1 PFRAME_DELETE

2 PFRAME

3 PLAT

4 OUVPATH

PFRAME_FREEZE

IN
FO

R
M

A
T

IO
N PFrame frozen. 1 PFRAME_FREEZE

2 PFRAME

3 PLAT

4 OUVPATH

PFRAME_UNFREEZE

IN
FO

R
M

A
T

IO
N PFrame unfrozen. 1 PFRAME_UNFREEZE

2 PFRAME

3 PLAT

4 OUVPATH

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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PFRAME_MOVE

IN
FO

R
M

A
T

IO
N

PFrame moved to 
different Organization 
Tree node.

1 PFRAME_MOVE

2 PFRAME

3 PLAT

4 OUVPATH

5 MOVE_FROM

6 MOVE_TO

PFRAME_EXITED

IN
FO

R
M

A
T

IO
N The vcsoneclient 

daemon is offline on 
this PFrame.

1 PFRAME_EXITED

2 PFRAME

3 PLAT

4 OUVPATH

PFRAME_ATTR_CHANGE

IN
FO

R
M

A
T

IO
N

An attribute has 
changed on a PFrame.

1 PFRAME_ATTR_CHANGE

2 PFRAME

3 PLAT

4 OUVPATH

5 ATTRNAME

6 SCOPE

7 DIMENSION

8 DATATYPE

9 VALUE

PFRAME_RESTARTED_
HASHADOW

E
R

R
O

R

PFrame restarted by the 
shadow.

1 PFRAME_RESTARTED_HASHADOW

2 PFRAME

3 PLAT

4 OUVPATH

PFRAME_JOINED

IN
FO

R
M

A
T

IO
N PFrame came into the 

RUNNING state.
1 PFRAME_JOINED

2 PFRAME

3 PLAT

4 OUVPATH

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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PFRAME_DDNA

E
R

R
O

R

PFrame is alive but the 
proxy is not running on 
the PFrame. The state of 
the PFrame is Daemon 
Dead Node Alive 
(DDNA).

1 PFRAME_DDNA

2 PFRAME

3 PLAT

4 OUVPATH

PFRAME_FAULTED
E

R
R

O
R

PFrame has faulted. 1 PFRAME_FAULTED

2 PFRAME

3 PLAT

4 OUVPATH

PFRAME_AGENT_FAULTED

E
R

R
O

R

Agent is faulted on the 
PFrame.

1 PFRAME_AGENT_FAULTED

2 PFRAME

3 PLAT

4 OUVPATH

5 AGENT

PFRAME_AGENT_RESTART

W
A

R
N

IN
G

Agent has restarted on 
the PFrame.

1 PFRAME_AGENT_RESTART

2 PFRAME

3 PLAT

4 OUVPATH

5 AGENT

PFRAME_INFO_CHANGED

IN
FO

R
M

A
T

IO
N

Information key has 
changed for this 
PFrame.

1 PFRAME_INFO_CHANGED

2 PFRAME

3 PLAT

4 OUVPATH

Path of the Organization unit value 
node.

5 KEY

6 OVAL

Old value

7 NVAL

New value

Service group events

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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GRP_ADD

IN
FO

R
M

A
T

IO
N

Group added to VCS 
One cluster

1 GRP_ADD

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 CSG

GRP_DELETE

IN
FO

R
M

A
T

IO
N

Group deleted from VCS 
One cluster

1 GRP_DELETE

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 CSG

GRP_FREEZE

IN
FO

R
M

A
T

IO
N

Group frozen 1 GRP_FREEZE

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 CSG

GRP_UNFREEZE

IN
FO

R
M

A
T

IO
N

Group unfrozen 1 GRP_UNFREEZE

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 CSG

GRP_MOVE

IN
FO

R
M

A
T

IO
N

Group moved to differ-
ent Organization Tree 
node

1 GRP_MOVE

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 MOVE_FROM

7 MOVE_TO

8 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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GRP_FAULT

E
R

R
O

R

Service group has 
faulted

1 GRP_FAULT

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 CSG

GRP_ATTR_CHANGE

IN
FO

R
M

A
T

IO
N

Service group attribute 
changed.

1 GRP_ATTR_CHANGE

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 ATTRNAME

8 SCOPE

9 DIMENSION

10 DATATYPE

11 VALUE

12 CSG

GRP_INIT_ONLINE

IN
FO

R
M

A
T

IO
N

Service group online 
initiated

1 GRP_INIT_ONLINE

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 WHY

Use either POLICY (Policy Master) or 
MANUAL (User initiated) to denote 
the source of the online.

8 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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GRP_ONLINE

IN
FO

R
M

A
T

IO
N

Service group is online 1 GRP_ONLINE

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 CSG

GRP_INIT_OFFLINE

IN
FO

R
M

A
T

IO
N

Service group offline 
initiated

1 GRP_INIT_OFFLINE

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 WHY

Use either POLICY (Policy Master) or 
MANUAL (User initiated) to denote 
the source of the offline.

8 CSG

GRP_OFFLINE

IN
FO

R
M

A
T

IO
N

Service group is offline 1 GRP_OFFLINE

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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GRP_SWITCH

IN
FO

R
M

A
T

IO
N

Service group switching 
initiated

1 GRP_SWITCH

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 TOSYS

8 CSG

GRP_KICKOUT

W
A

R
N

IN
G

Service group is getting 
kicked out from a sys-
tem to allow high prior-
ity groups to come 
online

1 GRP_KICKOUT

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 HIPRIGRP

8 CSG

GRP_SWITCHING_LOAD_INC
REMENTED

E
R

R
O

R

Service group switching 
initiated due to 
increased load

1 GRP_SWITCHING_LOAD_
INCREMENTED

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 TOSYS

8 CSG

GRP_CONCURRENCY VIOLA-
TION

C
R

IT
IC

A
L

Service group is online 
on more than one sys-
tem

1 GRP_CONCURRENCY VIOLATION

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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GRP_ONLINE_
CANCELLED_POSSIBLE_
CONCURRENCY

C
R

IT
IC

A
L

Failed to bring a service 
group online due to pos-
sible concurrency viola-
tion

1 GRP_ONLINE_CANCELLED_POSSIBLE_
CONCURRENCY

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 CSG

GRP_NOFAILOVER

C
R

IT
IC

A
L

Service group could not 
failover to any other 
system in the VCS One 
cluster

1 GRP_NOFAILOVER

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 CSG

GRP_COMPATIBILITY_
VIOLATION

C
R

IT
IC

A
L

Service group compati-
bility violation detected

1 GRP_COMPATIBILITY_VIOLATION

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 CSG

GRP_LOAD_VIOLATION

C
R

IT
IC

A
L

Service group compati-
bility load detected

1 GRP_LOAD_VIOLATION

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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GRP_DEPENDENCY_
VIOLATION

C
R

IT
IC

A
L

Service group depen-
dency violation 
detected

1 GRP_DEPENDENCY_VIOLATION

2 GRP

3 PLAT

4 OUVPATH

5 PRIORITY

6 SYS

7 CSG

Composite service group events

CSG_ADD

IN
FO

R
M

A
T

IO
N Composite service 

group is added
1 CSG_ADD

2 CSG

3 OUVPATH

CSG_ATTN

E
R

R
O

R

Composite service 
group flagged to denote 
it requires user 
attention.

1 CSG_ATTN

2 CSG

3 OUVPATH

CSG_ATTN_REMOTE

E
R

R
O

R

Composite service 
group flagged to denote 
it requires user 
attention in the remote 
VCS One cluster.

1 CSG_ATTN_REMOTE

2 CSG

3 RCLUSTER

CSG_DELETE

IN
FO

R
M

A
T

IO
N Composite service 

group is deleted
1 CSG_DELETE

2 CSG

3 OUVPATH

CSG_ONLINE

IN
FO

R
M

A
T

IO
N Composite service 

group is online
1 CSG_ONLINE

2 CSG

3 OUVPATH

CSG_ONLINE_REMOTE

IN
FO

R
M

A
T

IO
N Composite 

service group is online 
on the remote VCS One 
cluster

1 CSG_ONLINE_REMOTE

2 CSG

3 RCLUSTER

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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CSG_OFFLINE

IN
FO

R
M

A
T

IO
N Composite service 

group is offline
1 CSG_OFFLINE

2 CSG

3 OUVPATH

CSG_OFFLINE_REMOTE

IN
FO

R
M

A
T

IO
N Remote composite 

service group is offline
1 CSG_OFFLINE_REMOTE

2 CSG

3 RCLUSTER

CSG_MOVE

IN
FO

R
M

A
T

IO
N

Composite service 
group moves in the 
organization tree

1 CSG_MOVE

2 CSG

3 OUVPATH

4 MOVE_FROM

5 MOVE_TO

CSG_ATTR_CHANGE

IN
FO

R
M

A
T

IO
N

Modification of a 
composite service group 
attribute

1 CSG_ATTR_CHANGE

2 CSG

3 OUVPATH

4 ATTRNAME

5 SCOPE

6 DIMENSION

7 DATATYPE

8 VALUE

CSG_CONCURRENCY_
VIOLATION

C
R

IT
IC

A
L Composite service 

group has a 
concurrency violation

1 CSG_CONCURRENCY_
VIOLATION

2 CSG

CSG_PARTIAL

IN
FO

R
M

A
T

IO
N Composite 

service group in partial 
state

1 CSG_PARTIAL

2 CSG

3 OUVPATH

CSG_PARTIAL_REMOTE

IN
FO

R
M

A
T

IO
N Remote composite 

service group in partial 
state

1 CSG_PARTIAL_REMOTE

2 CSG

3 RCLUSTER

Virtual machine events

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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VFRAME_ADD

IN
FO

R
M

A
T

IO
N

Virtual machine added 
to VCS One cluster.

1 VFRAME_ADD

2 VFRAME

3 VTYPE

4 PLAT

5 OUVPATH

6 PRIORITY

7 CSG

VFRAME_DELETE

IN
FO

R
M

A
T

IO
N

Virtual machine deleted 
from VCS One cluster.

1 VFRAME_DELETE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 CSG

VFRAME_FREEZE

IN
FO

R
M

A
T

IO
N

Virtual machine frozen. 1 VFRAME_FREEZE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 CSG

VFRAME_UNFREEZE

IN
FO

R
M

A
T

IO
N

Virtual machine 
unfrozen.

1 VFRAME_UNFREEZE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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VFRAME_MOVE

IN
FO

R
M

A
T

IO
N

Virtual machine moved 
to different Organiza-
tion Tree node.

1 VFRAME_MOVE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 MOVE_FROM

7 MOVE_TO

8 CSG

VFRAME_FAULT

E
R

R
O

R

Virtual machine has 
faulted.

1 VFRAME_FAULT

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

VFRAME_ATTR_CHANGE

IN
FO

R
M

A
T

IO
N

Virtual machine 
attribute changed.

1 VFRAME_ATTR_CHANGE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 ATTRNAME

8 SCOPE

9 DIMENSION

10 DATATYPE

11 VALUE

12 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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VFRAME_INIT_ONLINE

IN
FO

R
M

A
T

IO
N

Virtual machine online 
initiated.

1 VFRAME_INIT_ONLINE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 WHY

Use either POLICY (Policy Master) or 
MANUAL (User initiated) to denote 
the source of the online.

8 CSG

VFRAME_ONLINE

IN
FO

R
M

A
T

IO
N

Virtual machine is 
online.

1 VFRAME_ONLINE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

VFRAME_INIT_OFFLINE

IN
FO

R
M

A
T

IO
N

Virtual machine offline 
initiated.

1 VFRAME_INIT_OFFLINE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 WHY

Use either POLICY (Policy Master) or 
MANUAL (User initiated) to denote 
the source of the offline.

8 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it
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VFRAME_OFFLINE

IN
FO

R
M

A
T

IO
N

Virtual machine is 
offline.

1 VFRAME_OFFLINE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

VFRAME_SWITCH

IN
FO

R
M

A
T

IO
N

Virtual machine 
switching initiated.

1 VFRAME_SWITCH

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 TOPFRAME

8 CSG

VFRAME_MIGRATE

IN
FO

R
M

A
T

IO
N

Virtual machine 
migration initiated.

1 VFRAME_MIGRATE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 TOPFRAME

8 CSG

VFRAME_MIGRATE_FAILED

E
R

R
O

R

Virtual machine 
migration failed.

1 VFRAME_MIGRATE_FAILED

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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VFRAME_MIGRATE_
COMPLETE

IN
FO

R
M

A
T

IO
N

Virtual machine 
migration request 
accepted by vCenter 
Server. 

This event does not 
indicate a successful 
migration to the target 
PFrame.

See “Switching a 
VFrame between 
PFrames” on page 530.

1 VFRAME_MIGRATE_COMPLETE

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

VFRAME_KICKOUT

W
A

R
N

IN
G

Virtual machine is 
getting kicked out from 
a PFrame to allow high 
priority virtual 
machines to come 
online.

1 VFRAME_KICKOUT

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 HIPRIVFRAME

8 CSG

VFRAME_SWITCHING_LOAD
_INCREMENTED

E
R

R
O

R

Virtual machine 
switching initiated due 
to increased load.

1 VFRAME_SWITCHING_LOAD_
INCREMENTED

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 TOPFRAME

8 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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VFRAME_CONCURRENCY 
VIOLATION

C
R

IT
IC

A
L

Virtual machine is 
online on more than 
one PFrame.

1 VFRAME_CONCURRENCY 
VIOLATION

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

VFRAME_ONLINE_
CANCELLED_POSSIBLE_
CONCURRENCY

C
R

IT
IC

A
L

Failed to bring a virtual 
machine online due to 
possible concurrency 
violation.

1 VFRAME_ONLINE_CANCELLED_
POSSIBLE_CONCURRENCY

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

VFRAME_NOFAILOVER

C
R

IT
IC

A
L

Virtual machine could 
not failover to any other 
PFrame in the VCS One 
cluster.

1 VFRAME_NOFAILOVER

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 CSG

VFRAME_COMPATIBILITY_ 
VIOLATION

C
R

IT
IC

A
L

Virtual machine 
compatibility violation 
detected.

1 VFRAME_COMPATIBILITY_VIOLATION

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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VFRAME_LOAD_VIOLATION

C
R

IT
IC

A
L

Virtual machine 
compatibility load 
detected.

1 VFRAME_LOAD_VIOLATION

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

VFRAME_DEPENDENCY_
VIOLATION

C
R

IT
IC

A
L

Virtual machine 
dependency violation 
detected.

1 VFRAME_DEPENDENCY_VIOLATION

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 CSG

VFRAME_RESERVATION_INI
TIATED

IN
FO

R
M

A
T

IO
N

Reservation for virtual 
machine initiated.

RES-TYPE-KEY is CPU 
or MEM

1 VFRAME_RESERVATION_INITIATED

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 RES-TYPE-KEY 

8 CSG

VFRAME_RESERVATION_FAI
LED

E
R

R
O

R

Reservation for virtual 
machine failed.

RES-TYPE-KEY is CPU 
or MEM

1 VFRAME_RESERVATION_FAILED

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 RES-TYPE-KEY 

8 CSG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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VFRAME_RESERVATION_SU
CCESS

IN
FO

R
M

A
T

IO
N

Reservation for virtual 
machine successful.

RES-TYPE-KEY is CPU 
or MEM

1 VFRAME_RESERVATION_SUCCESS

2 VFRAME

3 PLAT

4 OUVPATH

5 PRIORITY

6 PFRAME

7 RES-TYPE-KEY 

8 CSG

Resource events

RES_STATE_UNKNOWN

E
R

R
O

R

Resource state is 
unknown

1 RES_STATE_UNKNOWN

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

RES_MONITOR_IMEOUT

E
R

R
O

R

Resource monitor timed 
out

1 RES_MONITOR_TIMEOUT

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

RES_OFFLINE_
INEFFECTIVE

E
R

R
O

R

Offline ineffective for 
the resource

1 RES_OFFLINE_INEFFECTIVE

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it
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RES_RESTARTING

E
R

R
O

R

Resource is restarting 1 RES_RESTARTING

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

RES_AUTO_ONLINE

W
A

R
N

IN
G

Resource went online 
outside VCS One control

1 RES_AUTO_ONLINE

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

RES_FAULT

E
R

R
O

R

Resource has faulted 1 RES_FAULT

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

RES_ADMIN_WAIT

E
R

R
O

R

Resource is in 
ADMIN_WAIT state

1 RES_ADMIN_WAIT

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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AGENT_GEN_SNMP

C
R

IT
IC

A
L

Agent for the resource 
has generated notifica-
tion

1 AGENT_GEN_SNMP

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

8 AGENTMSG

RESOURCE_MONITOR_
TIME_CHANGED

W
A

R
N

IN
G

The time taken for exe-
cution of monitor entry 
point for resource has 
changed

1 RESOURCE_MONITOR_TIME_
CHANGED

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

8 INFO

RES_STATE_CHANGE

IN
FO

R
M

A
T

IO
N

Resource underwent a 
state transition on the 
system. 

Note: To generate the 
RES_STATE_CHANGE 
event, make sure the 
group level attribute, 
TriggerResStateChange, 
is set to 1.

1 RES_STATE_CHANGE

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

8 ARG

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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RES_ATTR_CHANGE

IN
FO

R
M

A
T

IO
N

Resource attribute 
changed

1 RES_ATTR_CHANGE

2 RES

3 GRP

4 TYPE

5 PLAT

6 OUVPATH

7 SYS

8 ATTRNAME

9 SCOPE

10 DIMENSION

11 DATATYPE

12 VALUE

User, User group, Organization Tree, Extended Attribute events

USER_MOVE

IN
FO

R
M

A
T

IO
N

User moved to new 
Organization Tree node

1 USER_MOVE

2 USER

3 OUVPATH

4 MOVE_FROM

5 MOVE_TO

USERGROUP_MOVE

IN
FO

R
M

A
T

IO
N

User group moved to 
new Organization Tree 
node

1 USERGROUP_MOVE

2 USER

3 OUVPATH

4 MOVE_FROM

5 MOVE_TO

OUNAME_ADD

IN
FO

R
M

A
T

IO
N Organization unit name 

node added to 
Organization tree

1 OUNAME_ADD

2 OUNPATH

OUNAME_DELETE

IN
FO

R
M

A
T

IO
N Organization unit name 

node deleted from 
Organization tree

1 OUNAME_DELETE

2 OUNPATH

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed
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About rules
A rule can be a business rule or a notification rule.

A rule is triggered by an event and executes a job. Events are not part of a 
workflow; the order of job execution may not be the same as the order of the 
events that invoke the job. However, multiple tasks associated with a job are 
executed in sequence.

Using notification rules you can specify email, SNMP and syslog notifications.

Rules are not user-private. All users that have read privileges of rules can view 
all rules configured in the VCS One cluster.

A rule has the following components:

OUVALUE_ADD

IN
FO

R
M

A
T

IO
N Organization unit value 

node added to 
Organization tree

1 OUVALUE_ADD

2 OUVPATH

OUVALUE_DELETE

IN
FO

R
M

A
T

IO
N Organization unit value 

node deleted from
Organization tree

1 OUVALUE_DELETE

2 OUVPATH

EA_ADD

IN
FO

R
M

A
T

IO
N Extended attribute 

added to VCS One 
cluster

1 EA_ADD

2 OUVPATH

3 EA

4 EATYPE

EA_DELETE

IN
FO

R
M

A
T

IO
N Extended attribute 

deleted from VCS One 
cluster

1 EA_DELETE

2 OUVPATH

3 EA

4 EATYPE

Table 32-1 VCS One Cluster level events and associated parameters

Event

S
ev

er
it

y Description Parameters Passed

Rule name User-selected name of the rule. A valid name starts with an 
alpha character and has no special characters or white space.

Trigger using The type of event that triggers the rule to run. Policy Master 
event or schedule event.
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More information is available about privileges for rules.

See “Catalog of automation privileges” on page 768. 

Rule conditions reference
Within the rule definition, you can define conditions to evaluate before the job is 
executed. A condition is created in the form of a condition expression, and can 
be one of the following types:

Rule description Description of the rule.

Rule organization unit 
node path

The node in the Organization Tree that defines the objects in 
the Organization Tree affected by the rule. 

Creator User that created the rule.

Owner Rule owner can be the rule creator or any of the user groups to 
which the creator belongs. The rule is run using the privileges 
associated with the owner.

Quiet time Controls how often a rule may be triggered for the same object 
and the same event.

The number of seconds to wait after the rule has been 
triggered, and before the rule may be triggered again for the 
same object and the same event. 

Enabled If true the rule will run, if not true the rule will not run.

Event criteria The event criteria changes depending on the type of event:

Policy Master event: Defines the list of objects and organization 
unit nodes on which the event will occur.

Schedule event: Defines the date and time the event will occur.

Condition set This field allows you to define a set of conditions to evaluate 
before the job executes. The rule can be attribute based or time 
based.

See “Rule conditions reference” on page 797.

Job to execute Job name to execute

Schedule based condition Use schedule-based conditions to define a time for a Policy 
Master event. 

The condition is defined by being before or after a hour, minute 
and date. The time refers to the time on the Policy Master 
system.
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Multiple conditions are implicitly joined with the AND operator.

About jobs
A Job is associated with one or more rules. Jobs are executed automatically 
through pre-configured rules or manually through the console. You can not 
execute a job through the command line.

A job has an associated OUpath. Execution of a job can not access any objects 
outside of the scope of the OU path. The scope of the OUPath includes the 
OUnode and all nodes below that node in the Organization Tree. It does not 
include nodes above or adjacent to the node.

A user must have the Execute Job privilege to execute a job. A user must also 
have appropriate privileges to execute both the tasks in the job and the job itself.

Jobs are not user-private. A job is visible to all users on its OU node and above 
that have read privileges of business policy automation.

See “Catalog of automation privileges” on page 768.

Components of a job
A Job consists of one or more tasks, and has the following components:

Attribute-based condition The attribute name can only be a scalar global attribute or 
extended attribute. Use attribute-based conditions to check of 
one of the following attribute values: 

■ Object type: Checks if the object is of type System or 
Group

■ Object type: Checks if the object is of type System, Group, 
or Frame.

■ Object name: Can be a specific system or group object 
name, or it could be a variable (explicit object or event 
object.)

■ Condition - Operator (equal to or not equal to) - Value 
condition.

Job name User-selected name of the job.

Job description Description of the job. Can be 1024 characters.

Job organization unit 
node path

The node in the Organization Tree that defines the objects 
associated with the job.

This OUpath defines the objects in the Organization Tree affected 
by the job.
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More information is available about privileges for jobs.

See “Catalog of automation privileges” on page 768. 

Privileges of a job
The tasks associated with a job are executed with the privileges of the user who 
owns the job. 

Manual job execution
VCS One checks if the user has the EXECUTE_JOB privilege for the job, as well as 
sufficient privileges for each task in the job.

Automated job execution
The job will be executed by the user in the context of the rule’s owner.

Only the rule’s owner explicit privileges will be used to execute the job. The 
owner’s user group privileges will not be considered.

About tasks
Tasks are the actions taken in the VCS One cluster as the result of an event. 
Tasks do not exist alone; they are always part of a job. The list of available tasks 
are pre-defined and not user-editable. 

One of the following actions is the result of a task:

■ A VCS One command runs

■ An email is sent

■ A script runs

■ A syslog notification

Each task has input parameters that provide information about the object(s) 
associated with the task. 

The input parameters are configured during definition of the job.

List of tasks The list of tasks that the job executes
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Table 32-2 lists the predefined tasks actions, description, and input parameters 
for each available action.

Table 32-2 Predefined task actions and required task parameters

Task action Task description Parameters

SCRIPT Execute script 1 SCRIPTNAME

2 ARGS

3 USEEVENT

SSHSCRIPT Execute script using SSH 1 SCRIPTNAME

2 ARGS

3 USEEVENT

4 USER

5 HOST

6 GRPHOST

7 AUTH 

8 PASSWORD

9 PASSPHRASE

10 PRIVATEKEY

SEND_MAIL Send Mail 1 ADDRESS

2 SUB

3 BODY

4 USE_OWNER_SNMP

SNMP_TRAP Send an SNMP trap 1 CONSOLES

2 USE_OWNER_SNMP

SYSLOG Send Syslog 1 HOSTS

2 MESSAGES

3 PREFIX_EVENT_MESSAGE

HACOMMAND Execute ha-command

Note: Not all ha-commands are supported. 
Use the validate option in the Task Details 
page when you configure the details of the 
task to confirm whether a command is 
valid and supported. 

See “Creating a job” on page 466.

1 COMMAND
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CSG_ONLINE Bring composite service group online 1 CSG

Composite service group name

CSG_OFFLINE Take composite service group offline 1 CSG

Composite service group name

GRP_ONLINE Bring service group online 1 GRP

Group name

2 SYS

Target system to online the group

3 EVACLOWPRI

4 PROPAGATE

GRP_OFFLINE Take service group offline 1 GRP

Group name

2 SYS

System to offline the group from

3 PROPAGATE

GRP_ADDSYS_TO_
SYSLIST

Add system to SystemList attribute 1 GRP

Group name

2 SYS

3 PROPAGATE

GRP_FREEZE Freeze service group 1 GRP

Group name

2 PROPAGATE

GRP_SETPRI Set Service Group Priority 1 GRP

Group name

2 PRI

Value to set the group’s Priority 
attribute

3 PROPAGATE

SYS_FREEZE Freeze system 1 SYS

2 EVACUATE

START_FRAME Start frame 1 FRAME

STOP_FRAME Stop frame 1 FRAME

Table 32-2 Predefined task actions and required task parameters

Task action Task description Parameters



802 Automated tasks reference
About tasks
Privileges of a task
When using the Script task, the user running the task must have VCS One 
cluster level EXECUTE_SCRIPT privileges. The script is executed as the root 
user on the Policy Master node.

MIGRATE_FRAME Migrate frame 1 FRAME

2 TARGETFRAME

REFRESH_SYSTEMLIST Refresh SystemList attribute 1 GRP

GRP_STATE_WAIT Group state wait 1 GRP

2 SYS

3 STATE

SYS_STATE_WAIT System state wait 1 SYS

2 STATE

RES_STATE_WAIT Resource state wait 1 RES

2 SYS

3 STATE

FRAME_STATE_WAIT Frame state wait 1 VFRAME

2 PFRAME

3 STATE

Table 32-2 Predefined task actions and required task parameters

Task action Task description Parameters
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This chapter includes the following topics:

■ About the VCS One configuration in XML

■ Building blocks of an XML configuration file

■ The main.xml file format

■ Sample main.xml configuration file

■ The bpa.xml file format

■ Sample bpa.xml configuration file

■ The prefs.xml file
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About the VCS One configuration in XML
The VCS One configuration in XML format is provided in the following files. The 
XML configuration files are by default below the
$VCSONE_CONF/conf/directory.

■ main.xml — contains the VCS One object instances like service group, 
systems, etc. and their attributes.

■ types.xml — contains the bundled agent definitions

■ vtypes.xml — contains the virtualization access layer (VAL) related 
definitions.

■ bpa.xml — contains definitions of business rules, notification rules, and jobs. 

■ prefs.xml — contains the user interface preferences and custom view 
definitions. 

■ main.dtd — reveals the schema and syntax of the main.xml. Make sure you 
include this in the beginning of the main.xml file:

<!DOCTYPE config SYSTEM main.dtd>

■ types.dtd — reveals the schema and syntax of the types.xml. Make sure you 
include this in the beginning of types.xml file:

<!DOCTYPE config SYSTEM types.dtd>

■ vtypes.dtd — reveals the schema and syntax of the vtypes.xml file. Make 
sure you include the following line in the beginning of the vtypes.xml file.

<!DOCTYPE config SYSTEM vtypes.dtd>

■ orgtree.dtd — reveals the schema and syntax of the orgtree.xml file. Make 
sure you include the following line in the beginning of the orgtree.xml file.

<!DOCTYPE config SYSTEM orgtree.dtd>

Building blocks of an XML configuration file
Following are some of the major building blocks of an VCS One XML 
configuration file:

Attribute definition
An attribute definition in an XML file looks like the following:

<attributes name=“PathName” type=“str” dimension=“scalar”>
<must_configure>1</must_configure>
<editable>1</editable>
<default><scalar>/tmp/foo</scalar></default>

</attributes>
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Attribute instance
An attribute instance in an XML file looks like the following:

<attribute name=“PathName”>
<scalar>”/tmp/test_res”</scalar>

</attribute>

Object instance
An object instance in an XML file looks like the following:

<group name=“Test_Group”>
<attributes>

<attribute name=“SystemList”>
<val name=“prod_sys1”>0</val>
<val name=“prod_sys2”>1</val>

</attribute>
</attributes>
<resources>

<resource name=“Test_Res” type=“FileOnOff”>
<attribute name=“Pathname”>

<scalar>”/tmp/test_res</scalar>
</attribute>

</resource>
...........more resources…….
<link parent=“Test_Res1” child=“TestRes2”/>

</resources>
</group>

The above example depicts a service group definition. Other object definitions 
like clusters, systems, etc. will be similar.

Group dependency
A group dependency in a XML file looks like the following:

<group name=“Test_Group1”>
..........

</group>
<group name=“Test_Group2>

..........
<requires>

<child>”Test_grp1”</child>
<kind>”hard”</kind>
<location>”local”</location>

</requires>
</group>

The main.xml file format
The main.xml file has include clauses along with definitions for the cluster, 
systems, service groups, and resources. It also includes service group and 
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resource dependency clauses. The following outlines the format of the main.xml 
file.

Include clauses
Include clauses provide a modular approach to allow additional configuration 
files to be incorporated into the main.xml file. The types.<platform>.xml file, 
which contains resource type definitions, is always an include clause in the 
main.xml file. Additional include clauses are typically required for the 
configuration files of custom agents. For example:

<include>”types.linux.xml”</include>
<include>”OracleTypes.xml”</include>

Cluster definition
Defines the attributes of the VCS One cluster, including the cluster name and 
the names of the users. For example:

<cluster name=“Test_clus”>
...... // Attributes

</cluster>

System definition
Specifies the name of each system in the VCS One cluster. The system names 
must match the one returned by the hostname command. 

Pframe definition
Define the name of each physical systems that can host virtual machines 
(pframes) in the VCS One cluster. The pframe names must match the one 
returned by the hostname command. Note that the pframe uses the same name 
space as the system definition.

Service group definition
This section of the file defines the following name, attributes, resources and 
dependencies of the service group:

■ Service group name and attributes

The VCS One cluster wide unique name of the service group and service 
group level attributes are defined first. The following is an example of the 
definition of the service group attribute SystemList, which designates all 
systems on which a service group can come online.
<group name=“Test_Group1”>
......// Attributes / Resources / Dependencies.
</group>
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The following example configures the SystemList attribute for the service 
group to be able to come online on SystemA, SystemB and SystemC. 
<SystemList>

<val key="SystemA"></val>
<val key="SystemB"></val>
<val key="SystemC"></val>

</SystemList>

■ Resources defined

Defines each resource used in the group. Resources can be added in any 
order. 

■ Service Group Dependency Clause

Defines dependencies between this service group and another. The keyword 
“requires” indicates a service group dependency. The following is an XML 
example of the section of the service group definition where the type of the 
service group dependency is defined. This example is of an local hard 
service group dependency.
<requires>

<group>foo</group>
<kind>hard</kind>
<location>local</location>

■ Resource Dependency Clause

A dependency between resources is indicated by the keyword “link” 
followed by the parent resource name and then the child resource name. For 
example:
<link parent=”vol1” child=”dg1” />

Resource dependencies indicate the child resource must be online before 
the parent resource can be brought online, and conversely, the parent must 
be offline before the child can be taken offline. To override this behavior, 
use the
-ignoreparent option of the hares -offline command.

Vframe definition
This section of the file defines the following virtual machine name, attributes, 
resources, and dependencies of the vframe:

■ Virtual machine name, type, linked system, and attributes

The VCS One cluster-wide unique name of the vframe and vframe-level 
attributes are defined first. The following is an example of the definition of 
the vframe attribute SystemList, which designates all pframes on which a 
vframe can come online. In this example virtual machine vm1 is of type 
ESXVM and vm1_sys is the object that is associated with it.
<vframe name="vm1" vtype="ESXVM">
......// Attributes / Resources / Dependencies.
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</vframe>

The following example configures the SystemList attribute for the service 
group to be able to come online on esxhost1 and esxhost2. 
<attribute name="SystemList">

<val key="esxhost1">0</val>
<val key="esxhost2">1</val>

</attribute>

■ Name space

Note that the vframe uses the same name space as the service group 
definition.

Sample main.xml configuration file
<!DOCTYPE config SYSTEM "main.dtd">
<config>

<include>types.linux.xml</include>
<include>types.sun.xml</include>
<include>types.win.xml</include>
<include>vtypes.xml<include>

<!-- Cluster Definition.-->
<cluster name="Test_Cluster1">

<attributes>
<!-- Scalar attribute. -->

<attribute name="ClusterAddress"> 
<scalar>192.168.0.2</scalar>

</attribute>
<!-- Recommended attribute. Should specify this.-->

<attribute name="DefaultPlatform"> 
<scalar>linux/x86</scalar>

</attribute>
</attributes>

</cluster>

<!-- Vobject Definition.-->
<vobject name="vc1" vtype="VMwareVC">

<attributes>
</attributes>

</vobject

<!-- System Definitions.-->
<system name="photon">
        <attributes>
        </attributes>
</system>
<system name="meson">
        <attributes>
        </attributes>
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</system>

<!-- Pframe definitions. -->
<pframe name="esxhost1" vtypes="ESX" associatedvobjs="vc1">

<attributes>
</attributes>

</pframe>

<!-- Group definitions. -->
<group name="GroupOne">
        <attributes>

<!-- Association attribute. -->
                <attribute name="SystemList">
                        <val key = "photon">0</val>
                        <val key = "meson">0</val>
                </attribute>
        </attributes>

<!-- Group's resources.     -->
        <resources>

<!-- Resource attribute.    -->
<resource name = "Test_fileonoff1" type = "FileOnOff">

<!-- Localised attribute.   -->
<attribute name = "PathName" context = "photon">

<scalar>"/tmp/foo"</scalar>
</attribute>

</resource>
        </resources>
</group>
<group name="VCS">
        <attributes>
                <!-- Association attribute. -->

<attribute name="SystemList">
<val key = "photon">0</val>
<val key = "meson">0</val>

</attribute>
        </attributes>

<!-- Group's resources. -->
        <resources>

<!-- Resource attribute. -->
<resource name = "Test_fileonoff2" type = "FileOnOff">

<!-- Localised attribute.   -->
<attribute name = "PathName" context = "photon">

<scalar>"/tmp/foo1"</scalar>
</attribute>

</resource>
        </resources>

<requires>
<child>”Veritas Cluster Server One”</child>
<kind>”hard”</kind>
<location>”local”</location>
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</requires>
</group>
<vframe name="vm1" vtype="ESXVM" linksys="vm1_sys" 
associatedvobjs="vc1">

<attributes>
<attribute name="SystemList">

<val key="esxhost1">0</val>
<val key="esxhost2">1</val>

</attribute>
</attributes>

</vframe>
</config>

The bpa.xml file format
This file includes definitions of business rules, notification rules, and jobs. It 
resides in the ext directory. The ext directory is a subdirectory of the directory 
where main.xml is present.

Business rule definition
Defines properties of a business rule such as event selection criteria, object type, 
and associate-job. 
<rule enabled="true" event_type="1" isusergrp="false" 
name="sysrule" object_type="SYSTEM" ou="/VCSOneCO=Marketing" 
owner="simuser@domain" quiet_time="0">

<description></description>
<object_selection type="LIST">mktg_linsys6</object_selection>
<event_selection type="ALL"></event_selection>
<associated-job name="sysjob"/>

</rule>

Job Definition
Defines properties of the business rule such as organization unit and tasks.
<job name="sysjob" ou="/VCSOneCO=Marketing">

<description></description>
<task halt_on_error="true" timeout="5" type="GRP_SETPRI" 
wait="0">

<param name="%GRP">websvr6</param>
<param name="%PRI">5</param>
<param name="%PROPAGATE">false</param>

</task>
<task halt_on_error="true" timeout="5" type="SCRIPT" wait="0">

<param name="%ARGS">{Event parameters}</param> 
<param name="%SCRIPTNAME">backup.sh</param> 
<param name="%USEEVENT">true</param> 

</task>
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</job>

Notification rule definition
Defines various properties of notification rule such as event selection criteria, 
object type, and notification tasks.
<notification_rule enabled="true" event_type="1" isusergrp="false" 
name="NR1" object_type="GROUP" ou="/" owner="simuser@domain" 
quiet_time="0">

<description></description>
<object_selection type="ALL">Customers="CellStop"</
object_selection>
<event_selection type="ALL"></event_selection>
<task halt_on_error="false" timeout="1000" type="SEND_MAIL" 
wait="0">

<param name="%ADDRESS">admin@wirelessdept.com</param>
<param name="%USE_OWNER_EMAIL">false</param>

</task>
<task halt_on_error="false" timeout="1000" type="SNMP_TRAP" 
wait="0">

<param name="%CONSOLES">sol_openview</param>
<param name="%USE_OWNER_SNMP">false</param>

</task>
<task halt_on_error="false" timeout="1000" type="SYSLOG" 
wait="0">

<param name="%HOSTS">sol_syscollector</param>
</task>

</notification_rule>

Automation Settings
Defines various notification settings.
<settings SmtpFromPath="VCSOne-Notifier" SmtpReturnPath="" 
SmtpServer="" SecondarySmtpServer="" SmtpServerTimeout="10" 
SmtpWebconsole="" SnmpCommunity="public" MaxEmail="100" 
SnmpTrapPort="162" DefaultSnmpConsole="" EnableScript="0" 
EnableSmtp="0" EnableSnmp="0" EnableSyslog="0" 
BusinessEvalMaxThreads="10" BusinessEvalMinThreads="5" 
BusinessEvalQueueSize="100" DefaultTaskMaxThreads="10" 
DefaultTaskMinThreads="5" DefaultTaskQueueSize="100" 
EmailTaskMaxThreads="1" EmailTaskMinThreads="1" 
EmailTaskQueueSize="500" ExecutorMaxThreads="10" 
ExecutorMinThreads="5" ExecutorQueueSize="100" 
NotificationEvalMaxThreads="1" NotificationEvalMinThreads="1" 
NotificationEvalQueueSize="500" SNMPTaskMaxThreads="1" 
SNMPTaskMinThreads="1" SNMPTaskQueueSize="500" 
ScriptTaskMaxThreads="20" ScriptTaskMinThreads="10" 
ScriptTaskQueueSize="500" SleepThreads="2" SyslogTaskMaxThreads="1" 
SyslogTaskMinThreads="1" SyslogTaskQueueSize="500" 
TimeoutThreads="2"/>
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Sample bpa.xml configuration file
<bpa>

<!------ Job Definition ---------->
<job name="provisionJob" ou="/">

<description></description>
<task halt_on_error="true" timeout="5" type="SCRIPT" 
wait="10">      

<param name="%ARGS">{Event parameters}</param>
<param name="%SCRIPTNAME">provision.sh</param>
<param name="%USEEVENT">true</param>

</task>
<task halt_on_error="true" timeout="5" type="SEND_MAIL" 
wait="10">

<param name="%ADDRESS">admin@corp.com</param>
<param name="%SUB">Provision Completed</param>
<param name="%BODY">For application @{x}</param>

</task>
</job>

<!------ Business Rule Definition ---------->
<rule enabled="true" event_type="1" isusergrp="false" 
name="ProvisionRule" object_type="GROUP" ou="/" 
owner="simuser@domain" quiet_time="0">

<description></description>
<object_selection type="LIST">Corp-Apache-App</
object_selection>
<event_selection type="LIST">GRP_NOFAILOVER</
event_selection>
<associated-job name="provisionJob">

<variable name="@{x}">Event.GRP</variable>
</associated-job>

</rule>

<!------ Notification Rule Definition ---------->
<notification_rule enabled="true" event_type="1" 
isusergrp="false" name="NotifySysFault" object_type="SYSTEM" 
ou="/" owner="simuser@domain" quiet_time="0">

<description></description>
<object_selection type="ALL">/</object_selection>
<event_selection type="LIST">SYS_FAULTED$SYS_DDNA</
event_selection>
<task halt_on_error="false" timeout="1000" type="SEND_MAIL" 
wait="0">

<param name="%ADDRESS">admin@corp.com</param>
<param name="%USE_OWNER_EMAIL">false</param>

</task>
<task halt_on_error="false" timeout="1000" type="SNMP_TRAP" 
wait="0">

<param name="%CONSOLES">openviewsys</param>
<param name="%USE_OWNER_SNMP">false</param>
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</task>
</notification_rule>

<!------ Automation Settings ---------->
<settings SmtpFromPath="VCSOne-Notifier" SmtpReturnPath="" 
SmtpServer="" SecondarySmtpServer="" SmtpServerTimeout="10" 
SmtpWebconsole="" SnmpCommunity="public" MaxEmail="100" 
SnmpTrapPort="162" DefaultSnmpConsole="" EnableScript="0" 
EnableSmtp="0" EnableSnmp="0" EnableSyslog="0" 
BusinessEvalMaxThreads="10" BusinessEvalMinThreads="5" 
BusinessEvalQueueSize="100" DefaultTaskMaxThreads="10" 
DefaultTaskMinThreads="5" DefaultTaskQueueSize="100" 
EmailTaskMaxThreads="1" EmailTaskMinThreads="1" 
EmailTaskQueueSize="500" ExecutorMaxThreads="10" 
ExecutorMinThreads="5" ExecutorQueueSize="100" 
NotificationEvalMaxThreads="1" NotificationEvalMinThreads="1" 
NotificationEvalQueueSize="500" SNMPTaskMaxThreads="1" 
SNMPTaskMinThreads="1" SNMPTaskQueueSize="500" 
ScriptTaskMaxThreads="20" ScriptTaskMinThreads="10" 
ScriptTaskQueueSize="500" SleepThreads="2" 
SyslogTaskMaxThreads="1" SyslogTaskMinThreads="1" 
SyslogTaskQueueSize="500" TimeoutThreads="2"/>

</bpa>

The prefs.xml file 
This file includes user UI preferences and custom view definitions. It resides in 
the ext directory. The ext directory is a subdirectory of the directory where 
main.xml is present.

The following text is a sample prefs.xml file
<preferences>

<user name="simuser@domain">
<pref name="UPDATER_MODE" value="TimedRefresh"/>
<pref name="UPDATE_TIMER" value="01:00"/>
<vcsoneset name="My Objects">

<custom_view description="" expression="EA:/
VCSOneCO=Retail~grp~Customers&amp;EA:/
VCSOneCO=Wholesale~grp~Project" name="ProjectTree"/>

</vcsoneset>
</user>

</preferences>
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This chapter includes the following topics:

■ About attributes

■ Viewing and editing attributes

■ VCS One cluster level attributes

■ Composite service group attributes

■ Remote cluster attributes

■ System attributes

■ Service group attributes

■ Resource type attributes

■ Resource attributes

■ Role attributes

■ User attributes

■ Group Transition Queue attributes

■ Action entry attributes

■ Set name attributes

■ OUname attributes

■ OUvalue attributes
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About attributes
Attributes define how VCS One controls the associated object.

Unless otherwise noted, attributes values are case-insensitive and the value 
remains persistent if the Policy Master restarts.

If an attribute is denoted Internal Use Only, do not change or modify the value 
of the attribute.

Virtualization-related attributes are covered in a separate chapter.

See “Virtualization attributes reference” on page 901.

About the data-type of attributes
Attribute values have one of the following data-types:

About the dimension of attributes
Attribute values have one of the following dimensions:

string String values are a sequence of characters in double quotes (“). You do not 
have to enclose strings in quotes when they begin with a letter, and 
contains only letters, numbers, dashes (-), and underscores (_).

■ A string consisting of only letters and numbers does not require 
quotes. A network interface such as eth0 is an example.
Enclosing the string in double quotes is also acceptable—"eth0".

■ Strings containing delimiters, such as periods in IP addresses or 
slashes in path names, require quotes. The IP address 
"192.168.100.1" is an example.

A string can contain double quotes. If the string contains double quotes, 
precede the string by a backslash. Within a string, represent a backslash 
with two forward slashes (\\).

integer Signed integer constants are a sequence of digits from 0 to 9. You can 
precede them with a dash. They are base 10. Integers cannot exceed the 
value of a 32-bit signed integer: 21471183247.

boolean Boolean values are integers with the possible values of 0 (false) or 1 (true).

scalar A scalar has only one value. 

vector A vector is an ordered list of values. Each value is indexed using a positive 
integer [zero or higher]. 
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Viewing and editing attributes
Each attribute has its own set of valid values. You can define the value of an 
attribute in one of the following ways:

■ Use the VCS One console 

■ Enter a command on the command line

■ Edit the appropriate configuration file

The command you use to define the value of an attribute depends on the type of 
the attribute. Some attributes may not be modifiable.

Some attributes have an empty value. In the console, the value 
<BLANK_VALUE> is equivalent to an empty value. When using the command 
line, the value ““ denotes an empty value.

To display a specific attribute of a given type and the current value using the 
command line

◆ Type the following command
hacommand -display -attribute attribute

Use the following information to replace the appropriate variables:

keylist A keylist is an unordered list of unique strings in that list.

association An association is an unordered list of name-value pairs. 

hacommand Use one of the following commands depending on the type of the 
attribute:

haclus type cluster

hasys type system

hapframe type pframe 

havframe type vframe

haobject type vobject

hagrp type service group

hatype type resource type

hares type resource

hauser type user
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See the Veritas Cluster Server One Command Reference Guide.

To display a specific attribute of a given type and the current value using the 
VCS One console

See “Editing VCS One cluster attributes” on page 632.

VCS One cluster level attributes
Table 34-1 lists VCS One cluster attributes in alphabetical order and provides 
definitions and information about their use.

harole type role

haset type set

attribute Name of the specific attribute. 
To display all attributes of this type, use only the -display flag

Table 34-1 VCS One cluster level attributes

VCS One cluster 
Attribute

Definition

AuthBrokerMap Type-dimension: string-association

This attribute sets the VCS One cluster-wide mappings of domain type to an 
Authentication broker servicing that domain type. For example, each of the following 
commands could go to their own preferred Authentication broker to get a credential 
and present it to the Policy Master, without the Policy Master being an AD, NIS, or 
LDAP client:

hasys -state -user abcd@AD-domain -domaintype nt

hasys -state -user abcd@nis-domain -domaintype nis

hasys -state -user abcd@ldap-domain -domaintype ldap

These commands may be run from anywhere in the VCS One cluster.

The Policy Master Authentication Broker and the Authentication Broker that are 
pointed to by this attribute should be trusted or in the same root hierarchy.

If this attribute is not set, environment variables for command-line interface or user-
selection of these values in the GUI determine the mapping.

Change this attribute to have flexibility to add users from existing domains without 
the need to change the Policy Master node Authentication broker.

Default value = ““

You may edit the value of this attribute with the GUI or the haclus -modify command.
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ClusterAddress Type-dimension: string-keylist

List of IP addresses and ports on which the Policy Master listens for incoming 
connections from the VCS One cluster. When the Policy Master updates the 
ClusterAddress values, it communicates the values to the VCS One client daemons, 
which update the values in the vcsone.conf file. Systems not running when updates 
occur obtain the ClusterAddress values when they reconnect to the Policy Master. 

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may edit the value of this attribute with the GUI or the haclus -modify command.

ClusterDirs Type-dimension: string-association

The currently defined VCS One directory variables such as VCSONE_HOME, 
VCSONE_CONF, and VCSONE_TRIGGERS_DIR. 

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

ClusterMode Type-dimension: integer-scalar

Indicates the start mode (cold or normal) and run mode (manual or simulator) of the 
VCS One cluster.

The value of this attribute does not persist when the Policy Master restarts

Default value = 0

You may not edit the value of this attribute.

ClusterName Type-dimension: string-scalar

User-defined label for the name of the VCS One cluster in the GUI. 

Limit this name to 128 characters.

Default value = VCSOne

ClusterState Type-dimension: integer-scalar

Current state of the VCS One cluster.

The value of this attribute does not persist when the Policy Master restarts.

Default value = 1

You may not edit the value of this attribute.

Table 34-1 VCS One cluster level attributes

VCS One cluster 
Attribute

Definition
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CompatibleClientVersion Type-dimension: string-association

Defines the minimum version and maximum version of the client daemon that is 
compatible with the Policy Master.

Default values: 
Minimum = 2.0
Maximum = 2.0

You may edit the value of this attribute only by editing the configuration file directly.

CompatibleCLIVersion Type-dimension: string-association

Defines the minimum version and maximum version of the ha- commands, such as 
hagrp, that are compatible with the Policy Master.

Default values: 
Minimum = 2.0
Maximum = 2.0

You may edit the value of this attribute only by editing the configuration file directly.

CompatibleDRVersion Type-dimension: string-association

Defines the minimum version and maximum version of the DR Connector that is 
compatible with the Policy Master.

Default values: 
Minimum = 1.0
Maximum = 1.0

You may not edit the value of this attribute.

CompatibleGUIVersion Type-dimension: string-association

Defines the minimum version and maximum version of the GUI that is compatible 
with the Policy Master.

Default values: 
Minimum = 2.0
Maximum = 2.0

You may edit the value of this attribute only by editing the configuration file directly.

CounterInterval Type-dimension: integer-scalar

Interval in seconds by which the GlobalCounter is increased.

Default value = 30 seconds

You may not edit the value of this attribute.

Table 34-1 VCS One cluster level attributes

VCS One cluster 
Attribute

Definition
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Created Type-dimension: integer-scalar

Timestamp of when the VCS One cluster was created. 

Default value = ““

You may not edit the value of this attribute.

CredRenewInterval Type-dimension: integer-scalar

The number of days after which VCS One renews its credentials with the 
authentication broker. 

For example, the value 5 indicates that credentials are renewed every 5 days; the 
value 0 indicates that credentials are not renewed.

The value of this attribute must be between 0 and 730.

Default value = 90.

You may edit the value of this attribute with the GUI or the haclus -modify command.

DefaultAuthDomain Type-dimension: string-scalar

Default authentication domain and domain type information for the VCS One cluster. 
Takes the following value: domain_type:domain_name

For example, nis:ourlab.com where ourlab.com is an NIS domain.

If you specify both domain and domain type on the command line, this value is 
overridden.

Usage: The format user@domain is enforced in the VCS One cluster. Modify this 
attribute to contain a domain type and domain name when the use of one particular 
domain is dominant in the environment. 

If this value is not set then the following is an example command:
hasys -state -user username@domain -domaintype domain_type

If this value is set then the following is an example command:
hasys -state -user username

Default value = ““

You may edit the value of this attribute with the GUI or the haclus -modify command.

Table 34-1 VCS One cluster level attributes
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VCS One cluster level attributes
DefaultPlatform Type-dimension: string-scalar

User-defined attribute that represents the most common platform in the VCS One 
cluster.

The following values are valid for this attribute: aix, aix/rs6000, 
hpux, linux, linux/x86, solaris, solaris/sparc, solaris/x86, windows, windows/x86.

Default value = linux/x86

You may edit the value of this attribute with the GUI or the haclus -modify command.

DeploymentTimeout Type-dimension: integer-scalar

Timeout window with which clients can be deploying using deployment credential.

Default value = 0

You may edit the value of this attribute with the GUI or the haclus -modify command.

DRAddress Type-dimension: string-keylist

List of IP addresses on which the Policy Master listens for incoming connections from 
a remote VCS One cluster.

You may edit the value of this attribute only by directly editing the main.xml 
configuration file.

See “Changing the local cluster’s DR address value” on page 608.

Note: You must stop the Policy Master before you edit the value of this attribute.

DRListeningPort Type-dimension: integer-scalar

Port on which the local VCS One cluster listens for incoming connections from the 
remote VCS One clusters.

The value for this attribute must be between 1025 and 65535.

Default = 14151

You may edit the value of this attribute only by directly editing the main.xml 
configuration file.

See “Changing the local cluster’s DR port value” on page 607.

Note: You must stop the Policy Master before you edit the value of this attribute.

EAMaxValidValue Type-dimension: integer-scalar

Attribute to restrict the maximum permitted extended attribute validation values.

The value for this attribute must be between 1 and 65536.

Default value = 50

You may edit the value of this attribute with the GUI or the haclus -modify command.

Table 34-1 VCS One cluster level attributes
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EnableFFDC Type-dimension: boolean-scalar

Enables (1)/Disables(0) First Failure Data Capture function.

Default value = 1

You may edit the value of this attribute with the GUI or the haclus -modify command.

EnableReservation Type-dimension: string-keylist

Specify the vframe vtypes for which reservations are enabled. 

For example if reservations are enabled for ESXVM and disabled for LDOMSVM the 
attribute value is ESXVM.

Enable reservations for a given technology is allowed only when all the VFrames of 
the given vtype are OFFLINE.

Default value = ""

EngineClass Type-dimension: string-scalar

User-defined attribute specifying the scheduling class for Policy Master.

Default value = TS

You may edit the value of this attribute with the GUI or the haclus -modify command.

EnginePriority Type-dimension: string-scalar

User-defined attribute specifying the priority of the Policy Master engine.

Default value = ““

You may edit the value of this attribute with the GUI or the haclus -modify command.

FarmUUID Type-dimension: string-scalar

Unique universal identifier for the farm.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

Table 34-1 VCS One cluster level attributes
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FragmentationPolicy Type-dimension: string-scalar

User-defined attribute specifying how VCS One resolves service group or VFrame 
placement when available systems or PFrames have the same Disruption Factor.

See “About disruption factor and kickout” on page 318.

The following values are valid for this attribute:

BiggestAvailable. VCS One evaluates the first PrecedenceOrder key (typically, CPU) 
and places the service group on the system (equivalently the VFrame on the PFrame) 
with the greatest Capacity value for the service group’s (VFrame’s) Load.

BestFit. VCS One evaluates the first PrecedenceOrder value (typically, CPU) and 
places the service group on the system (equivalently the VFrame on the PFrame) with 
the closest sufficient Capacity value for the service group’s (VFrame’s) Load.

Heuristic. The system (PFrame) that is chosen is based on whether or not the service 
group (VFrame) has a local dependency with another service group or VFrame.

Default value = BiggestAvailable

You may edit the value of this attribute with the GUI or the haclus -modify command.

GlobalCounter Type-dimension: integer-scalar

Internal use counter. The CounterInterval attribute specifies the interval at which 
this counter increases.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LastConfigUpdate Type-dimension: integer-scalar

Timestamp of when VCS One cluster object was last modified.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LicensedCPUs Type-dimension: integer-association

Total number of CPUs allowed to participate in the VCS One cluster. 
The value of this attribute does not persist when the Policy Master restarts.

Default values:

LinWin = 0
Unix = 0

You may not edit the value of this attribute.

Table 34-1 VCS One cluster level attributes
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LicensedFeatures Type-dimension: integer-scalar

Indicates VCS One features currently enabled.

The value of this attribute does not persist when the Policy Master restarts

Default value = 0

You may not edit the value of this attribute.

LicenseMode Type-dimension: integer-scalar

Indicates the current license-based mode in which the VCS One cluster is running.

The value of this attribute does not persist when the Policy Master restarts. 

Default value = 1.

You may not edit the value of this attribute.

LicenseType Type-dimension: integer-scalar

Type of license key that the Policy Master uses.

The value of this attribute does not persist when the Policy Master restarts.

Default value = 0

You may not edit the value of this attribute.

LockMemory Type-dimension: string-scalar

Disables paging for Policy Master process if set to CURRENT or ALL. 
Enables paging if set to NONE.

Default value = ALL

You may edit the value of this attribute with the GUI or the haclus -modify command.

LogDbg Type-dimension: string-keylist

Specifies which debug messages are logged.

Default value = ““

You may edit the value of this attribute with the GUI or the haclus -modify command.

LogSize Type-dimension: integer-scalar

Maximum size, in bytes, for the log files the Policy Master and the client daemon 
generate. Log files reaching this size roll over. For example, vcsoneclientd_A.log 
becomes vcsoneclientd_B.log, and vcsoneclientd_A.log becomes the new log file. 

The value for this attribute must be between 65536 and 134217728.

Default value = 33554432

You may edit the value of this attribute with the GUI or the haclus -modify command.

Table 34-1 VCS One cluster level attributes
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VCS One cluster level attributes
MaxGrpCompatMatrixSize Type-dimension: integer-scalar

The maximum number of service group or VFrame combinations to allow in a single 
CLI instance that sets compatibility between service groups or VFrames using 
SET/OU/EA specification.

Default value = 100

You may edit the value of this attribute with the GUI or the haclus -modify command.

MsgCatID Type-dimension: integer-scalar

Message category ID that is used for the VCS One cluster object.

Default value = 1.

You may edit the value of this attribute with the GUI or the haclus -modify command.

NodeIdCounter Type-dimension: integer-scalar

Indicates the node ID that will be assigned to the next system/pframe that is added to 
the VCS One cluster.

Default value = 1024

You may not edit the value of this attribute.

PMStartupTime Type-dimension: integer-scalar

Indicates the startup time for the Policy Master.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

PolicyHBTimeout Type-dimension: integer-scalar

The number of seconds for the Policy Master network module to wait before pro-
actively killing the Policy Master if the Policy Master thread has stopped sending a 
heartbeat signal to the network module. The Policy Master normally sends a 
heartbeat signal to the network module several times in a second. This heartbeat 
signal may stop when the Policy Master thread hangs for any reason or encounters an 
unknown defect. 

The network module kills the Policy Master process to avoid being stuck in this state 
forever. It initiates a restart or a failover of the Policy Master daemon process.

This behavior can be turned off by setting the PolicyHBTimeout attribute value to 0.

Default value = 0

You may edit the value of this attribute with the GUI or the haclus -modify command.

Table 34-1 VCS One cluster level attributes
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PrecedenceOrder Type-dimension: string-association

User-defined keys that refer to the aspects of system (or PFrame’s) resource capacity 
and of corresponding service group (or VFrame’s) load. The names, or keys, can be 
combined with a value to define capacity 

See “About Load and Capacity” on page 55.

Administrators may delete a PrecedenceOrder key using hagrp -modify only if 
all service group loads and system capacities have zero values associated with the 
key.

Default values:

■ Key1=CPU

■ Key 2=MEM

You may edit the value of this attribute with the GUI or the haclus -modify command.

ProcessClass Type-dimension: string-scalar

The scheduling class for the processes that are forked off by the Policy Master.

Default value = TS

You may edit the value of this attribute with the GUI or the haclus -modify command.

ProcessPriority Type-dimension: string-scalar

The scheduling priority for the processes that are forked off by the Policy Master.

Default value = ““

You may edit the value of this attribute with the GUI or the haclus -modify command.

ProductVersion Type-dimension: integer-scalar

VCS One product version. 

The value of this attribute does not persist when the Policy Master restarts.

Default value = 2.0.

You may not edit the value of this attribute.

ProtocolVersion Type-dimension: integer-scalar

A version number. The VCS One Policy Master uses this protocol version to 
communicate. All clients must provide a protocol version lower or equal to the Policy 
Master protocol version to successfully communicate. 
The value of this attribute does not persist when the Policy Master restarts.

Default value = 1.0

You may not edit the value of this attribute.
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ProxysimIPAddr Type-dimension: string-scalar

An IP address. The simulated Policy Master uses this IP address to ping the proxysim. 
This IP address is updated on the Policy Master when the proxysim connects for the 
first time with the Policy Master.

Default value = ““

Do not edit the value of this attribute.

ResourceKeys Type-dimension: string-association

Specifies which PrecedenceOrder key values correspond to the CPU and memory load 
and capacity values. It has two predefined keys 'cpu_key' and 'mem_key' for 
representing the CPU and memory resource. 

For example, if the value 'cpu' of PrecedenceOrder key 'key1' represents cpu capacity 
and load values, the value of the cpu_key should be 'cpu'. The value of the 'mem_key' 
should be 'mem'.

Use the haclus command to see the values for this attribute:

# haclus -value resourcekeys
cpu_key cpu mem_key mem

Default values: 

■ cpu_key “cpu”

■ mem_key “mem”

RestartMode Type-dimension: integer-scalar

Determines the start mode of the VCS One cluster the next time the cluster is started.

The value for this attribute must be between 1 and 4, which indicate the following 
values:

■ 0 = Unknown

■ 1 = Normal

■ 2 = Invalid 

■ 3 = Invalid 

■ 4 = Cold

Default value = 4.

You may not edit the value of this attribute.

SiteAddress Type-dimension: string-association

Denotes the IP address or the hostname that is associated with a site name.

Default value = ““

You may edit the value of this attribute with the GUI or the haclus -modify command.
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SkipCVNCheck Type-dimension: integer-scalar

Indicates whether or not a configuration version number check is done whenever the 
VCS One client connects to the Policy Master.

SkipCVNCheck = 1 indicates the check is not done.

Default value = 0

You may edit the value of this attribute with the GUI or the haclus -modify command.

SourceFile Type-dimension: string-scalar

The name of the XML file where this object resides.

Default value = main.xml

You may not edit the value of this attribute.

TrustedAuthBrokerID Type-dimension: string-keylist

Lists the trusted authentication brokers’ UUIDs. Includes remote authentication 
brokers that have trust set up with the VCS One cluster. 

Type the following command on the broker host to retrieve the broker UUID:

# /opt/VRTSvcsone/bin/haat getbrokeruuid -b localhost:14159

Default value = ""

VALTechnologies Type-dimension: string-keylist

Lists the supported virtualization technologies.

Default value = VMware

You may not edit the value of this attribute.

WebserverSubsystems Type-dimension: string-keylist

The list of enabled subsystems in the VCS One web server. 

The following values are valid for this attribute: ACTIOND, BPA, RCA, SEARCH, WS

Default value = ACTIOND, BPA, RCA, SEARCH, WS

Contact Symantec support before modifying this attribute.
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Composite service group attributes
Table 34-2 lists composite service group attributes in alphabetical order and 
provides definitions and information about their use.

Table 34-2 Composite service group attributes

Composite service 
group attributes

Definition

Authority Type-dimension: boolean-scalar

This attribute is applicable only in a VCS One global cluster environment.

Indicates whether or not the local VCS One cluster is allowed to bring the composite 
service group online.

0—the local VCS One cluster is not allowed to bring the composite service group online.

1—the local VCS One cluster is allowed to bring the composite service group online.

The Authority attribute prevents a composite service group from coming online in 
multiple sites at the same time.

See “How VCS One resolves authority for application that spans clusters” on page 80.

Default value = “ “

You may not edit the value of this attribute.

See “Requesting authority for a global CSG” on page 615.

AttnInfo Type-dimension: string-association

The names of the service groups or VFrames in the composite service group that are 
responsible for the ATTN flag being set for the CSG, along with the reason why ATTN was 
set. 

The following values are valid for the reason:

■ Unable to online

■ Group fault

■ Any instance of a parallel group is faulted

■ VFrame fault

The names of the CSG that are responsible for the ATTN flag being set, along with the 
reason why ATTN was set. 

The following values are valid for the reason:

■ Concurrency Violation

■ State is Stale

Default value = ““

You may not edit the value of this attribute.

See “ATTN flag is set for the CSG” on page 736.
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ClusterList Type-dimension: string-keylist

This attribute is applicable only in a VCS One global cluster environment.

Specifies the list of VCS One clusters on which the composite service group is set to run.

You may edit the value of this attribute with the GUI or the hacsg -modify command.

See “Configuring a global CSG” on page 614.

Created Type-dimension: integer-scalar

Timestamp of when system/pframe object was created

Default value = ““

You may not edit the value of this attribute.

Table 34-2 Composite service group attributes
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CSGState Type-dimension: integer-scalar

The state of the composite service group.

This attribute represents the collective running states of the constituent service groups 
and VFrames of the composite service group. 

The following values are valid for this attribute:

■ ONLINE - All the service groups and VFrames in the CSG are online.

■ PARTIAL - Some service groups or VFrames in the CSG are offline, and the others are 
in the online or the partial state. Or, no service groups or VFrames are offline, some 
or all service groups or VFrames are partial, and the rest, if any, are online.

■ OFFLINE - All the service groups or VFrames in the CSG are offline.

■ ONLINE | PENDING - All service groups or VFrames in the CSG are online, but one or 
more of the constituent service groups or VFrames are in transition to a different 
state.

■ PARTIAL | PENDING - Same as PARTIAL, but some service groups or VFrames are in 
transition to a different state.

■ PARTIAL | ATTN - Same as PARTIAL, but some service groups or VFrames are faulted or 
are unable to go online.

■ PARTIAL | ATTN | PENDING - Same as PARTIAL, but some service groups or VFrames are 
faulted or unable to go online, while one or more of the remaining service groups or 
VFrames in the CSG are in transition to a different state.

■ OFFLINE | PENDING - Same as OFFLINE, but some service groups or VFrames may be in 
transition to a different state.

■ OFFLINE | ATTN - One of the following conditions is true: All service groups or 
VFrames are faulted; all service groups or VFrames are offline or faulted; all service 
groups or VFrames are offline and some of them are unable to come online.

■ OFFLINE | ATTN | PENDING - Same as OFFLINE | ATTN but some service groups or VFrames 
in the CSG are in transition to a different state.

Default value = OFFLINE

The ATTN modifier indicates that one or more of the service groups or VFrames in the 
CSG are faulted or are unable to go online anywhere in the VCS One cluster.

The PENDING modifier indicates that one or more service groups or VFrames in CSG are in 
transition.

The value of this attribute does not persist when the Policy Master restarts. The value is 
re-evaluated upon each Policy Master restart.

You may not edit the value of this attribute.

See “How VCS One determines the state of a multi-tier application” on page 80.

Table 34-2 Composite service group attributes

Composite service 
group attributes

Definition



833Attributes reference
Composite service group attributes
GroupList Type-dimension: string-keylist

The names of the service groups that are in the composite service group.

Default value = ““

You may edit the value of this attribute with the GUI or the hacsg -modify command.

InTransition Type-dimension: boolean-scalar

Indicates whether or not the CSG state is in transition. If any service group or VFrame in 
the CSG, or any resource in the service groups or any resource in the VFrames within the 
CSG is in transition, the value is set to 1. If not, the value is set to 0.

Default value = ““

You may not edit the value of this attribute.

LastConfigUpdate Type-dimension: integer-scalar

Timestamp of when CSG object was last modified.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LastStateUpdate Type-dimension: integer-scalar

The timestamp of when the state of the composite service group’s last changed.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

MsgCatID Type-dimension: integer-scalar

Message category ID that is used for the CSG object

Default value = 1

You may edit the value of this attribute with the GUI or the hasys -modify command.
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NotifyAttrChange Type-dimension: string-keylist

Editable list of attribute names. If the user wants to get notified of any changes to the 
value of a CSG attribute, then the name of that attribute should be added as a key to the 
this attribute. 

Upon any changes to the value of such attributes that are listed in NotifyAttrChange, a 
CSG_ATTR_CHANGE event is generated.

Default value = ““

You may not edit the value of this attribute.

SourceFile Type-dimension: string-scalar

The name of the XML file where this object resides.

Default value = main.xml

You may edit the value of this attribute with the GUI or the haclus -modify command.
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Remote cluster attributes
Table 34-3 lists remote cluster attributes in alphabetical order and provides 
definitions and information about their use.

Table 34-3 Remote cluster attributes

Remote VCS One 
cluster attribute

Definition

ClusterName Type-dimension: string-scalar

User-defined label for the name of the remote cluster.

The name of the remote cluster must not exceed 128 characters. The name cannot start 
with a number or contain any special characters.

Default value = “ ”

You may not edit the value of this attribute.

ClusterState Type-dimension: integer-scalar

Indicates the current state of the remote VCS One cluster.

You may not edit the value of this attribute.

See “Cluster states in VCS One global clusters” on page 932.

ConnectionRole Type-dimension: string-scalar

Specifies whether the remote cluster initiates the connection to the local cluster or 
accepts the connection from the local cluster. The value of this attribute can be one of the 
following:

■ Initiator—the remote cluster initiates the connection to the local cluster

■ Acceptor—the remote cluster accepts the connection from the local cluster

You may not edit the value of this attribute.

See “Determining the connection role of clusters” on page 596.

ConnectionTimeout Type-dimension: integer-scalar

Time-out value in seconds to initiate a connection to the remote cluster. 

If the specified value is exceeded, VCS One reports an error and retries to initiate a 
connection.

The value for this attribute must be between 2 and 50.

Default value = 5 seconds

You may edit the value of this attribute with the GUI or the haclus -modify command.
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ConsolidatedLinkStatus Type-dimension: string-scalar

Indicates the consolidated status of the network links between the local and the remote 
clusters.

■ DISABLED—all the network links are disabled

■ DOWN—all the network links are down

■ UP—all the network links are up

■ PARTIAL UP—at least one of the network links is up

You may not edit the value of this attribute.

See “Network link states in VCS One global clusters” on page 933.

DRPort Type-dimension: integer-scalar

Port on which the remote VCS One cluster listens for incoming connections. The value of 
this remote cluster object’s attribute must match the value of the cluster-level attribute 
DRListeningPort that you defined for the cluster at the remote site.

The value for this attribute must be between 1025 and 65535.

Default = 14151

You may edit the value of the DRPort attribute with the GUI or the haclus -modify 
command.

Note: You must set the value of the EnableConnections attribute to 0 before you edit the 
value of this attribute.

EnableConnections Type-dimension: boolean-scalar

Indicates whether VCS One on the local cluster must establish (1) or close (0) connections 
with the remote cluster. 

You must set the value of this attribute to 1 on both the VCS One clusters to establish the 
network connection.

Default value = 0

You may edit the value of this attribute with the GUI or the haclus -modify command.

Table 34-3 Remote cluster attributes
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LinkStatus Type-dimension: integer-association

Indicates the status of each network link that is specified in the NetworkConnections 
attribute for the VCS One cluster that initiates the inter-cluster connection.

The status of the network link between the local and the remote clusters can be UP, 
DOWN, or DISABLED. 

See “Network link states in VCS One global clusters” on page 933.

The LinkStatus attribute stores the network link in the same format as you defined in the 
NetworkConnections attribute:

destinationIP[:sourceIP]

For example, you may see the following value for the LinkStatus attribute if you had 
defined two network links and if EnableConnection attribute is set to 1 on both the VCS 
One clusters:

192.168.1.16:192.168.1.20 = UP

192.168.2.16:192.168.2.20 = DOWN

You may not edit the value of this attribute.

MaxHeartbeatInterval Type-dimension: integer-scalar

The maximum number of seconds to elapse without a heartbeat. If no messages are 
exchanged on a particular network connection for this interval, an explicit heartbeat is 
exchanged.

The value for this attribute must be between 5 and 360.

Default value = 5 seconds

You may edit the value of this attribute with the GUI or the haclus -modify command.

MissedHeartbeat
Threshold

Type-dimension: integer-scalar

The maximum number of missed heartbeats that the Policy Master waits before 
declaring the network link as down.

The value for this attribute must be between 2 and 50.

Default value = 5 seconds

You may edit the value of this attribute with the GUI or the haclus -modify command.
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NetworkConnections Type-dimension: string-keylist

Specifies the list of network links that the local cluster uses to connect to the remote 
cluster.

where:

■ destinationIP is the IP address of the remote cluster
You must specify a value for the destination IP address.

■ sourceIP is the IP address of the local cluster
If you do not specify a source IP address, VCS One uses any of the available IP 
addresses on the local cluster to connect to the remote cluster.

For example, you can specify the value of this attribute as 192.168.1.16. In this case, VCS 
One uses any available IP addresses on the local cluster.

You may edit the value of this attribute with the GUI or the haclus -modify command.

Note: You must set the value of the EnableConnections attribute to 0 before you edit the 
value of this attribute.

RClusterUUID Type-dimension: string-scalar

Unique universal identifier for the remote VCS One cluster.

Default value = ““

You may not edit the value of this attribute.

ReconnectInterval Type-dimension: integer-scalar

Number of seconds to wait before VCS One attempts to reconnect to a remote cluster.

The value for this attribute must be between 2 and 50.

Default value = 5 seconds

You may edit the value of this attribute with the GUI or the haclus -modify command.

RunningDRVersion Type-dimension: string-scalar

Indicates the version of the DR component that is currently running on the local cluster.

You may not edit the value of this attribute.

SourceFile Type-dimension: string-scalar

The name of the XML file where this object resides.

Default value = main.xml

You may edit the value of this attribute with the GUI or the haclus -modify command.
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System attributes
System objects and PFrame objects have many similar attributes, but are listed 
separately for clarity. 

See “PFrame attributes” on page 906.

Table 34-4 lists system attributes in alphabetical order and provides definitions 
and information about their use.

Table 34-4 System level attributes

System Attribute Definition

AgentsStopped Type-dimension: integer-scalar

AgentStopped is set to 1 when all agents on the system are stopped. Typically, the use 
of the hastop command to stop vcsoneclientd stops the agents. 
The value of this attribute does not persist when the Policy Master restarts.

Default value = 0

You may not edit the value of this attribute.

AgentVersionInfo Type-dimension: string-association

Displays the version information of the agents that are installed on the system.

You may edit the value of this attribute with the hasys -modify command or the GUI.

AssociatedVobjects Type-dimension: 

The list of objects that this system is associated with.

Default value = ““

AutoDeploy Type-dimension: integer-scalar

Indicates if the system can be deployed using deployment credentials.

Default value = 1

You may edit the value of this attribute with the hasys -modify command or the GUI.

AutoEnablePending Type-dimension: integer-scalar

The number of service groups that are not fully probed on a newly joined system. 
When value drops to zero, the Policy Master attempts to bring online on the system 
those service groups that are listed in the GTQ with INTENTONLINE entries.

Default value = 0

You may not edit the value of this attribute.
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AvailableCapacity Type-dimension: integer-association

Key-values pairs. These pairs contain the calculated values that are based on the 
Capacity attribute, the ReserveCapacity attribute, and the Load attribute for all 
the applicable service groups. 

See “Capacity” on page 841, “ReservedCapacity” on page 845, and “Load” on 
page 853. 

The value of this attribute does not persist when the Policy Master restarts

When a system has the DDNAState attribute = 1, the value of this attribute is the last 
known value when the system was connected with the Policy Master.

You may not edit the value of this attribute.

Capacity Type-dimension: integer-association

When adding a system to a VCS One cluster, an administrator defines a system’s 
Capacity attribute by associating integer values with user-defined keys. The key-
value pairs (for example, “cpu 6 memory 3096”) represent the capacity of the system.

The keys, such as “cpu” and “memory” (see “PrecedenceOrder” on page 827), are 
initially defined in the VCS One cluster attribute PrecedenceOrder. Users may 
define up to four keys.

The service group level attribute Load that the administrator defines when creating 
a service group corresponds to the system Capacity attribute. For example, a 
service group’s Load attribute may be “cpu 2 memory 1028” and a system’s 
Capacity attribute may be “cpu 6 memory 3096”. A service group whose Load 
exceeds a system’s Capacity cannot be brought online on that system. See 
information about “Load” on page 853.

The Policy Master reserves capacity on a system where it plans to online a service 
group. The ReservedCapacity attribute contains the key-value pairs reflecting the 
reserved capacity. See “ReservedCapacity” on page 845.

The system maintains an attribute that is called AvailableCapacity, which 
reflects the initial Capacity of a system minus ReservedCapacity and the Load 
it currently bears. See “AvailableCapacity” on page 841.

You may edit the value of this attribute with the GUI or the hasys -modify command.

Created Type-dimension: integer-scalar

Timestamp of when system object was created

Default value = ““

You may not edit the value of this attribute.

Table 34-4 System level attributes
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DDNAPingInterval Type-dimension: integer-scalar

The interval in seconds to wait before Policy Master investigates current status of a 
system in the DDNA (Daemon Dead Node Alive) state or the UNREACHABLE state.

The value of this attribute must be between 10-360.

Default value = 20

You may edit the value of this attribute with the GUI or the hasys -modify command.

DDNAState Type-dimension: integer-scalar

DDNA (Daemon Dead Node Alive) state of 1 indicates the vcsoneclientd process on 
the system, which is still alive, does not send heartbeats to the Policy Master.

Default value = 0

You may not edit the value of this attribute.

EnableFFDC Type-dimension: boolean-scalar

Indicates if First Failure Data Capture (FFDC) functionality is enabled for the VCS 
One client running on this system.

See “About the first failure data capture (FFDC) log” on page 707.

Enabled = 1; Disabled = 0

Default value = 1

You may edit the value of this attribute with the GUI or the haclus -modify command.

FirstTimeConnect Type-dimension: integer-scalar

Indicates whether or not the system has connected to the Policy Master since the 
time a fresh configuration was loaded into the configuration database.

Default value = 1

You may not edit the value of this attribute.

Frozen Type-dimension: boolean-scalar

Indicates if service groups can be brought online on the system. Service groups 
cannot be brought online if the attribute value is 1.

Default value = 0.

The Policy Master sets the value of this attribute in response to Freeze or Unfreeze 
menu items in the GUI, or the hasys -freeze | -unfreeze command. 
The user may not directly edit this attribute. 

GroupList Internal use only.

InternalSysFlag Internal use only.

Table 34-4 System level attributes
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LastConfigUpdate Type-dimension: integer-scalar

Timestamp of when system object was last modified.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LastStateUpdate Type-dimension: integer-scalar

The timestamp of when system’s state last changed.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LinkedVFrame Type-dimension: string-association

Attributes of the VFrame that is linked to this system, or equivalently, the VFrame on 
which this system runs.

This attribute has the following keys:

■ Name: The name of the linked VFrame.

■ UseForPolicy: Determines whether (1) or not (0) this VFrame is using VMHA 
policy.
See “About virtual machine high availability” on page 68.

Default value = ““

You may not edit the value of this attribute directly.

LogDbg Type-dimension: string-keylist

Specifies which debug messages are written to the vcsoneclientd log file.

Default value = ““

MaxHeartbeatInterval Type-dimension: integer-scalar

Interval in seconds that determines how often a system should send a heartbeat to 
the Policy Master.

The value for this attribute must be between 5 and 360.

Default value = 10 

You may not edit the value of this attribute.

Table 34-4 System level attributes
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MissedHeartbeatThreshold Type-dimension: integer-scalar

A number that denotes how many missed heartbeats the Policy Master waits before 
investigating the system missing heartbeats.

The value for this attribute must be between 2 and 50.

Default value = 3

You may edit the value of this attribute with the GUI or the hasys -modify command.

MsgCatID Type-dimension: integer-scalar

Message category ID that is used for the system object

Default value = 1

You may edit the value of this attribute with the GUI or the hasys -modify command.

NodeId Type-dimension: integer-scalar

The node ID of the system. The Policy Master assigns this node ID.

Default value = -1

You may not edit the value of this attribute.

NotifyAttrChange Type-dimension: string-keylist

The value of this attribute is a list of attributes. Whenever any of the attributes in 
this list is modified, the SYS_ATTR_CHANGE event is generated.

Use this attribute to monitor changes in system attributes. 

Default value = ““

NumMissedHeartbeat Type-dimension: integer-scalar

Number of heartbeats the specific system has missed. When the 
NumMissedHeartbeats crosses the MissedHeartbeatThreshold value, the Policy 
Master starts investigating the system.

Default value = 0

You may not edit the value of this attribute.

The value of this attribute does not persist when the Policy Master restarts.

Table 34-4 System level attributes
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OnGrpCnt Type-dimension: integer-scalar

The number of service groups online or partially online on the system. This number 
does not include the number of service groups that are planned to be brought online. 
The value of this attribute does not persist when the Policy Master restarts.

When a system has the DDNAState attribute = 1, the value of this attribute is the last 
known value when the system was connected with the Policy Master.

Default value = ““

You may not edit the value of this attribute.

PlatformName Type-dimension: string-scalar

Name of the platform in use on the system.

The following values are valid for this attribute: aix, aix/rs6000, hpux, linux,
linux/x86, solaris, solaris/sparc, solaris/x86, windows, windows/x86, and notknown.

The value ‘notknown’ denotes an unmanaged system.

See “How VCS One manages a virtualized environment” on page 66.

Add back in esx as appropriate

Default value = ““

You may modify the value of this attribute with the hasys -modify command or the 
GUI.

ReservedCapacity Type-dimension: integer-association

Key-values pairs. The Policy Master defines these pairs and designates the reserve 
capacity on the system. 

For example, if the Policy Master plans to fail over group G1 to system S2, the 
ReserveCapacity attribute on system S2 includes the capacity that is required for G1. 
As G1 is brought online on S2, the Policy Master removes the capacity that G1 
requires from the ReserveCapacity attribute value. 

See “Capacity” on page 841.

When a system has the DDNAState attribute = 1, the value of this attribute is the last 
known value when the system was connected with the Policy Master.

Default value = ““

You may not edit the value of this attribute.

SourceFile Type-dimension: string-scalar

The name of the XML file where this object resides.

Default value = main.xml

You may edit the value of this attribute with the GUI or the hasys -modify command.

Table 34-4 System level attributes
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StaleSysState Type-dimension: boolean-scalar

Denotes whether or not the state of the system is based on an old value from the 
database which has not as yet been determined accurately by the Policy Master.

Default value = 0

You may not edit the value of this attribute.

SysInfo Type-dimension: string-association

Indicates the system-specific information by key—value pairs. This attribute is 
updated each time the VCS One client daemon connects to the Policy Master.

Default value = 
MemoryReal = ““
MemoryVirt= ““
OsType = ““
OsVersion = ““
CpuCount = ““
CpuArch = ““
CpuSpeed = ““
NetHwAddr = ““

You may not edit the value of this attribute.

SysName Type-dimension: string-scalar

Indicates the system’s name. 

The value of this attribute does not persist when the Policy Master restarts

Default value = ““

You may not edit the value of this attribute.

SysState Type-dimension: integer-scalar

Indicates the system’s state:

1 = UNKNOWN

8 = LOCAL_BUILD

11 = RUNNING

12 = LEAVING

14 = EXITED

15 = FAULTED

Default value = 1 

You may not edit the value of this attribute.
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SystemConfigVersion Type-dimension: integer-scalar

Indicates whether the Policy Master is to push fresh configuration information to the 
system when the system’s vcsoneclientd connects to the Policy Master.

Default value = 0

You may not edit the value of this attribute.

SystemIPAddrs Type-dimension: string-vector

Value specifies the IP address(es) configured for the system. The Policy Master uses 
the list to ping the system in case of a fault. 

Every time the system’s vcsoneclientd daemon starts, the daemon updates the value 
of the attribute.

Default value = ““

You may not edit the value of this attribute.

SystemMode Type-dimension: string-scalar

Indicates whether this system is an actual system (Real) or a simulated system 
(Simulated).

Default value = Real

You may not edit the value of this attribute.

SystemSequenceNumber Type-dimension: integer-scalar

Specifies whether the Policy Master is to probe all resources on the system when the 
system’s vcsoneclientd connects to the Policy Master. Values are Yes (1) and No (0).

Default value = 0

You may not edit the value of this attribute.

SystemVersion Type-dimension: string-association

Version of the vcsoneclientd (VCS One client system daemon) running on the system.

Default values are: 
DaemonVersion = ““
ProductVersion = ““
BuildDate = ““
PSTAMP = ““
ProtocolVersion = ““

You may not edit the value of this attribute.
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Service group attributes
Service group objects and VFrame objects have many similar attributes, but are 
listed separately for clarity. 

See “VFrame attributes” on page 914.

SysUserName Type-dimension: string-scalar

The user name that is associated with a system. The privileges that are granted to 
this user determine the operations that the root user on that system can perform 
within the VCS One cluster.

Default value = ““

You may not edit the value of this attribute.

SystemUUID Type-dimension: string-scalar

Specifies the System UUID, a unique identifier for the system.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

TransitionOffline Type-dimension: integer-scalar

When user issues hastop -sys command without the 
-evacuate option, Policy Master sets value of TransitionOffline to 1 for a brief time.

The value of this attribute does not persist when the Policy Master restarts.

Default value = 0

You may not edit the value of this attribute.

TransitionOnline Type-dimension: integer-scalar

When user issues hastop -sys command with the -evacuate option, Policy Master sets 
value of TransitionOnline to 1 for a brief time. 

The value of this attribute does not persist when the Policy Master restarts.

Default value = 0

You may not edit the value of this attribute.

UsePMIPAddrs Type-dimension: string-keylist

Specifies the list of IP addresses (and ports) that the client system uses to connect to 
the Policy Master. This list must be a subset of the IP addresses that the Policy 
Master listens on. The cluster attribute ClusterAddress specifies on which IP 
addresses the Policy Master listens.

Default value = ““
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Table 34-5 lists service group attributes in alphabetical order and provides 
definitions and information about their use:

Table 34-5 Service group attributes

Service Group 
Attribute

Definition

ActiveCount Internal use only.

AssociatedVobjects Type-dimension: 

The list of objects that this system is associated with.

Default value = ““

AutoEnableWait Type-Dimension: boolean-scalar

For internal use. If set to 1 it indicates Policy Master is waiting to probe a service group 
on this newly joined system. Once the service group is probed this value is set to 0 and 
AutoEnablePending for the system decrements by 1.

Default value = 0.

The value of this attribute is set individually for each system in the group's SystemList.

You may not edit the value of this attribute.

CompatibleGroups Type-dimension: string-keylist

A list of the service groups that are compatible with the current service group. This 
attribute does not have a value if the IncompatibleGroups attribute has a value.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.
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ContainerInfo Type-Dimension: string-association

Used in operating system virtualization technology environments. Describes the 
Container information and whether that information is passed to the agent framework. 

Can only be modified if all resources in the service group are in a clean OFFLINE state.

Has the following keys: 

NAME: Name of the Container in free-form non-null text 

TYPE: Type of the Container. Valid values are ZONE and WPAR. The XRM option is not 
supported.

ENABLED: Valid values are 0 and 1. Indicates if the Policy Master does (1) or does not (0) 
pass ContainerInfo to the agents managing resources in a service group. (Target service 
group must have the value 1 set for either the RunInContainer key or the PassCInfo key in 
the resource attribute ContainerOpts.)

By default, this attribute is NULL, indicating the service group is not associated with a 
Container. 

Default value = ““

Created Type-dimension: integer-scalar

Timestamp of when service group object was created

Default value = ““

You may not edit the value of this attribute.

 CSGName Type-Dimension: string-scalar

Denotes the name of the composite service group to which this service group belongs. A 
blank value indicates this service group does not belong to a composite service group.

This attribute remains persistent across Policy Master reboots.

You may edit the value of this attribute only by editing the configuration file directly.

Default value = ““

CurrentCount Type-Dimension: integer-scalar

Internal use only. Number of systems on which the service group is active. 
The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.
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Enabled Type-Dimension: boolean-scalar

Indicates if a service group can be failed over or brought online. If any of the local values 
are disabled, the service group is disabled.

Default value = 1 (enabled)

The value of this attribute is set individually for each system in the group's SystemList.

You may only edit the value of this attribute if the group’s SystemList attribute is non-
empty. 

You may edit the value of this attribute with the hagrp -enable or hagrp -disable 
command or the GUI.

You may edit the value of this attribute for an individual service group instance by 
editing the main.xml configuration file directly.

Evacuate Type-Dimension: boolean-scalar

Indicates if VCS One initiates an automatic failover when user issues the command

hastop -local -evacuate.

Default value = 1

FirstLocalOnline Type-Dimension: string-scalar

Internal use only for VCS One agents.

This attribute is applicable only in a VCS One global cluster environment.

When the value of this attribute is 1, VCS One agents that need to perform any pre-online 
tasks invoke specific setup scripts before bringing the application online. When the local 
cluster acquires authority for the global CSG from the remote cluster, the value of 
FirstLocalOnline attribute is set to 1 for the service groups of that global CSG.

The value of this attribute does not persist when the Policy Master restarts.

Default value = "0"

You may not edit the value of this attribute.

Flags Type-Dimension: integer-scalar

Provides additional information for the state of resources in the service group. Primarily 
this attribute raises flags pertaining to the resource. 

Values:

RES_NEED_ATTN indicates that one or more resources in the service group has a flag 
raised. For information about the Flags resource attribute, see “Flags” on page 877.

The value of this attribute is set individually for each system in the group's SystemList.

You may not edit the value of this attribute.
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Frozen Type-Dimension: boolean-scalar

Disables all actions on the service group except for the monitor actions that the agents 
perform.

Examples of disabled actions are autostart, online, offline, and failover. 

All agents that are bundled with VCS One observe this convention.

Default value = 0 (not frozen)

The Policy Master sets the value of this attribute in response to Freeze or Unfreeze menu 
items in the GUI, or the hagrp -freeze | -unfreeze command. The user may not directly 
edit this attribute. 

GrpFaultPolicy Type-Dimension: string-scalar

Specifies whether VCS One fails over or does not fail over a faulted service group. . The 
following values are valid for this attribute:

■ Failover

■ NoFailover 

See “Service group level control after a fault” on page 262.

Default value = Failover

GTQDisplayName Type-Dimension: string-scalar

Default value = ““

You may not edit the value of this attribute.

IncompatibleGroups Type-dimension: string-keylist

A list of the service groups that are incompatible with the current service group. This 
attribute does not have a value if the CompatibleGroups attribute has a value.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

LastConfigUpdate Type-dimension: integer-scalar

Timestamp of when service group object was last modified.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.
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LastRestartTime Type-dimension: integer-scalar

Timestamp of when service group last restarted.

Default value = 0

You may not edit the value of this attribute.

LastStateUpdate Type-dimension: integer-scalar

Timestamp of when a service group’s state last changed.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LastSuccess Type-dimension: integer-scalar

Indicates the time when the service group was brought online because of a restart.

Default value = 0

The value of this attribute is set individually for each system in the group's SystemList 
only when the service group is a parallel service group.

You may not edit the value of this attribute.

Load Type-Dimension: integer-association

Integer value expressing total system Load that this service group exerts on a system.

For example, the administrator may assign a value of 100 to a large production SQL and 
15 to a Web server.

When creating a service group, an administrator defines a service group’s Load attribute 
by associating integer values with user-defined keys. The key-value pairs (for example, 
“cpu 4 memory 1028”) represent the load a service group places on a system’s resources. 

The keys, such as “cpu” and “memory” (see “PrecedenceOrder” on page 827) are initially 
defined in the cluster attribute 

PrecedenceOrder. Users may define up to four keys.

The system level attribute, Capacity, which the administrator defines when adding a 
system, corresponds to the Load attribute. For example, a system’s Capacity attribute 
may be “cpu 6 memory 3046” and a service group Load attribute may be “cpu 2 memory 
1028”. See information about “Capacity” on page 841.

The hagrp -changeload command enables users to change the Load attribute 
definition for an online service group.

Default value = 0
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ManualOps Type-Dimension: boolean-scalar

Indicates if manual operations are allowed on the service group. If set to 0 then online, 
offline and switch operations are not permitted.

Default value = 1 (enabled)

MasterGroup For future use.

MsgCatID Type-dimension: integer-scalar

Message category ID that is used for the service group object

Default value = 1

NodeFaultPolicy Type-Dimension: string-scalar

Specifies whether or not to fail over the service group when the application node on 
which it runs faults. The following values are valid for this attribute:

■ Failover - VCS One fails over the service group to the best available target node.

■ NoFailover - VCS One does not fail over the service group.

See “System level control after a fault” on page 263.

To specify VCS One Start functional mode (license), set the following values:

■ GrpFaultPolicy = NoFailover 

■ NodeFaultPolicy = NoFailover

Default value = Failover

NotifyAttrChange Type-dimension: string-keylist

The value of this attribute is a list of attributes. Whenever any of the attributes in this 
list is modified, the GRP_ATTR_CHANGE event is generated.

Use this attribute to monitor changes in service group attributes. 

Default value = ““

NumRetries Type-dimension: integer-scalar

Indicates the number of attempts made to restart a service group.

Default value = 0

The value of this attribute is set individually for each system in the group's SystemList.

You may not edit the value of this attribute.
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OffHostResource Type-dimension: string-keylist

A list of the off-host resources that use this service group as a control group.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

OnlineRetryLimit Type-dimension: integer-scalar

Indicates the number of attempts that the Policy Master makes to restart a faulted 
service group.

Default value = 0

Parallel Type-Dimension: integer-scalar

Indicates if the service group is failover (0) or parallel (1).

Default value = 0

PathCount Type-Dimension: integer-scalar

For internal use only. Number of resources in path not yet taken offline. When this 
number drops to zero, the engine may take the entire service group offline if critical fault 
has occurred. 

The value of this attribute does not persist when the Policy Master restarts.

You may not edit the value of this attribute.

PlatformName Type-dimension: string-scalar

Name of system platform for which service group is configured to run.

If a default platform name has not been set for the VCS One cluster, then specify the 
platform when creating the service group. If this attribute has been set for the VCS One 
cluster, it is used by default for a new service group unless you explicitly set the platform.

The following values are valid for this attribute: aix, aix/rs6000, hpux, linux,
linux/x86, solaris, solaris/sparc, solaris/x86, windows, and windows/x86.

Default value = ““

You may edit the value of this attribute with the hagrp -modify command or the GUI.
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Priority Type-Dimension: integer-scalar

Indicates the priority of the service group, ranging from highest (1) to lowest (5). Higher 
priority service groups take precedence over lower priority service groups when the 
service groups contend for resources. Low priority service groups may be kicked out of a 
system in favor of a higher priority service group. The value for this attribute must be 
between 1 and 5.

Default value = 5

You may edit the value of this attribute with the hagrp -modify command.

Probed Type-Dimension: boolean-scalar

Probed = 1 indicates one of the following conditions:

■ Agents have detected all enabled resources in the service group.

■ A service group with no resources or no enabled resources is detected when Policy 
Master starts or restarts.

Probed = 0 indicates one of the following conditions:

■ Agents have not detected all enabled resources in the service group.

■ A new service group is added with no resources or no enabled resource while the 
Policy Master is running.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

The value of this attribute is set individually for each system in the group's SystemList.

You may not edit the value of this attribute.

ProbesPending Type-Dimension: integer-scalar

The number of resources that the agent has not yet detected on each system. 

The value of this attribute does not persist when the Policy Master restarts.

The value of this attribute is set individually for each system in the group's SystemList.

Default value = ““

You may not edit the value of this attribute.

Responding Type-Dimension: integer-scalar

For internal use only. Indicates the engine is responding to a failover event and is in the 
process of bringing the service group online or failing over the node. 
The value of this attribute does not persist when the Policy Master restarts.

You may not edit the value of this attribute.
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SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = main.xml

StandbyGroup For future use.

State Type-Dimension: integer-scalar

The state on each system of the service group. The following states are the possible 
values:
OFFLINE All non-persistent resources are offline.

ONLINE All resources whose AutoStart attribute is equal to 1 are online.

FAULTED At least one critical resource in the service group is faulted or is affected by a 
fault.

PARTIAL At least one, but not all, resources with Operations=OnOff is online, and not all 
AutoStart resources are online.

STARTING  Service group is attempting to go online.

STOPPING Service group is attempting to go offline.

A service group state can be a combination of multiple states. For example, 

OFFLINE | FAULTED

OFFLINE | STARTING

PARTIAL | FAULTED

PARTIAL | STARTING

PARTIAL | STOPPING

ONLINE | STOPPING

Default value = 1

The value of this attribute does not persist when the Policy Master restarts

The value of this attribute is set individually for each system in the group's SystemList.

You may not edit the value of this attribute.

SystemList Type-Dimension: integer-association

List of systems on which the service group is configured to run. Each system has an 
associated value reflecting its priority. Lower priority numbers indicate a preference for 
the system as a failover target. 

A service group must not be online on the systems to be deleted from its SystemList.

Default value = “”
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SystemListExpr Type-dimension: string-association

Expression that is used to derive the value of the SystemList attribute for a service group. 
Used when user performs the refresh for the SystemList.
Default values are: 
OU = ““
EA = ““

SystemZones Type-Dimension: integer-association

Indicates the virtual sublists within the SystemList attribute that grant priority in failing 
over. Values are string/integer pairs. The string key is the name of a system in the 
SystemList attribute, and the integer is the number of the zone. Systems with the same 
zone number are members of the same zone. If a service group faults on one system in a 
zone, it is granted priority to fail over to another system within the same zone.

Default value = ““

TriggerResStateChange Type-Dimension: boolean-scalar

Determines whether or not to invoke the resstatechange trigger if resource state 
changes.

Default value = 0 (disabled)

UserStrLocal Type-Dimension: string-scalar

Use this attribute for any purpose. It is not used by the Policy Master.

Default value = ““

You may edit the value of this attribute with the hagrp -modify command.

The value of this attribute is set individually for each system in the group's SystemList.

UserIntLocal Type-Dimension: integer-scalar

Use this attribute for any purpose. It is not used by the Policy Master.

Default value = 0

You may edit the value of this attribute with the hagrp -modify command.

The value of this attribute is set individually for each system in the group's SystemList.
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Resource type attributes
Resource type attributes apply to all resources of that specific type. The table in 
this section describes these static attributes. More information is available 
about resource type attributes.

See the Veritas Cluster Server One Agent Developer’s Guide.

Specific resource types that have defined values are listed in the file vcsone.xml. 
Unless otherwise notes, you may override the value of these attributes at the 
resource level.

Overriding static resource type attributes
Users can override the values of some predefined, static attributes for a specific 
resource without affecting the values of the attributes for other resources of 
that type. The table that follows identifies the attributes that can be overridden.

Users can override the values of specific resource attribute by:

■ Explicitly defining the attribute for the resource in the main.xml 
configuration file

■ Using the hares command from the command line with the -override 
option

Also, users can:

■ View the values of the overridden attributes by using the hares -display 
command. 

■ Remove overridden values of static attributes by using the 
hares -undo_override option from the command line.

Table 34-6 lists resource type attributes in alphabetical order and provides 
definitions and information about their use:

Table 34-6 Resource type attributes

Resource Type 
Attribute

Definition

ActionTimeout Type-Dimension: integer-scalar

Timeout value in seconds for the Action entry point. 

The valid values of this attribute are in the range of 4-315360000.

Default value = 30 
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AgentClass Type-Dimension: string-scalar

Indicates the scheduling class for the VCS One agent process. The following values are 
valid:

■ RT (Real Time)

■ TS (Time Sharing)

■ SHR (Solaris only)

You may use only one of the following sets of attributes to configure scheduling class 
and priority for VCS One:

■ AgentClass, AgentPriority, ScriptClass, ScriptPriority

■ OnlineClass, OnlinePriority, EPClass, EPPriority

This attribute is in use if the values of the following attributes is -1: 
OnlineClass, OnlinePriority, EPClass, and EPPriority

You may not override this value at the individual resource level.

Default value = TS

AgentDirectory Type-dimension: string-scalar

Specifies the path to a working directory for an agent and the directory from which 
script entry points are run.

If users do not set the AgentDirectory attribute, the agent uses the default directory 
$VCSONE_HOME/bin/resource_type. If the default directory does not exist, the agent 
uses the common agents directory /opt/VRTSagents/ha/bin/resource_type. If the 
agent cannot find any of the directories, the agent fails. 

Default =””

AgentFailedOn Type-Dimension: string-keylist

A list of systems on which the agent for the resource type has failed. 
The value of this attribute does not persist when the Policy Master restarts

You may not override this value at the individual resource level.

Default value is not applicable to this attribute.

You may not edit the value of this attribute.
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AgentFile Type-dimension: string-scalar

Specifies the path to an agent binary for a resource type. 

If the AgentFile attribute is not set, the vcsoneclientd process uses the agent in the 
agent file in following locations, in the order specified:

■ AgentDirectory attribute 

■ /opt/VRTSvcsone/bin/resource_type

■ /opt/VRTSagents/ha /resource_type

If the vcsoneclientd cannot find an agent file, the agent fails.

AgentPriority Type-Dimension: string-scalar

Indicates the priority in which the agent process runs.

You may use only one of the following sets of attributes to configure scheduling class 
and priority for VCS One:

■ AgentClass, AgentPriority, ScriptClass, ScriptPriority

■ OnlineClass, OnlinePriority, EPClass, EPPriority

This attribute is in use if the values of the following attributes is -1: 
OnlineClass, OnlinePriority, EPClass, and EPPriority

You may not override this value at the individual resource level.

Default value = 0

AgentReplyTimeout Type-Dimension: integer-scalar

The number of seconds the engine waits to receive a heartbeat from the agent before 
restarting the agent.

You may not override this value at the individual resource level.

The valid values of this attribute are in the range of 4-315360000.

Default value = 130

AgentStartTimeout Type-Dimension: integer-scalar

The number of seconds after starting the agent that the engine waits for the initial 
agent “handshake” before restarting the agent.

You may not override this value at the individual resource level.

Default value = 60

Table 34-6 Resource type attributes
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AllowedOnlineOps Type-Dimension: string-keylist

Defines whether or not an online resource can be deleted or modified.

The following values are valid for this attribute:

■   ““ ( null value)
The resource must be offline before it can be deleted.

■ delete
An online resource can be deleted.

■  modify
An online resource can be modified.

■ delete modify
An online resource can be deleted or modified.

Default value = ““

ArgList Internal use only.

AttrChangedTimeout Type-Dimension: integer-scalar

Maximum time (in seconds) within which the attr_changed entry point must complete 
or be terminated.

The valid values of this attribute are in the range of 4-315360000.

Default value = 60 seconds

AutoStart Type-Dimension: boolean-scalar

Specifies whether the resource is brought online when the service group is brought 
online;

Default value = 1 second

CleanRetryLimit Type-Dimension: integer-scalar

Number of times to retry clean before moving a resource to ADMIN_WAIT state. If set to 
0, clean is re-tried indefinitely. 

The valid values of this attribute are in the range of 0-1024.

Default value = 0

CleanTimeout Type-Dimension: integer-scalar

Maximum time (in seconds) within which the clean entry point must complete or else 
be terminated.

The valid values of this attribute are in the range of 4-315360000.

Default value = 60 
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CloseTimeout Type-Dimension: integer-scalar

Maximum time (in seconds) within which the close entry point must complete or else 
be terminated.

The valid values of this attribute are in the range of 4-315360000.

Default value = 60 

ConfInterval Type-Dimension: integer-scalar

When a resource has remained online for the specified number of seconds, the agents 
ignore previous faults and restart attempts when evaluating other attributes, such as 
the ToleranceLimit attribute and the RestartLimit attribute.

Default value = 600 seconds

ContainerOpts Type-Dimension: integer-association

Used in operating system virtualization technology environments. Indicates the 
options that may be passed to the agent framework so that Container behavior can be 
controlled at a resource level. 

This attribute cannot be modified if resources of this type are in use, unless you 
override for the specific resource you want modified. If you override this attribute, it 
can only be modified if the resource is in a clean OFFLINE state.

Note: A Mount resource type does not have this attribute. In order for a Mount 
resource to be brought up inside a Container, you must override this attribute at the 
resource level and set RUNINCONTAINER to 1.

Has the following keys: 

RUNINCONTAINER: Valid values are 0 and 1. Assign the value to 1 if you want the 
resource to be managed inside a Container. Group level attribute ContainerInfo must 
be set in order for this value to be effective. 

PASSCINFO: Valid values are 0 and 1. If set to 1, the agent framework sends the 
Container Information to the resource (agent entry points). Group level attribute 
ContainerInfo must be set in order for this value to be effective. 

PASSLOADINFO - Valid values are 0 and 1. If set to 1, the service group’s Load values are 
passed on to the resource verbatim.

Note: Load values must be set or changed when service group is in the OFFLINE state for 
a zone-enabled service group. Specifically, you may not use the hagrp -changeload 
command unless the zone-enabled service group is in the OFFLINE state. 

Default value = ““
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Created Type-Dimension: integer-scalar

Timestamp of when resource type object was created

Default value = ““

You may not edit the value of this attribute.

EPClass Type-Dimension: string-scalar

Configures the scheduling class for all entry points except online entry point. The 
following values are valid for this attribute:

■ RT (Real Time)

■ TS (Time Sharing)

■ SHR (Solaris only)

You may use only one of the following sets of attributes to configure scheduling class 
and priority for VCS One:

■ AgentClass, AgentPriority, ScriptClass, ScriptPriority

■ OnlineClass, OnlinePriority, EPClass, EPPriority

If the value of the EPPriority attribute is -1, this attribute is not in use and the 
following attributes are in effect: AgentClass, AgentPriority, ScriptClass, ScriptPriority

See “About the control of the scheduling class and scheduling priority of agent 
operations” on page 57.

You may not override this value at the individual resource level.

Default value = -1
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EPPriority Type-Dimension: string-scalar

Configures the scheduling priority for all entry points except the online entry point.

You may use only one of the following sets of attributes to configure scheduling class 
and priority for VCS One:

■ AgentClass, AgentPriority, ScriptClass, ScriptPriority

■ OnlineClass, OnlinePriority, EPClass, EPPriority

If the value of this attribute is -1, this attribute is not in use and the following 
attributes are in effect: AgentClass, AgentPriority, ScriptClass, ScriptPriority

If the value of this attribute is 0, it indicates the base operating system priority for the 
configured scheduling class.

For example:

■ (Solaris) If the EPClass attribute is set to TS*, and the value of the EPPriority 
attribute is set to 0, then the base priority for entry points is set to 59, as that is 
the default value set by the operating system. 

■ (Solaris) If the EPClass attribute is set to TS*, and the value of the EPPriority 
attribute is set to -20, then the scheduling priority of the entry point would be 39 
(59 base value and - 20 configured value) 

■ (Solaris) If the EPClass attribute is set to RT*, and the value of the EPPriority 
attribute is set to 0, then the base priority for entry points is set to 100 by the 
operating system.

See “About the control of the scheduling class and scheduling priority of agent 
operations” on page 57.

You may not override this value at the individual resource level.

Default value = -1

FaultOnMonitorTimeouts Type-Dimension: integer-scalar

When a monitor times out as many times as the value specified, the corresponding 
resource is brought down by calling the clean entry point. The resource is then marked 
FAULTED, or it is restarted, depending on the value of the RestartLimit attribute.

When FaultOnMonitorTimeouts is set to 0, monitor failures are not considered 
indicative of a resource fault. A low value may lead to spurious resource faults, 
especially on heavily loaded systems.

The valid values of this attribute are in the range of 0-2147483647.

Default value = 4

Table 34-6 Resource type attributes

Resource Type 
Attribute

Definition



865Attributes reference
Resource type attributes
FireDrill Type-Dimension: boolean-scalar

Specifies whether or not fire drill is enabled for the resource type. If set to 1, fire drill is 
enabled. If set to 0, it is disabled.

You may not override this value at the individual resource level.

Default value = 0

IMF Type-Dimension: integer-scalar

Enables the use and control of type-level monitoring for a resource. By setting this 
attribute, the agent developer can switch between type-level monitoring and 
monitoring a resource using the monitor entry point.

The IMF attribute has the following keys:

■ Mode-This key can take values from 0 to 3. Default value is 3.
0 - Set the Mode to 0 to disable type-level monitoring. When the Mode is set to 1, 
the agent monitors all resource using the monitor entry point.
1- Set the Mode to 1 to enable type-level monitoring for all offline resources. 
When the Mode is set to 1, the agent monitors all the offline resources using type-
level monitoring, whereas it monitors all the online resources using the monitor 
entry point.
2- Set the Mode to 2 to enable type-level monitoring for all online resources. 
When the Mode is set to 2, the agent monitors all online resources using type-
level monitoring, but it monitors all the offline resources using the monitor entry 
point.
3- Set the mode to 3 to enable type-level monitoring for both online and offline 
resources.

■ MonitorFreq-Specifies the frequency at which the monitor entry point is invoked, 
after type-level monitoring has been enabled for a module. The value of this key is 
an integer. 
If you enable type-level monitoring, the monitor entry point is invoked every 
(MonitorFrequency x MonitorInterval) number of seconds, where MonitorInterval 
is a type-level static attribute.
If the MonitorFreq is set to 0 (zero), the resource is monitored periodically using 
the monitor entry point. Default value is 100.

■ RegisterRetryLimit-When the Mode key is set to 1, 2 or 3, the 
VCSAgEPIMFRegister entry point is invoked for some of the resources to register 
them with the type-level monitoring module. If the registration fails for a 
resource, the agent framework re-tries to register each resource depending upon 
the value of RegisterRetryLimit set. If it cannot register the resource, it continues 
monitoring the resource using the monitor entry point. Default value: 100
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InfoInterval Type-Dimension: integer-scalar

Duration (in seconds) after which the agent framework invokes the info entry point for 
ONLINE resources of the particular resource type. 

If set to 0, the agent framework does not periodically invoke the info entry point. To 
manually invoke the info entry point, use the command hares -refreshinfo. If the 
value you designate is 30, for example, the entry point is invoked every 30 seconds for 
all ONLINE resources of the particular resource type.

The valid values of this attribute are in the range of 0-315360000.

Default value = 0

InfoTimeout Type-Dimension: integer-scalar

Timeout value for info entry point. If entry point does not complete by the designated 
time, the agent framework cancels the entry point’s thread.

The valid values of this attribute are in the range of 4-315360000.

Default value = 30 seconds

LastConfigUpdate Type-Dimension: integer-scalar

Timestamp of when type object was last modified

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LevelTwoMonitorFreq Type-Dimension: integer-scalar

Specifies the frequency with which the agent for this type performs second-level 
monitoring. Default is 1, which means every monitor cycle would also do second-level 
monitoring.

The valid values of this attribute are in the range of 0-1024.

Default value = 1

You may edit the value of this attribute with the hares -modify command or the GUI.

LogDbg Type-Dimension: string-keylist

Indicates the debug severities that are enabled for the resource type or agent 
framework. The debug severities that are used by the agent entry points are in the 
range of DBG_1–DBG_21. The debug messages from the agent framework are logged 
with the severities DBG_AGINFO, DBG_AGDEBUG, AND DBG_AGTRACE, representing the least 
to most verbose.

Default value = ““
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LogFileSize Type-Dimension: integer-scalar

Specifies the size (in bytes) of the agent log file. 

You may not override this value at the individual resource level.

The valid values of this attribute are in the range of 
65536 (64 KB) -134217728 (128 MB).

Default value = 33554432 (32 MB)

MinCompatAgentVersion Type-Dimension: string-scalar

Each time an agent registers with the Policy Master, the Policy Master checks the 
version of the agent to ensure it meets the requirements of the 
MinCompatAgentVersion attribute. 

Specifies the lowest version of an agent for this resource type that can work with this 
version of the Type definition. The TypeDefinitionVersion attribute gives the version 
of this Type definition.

Default value = UNKNOWN

Do not edit the value of this attribute.

MonitorInterval Type-Dimension: integer-scalar

Duration (in seconds) between two consecutive monitor calls for an ONLINE or 
transitioning resource.

The valid values of this attribute are in the range of 1-315360000.

Default value = 60 seconds

A lower value may affect performance if many resources of the same type exist. A 
higher value may delay detection of a faulted resource.

MonitorMethod Type-Dimension: string-scalar

Specifies the method of monitoring the resource uses. Default value indicates a 
monitor function is run periodically to check the health of the resource.

The value of this attribute does not persist when the Policy Master restarts

You may not override this value at the individual resource level.

Default value = Traditional

You may not edit the value of this attribute.

Table 34-6 Resource type attributes

Resource Type 
Attribute

Definition



868 Attributes reference
Resource type attributes
MonitorStatsParam Type-Dimension: integer-association

Stores the required parameter values for calculating monitor time statistics. The 
following values are valid for this attribute:

Frequency: Defines the number of monitor cycles after which the average monitor 
cycle time should be computed and sent to the engine. The configured value for this 
attribute must be between 1 and 30. Default value = 0.

ExpectedValue: The expected monitor time in milliseconds for all resources of this 
type. Default value = 100.

ValueThreshold: The acceptable percentage difference between the expected monitor 
cycle time (ExpectedValue) and the actual monitor cycle time. Default value = 100.

AvgThreshold: The acceptable percentage difference between the benchmark average 
and the moving average of monitor cycle times. Default value = 40.

MonitorTimeout Type-Dimension: integer-scalar

Maximum time (in seconds) within which the monitor entry point must complete or 
else be terminated.

The valid values of this attribute are in the range of 4-315360000.

Default value = 60 seconds

MsgCatID Type-dimension: integer-scalar

Message category ID that is used for the resource type object.

Default value = 1

NumThreads Type-Dimension: integer-scalar

Limits the number of threads an agent can create.

For the efficient management of system and process resources, the agent framework 
uses a threads-on-demand method to create and remove service threads: an agent adds 
threads dynamically for a given resource and the agent framework removes threads no 
longer needed, freeing them for use by other agents. A significantly large number of 
threads (over 30, for example) can degrade system and process performance. 

A value of 1 prevents the creation of multiple threads. This limit does not include the 
threads that are used for other internal purposes.

You may not override this value at the individual resource level.

Default= 10
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OfflineMonitorInterval Type-Dimension: integer-scalar

Duration in seconds between two consecutive monitor calls for an OFFLINE resource. If 
set to 0, OFFLINE resources are not monitored.

With a value of 0, concurrency violations are not detected. If an application that is 
supposed to be in the offline state on a node is brought to the online state outside of 
VCS One control, the application continues to run. This behavior is because VCS One 
cannot detect this state change. Data is protected using I/O fencing. As mentioned, to 
avoid this, one can set OfflineMonitorInterval to a non-zero value (apart from 
overriding it for a specific resource).

The valid values of this attribute are in the range of 0-315360000.

Default value = 0

OfflineTimeout Type-Dimension: integer-scalar

Maximum time (in seconds) within which the offline entry point must complete or else 
be terminated.

The valid values of this attribute are in the range of 4-315360000.

Default value = 300 seconds

OfflineWaitLimit Type-Dimension: integer-scalar

Number of monitor intervals to wait after the offline process is completed, and before 
the resource is taken offline.

Increase this value for the virtual machines that take longer than four minutes to shut 
down.

The valid values of this attribute are in the range of 0-1024.

Default value = 0
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OnlineClass Type-Dimension: string-scalar

Configures the scheduling class for the online entry point. The following values are 
valid for this attribute:

■ RT (Real Time)

■ TS (Time Sharing)

■ SHR (Solaris only)

You may use only one of the following sets of attributes to configure scheduling class 
and priority for VCS One:

■ AgentClass, AgentPriority, ScriptClass, ScriptPriority

■ OnlineClass, OnlinePriority, EPClass, EPPriority

If the value of the OnlinePriority attribute is -1, this attribute is not in use and the 
following attributes are in effect: AgentClass, AgentPriority, ScriptClass, ScriptPriority

See “About the control of the scheduling class and scheduling priority of agent 
operations” on page 57.

You may not override this value at the individual resource level.

Default value = -1
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OnlinePriority Type-Dimension: string-scalar

Configures the scheduling priority for the online entry point.

You may use only one of the following sets of attributes to configure scheduling class 
and priority for VCS One:

■ AgentClass, AgentPriority, ScriptClass, ScriptPriority

■ OnlineClass, OnlinePriority, EPClass, EPPriority

If the value of this attribute is -1, this attribute is not in use and the following 
attributes are in effect: AgentClass, AgentPriority, ScriptClass, ScriptPriority

If the value of this attribute is 0, it indicates the base operating system priority for the 
configured scheduling class.

For example:

■ (Solaris) If the EPClass attribute is set to TS*, and the value of the EPPriority 
attribute is set to 0, then the base priority for entry points is set to 59, as that is 
the default value set by the operating system. 

■ (Solaris) If the EPClass attribute is set to TS*, and the value of the EPPriority 
attribute is set to -20, then the scheduling priority of the entry point would be 39 
(59 base value and - 20 configured value) 

■ (Solaris) If the EPClass attribute is set to RT*, and the value of the EPPriority 
attribute is set to 0, then the base priority for entry points is set to 100 by the 
operating system.

See “About the control of the scheduling class and scheduling priority of agent 
operations” on page 57.

You may not override this value at the individual resource level.

Default value = -1

OnlineRetryLimit Type-Dimension: integer-scalar

Number of times to retry online if the attempt to bring a resource online is 
unsuccessful.

The value for this attribute must be between 0 and 1024.

Default value = 0
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OnlineTimeout Type-Dimension: integer-scalar

Maximum time (in seconds) within which the online entry point must complete or else 
be terminated.

The valid values of this attribute are in the range of 4-315360000.

Default value = 300 seconds

Modification notes: Increase only if resource is likely to take a longer time to come 
online.

OnlineWaitLimit Type-Dimension: integer-scalar

Number of monitor intervals to wait after completing the online procedure, and before 
the resource becomes online.

The valid values of this attribute are in the range of 0-2147483647.

Default value = 2

OpenTimeout Type-Dimension: integer-scalar

Maximum time (in seconds) within which the open entry point must complete or else 
be terminated.

The valid values of this attribute are in the range of 4-315360000.

Default value = 60 seconds

Operations Type-Dimension: string-scalar

Indicates the valid operations of the resources of the resource type. 

Values are OnOnly (can online only), OnOff (can online and offline), None (cannot 
online or offline).

You may not override this value at the individual resource level.

Default value = OnOff

You may modify the value of this attribute when a resource of that type is not 
configured.

RestartLimit Type-Dimension: integer-scalar

Number of times to retry bringing a resource online when it is taken offline 
unexpectedly and before VCS One declares it FAULTED.

The valid values of this attribute are in the range of 0-2147483647.

Default value = 0
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ScriptClass Type-Dimension: string-scalar

Indicates the scheduling class of the script processes created by the agent.The online 
script is an example of a script process affected by this scheduling class. The following 
values are valid for this attribute:

■ RT (Real Time)

■ TS (Time Sharing)

■ SHR (Solaris only)

You may use only one of the following sets of attributes to configure scheduling class 
and priority for VCS One:

■ AgentClass, AgentPriority, ScriptClass, ScriptPriority

■ OnlineClass, OnlinePriority, EPClass, EPPriority

This attribute is in use if the values of the following attributes is -1: 
OnlineClass, OnlinePriority, EPClass, and EPPriority

You may not override this value at the individual resource level.

Default value = TS

ScriptPriority Type-Dimension: string-scalar

Indicates the priority of the script processes created by the agent.

You may use only one of the following sets of attributes to configure scheduling class 
and priority for VCS One:

■ AgentClass, AgentPriority, ScriptClass, ScriptPriority

■ OnlineClass, OnlinePriority, EPClass, EPPriority

This attribute is in use if the values of the following attributes is -1: 
OnlineClass, OnlinePriority, EPClass, and EPPriority

You may not override this value at the individual resource level.

Default value = 0

SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = types.xml

SupportedActions Type-Dimension: string-keylist

Valid action tokens for resource.

You may not override the value of this attribute at the individual resource level.

Default value = ““

Table 34-6 Resource type attributes

Resource Type 
Attribute

Definition



874 Attributes reference
Resource attributes
Resource attributes
Table 34-7 lists resource attributes in alphabetical order and provides 
definitions and information about their use:

ToleranceLimit Type-Dimension: integer-scalar

Number of times the monitor entry point should return OFFLINE before declaring the 
resource FAULTED.

The valid values of this attribute are in the range of 0-2147483647.

Default value = 0

Modification note: A large value could delay detection of a genuinely faulted resource.

TypeDefinitionVersion Type-Dimension: string-scalar

Specifies the version of the type-definition in use by all the agents of this type on a 
given platform. The type-definition version for a given resource type could be different 
on different platforms.

See “About the types file” on page 686.

Default value = UNKNOWN

Do not edit the value of this attribute.

Table 34-6 Resource type attributes

Resource Type 
Attribute

Definition

Table 34-7 Resource attributes

Resource Attribute Definition

ArgListValues Type-Dimension: string-vector

List of arguments that are passed to the resource’s agent on each system/pframe. This 
attribute is resource-specific and system/pframe-specific, which means that the list of 
values that are passed to the agent depend on which system/pframe and resource they 
are intended.

Default value is not applicable to this attribute

You may not edit the value of this attribute.

AutoStart Type-Dimension: boolean-scalar

Indicates the resource is brought online when the service group is brought online.

Default value = 1
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ComputeStats Type-Dimension: boolean-scalar

Indicates to agent framework whether or not to calculate the resource’s monitor 
statistics.

Default value = 0

ConfidenceLevel Type-Dimension: integer-scalar

Indicates the level of confidence [percentage] in an online resource. 

The value for this attribute ranges from 0-100. Note that some VCS One agents may not 
take advantage of this attribute and may always set it to 0. Set the level to 100% if the 
attribute is not used. 

Default value = 0.

You may not edit the value of this attribute.

ConfidenceMsg Type-Dimension: string-scalar

Indicates the reason why the level of confidence of an online resource is not 100%.

The values for this attribute are specific to the agent that manages the resource.

Default value = ““

You may not edit the value of this attribute.

ControlGroup Type-Dimension: string-scalar

This attribute indicates whether or not a resource is an off-host resource. The following 
values are valid for this attribute: 

■ ControlGroup value = ““ (null) indicates the resource is a local resource. 

■ ControlGroup value = name of the control group indicates the resource is an off-host 
resource. 

The control group is located on the control system. 

Only resources of type NetAppExport can be configured as off-host resources.

ControlMode Type-Dimension: boolean-scalar

Indicates whether (1) or not(0) it is necessary to provide values for required attributes in 
order for a resource in the control group to online completely.

Use ControlMode = 1 when the resource is running as part of the control group and it is 
not necessary to provide values for the required attributes of the resource. Tells the agent 
that the off-host resource provides this resource the list of arguments.

Only resources of type NetAppExport can be configured as off-host resources.

Default value = 1

Table 34-7 Resource attributes

Resource Attribute Definition
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Enabled Type-dimension: boolean-scalar

Indicates that agents monitor the resource. If a resource is created dynamically while 
VCS One is running, you must enable the resource before VCS One monitors it. 

When Enabled = 0, the resource is disabled. A disabled resource is not brought online.

Default value = 1 if the resource is in main.xml before starting VCS One, otherwise the 
default value is 0.

You may edit the value of this attribute only by editing the configuration file directly.

Flags Type-Dimension: integer-scalar

Provides additional information for the state of a resource. Primarily this attribute raises 
flags pertaining to the resource. 

Values:

AGENT FAILED indicates that the agent for the resource has failed.

CONTROL GROUP OFFLINE indicates that the control group is offline.

NORMAL indicates standard working order.

RESTARTING indicates the resource has faulted and the agent is attempting to restart 
the resource on the same system/pframe.

STATE UNKNOWN indicates the latest monitor call by the agent could not determine if 
the resource was online or offline.

MONITOR TIMEDOUT indicates the latest monitor call by the agent was terminated 
because it exceeded the maximum time that is specified by the static attribute 
MonitorTimeout.

UNABLE TO OFFLINE indicates the agent attempted to offline the resource but the 
resource did not go offline. This flag is also set when a resource faults and the clean entry 
point completes successfully, but the subsequent monitor hangs or is unable to 
determine resource status.

Default value is not applicable to this attribute.

You may not edit the value of this attribute.

Group Type-Dimension: string-scalar

The name of the group to which the resource belongs. Applicable only for resources 
belonging to service groups.

See “VFrame” on page 882.

This attribute only displays using the CLI, for example, the hares -display command.

Default value = ““

You may not edit the value of this attribute.

Table 34-7 Resource attributes

Resource Attribute Definition
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IState Type-Dimension: integer-scalar

Indicates the internal state of a resource. In addition to the State attribute, this attribute 
shows to which state the resource is transitioning.

Values:

NOT WAITING — Resource is not in transition.

WAITING TO GO ONLINE — Agent has been notified to bring the resource online but the 
procedure is not yet complete.

WAITING FOR CHILDREN ONLINE — Resource is to be brought online, but the resource depends 
on at least one offline resource. Resource transitions to WAITING TO GO ONLINE state when 
all children are online.

WAITING TO GO OFFLINE — Agent has been notified to take the resource offline but the 
procedure is not yet complete.

WAITING TO GO OFFLINE (propagate) — Agent has been notified to take the resource offline 
but the procedure is not yet complete. When the process is complete, the resource’s 
children are also offline.

WAITING TO GO ONLINE (reverse) — Resource is waiting to be brought online, but when it is 
online it attempts to go offline. Typically this is the result of an offline command that is 
issued while the resource waits to go online.

WAITING TO GO OFFLINE (reverse/propagate) — Resource is waiting to be brought online, but 
when it is online it attempts to go offline, and the resource propagates the offline action.

Default value = NOT WAITING

You may not edit the value of this attribute.

LastOnline Type-Dimension: string-scalar

Indicates the system/pframe name on which the resource was last online. The Policy 
Master sets this attribute. 

Default value is not applicable to this attribute.

You may not edit the value of this attribute.

MonitorOnly Type-dimension: boolean-scalar

A value of 0 indicates a resource can be taken offline and brought online. If the resource 
can be monitored only, the value is 1. 

The hagrp -freeze command modifies the value of this attribute.

Default value = 0

You may not edit the value of this attribute.

Table 34-7 Resource attributes

Resource Attribute Definition
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MonitorTimeStats Type-dimension: string-association

Keys are Average and TS. The values indicate the Average time that is taken by the 
monitor entry point since the time that is indicated by the timestamp (TS) that Average 
was updated. 

Default value = Average = 0; TS = ““

You may not edit the value of this attribute.

Name Type-Dimension: string-scalar

Name of the resource.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

NotifyAttrChange Type-Dimension: string-keylist

The value of this attribute is a list of attributes. Whenever any of the attributes in this list 
is modified, the RES_ATTR_CHANGE event is generated.

Use this attribute to monitor changes in resource attributes. 

Default value = ““

Path Type-Dimension: string-scalar

Set to 1 to identify a resource as a member of a path in the dependency tree to be taken 
offline on a specific system/pframe after a resource faults.

Default value = 0.

You may not edit the value of this attribute.

PlatformName Type-Dimension: string-scalar

The name of the platform of the service group to which the resource belongs.

See “PlatformName” on page 855.

This attribute only displays using the CLI, for example, the hares -display command.

Default value = ““

You may not edit the value of this attribute.

Probed Type-Dimension: integer-scalar

Indicates whether the agent has detected the resource.

Default value = 0.

You may not edit the value of this attribute.

Table 34-7 Resource attributes

Resource Attribute Definition
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ResCreated Type-Dimension: integer-scalar

Default value = ““

You may not edit the value of this attribute.

ResFaultPolicy Type-Dimension: string-scalar

Controls the behavior of a resource in the event of a fault. The following values are valid 
for this attribute:

■ FaultPropagateAll

■ FaultPropagateParent

■ FaultHold

■ FaultNone

See “Resource level control after a fault” on page 260.

See “Faulted resource state not reflected in service group state” on page 714.

Default value = FaultPropagateAll

ResLastConfigUpdate Type-Dimension: integer-scalar

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

ResLastStateUpdate Type-Dimension: integer-scalar

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

ResourceInfo Type-Dimension: string-association

Indicates information about the resource as it is populated by the info entry point. This 
attribute has three predefined keys:

State: Values are Valid, Invalid, or Stale

Msg: Output of the info entry point captured on stdout by the agent framework

TS: Timestamp that indicates when the agent framework updated the ResourceInfo 
attribute.

Defaults:

State = Valid

Msg = “”

TS = “”

Table 34-7 Resource attributes

Resource Attribute Definition
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Signaled Type-Dimension: integer-association

Used when you bring a service group online or take it offline. This attribute indicates 
whether or not a resource has been traversed. The following values are valid for this 
attribute: online, offline, clear, visited.

The value of this attribute does not persist when the Policy Master restarts.

Default values:

online = 0

offline = 0

clear = 0

visited = 0

You may not edit the value of this attribute.

SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = ““

Start Type-Dimension: integer-scalar

Indicates whether a resource was started (the process of bringing it online was initiated) 
on a system/pframe.

Default value = 0.

You may not edit the value of this attribute.

Table 34-7 Resource attributes

Resource Attribute Definition
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State Type-Dimension: integer-scalar

Displays the state of the resource and the flags that are associated with the resource.

This attribute and the Flags attribute present a comprehensive view of the resource’s 
current state.

Values:

ONLINE

OFFLINE

FAULTED

ONLINE | STATE UNKNOWN

ONLINE | MONITOR TIMEOUT

ONLINE | UNABLE TO OFFLINE

ONLINE | ADMIN_WAIT

OFFLINE | STATE UNKNOWN

FAULTED | RESTARTING

A faulted resource is physically offline, though unintentionally.

Default value = OFFLINE.

You may not edit the value of this attribute.

Type Type-Dimension: string-scalar

The resource type of the resource.

This attribute only displays using the CLI, for example, the hares -display command.

Default value = ““

You may not edit the value of this attribute.

VFrame Type-Dimension: string-scalar

The name of the VFrame to which the resource belongs. Applicable only for resources 
belonging to VFrames.

See “Group” on page 877.

This attribute only displays using the CLI, for example, the hares -display command.

Default value = ““

You may not edit the value of this attribute.

Table 34-7 Resource attributes

Resource Attribute Definition
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Table 34-8 lists role attributes in alphabetical order and provides definitions 
and information about their use.

Note: Role attributes that correspond to virtualization are visible to the user. 
This capability is not supported in the current release, but will be available in 
the future.

WorkLoad Type-Dimension: integer-association

Service group’s load is passed to this resource when PassLoadInfo in ContainerOpts 
attribute for this resource type is set to 1. Service group’s load is stored verbatim in this 
attribute.

Default value = ““

You may not edit the value of this attribute.

Table 34-7 Resource attributes

Resource Attribute Definition

Table 34-8 Role attributes

Role attribute Definition

AutomationPrivileges Type-Dimension: integer-scalar

The business policy automation privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

Category Type-Dimension: integer-scalar

Denotes certain characteristics of a role.

Default value = 0.

You may edit the value of this attribute only by editing the configuration file directly.

Count Internal use only.

Created Type-Dimension: integer-scalar

Timestamp of when role was created

Default value = ““

You may not edit the value of this attribute.
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CSGPrivileges Type-Dimension: integer-scalar

The composite service group privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

Description Type-Dimension: string-scalar

Text that describes the role.

Default value = ““

FarmPrivileges Type-Dimension: integer-scalar

The farm level privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

GroupPrivileges Type-Dimension: integer-scalar

The group level privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly

LastConfigUpdate Type-Dimension: integer-scalar

Timestamp of when role was last modified.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

MsgCatID Type-Dimension: integer-scalar

Message category ID used for the role object.

Default value = 1

NotifierPrivileges Type-Dimension: integer-scalar

The Notifier Privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

Table 34-8 Role attributes

Role attribute Definition
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ObjectPrivileges Type-Dimension: integer-scalar

The object level privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

OTPrivileges Type-Dimension: integer-scalar

The OrgTree privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

PFramePrivileges Type-Dimension: integer-scalar

The PFrame privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

ResourcePrivileges Type-Dimension: integer-scalar

The resource privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

rollback_state Internal use only.

SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = main.xml

SystemPrivileges Type-Dimension: integer-scalar

The system privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

Type Type-Dimension: integer-scalar

Denotes the type of this role. Possible values are Object, System, Group, Resource, User, 
OT, Notifier, VObject, PFrame, VFrame, Farm, CSG, or Automation. 

The value for this attribute must be between -1 and 12.

Default value = -1.

You may edit the value of this attribute only by editing the configuration file directly.

Table 34-8 Role attributes

Role attribute Definition
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Table 34-9 lists user and usergroup attributes in alphabetical order and provides 
definitions and information about their use.

Note: User attributes that correspond to virtualization are visible to the user. 
This capability is not supported in the current release, but will be available in 
the future.

UserPrivileges Type-Dimension: integer-scalar

The user privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

ValidPrivBits Internal use only.

VFramePrivileges Type-Dimension: integer-scalar

The VFrame privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

VObjectPrivileges Type-Dimension: integer-scalar

The vobject level privileges that a role contains.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly

Table 34-8 Role attributes

Role attribute Definition

Table 34-9 User and usergroup level attributes

User Attribute Definition

CanImpersonate Internal use only.

Created Type-Dimension: integer-scalar

Timestamp of when user object was created

Default value = ““

You may not edit the value of this attribute.
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CSGRoles Type-Dimension: string-association

List of composite service groups and the respective composite service group roles 
that are assigned to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

EffectiveCSGPrivs Internal use only.

EffectiveFarmPrivs Internal use only.

EffectiveGrpPrivs Internal use only.

EffectiveNotifierPrivs Internal use only.

EffectiveObjPrivs Internal use only.

EffectiveOTPrivs Internal use only.

EffectiveOUAutomationPrivs Internal use only.

EffectiveOUCSGPrivs Internal use only.

EffectiveOUGrpPrivs Internal use only.

EffectiveOUObjPrivs Internal use only.

EffectiveOUPFramePrivs Internal use only.

EffectiveOUSysPrivs Internal use only.

EffectiveOUUsrGrpPrivs Internal use only.

EffectiveOUUsrPrivs Internal use only.

EffectiveOUVFramePrivs Internal use only.

EffectiveOUVObjectPrivs Internal use only.

EffectivePFramePrivs Internal use only.

EffectiveResPrivs Internal use only.

EffectiveSysPrivs Internal use only.

EffectiveUsrGrpPrivs Internal use only.

EffectiveUsrPrivs Internal use only.

EffectiveVFramePrivs Internal use only.

Table 34-9 User and usergroup level attributes

User Attribute Definition
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EffectiveVObjectPrivs Internal use only.

Email Type-dimension: string-scalar

The user’s email address that is used for notification.

Default =””

Enabled Type-dimension: boolean-scalar

Specifies whether user is enabled, that is, capable of performing privileged 
operations.

Default value = 1.

You may edit the value of this attribute only by editing the configuration file 
directly.

FarmRoles Type-Dimension: string-association

The roles that are assigned to the user for the VCS One cluster.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

FirstName Type-Dimension: string-scalar

The first name of the user.

Default value = ““

GroupRoles Type-dimension: string-association

List of service groups and the respective group roles that are assigned to the user.

Default =””

You may edit the value of this attribute only by editing the configuration file 
directly.

LastConfigUpdate Type-Dimension: integer-scalar

Timestamp of when user object was last modified

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LastLogin Type-Dimension: integer-scalar

Denotes the last time the user logged on to the VCS One cluster using the GUI.

Default value = ““

You may not edit the value of this attribute.

Table 34-9 User and usergroup level attributes

User Attribute Definition
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LastMessageSent Internal use only.

LastName Type-Dimension: string-scalar

The last name of the user.

Default value = ““

MsgCatID Type-Dimension: integer-scalar

Message category ID used for the user object.

Default value = 1

NotifierRoles Type-Dimension: string-association

The list of notifier roles that are assigned to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

ObjectRoles Type-Dimension: string-association

A list of objects and the respective object roles that are assigned to the user on the 
VCS One cluster.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

OTRoles Type-Dimension: string-association

A list of OUValuePaths and the respective OT roles that are assigned on them to the 
user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

OUAutomationRoles Type-Dimension: string-association

A list of OUValuePaths and the respective automation roles that are assigned on 
them to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

Table 34-9 User and usergroup level attributes

User Attribute Definition
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OUCSGRoles Type-Dimension: string-association

A list of OUValuePaths and the respective composite service group roles that are 
assigned to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

OUGroupRoles Type-Dimension: string-association

A list of OUValuePaths and the respective group roles that are assigned on them to 
the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

OUObjectRoles Type-Dimension: string-association

A list of OUValuePaths and the respective object roles that are assigned on them to 
the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

OUPFrameRoles Type-Dimension: string-association

A list of OUValuePaths and the respective PFrame roles that are assigned on them 
to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

OUSystemRoles Type-Dimension: string-association

A list of OUValuePaths and the respective system roles that are assigned on them 
to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

Table 34-9 User and usergroup level attributes

User Attribute Definition
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OUUserGroupRoles Type-Dimension: string-association

A list of OUValuePaths and the respective usergroup roles that are assigned on 
them to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

OUUserRoles Type-Dimension: string-association

A list of OUValuePaths and the respective user roles that are assigned on them to 
the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

OUVFrameRoles Type-Dimension: string-association

A list of OUValuePaths and the respective VFrame roles that are assigned on them 
to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

OUVObjectRoles Type-Dimension: string-association

A list of OUValuePaths and the respective vobject roles that are assigned on them 
to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

PFrameRoles Type-Dimension: string-association

List of PFrames and the respective PFrame roles that are assigned to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

Table 34-9 User and usergroup level attributes

User Attribute Definition
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ResourceRoles Type-dimension: string-association

List of resources and the respective resource roles that are assigned on them to the 
user.

Default =””

You may edit the value of this attribute only by editing the configuration file 
directly.

SnmpAddress Type-dimension: string-scalar

IP address of console where SNMP traps are to be sent for the user.

Default =””

SourceFile Type-dimension: string-scalar

The name of the XML file where this object resides.

Default value = main.xml

SystemRoles Type-dimension: string-association

List of systems and the respective system roles that are assigned on them to user.

Default =””

You may edit the value of this attribute only by editing the configuration file 
directly.

UserGroupRoles Type-Dimension: string-association

List of user groups and the respective user group roles that are assigned on them to 
user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

UserPref Type-Dimension: integer-scalar

Denotes if this User object is a User Preference object.

Default value = 0.

You may edit the value of this attribute only by editing the configuration file 
directly.

UserRoles Type-dimension: string-association

List of users and the respective user roles that are assigned on them to user.

Default =””

You may edit the value of this attribute only by editing the configuration file 
directly.

Table 34-9 User and usergroup level attributes

User Attribute Definition
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VCSOneClientName Type-dimension: string-vector

A special attribute of a VCSOneClient user that denotes the name of the client 
system of the particular VCS One Client process.

Default =””

You may edit the value of this attribute only by editing the configuration file 
directly.

VFrameRoles Type-Dimension: string-association

List of VFrames and the respective VFrame roles that are assigned to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

VObjectRoles Type-Dimension: string-association

List of Vobjects and the Vobject roles that are assigned on them to the user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

WebUser Type-dimension: integer-scalar

A flag denoting that the user is a special Web server user.

Default value = ““

You may edit the value of this attribute only by editing the configuration file 
directly.

Table 34-9 User and usergroup level attributes

User Attribute Definition
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Group Transition Queue attributes
Table 34-10 lists GTQ attributes in alphabetical order and provides definitions 
and information about their use.

Table 34-10 Group transition queue attributes

GTQ entry attribute Definition

CompatibleGroups Type-Dimension: string-keylist

List of the service group names that are compatible with the service group represented by 
this GTQ entry. If this attribute has a value, the service group’s IncompatibleGroups 
attribute may not have a value. A service group must be compatible with service groups 
with which it has a dependency relationship.

Default= none

You may edit the value of this attribute only by editing the main.xml configuration file 
directly.

ContextIdList Internal use only.

GroupNameList Type-Dimension: string-keylist

List of the service group names that this GTQ entry represents.

Default value = ““

You may not edit the value of this attribute.

IncompatibleGroups Type-Dimension: string-keylist

List of the service group names that are incompatible with current service group. If the 
attribute has a value, the service group’s CompatibleGroups attribute may not have a 
value, and vice versa. A service group must be compatible with service groups with which 
it has a dependency relationship.

Default value = none

You may edit the value of this attribute only by editing the configuration file directly.

Load Type-Dimension: integer-association

Load of all the service groups for which the target system is to be decided.

Default value = ““

You may not edit the value of this attribute.

MsgCatID Type-Dimension: integer-scalar

Message category ID used for the GTQ entry object

Default value = 1
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Action entry attributes
Action entry attributes are part of the GTQ functionality.

Priority Type-Dimension: integer-scalar

Priority of the service groups that this GTQ entry represents.

Default value = ““

You may not edit the value of this attribute.

RollbackCopy Internal use only.

SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = main.xml

TargetCriteria Type-Dimension: integer-scalar

Criteria for the decision of the target system/pframe.

Default value = ““

You may not edit the value of this attribute.

TargetFlag Type-Dimension: integer-scalar

A flag that is specific to this GTQ entry indicating if this is INTENTONLINE GTQEntry, if 
target is yet to be decided, or if target decision is already made.

Default value = ““

You may not edit the value of this attribute.

TargetSystem Type-Dimension: string-scalar

The system/pframe where the service group is targeted to go online.

Default value = ““

You may not edit the value of this attribute.

Table 34-10 Group transition queue attributes

GTQ entry attribute Definition



895Attributes reference
Action entry attributes
Table 34-11 lists action entry attributes in alphabetical order and provides 
definitions and information about their use:

Table 34-11 Action entry attributes

Action entry attribute Definition

DependentActionList Type-Dimension: string-keylist

List of the action names on which this action depends.

Default value = ““

You may not edit the value of this attribute.

DependentKickoutActionList Type-Dimension: string-keylist

List of the dependent action names that are specific to target system/pframe. 
Examples are: offline action for a service group that is to be kicked out, or online of 
a child service group on which this service group depends. This list is always 
cleared before redeciding target.

Default value = ““

You may not edit the value of this attribute.

GroupName Type-Dimension: string-scalar

Name of the service group.

Default value = ““

You may not edit the value of this attribute.

MsgCatID Type-Dimension: integer-scalar

Message category ID that is used for the actionentry object

Default value = 1

NextActionList Type-Dimension: string-keylist

Next action to be executed in the plan sequence. 

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

OpCode Type-Dimension: integer-scalar

Operation code. Valid values are: online, offline, and intent-online

Default value = ““

You may not edit the value of this attribute.
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RollbackCopy Type-Dimension: integer-scalar

For internal use. 

The value of this attribute does not persist when the Policy Master restarts

Default value = ““

You may not edit the value of this attribute.

SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = main.xml

SourceSystem Type-Dimension: string-scalar

Source system/pframe name that is applicable for online ActionEntry only when 
doing a failover. For example, the system/pframe name on which the service group 
faulted.

Default value = ““

You may not edit the value of this attribute.

Status Type-Dimension: integer-scalar

Operation-related status. Valid values are started, not started. completed, and 
on_hold.

Default value = ““

You may not edit the value of this attribute.

System Type-Dimension: string-scalar

System name on which to perform the operation.

Default value = ““

You may not edit the value of this attribute.

TimeStarted Type-Dimension: integer-scalar

Time when the operation started. Set in terms of the global counter.

Default value = ““

You may not edit the value of this attribute.

Table 34-11 Action entry attributes

Action entry attribute Definition
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Set name attributes
Table 34-12 lists set name attributes in alphabetical order and provides 
definitions and information about their use:

OUname attributes
OUname attributes are part of the Organization Tree functionality.

Table 34-12 Set name attributes

Set name attribute Definition

Description Type-Dimension: string-scalar

The text of the set name.

Default value = ““

EAExpression Type-Dimension: string-scalar

The extended attributes expression that is used to create the set.

Default value = ““

MsgCatID Type-Dimension: integer-scalar

Message category ID that is used for the object.

Default value = 1

OUExpression Type-Dimension: string-scalar

The organization unit expression that is used to create the set.

Default value = ““

SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = ““
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Table 34-13 lists OUname attributes in alphabetical order and provides 
definitions and information about their use:

OUvalue attributes
OUvalue attributes are part of the Organization Tree functionality.

Table 34-14 lists OUvalue attributes in alphabetical order and provides 
definitions and information about their use:

Table 34-13 OUname attributes

OUname attribute Definition

Description Type-Dimension: string-scalar

The text of the ouname description.

Default value = ““

MsgCatID Type-dimension: integer-scalar

Message category ID that is used for the ouname object.

Default value = 1

SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = orgtree.xml

Table 34-14 OUvalue attributes

OUvalue attribute Definition

Description Type-Dimension: string-scalar

The text of the ouvalue description.

Default value = ““

MsgCatID Type-dimension: integer-scalar

Message category ID that is used for the ouvalue object.

Default value = 1

SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = orgtree.xml



899Attributes reference
OUvalue attributes



900 Attributes reference
OUvalue attributes



Chapter
 35
Virtualization attributes 
reference

This chapter includes the following topics:

■ About virtualization solution attributes

■ Viewing and editing virtualization attributes

■ Virtualization type attributes

■ PFrame attributes

■ VFrame attributes

■ VMwareVC attributes

■ ESX server attributes

■ ESX virtual machine attributes

■ Logical Domain server attributes

■ Logical Domain virtual machine attributes
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About virtualization solution attributes
About virtualization solution attributes
Attributes define how VCS One controls the associated object.

Unless otherwise noted, attributes values are case-insensitive and the value 
remains persistent if the Policy Master restarts.

If an attribute is denoted Internal Use Only, do not change or modify the value 
of the attribute.

Attributes that are not virtualization-related are covered in a separate chapter.

See “About attributes” on page 816.

About the data-type of attributes
Attribute values have one of the following data-types:

About the dimension of attributes
Attribute values have one of the following dimensions:. 

string String values are a sequence of characters in double quotes (“). You do not 
have to enclose strings in quotes when they begin with a letter, and 
contains only letters, numbers, dashes (-), and underscores (_).

■ A string consisting of only letters and numbers does not require 
quotes. A network interface such as eth0 is an example.
Enclosing the string in double quotes is also acceptable—"eth0".

■ Strings containing delimiters, such as periods in IP addresses or 
slashes in path names, require quotes. The IP address 
"192.168.100.1" is an example.

A string can contain double quotes. If the string contains double quotes, 
precede the string by a backslash. Within a string, represent a backslash 
with two forward slashes (\\).

integer Signed integer constants are a sequence of digits from 0 to 9. You can 
precede them with a dash. They are base 10. Integers cannot exceed the 
value of a 32-bit signed integer: 21471183247.

boolean Boolean values are integers with the possible values of 0 (false) or 1 (true).

scalar A scalar has only one value. 

vector A vector is an ordered list of values. Each value is indexed using a positive 
integer [zero or higher]. 

keylist A keylist is an unordered list of unique strings in that list.

association An association is an unordered list of name-value pairs. 
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Viewing and editing virtualization attributes
Each attribute has its own set of valid values. You can define the value of an 
attribute in one of the following ways:

■ Use the VCS One console 

■ Enter a command on the command line

■ Edit the appropriate configuration file

The command you use to define the value of an attribute depends on the type of 
the attribute. Some attributes may not be modifiable.

Some attributes have an empty value. In the console, the value 
<BLANK_VALUE> is equivalent to an empty value. When using the command 
line, the value ““ denotes an empty value.

To display a specific attribute of a given type and the current value using the 
command line

◆ Type the following command
hacommand -display -attribute attribute

Use the following information to replace the appropriate variables:

See the Veritas Cluster Server One Command Reference Guide.

To display a specific attribute of a given type and the current value using the 
VCS One console

See “Editing VCS One cluster attributes” on page 632.

hacommand Use one of the following commands depending on the type of the 
attribute:

havtype: type VType

hapframe: type PFrame

havframe: type VFrame

havobject: type VObject

attribute Name of the specific attribute. 
To display all attributes of this type, use only the -display flag
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Virtualization type attributes
Virtualization type (vtype) objects have attributes that define how VCS One is to 
manage virtualization objects. 

These attributes are generic to all virtualization objects, therefore they apply to 
objects of type ManagementConsole, ESXServer, and ESXVM, LDomsServer, and 
LDomVM, PFrame, and VFrame.

Table 35-1 lists VType object attributes in alphabetical order and provides 
definitions and information about their use:

Table 35-1 Virtualization type attributes

VType attribute Definition

ActionList Internal use only.

List of actions that can be performed on this VFrame.

AssociatedPFrame The list of PFrames that this object is associated with.

Default value = ““

AssociatedVFrame The list of VFrames that this object is associated with.

Default value = ““

AllowedObjects Type and dimension: string-keylist

The list of the object types that you can attach a vtype to. Do not edit this attribute.

Default: ““

Examples: 

■ Group

■ System

ArgList Internal use only. 

Ordered list of attributes whose value are passed to the plug-in action entry point.

BaseVType Type and dimension: keylist-string

The name of the parent interface that defines the behavior for this interface. Do not 
edit this attribute.

Default: ““

Examples:

■ PFrame

■ VFrame
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EnableAutoLinkSys Specifies whether (1) or not (0) a VFrame is automatically linked to a system.

See “About VFrames with linked systems” on page 69.

You may also manually link a VFrame and a system.

See “Linking a VFrame to a system” on page 542.

If this attribute is set to 0, the VFrame would not have a linked system unless the user 
manually links a system to the VFrame.

The VCS One configuration need not have an equal number of systems and VFrames.

This attribute is always set to 0 in the simulator.

Default = 1

GrabLoadStatic Type-Dimension: integer-scalar

Indicates whether (1) or not (0) the state of the service group that is running in the 
virtual machine is considered in the calculation of the Load that is exerted by the 
virtual machine.

Default = 1

InternalUseOnly Type and dimension: integer-scalar

An internal-use only attribute. 

If set, the interface is for internal use only.

Default: 0

LastConfigUpdate Type-Dimension: integer-scalar

Timestamp of when Vtype object was last modified.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LastStateUpdate Type-dimension: integer-scalar

The timestamp of when this object’s state last changed.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

MsgCatID Type-Dimension: integer-scalar

Message category ID that is used for the virtualization object (VObject).

Default = 1

Table 35-1 Virtualization type attributes

VType attribute Definition
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PFrame attributes
PFrame attributes are part of the reservation-related functionality. These 
attributes are of type PFrame.

System objects and PFrame objects have many similar attributes, but are listed 
separately for clarity. 

See “System attributes” on page 840.

NotifyAttrChange Type-Dimension: string-keylist

The value of this attribute is a list of attributes. Whenever any of the attributes in this 
list is modified, one of the following events is generated:

■ PFRAME_ATTR_CHANGE event is generated for a PFrame

■ VFRAME_ATTR_CHANGE event is generated for a VFrame

Use this attribute to monitor changes in PFrame and VFrame attributes.

Default = ““

PlatformName Type-Dimension: string-scalar

The following values are valid for this attribute: aix, aix/rs6000, esx, hpux, linux,
linux/x86, solaris, solaris/sparc, solaris/x86, windows, and windows/x86.

When the type is a PFrame, the value ‘notknown’ denotes an unmanaged PFrame.

See “How VCS One manages a virtualized environment” on page 66.

Default = ““

SourceFile Type-Dimension: string-scalar

The name of the XML file where this object resides.

Default value = vtypes.xml

VobjectCreated Type-Dimension: integer-scalar

Timestamp of when the VObject was created.

Default = ““

You may not edit the value of this attribute.

VobjectLastConfigUpdate Type-Dimension: integer-scalar

Timestamp of when VObject was last modified.

The value of this attribute does not persist when the Policy Master restarts.

Default = ““

You may not edit the value of this attribute.

Table 35-1 Virtualization type attributes

VType attribute Definition
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Each PFrame object includes all the attributes of type VType as well as the 
following attributes.

Table 35-2 lists PFrame object attributes in alphabetical order and provides 
definitions and information about their use.

Table 35-2 PFrame level attributes

PFrame Attribute Definition

AgentsStopped Type-dimension: integer-scalar

AgentStopped is set to 1 when all agents on the PFrame are stopped. Typically, the 
use of the hastop command to stop vcsoneclientd stops the agents. 
The value of this attribute does not persist when the Policy Master restarts.

Default value = 0

You may not edit the value of this attribute.

AgentVersionInfo Type-dimension: string-association

Displays the version information of the agents that are installed on the PFrame.

Default value = 1

You may edit the value of this attribute with the hapframe -modify command or the 
GUI.

AssociatedVobjects The list of objects that this PFrame is associated with.

Default value = ““

AutoDeploy Type-dimension: integer-scalar

Indicates if the PFrame can be deployed using deployment credentials.

Default value = 1

You may edit the value of this attribute with the hapframe -modify command or the 
GUI.

AutoEnablePending Type-dimension: integer-scalar

The number of VFrames that are not fully probed on a newly joined PFrame. When 
value drops to zero, the Policy Master attempts to bring online on the PFrame those 
VFrames that are listed in the GTQ with INTENTONLINE entries.

Default value = 0

You may not edit the value of this attribute.
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AvailableCapacity Type-dimension: integer-association

Key-values pairs. These pairs contain the calculated values that are based on the 
Capacity attribute, the ReserveCapacity attribute, and the Load attribute for all 
the applicable VFrames. 

See “Capacity” on page 908, “ReservedCapacity” on page 912, and “Load” on 
page 919. 

The value of this attribute does not persist when the Policy Master restarts

When a PFrame has the DDNAState attribute = 1, the value of this attribute is the last 
known value when the PFrame was connected with the Policy Master.

You may not edit the value of this attribute.

Capacity Type-dimension: integer-association

When adding a PFrame to a VCS One cluster, an administrator defines a PFrame’s 
Capacity attribute by associating integer values with user-defined keys. The key-
value pairs (for example, “cpu 6 memory 3096”) represent the capacity of the 
PFrame.

The keys, such as “cpu” and “memory” are initially defined in the VCS One cluster 
attribute PrecedenceOrder. Users may define up to four keys.

See “PrecedenceOrder” on page 827.

The VFrame level attribute Load that the administrator defines when creating a 
VFrame corresponds to the PFrame Capacity attribute. For example, a VFrame’s 
Load attribute may be “cpu 2 memory 1028” and a PFrame’s Capacity attribute 
may be “cpu 6 memory 3096”. A VFrame whose Load exceeds a PFrame’s Capacity 
cannot be brought online on that PFrame. See information about “Load” on page 919.

The Policy Master reserves capacity on a PFrame where it plans to online a VFrame. 
The ReservedCapacity attribute contains the key-value pairs reflecting the 
reserved capacity. See “ReservedCapacity” on page 912.

The PFrame maintains an attribute that is called AvailableCapacity, which 
reflects the initial Capacity of a PFrame minus ReservedCapacity and the Load 
it currently bears. See “AvailableCapacity” on page 908.

You may edit the value of this attribute with the GUI or the hapframe -modify 
command.

ConfigVersion Type-dimension: integer-scalar

Indicates whether the Policy Master is to push fresh configuration information to the 
PFrame when the PFrame’s vcsoneclientd connects to the Policy Master.

Default value = 0

You may not edit the value of this attribute.

Table 35-2 PFrame level attributes

PFrame Attribute Definition
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Created Type-dimension: integer-scalar

Timestamp of when PFrame object was created

Default value = ““

You may not edit the value of this attribute.

DDNAPingInterval Type-dimension: integer-scalar

The interval in seconds to wait before Policy Master investigates current status of a 
PFrame in the DDNA (Daemon Dead Node Alive) state. 

The value of this attribute must be between 10-360.

Default value = 20

You may edit the value of this attribute with the GUI or the hapframe -modify 
command.

DDNAState Type-dimension: integer-scalar

DDNA (Daemon Dead Node Alive) state of 1 indicates the vcsoneclientd process on 
the PFrame, which is still alive, does not send heartbeats to the Policy Master.

Default value = 0

You may not edit the value of this attribute.

EnableFFDC Type-dimension: boolean-scalar

Indicates if First Failure Data Capture (FFDC) functionality is enabled for the VCS 
One client running on this PFrame.

See “About the first failure data capture (FFDC) log” on page 707.

Enabled = 1; Disabled = 0

Default value = 1

You may edit the value of this attribute with the GUI or the haclus -modify command.

Flags Type-Dimension: integer-scalar

Provides additional information for the state of resources in the VFrame. Primarily 
this attribute raises flags pertaining to the resource. 

Values:

RES_NEED_ATTN indicates that one or more resources in the VFrame has a flag 
raised. For information about the Flags resource attribute, see “Flags” on page 877.

The value of this attribute is set individually for each PFrame in the VFrame's 
PFrameList.

You may not edit the value of this attribute.

Table 35-2 PFrame level attributes

PFrame Attribute Definition
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FirstTimeConnect Type-dimension: integer-scalar

Indicates whether or not the PFrame has connected to the Policy Master since the 
time a fresh configuration was loaded into the configuration database.

Default value = 1

You may not edit the value of this attribute.

Frozen Type-dimension: boolean-scalar

Indicates if VFrames can be brought online on the PFrame. VFrames cannot be 
brought online if the attribute value is 1.

Default value = 0.

The Policy Master sets the value of this attribute in response to Freeze or Unfreeze 
menu items in the GUI, or the hasys -freeze | -unfreeze command. 
The user may not directly edit this attribute. 

Info Type-dimension: string-association

Indicates the object-specific information by key—value pairs. This attribute is 
updated each time the VCS One client daemon connects to the Policy Master.

Default value = 
MemoryReal = ““
MemoryVirt= ““
OsType = ““
OsVersion = ““
CpuCount = ““
CpuArch = ““
CpuSpeed = ““
NetHwAddr = ““

You may not edit the value of this attribute.

IPAddresses Type-dimension: string-vector

Value specifies the IP address(es) configured for the PFrame. The Policy Master uses 
the list to ping the PFrame in case of a fault. 

Every time the PFrame’s vcsoneclientd daemon starts, the daemon updates the value 
of the attribute.

Default value = ““

You may not edit the value of this attribute.

Table 35-2 PFrame level attributes

PFrame Attribute Definition
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LastStateUpdate Type-dimension: integer-scalar

The timestamp of when PFrame’s state last changed.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

LogDbg Type-dimension: string-keylist

Specifies which debug messages are written to the vcsoneclientd log file.

Default value = ““

MaxHeartbeatInterval Type-dimension: integer-scalar

Interval in seconds that determines how often a PFrame should send a heartbeat to 
the Policy Master.

The value for this attribute must be between 5 and 360.

Default value = 10 

You may not edit the value of this attribute.

MissedHeartbeatThreshold Type-dimension: integer-scalar

A number that denotes how many missed heartbeats the Policy Master waits before 
investigating the PFrame missing heartbeats.

The value for this attribute must be between 2 and 50.

Default value = 3

You may edit the value of this attribute with the hapframe -modify command or the 
GUI.

Mode Type-dimension: string-scalar

Indicates whether this PFrame is an actual PFrame (Real) or a simulated PFrame 
(Simulated).

Default value = Real

You may not edit the value of this attribute.

Name Type-dimension: string-scalar

Indicates the PFrame’s name. 

The value of this attribute does not persist when the Policy Master restarts

Default value = ““

You may not edit the value of this attribute.

Table 35-2 PFrame level attributes

PFrame Attribute Definition
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NodeId Type-dimension: integer-scalar

The node ID of the PFrame. The Policy Master assigns this node ID.

Default value = -1

You may not edit the value of this attribute.

NumMissedHeartbeat Type-dimension: integer-scalar

Number of heartbeats the specific PFrame has missed. When the 
NumMissedHeartbeats crosses the MissedHeartbeatThreshold value, the Policy 
Master starts investigating the PFrame.

Default value = 0

You may not edit the value of this attribute.

The value of this attribute does not persist when the Policy Master restarts.

OnLineCnt Type-dimension: integer-scalar

The number of VFrames online or partially online on the PFrame. This number does 
not include the number of VFrames that are planned to be brought online. 
The value of this attribute does not persist when the Policy Master restarts.

When a PFrame has the DDNAState attribute = 1, the value of this attribute is the last 
known value when the PFrame was connected with the Policy Master.

Default value = ““

You may not edit the value of this attribute.

ReservedCapacity Type-dimension: integer-association

Key-values pairs. The Policy Master defines these pairs and designates the reserve 
capacity on the PFrame. 

For example, if the Policy Master plans to fail over group G1 to system S2, the 
ReserveCapacity attribute on system S2 includes the capacity that is required for G1. 
As G1 is brought online on S2, the Policy Master removes the capacity that G1 
requires from the ReserveCapacity attribute value. 

See “Capacity” on page 908.

When a PFrame has the DDNAState attribute = 1, the value of this attribute is the last 
known value when the PFrame was connected with the Policy Master.

Default value = ““

You may not edit the value of this attribute.

Table 35-2 PFrame level attributes

PFrame Attribute Definition
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StaleSysState Type-dimension: boolean-scalar

Denotes whether or not the state of the PFrame is based on an old value from the 
database which has not as yet been determined accurately by the Policy Master.

Default value = 0

You may not edit the value of this attribute.

State Type-dimension: integer-scalar

Indicates the PFrame’s state:

1 = UNKNOWN

8 = LOCAL_BUILD

11 = RUNNING

12 = LEAVING

14 = EXITED

15 = FAULTED

Default value = 1 

You may not edit the value of this attribute.

SystemSequenceNumber Type-dimension: integer-scalar

Specifies whether the Policy Master is to probe all resources on the PFrame when the 
PFrame’s vcsoneclientd connects to the Policy Master. Values are Yes (1) and No (0).

Default value = 0

You may not edit the value of this attribute.

TransitionOffline Type-dimension: integer-scalar

When user issues hastop -sys command without the 
-evacuate option, Policy Master sets value of TransitionOffline to 1 for a brief time.

The value of this attribute does not persist when the Policy Master restarts.

Default value = 0

You may not edit the value of this attribute.

TransitionOnline Type-dimension: integer-scalar

When user issues hastop -sys command with the -evacuate option, Policy Master sets 
value of TransitionOnline to 1 for a brief time. 

The value of this attribute does not persist when the Policy Master restarts.

Default value = 0

You may not edit the value of this attribute.

Table 35-2 PFrame level attributes

PFrame Attribute Definition
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VFrame attributes
VFrame attributes are part of the reservation-related functionality. These 
attributes are of type VFrame. 

Service group objects and VFrame objects have many similar attributes, but are 
listed separately for clarity. 

See “Service group attributes” on page 848.

Each VFrame object includes all the attributes of type VType as well as the 
following attributes.

UsePMIPAddrs Type-dimension: string-keylist

Specifies the list of IP addresses (and ports) that the client system uses to connect to 
the Policy Master. This list must be a subset of the IP addresses that the Policy 
Master listens on. The cluster attribute ClusterAddress specifies on which IP 
addresses the Policy Master listens.

Default value = ““

UserName Type-dimension: string-scalar

The user name that is associated with a PFrame. The privileges that are granted to 
this user determine the operations that the root user on that PFrame can perform 
within the VCS One cluster.

Default value = ““

You may not edit the value of this attribute.

Version Type-dimension: string-association

Version of the vcsoneclientd (VCS One client system daemon) running on the 
PFrame.

Default values are: 
DaemonVersion = ““
ProductVersion = ““
BuildDate = ““
PSTAMP = ““
ProtocolVersion = ““

You may not edit the value of this attribute.

Table 35-2 PFrame level attributes

PFrame Attribute Definition
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VFrame attributes
Table 35-3 lists VFrame object attributes in alphabetical order and provides 
definitions and information about their use.

Table 35-3 VFrame attributes

VFrame Attribute Definition

AssociatedVobjects Type-dimension: 

The list of objects that this PFrame is associated with.

Default value = ““

AutoEnableWait Type-Dimension: boolean-scalar

For internal use. 

If set to 1 it indicates Policy Master is waiting to probe a VFrame on this newly joined 
PFrame. Once the VFrame is probed this value is set to 0 and AutoEnablePending for the 
PFrame decrements by 1.

Default value = 0.

The value of this attribute is set individually for each PFrame in the VFrame's 
PFrameList.

You may not edit the value of this attribute.

CompatibleVFrames Type-dimension: string-keylist

A list of the VFrames that are compatible with the current VFrame. This attribute does 
not have a value if the IncompatibleVFrames attribute has a value.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.
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ContainerInfo Type-Dimension: string-association

Used in operating system virtualization technology environments. Describes the 
Container information and whether that information is passed to the agent framework. 

Can only be modified if all resources in the group are in a clean OFFLINE state.

Has the following keys: 

NAME: Name of the Container in free-form non-null text 

TYPE: Type of the Container. Valid values are ZONE and WPAR. The XRM option is not 
supported.

ENABLED: Valid values are 0 and 1. Indicates if the Policy Master does (1) or does not (0) 
pass ContainerInfo to the agents managing resources in a VFrame. (Target VFrame must 
have the value 1 set for either the RunInContainer key or the PassCInfo key in the 
resource attribute ContainerOpts.)

By default, this attribute is NULL, indicating the VFrame is not associated with a 
Container. 

Default value = ““

Created Type-dimension: integer-scalar

Timestamp of when VFrame object was created.

Default value = ““

You may not edit the value of this attribute.

CSGName Type-Dimension: string-scalar

Denotes the name of the composite service group to which this VFrame belongs. A blank 
value indicates this VFrame does not belong to a composite service group.

This attribute remains persistent across Policy Master reboots.

You may edit the value of this attribute only by editing the configuration file directly.

Default value = ““

CurrentCount Type-Dimension: integer-scalar

Internal use only. Number of PFrames on which the VFrame is active. 
The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

Table 35-3 VFrame attributes

VFrame Attribute Definition
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Enabled Type-Dimension: boolean-scalar

Indicates if a VFrame can be failed over or brought online. If any of the local values are 
disabled, the VFrame is disabled.

Default value = 1 (enabled)

The value of this attribute is set individually for each PFrame in the VFrame's 
PFrameList.

You may only edit the value of this attribute if the group’s SystemList attribute or the 
VFrames PFrameList is non-empty. 

You may edit the value of this attribute with the havframe -enable or havframe -disable 
command or the GUI.

You may edit the value of this attribute for an individual VFrame instance by editing the 
main.xml configuration file directly.

Evacuate Type-Dimension: boolean-scalar

Indicates if VCS One initiates an automatic failover when user issues the command

hastop -local -evacuate.

Default value = 1

FirstLocalOnline Type-Dimension: string-scalar

Internal use only for VCS One agents.

This attribute is applicable only in a VCS One global cluster environment.

When the value of this attribute is 1, VCS One agents that need to perform any pre-online 
tasks invoke specific setup scripts before bringing the application online. When the local 
cluster acquires authority for the global CSG from the remote cluster, the value of 
FirstLocalOnline attribute is set to 1 for the VFrames of that global CSG.

The value of this attribute does not persist when the Policy Master restarts.

Default value = "0"

You may not edit the value of this attribute.

Flags Type-Dimension: integer-scalar

Provides additional information for the state of resources in the VFrame. Primarily this 
attribute raises flags pertaining to the resource. 

Values:

RES_NEED_ATTN indicates that one or more resources in the VFrame has a flag raised. 
For information about the Flags resource attribute, see “Flags” on page 877.

The value of this attribute is set individually for each PFrame in the group's VFrameList.

You may not edit the value of this attribute.

Table 35-3 VFrame attributes

VFrame Attribute Definition
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Frozen Type-Dimension: boolean-scalar

Disables all actions on the VFrame except for the monitor actions that the agents 
perform.

Examples of disabled actions are autostart, online, offline, and failover. 

All agents that are bundled with VCS One observe this convention.

Default value = 0 (not frozen)

The Policy Master sets the value of this attribute in response to Freeze or Unfreeze menu 
items in the GUI, or the havframe -freeze | -unfreeze command. The user may not 
directly edit this attribute. 

IncompatibleVFrames Type-dimension: string-keylist

A list of the VFrames that are incompatible with the current VFrame. This attribute does 
not have a value if the CompatibleVFrames attribute has a value.

Default value = ““

You may edit the value of this attribute only by editing the configuration file directly.

LastSuccess Type-dimension: integer-scalar

Timestamp of when VFrame last restarted.

Default value = 0

You may not edit the value of this attribute.

Table 35-3 VFrame attributes

VFrame Attribute Definition
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Load Type-Dimension: integer-association

Integer value expressing total PFrame Load that this VFrame exerts on a PFrame.

For example, the administrator may assign a value of 100 to a large production SQL and 
15 to a Web server.

When creating a VFrame, an administrator defines a VFrame’s Load attribute by 
associating integer values with user-defined keys. The key-value pairs (for example, “cpu 
4 memory 1028”) represent the load a VFrame places on a PFrame’s resources. 

The keys, such as “cpu” and “memory” are initially defined in the cluster attribute 
PrecedenceOrder. 

See “PrecedenceOrder” on page 827.

The PFrame level attribute, Capacity, which the administrator defines when adding a 
PFrame, corresponds to the Load attribute. For example, a PFrame’s Capacity attribute 
may be “cpu 6 memory 3046” and a VFrame Load attribute may be “cpu 2 memory 
1028”. See information about “Capacity” on page 908.

The havframe -changeload command enables users to change the Load attribute 
definition for an online service group.

Default value = 0

ManualOps Type-Dimension: boolean-scalar

Indicates if manual operations are allowed on the VFrame. If set to 0 then online, offline 
and switch operations are not permitted.

Default value = 1 (enabled)

NumRetries Type-dimension: integer-scalar

Indicates the number of attempts made to restart a VFrame.

Default value = 0

The value of this attribute is set individually for each PFrame in the group's VFrameList.

You may not edit the value of this attribute.

OffHostResource Type-dimension: string-keylist

A list of the off-host resources that use this VFrame as a control group.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

You may not edit the value of this attribute.

Table 35-3 VFrame attributes

VFrame Attribute Definition
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OnlineRetryLimit Type-dimension: integer-scalar

Indicates the number of attempts that the Policy Master makes to retry the online 
operation if the attempt to bring a VFrame online is unsuccessful.

Default value = 0

PFrameList Type-Dimension: integer-association

List of PFrames on which the VFrame is configured to run. Each PFrame has an 
associated value reflecting its priority. Lower priority numbers indicate a preference for 
the PFrame as a failover target. 

A VFrame must not be online on the PFrame to be deleted from its PFrameList.

Default value = “”

PFrameListExpr Type-dimension: string-association

Expression that is used to derive the value of the PFrameList attribute for a VFrame. Used 
when user performs the refresh for the PFrameList.
Default values are: 
OU = ““
EA = ““

Priority Type-Dimension: integer-scalar

Indicates the priority of the VFrame, ranging from highest (1) to lowest (5). Higher 
priority VFrames take precedence over lower priority VFrames when the VFrames 
contend for resources. Low priority VFrames may be kicked out of a PFrame in favor of a 
higher priority VFrame. The value for this attribute must be between 1 and 5.

Default value = 5

You may edit the value of this attribute with the havframe -modify command.

Table 35-3 VFrame attributes

VFrame Attribute Definition
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Probed Type-Dimension: boolean-scalar

Probed = 1 indicates one of the following conditions:

■ Agents have detected all enabled resources in the VFrame.

■ A VFrame with no resources or no enabled resources is detected when Policy Master 
starts or restarts.

Probed = 0 indicates one of the following conditions:

■ Agents have not detected all enabled resources in the VFrame.

■ A new VFrame is added with no resources or no enabled resource while the Policy 
Master is running.

The value of this attribute does not persist when the Policy Master restarts.

Default value = ““

The value of this attribute is set individually for each PFrame in the VFrame's 
PFrameList.

You may not edit the value of this attribute.

ProbesPending Type-Dimension: integer-scalar

The number of resources that the agent has not yet detected on each PFrame. 

The value of this attribute does not persist when the Policy Master restarts.

The value of this attribute is set individually for each PFrame in the VFrame's 
PFrameList.

Default value = ““

You may not edit the value of this attribute.

Table 35-3 VFrame attributes

VFrame Attribute Definition
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State Type-Dimension: integer-scalar

The state on each PFrame of the VFrame. The following states are the possible values:
OFFLINE All non-persistent resources are offline.

ONLINE All resources whose AutoStart attribute is equal to 1 are online.

FAULTED At least one critical resource in the VFrame is faulted or is affected by a fault.

PARTIAL At least one, but not all, resources with Operations=OnOff is online, and not all 
AutoStart resources are online.

STARTING  VFrame is attempting to go online.

STOPPING VFrame is attempting to go offline.

A VFrame state can be a combination of multiple states. For example, 

OFFLINE | FAULTED

OFFLINE | STARTING

PARTIAL | FAULTED

PARTIAL | STARTING

PARTIAL | STOPPING

ONLINE | STOPPING

Default value = 1

The value of this attribute does not persist when the Policy Master restarts

The value of this attribute is set individually for each PFrame in the VFrame's 
PFrameList.

You may not edit the value of this attribute.

UserStrLocal Type-Dimension: string-scalar

Use this attribute for any purpose. It is not used by the Policy Master.

Default value = ““

You may edit the value of this attribute with the havframe -modify command.

The value of this attribute is set individually for each VFrame in the VFrame's 
PFrameList.

UserIntLocal Type-Dimension: integer-scalar

Use this attribute for any purpose. It is not used by the Policy Master.

Default value = 0

You may edit the value of this attribute with the havframe -modify command.

The value of this attribute is set individually for each VFrame in the VFrame's 
PFrameList.

Table 35-3 VFrame attributes

VFrame Attribute Definition
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VMwareVC attributes
VMwareVC attributes are part of the VMware-related functionality.

The following attributes types are associated with VMware-related objects:

■ VMwareVC

■ ESXServer

■ ESXVM

Each VMwareVC object includes all the attributes of type VType as well as the 
following attributes.

Table 35-4 lists VMwareVC object attributes in alphabetical order and provides 
definitions and information about their use:

TriggerResStateChange Type-Dimension: boolean-scalar

Determines whether or not to invoke the resstatechange trigger if resource state 
changes.

Default value = 0 (disabled)

Table 35-3 VFrame attributes

VFrame Attribute Definition

Table 35-4 VMwareVC type attributes

VMwareVC attribute Definition

ActionList Internal use only.

List of actions that can be performed on this object.

APIUrl Type-dimension: string-scalar

The URL to access the API for the configured VMware VirtualCenter.

Default value = ““

You may not edit the value of this attribute for the type definition. You can edit the value 
of this attribute for the object of this type when you have created a VObject.

ArgList Internal use only. 

Ordered list of attributes whose values are passed to the plug-in action entry points.
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ESX server attributes are part of the VMware-related functionality. These 
attributes are of type ESXServer.

Each ESXServer object includes all the attributes of type VType as well as the 
following attributes.

KeystoreFile Type-dimension: string-scalar

Full path to a keystore file. The keystore file is used to create a secure connection with the 
VMware VirtualCenter management console.

Default value = “None”

You may modify this attribute with the GUI or the havtype -modify command.

Password Type-dimension: string-scalar

Password that is used to connect to the VMware VirtualCenter management console.

Default value = ““

You may not edit the value of this attribute for the type definition. You can edit the value 
of this attribute for the object of this type when you have created a VObject.

TechnologyName Internal use only.

Indicates the virtualization technology name.

Username Type-dimension: string-scalar

User name that is used to connect to the VMware VirtualCenter management console.

Default value = ““

You may not edit the value of this attribute for the type definition. You can edit the value 
of this attribute for the object of this type when you have created a VObject.

Table 35-4 VMwareVC type attributes

VMwareVC attribute Definition
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Table 35-5 lists ESX server object attributes in alphabetical order and provides 
definitions and information about their use. 

Table 35-5 ESXServer type attributes

ESXServer attribute Definition

DatacenterName Type-Dimension: string-scalar

Specifies the datacenter name.

Default = ““

You may not edit the value of this attribute for the type definition. You can edit 
the value of this attribute for the object of this type when you have created a 
PFrame object.

DisableReservation Type-dimension: integer-scalar 

If this attribute is set to 1 for a given PFrame, resource reservations are not 
carried out for the VFrames on that PFrame. VCS One uses this attribute if 
reservations are enabled globally at the server farm level. You can only change 
this attribute when no VFrame is ONLINE on the PFrame. 

Default value = 0

FailedReservationTimerExpiry Type-Dimension: integer-scalar

Used by the Policy Master to determine the time (in minutes) after which the 
Policy Master can automatically remove a Vframe´s name from the list of 
Vframes present in the FailedReservationVFrames attribute of a Pframe.

Default value = 60

FailedReservationVFrames Type-Dimension: string-keylist

The list of Vframes for which resource reservations have failed on a given 
Pframe. 

VCS One does not allow a VFrame to be brought online on a PFrame if the name 
of the VFrame is in the PFrame’s FailedReservationVFrames attribute.

To manually remove a VFrame from this list.

The Policy Master automatically removes a VFrame from this list after a 
predetermined amount of time, set by the FailedReservationTimerExpiry 
attribute.
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ESX virtual machine attributes are part of the VMware-related functionality. 
These attributes are of type ESXVM.

Each ESXVM object includes all the attributes of type VType as well as the 
following attributes.

Table 35-6 lists ESX virtual machine object attributes in alphabetical order and 
provides definitions and information about their use. 

HealthCheckIPs Type-Dimension: string-association

The Policy master uses the IP addresses specified in this attribute to determine 
if a Pframe has faulted when the connection with the client daemon is lost.

This attribute has the following keys: IP1, IP2, IP3, and IP4.

It is mandatory to specify a valid IP address for the key IP1.

Default: ““ for all keys.

Table 35-5 ESXServer type attributes

ESXServer attribute Definition

Table 35-6 ESXVM type attributes

ESXVM attribute Definition

BiosUUID Type-dimension: string-scalar

Specifies the BIOS UUID, a unique identifier for the BIOS.

Default value = ““

You may not edit the value of this attribute for the type definition. You can edit the value 
of this attribute for the object of this type, when you have created a VFrame object.

DefaultLoad Type-dimension: 

This attribute 

Default value = 

MACAddrs Type-dimension: 

The MAC address of the VFrame. The value of this attribute is populated by the discovery 
operation. If the VFrame is added manually, the user populates the value of this attribute.

Default value = ““

Do not edit the value of this attribute.
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Logical Domain server attributes are part of the LDom-related functionality. 
These attributes are of type LDomsServer.

Each LDomsServer object includes all the attributes of type VType as well as the 
following attributes.

NetworkDetails Type-dimension: string-association

The NIC, IP address, netmask, default gateway, and DNS of the virtual machine’s 
operating system’s primary network.

This attribute is used by ESX agents to set the guestinfo variables of the virtual 
machine operating system when the virtual machine is configured for disaster recovery 
(DR) failover.

The network details must be specific to the DR site.

The NIC, IPAddress, Netmask, and Gateway keys are mandatory for network 
configuration on the DR site. Otherwise, the virtual machine network will not reconfigure 
to the new site during DR failover. The DNS key is optional.

This attribute has the following keys: 

■ NIC: The network interface alias or the MAC address of the virtual machine's 
operation system primary network.
For example: On a Linux guest OS, eth0. On a Windows guest OS, 
AA:BB:CC:DD:EE:FF

■ IPAddress: The IP address of the virtual machine’s operating system’s primary 
network.

■ Netmask: The netmask of the virtual machine’s operating system’s primary network.

■ Gateway: The default gateway of the virtual machine’s operating system’s primary 
network.

■ DNS: The DNS of the virtual machine's operating system’s primary network.
Configure more than one DNS by using a semicolon as a separator.
For example: 44.44.44.44;55.55.55.55

Default: ““ for all the keys.

Table 35-6 ESXVM type attributes

ESXVM attribute Definition
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Table 35-7 lists Logical Domain server attributes in alphabetical order and 
provides definitions and information about their use. 

Logical Domain virtual machine attributes
Logical Domain virtual machine attributes are part of the LDom-related 
functionality. These attributes are of type LDomsVM.

Each LDomsVM object includes all the attributes of type VType as well as the 
following attributes.

Table 35-7 Logical Domain server attributes

LDom Server 
attribute

Definition

DisableReservation Type-dimension: integer-scalar 

If this attribute is set to 1 for a given PFrame, resource reservations are not carried 
out for the VFrames on that PFrame. VCS One uses this attribute if reservations 
are enabled globally at the server farm level. Change the value of this attribute 
only when no VFrame is ONLINE on the PFrame. 

Default value = 0

FailedReservationTimerExpiry Type-Dimension: integer-scalar

Used by the Policy Master to determine the time (in minutes) after which the 
Policy Master can automatically remove a Vframe´s name from the list of Vframes 
present in ´FailedReservationVFrames´ attribute of a Pframe.

Default value = 60

FailedReservationVFrames Type-Dimension: string-keylist

The list of Vframes for which resource reservations have failed on a given Pframe. 

VCS One does not allow a VFrame to be brought online on a PFrame if the name of 
the VFrame is in the PFrame’s FailedReservationVFrames attribute.

To manually remove a VFrame from this list.

The Policy Master automatically removes a VFrame from this list after a 
predetermined amount of time, set by the FailedReservationTimerExpiry 
attribute.

ReservationsInProgress Internal use only.
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Table 35-8 lists Logical Domain virtual machine attributes in alphabetical order 
and provides definitions and information about their use. 

Table 35-8 Logical Domain virtual machine attributes

LDom VM 
attribute

Definition

NetworkDetails Type-dimension: string-association

The IP address, netmask, DNS, and default router of the guest operating system.

This attribute is used by the LDom agent to set the 
network-boot-arguments PROM variable of the guest operating system. Use only 
when the guest domain is configured for disaster recovery (DR) failover.

The network details must be specific to the DR site.

This attribute has the following keys: 

■ IPAddress: The IP address of the guest operating system.

■ Netmask: The netmask of the guest operating system.

■ Gateway: The default router or gateway of the guest operating system.

■ DNS: The DNS of the guest operating system.
Configure more than one DNS by using a semicolon as a separator.

The IPAddress, Netmask, and Gateway keys are mandatory for network configuration on 
the DR site. The DNS key is optional.

Default value = ““ for all the keys.

PropagatePMDetails Type-Dimension: string-scalar

This attribute is only valid when all the following conditions are met: 

■ The NetworkDetails attribute is configured for the VFrame.
See “NetworkDetails” on page 929.

■ The VCS One client is configured inside the guest domain.

■ The VRTSvcsnr package is installed in the guest operating system. 
See “Configuring an LDom for disaster recovery” on page 563.

■ The guest domain has had a disaster recovery failover.

When the guest domain is brought online on a PFrame, this attribute determines 
whether (1) or not (0) the vcsone.conf file in the guest domain is updated to reflect the 
Policy Master in the DR site.

The vcsone.conf file contains information about the Policy Master to which the PFrame is 
connected.

Default = 1
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State reference

This chapter includes the following topics:

■ Cluster states in VCS One global clusters

■ Network link states in VCS One global clusters
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Cluster states in VCS One global clusters
In a global cluster environment, VCS One uses the network connections between 
the VCS One clusters to monitor and maintain the “health” of the remote VCS 
One clusters. The primary link is used for inter-cluster communication and 
exchange of cluster information. The heartbeating occurs on all network links. 
When you enable network connection between the VCS One clusters, the 
heartbeating between the VCS One clusters is also enabled. VCS One monitors 
the state of remote clusters using the heartbeats. The state is then 
communicated to the VCS One engine, which takes appropriate action when 
required based on the information. 

See “How global clusters work” on page 77.

Table 36-1 provides a list of VCS One remote cluster states and their 
descriptions. 

Table 36-1 VCS One cluster state definitions

State Definition

INIT The initial state of the VCS One cluster. This is the default state.

The VCS One clusters do not have any connections established at this 
point.

BUILD The local and the remote VCS One clusters have established 
connection. 

The VCS One clusters exchange the initial snapshot information.

EXITED The connections between the local and the remote VCS One clusters 
are closed.

EXITING The local or the remote VCS One cluster is closing the connections.

TRANSITIONING The Policy Master in the remote VCS One cluster is failing over from 
one node to the other in the Policy Master cluster.

FAULTED The local VCS One cluster has lost connectivity with the remote VCS 
One cluster.

LINK_FAILOVER The primary link that is used for inter-cluster communication is 
down. The VCS One cluster that initiates the connection request 
(Initiator) is failing over the communication link to an active 
secondary link that is available between the VCS One clusters.

RUNNING The VCS One clusters are successfully connected, and have 
completed exchanging the snapshot information.
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Examples of VCS One cluster state transitions
■ If a network connection is established between the VCS One clusters, the 

clusters exchange initial snapshot information. The state of the remote 
cluster in view of the local cluster transitions from INIT to BUILD state.

INIT -> BUILD

■ If a network connection is reestablished between the VCS One clusters, the 
state of the remote cluster in view of the local cluster transitions from 
EXITED/FAULTED to BUILD state.

EXITED -> BUILD

FAULTED -> BUILD

■ If the exchange of snapshot between the clusters is complete, the state of 
the remote cluster in view of the local cluster transitions from BUILD to 
RUNNING state.

BUILD -> RUNNING

■ If the local VCS One cluster loses all network connections to a remote VCS 
One cluster in the BUILD/RUNNING state when the snapshots are exchanged, 
VCS One transitions the remote cluster state to FAULTED.

BUILD -> FAULTED

RUNNING -> FAULTED

■ If the value of the EnableConnections attribute is set to 0 when the remote 
cluster is in BUILD/RUNNING state, VCS One transitions the remote cluster 
state to EXITED after all connections are closed.

BUILD -> EXITED

RUNNING -> EXITED

Network link states in VCS One global clusters
In a VCS One global cluster environment, the local and the remote clusters 
communicate using the network connection details that you define in the 
NetworkConnections attribute on the VCS One cluster that initiates the 
connection request. The LinkStatus attribute indicates the status of each 
network link between the local and the remote clusters. The status of the 
network connections depends on the value of the EnableConnections attribute.

See “Remote cluster attributes” on page 836.
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Table 36-2 provides a list of the individual link status for each network link 
between the local and the remote clusters and their description. 

Table 36-3 provides a list of the consolidated status of all the network links 
between the local and the remote clusters and their description.

Table 36-2 Individual links status for network connections

State Definition

DOWN The network connection is not established between the local and the 
remote cluster. 

The status of a network link can be DOWN in the following cases:

■ VCS One has not attempted to establish connection.

■ VCS One cannot establish connection between the VCS One 
clusters due to a link failure.

■ VCS One is gracefully shut down.

UP The network connection is established between the local and the 
remote cluster.

DISABLED The network connection is disabled between the local and the remote 
VCS One clusters.

The network connection cannot be established because the value of 
the EnableConnections attribute is set to 0 on the local or the remote 
cluster.

Table 36-3 Consolidated link status for network connections

State Definition

DOWN All the individual network links between the VCS One clusters are 
down.

UP All the individual network links between the VCS One clusters are up.

PARTIAL UP At least one individual network link between the VCS One clusters is 
up.

DISABLED All the individual network links between the VCS One clusters have 
the connection disabled.

DISABLED DOWN At least one network link between the VCS One clusters is down while 
while all other network links have the connection disabled.
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Examples of network link state transitions
■ If the value of the EnableConnections attribute is set to 0 on the VCS One 

cluster to which VCS One initiates a network connection, then the network 
connection status transitions to DISABLED state. 

Empty -> DISABLED

■ If the value of the EnableConnections attribute is set to 1 on both the VCS 
One clusters and if VCS One establishes a network connection, then the 
network connection status transitions to UP state. 

Empty -> UP

The state of the remote cluster in view of the local cluster transitions to 
BUILD/RUNNING state.

■ If the value of the EnableConnections attribute is set to 0 on one or both the 
clusters and the network connections are already established, then the 
network connection status transitions from UP to DISABLED state.

UP -> DISABLED

The state of the remote cluster in view of the local cluster transitions from 
BUILD/RUNNING state to EXITING/EXITED.

■ If the value of the EnableConnections attribute is set to 0 on one or both the 
clusters and the network connections are down, then the network 
connection status transitions from DOWN to DISABLED state. 

DOWN -> DISABLED

The state of the remote cluster in view of the local cluster transitions to 
EXITING/EXITED.

■ If the network connections are already established and one of the links goes 
down, the connection status transitions from UP to PARTIAL UP state. 

UP -> PARTIAL UP

■ If the primary link goes down:

The state of the remote cluster in view of the local cluster transitions 
from BUILD/RUNNING state to LINK_FAILOVER to BUILD/RUNNING.

■ If any of the links other than the primary link go down:

The state of the remote cluster in view of the local cluster remains as 
BUILD/RUNNING state.

■ If the network connections are already established and all of the links go 
down, the connection status transitions from UP to DOWN state. 

UP -> DOWN

The state of the remote cluster in view of the local cluster transitions from 
BUILD/RUNNING state to FAULTED.
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■ If the links between the clusters are DISABLED and one or more links go down, 
then the link state transitions from DISABLED to DISABLED DOWN if at least one 
link is UP.

DISABLED -> DISABLED DOWN

■ If the links between the clusters are DISABLED and if the value of the 
EnableConnections attribute is set to 1 on both the clusters, the link state 
transitions from DISABLED to UP.

DISABLED -> UP 
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Appendix

This section includes the following appendix:

■ “How to configure resources and applications on Windows” on page 939.
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Appendix
 A
How to configure 
resources and applications 
on Windows

This appendix includes the following topics:

■ “About configuring resources and applications” on page 940

■ “About configuring shared storage” on page 941

■ “About configuring file shares” on page 951

■ “About configuring print shares” on page 967

■ “About configuring the MSDTC Server” on page 983

■ “Configuring an MSDTC Server service group” on page 986

■ “About configuring the MSDTC clients” on page 995

■ “About the VCS One Application Manager utility” on page 999

■ “Viewing DTC transaction information” on page 999

■ “About configuring services” on page 1001

■ “Configuring processes” on page 1004

■ “About configuring infrastructure and support agents” on page 1006
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About configuring resources and applications
Veritas Cluster Server One (VCS One) monitors resources using agents. VCS One 
continuously monitors the resources used by an application to detect the state 
of the application. If all resources required by the application are available, VCS 
One declares the application as available.

VCS One provides configuration wizards to configure commonly-used 
resources. You can also use the VCS One console to configure these resources 
manually.

Configuring resources and applications in VCS One involves the following tasks:

■ Creating a service group with all resources required for the application and 
configuring those resources.

For example, to configure a database you must configure resources for the 
database, the underlying shared storage and the network components. To 
configure a resource you must define values for its attributes. The resources 
must be logically grouped in a service group. When a resource faults, the 
entire service group fails over to another system.

■ Assigning dependencies between resources.

For example, a MountV resource depends on a VMDg resource. Similarly, an 
IP resource depends on a NIC resource.

■ Bringing the service group online.

Windows Server 2008 considerations
The following items apply if your setup involves Windows Server 2008 systems:

■ User Access Control (UAC)

On Windows Server 2008, if User Access Control (UAC) is enabled and 
configured, non-default administrators cannot run VCS One commands 
from the command prompt. All VCS One commands must be run from the 
command prompt in the Run as administrator mode.

To launch the command prompt in the Run as administrator mode, right-
click the command prompt shortcut from the Windows Start menu and 
click Run as administrator from the context menu.

See the Microsoft documentation for more information on UAC.

■ Windows Firewall

If you have configured the Windows firewall on Windows Server 2008, 
ensure that the firewall settings allow access to the services and ports used 
by VCS One.

Refer to the Appendix in the Veritas Cluster Server One Installation and 
Upgrade Guide for details.
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About configuring shared storage
■ Windows Server 2008 Server Core

If you wish to configure VCS One resources and service groups on Windows 
Server 2008 Server Core systems, you must manually add the required 
resources and configure the service groups.

You can perform the steps either directly on the Server Core machine using 
VCS One commands from the command line or remotely using the VCS One 
console.

See “Adding a service group or an infrastructure service group” on 
page 357.

See “Adding a resource to a service group” on page 426.

Before configuring resources and service groups, review the agent attribute 
definitions described in the Veritas Cluster Server One Bundled Agents 
Reference Guide.

About configuring shared storage
Refer to the following topics depending on your storage environment:

■ If your configuration uses shared disks and volumes managed using 
Windows Logical Disk Manager (LDM), use the DiskReservation (DiskRes) 
and Mount agents.

See “About managing shared storage using Windows Logical Disk Manager 
(LDM)” on page 942.

■ If your configuration uses shared disks and volumes managed using Veritas 
Storage Foundation for Windows (SFW), use the VMDg and MountV agents.

See “About managing shared storage using SFW” on page 949.
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About managing shared storage using Windows Logical Disk 
Manager (LDM)

Before you configure shared storage, review the attribute definitions of the Disk 
Reservation (DiskRes) and the Mount agents.

See the Veritas Cluster Server One Bundled Agents Reference Guide.

About LDM support
The following limitations apply in this release:

■ HA support is not available for LDM on Windows Server 2003.

■ For using LDM, your storage devices must be configured to use SCSI-3 disk 
reservations. SCSI-2 is not supported.

Prerequisites for configuring storage using LDM
Note the following prerequisites before you configure shared storage with LDM:

■ Verify that the disk signature is the same on all systems that share the disk. 
See “Reserving disks (Windows LDM)” on page 943.

■ Install software drivers for the disk controller device identically on each 
system in the VCS One cluster. Verify that these driver services run 
successfully on all systems.

■ Disable the option Reset SCSI Bus at IC Initialization from the SCSI Select 
utility.

■ If using the agents in a Fibre Channel setup, enable target resets for the 
adapters.

■ Verify that the device path to the disk is recognized by each system sharing 
the disk.

See “Verifying disks are visible from systems” on page 943.

■ Disable the write cache on the internal SCSI RAID controller.

■ For each system, unassign the drive letter for the disk device path 
configured for mounting.

See “Unassigning a drive letter (Windows LDM)” on page 945.

■ On Windows Server 2008, after creating disk partitions ensure that you do 
not assign drive letters to those partitions. If you assign drive letters to the 
partitions, you must either remove the drive letters before configuring the 
disks in VCS One or use the same drive letters for those disks, in the VCS 
One configuration.
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■ When you install the VCS One client on Windows Server 2008 systems, the 
Windows automount feature is disabled automatically on the system. 
Disabling automount prevents Windows from automatically mounting or 
assigning drive letters to the volumes. Ensure that the automount feature 
remains disabled. This is required for disks that are configured in VCS One.

Verifying disks are visible from systems
Use the Windows Disk Management tool to verify that the shared disks are 
visible from each system that is going to be part of the VCS One cluster. You 
must run Disk Management on all systems each time you add a shared disk. This 
ensures each disk has a valid signature written to it and the device paths and 
symbolic links are updated.

To verify that disks are visible

1 Log on as a local Administrator.

2 Open Disk Management.

Type the following on the command prompt:

diskmgmt.msc

3 Verify that the shared disks are visible in the right-pane.

4 Close Windows Disk Management.

Reserving disks (Windows LDM)
You must reserve shared disks from a client system before you configure an 
application in a VCS One cluster.

Perform the following steps for reserving disks from a client system.

To reserve the disks

1 To display all the disks, type the following on the command line:

havol -scsitest /L

You will see a table that lists all the disks that are visible from the current 
system. Make a note of the disk numbers (Disk# column in the table). You 
will need it in the next step.

2 To reserve a disk, type the following on the command line:

havol -scsitest /RES:<disk_number>

For example, to reserve disk 4, type:
havol -scsitest /RES:4

If a disk is already reserved on another client system, you can use the 
following command to override the existing reservation and reserve the 
disk from the current client system:



944 How to configure resources and applications on Windows
About configuring shared storage
havol -scsitest /RES:<disk_number> -F

Make a note of the disk number and the corresponding signature. You will 
require these details to identify and reserve the disks while configuring the 
Mount and DiskRes resources in a service group.

For more details on the havol utility See “About the havol utility” on 
page 946.

Creating volumes (Windows LDM)
Use the Windows Disk Management tool to create volumes on the reserved disk. 
Refer to Microsoft Windows documentation for more information about the 
Disk Management tool.

Perform the following steps.

To create volumes

1 Use the Windows Disk Management tool to verify that the disks are visible 
on the client systems in the VCS One cluster, and then create volumes on the 
reserved disks.

2 After you create the required volumes on a client system, release the 
reserved disks from that client system.

See “Releasing disks (Windows LDM)” on page 945.

3 Rescan the disks on all the remaining client systems where the shared disks 
are connected.

Mounting volumes (Windows LDM)
Use the Windows Disk Management tool to mount volumes that you created 
earlier.

Perform the following steps.

To mount the volumes

1 Use the Windows Disk Management tool to mount the volumes that you 
created on the reserved disks.

2 After you mount the volumes on the client system, run the CHKDSK command 
and verify that there are no errors on the mounted volumes.

3 Make a note of the drive letters that you assign to the mounted volumes. You 
must use the same drive letters when you mount those volumes on the 
remaining client systems in the VCS One cluster.

Refer to Microsoft Windows documentation for more information on the 
CHKDSK command and the Windows Disk Management tool.
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Unassigning a drive letter (Windows LDM)
While installing an application on multiple client systems, you must first 
unassign drive letters and release the disks from one client system, then reserve 
the disks and mount the volumes using the same drive letters, and then install 
the application on the failover client systems.

Perform the following steps to unassign a drive letter for a volume.

To unassign a drive letter

1 Log on as a local Administrator.

2 Open Disk Management.

Type the following on the command prompt:

diskmgmt.msc

3 Right-click the partition or logical drive and click Change Drive Letter and 
Path.

4 In the Change Drive Letter and Paths dialog box, click the drive letter and 
click Remove.

You must run Disk Management on all systems each time you add a shared 
disk. This ensures each disk has a valid signature written to it and the 
device paths and symbolic links are updated.

Releasing disks (Windows LDM)
While installing an application on multiple client systems you must release the 
disks from one client system and then reserve the disks on the failover client 
system.

Perform the following steps to release reserved disks.

To release disks

1 To display all the disks, type the following on the command prompt:

havol -scsitest /L

You will see a table that lists all the disks that are visible from the current 
system. Make a note of the disk numbers (Disk# column in the table). You 
will need it in the next step.

2 To release a reserved disk, type the following on the command prompt:

havol -scsitest /REL:<disk_number>

For example, to release disk 4, type:
havol -scsitest /REL:4
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About the havol utility
The havol utility provides the following options:

■ getdrive

Retrieves information about the disk and stores it in a file called 
DriveInfo.txt in the same path from where you execute the command.

■ scsitest

Reserves and releases disks. It helps troubleshoot issues related to SCSI 
reservation.

Syntax

havol -scsitest <options>

havol -getdrive [-details]

Using the -getdrive option
Type the following at the command prompt:

havol -getdrive

For detailed information about the disk, type the following:

havol -getdrive -details

The utility retrieves information about the disk and stores it in a file called 
DriveInfo.txt in the same path from where you execute the command.

Sample file contents include the following details:
Detailed Information about Fixed Disks with valid volumes in the 
system : VCSONEW2K8112J

Harddisk Number  = 1
Harddisk Type    = Basic Disk
Disk Signature   = 130349684
Valid Partitions = 3
Access Test      = SUCCESS
Partition Number = 3
Partition Type   = IFS Partition
Bootable         = NO
Partition Size   = 400.06 MB
WINNT style Name = \device\Harddisk1\Partition3
Target Name      = \Device\HarddiskVolume6
Device Name      = \\?\Volume{03074b0e-b4d7-11d6-b5a9-
00d0b7471a1f}\
DriveLetter      = Unassigned
DrivePath001     = F:\f1\

Partition Number = 2
Partition Type   = IFS Partition
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Bootable         = NO
Partition Size   = 400.06 MB
WINNT style Name = \device\Harddisk1\Partition2
Target Name      = \Device\HarddiskVolume5
Device Name      = \\?\Volume{03074af7-b4d7-11d6-b5a9-
00d0b7471a1f}\
DriveLetter      = Unassigned
DrivePath001     = F:\f2\

Partition Number = 1
Partition Type   = IFS Partition
Bootable         = NO
Partition Size   = 4.01 GB
WINNT style Name = \device\Harddisk1\Partition1
Target Name      = \Device\HarddiskVolume4
Device Name      = \\?\Volume{e587ddc7-8cee-11d6-b401-
00d0b7471a1f}\
DriveLetter      = F:
MountPoint001    = F:\f2\ -> \\?\Volume{03074af7-b4d7-11d6-b5a9-
00d0b7471a1f}\
MountPoint002    = F:\f1\ -> \\?\Volume{03074b0e-b4d7-11d6-b5a9-
00d0b7471a1f}\

Using the -scsitest option
Type the following at the command prompt:

havol -scsitest [/option]

The variable option represents additional parameters for the command, listed in 
“Options for the -scsitest command” on page 948.

Caution: Reserving or releasing shared disks may cause the configured service 
groups to fail over to another system.

Retrieving the disk number
Most scsitest options require the disk number. To list the disk numbers visible 
from the system, type the following at the command prompt:

havol -scsitest /L

Verify the disk signature to ensure you choose the correct disk number. If the 
required disk number or signature is not listed, try rescanning the SCSI bus.

Type the following at the command prompt:

havol -scsitest /RESCAN
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Options for the -scsitest command
Use the following options with the scsitest command to limit the diagnostic 
information to specific components.

Table A-1 -scscitest command: basic options

Basic Options Action

-ADDR:1 Gets the SCSI address of disk number 1.

-LISTDISKS or -L Lists all visible disks.

-REL:1 Releases disk number 1.

-RES:1 Reserves disk number 1.

-RES:1 -FORCE (or -F) Preempts if disk number 1 is already reserved and then 
reserves the disk.

-RESCAN Rescans the SCSI bus.

-SIG:1 Retrieves the signature of disk number 1.

-PRKEY Lists the Persistent Reservation Key that is used for SCSI-
3 operations on the current client system.

-PRKEY:1 Lists the Persistent Reservation Key for disk number 1.
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About managing shared storage using SFW
In Veritas Storage Foundation for Windows (SFW), disk groups are created on 
physical disks. These disk groups are further divided into volumes that can be 
mounted on the cluster systems.

Perform the following tasks to create volumes and to make them accessible from 
cluster systems:

■ Create dynamic disk groups.

■ Create volumes.

■ Import the disk group and mount the volumes.

See the Veritas Storage Foundation Administrator’s Guide for instructions.

Before you configure shared storage, review the attribute definitions of the 
VMDg and the MountV agents.

See the Veritas Cluster Server One Bundled Agents Reference Guide.

Considerations for using SFW with VCS One
The following advanced features of SFW require special consideration when 
used in a VCS One environment:

■ Deporting Disk Groups

SFW does not allow disk groups configured as VCS One resources to be 
deported. They must be brought online or taken offline using VCS One.

■ Dynamic Group Split and Join (DGSJ)

SFW does not allow splitting a disk group configured as a VCS One resource 
if the split operation causes a volume configured as a VCS One resource to 
be part of the target group.

SFW does not allow a disk group configured as a VCS One resource to be the 
source disk group in a join operation.

■ Deleting Volumes

SFW does not allow deleting volumes configured as VCS One resources.

■ Volume Snap Back

If a volume formed as a result of a Prepare and Snap Shot operation is 
configured as a VCS One resource, SFW does not allow Snap Back 
operations on the volume.

See the Veritas Storage Foundation Administrator’s Guide for more 
information.
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Prerequisites for configuring storage using SFW
Note the following prerequisites before you configure shared storage with SFW:

■ Ensure that Storage Foundation for Windows (SFW) is installed on the client 
systems.

■ If you have configured Windows firewall, add port 2148 to the firewall 
exceptions list.

■ Configure clustered disk groups using Storage Foundation for Windows. 
Verify the disk groups contain shared disks only.

■ Disable the option Reset SCSI Bus at IC Initialization from the SCSI Select 
utility.

■ Create a separate clustered disk group for each application to be clustered. 
Do not create a clustered disk group for more than one application. 
Configure all volumes to be part of the VCS One configuration and of the 
same service group.

■ Assign a unique disk group name to each clustered disk group within a 
cluster.

■ Ensure that the device path to the shared disk groups is recognized by all 
systems sharing the disk.

■ If you are using SFW 5.1, you must install the hotfix that supports SCSI 
(including SCSI-3) Persistent Group Reservation (PGR) on shared disks 
managed using SFW.

Install the hotfix from the following location:

http://svlvault.veritas.com/cgi-bin/patch_central?archive=3248

You must install this hotfix only if you are using SFW 5.1 to manage your 
storage in a VCS One cluster environment.

This hotfix is not required if you are using SFW 5.1 SP1 or later versions.

http://svlvault.veritas.com/cgi-bin/patch_central?archive=3248
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About configuring file shares
This topic describes how to configure file shares in VCS One. The attribute 
definitions of the FileShare agent are described in the Veritas Cluster Server One 
Bundled Agents Reference Guide.

The File Share Configuration Wizard enables you to create and modify file share 
service groups that make shares highly available in the VCS One cluster.

Note: You cannot use the File Share Configuration Wizard to create and modify 
file share service groups on Windows Server 2008 Server Core systems. Use the 
VCS One console instead.

About File Share service group types
You can use the File Share Configuration Wizard to create the following types of 
service groups:

■ Failover

A failover service group contains multiple systems wherein the file shares 
reside on shared drives that are accessible from all the systems that are part 
of the service group. VCS One monitors the file shares in the virtual server 
context. If there is any failure on the system where the service group is 
online, VCS One brings the service group online on another system defined 
in the service group’s system list, thus making the file shares highly 
available.

■ Start/Stop

A start/stop service group is configured on a single system wherein the file 
shares reside on the local system disks. VCS One monitors the file shares 
and the underlying storage and network components used by those file 
shares on the system where the service group is configured. Start/stop 
service groups do not require that the application data reside on shared 
drives. You can configure start/stop service groups to make the file shares 
available in the local system context or the virtual server context. 
Depending on the configuration, users can access file shares using the local 
system name or the virtual server name. As start/stop service groups do not 
contain multiple systems, you cannot fail over a start/stop service group. 
VCS One monitors the service group, brings it online and takes it offline on 
the system where the service group is configured. If there is any failure, 
VCS One faults the service group, the configured file shares become 
unavailable and administrative intervention is required.
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Before you configure a file share service group
Note the following prerequisites before you configure a file share service group:

■ The VCS One client must be configured on the systems that are going to be 
part of the service group.

■ The logged-on user must have read access on the systems that are going to 
be part of the service group.

■ The VCS One Remoting and Client Daemon services must be running on the 
systems that are going to be part of the service group.

■ For a failover service group, the directories that you wish to configure must 
reside on shared drives that are mounted on the system where you run the 
wizard. For start/stop service groups, shared drives are not required.

The wizard allows you to add existing shares to the VCS One configuration. 
However, you cannot add special shares (shares created by the operating 
system for administrative and system use). For example, you cannot add the 
shares ADMIN$, print$, IPC$, and DriveLetter$ to the VCS One 
configuration.

■ For a failover service group, the disk groups and volumes that you specify 
for the file share service group must not be configured in another service 
group in the VCS One cluster.

■ This is applicable if you are using Windows Logical Disk Management (LDM) 
to manage your storage.

For a failover service group, the disk groups and volumes that you specify 
must be mounted once on all the systems that are going to be part of the 
service group so as to ensure that the disks are visible from all those 
systems. However, before configuring the file share service group, ensure 
that you mount them on the system where you run the wizard.

See “About configuring shared storage” on page 941.

■ If your storage configuration uses folder mounts, verify the following:

■ The configured path exists.

■ The directory is empty.

■ The volume on which the directory resides is NTFS-formatted.

■ The directory is not a system directory.

■ If you have configured a firewall, ensure that you add the required ports to 
the firewall exceptions list.

Refer to the Veritas Cluster Server One Installation Guide for the list of ports 
used by VCS One.

■ Keep the following details with you; the wizard prompts for this 
information:
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■ A user account configured on the Policy Master. This user account 
must have read access to the VCS One OU and the privileges to add and 
modify service groups. The user account must have the privileges to 
attach service groups to the desired OUValue.

If you choose to use the logged-on user, ensure that the logged-on user 
account has these privileges.

■ A unique virtual IP address for the file share server.

The virtual IP address is optional for a start/stop service group.

■ A unique virtual server name for the file share server.

This is the name by which clients access the server. The virtual name 
must not exceed 15 characters.

The virtual server name is optional for a start/stop service group.

Configuring a file share service group using the wizard
Perform the following steps to configure a file share service group using the File 
Share Configuration Wizard.

To configure a file share service group

1 Click Start > Programs > Symantec > VCS One > File Share Configuration 
Wizard to start the File Share Configuration Wizard.

2 Review the information in the Welcome panel and click Next.

3 On the Policy Master Details panel specify the following information and 
then click Next:

Policy Master: IP 
Address

Displays the virtual IP address of the Policy Master (PM).
This is the IP address that was specified during VCS One client 
configuration.

Policy Master: 
Port

Displays the port number used by the PM.
The default port is 14151.

Use Logged-on 
user credentials

Check the Use Logged-on user credentials check box if you 
want the wizard to use the logged-on user account context to 
perform the configuration tasks.
This option is checked by default.
The logged-on user account must have the privileges to access 
all the systems selected for the wizard operations.
The logged-on user account must be configured in the VCS 
One cluster and must have privileges to add and modify 
service groups in the VCS One cluster.
If you do not want to use the logged-on user account context, 
clear this check box.
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4 On the Service Group Options panel, select from the following options and 
then click Next:

■ Click Create failover service group if you wish to configure a failover 
service group.

■ Click Create start/stop service group if you wish to configure a start/
stop service group on the local system.

5 On the OUValue Selection panel specify the OUValue that you want to attach 
the service group with and then click Next.

You can either type the OUValue path or select the OUValue from the VCS 
One Organization Tree.

Type the OUValue path in the format /OUName=OUValue. In case of nested 
OU objects, the format is OUName=OUValue1/OUName=OUValue2.

For example, /VCSOneCO=Retail or /VCSOneCO=Marketing/
B2B=Dept.

You cannot attach service groups with OUName; you must specify a 
OUValue.

If you are configuring a start/stop service group, proceed to step 8.

6 For a failover service group, on the System Selection panel select the 
systems for the file share service group and then click Next.

This step is not applicable if you are configuring a start/stop service group.

The Available Systems box displays the systems in the VCS One cluster that 
the specified user account has access to.

Select the systems from the Available Systems box and click the right arrow 
to move the systems to the Selected Systems box. To remove a system from 
the Selected Systems box, click the system in the Selected Systems box and 
click the left arrow.

User Name Type a VCS One user name.
The user account must be configured in the VCS One cluster 
and must have privileges to add and modify service groups in 
the VCS One cluster.
This option is disabled if you check the Use logged-on user 
credentials check box.

Password Type the password for the specified user.

Domain Type From the drop-down list select the type of domain to which 
the user belongs.

Domain Name Type the domain name of the specified user.
For example, if a user Tom is part of the domain mydomain, 
type mydomain if Tom@mydomain is configured on the Policy 
Master.
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If you are configuring the service group on a virtual machine that has 
virtual machine high availability (VMHA) policy enabled, the wizard does 
not allow you to add any other system to the service group. You cannot add 
more than one vframe to a service group if a vframe is enabled for VMHA.

See “About virtual machine high availability” on page 68 for more details 
about VMHA.

To change a system’s failover priority in the service group, click the system 
from the Selected Systems box and then click the up and down arrows. 
System priority defines the order in which service groups are failed over to 
systems. The system at the top of the list has the highest priority while the 
system at the bottom of the list has the lowest priority.

To search for specific systems, click Edit Filter, select the desired filter 
criteria and then click Update Filter. The Available Systems box then 
displays the systems as per your chosen search criteria.

Table A-2 lists the various filter options that you can use to search systems.

Table A-3 System selection panel: Filter criteria

Filter Criteria Usage and Example

Organization 
Unit

Search systems based on the VCS One OU objects that they 
belong to. You can either type the OU object details or choose 
the desired OU object from the Organization Tree displayed.

Example: To list the systems belonging to the OUName 
VCSOneCO and OUValue Retail, either select Retail, or type
/VCSOneCO=Retail.

Attributes Search systems based on the number of CPUs or the amount 
of random access memory (RAM) available, or a combination 
of both.
Example: To list systems with 4 units of CPU and having 4 GB 
of RAM, type 2 and 4 in the CPU and Memory fields 
respectively.
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Expressions Search systems based on the VCS One Extended Attributes 
(EA) or OU expressions, or a combination of both.
Specify the details in the following format:
EA Expression: EA=’EA value’
OU Expression: Type /OUName=OUValue
For EA Expressions, ‘specify’ the EA value in single quotation 
marks.

Example: To list systems administered (EA=Admin) by Tom 
(EA value=Tom) and that belong to the OUValue Retail, 
specify the details as follows:
EA Expression: Admin=‘Tom’
OU Expression: /VCSOneCO=Retail

You can also use wild cards in the search. For example, 
EA Expression: *Marketing
OU Expressions: /Product=*/Department=Sales

Extended 
Attributes

Search systems based on the VCS One Extended Attributes. 
Select an EA from the Name box, then type or select an 
appropriate EA value in the Value box, and then click Add.
Use the boolean AND or OR buttons to combine multiple 
Extended Attributes and achieve the desired filter criteria.

Example: To list systems administered (EA=Admin) by Tom 
(EA value=Tom) and having operating system (EA=OS) as 
Windows Server 2008 (EA value=Win2008), do the following:

■ Select Admin and Tom in the Name and Value box 
respectively, and then click Add.

■ Click AND.

■ Select OS and Win2008 in the Name and Value box 
respectively, and then click Add.
Your search filter should appear as follows:
Admin=‘Tom’ AND OS=‘Win2008’

Keyword Search systems based on keywords. You can use * and % as 
wildcard characters to filter systems.

Example: To list sytems whose names start with the word 
Win, type Win* or Win%. To list systems whose names 
contain the word Win, type *Win* or %Win%.
The keywords are not case sensitive. *win and *WIN will fetch 
the same results.
Do not use the wildcard characters in between keywords. 
*SystemName* or %SystemName% is a valid input. 
System*Name or System%Name is an invalid input.

Table A-3 System selection panel: Filter criteria

Filter Criteria Usage and Example



957How to configure resources and applications on Windows
About configuring file shares
7 For a failover service group, on the Network Configuration panel, specify the 
network details and the virtual server name for the file share server and 
then click Next.

This step is not applicable if you are configuring a start/stop service group.

Virtual Server Name Type a unique virtual server name by which the file 
share server will be known to clients.
The virtual name must not exceed 15 characters.

Virtual IP Address Type a unique virtual IP address for the file share 
server.

Subnet Mask Type the subnet to which the virtual IP belongs.
This field displays the subnet of the local system by 
default.

Adapter Display Name Select a public network adapter name for each system.
To view the adapters associated with a system, select 
the Adapter Display Name field and click the arrow to 
expand the drop-down list. This list displays all the 
TCP/IP enabled adapters on the system.

Advanced Settings Click Advanced Settings and specify additional details 
for Active Directory (AD) and DNS updates. These 
settings apply to the Lanman resource in the service 
group.
On the Advanced Settings dialog box, set the following 
options as desired:

■ Check Active Diretory Update Required check box to 
enable the Lanman resource to update the Active 
Directory with the virtual server name.

■ In the Organizational Unit field, specify the 
distinguished name of the Windows AD 
Organizational Unit (OU). To browse for an OU, click 
Browse and search for the OU using the Windows Find 
Organization Units dialog box.
By default, the Lanman resource adds the virtual 
server details to the default container "Computers."

■ Check the AD Update Critical For Online check box to 
set the Lanman attribute ADCriticalForOnline to 1. 
The Lanman resource will fault if the AD update fails.

■ Check the DNS Update Required check box to set the 
Lanman attribute DNSUpdateRequired to 1. The 
Lanman agent updates the DNS with the specified 
virtual server details.
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If you are configuring a failover service group, proceed to step 9.

8 For a start/stop service group, on the Network Configuration panel, choose 
the desired option and then click Next.

This step is not applicable if you are configuring a failover service group.

Do one of the following:

■ To configure the file shares in the virtual server context click Use 
virtual IP context. Clients can access the file shares using the virtual 
server name, \\virtualservername\ filesharename.

Specify the following details:

■ Check the DNS Update Critical For Online check box to 
set the Lanman attribute DNSCriticalForOnline to 1. 
The Lanman resource faults if the agent fails to 
update the DNS.

■ Check the Ignore Default check box to set the Lanman 
attribute DNSOptions to IgnoreDefault. The Lanman 
agent will update only the DNS servers specified in 
the AdditionalDNSServers attribute.

■ Check the Purge Duplicate check box to set the 
Lanman attribute DNSOptions to PurgeDuplicate. The 
Lanman agent will remove duplicate entries from the 
DNS servers.

■ Click OK.

Note: The Lanman agent uses the VCS One Remoting 
Service user accout context to perform AD and DNS 
updates. This accout must have privileges to create and 
update computer accounts on the specified container.

Virtual Server Name Type a unique virtual server name by which the file share 
server will be known to clients.

The virtual name must not exceed 15 characters.

Virtual IP Address Type a unique virtual IP address for the file share server.

Subnet Mask Type the subnet to which the virtual IP belongs. This field 
displays the subnet of the local system by default.

Adapter Display 
Name

Select a public network adapter from the drop-down list. 
This list displays all the TCP/IP enabled adapters on the 
system.
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■ To configure the file shares in the local system context, click Use local 
system name context and then select an IP address from the list.

Advanced Settings Click Advanced Settings and specify additional details 
for Active Directory (AD) and DNS updates. These 
settings apply to the Lanman resource in the service 
group.

On the Advanced Settings dialog box, set the following 
options as desired:

■ Check Active Diretory Update Required check box to 
enable the Lanman resource to update the Active 
Directory with the virtual server name.

■ In the Organizational Unit field, specify the 
distinguished name of the Windows AD 
Organizational Unit (OU). To browse for an OU, click 
Browse and search for the OU using the Windows 
Find Organization Units dialog box. By default, the 
Lanman resource adds the virtual server details to 
the default container "Computers."

■ Check the AD Update Critical For Online check box 
to set the Lanman attribute ADCriticalForOnline to 
1. The Lanman resource will fault if the AD update 
fails.

■ Check the DNS Update Required check box to set the 
Lanman attribute DNSUpdateRequired to 1. The 
Lanman agent updates the DNS with the specified 
virtual server details. 

■ Check the DNS Update Critical For Online check box 
to set the Lanman attribute DNSCriticalForOnline to 
1. The Lanman resource faults if the agent fails to 
update the DNS.

■ Check the Ignore Default check box to set the 
Lanman attribute DNSOptions to IgnoreDefault. 
The Lanman agent will update only the DNS servers 
specified in the AdditionalDNSServers attribute.

■ Check the Purge Duplicate check box to set the 
Lanman attribute DNSOptions to PurgeDuplicate. 
The Lanman agent will remove duplicate entries 
from the DNS servers.

■ Click OK.

Note: The Lanman agent uses the VCS One Remoting 
Service user accout context to perform AD and DNS 
updates. This accout must have privileges to create and 
update computer accounts on the specified container.



960 How to configure resources and applications on Windows
About configuring file shares
Clients can access the file shares using the local system name, 
\\localsystemname\ filesharename.

9 On the File Share Configuration panel, specify the directories that you wish 
to configure in the file share service group, set their share properties, and 
then click Next.

Enter a directory path Type the path of the directory that you wish to 
configure.

Note: The wizard allows you to add existing shares to 
the VCS One configuration. However, you cannot add 
special shares (shares created by the operating 
system for administrative and system use). For 
example, you cannot add the shares ADMIN$, print$, 
IPC$, and DriveLetter$ to the VCS One configuration.

Add Click Add or press Enter to add the specified directory 
to the list. To browse for a directory, click the ellipsis 
(...) button, select a directory, and then click OK.

Add Existing Shares Click Add Existing Shares to view the existing shares, 
then select a share and click Add.

Share Path Displays the path of the directory that you added.

To edit the path, either double-click the path and type 
a new path or click the adjacent ellipsis button (...), 
choose the appropriate directory and click OK.

Share Name If a selected directory is already shared, the Share 
Name column displays the name by which it is shared. 
You can select a listed share name to make an existing 
share highly available. You can also create a new 
share for the same directory by typing a new share 
name.

You can add a share multiple times and share it with a 
different share name, users, and user permissions.

Remove To remove a share from the file share configuration, 
click to select a share and then click Remove.
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To set the share properties click the edit icon adjacent to a share name and 
on the File Share Properties dialog box specify the options as follows:

User Limit Type the number of users that are allowed access to 
the selected share.

If you type zero or a value greater than what Windows 
supports, access is granted to the maximum users 
allowed on Windows.

Maximum Allowed Check the Maximum Allowed check box to allow 
access to the maximum number of users allowed on 
Windows.

Enable access-based 
enumeration

Check the Enable access-based enumeration check 
box to enable the Windows access-based enumeration 
feature on the selected share.

Enable cache Check the Enable cache check box to enable local 
caching of the contents of the selected share.

Then, specify how the contents of the share are 
available to users for offline access.
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In the drop down list select from the following 
caching options:

■ Manual caching of files and programs: Only the 
files and programs specified by the user are 
available offline. The value of the file share 
agent attribute ClientCacheType is set to 
MANUAL.

■ Automatic caching of programs: All the files and 
programs that the users access from the file 
share are available offline. The value of the file 
share agent attribute ClientCacheType is set to 
DOCS.

■ Optimized automatic caching of files and 

programs: All files and programs, including 
executables, are cached locally. The next time 
the user accesses the executable files, they are 
launched from the local cache. The value of the 
file share agent attribute ClientCacheType is set 
to PROGRAMS.

Hide share Check the Hide Share check box to make the new 
share a hidden share.

Share all subfolders Check the Share all subfolders check box to share the 
subfolders in the selected share.

Hide child shares Check the Hide child shares check box to make the 
shared subfolders as hidden shares.

Copy properites to selected 
shares

The properties that you set on the Share Properties 
dialog box are applicable to the selected share.

To copy these share properties to other shares, check 
the Copy properties to selected shares check box and 
then select the shares displayed in the box.

Note that the box will display only those shares that 
you added earlier.

Apply Click Apply to set the share properties to the selected 
share.

If you are copying these properties to other shares, 
click OK on the message that prompts you to confirm 
the action.

Reset properties Click Reset properties if you wish to revert the share 
properties to the default values.

Note that this will discard the settings you specified 
for the selected share.
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10 On the Share Permissions panel, add users for the file shares, assign them 
permissions, and then click Next.

All Shares Click All Shares if you wish to grant users access to all the 
shares simultaneously.

Selected Share Click Selected Share and then select a share listed in the 
box. The users that you add will have access only to the 
selected share.

Note that using this method you can assign users to only 
one share at a time. You cannot select multiple shares.

Add Click Add and specify a user name in the Windows Select 
User or Group dialog box and then click OK. The user 
name is displayed in the Users list.

You can configure a maximum of 50 users for each file 
share. To configure more users, create and then add a user 
group.

Select Permissions for all 
the users

From the drop-down list, select the permission to be 
associated with the users and then click Apply. The 
selected permission is granted to all the users in the Users 
list.

To assign permissions for a specific user, select the 
desired permission from the Permissions drop-down list.

Remove Select a user and then click Remove to remove that user 
from the list.
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11 On the Service Group Summary panel, review the service group 
configuration, edit the service group name and the resource names if 
required, and then click Next.

12 The Commit Configuration panel displays the service group configuration 
progress. The wizard starts running the commands to create the service 
group. Various messages indicate the status of these commands. After all 
the tasks are complete, click Next.

13 On the Finish panel, check the Bring the service group online check box if 
you want the wizard to bring the service group online after the service group 
is configured, and then click Finish.

Service Group Details Displays the service group name, a list of resources, 
and their attributes details. The wizard assigns 
unique names to the service group and its resources.

You can change the name of the service group and 
the resources (not the attributes), if required.

To edit a name, select the name and either click it or 
press the F2 key. Edit the name and then press the 
Enter key to confirm the changes. To cancel editing a 
name, press the Esc key.

For a failover service group, if you specify shared 
volumes created in an SFW environment, the wizard 
configures the VMDg and MountV resources. If you 
specify shared volumes created in the Windows LDM 
environment, the wizard configures the DiskRes and 
Mount resources for storage.

For a start/stop service group, if you configure the 
service group in the local system name context, the 
wizard configures a IPMonitor resource. If you 
configure the service group in the virtual IP context, 
the wizard configures a MountMonitor resource.

Configure a common resource 
for shares having similar 
attributes

This option is checked by default. It means that the 
wizard creates a single fileshare resource that is 
common for all shares that have similar properties. 
For example, shares which have similar set of users 
and user permissions are grouped in a single 
fileshare resource.

Clear this check box if you want the wizard to create 
separate file share resources for each share.

Note that the service group summary details change 
depending on whether or not you have checked this 
check box.



965How to configure resources and applications on Windows
About configuring file shares
The wizard issues a command to bring the service group online on the local 
system.

This completes the file share service group creation.

A service group may fail to come online due to various reasons. This does 
not mean that the service group was not configured. In such cases, you must 
probe the resources and then bring the service group online manually from 
the VCS One console.

Modifying a file share service group using the wizard
You can modify file share service groups using the File Share Configuration 
Wizard. You can modify both start/stop and failover service groups using the 
wizard. You can modify a start/stop service group to configure it from a virtual 
server context to the local system context and vice versa.

Note: You cannot convert a failover service group to a start/stop service group 
and vice versa.

Note the following prerequisites before you modify a file share service group:

■ If the file share service group is online or partially online, you must run the 
wizard from a system on which the service group is online or partially 
online. You can then use the wizard to add resources and remove offline 
resources from the service group. You cannot change attributes of resources 
that are online. To change the resource attributes, you must take the service 
group offline. 

■ For a failover service group, if you are running the wizard to remove a 
system from the service group’s system list, do not run the wizard on the 
system being removed.

■ For a failover service group, if you are running the wizard to add a system to 
the service group’s system list, ensure that the shared drives that contain 
the file shares are configured on the system being added.

■ You cannot convert a failover service group into a start/stop service group 
and vice versa. If you wish to change the service group type, delete the 
existing service group and recreate it using the wizard.

Verify the prerequisites for each type of service group before you proceed.

Perform these steps to modify a file share service group using the File Share 
Configuration Wizard.

To modify a file share service group

1 Click Start > Programs > Symantec > VCS One > File Share Configuration 
Wizard to start the File Share Configuration Wizard.
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2 Review the information on the Welcome panel and click Next.

3 On the Policy Master Details panel specify the following information and 
then click Next:

4 On the Service Group Options panel, click Modify service group, specify the 
service group, and then click Next.

You can either type the service group name or select a service group from 
the list. The list displays only those service groups that are either created or 
modified using the wizard. If the service group that you created manually 
does not appear in the list, you can type the service group name.

5 Complete the subsequent wizard steps.

See “Configuring a file share service group using the wizard” on page 953.

Policy Master: IP 
Address

Displays the virtual IP address of the Policy Master (PM).
This is the IP address that was specified during VCS One client 
configuration.

Policy Master: 
Port

Displays the port number used by the PM.
The default port is 14151.

Use Logged-on 
user credentials

Check the Use Logged-on user credentials check box if you 
want the wizard to use the logged-on user account context to 
perform the desired tasks.
This option is checked by default.
The logged-on user account must have the privileges to access 
all the systems selected for the wizard operations.
The logged-on user account must be configured in the VCS 
One cluster and must have privileges to add and modify 
service groups in the VCS One cluster.
If you do not want to use the logged-on user account context, 
clear this check box.

User Name Type a VCS One user name.
The user account must be configured in the VCS One cluster 
and must have privileges to add and modify service groups in 
the VCS One cluster.
This option is disabled if you check the Use logged-on user 
credentials check box.

Password Type the password for the specified user.

Domain Type Select the type of the domain to which the user belongs.

Domain Name Type the domain name of the specified user.
For example, if a user Tom is part of the domain mydomain, 
type mydomain if Tom@mydomain is configured on the Policy 
Master.
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About configuring print shares
This topic describes how to configure print shares and make them highly 
available. You can configure a print share service group to share network 
printers in the VCS One cluster. Use the Print Share Configuration Wizard to 
create and modify print share service groups.

Before you configure a print share service group, review the attribute 
definitions of the PrintShare agents.

See the Veritas Cluster Server One Bundled Agents Reference Guide.

Note: You cannot use the Print Share Configuration Wizard to create and modify 
print share service groups on a Windows Server 2008 Server Core system. Use 
the VCS One console instead.

About Print Share service group types
You can use the Print Share Configuration Wizard to create the following types 
of service groups:

■ Failover

A failover service group contains multiple systems wherein the printer 
configuration information resides on shared drives that are accessible from 
all the systems that are part of the service group. VCS One monitors the 
print shares in the virtual server context. If there is any failure on the 
system where the service group is online, VCS One brings the service group 
online on another system defined in the service group’s system list, thus 
making the configured printers highly available.

■ Start/stop

A start/stop service group is configured on a single system wherein the 
printer configuration information resides on the local system disk. VCS One 
monitors the printers and the underlying storage and network components 
used by the print shares on the system where the service group is 
configured. Start/stop service groups do not require that the application 
data reside on shared drives. You can configure start/stop service groups to 
make the printers available in the local system context or the virtual server 
context. Depending on the configuration, clients can access the printers 
using the local system name or the virtual server name. As the service 
group does not contain multiple systems, you cannot fail over a start/stop 
service group. VCS One monitors the service group, brings it online, and 
takes it offline on the system where the service group is configured. If there 
is any failure, VCS One faults the service group, the configured printers 
become unavailable, and administrative intervention is required.
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Before you configure a Print Share service group
Note the following prerequisites before you configure a print share service 
group:

■ The VCS One client must be configured on the systems that are going to be 
part of the service group.

■ The logged-on user must have read access on the systems that are going to 
be part of the service group.

■ The VCS One Remoting and Client Daemon services must be running on the 
systems that are going to be part of the service group.

■ The logged-on user must have local Administrator privileges on the system 
from where you run the wizard.

■ Ensure that you have the IP addresses of the printers that you wish to 
configure in the service group.

■ For a failover service group, Symantec recommends creating the spooler and 
the replication directories on different disk partitions or volumes.

■ For a failover service group, the disk groups and volumes that you specify 
for the print share service group must not be configured in another service 
group in the VCS One cluster.

■ If your storage configuration uses folder mounts, verify the following:

■ The configured path exists.

■ The directory is empty.

■ The volume on which the directory resides is NTFS-formatted.

■ The directory is not a system directory.

■ This is applicable if you are using Windows Logical Disk Management (LDM) 
to manage your storage.

For a failover service group, mount the drives for storing the spooler and 
the registry replication information once on all the systems that are going 
to be part of the service group so as to ensure that the disks are visible from 
all those systems. However, before configuring the print share service 
group, ensure that you mount them on the system where you run the 
wizard.

See “About configuring shared storage” on page 941.

■ Install software drivers for the network printers on the systems that will be 
part of the print share service group.

■ If you have configured a firewall, ensure that you add the required ports to 
the firewall exceptions list.
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Refer to the Veritas Cluster Server One Installation Guide for the list of ports 
used by VCS One.

■ Keep the following details with you; the wizard prompts for this 
information:

■ A user account configured on the Policy Master. This user account 
must have read access to VCS One OU and the privileges to add and 
modify service groups. The user account must have the privileges to 
attach service groups to the desired OUValue.

If you choose to use the logged-on user, ensure that the logged-on user 
account has these privileges.

■ A unique virtual IP address to be assigned to the print share server.

The virtual IP address is optional for a start/stop service group.

■ A unique virtual server name to be assigned to the print share server.

This is the name by which clients access the server. The virtual name 
must not exceed 15 characters.

The virtual server name is optional for a start/stop service group.

■ List of printers or their IP addresses, that you wish to share.

Configuring a print share service group using the wizard
Configuring a print share service group involves the following tasks:

■ Creating a print share service group with a PrintSpool resource and bringing 
the service group online. For a failover service group, this also involves 
configuring the Lanman resource (virtual server) on which the PrintSpool 
resource depends.

■ Adding a network printer to the virtual server created by the Lanman 
resource. For a start/stop service group configured in the local system 
context, add the network printer to the localhost.

This also involves creating a new TCP/IP port for the printer and installing 
the printer drivers.

For a failover service group, the drivers must be installed on the shared 
drives. This makes the printer information available on the server 
whereever the print share service group is online.

■ Adding a PrintShare resource to the print share service group and then 
bringing the resource online.

Perform the following steps to configure a print share service group using the 
Print Share Configuration Wizard.
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To create a print share service group with a PrintSpool resource

1 Click Start > Programs > Symantec > VCS One > Print Share Configuration 
Wizard to start the Print Share Configuration Wizard.

2 Review the information on the Welcome panel and then click Next.

3 On the Policy Master Details panel specify the following information and 
then click Next:

4 On the Service Group Options panel, select from the following options and 
then click Next:

Policy Master: IP 
Address

Displays the virtual IP address of the Policy Master (PM).
This is the IP address that was specified during VCS One client 
configuration.

Policy Master: 
Port

Displays the port number used by the PM.
The default port is 14151.

Use Logged-on 
user credentials

Check the Use Logged-on user credentials check box if you 
want the wizard to use the logged-on user account context to 
perform the configuration tasks.
This option is checked by default.
The logged-on user account must have the privileges to access 
all the systems selected for the wizard operations.
The logged-on user account must be configured in the VCS 
One cluster and must have privileges to add and modify 
service groups in the VCS One cluster.
If you do not want to use the logged-on user account context, 
clear this check box.

User Name Type a VCS One user name.
The user account must be configured in the VCS One cluster 
and must have privileges to add and modify service groups in 
the VCS One cluster.
This option is disabled if you check the Use logged-on user 
credentials check box.

Password Type the password for the specified user.

Domain Type From the drop-down list select the type of domain to which 
the user belongs.

Domain Name Type the domain name of the specified user.
For example, if a user Tom is part of the domain mydomain, 
type mydomain if Tom@mydomain is configured on the Policy 
Master.
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■ Click Create failover service group if you wish to configure a failover 
service group.

■ Click Create start/stop service group if you wish to configure a start/
stop service group on the local system.

5 On the OUValue Selection panel specify the OUValue that you want to attach 
the service group with and then click Next.

You can either type the OUValue path or select the OUValue from the VCS 
One Organization Tree.

Type the OUValue path in the format /OUName=OUValue. In case of nested 
OU objects, the format is OUName=OUValue1/OUName=OUValue2.

For example, /VCSOneCO=Retail or /VCSOneCO=Marketing/
B2B=Dept.

You cannot attach service groups with OUName; you must specify a 
OUValue.

If you are configuring a start/stop service group, proceed to step 8.

6 For a failover service group, on the System Selection panel select the 
systems for the print share service group and then click Next.

This step is not applicable if you are configuring a start/stop service group.

The Available Systems box displays the systems in the VCS One cluster that 
the specified user account has access to.

Select the systems from the Available Systems box and click the right arrow 
to move the systems to the Selected Systems box. To remove a system from 
the Selected Systems box, click the system in the Selected Systems box and 
click the left arrow.

If you are configuring the service group on a virtual machine that has 
virtual machine high availability (VMHA) policy enabled, the wizard does 
not allow you to add any other system to the service group. You cannot add 
more than one vframe to a service group if a vframe is enabled for VMHA.

See “About virtual machine high availability” on page 68 for more details 
about VMHA.

To change a system’s failover priority in the service group, click the system 
from the Selected Systems box and then click the up and down arrows. 
System priority defines the order in which service groups are failed over to 
systems. The system at the top of the list has the highest priority while the 
system at the bottom of the list has the lowest priority.

To search for specific systems, click Edit Filter, select the desired filter 
criteria and then click Update Filter. The Available Systems box then 
displays the systems as per your chosen search criteria.
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Table A-2 lists the various filter options that you can use to search systems.

Table A-4 System selection panel: Filter criteria

Filter Criteria Usage and Example

Organization 
Unit

Search systems based on the VCS One OU objects that they 
belong to. You can either type the OU object details or choose 
the desired OU object from the Organization Tree displayed.

Example: To list the systems belonging to the OUName 
VCSOneCO and OUValue Retail, either select Retail, or type
/VCSOneCO=Retail.

Attributes Search systems based on the number of CPUs or the amount 
of random access memory (RAM) available, or a combination 
of both.
Example: To list systems with 4 units of CPU and having 4 GB 
of RAM, type 2 and 4 in the CPU and Memory fields 
respectively.

Expressions Search systems based on the VCS One Extended Attributes 
(EA) or OU expressions, or a combination of both.
Specify the details in the following format:
EA Expression: EA=’EA value’
OU Expression: Type /OUName=OUValue
For EA Expressions, specify the EA value in single quotation 
marks.

Example: To list systems administered (EA=Admin) by Tom 
(EA value=Tom) and that belong to the OUValue Retail, 
specify the details as follows:
EA Expression: Admin=‘Tom’
OU Expression: /VCSOneCO=Retail

You can also use wild cards in the search. For example, 
EA Expression: *Marketing
OU Expressions: /Product=*/Department=Sales
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7 For a failover service group, on the Network Configuration panel, specify the 
network details and the virtual server name for the print share server and 
then click Next.

This step is not applicable if you are configuring a start/stop service group.

Extended 
Attributes

Search systems based on the VCS One Extended Attributes. 
Select an EA from the Name box, then type or select an 
appropriate EA value in the Value box, and then click Add.
Use the boolean AND or OR buttons to combine multiple 
Extended Attributes and achieve the desired filter criteria.

Example: To list systems administered (EA=Admin) by Tom 
(EA value=Tom) and having operating system (EA=OS) as 
Windows Server 2008 (EA value=Win2008), do the following:

■ Select Admin and Tom in the Name and Value box 
respectively, and then click Add.

■ Click AND.

■ Select OS and Win2008 in the Name and Value box 
respectively, and then click Add.
Your search filter should appear as follows:
Admin=‘Tom’ AND OS=‘Win2008’

Keyword Search systems based on keywords. You can use * and % as 
wildcard characters to filter systems.

Example: To list sytems whose names start with the word 
Win, type Win* or Win%. To list systems whose names 
contain the word Win, type *Win* or %Win%.
The keywords are not case sensitive. *win and *WIN will fetch 
the same results.
Do not use the wildcard characters in between keywords. 
*SystemName* or %SystemName% is a valid input. 
System*Name or System%Name is an invalid input.

Virtual Server Name Type a unique virtual server name by which the print 
share server will be known to clients.
The virtual name must not exceed 15 characters.

Virtual IP Address Type a unique virtual IP address for the print share 
server.

Subnet Mask Type the subnet to which the virtual IP belongs.
This field displays the subnet of the local system by 
default.

Table A-4 System selection panel: Filter criteria

Filter Criteria Usage and Example
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Adapter Display Name Select a public network adapter name for each system.
To view the adapters associated with a system, select 
the Adapter Display Name field and click the arrow to 
expand the drop-down list. This list displays all the 
TCP/IP enabled adapters on the system.

Advanced Settings Click Advanced Settings and specify additional details 
for Active Directory (AD) and DNS updates. These 
settings apply to the Lanman resource in the service 
group.
On the Advanced Settings dialog box, set the following 
options as desired:

■ Check Active Diretory Update Required check box to 
enable the Lanman resource to update the Active 
Directory with the virtual server name.

■ In the Organizational Unit field, specify the 
distinguished name of the Windows AD 
Organizational Unit (OU). To browse for an OU, click 
Browse and search for the OU using the Windows Find 
Organization Units dialog box.
By default, the Lanman resource adds the virtual 
server details to the default container "Computers."

■ Check the AD Update Critical For Online check box to 
set the Lanman attribute ADCriticalForOnline to 1. 
The Lanman resource will fault if the AD update fails.

■ Check the DNS Update Required check box to set the 
Lanman attribute DNSUpdateRequired to 1. The 
Lanman agent updates the DNS with the specified 
virtual server details.
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If you are configuring a failover service group, proceed to step 9.

8 For a start/stop service group, on the Network Configuration panel, choose 
the desired option and then click Next.

This step is not applicable if you are configuring a failover service group.

Do one of the following:

■ To configure print shares in the virtual server context, click Use virtual 
IP context. Client can access the print share server using the virtual 
server name, \\virtualservername\printsharename.

Specify the following details:

■ Check the DNS Update Critical For Online check box to 
set the Lanman attribute DNSCriticalForOnline to 1. 
The Lanman resource faults if the agent fails to 
update the DNS.

■ Check the Ignore Default check box to set the Lanman 
attribute DNSOptions to IgnoreDefault. The Lanman 
agent will update only the DNS servers specified in 
the AdditionalDNSServers attribute.

■ Check the Purge Duplicate check box to set the 
Lanman attribute DNSOptions to PurgeDuplicate. The 
Lanman agent will remove duplicate entries from the 
DNS servers.

■ Click OK.

Note: The Lanman agent uses the VCS One Remoting 
Service user accout context to perform AD and DNS 
updates. This accout must have privileges to create and 
update computer accounts on the specified container.

Virtual Server Name Type a unique virtual server name by which the print 
share server will be known to clients.

The virtual name must not exceed 15 characters.

Virtual IP Address Type a unique virtual IP address for the print share 
server.

Subnet Mask Type the subnet to which the virtual IP belongs. This field 
displays the subnet of the local system by default.

Adapter Display 
Name

Select a public network adapter from the drop-down list. 
This list displays all the TCP/IP enabled adapters on the 
system.
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■ To configure the print shares in the local system context, click Use 
local system name context and then select an IP address from the list.

Advanced Settings Click Advanced Settings and specify additional details 
for Active Directory (AD) and DNS updates. These 
settings apply to the Lanman resource in the service 
group.

On the Advanced Settings dialog box, set the following 
options as desired:

■ Check Active Diretory Update Required check box to 
enable the Lanman resource to update the Active 
Directory with the virtual server name.

■ In the Organizational Unit field, specify the 
distinguished name of the Windows AD 
Organizational Unit (OU). To browse for an OU, click 
Browse and search for the OU using the Windows 
Find Organization Units dialog box. By default, the 
Lanman resource adds the virtual server details to 
the default container "Computers."

■ Check the AD Update Critical For Online check box 
to set the Lanman attribute ADCriticalForOnline to 
1. The Lanman resource will fault if the AD update 
fails.

■ Check the DNS Update Required check box to set the 
Lanman attribute DNSUpdateRequired to 1. The 
Lanman agent updates the DNS with the specified 
virtual server details. 

■ Check the DNS Update Critical For Online check box 
to set the Lanman attribute DNSCriticalForOnline to 
1. The Lanman resource faults if the agent fails to 
update the DNS.

■ Check the Ignore Default check box to set the 
Lanman attribute DNSOptions to IgnoreDefault. 
The Lanman agent will update only the DNS servers 
specified in the AdditionalDNSServers attribute.

■ Check the Purge Duplicate check box to set the 
Lanman attribute DNSOptions to PurgeDuplicate. 
The Lanman agent will remove duplicate entries 
from the DNS servers.

■ Click OK.

Note: The Lanman agent uses the VCS One Remoting 
Service user accout context to perform AD and DNS 
updates. This accout must have privileges to create and 
update computer accounts on the specified container.
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Clients can access the print shares using the local system name, 
\\localsystemname\printsharename.

9 On the Data Path Configuration panel, specify the spool and registry 
replication directories and then click Next.

This step is not applicable if you are configuring a start/stop service group 
using the local system name context.

Specify the spool and registry replication data path as follows:

Spooler Directory Type the path or click ... (ellipsis button) to browse for the 
directory. All print commands are spooled at this location.

Replication 
Directory

Type the path or click ... (ellipsis button) to browse for the 
directory. All changes related to the printer registry keys 
are logged at this location.
For a failover service group, the selected directories must 
fulfill the following conditions:

■ The selected drive, the mount path, and the file path must 
not be configured in another service group.

■ The directories must reside on shared, non-system drives.
Symantec recommends creating the directories for 
replication and spooling on different mounts.
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10 On the Build Print Server panel, review the service group configuration 
details, edit the service group name and the resource names if required, and 
then click Next.

11 The Build Print Server panel displays the service group configuration 
progress. The wizard starts running the commands to create the service 
group and displays the service group configuration progress. Various 
messages indicate the status of these commands. After all the tasks are 
complete, click Next.

12 Verify that the PrintSpool and Lanman resources are online on the system 
and then proceed to the next step.

The next step involves adding a network printer either to the virtual server 
(Lanman resource) you just created or to the local system (for a start/stop 
service group configured in local system context), and to create a new TCP/
IP port for the printer.

Perform the following steps to add a network printer

1 Use the Windows Add Printer wizard to add the network printer.

You can launch the Windows Add Printer wizard using any of the following 
ways:

Service Group Details Displays the service group name, a list of resources, 
and their attributes details. The wizard assigns 
unique names to the service group and its resources.

You can change the name of the service group and 
the resources (not the attributes), if required.

To edit a name, select the name and either click it or 
press the F2 key. Edit the name and then press the 
Enter key to confirm the changes. To cancel editing a 
name, press the Esc key.

For a failover service group, if you specify shared 
volumes created in an SFW environment, the wizard 
configures the VMDg and MountV resources. If you 
specify shared volumes created in the Windows LDM 
environment, the wizard configures the DiskRes and 
Mount resources for storage.

For a start/stop service group, if you configure the 
service group in the local system name context, the 
wizard configures a IPMonitor resource. If you 
configure the service group in the virtual server 
context, the wizard configures a MountMonitor 
resource.
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■ Return to the Print Share Configuration Wizard and on the Printer 
Selection panel, click Add Printer.

or

■ From Windows Explorer search for the virtual server (Lanman resource 
configured in the service group), explore the virtual server by double-
clicking its name and on the virtual server’s Printers folder, double-
click Add Printer.

If you have configured a start/stop service group using the local system 
name context, add the network printer to the local system. Click Start > 
Settings > Printers and Faxes, (or Start > Devices and Printers) and 
then click Add a Printer (or Add a Printer) from the File menu.

2 Follow the Windows Add Printer wizard instructions to add the network 
printer.

Note the following points while adding printers:

■ Ensure that you add the printer to the virtual server. For a start/stop 
service group configured in the local system name context, add the 
printer to the local system.

■ On the Add Printer wizard’s Printer Sharing dialog box, choose the Do 
not share this printer option.

■ Repeat the steps for each additional printer to be installed.

3 Return to the Print Share Configuration Wizard and ensure that the network 
printer that you added is displayed in the Available Printers list on the 
Printer Selection panel. Then proceed to the next step.

The next step involves configuring a PrintShare resource in the service 
group and bringing it online.

Perform the following steps to configure a PrintShare resource for the 
service group

1 The Available Printers list on the Printer Selection panel displays the 
printers that you added earlier. Choose the printers that you want to add to 
the print share service group and then click Next.

Complete the following details:

Printer Name Click to select the printers and then click the right arrow to 
include the selected printers in the service group.
To remove a selected printers click the left arrow.

Share Name Type a unique share name for the printer. This is the name by 
which it is known to clients.
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2 On the Service Group Summary panel, review the service group 
configuration details, and then click Next.

3 The Commit Configuration panel displays the service group configuration 
progress. The wizard starts running the commands to add the printshare 
resource to the service group. Various messages indicate the status of these 
commands. After all the tasks are complete, click Next.

4 On the Finish panel, check the Bring the service group online check box if 
you want the wizard to bring the service group online after the service group 
is configured, and then click Finish.

The wizard issues a command to bring the service group online on the local 
system. This completes the print share service group creation.

A service group may fail to come online due to various reasons. This does 
not mean that the service group was not configured. In such cases, you must 
probe the resources and then bring the service group online manually from 
the VCS One console.

Service Group Details Displays the service group name, a list of resources, 
and their attributes details. The wizard assigns 
unique names to the service group and its resources.

You can change the name of the service group and 
the resources (not the attributes), if required.

To edit a name, select the name and either click it or 
press the F2 key. Edit the name and then press the 
Enter key to confirm the changes. To cancel editing a 
name, press the Esc key.

For a failover service group, if you specify shared 
volumes created in an SFW environment, the wizard 
configures the VMDg and MountV resources. If you 
specify shared volumes created in the Windows LDM 
environment, the wizard configures the DiskRes and 
Mount resources for storage.

For a start/stop service group, if you configure the 
service group in the local system name context, the 
wizard configures a IPMonitor resource. If you 
configure the service group in the virtual IP context, 
the wizard configures a MountMonitor resource.
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Modifying a print share service group using the wizard
You can modify print share service groups using the Print Share Configuration 
Wizard. You can modify both start/stop and failover service groups using the 
wizard.

Note: You cannot convert a failover service group to a start/stop service group 
and vice versa.

Note the following prerequisites before you modify a print share service group:

■ If the print share service group is online or partially online, you must run 
the wizard from a system on which the service group is online or partially 
online. You can then use the wizard to add resources and remove offline 
resources from the service group. You cannot change attributes of resources 
that are online. To change the resource attributes, you must take the service 
group offline. 

■ For a failover service group, if you are running the wizard to remove a 
system from the service group’s system list, do not run the wizard on the 
system being removed.

■ For a failover service group, if you are running the wizard to add a system to 
the service group’s system list, ensure that the shared drives that contain 
the print shares are configured on the system being added.

■ If you are modifying the service group to remove a PrintShare resource, 
make sure you take the resource offline before deleting it.

■ You cannot convert a failover service group into a start/stop service group 
and vice versa. If you wish to change the service group type, delete the 
existing service group and recreate it using the wizard.

Verify the prerequisites for each type of service group before you proceed.

Perform these steps to modify a print share service group using the Print Share 
Configuration Wizard.

To modify a print share service group

1 Click Start > Programs > Symantec > VCS One > Print Share Configuration 
Wizard to start the Print Share Configuration Wizard.

2 Review the information on the Welcome panel and click Next.
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3 On the Policy Master Details panel specify the following information and 
then click Next:

4 On the Service Group Options panel, click Modify service group, specify the 
service group, and then click Next.

You can either type the service group name or select a service group from 
the list.

The list displays only those service groups that are either created or 
modified using the wizard. If the service group that you created manually 
does not appear in the list, you can type the service group name.

5 Complete the subsequent wizard steps.

See “Configuring a print share service group using the wizard” on page 969.

Policy Master: IP 
Address

Displays the virtual IP address of the Policy Master (PM).
This is the IP address that was specified during VCS One client 
configuration.

Policy Master: 
Port

Displays the port number used by the PM.
The default port is 14151.

Use Logged-on 
user credentials

Check the Use Logged-on user credentials check box if you 
want the wizard to use the logged-on user account context to 
perform the desired tasks.
This option is checked by default.
The logged-on user account must have the privileges to access 
all the systems selected for the wizard operations.
The logged-on user account must be configured in the VCS 
One cluster and must have privileges to add and modify 
service groups in the VCS One cluster.
If you do not want to use the logged-on user account context, 
clear this check box.

User Name Type a VCS One user name.
The user account must be configured in the VCS One cluster 
and must have privileges to add and modify service groups in 
the VCS One cluster.
This option is disabled if you check the Use logged-on user 
credentials check box.

Password Type the password for the specified user.

Domain Type Select the type of the domain to which the user belongs.

Domain Name Type the domain name of the specified user.
For example, if a user Tom is part of the domain mydomain, 
type mydomain if Tom@mydomain is configured on the Policy 
Master.
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About configuring the MSDTC Server
Microsoft Distributed Transaction Coordinator (MSDTC) service enables you to 
perform distributed transactions. A distributed transaction updates data on 
more than one computer in a network. The MSDTC service ensures that a 
transaction is successfully committed on each computer. A failure to commit on 
a single system aborts the transaction on all systems in the network. If a 
transaction spans across more than one computer in the network, you must 
ensure that the MSDTC service is running on all the computers. Also, all the 
computers must be able to communicate with each other.

MSDTC servers and SQL servers can co-exist on the same cluster systems. If the 
MSDTC Server and the SQL Server are running on the same system, the MSDTC 
client is configured in the default configuration. You do not need to configure 
the MSDTC client on that system. You must configure the MSDTC client on all 
the systems that are not part of the MSDTC Server service group.

To configure high availability for MSDTC, you first configure the MSDTC Server 
service group using the MSDTC Service Group Configuration Wizard and then 
configure the MSDTC client manually.

VCS One provides several ways of configuring a service group, which include the 
service group configuration wizard, VCS One Web console, and the command 
line. The following sections describe the steps involved in configuring an 
MSDTC Server using the service group configuration wizard in the VCS One 
cluster.

Before configuring the MSDTC Server, review the resource type and the 
attribute definitions of the MSDTC agent.

Refer to the Veritas Cluster Server One Bundled Agents Guide.

About MSDTC Server service group types
You can use the MSDTC Server Service Group Configuration Wizard to create 
the following types of service groups:

■ Failover

A failover service group contains multiple systems wherein the MSDTC logs 
and registry information resides on shared drives that are accessible from 
all the systems that are part of the service group. VCS One monitors the 
MSDTC service in the virtual server context. MSDTC clients can access the 
MSDTC Server using the virtual server name. If there is any failure on the 
system where the service group is online, VCS One brings the service group 
online on another system defined in the service group’s system list. The 
volumes containing the MSDTC logs and the registry information are 
mounted on that system and the MSDTC service is started in the virtual 
server context, thus making the MSDTC service highly available.
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■ Start/Stop

A start/stop service group is configured on a single system wherein the 
MSDTC logs and registry information reside on the local system disks. VCS 
One monitors the MSDTC service and the underlying storage and network 
components used by MSDTC on the system where the service group is 
configured. Start/stop service groups do not require that the application 
data reside on shared drives. You can configure start/stop service groups to 
run the MSDTC service in the local system context or the virtual server 
context. Depending on the configuration, MSDTC clients can access the 
MSDTC Server using the local system name or the virtual server name. As 
start/stop service groups do not contain multiple systems, you cannot fail 
over a start/stop service group. VCS One monitors the service group, brings 
it online and takes it offline on the system where the service group is 
configured. If there is any failure, VCS One faults the service group, the 
configured MSDTC service becomes unavailable and administrative 
intervention is required.

Before you configure the MSDTC Server service group
Note the following prerequisites before you configure the MSDTC service group:

■ The VCS One client must be configured on all the systems that are going to 
be part of the service group.

■ The MSDTC Server must be installed on all the systems that are going to be 
part of the service group.

■ All the systems that are going to be part of the service group must be 
running the same operating system.

■ The Distributed Transaction Coordinator (DTC) service must be stopped on 
all the systems that are going to be part of the service group.

■ The logged-on user must have local Administrator privileges on all the 
systems that are going to be part of the service group.

■ The logged-on user must have write permissions on the registry hive 
HKEY_CLASSES_ROOT on all the systems that are going to be part of the 
service group.

■ The VCS One Remoting and Client Daemon services must be running on all 
the systems that are going to be part of the service group.

■ The Remote Registry service must be running on all the systems that are 
going to be part of the service group.

■ For a failover service group, create a disk group (cluster disk group in case of 
SFW) on shared disks and then create the following volumes for MSDTC:
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■ MSDTC_LOG for storing the MSDTC log files.

■ MSDTC_REGREP for storing the registry keys that must be replicated 
among cluster systems for the MSDTC service group. Symantec 
recommends that you create a 100 MB volume for this purpose.

■ For a failover service group, the disk groups and volumes that you specify 
for the MSDTC service group must not be configured in another service 
group in the VCS One cluster.

■ If your storage configuration uses folder mounts, verify the following:

■ The configured path exists.

■ The directory is empty.

■ The volume on which the directory resides is NTFS-formatted.

■ The directory is not a system directory.

■ This is applicable if you are using Windows Logical Disk Management (LDM) 
to manage your storage.

For a failover service group, mount the drives for storing the MSDTC log 
files and registry replication information once on all the systems that are 
going to be part of the service group, so as to ensure that the disks are 
visible from all those systems. Ensure that the same drive letter is available 
on all the systems.

However, before configuring the MSDTC service group, ensure that you 
mount the drives on the system where you run the wizard.

See “About configuring shared storage” on page 941.

■ If you have configured a firewall, ensure that you add the required ports to 
the firewall exceptions list.

Refer to the Veritas Cluster Server One Installation Guide for the list of ports 
used by VCS One.

Refer to the MSDTC documentation for the list of ports used by MSDTC 
Server.

■ Make a note of the following details; the wizard prompts for this 
information:

■ A user account configured on the Policy Master. This user account 
must have read access to the VCS One OU and the privileges to add and 
modify service groups.

The user account must have the privileges to attach service groups to 
the desired OUValue.

If you choose to use the logged-on user, ensure that the logged-on user 
account has these privileges.

■ A unique virtual IP address to be assigned to the MSDTC Server.

The virtual IP address is optional for a start/stop service group.
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■ A unique virtual server name to be assigned to the MSDTC Server.

This is the name that is used by MSDTC clients to connect to the 
MSDTC Server. The DTC service runs under this name. The virtual 
name must not exceed 15 characters.

The virtual server name is optional for a start/stop service group.

Configuring an MSDTC Server service group
To configure high availability for MSDTC Server, you first use the MSDTC 
Service Group Configuration Wizard to create a service group for the MSDTC 
Server and then configure the MSDTC client manually.

The following steps describe how to configure an MSDTC Server service group 
using the MSDTC Service Group Configuration Wizard.

The MSDTC Service Group Configuration Wizard enables you to create a MSDTC 
Server service group, define the attributes for its resources, and modify the 
MSDTC Server service group on all the systems within the cluster. Also, if you 
plan to have multiple systems as a part of the MSDTC service group 
configuration, you can specify the failover priority for the systems while 
configuring the service group.

Additionally, the wizard also enables you to configure the service group on a 
single system wherein VCS One can bring the service group online, take it 
offline, and monitor the state of the MSDTC service on that system.

To configure an MSDTC Server service group

1 Click Start > Programs > Symantec > VCS One > MSDTC Configuration 
Wizard to start the MSDTC Service Group Configuration Wizard.

2 Review the information on the Welcome panel and then click Next.

3 On the Policy Master Details panel specify the following information and 
then click Next:

Policy Master: IP 
Address

Displays the virtual IP address of the Policy Master (PM).
This is the IP address that was specified during VCS One client 
configuration.

Policy Master: 
Port

Displays the port number used by the PM.
The default port is 14151.
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4 On the Service Group Options panel, select from the following options and 
then click Next:

■ Click Create failover service group if you wish to configure a failover 
service group.

■ Click Create start/stop service group if you wish to configure a start/
stop service group on the local system.

5 On the OUValue Selection panel specify the OUValue that you want to attach 
the service group with and then click Next.

You can either type the OUValue path or select the OUValue from the VCS 
One Organization Tree.

Type the OUValue path in the format /OUName=OUValue. In case of nested 
OU objects, the format is OUName=OUValue1/OUName=OUValue2.

For example, /VCSOneCO=Retail or /VCSOneCO=Marketing/
B2B=Dept.

You cannot attach service groups with OUName; you must specify a 
OUValue.

Use Logged-on 
user credentials

Check the Use Logged-on user credentials check box if you 
want the wizard to use the logged-on user account context to 
perform the configuration tasks.
This option is checked by default.
The logged-on user account must have the privileges to access 
all the systems selected for the wizard operations.
The logged-on user account must be configured in the VCS 
One cluster and must have privileges to add and modify 
service groups in the VCS One cluster.
If you do not want to use the logged-on user account context, 
clear this check box.

User Name Type a VCS One user name.
The user account must be configured in the VCS One cluster 
and must have privileges to add and modify service groups in 
the VCS One cluster.
This option is disabled if you check the Use logged-on user 
credentials check box.

Password Type the password for the specified user.

Domain Type From the drop-down list select the type of domain to which 
the user belongs.

Domain Name Type the domain name of the specified user.
For example, if a user Tom is part of the domain mydomain, 
type mydomain if Tom@mydomain is configured on the Policy 
Master.
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If you are configuring a start/stop service group, proceed to step 8.

6 For a failover service group, on the System Selection panel select the 
systems for the MSDTC service group and then click Next.

This step is not applicable if you are configuring a start/stop service group.

The Available Systems box displays the systems in the VCS One cluster that 
the specified user account has access to.

Select the systems from the Available Systems box and click the right arrow 
to move the systems to the Selected Systems box. To remove a system from 
the Selected Systems box, click the system in the Selected Systems box and 
click the left arrow.

If you are configuring the service group on a virtual machine that has 
virtual machine high availability (VMHA) policy enabled, the wizard does 
not allow you to add any other system to the service group. You cannot add 
more than one vframe to a service group if a vframe is enabled for VMHA.

See “About virtual machine high availability” on page 68 for more details 
about VMHA.

To change a system’s failover priority in the service group, click the system 
from the Selected Systems box and then click the up and down arrows. 
System priority defines the order in which service groups are failed over to 
systems. The system at the top of the list has the highest priority while the 
system at the bottom of the list has the lowest priority.

To search for specific systems, click Edit Filter, select the desired filter 
criteria and then click Update Filter. The Available Systems box then 
displays the systems as per your chosen search criteria.

Table A-2 lists the various filter options that you can use to search systems.

Table A-5 System selection panel: Filter criteria

Filter Criteria Usage and Example

Organization 
Unit

Search systems based on the VCS One OU objects that they 
belong to. You can either type the OU object details or choose 
the desired OU object from the Organization Tree displayed.

Example: To list the systems belonging to the OUName 
VCSOneCO and OUValue Retail, either select Retail, or type
/VCSOneCO=Retail.

Attributes Search systems based on the number of CPUs or the amount 
of random access memory (RAM) available, or a combination 
of both.
Example: To list systems with 4 units of CPU and having 4 GB 
of RAM, type 2 and 4 in the CPU and Memory fields 
respectively.
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Expressions Search systems based on the VCS One Extended Attributes 
(EA) or OU expressions, or a combination of both.
Specify the details in the following format:
EA Expression: EA=’EA value’
OU Expression: Type /OUName=OUValue
For EA Expressions, specify the EA value in single quotes.

Example: To list systems administered (EA=Admin) by Tom 
(EA value=Tom) and that belong to the OUValue Retail, 
specify the details as follows:
EA Expression: Admin=’Tom’
OU Expression: /VCSOneCO=Retail

You can also use wild cards in the search. For example, 
EA Expression: *Marketing
OU Expressions: /Product=*/Department=Sales

Extended 
Attributes

Search systems based on the VCS One Extended Attributes. 
Select an EA from the Name box, then type or select an 
appropriate EA value in the Value box, and then click Add.
Use the boolean AND or OR buttons to combine multiple 
Extended Attributes and achieve the desired filter criteria.

Example: To list systems administered (EA=Admin) by Tom 
(EA value=Tom) and having operating system (EA=OS) as 
Windows Server 2008 (EA value=Win2008), do the following:

■ Select Admin and Tom in the Name and Value box 
respectively, and then click Add.

■ Click AND.

■ Select OS and Win2008 in the Name and Value box 
respectively, and then click Add.
Your search filter should appear as follows:
Admin=’Tom’ AND OS=’Win2008’

Keyword Search systems based on keywords. You can use * and % as 
wildcard characters to filter systems.

Example: To list sytems whose names start with the word 
Win, type Win* or Win%. To list systems whose names 
contain the word Win, type *Win* or %Win%.
The keywords are not case sensitive. *win and *WIN will fetch 
the same results.
Do not use the wildcard characters in between keywords. 
*SystemName* or %SystemName% is a valid input. 
System*Name or System%Name is an invalid input.

Table A-5 System selection panel: Filter criteria

Filter Criteria Usage and Example
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7 For a failover service group, on the Network Configuration panel, specify the 
network details and the virtual server name for the MSDTC Server and then 
click Next.

This step is not applicable if you are configuring a start/stop service group.

Virtual Server Name Type a unique virtual server name by which the 
MSDTC Server will be known to clients. The DTC 
service runs under this name.
The virtual name must not exceed 15 characters.

Virtual IP Address Type a unique virtual IP address for the MSDTC 
Server.

Subnet Mask Type the subnet to which the virtual IP belongs.
This field displays the subnet of the local system by 
default.

Adapter Display Name Select a public network adapter name for each system.
To view the adapters associated with a system, select 
the Adapter Display Name field and click the arrow to 
expand the drop-down list. This list displays all the 
TCP/IP enabled adapters on the system.

Advanced Settings Click Advanced Settings and specify additional details 
for Active Directory (AD) and DNS updates. These 
settings apply to the Lanman resource in the service 
group.
On the Advanced Settings dialog box, set the following 
options as desired:

■ Check Active Diretory Update Required check box to 
enable the Lanman resource to update the Active 
Directory with the virtual server name.

■ In the Organizational Unit field, specify the 
distinguished name of the Windows AD 
Organizational Unit (OU). To browse for an OU, click 
Browse and search for the OU using the Windows Find 
Organization Units dialog box.
By default, the Lanman resource adds the virtual 
server details to the default container "Computers."

■ Check the AD Update Critical For Online check box to 
set the Lanman attribute ADCriticalForOnline to 1. 
The Lanman resource will fault if the AD update fails.

■ Check the DNS Update Required check box to set the 
Lanman attribute DNSUpdateRequired to 1. The 
Lanman agent updates the DNS with the specified 
virtual server details.
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If you are configuring a failover service group, proceed to step 9.

8 For a start/stop service group, on the Network Configuration panel, choose 
the desired option and then click Next.

This step is not applicable if you are configuring a failover service group.

Do one of the following:

■ To configure the MSDTC Server in the virtual server context, click Use 
virtual IP context. Clients can access the MSDTC Server using the 
virtual server name.

Specify the following details:

■ Check the DNS Update Critical For Online check box to 
set the Lanman attribute DNSCriticalForOnline to 1. 
The Lanman resource faults if the agent fails to 
update the DNS.

■ Check the Ignore Default check box to set the Lanman 
attribute DNSOptions to IgnoreDefault. The Lanman 
agent will update only the DNS servers specified in 
the AdditionalDNSServers attribute.

■ Check the Purge Duplicate check box to set the 
Lanman attribute DNSOptions to PurgeDuplicate. The 
Lanman agent will remove duplicate entries from the 
DNS servers.

■ Click OK.

Note: The Lanman agent uses the VCS One Remoting 
Service user accout context to perform AD and DNS 
updates. This accout must have privileges to create and 
update computer accounts on the specified container.

Virtual Server Name Type a unique virtual server name by which the MSDTC 
Server will be known to clients. The DTC service runs 
under this name.

The virtual name must not exceed 15 characters.

Virtual IP Address Type a unique virtual IP address for the MSDTC Server.

Subnet Mask Type the subnet to which the virtual IP belongs. This field 
displays the subnet of the local system by default.

Adapter Display 
Name

Select a public network adapter from the drop-down list. 
This list displays all the TCP/IP enabled adapters on the 
system.
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Advanced Settings Click Advanced Settings and specify additional details 
for Active Directory (AD) and DNS updates. These 
settings apply to the Lanman resource in the service 
group.

On the Advanced Settings dialog box, set the following 
options as desired:

■ Check Active Diretory Update Required check box to 
enable the Lanman resource to update the Active 
Directory with the virtual server name.

■ In the Organizational Unit field, specify the 
distinguished name of the Windows AD 
Organizational Unit (OU). To browse for an OU, click 
Browse and search for the OU using the Windows 
Find Organization Units dialog box. By default, the 
Lanman resource adds the virtual server details to 
the default container "Computers."

■ Check the AD Update Critical For Online check box 
to set the Lanman attribute ADCriticalForOnline to 
1. The Lanman resource will fault if the AD update 
fails.

■ Check the DNS Update Required check box to set the 
Lanman attribute DNSUpdateRequired to 1. The 
Lanman agent updates the DNS with the specified 
virtual server details. 

■ Check the DNS Update Critical For Online check box 
to set the Lanman attribute DNSCriticalForOnline to 
1. The Lanman resource faults if the agent fails to 
update the DNS.

■ Check the Ignore Default check box to set the 
Lanman attribute DNSOptions to IgnoreDefault. 
The Lanman agent will update only the DNS servers 
specified in the AdditionalDNSServers attribute.

■ Check the Purge Duplicate check box to set the 
Lanman attribute DNSOptions to PurgeDuplicate. 
The Lanman agent will remove duplicate entries 
from the DNS servers.

■ Click OK.

Note: The Lanman agent uses the VCS One Remoting 
Service user accout context to perform AD and DNS 
updates. This accout must have privileges to create and 
update computer accounts on the specified container.
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■ To configure the MSDTC Server in the local system context, click Use 
local system name context and then select the IP address. The wizard 
displays the IP address of the local system.

Clients can access the MSDTC Server using the local system name.

9 On the Specify Data Path panel, specify the location for storing the MSDTC 
log and registry replication information and then click Next.

If the directory does not exist, the wizard creates it.

Specify the log and the registry replication path as follows:

MSDTC Log 
Location

Type the path or click Browse to select a directory.

Registry 
Replication 
Location

This option is applicable only if you are configuring a failover 
service group.

Type the path or click Browse to select a directory. All changes 
related to the MSDTC registry keys will be logged at this location.

For a failover service group, the selected directories must fulfill the 
following conditions:

■ The selected drive, the mount path, and the file path must not 
be configured in another service group.

■ The directories must reside on shared, non-system drives.

Symantec recommends creating the directories for replication and 
logs on different mounts.
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10 On the Service Group Summary panel, review the service group 
configuration details, edit the service group name and the resource names if 
required, and then click Next.

11 The wizard starts running the commands to create the service group and 
displays the service group configuration progress. Various messages 
indicate the status of these commands. After all the tasks are complete, click 
Next.

12 On the Finish panel, check the Bring the service group online check box if 
you want the wizard to bring the service group online after the service group 
is configured, and then click Finish.

The wizard issues a command to bring the service group online on the local 
system. A service group may fail to come online due to various reasons. This 
does not mean that the service group was not configured. In such cases, you 
must probe the resources and then bring the service group online manually 
from the VCS One console.

This completes the MSDTC Server service group creation. You must now 
configure the MSDTC client.

See “About configuring the MSDTC clients” on page 995.

Service Group Details Displays the service group name, a list of resources, 
and their attributes details. The wizard assigns 
unique names to the service group and its resources.

You can change the name of the service group and 
the resources (not the attributes), if required.

To edit a name, select the name and either click it or 
press the F2 key. Edit the name and then press the 
Enter key to confirm the changes. To cancel editing a 
name, press the Esc key.

For a failover service group, if you specify shared 
volumes created in an SFW environment, the wizard 
configures the VMDg and MountV resources. If you 
specify shared volumes created in the Windows LDM 
environment, the wizard configures the DiskRes and 
Mount resources for storage.

For a start/stop service group, the wizard configures 
a MountMonitor resource.
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After configuring MSDTC Server in the VCS One cluster
If you have already configured a SQL Server service group in the VCS One 
cluster, then after configuring the MSDTC service group you must take the SQL 
Server service group offline and bring it online again.

About configuring the MSDTC clients
Configure the MSDTC clients after configuring the service group for the MSDTC 
Server. You must configure the MSDTC client on all systems except the systems 
that are part of the MSDTC Server service group.

Procedures for Windows 2003 and Windows 2008 are different. Follow the 
appropriate procedure depending on the operating system.

Configuring MSDTC client on Windows 2003 systems
Complete the MSDTC client and security configuration on Windows 2003 
systems as described below.

To configure an MSDTC client on Windows 2003 systems

1 Ensure that the MSDTC Server service group is online.

2 Launch the Windows Component Services Administrative tool.

Click Start > Programs > Administrative Tools > Component Services

or

Click Start > Run, type dcomcnfg and click OK.

3 In the console tree of the Component Services administrative tool, expand 
Component Services > Computers, right-click My Computer and then click 
Properties.

4 On the MSDTC tab, perform the following steps:

■ Clear the Use local coordinator check box.

■ In the Remote Host field, specify the virtual server name that you 
specified while creating the MSDTC Server service group.

If you are unsure of the exact name, click Select to search from a list of 
all computers on the network and select the MSDTC virtual server 
name from the list.

■ Click Security Configuration.

■ On the Security Configuration dialog box, check Network DTC Access, 
Allow Remote Clients, Allow Remote Administration, Allow Inbound 
and Allow Outbound check boxes, and then click OK.

■ Click Apply and then click OK.
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Configuring MSDTC client on Windows 2008 systems
Complete the MSDTC client and security configuration on Windows 2008 
systems as described below.

To configure an MSDTC client on Windows 2008

1 Ensure that the MSDTC Server service group is online.

2 Launch the Windows Component Services Administrative tool.

Click Start > Programs > Administrative Tools > Component Services

or

Click Start > Run, type dcomcnfg and click OK.

3 In the console tree of the Component Services administrative tool, expand 
Component Services > Computers, right-click My Computer and then click 
Properties.

4 On the MSDTC tab, perform the following steps:

■ Clear the Use local coordinator check box.

■ In the Remote Host field, specify the virtual server name that you 
specified while creating the MSDTC Server service group.

If you are unsure of the exact name, click Select to search from a list of 
all computers on the network and select the MSDTC virtual computer 
name from the list.

■ Click Apply and then click OK.

Modifying the MSDTC Server service group
Perform these steps to modify an MSDTC Server service group using the MSDTC 
Service Group Configuration Wizard.

Note the following prerequisites before you proceed:

■ If the MSDTC Server service group is online or partially online, you must 
run the wizard from a system on which the service group is online or 
partially online. You can then use the wizard to add resources and remove 
offline resources from the service group. You cannot change attributes of 
resources that are online.

■ To change the resource attributes, you must take the service group offline. 
However, the storage resources (MountV-VMDg, Mount-DiskRes, 
MountMonitor) for the service group must be online on the system where 
you run the wizard.

■ For a failover service group, if you are running the wizard to remove a 
system from the service group’s system list, do not run the wizard on the 
system being removed.
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■ For a failover service group, if you are running the wizard to add a system to 
the service group’s system list, ensure that the shared drives that contain 
the MSDTC data are mounted on the system that is being added.

■ If you are modifying the service group to remove a resource, make sure you 
take the resource offline before deleting it.

To modify an MSDTC Server service group

1 Click Start > Programs > Symantec > VCS One > MSDTC Configuration 
Wizard to start the MSDTC Service Group Configuration Wizard.

2 Review the information on the Welcome panel and click Next.

3 On the Policy Master Details panel specify the following information and 
then click Next:

Policy Master: IP 
Address

Displays the virtual IP address of the Policy Master (PM).
This is the IP address that was specified during VCS One client 
configuration.

Policy Master: 
Port

Displays the port number used by the PM.
The default port is 14151.

Use Logged-on 
user credentials

Check the Use Logged-on user credentials check box if you 
want the wizard to use the logged-on user account context to 
perform the desired tasks.
This option is checked by default.
The logged-on user account must have the privileges to access 
all the systems selected for the wizard operations.
The logged-on user account must be configured in the VCS 
One cluster and must have privileges to add and modify 
service groups in the VCS One cluster.
If you do not want to use the logged-on user account context, 
clear this check box.

User Name Type a VCS One user name.
The user account must be configured in the VCS One cluster 
and must have privileges to add and modify service groups in 
the VCS One cluster.
This option is disabled if you check the Use logged-on user 
credentials check box.

Password Type the password for the specified user.

Domain Type Select the type of the domain to which the user belongs.
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4 On the Service Group Options panel, click Modify service group, specify the 
service group, and then click Next.

You can either type the service group name or select a service group from 
the list.

The list displays only those service groups that are either created or 
modified using the wizard. If the service group that you created manually 
does not appear in the list, you can type the service group name.

5 Complete the subsequent wizard steps.

See “Configuring an MSDTC Server service group” on page 986.

Domain Name Type the domain name of the specified user.
For example, if a user Tom is part of the domain mydomain, 
type mydomain if Tom@mydomain is configured on the Policy 
Master.
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About the VCS One Application Manager utility
VCS One starts the MSDTC service in the cluster under the context of the virtual 
server. As the Windows MMC snap-in is not aware of such a configuration, it is 
not possible to view the transactions on a DTC virtual server from a system 
where the MSDTC resource is online.

VCS One provides a virtual MMC viewer, the VCS One Application Manager 
utility, that enables you to view the distributed transaction statistics on the DTC 
virtual server from a system where the MSDTC resource is online.

Viewing DTC transaction information
In cases where a communication line fails or a distributed transaction 
application leaves unresolved transactions, you might want to view transaction 
lists and statistics, control which transactions are displayed, set transaction 
time-out periods, and control how often transactions are updated. The following 
steps describe how to view the DTC transactions information.

Prerequisites for viewing DTC transaction information are as follows:

■ An MSDTC service group must be configured and online in the cluster.

■ The MSDTC client must be configured on the systems on which you wish to 
view the transactions.

■ The MSDTC service group must be online on the system where you run the 
VCS One Application Manager utility.

To view transactions from a system where MSDTC resource is online

1 Start the VCS One Application Manager utility.

Click Start > Programs > Symantec > VCS One > Application Manager.

2 Select MSDTC from the Select the resource type list.

3 Select the MSDTC resource that is online and then click Manage, or double-
click the MSDTC resource name.

Application Manager launches the Component Services snap-in in the 
virtual server context.

4 In the console tree of the Component Services administrative tool, expand 
Component Services > Computers > My Computer > Distributed 
Transaction Coordinator > Local DTC.

5 Click Transaction List to view all transactions, their status, and their 
identifiers. Right-click a transaction and click View > Properties to list the 
parent transaction and its children.
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6 Click Transaction Statistics to view statistical information about the 
transactions in which a server participated.

You can use transaction statistics to get an overview of DTC performance.

Refer to the Microsoft documentation for further information.

The following steps describe how to view DTC transactions from nodes that are 
not part of the MSDTC Server service group.

To view transactions from any system in the domain

1 Launch the Windows Component Services Administrative tool.

Click Start > Programs > Administrative Tools > Component Services.

or

Click Start > Run, type dcomcnfg and click OK.

2 In the console tree of the Component Services administrative tool, double-
click Component Services, right-click Computers, click New > Computer.

3 In the Add Computer dialog box, specify the virtual server name that you 
specified while creating the MSDTC Server service group. If you are unsure 
of the exact name, click Browse to search from a list of all computers on the 
network and select the virtual computer name from the list.

4 Click OK. The virtual computer entry is added to the Computers container.

5 Expand the newly added virtual computer entry and double-click 
Distributed Transaction Coordinator.

6 Click Transaction List to view all transactions, their status, and their 
identifiers. Right-click a transaction and click View > Properties to list the 
parent transaction and its children.

7 Click Transaction Statistics to view statistical information about the 
transactions in which a server participated.

You can use transaction statistics to get an overview of DTC performance.

Refer to the Microsoft documentation for further information.
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About configuring services
This topic provides information on how to configure services in a VCS One 
cluster. To start, stop, and monitor a service, use the GenericService agent. To 
monitor a service, use the ServiceMonitor agent.

Review the resource types and attribute definitions of the GenericService and 
ServerMonitors agents.

See the Veritas Cluster Server One Bundled Agents Reference Guide.

Note the following prerequisites before you configure services:

■ Change the startup type of the generic service to Manual.

See “Changing the startup type of services” on page 1001.

■ If monitoring the service in a user-context, configure the service to start in 
the context of the specified user account. Make sure the check box for Allow 
service to interact with desktop is unchecked.

See “Configuring a service to start in a user context” on page 1001.

Changing the startup type of services
Perform the following steps to change the startup type of services that you wish 
to configure using the GenericService or the ServiceMonitor agent.

To change a service startup type to Manual

1 Open the Services Control Manager.

2 Right-click the service and click Properties. 

3 On the General tab, select Manual from the Startup Type list.

4 Click OK.

5 Close the Services Control Manager.

Configuring a service to start in a user context
Perform the following steps to configure a service to start in the context of a 
user account.

To configure a service to start in a user-context

1 Open the Services Control Manager.

2 Right-click the service and click Properties.

3 On the LogOn tab, click This Account, and then click Browse to browse 
existing user accounts.
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4 In the Select User dialog box, click the user in whose context you want to run 
the service and then click OK.

5 Enter the password for the selected user.

6 Click OK and close the Services Control Manager.

Configuring a service with the GenericService agent
Perform the following steps to configure a service with the GenericService 
agent.

To configure a service with the GenericService agent

1 In your service group, create a resource of type GenericService.

See “Adding a resource to a service group” on page 426 for instructions.

2 Configure the following required attribute for the resource:

■ ServiceName

The name of the service to be monitored, as displayed by SCM.

If required, configure the following optional attributes for the resource:

■ UserAccount

A valid user account in whose context the service will be monitored. 
Username can be of the form username@domain.com or 
domain.com\username. If you do not specify a value for this attribute, 
then the user account of the service in the SCM is ignored. To monitor 
service under built-in accounts, you must provide explicit values.

For example, on Windows 2003 you can specify the username as 
follows:

User Account=”LocalSystem”, ”Local Service”, or “Network Service”. 
Domain=”NT Authority”.

■ Password

The password for the user account.

■ Domain

The domain name to which the user specified in the UserAccount 
attribute belongs.

3 Configure other resources in the service group, if required.

4 Bring the GenericService resource, and other resources in the service group, 
online.
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Configuring a service with the ServiceMonitor agent
The ServiceMonitor agent monitors a service or starts a script that monitors a 
service.

Note the following prerequisites before you configure the service using the 
ServiceMonitor agent:

■ To use the agent to start a script, copy the script locally on each system in 
the cluster.

■ To use the agent to monitor a service, start the service in the context of the 
LocalSystem account or in the context of the user account specified in the 
configuration.

■ Verify that the user account in whose context the service or script needs to 
be started, exists as a domain user or LocalSystem user.

To configure a service with the ServiceMonitor agent

1 In your service group, create a resource of type ServiceMonitor.

See “Adding a resource to a service group” on page 426.

2 Configure the following required attribute for the resource:

■ ServiceorScriptName

The name of the service to be monitored using the Service Control 
Manager (SCM). When monitoring the service through a user defined 
script, specify the complete path of the script, including any command-
line arguments.

If you are monitoring a service through a user-defined script, specify the 
following attributes values:

■ MonitorService

A flag that defines whether the agent monitors a service using the SCM 
or starts a script to monitor a service. If the flag is set to 1, the agent 
monitors a service specified by the attribute ServiceOrScriptName. If 
the flag is set to 0 the agent starts a script specified by the attribute 
ServiceOrScriptName. Default is 1.

■ MonitorProgTimeout

The maximum wait time, in seconds, for the agent to receive a return 
value from the monitor script. This attribute is ignored if the 
MonitorService flag is set to 1. Default is 30 seconds.

3 Configure other resources in the service group, if required.

4 Bring the ServiceMonitor resource, and other resources in the service group, 
online.
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Configuring processes
Configure a Process resource manually as described below.

Review the resource types and attribute definitions of the Process agent.

See the Veritas Cluster Server One Bundled Agents Reference Guide.

Note the following prerequisites before you configure a process:

■ The executables configured as the start, stop, and monitor programs must 
reside on local drives.

■ When you define the StartProgram, StopProgram, or MonitorProgram 
attributes, enclose the path of the executable file in double quotes. Do not 
enclose arguments in double quotes.

For example, specify the StartProgram attribute in the following format:
StartProgram = "executable_pathname" arguments

To configure process

1 In your service group, create a resource of type Process.

See “Adding a resource to a service group” on page 426.

2 Configure the following required attribute for the resource:

■ StartProgram

The process to be monitored by the agent. You must specify the 
complete path of the executable, its file extension, and command-line 
arguments, if any. If you define the start program as a script to launch 
another program, you must specify the monitor program in the 
configuration file.

If you define the start program as a script (a perl script, or a vbs script), 
the start program should be the program that interprets the script 
(perl.exe, or cscript.exe) and the script itself should be passed as an 
argument.

Configure the following optional attributes, if required:

■ StartupDirectory

The startup directory for the process indicated by the StartProgram 
attribute.

■ MonitorProgram

A program that monitors the process specified as the start program. 
You must specify the complete path of the executable, its file extension, 
and command-line arguments, if any. If you do not specify a value for 
this attribute, VCS One monitors the start program. However, if the 
start program is a script to launch another program, you must specify a 
monitor program.
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■ MonitorProgramTimeout

The maximum wait time, in seconds, for the agent to receive a return 
value from the monitor routine. This attribute is ignored if the monitor 
program is not specified.

3 Configure other resources in the service group, if required.

4 Bring the Process resource, and other resources in the service group, online.
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About configuring infrastructure and support 
agents

This topic describes how to configure the VCS One infrastructure and support 
agents. Before configuring the agents, review the resource types and the 
attribute definitions of these agents.

See the Veritas Cluster Server One Bundled Agents Reference Guide.

Configure the following agents depending on your requirement:

■ To configure registry replication, use the Registry Replication (RegRep) 
agent.

See “Configuring registry replication” on page 1007.

■ To configure a dummy resource to mirror the state of another resource, use 
the Proxy agent.

See “Configuring a proxy resource” on page 1009.

■ To determine the state of a service group with no OnOff resources, use the 
Phantom agent.

See “Configuring a phantom resource” on page 1010.

■ To test VCS One functionality, configure the various file agents.

See “Configuring file resources” on page 1010.
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Configuring registry replication
The Registry Replication (RegRep) agent replicates the registry of the active 
cluster system. Perform the following steps to configure registry replication 
with the RegRep agent.

Note: Verify that the disk groups, volumes or LUNs that you specify for the 
storage resources are not already configured in another service group in the 
VCS One cluster.

To configure registry replication

1 Configure an exclusive MountV resource (Mount in case of Windows LDM) 
for the Registry Replication agent. Verify that no other applications use this 
resource.

2 Create a resource of type RegRep.

See “Adding a resource to a service group” on page 426.

3 Configure the following required attributes for the resource:

■ Keys

The list of registry keys to be monitored. From the ‘name-value’ pair of 
a registry key, you must provide the name of the registry keys to be 
synchronized and not the value for that key.

When defining the keys, you must use the abbreviations for the 
registry hive.

See “Abbreviations for registry keys” on page 1008.

Specify registry keys or subkeys that you wish to exclude from 
replication.

See “About excluding keys from replication” on page 1008.

See “About ignoring subkeys for replication” on page 1009.

Do not configure more than 63 keys for a single RegRep resource 
otherwise the resource will go in an UNKNOWN state.

■ MountResName or FilerResName

The name of the MountV resource (Mount in case of Windows LDM) on 
which the regrep resource depends. The resource specifies the mount 
drive or LUN on the shared disk where the log file is created.

■ ReplicationDirectory

The directory on the shared disk in which the registry changes are 
logged.

4 Configure other resources for the service group, if required.
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5 Link the RegRep and MountV resources (Mount in case of Windows LDM) 
such that the RegRep resource depends on the MountV resource.

See “Linking resources” on page 437 for instructions.

6 Bring the RegRep resource, and other resources in the service group, online.

Abbreviations for registry keys
To configure a registry key to be replicated or excluded, use the abbreviation 
corresponding to the registry hive.

Table A-6 on page 1008 lists the registry hives and their corresponding 
abbreviations.

About excluding keys from replication
The Registry Replication agent uses an algorithm for excluding keys. For 
example, assume a registry key KEY_X has a subkey of KEY_Y, which has a subkey 
KEY_Z. This key would appear as KEY_X\KEY_Y\KEY_Z in the Registry Editor.

Table A-7 on page 1008 describes various scenarios of keys marked for 
replication and for exclusion. The Result column describes the agent behavior in 
these scenarios.

Table A-6 RegRep agent - Registry hive and abbreviations

Registry Hive Abbreviation

HKEY_LOCAL_MACHINE HKLM

HKEY_CURRENT_USER HKCU

HKEY_USERS HKU

HKEY_CURRENT_CONFIG HKCC

HKEY_CLASSES_ROOT HKCR

Table A-7 RegRep agent - Exclude keys and behavior

Keys for 
Replication

Exclude Keys Result

KEY_X KEY_Y\KEY_Z KEY_Y is excluded. So is KEY_Z. 

KEY_X KEY_Y KEY_Y is excluded. So is KEY_Z.

KEY_X KEY_X KEY_X is not excluded and an error message is 
logged. 
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About ignoring subkeys for replication
Use the IgnoreSubKeys option for the Keys attribute to prevent the 
RegistryReplication agent from replicating the subkeys. 

Table A-8 on page 1009 describes possible combination of values for the Keys 
attribute. The Result column describes the agent behavior in these scenarios.

Symantec recommends not to set the IgnoreSubKeys value when the RegRep 
resource is online. Even if the value is set with the resource online, the changes 
will be applicable after the next online routine.

Configuring a proxy resource
The Proxy agent monitors and mirrors the state of a resource on a local or 
remote system in a VCS One cluster. Use this agent to reduce overhead in 
configurations where multiple resources point at the same physical device. For 
example, if multiple service groups use the same NIC, configure one service 
group to monitor the NIC and have Proxy resources in the other service groups 
to mirror the state of the NIC resource.

To configure a proxy resource

1 Create a resource of type Proxy.

KEY_X\KEY_Y KEY_X KEY_X is not excluded and an error message is 
logged.

Table A-8 RegRep agent - IgnoreSubKeys and behavior

Value Specified for “Keys” Attribute Result

"HKLM\SOFTWARE\VERITAS\VCSONE" Replicates the subkeys

"HKLM\SOFTWARE\VERITAS\VCSONE"=IgnoreSubKeys Does not replicate the subkeys

"HKLM\SOFTWARE\VERITAS\VCSONE"=IgnoreSubKeys:Yes Does not replicate the subkeys

"HKLM\SOFTWARE\VERITAS\VCSONE"=IgnoreSubKeys:No Replicates the subkeys

"HKLM\SOFTWARE\VERITAS\VCSONE"=<any other value> Replicates the subkeys

Table A-7 RegRep agent - Exclude keys and behavior

Keys for 
Replication

Exclude Keys Result
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See “Adding a resource to a service group” on page 426.

2 Configure the following required attribute for the resource:

■ TargetResName

The name of the target resource whose status is to be monitored and 
mirrored by the Proxy resource.

If required, configure the following optional attribute for the resource:

■ TargetSysName

The name of the system associated with the target resource. If this 
attribute is not specified, the Proxy resource assumes the system is 
local.

3 Configure other resources for the service group, if required.

4 Bring the Proxy resource, and other resources in the service group, online.

Configuring a phantom resource
A Phantom resource enables VCS One to determine the status of service groups 
that do not include OnOff resources.

To configure a phantom resource

1 Create a resource of type Phantom.

See “Adding a resource to a service group” on page 426.

2 Configure other resources for the service group, if required.

3 Bring the Phantom resource, and other resources in the service group, 
online.

Configuring file resources
The FileNone, ElifNone, FileOnOff, and FileOnOnly agents help you test VCS 
One functionality. The process of configuring these resources is similar.

These agents perform the following functions:

■ The FileNone agent monitors a file and returns ONLINE if the file exists.

■ The ElifNone agent monitors a file and returns ONLINE if the file does not 
exist.

■ The FileOnOff agent creates, removes, and monitors a file.

■ The FileOnOnly agent creates and monitors a file.

To configure file resources:

1 In your service group, create a resource of the desired type. 
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See “Adding a resource to a service group” on page 426.

2 Configure the following required attribute for the resource:

■ PathName

The complete path of the file to be monitored.

3 If required, configure additional resources in the service group.

4 Bring the file resource, and other resources, in the service group online.
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Glossary
AB

See authentication broker.

active/active configuration

A failover configuration where each system runs a number of service groups. If either 
system fails, the other system takes over and runs both system’s service groups. Also 
known as a symmetric configuration.

active/passive configuration

A failover configuration consisting of a number of service groups on a primary system, and 
one dedicated target failover system in case the primary system fails. Also known as an 
asymmetric configuration.

administrative IP address

The operating system controls certain IP addresses and brings them up even before VCS 
One or VCS brings applications online. An administrative IP address can be used to access 
a specific system over the network for doing administrative tasks. Examples of these tasks 
are examining logs to troubleshoot issues or cleaning up temp files to free space. Typically, 
there is one administrative IP address per node per subnet.

advanced workload management

The feature in VCS One that uses attributes such as service group Priority, Capacity, Load, 
and CompatibleGroups to choose the best possible target system to host a service group 
during start up or automated failover.

agent

A process that starts, stops, monitors and reports status of resources as well as cleans up 
after resource faults.

agent framework

A set of common, predefined functions compiled into each agent. These functions include 
the ability to connect to the Policy Master (or HAD on the Policy Master cluster), and to 
understand common configuration attributes. 

application-aware VFrame

A VFrame that represents a virtual machine, is linked to a system object, and runs 
vcsoneclientd. The application-aware vframe is used to manage virtual machines that host 
service groups.

See black box VFrame

asymmetric configuration

See active/passive configuration.
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AT

Veritas Product Authentication Service. 

authentication broker

A component of Veritas Product Authentication Services that serves as an intermediate 
registration authority and a certification authority. Used to authenticate VCS One users 
when they log to the VCS One cluster. The authentication broker is one level beneath the 
root broker. See root broker.

AWM

See advanced workload management.

base IP address

The IP address of the physical network interface brought up by the operating system. It can 
be used as an administrative IP address.

black box VFrame

A VFrame object that has one of the following characteristics.

■ A VFrame that is not linked to a system object.

■ A Vframe that has a system object linked to it, and the system object is categorized as 
operating system type "notknown". 

A black box VFrame is the object used to have VCS One manage only the virtual machine 
and not applications running inside the virtual machine.

business rule

The definition of what actions occur in response to event policy configured.

CLI

Command line interface.

cluster

A cluster is two or more computers linked together for some combination of failover, load 
balancing, multiprocessing, or improved manageability. 

Cluster Manager (Java Console)

A Java-based graphical user interface to manage the Policy Master cluster. It provides 
complete administration capabilities, and can run on any system inside or outside the 
cluster, on any operating system that supports Java.

Cluster Manager (Web Console)

A Web-based graphical user interface for monitoring and administering the Policy Master 
cluster.

Disaster Recovery

A solution that supports failover of an application to a cluster in a remote location in the 
event that the local cluster becomes unavailable. Disaster recovery is based on high 
availability and data replication technologies. 

See also global cluster.
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entry point

The functions an agent performs, such as online, offline and monitor. The code sections 
that carry out these functions can be compiled into the agent itself or implemented as 
individual Perl scripts.

See Veritas Cluster Server One Agent Developer’s Guide.

failover

A failover is the VCS One-initiated movement of a service group to another system. See 
also switch.

floating IP address

See virtual IP address.

gateway

The process that runs on the Policy Master node that executes the GUI and Command Line 
Interface (CLI) processing for the Policy Master.

global cluster

A group of geographically dispersed clusters that connect and communicate with each 
other to provide application availability in the event of a disaster.

See also Disaster Recovery.

group

See service group.

group transition queue

An internal data structure used by advanced workload management to create a prioritized 
list of service groups and the actions planned for them. Can be in manual or automatic 
mode.

GTQ

See group transition queue

GUI

Graphical User Interface

logical IP address

See virtual IP address.

main.xml / main.cf .extension files

The main.xml file is the file that contains the VCS One object instances like service group, 
systems, etc. and their attributes.

The main.cf file is the file in which the Policy Master VCS-based cluster configuration is 
stored.

NIC bonding

Combining two or more NICs to form a single logical NIC, which creates higher bandwidth 
and a more resilient connection to a network switch.

node

The physical system on which applications and service groups reside. When a system is 
managed by VCS One, it becomes a node of the VCS One cluster.
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notification rule

The definition of which users receive notice of certain events of a specified severity 
concerning VCS One objects, and how the notice is sent and received. 

notifier

A core function that enables authorized users to receive notice when events of a certain 
type and severity occur.

NTP

Network Time Protocol. Typically used to keep the clocks on VCS One cluster client systems 
synchronized with each other.

PFrame

A PFrame is a VCS One object representation of an operating system that run a hypervisor 
technology and is capable of running multiple virtual machines on it. 

Policy Master

A single highly available specialized application that provides the central logic of the VCS 
One cluster. Also known as the Policy Master daemon or vcsoned, it is responsible for all 
configuration and management of the VCS One environment. Runs in the Policy Master 
cluster.

plumb

Term used in some operating systems to make a physical NIC ready to bring up an IP 
address.

PM

See Policy Master.

RB

See root broker.

resource

Individual components that work together to provide an application service. A resource 
may be a physical component such as a disk or network interface card, a software 
component such as Oracle8i or a Web server, or a configuration component such as an IP 
address or mounted file system.

resource dependency

Resource dependencies indicate resources that depend on each other because of 
application or operating system requirements. Resource dependencies are graphically 
depicted in a hierarchy, also called a tree, where the resources higher up (parent) depend 
on the resources lower down (child). 

resource types

Each resource in a VCS One cluster is identified by a unique name and classified according 
to its type. VCS One includes a set of predefined resource types for storage, networking, 
and application services.

root broker

The main registration and certification authority for Veritas Product Authentication 
Services. Usually there is only one root broker per domain. See authentication broker.
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seeding

A cluster is seeded if the number of cluster systems declared in the /etc/gabtab file in the 
Policy Master cluster equals the number of systems actually running in the Policy Master 
cluster. Seeding is not relevant in the VCS One cluster.

segment

A local groupings of systems in the VCS One cluster.

service group

A service group is a collection of resources working together to provide application 
services. It typically includes multiple hardware–based and software–based resources 
working together to provide a single service.

service group dependency

A service group dependency provides a mechanism by which two service groups can be 
linked by a dependency rule, similar to the way resources are linked.

shared storage 

Storage devices that are connected to and used by two or more systems.

SMTP notification

Simple Mail Transport Protocol (SNMP) can be used to notify specific VCS One users via 
email of VCS One cluster events.

SNMP notification

Simple Network Management Protocol (SNMP) developed to manage nodes on an IP 
network. In VCS One, users can use SNMP to receive notification at a specific console 
concerning specific events.

state

The current activity status of a resource, group or system. Resource states are given 
relative to all systems.

switch

A manual operator-initiated process of moving a service group from one system to another. 
A switch can be done either from the GUI or the command line. See failover.

symmetric configuration

See active/active configuration.

system

A system in VCS One is an object that represents an operating system that is not capable of 
running virtual machines.

test IP address

IP addresses to help determine the state of a link by sending out a ping probe to another 
NIC (on another system.) Requires a return ping to complete the test. Test IP addresses can 
be the same as base IP addresses.

types.extension.xml and types.cf file

The types.xml file describes standard resource types to the VCS One engine; specifically, 
the data required to control a specific resource. 

The types.cf file describes the same to the high availability daemon running in the Policy 
Master cluster.
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VFrame

A VFrame is a VCS One object representation of a virtual machine. See also black box 
VFrame.

virtual IP address

IP addresses that can move from one NIC to another or from one system to another. These 
IP addresses move with the service group. Sometimes called a logical or floating IP 
address.

vcsoneclientd

A stateless daemon that is responsible for communication between the client systems and 
the Policy Master, as well as the starting and stopping of agents on the local system. 
Contained in the VRTSvcsonecd package.

vcsoned

The Policy Master daemon. Equivalent to the Policy Master. Provides the central logic of 
the VCS One cluster. Responsible for all configuration and management of the VCS One 
environment.

vald

The Virtualization Access Layer daemon. This daemon is a process that connects to the 
Policy Master daemon to support interaction between the Policy Master and a specific 
virtualization technology. By default, vald is a non-critical resource in the Policy Master 
service group.

VxDBMS

A Veritas proprietary relational database management system used for the Policy Master 
configuration database.
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about 659
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DR address on local cluster 608
DR port on local cluster 607

changing browser settings 115
changing database password 692
child resource 32
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configurations in dependency 288
configure

before configuring MSDTC service group 
(Windows) 984

MSDTC client on Windows Server 2003 995
MSDTC client on Windows Server 2008 996

configured information 251
configuring

global CSG 614
notification SMTP settings 639
notification SNMP settings 639

ConfInterval attribute 863
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about 122
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about client 48
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default Simulator
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firm 287
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ElifNone agent, configuring (Windows) 1010
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History menu
about 132
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user 763, 768

roles
about 37
adding 650
categories 755
deleting 653
updating privilege 652

roles section
about 193

rules section
configuration 184
operations 184

RunningDRVersion attribute 839

S
ScriptClass attribute 874
ScriptPriority attribute 874
SCSI-3

in Policy Master cluster 101
in the cluster 90
on coordinator disks 98

scsitest 947
search section



1029Index
about 201
searching

logs 187, 189, 190
security

about 59
seeding configuration database from existing 

database 691
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